翎风引擎历史更新记录

翎风引擎官方网站

说明书如有错误地方请在群共享以文本方式提出或者论坛提交

声明：网络交易有风险,交流群内私下交易风险自行承担

程序网站：Http://www.LFM2.Com

备用网站：Http://www.LFM2.Net

QQ交流群：网站上查看

【2025-07-01 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、RunGate.exe
1.修复了自定义装备框坐标改变后的重复显示的问题
2.修复了元素属性和套装属性的防御蛛网无法抵御部分怪物释放的蛛网
3.修复了掉落人物身上物品命令HumanDropUseItem不能触发身上物品掉落触发[@HumDropItem]
4.修复了宠物无实体模式失效的问题
5.修复了新爆率格式存在 RANDOM时，如#CHILD 1/1 RANDOM ，角色杀怪爆率倍数对子爆率无效的问题
6.扩展了OpenHeroDlg和ADDBUTTON支持时装首饰盒和神佑位置
7.修改多级脚本M.排除了NPC
8.修改了怪物属性扩展MonSpAbilList中几个参数由原来开关模式改为几率模式
9.增加了自定义装备框支持套装属性
10.增加了自定义装备框支持英雄，命令前面加H.
11.增加了摆摊物品购买前触发和终止购买命令
12.增加了新爆率格式杀怪爆率无效的参数 BURSTRATE 例：#CHILD 1/1 BURSTRATE
13.增加了内挂挂机只打列表中怪物选项
14.增加了自定义技能- 攻击目标当选择为” 半月攻击 “ 时，增加默认伤害格数和技能等级提升一级格数设置
15.增加了修复沙巴克城门和城墙的脚本命令
16.解决了一处严重漏洞，本次更新网关需同步更新.
17.优化了其他几处细节

【2025-05-21 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、合区工具.exe、数据管理工具.exe
1.修复了“战斗状态退出”功能的 “不允许使用药品” 选项勾选后不保存的问题
2.修复了“战斗力计算设置”中新职业设置的参数值不保存的问题
3.扩展了十步一杀技能的最大距离从12格调整到22格
4.扩展了MOBFIREBURN支持42E+的伤害
5.增加了升级武器页面支持最大持久控制
6.修改了切换地图保护排除当前地图随机或被技能拉动，仅切换地图有效

【2025-04-06 更新:】
本次更新文件：UpdateServer.exe
1.优化了微端更新下发相关

【2025-04-02 更新:】
本次更新文件：M2Server.exe、UpdateServer.exe
1.修复了微端程序会出现不更新的一处问题
2.优化了引擎的几处细节

【2025-03-25 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.优化了角色在地图雷达显示
2.优化了显示会员类型条件的一些细节
3.优化了角色下线后施的毒消失支持所有目标类型

【2025-03-22 更新:】
本次更新文件：M2Server.exe
1.修复了显示改名后的装备名字变量在取下物品后变量不会清空的问题

【2025-03-15 更新:】
本次更新文件：M2Server.exe
1.增加了操作行会安定度、繁荣度、建筑度、人气度命令聊天框提示的关闭选项
2.优化了releasemagic 和releasemagicex 释放强化技能的算法

【2025-03-10 更新:】
本次更新文件：M2Server.exe
1.修复了调整元素倍率后ScatterMonItems命令的一处计算错误

【2025-03-07 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了自定义属性在悬浮框顶部显示时会多出一个关闭按钮的问题
2.优化了角色交易系统查看购买角色装备时支持自定义装备框

【2025-03-01 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了战斗状态强制退出时角色不会掉线的问题
2.修复了调整元素倍率后怪物元素失效的问题
3.修改了宝宝杀人主人红名选项为攻击目标主人灰名
4.增加了施毒术向宝宝施毒灰名选项
5.优化了启动游戏窗口后最小化登录器的反应时间

【2025-02-28 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、数据管理工具.exe、合区工具.exe、DBServer.exe
1.优化了内挂BOSS提示相关
2.优化了内挂挂机时被攻击操作对触龙神伤害的一处误判为角色攻击得问题
3.优化了拍卖行出价前触发支持获取拍卖人名称
4.优化了人物变身怪物后小地图雷达显示为怪物
5.扩展了GetAllDBItemFieldValue及多个装备相关命令支持称号和新增装备位置
6.增加了武器按次数升级选项（涉及更新DBServer.exe、合区工具、数据管理工具）
7.优化了系统兼容性相关
8.优化了其它细节

【2025-01-17 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了个别类型物品持久相关的一处问题
2.修改了红绿毒切换地图消失和下线消失为独立选项
3.增加了复古模式悬浮框选项
4.增加了武器诅咒前触发和中止诅咒命令
5.增加了内挂隐藏MapEffect,PlayEffect特效选项
6.优化了其它几处细节

【2024-12-26 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.悬浮框特效进行相关扩展支持及优化
2.自定义特效配置进行了相关整合优化
3.自定义装备框试用机制修改为在线2人内可以开启所有框框，超过2人只可开启2个，已经开启不受影响
4.暴击几率突破百分比计算修改为继续百分比不再为千分比，如原200%相当于20%，现200%即100%可以打出暴击
5.优化了UserItem 和 HeroUserItem 使用自定义装备栏的一处细节
6.列表信息2增加了自定义特效分支“光柱特效”和原地面特效自选使用

【2024-12-18 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.扩展了容器使用PLAYIMG PLAYIMGEX IMG IMGEX TEXT支持SCRIPTPARAM的ID触发
2.扩展了分身支持使用FS.CHANGESPEED调整攻击速度
3.扩展了UserItem和HeroUserItem支持200-249自定义位置和时装首饰盒及神佑盒
4.扩展了SetNewItemValue 和SetNewItemValueEX调整值支持到65535
5.扩展了悬浮框特效支持不显示悬浮框背景和边框选项

【2024-12-13 更新:】
本次更新文件：MakeGameLogin.exe
1.修复了登录器内存读取导入表用序号的一处问题

【2024-12-11 更新:】
本次更新文件：MakeGameLogin.exe
1.修复了人物起始第一个动作武器会闪一下的问题
2.修复了自动使用叠加物品数量显示不对的问题
3.修复了背包同时有普通药和特效药时吃药的一处问题

【2024-12-06 更新:】
本次更新文件：全套更新
1.增加了将指定位置物品转换为数据库对应IDX物品的命令
2.增加了50个自定义装备框
3.增加了悬浮框不显示物品名称选项（选项-客户端设置-装备信息，，选项expend5值 > 9 才生效 ）
4.增加了AutoTakeOnItemEx 物品唯一ID 穿戴位置
5.配置器-客户端界面设置-其他配置中增加对内挂BOSS提示的范围修改
6.扩展了人物和英雄出战栏在自定义UI中开启支持他人可见（默认不可见，常用于自定义装备框才会开启）
7.扩展了ItemShow 、HeroUserItem、UserItem makeindexitem的显示物品框字段支持定义物品框
8.扩展了物品数据库持久支持到42E
9.扩展了装备自定义进度条支持到922G
10.扩展了时装首饰盒
11.扩展了时装神佑

【2024-11-11 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了合区工具新增属性附加属性不合并的问题
2.修改了内挂BOSS提示范围10格内不再提示
3.修改多职业选择角色界面读取素材为选项（界面UI设置-其他配置）
4.组队界面增加了显示队友血条选项
5.增加了调整人物套装属性百分比命令

【2024-10-22 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了MAPTOGGLE对扩展的小地图兼容性问题
2.优化了其它几处细节

【2024-10-19 更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、RunGate.exe
1.修复了一处引擎报错
2.修复了ChangeHumAbility兼容自定义技能直线攻击一处问题
3.自动练功还原支持间隔0秒
4.扩展了强制显示国家颜色地图参数SHOWNATIONCOLOR(1) 不包含怪物
5.扩展了OpenClientDlg支持背包位置
6.扩展了GIVE和GiveOnItem命令
7.增加了武器升级失败破碎前触发和终止武器破碎的命令
8.优化了诱惑之光诱惑自定义怪物的一处细节
9.优化了其他多处细节

【2024-09-21 更新:】
本次更新文件：DBServer.exe
1.修复了DBServer.exe创建ApexMir.DB数据库文件的一处问题

【2024-09-15更新:】
本次更新文件：全套更新
1.修复了HideModeEx 隐身无效的问题
2.扩展了获取物品的附加属性
3.扩展了修改物品的附加属性
4.扩展了OK框相关
5.扩展了自定义技能相关
6.扩展了NeedLevel计算工具
7.扩展了宝石镶嵌位置相关
8.扩展自定义属性支持ASC, ARC, MPC
9.扩展了修改物品的附加属性值命令
10.扩展了获取物品的附加属性值命令
11.扩展了读取物品的附加属性值命令
12.扩展了物品使用条件设置
13.扩展了UPGRADEITEMEX升级命令
14.扩展了ChangeHumAbility命令
15.扩展了ChangeHumAbilityEx命令
16.扩展了ChangeHumAbilityPercentage命令
17.扩展了组队队友图标
18.数据库增加了JOB 字段（详见文档：使用物品所需条件设置）
19.性能设置增加了地图无人怪物静止选项
20.宠物名称展示修改，名称颜色为数据库设置的颜色
21.增加了英雄身上掉落物品触发[@HeroDropItem]
22.物品佩戴条件增加刺术、箭术、武力

【2024-08-15更新:】
本次更新文件：M2Server.exe
1.修复了因技能魔法设置中增加职业技能的疏忽导致原三职业技能显示不全的问题
2.扩展了丢弃金币限制支持到922G

【2024-08-13更新:】
本次更新文件：M2Server.exe
1.修复了衣服掉落不会触发HumDropItem的问题
2.修复了角色背包负重的问题

【2024-08-05更新:】
本次更新文件：M2Server.exe
1.修复了取下身上物品触发相关操作的细节问题

【2024-07-30更新:】
本次更新文件：M2Server.exe
1.优化了GetMultiRandomNumber随机赋值相关
2.优化了MOVR随机赋值相关
3.优化iF多条件检测和OR条件检测相关

【2024-07-27更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、GameCenter.exe、LoginSrv.exe
1.修复了控制器清理角色数据时不清理角色出售数据的问题
2.修复了LoginSrv当服务端名称超长时ID数据库位置不正确的问题
3.修复了G变量为负数时重启后归0的问题
4.扩展了DoTaunt嘲讽命令支持分散范围
5.优化了登录器获取机器码相关
6.修改了人物身上物品掉落HumDropItem不在支持背包物品掉落触发

【2024-07-18更新:】
本次更新文件：MakeGameLogin.exe
1.修复了自定义大对话框的一处细节

【2024-07-17更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、GameCenter.exe
1.修复了控制器清理角色数据不清理自定义货币的问题
2.修复了宠物蛋返回背包后名称颜色无效的问题
3.优化了英雄相关

【2024-07-15更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了ImgNum在物品备注内一处显示细节
2.优化了英雄相关

【2024-07-10更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了召唤分身命令定义颜色的无效问题
2.修复了套装备注文字颜色无效的问题
3.优化了战士英雄出刀
4.优化了虚数漂血素材支持自定义Resources目录
5.优化了内挂的自动凝聚技能
6.优化了其它几处细节

【2024-07-04更新:】
本次更新文件：全套更新
1.修复了宠物蛋返回背包后属性显示的一处细节处理
2.修改PLAYEFFECT图层顺序兼容老版本
3.优化了几条命令的执行效率
4.优化了自定义技能召唤宝宝相关
5.优化了其它多处细节
6.增加了大大大数值选项
7.扩展了ForMulAtion 支持命令内进行随机数值运算
8.扩展了杀怪经验支持922G
9.扩展了套装备注未激活物品显示设置
10.优化了LockUpdateAbil、UpdateAbil两条关于属性修改的命令（脚本涉及修改属性的请参阅）
11.关于修改角色属性命令必看说明

【2024-06-13更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、合区工具.exe、数据管理工具.exe
1.修复了call 自定义对话框关闭不干脆的问题
2.修复了自定义的宠物蛋LOOKS 从宠物栏返回背包会改变LOOKS的问题
3.修复了V8引擎带数据转翎风时部分角色经验清空的问题
4.增加了自定义伤害的地图参数
5.增加了刷新巡逻怪物的命令

【2024-06-07更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了丢弃物品相关的一处细节
2.扩展了MAPEFFECT支持图层的参数
3.扩展了PLAYEFFECT图层支持最顶层的参数

【2024-06-06更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe
1.修复了HideModeEx一处细节
2.修复了宝宝攻击触发的一处细节
3.修复了CheckNewItemValue无法检测26的附加属性
4.增加了忽视目标防御的命令
5.增加了在线查看他人装备的命令
6.增加了获取两个时间之间相差的命令
7.增加了按照物品序列号存仓的命令
8.增加了毒物躲避相关属性支持防御怪物麻痹
9.增加了一个独立的触龙神DB
10.增加了毫秒级个人定时器
11.增加了几个数组相关操作命令
12.增加了按照物品序列号展示背包物品到NPC对话框
13.优化了两处占用CPU性能相关处理
14.优化了其他几处细节

【2024-05-20更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了call脚本大对话框内容会闪烁问题
2.修复了可探索已知问题
3.修复了元素“防冰冻”无法防御冰霜群雨的冰冻问题
4.修改了物品入仓命令支持存仓前触发
5.优化了其它几处细节

【2024-05-17更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了开天斩技能伤害规则调用逐日规则的问题
2.修复了视觉区域刷新的一处细节问题
3.修复了ITEMSHOW一处非法请求查询数据库物品的问题
4.修复了一处细节处理会引起脚本异常的问题
5.修复了探索类怪物显示的一处问题
6.修复了反外挂网关历史遗留掉线卡角色问题

【2024-05-08更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UpdateServer.exe
1.修复了浑水摸鱼隐藏顶戴和名字变色会影响怪物得问题
2.修复了技能熟练点的一处细节判断导致频率使用问题
3.修复了当开启了延时退出游戏时跨服功能无法返回原区的问题
4.修复了拥有护身属性时伤害反弹属性无效的问题
5.修复了引擎的一处报错问题
6.完善了SetShadowShow对英雄的支持
7.完善了技能替换相关的已知细节处理

【2024-04-30更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了可视化仓库特效显示的一处问题
2.修复了DETOXIFCATION解毒无效的问题
3.优化了DelGuildMember支持踢出不在线的行会成员
4.优化了AddGuildMemberCount 扩容行会成员数量命令的处理
5.优化了手动使用快捷物品栏中的物品时暂停2秒内挂自动吃药
6.优化了CheckNewItemValue 检测元素的命令的一处细节
7.扩展了SHOWPROGRESSBARDLG采集框相关
8.扩展了开天斩和逐日剑法的一处细节参数设置
9.增加了调整人物属性百分比命令
10.优化了其他几处细节

【2024-04-27更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了掉落身上物品触发相关
2.增加了宠物蛋不显示基础属性选项
3.增加了改变技能特效的命令
4.优化了微端程序性能

【2024-04-13更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe、数据管理工具.exe、DBServer.exe
1.修复了使用命令掉落身上物品不触发提示的问题
2.修复了复活戒指在首饰盒的会影响衣服持久的问题
3.修复了上版处理DX后门时引起的一处兼容性问题
4.增加了人物身上掉落物品触发脚本
5.扩展了ChangeState伤害值支持922G
6.修改了登录器一些细节相关

【2024-04-12更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe、数据管理工具.exe、自定义UI升级.exe
1.增加了个人商店相关操作
2.扩展了称号数量相关
3.修复了DX绘图相关一处后门BUG

【2024-04-08更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe、数据管理工具.exe
1.修复了等级限制的一处细节处理问题
2.修复了GiveBoxItem的一处细节处理问题
3.修复了悬浮框特效合区后丢失的问题
4.修复了TakeBagItemColor回收命令的一处问题
5.修复了实名认证后合区后还需要再次认证的问题
6.扩展了等级经验突破42E
7.增加了通过唯一ID将物品放入OK框
8.增加了角色交易购买前触发

【2024-03-08更新:】
本次更新文件：M2Server.exe
1.增加了2个功能操作命令

【2024-03-03更新:】
本次更新文件：合区工具.exe、数据管理工具.exe
1.修复了合区工具和数据管理工具保存文件的一处细节问题

【2024-02-28更新:】
本次更新文件：M2Server.exe
1.优化了几处细节

【2024-02-26更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.优化了TakeBagItem，TakeBagItemEx对颜色的判断回收
2.优化了个人商店购买前触发支持购买的物品名称、物品价格的支持
3.增加了元素经验变量
4.增加了跑步

href="游戏引擎反外挂系统/功能操作命令/开启幻影移动.htm">幻影效果
5.完善了其

【2024-02-20更新:】
本次更新文件：M2Server.exe
1.修复了“发现非本地图角色” 的历史性遗留问题
2.增加了个人商店卖家在线时售出物品触发相关操作

【2024-02-19更新:】
本次更新文件：M2Server.exe
1.修复了humanhp的一处错误
2.修复了地图参数Timemap的一处细节处理

【2024-02-14更新:】
本次更新文件：M2Server.exe
1.扩展了HumanHp参数8为是否无视目标护身
2.修改了DelGuildMember支持对不在线的行会成员进行操作

【2024-02-05更新:】
本次更新文件：全套更新
1.优化了施毒术相关细节
2.优化了PLAYEFFECT相关细节
3.优化了快捷栏物品CD相关细节
4.优化了CSV获取相关细节
5.完善了套装属性相关细节
6.提升了普通微端线程数量

【2024-02-04更新:】
本次更新文件：全套更新
1.修复了翅膀特效显示的一处错误
2.修复了商店购买药品的一处问题
3.优化了切换场景移动的一处细节
4.优化了内挂使用物品相关细节
5.优化了宝宝攻击目标相关
6.优化了战士分身相关
7.增加了摆摊物品售罄自动收摊选项
8.增加了内挂手控死亡之眼选项
9.增加了套装支持元素属性
10.增加了货币关联的相关操作命令
11.增加了经验倍数元素
12.优化了其他几处细节相关
本版需要全套更新(表示压缩包内所有EXE文件都需要更新，如需手动更新可自己对比文件修改时间进行更新)

【2024-01-09更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了内挂物品栏恢复默认按钮无效的问题
2.优化了无限刀时野蛮的细节处理
3.优化了定时器的一处细节处理
4.优化了程序启动时加载文本速度
5.优化了复活传送命令组合使用时细节处理
6.扩展了TakeBagItem检测条件
7.修改了连击技能暴击与属性的暴击几率及威力进行分离

【2024-01-03更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了HeroUserItem调用错误的问题
2.修复了浑水摸鱼外观显示的一处问题
3.修复了师徒系统的一处关联错误
4.完善了MonSpAbilList改名相关
5.增加了宝宝切换目标频率设置
6.增加了Npc对话框调用怪物外观的元素
7.优化了道士英雄躲避相关

【2023-12-31更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、合区工具.exe、数据管理工具.exe
1.修复了一处可复制物品的漏洞[紧急]
2.增加了内挂相关细节功能
3.增加了调整极品属性支持等级
4.增加了怪物被多目标围攻切换频率设置
5.增加了怪物顶戴支持改名后的名称顶戴
6.优化了悬浮框相关细节
7.优化了自定义UI几处细节
8.优化了其他几处细节

【2023-12-21更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了跑步不会掉血的问题
2.修复了releasemagicEx释放多目标技能的一处问题
3.修复了移动时随机特效存在延时的问题
4.修复了瞬息移动后卡特效的问题
5.修复了道法自动连击的会卡位的问题
6.增加了开天斩人物重击几率设置

【2023-12-18更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe、数据管理工具.exe
1.修复了参数设置师徒传送间隔时间设置不保存的问题
2.修复了火龙教主的一处细节处理
3.修复了跨服摆摊的一处问题
4.修改了ChangeMonAbility 范围为空时为准确坐标
5.增加了查看在线角色支持金币显示排行
6.优化过地图链接和随机后移动相关丝滑度
7.优化了摆摊、个人商店、拍卖行几处细节
8.优化了丢弃金币可超越21E
9.优化了伤害响应相关
10.优化了企业版微端更新WZL文件相关
11.优化了地面极品特效绘制图层
12.优化了其他几处细节...

【2023-12-06更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了刷怪文件中副本地图不刷怪得问题
2.优化了魔法远距离攻击延迟相关处理
3.优化了角色切换场景停顿时间相关
4.优化了私聊记录相关细节
5.优化了锁定目标光圈细节处理
6.完善了新增悬浮框随鼠标移动模式2相关

【2023-12-02更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了分身伤害限血的问题
2.修复了RACE96僵尸怪物的一处问题
3.修复了人形怪佩戴物品持久的一处问题
4.修复了连击技能释放的一处问题
5.修复了查看人形怪装备名字显示带数字的问题
6.增加了杀死怪物名变量不显示数字KILLMONNAMEex
7.增加了查看人形怪装备前触发
8.优化了企业版微端更新规则(带宽饱和状态下更新优化)，以及缓存速度优化

【2023-11-09更新:】
本次更新文件：DBServer.exe
1.修复了英雄不支持附加属性值超过42E的问题

【2023-11-08更新:】
本次更新文件：M2Server.exe
1.修复了私聊显示等级时的一处细节处理

【2023-11-07更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了humanhp自定义飘血的一处错误
2.修复了天气系统图层的一处问题
3.修复了英雄倚天辟地和职业技能都开启存在施法动作的问题
4.修改了合击界面英雄关闭技能后文字颜色为灰色
5.修改了禁用商铺地图为购买和赠送时触发
6.扩展了GM命令扣金币支持922g
7.增加了自定义技能瞬移格数设置
8.增加了LineNotice.txt中滚动公告在参数设置中调整滚动速度
9.增加了拉自己镖车到身边的命令

【2023-11-06更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了伤害延迟的问题
2.修复了字典不支持小写字母的问题
3.增加了在怪物设置中MonSpAbilList.txt支持改名选项
4.优化了怪物性能处理相关
5.优化了其它几处细节

【2023-11-04更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、微端程序.exe、UI升级.exe
1.修复了非连击界面属性显示文字错误
2.修复了微端查看文件的一处问题
3.修复了个人商店翻页的问题
4.修复了致命一击元素特效显示的问题
5.修复了收回英雄命令的一处细节处理问题
6.增加了UI详细属性中支持暴击抗性和攻击抗性编辑
7.修改了内挂中“自动绕行”仅限控制手操，自动均默认自动绕行

【2023-10-23更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、合区工具.exe、数据管理工具、UI升级.exe
1.修复了忽视元素比例计算时非近身无效的问题
2.修复了角色黑名单系统的一处细节遗漏
3.修复了设置宝宝不打人的一处细节处理
4.修复了假人不释放攻杀的问题
5.修改了自定义技能英雄收回继续计算CD时间
6.恢复了速度调整相关
7.增加了元素点比设置
8.增加了打开和关闭个人商店的管理命令
9.增加了登录游戏时聊天框最顶部显示公告脚本
10.增加了自定义UI非连击界面详细信息文字编辑
11.增加了极品鹿出现可怪物设置中设置几率
12.增加了OpenClientDlg支持打开内挂、M地图
13.增加了假人范围捡物品和自动入包
14.增加了开启/关闭假人捡物品命令
15.增加了假人自定义指定捡取列表命令
16.增加了SENDMSG 8 和普通说话一样
17.增加了法师英雄攻击期间是否一直躲避
18.增加了攻击显血选项
19.优化了假人主动打和平怪（不让打请在假人配置设置）
20.优化了心灵召唤技能支持拉分身
21.优化了顶戴花铃被麻痹的一处细节
22.优化了其它几处细节

【2023-10-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe
1.修复了流星火雨两次伤害无效的问题
2.修复了内挂挂机会攻击宝宝为人形怪的下属问题
3.修复了合区工具的一处错误
4.修复了%ShowItem 的一处细节问题
5.优化了几处强迫症患者的需求

【2023-10-15更新:】
本次更新文件：全套更新
1.修复了暴击飘血的一处错误
2.修复了加入行会前触发的一处错误
3.扩展了AddNumberButton、AddArrButton、AddDlg、AddDlgEx位置支持
4.扩展了SendCenterMsg、SuperMoveMsg、SendNewLineMsg支持位置颜色与坐标、大小和支持 ImgNum 命令数字转图片
5.增加了IDC专用定制版微端（配置器-客户端选项内启用）,实现超快速更新(详细咨询IDC:LfDun.Com)
6.增加了几处细节相关选项
7.优化了其它几处细节处理

【2023-10-10更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginSrv.exe
1.修复了地图参数禁止丢物品的一处问题
2.修复了旧模式下OK框会闪烁的一处问题
3.修复了检测自己是不是徒弟checkmaster命令的一处问题
4.恢复了Shape114复活类物品为复活一次掉1点持久
5.优化了查看装备相关的一处细节
6.优化了新十步一杀流畅性的相关处理
7.优化了releasemagicEX对自定义技能的细节处理
8.增加了地面物品特效支持特效绘制
9.增加了自定义UI血球下方HP/MP显示编辑
10.修改了自定义UI组队勾选图片为-1时显示为默认图片
11.加快了流星火雨掉落速度
12.优化了其他几处细节

【2023-09-26更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LogDataServer.exe
1.修复了不可移动自定义怪物的一处问题
2.修改了防御和魔御得一处细节
3.修改了ChangeMonAbility和RecalcMonAbility坐标和范围为空时为全地图
4.优化了背包对比双击替换装备判断
5.优化了内挂挂机捡物品相关操作细节
6.完善了跨服几处相关细节处理
7.扩展了自定义OK框支持数据库属性和自定义字段属性
8.扩展了及时雨内挂修复神水共享英雄
9.增加了个人商店购买前触发和中止购买命令
10.增加了角色出售货币不存入委托人选项
11.增加了角色出售成功触发相关
12.增加了精准搜索（日志查询）选项

【2023-09-23更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了SetMiniMapRange填充色不支持页游小地图的问题
2.修复了一键回收命令的一处错误
3.扩展了GetItemFieldValue支持922G
4.优化了地图链接点相关细节处理
5.优化了跨服支持顶号下线处理，去掉之前提示
6.优化了使用MAKEPOSION命令上毒的一处细节处理
7.优化了自动替换装备相关细节判断
8.优化了SetNewItemValueEX为实时生效
9.优化了其它几处小细节

【2023-09-19更新:】
本次更新文件：M2Server.exe、DBServer.exe
1.修复了跨服功能的一处严重BUG

【2023-09-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginGate.exe
1.修复了伤害反弹元素的的一处问题
2.修复了releasemagicEx对自定义技能支持的问题
3.优化了跨服的一处细节处理
4.优化自定义技能的一处细节处理
5.优化了CreateNPC的一处细节处理
6.优化了宝宝血条相关的两处细节判断
7.优化了野蛮冲撞时换装的一处细节判断
8.优化了及时雨内挂英雄保护的细节处理
本版需要更新LoginGate.exe，不然登录不了

【2023-09-15更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.优化了几处细节

【2023-09-14更新:】
本次更新文件：全套更新
1.增加了实名认证系统调试功能
2.优化了网络状态显示的一处细节处理
3.优化了物品备注的一处细节判断

【2023-09-13更新:】
本次更新文件：全套更新
1.修复了控制器清理国家数据的一处问题
2.控制器增加了设置远程日志端口配置
3.增加了登录器与服务器之间网络速率显示
4.增加了阿里云实名认证接口
5.增加了交易前触发命令
6.增加了获取身上限时物品剩余时间命令
7.增加了NPC调用身上装备信息支持英雄
8.增加了镶嵌宝石支持暴击抗击和攻击伤害抗性元素
9.增加了新行会系统成员图标点击支持私聊
10.增加了3个内挂预留按钮到自定义UI
11.扩展了TakeBagItem回收物品参数支持是否回收极品
12.优化了自动范围拾取的一处细节处理
13.优化了HumanHP的一处细节处理
14.优化了角色后仰的一处细节处理
15.优化了英雄群体隐身术的一处细节处理
16.优化了地图参数加减泡点值装备栏显示细节
17.优化了ChangeModeEx相关细节处理
18.优化了Npc对话框读取Wil资源列表编号相关
19.优化了控制器对动态IP的支持，使用跨服功能不要启用
20.优化了控制器配置数据备份的逻辑
21.优化了新十步一杀技能相关
22.优化了自定义技能多处细节处理
23.优化了怪物相关的底层代码
24.优化了其它几处细节处理

【2023-08-23更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了富贵兽相关问题
2.修复了上版优化视野导致的相关问题
3.优化了快速切换场景的一处细节处理
4.限时的聚灵珠增加到期日期显示
5.增加了假人锁定相关指令
6.自定义技能增加了多目标飞行选项
7.悬浮框特效增加了顶层播放选项

【2023-08-18更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了前2个版本属性分配点的错误
2.优化了自定义直线技能相关
3.扩展了假人支持摆摊

【2023-08-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了自定义技能减元素属性的错误
2.修改了镶嵌宝石的生命值和魔法值显示相关
3.扩展了ChangeModeEx 34567属性支持922G
4.增加了中止查看他人装备和英雄装备命令
5.优化了几处细节体验

【2023-08-12更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了引擎一处报错
2.修复了视野相关的一处严重BUG
3.修复了自定义技能直线攻击的一处错误
4.修复了宠物技能物品属性显示的一处错误
5.优化了AddhpPer支持大数值相关
6.自定义技能增加了分裂效果

【2023-08-07更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.优化了道法内挂挂机相关
2.优化了内挂目标列表编辑
3.优化了怪物简装
4.优化了英雄宝宝获取杀死目标变量
5.优化了其它几处细节

【2023-08-06更新:】
本次更新文件：全套更新
1.修复了自定义技能推动绘制的一处细节
2.修复了排行榜数据读取不到的一处问题
3.修复了H.CheckNewItemValue特殊使用场景可能无效的问题
4.修复了假人召唤英雄报错的一处问题
5.修改了Messagebox同时多条则显示最后一条
6.优化了流星火雨技能的一处细节处理
7.优化了无极真气CD相关细节
8.优化了英雄独立触发相关细节处理
9.优化了道法职业内挂挂机相关细节
10.优化了商店修理物品时扣金币的一处细节
11.优化了合区工具选项保存的细节处理

【2023-07-28更新:】
本次更新文件：全套更新
1.优化了几处细节

【2023-07-27更新:】
本次更新文件：全套更新
1.修复了及时雨内挂英雄收回保护无效的问题
2.优化了上版英雄解除目标选项
3.优化了网络通讯相关

【2023-07-25更新:】
本次更新文件：全套更新
1.修复了多级脚本的一处细节错误例如 BB.M.HUMANHP
2.修复了releasemagic 释放技能触发的一处错误
3.调整死亡不掉装备的次数支持英雄H.SetNoDropItemCount
4.扩展了Npc对话框动态进度条功能支持大数值
5.优化了多级脚本的运用
6.扩展了跨服角色改名支持32字符
7.英雄增加当目标离开范围立即丢弃目标选项
8.优化了其它几处细节处理

【2023-07-22更新:】
本次更新文件：全套更新
1.修复了几个技能触发相关细节问题
2.修复了宠物的一处相关细节问题
3.修复了WebBrowser内置打开网页的一处细节问题
4.修复了自定义技能直线伤害的一处细节问题
5.优化了技能CD重置的相关细节处理
6.优化了移动野蛮的相关细节操作
7.优化了查看他人装备及提升鼠标锁定移动目标准确度
8.优化了装备对比衣服的一处细节
9.优化了容器相关细节
10.完善了跨服相关细节
11.增加了通过技能ID获取技能数据库字段并保存到保存变量

【2023-07-17更新:】
本次更新文件：M2Server.exe
1.修复了战士分身术无视自定义技能CD的问题
2.修复了爆率文件中U变量应用不支持大于U254的问题
3.修复了H.SETCUSTOMITEMTEXT命令英雄乱码的问题
4.优化了GOTOLABEL 9国家成员触发，当范围小于1为全地图
5.扩展了SetSuckDamage 总吸收值设置为 -1时 无限数值
6.扩展一键回收物品命令TakeBagItem回收的货币支持922京
7.增加了系统商铺赠送前触发

【2023-07-15更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe
1.增加了摆摊物品上架前触发
2.增加了跨区跨服功能命令***Beta版
3.修复了[Exception] TPlayObject::SearchViewRange 1-12的报错

【2023-06-26更新:】
本次更新文件：M2Server.exe
1.修复了战士自定义技能被视为魔法技能导致网关误报加速的问题

【2023-06-20更新:】
本次更新文件：MakeGameLogin.exe
1.优化了登录器对插件的兼容性

【2023-06-14更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe
1.优化了SetItemsLight命令实时刷新生效
2.优化了SetSkillPower对人形怪的一处处理细节
3.优化了在线人物货币展示相关细节
4.优化了排行榜的一处细节
5.优化了其它相关细节

【2023-06-07更新:】
本次更新文件：MakeGameLogin.exe
1.优化了宝宝锁定目标相关

【2023-06-06更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了英雄合击的一处问题
2.优化了怪物简装的一处细节
3.优化了引擎的一处可能引起报错的地方

【2023-06-05更新:】
本次更新文件：M2Server.exe
1.优化了CSV加载得一处细节处理
2.优化了Defines自定义常量注释相关细节

【2023-06-03更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.扩展了SET可批量设置个人标识
2.增加了个人标识取反操作方式
3.增加了获取玩家当前拥有的所有称号名命令
4.增加了脚本开启行会战命令
5.优化了sorthumvartolistEX排序命令的细节
6.优化了装备技能威力表相关
7.优化了其他几处细节

【2023-06-02更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LogDataServer.exe
1.修复了英雄飞到主人身边时图标上等级显示错误的问题
2.修复了2处可能引起M2报错的细节处理
3.增加了日志文件记录叠加物品使用相关（药品类除外）
4.复古模式背包显示装备属性位置增加坐标调整
5.优化了烈火剑法相关细节
6.优化了负载性能相关处理
7.优化了创建NPC命令相关细节
8.优化了诱惑之光技能控制诱惑目标时死亡几率
9.优化英雄锁定间隔相关
10.优化了其它几处小细节

【2023-05-28更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.优化了ItemShow灰化相关细节
2.优化了人物属性叠加给宝宝的相关细节
3.优化了其它几处细节

【2023-05-26更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.扩展了容器的滑动条支持鼠标滚动操作
2.扩展了音量开关支持保存本地记录
3.扩展了PlayMusicEX增加参数2（上一段播放没结束时,中止声音,开始播放当前内容）
4.扩展了NPC界面上向上滚动提示信息命令支持停留时间
5.扩展了功能设置中掉持久比例设置为0时为不掉持久
6.增加了键值对“字典”功能命令
7.增加了打印个人标识操作命令
8.增加了通过脚本命令获取宝宝所在位置信息命令
9.配置器增加了BigNum最低显示单位设置
10.优化了彻地钉技能伤害相关细节
11.优化了游戏命令提示相关细节
12.优化了怪物放大缩小后位置偏移相关
13.优化了角色视野刷新相关处理
14.优化了自定义技能CD相关细节
15.优化了其他几处细节

【2023-05-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.忽视防御元素增加同时忽视“伤害吸收”和“魔法防御”元素选项
2.内挂挂机寻找目标修改为优先攻击身边最近的怪
3.配置器增加登录背景色设置
4.增加了始终显示职业等级选项（客户端设置-功能选项2）
5.优化了游戏速度相关细节

【2023-05-15更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe、GameCenter.exe
1.修复了ItemShowM2报数量查询错误的问题
2.修复了英雄穿戴时装衣服不分性别的问题
3.修复了合区工具批量添加报错的问题
4.修复了内挂挂机被人物攻击触发项不判断下属攻击的问题
5.修复了英雄锁定目标追击距离不受限制的问题
6.修复了< 和 : 在某些场景下会被理解成脚本命令的关键符号的问题
7.修复了因扩展SETITEMEFFECT同时支持3个特效编号引起的绘制问题
8.控制台数据清理项目增加清理国家数据选项
9.聚灵珠当前值增加支持单位显示
10.传送自身特效播放速度增加自定义设置(客户端设置-功能选项)
11.增加了获取字符串长度、复制字符串、查找字符串命令
12.施毒术增加了人物下线毒消失选项
13.自定义技能地狱火模式增加了长度支持
14.优化了CSVOpenCache支持多文件使用
15.优化了修改地图内怪物属性ChangeMonAbility命令
16.优化了自定义OK框物品类型判断
17.优化了ExtractStringEx 、TextSplit分割出来的N变量支持超过21亿
18.优化了悬浮框显示相关细节
19.优化了<$RegMonX>:<$RegMonY>获取坐标相关

【2023-04-28更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了给予物品的一处问题
2.修复了魔法间隔参数不保存的问题
3.优化了各项游戏速度精准化

【2023-04-24更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.改进并优化了魔法速度相关调整
2.诱惑之光技能增加提高诱惑成功率选项
3.修复了CheckBagItems检测无效的问题
注意：本版开始魔法间隔相关调整作出了变动，升级需重新调整魔法速度，不兼容原速度参数

【2023-04-22更新:】
本次更新文件：全套更新
1.修复了微端程序加载素材时的一处细节处理
2.修复了自定义变量保存时强制文本编码的问题
3.修复了外显时装检测命令无效的问题
4.修复了怪物数据库RACE字段118的怪物MonSpAbilList.txt冰冻和蜘蛛网无效的问题
5.扩展了国家系统数量至255个
6.扩展了SETITEMEFFECT同时支持3个特效编号显示
7.更新了支持CSV为常量形式进行操作
8.更新了资源编辑器导入图片时候的确定也可以用ENTER执行
9.更新了魔法间隔M2支持设置负数来提高魔法速度
10.扩展了SetItemsLight 发光特效命令支持数据库Light字段所有特效
11.优化了游戏速度相关提升流畅度

【2023-04-10更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、脚本加密插件.exe
1.优化了悬浮框特效平铺模式
2.优化SetNewFengHaoValue调整属性0 、1 、24、 25支持突破100%

【2023-04-09更新:】
本次更新文件：M2Server.exe、脚本加密插件.exe、远程NPC脚本服务器.exe
1.增加了获取全身装备的原始数据字段总和值命令
2.增加了仿hero摆摊点击开始摆摊或停止摆摊将触发 [@ShopStall]
3.扩展了GetItemFieldValue可获取数据库自定义字段值
4.扩展了称号元素命令SetNewFengHaoValue支持24和25元素
5.更新了脚本加密工具支持UTF8编码脚本（本版开始原加密的脚本需重新加密使用）
6.更新了远程NPC脚本服务器程序支持加密脚本（需配合M2一起更新使用）

【2023-04-07更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.装备对比的默认规则增加仅对比最高攻击、魔法、道术选项
2.增加了鼠标在游戏窗口中坐标变量

【2023-04-06更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、RunGate.exe、GameCenter.exe
1.处理了自定义UI及时雨内挂“物品”栏缺少的选项
2.处理了AddTextListEx写入会强制修改文本编码的问题
3.增加了宝宝攻击目标掉血前触发获取对象的常用变量支持
4.元素检测与获取命令支持攻击伤害抗性附加属性
5.优化了网关和控制器相关细节处理
6.优化了视野相关细节

【2023-04-05更新:】
本次更新文件：M2Server.exe、RunGate.exe
1.优化了人物被踢下线后，关闭游戏窗口需等待问题
2.M2界面操作U变量和G变量支持922G
3.扩展了GetStringPosEX参数6支持完全匹配
4.增加带缓存的字符检测命令：CacheGetStringPosEx
5.去除自定义技能内力值不足提示

【2023-04-03更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、Wzl编辑器.exe、微端程序.exe
1.更新了配置器UI界面控制声音关闭按钮递减选项
2.更新了行会合一的一处细节判断处理
3.更新了WZL编辑器和微端程序对大体积PAK加载速度
4.增加了自定义技能直线攻击宽度设置
5.增加了自定义技能支持疾光电影类
6.增加了检查是否评定过主副将英雄的命令
7.优化了31类可放入物品快捷栏相关细节

【2023-04-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、合区工具.exe、数据管理工具.exe
1.扩展了MobEctypeMon支持名字颜色
2.扩展了自动替换装备界面支持当前物品名字显示
3.增加了不掉落身上装备操作命令
4.增加了悬浮框特效设置及相关操作命令
5.更新了releasemagicEX触发支持自定义技能
6.优化了默认NPC对话框、物品列表栏、OK框替换后素材显示偏移相关
7.优化了拆解装备相关细节

【2023-03-29更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.扩展了自动替换装备支持参数4是否自动替换
2.扩展了CSVOpenCache加载表格到内存支持热加载
3.优化了英雄内功经络相关

【2023-03-28更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、WZL编辑器.exe
1.修复了突破21E属性后个别技能伤害值无效的问题
2.更新了网关程序支持参数封加速
3.更新了假人指定攻击目标命令
4.更新了假人英雄数据存储和假人支持TIMERECALL命令
5.增加了CSV接口及相关命令
6.扩展了英雄UI预留按钮
7.优化了WZL编辑器将WZL另存为PAK的一处细节处理

【2023-03-26更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了引擎的已知报错
2.优化了无限仓库系统存取相关流程
3.优化了坐骑相关细节
4.修改了实时货币备注中运用
5.更新了GetItemFieldValue支持获取stock值和自定义数据库字段

【2023-03-18更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、NewopUI.Pak
1.修复了内挂挂机不抢怪无效的问题
2.扩展了AddHpPer 和 AddHpPerEx支持自定义漂血
3.将勋章特效和天使翼归纳入内挂翅膀特效（原在衣服简装控制）
4.客户端控制增加了漂血模式和淡出支持暴击特效选项
5.增加了几个元素组相关的操作命令
6.优化了老式仓库对叠加物品的一处细节处理

【2023-03-14更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了组队信息MP显示异常的问题
2.扩展了TAKE 支持参数6 判断物品持久是否满持久（可用于收回满经验聚灵珠）
3.增加了新的十步一杀DB，技能数据库MagID：211 其他参数与原技能相同（技能参数共享原十步一杀技能）
4.优化了CHECKSCRIPTPARAM命令相关
5.优化了TextSplit自定义分隔符相关
6.优化了自定义按钮图层相关

【2023-03-12更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1修复了自定义怪物自身特效自我中心绘制不支持普通模式
2.增加了七种货币常量用于实时显示
3.增加了货币改变触发（支持七种货币）
4.增加了物品进入背包触发及相关命令
5.增加了删除仓库物品命令
6.增加了存取物品到仓库前触发及相关命令
7.增加了获取仓库物品数量命令
8.增加了怪物数据库RACE 210 211（类似于大刀卫士攻击方式）
9.增加了时间戳变量和获取命令
10.增加了对话框和悬浮框变量显示数字单位元素命令
11.扩展了SuperMoveMsg、SendNewLineMsg支持国家模式
12.扩展了RangeHarm和RangeHarmEx 支持百分比伤害
13.扩展了TAKE 支持参数5是否收回自定义OK框物品
14.扩展了MOBFIREBURN支持百分比伤害
15.自定义技能列表和自定义怪物列表支持CTRL+F查找
16.宝宝CTRL+R锁定关联宠物
17.修改了鼠标指向目标时使用心灵召唤宝宝召唤到身边再走到目标身边攻击
18.优化了连击CD相关细节和挂机期间支持自动连击
19.优化称号的相关细节
20.优化了毒符互换相关细节
21.优化了文本编码相关细节

【2023-03-05更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了查看在线人物修改控件后导致无法查看详细信息问题
2.修复了延时脚本命令的一处BUG
3.增加聚灵珠使用前触发QF
4.增加聚灵珠使用前中断命令
5.增加给予一个满经验聚灵珠命令
6.增加检测包裹中满经验聚灵珠数量命令
7.增加拍卖行竞价购买前触发
8.增加拍卖行竞价终止购买命令
9.增加了拍卖行物品取回触发
10.增加了拍卖行终止取回物品命令
11.音量图标按钮修改为百分比减少至关闭
12.游戏窗口图标支持配置器上设置
13.更新了TCP列表程序
14.内挂药品保护支持大数值保护
15.扩展GetDBMonsterFieldValue支持922京属性
16.修改了武器高低位声排除魔法动作，仅限砍的动作生效

【2023-03-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了关于NPC大对话框问题
2.修复了日闪类推动的已知问题
3.扩展ChangeState增加参数10是否显示提示
4.M2在线人物支持货币排序和登录器标识显示
5.心灵召唤鼠标指向目标选项修改为宝宝锁定目标
6.战斗退出功能细致化完善并增加战斗状态触发
7.M大地图上坐标和名称可以移动到地图外显示
8.优化了直线攻击获取主目标相关细节
9.更新了合区数据提取工具
10.优化了其它几处细节

【2023-02-25更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了自定义技能目标播放效果【前奏】的一处播放问题
2.修复了宝宝血条对使用自定义怪物做宝宝时无效的问题
3.修复了RecallGamePet登录脚本使用时宠物状态显示错误的问题
4.修复上版修改残影导致对话框图层逻辑的问题
5.修复了战士直线攻击获取目标及攻击触发的问题
6.修复了死亡掉线后退出游戏需要等待的问题
7.修改了自定义怪物判断目标数量的一处错误
8.宝宝锁定目标支持大范围
9.客户端设置增加称号位置随图片大小移动选项
10.扩展OpenBigDialogBox命令支持窗口位置和关闭按钮位置
11.Text增加支持AUTOCOLOR彩色显示和FBOLD粗体显示
12.自定义技能和自定义怪物增加突进设置
13.自定义技能增加无举手动作选项
14.自定义技能日闪类推动
15.增加获取自定义怪物攻击模式类型
16.ADDBUTTON位置扩展支持M地图
17.仿页游小地图修改为切换不关闭
18.自定义UI中支持称号颜色修改
19.心灵召唤支持鼠标位置为宝宝攻击目标
20.开放922G属性(突破42E属性)
21.物品禁止存仓提示修改

【2023-02-15更新:】
本次更新文件：全套更新
1.修复了半月攻击多目标获取目标变量的一处问题
2.修复了无限刀模式下RangeHarm影响怪物速度的问题
3.修复了设置名字偏移后摆摊时名称错位问题
4.修复了自定义Npc对话框切换存在延时残影问题
5.修复了HumanMP 次数无效的问题
6.去除宝宝总数限制诱惑数量（22-11-18增加限制）
7.PAK批量转换工具增加压缩选项
8.扩展叠加物品重量OverLap=3时，重量为单物品重量
9.扩展SetArrBuff 和 ADDBUTTON 数量支持200个
10.扩展GOTOLABEL 模式(0,1,2,3) 增加模式9为国家成员触发模式 ，给自己国家成员触发
11.控制器默认备份增加M2Data和GuildBase备份
12.增加押镖期间获取当前镖车名称和坐标的变量
13.增加判断对面对象的类型命令
14.增加检测对象状态命令
15.灵符、游戏点、声望点、荣誉值 扩展支持922G

特别注意：本版开始以下命令时间参数，由原来的分钟修改为秒，如果你使用了下面的命令请注意更改时间....
ChangeGamePetAbility
ChangeSlaveAbility
ChangeSlaveAbilityEx
ChangeMonAbility

【2023-01-30更新:】
本次更新文件：M2Server.exe
1.修复了CHECKSCRIPTPARAM命令的一处错误
2.优化了部分机器WIN2008和2012系统启动引擎慢的问题

【2023-01-24更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了按住shift强制攻击造成速度过快假象的错误
2.修复了AddNumberButton一处错误
3.修改了SENDMOVEMSG命令客户端缓存规则
4.ImgNum支持922G属性转换显示

【2023-01-22更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.细致化游戏速度调整
2.遗漏的脚本命令扩展支持到922G属性
3.解决微端下载某些PAK素材时可能出现一直疯狂下载不得停的历史遗留问题

【2023-01-19更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了任务系统的一处问题
2.修复了NPC大对话的一处瑕疵
3.修复了无限属性选项不保存的问题
4.在线发送信息后增加禁止店铺操作
5.优化了登录器内存相关
6.ADDDLG位置增加查看他人属性
7.ELEMENT25变量支持

【2023-01-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了一键回收命令颜色值的一处错误
2.解决登录器无响应闪屏的问题
3.扩展了IF支持多条件检测运用
4.扩展了ADDBUTTON 支持对象位置
5.增加了C常量为对象常量,对象变量取值操作命令
6.增加SetCurrTarget设置当前对象命令可用于查看他人装备

【2023-01-13更新:】
本次更新文件：全套程序
1.修复了隐身戒指和套装隐身属性的一处错误
2.修复了无限刀攻击怪物等级低于40级时的一处问题
3.修复了连击技能释放的已知问题
4.修复了内挂挂机会攻击人形怪宝宝的问题
5.修复了自动替换装备的一处问题
6.修复了货币超多时候无法购买摆摊物品
7.修改物品特效备注显示
8.改进了参数设置-时间控制 NPC点击和NPC按钮间隔处理
9.String.ini 增加连击暴击提示文字自定义修改
10.优化了客户端播放声音相关细节
11.优化了登录器已知的内存相关细节
12.优化了同屏封包相关
13.优化了DBServer.exe、LoginSrv.exe、SelGate.exe、GameCenter.exe的相关细节
14.扩展了GetBagInfo支持参数3
15.扩展了TakeBagItem颜色值支持多个使用

【2022-12-31更新:】
本次更新文件：全套程序
1.修复了合区工具的一处错误
2.开放客户端插件功能

【2022-12-30更新:】
本次更新文件：全套程序
1.解决上版更新的DBSERVER的一处兼容性错误
2.解决上版关闭英雄收回保护会同时关闭人物保护的问题
3.优化物品入包相关，显著降低网络占用

【2022-12-29更新:】
本次更新文件：全套程序
1.修复了上版手动释放技能的一处问题
2.修复了启用爆出物品限制数量后的一处内存释放问题
3.客户端控制-其他控制增加禁用英雄自动收回保护选项
4.配置器超大属性显示,增加最大显示单位限制选项
5.配置器增加了聊天框提示是否显示"前往目标"选项

【2022-12-27更新:】
本次更新文件：全套程序
1.修正了内挂挂机的一处细节问题
2.修正了无缓存微端提示客户端密码错误的问题
3.修改了获取行会人数脚本命令GETGUILDMEMBERCOUNT参数3为1时排除离线挂机人物
4.增加了行会掌门人踢人前触发命令
5.增加了检测是否战斗状态命令
6.增加了行会战地图参数FIGHT3(是否掉装备)
7.扩展FILTERGLOBALMSG支持屏蔽SENDMOVEMSG
8.扩展GuildNoticeMsg支持行会成员
9.解决了怪物延时问题
10.修复了其它几处小细节问题
11.优化了英雄和分身多处细节

【2022-12-17更新:】
本次更新文件：全套程序
1.增加武器高位声并扩展自定义高位声
2.登录器背景图自适应恢复
3.N和U变量全部扩展支持大数值，不在局限于0-49
4.在线人数提升至99人，并提供5人大数值922G属性体验版
5.增加了战斗禁止退出功能(参数设置)
6.增加了客户端窗口标题内容显示命令
7.RangeHarmEx 参数6扩展支持大数值
8.修复了几处细节问题

【2022-12-04更新:】
本次更新文件：全套程序
1.优化了多处已知细节操作

【2022-12-03更新:】
本次更新文件：全套程序
1.修复了系统对等级默认属性的一处错误
2.修改Defines文件夹中INI内容中 //和;符号为注释符号
3.完善技能提示栏相关
4.扩展G、 N$变量全部支持大数值到922G
5.完善了分身的相关
6.优化了其它几处小细节

【2022-12-01更新:】
本次更新文件：全套程序
1.修复了ItemShow一处细节问题
2.修复了按住SHIFT存在中断的问题
3.修复了宝宝秒杀怪物时杀怪爆率倍数不生效的问题
4.修复了悬浮框超出分辨率遗漏装备栏的问题
5.修复了AddDlg容器坐标遮挡文字的一处问题
6.修复了原地复活后显示血量的一处问题
7.修复了神秘人相关的已知问题
8.修复了GM命令删除行会的一处问题
9.内挂挂机增加了X分钟无目标使用物品选项
10.修改了53类和7类宝石剩余值低于1万时的显示
11.控制器增加了开启日期和开启前清理数据选项
12.战士英雄和道士英雄支持自动开武力盾和道力盾
13.增加绝对路径CALLEX，和CALL用法一致
14.技能快捷键设置界面增加 内挂技能中增加显示技能在提示栏上 选项
15.增加获取角色背包信息
16.扩展 PlayImg PlayImgEx 参数M支持底层播放
17.重写并优化了分身相关(重大更新请详细测试，有问题请提交到论坛)
18.优化了其它几处细节

【2022-11-22更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.扩展斗笠数量
2.物品装备中暴击几率默认限制改为100%
3.悬浮框高度超出分辨率修改为自动换行
4.CreateNPC和N998、N999细节问题处理
5.解决停止服务器时引擎偶尔超时无响应控制器会强制关闭的问题
6.内挂禁止拉动聊天框选项移动到配置器-客户端选项
7.内挂增加隐藏怪物顶戴花铃选项
8.修复、优化了其它几处细节问题

【2022-11-18更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、合区工具.exe、数据管理工具.exe
1.优化嘲讽命令，并扩展了将怪物嘲讽到鼠标位置
2.技能参数中宝宝总数限制纳入法师的诱惑之光技能
3.解决#Define 会忽略空格后面内容的问题
4.聊天栏SENDTOPCHATBOARDMSG 和 SENDMSG 支持脚本功能
5.增加调整人物、英雄、宝宝、怪物体型大小命令
6.脚本刷怪命令扩展参数13支持怪物体型大小
7.GM命令刷怪扩展支持怪物体型大小
8.元素变量分割符恢复为逗号，并修复前几版由于分割号引起的BUG
9.扩展ItemShow增加参数G ，G= 灰化显示(0或空=正常，1=灰化)
10.临时数据模式命令SetTempDBMode扩展关闭可保存临时数据
11.狮子吼增加持续麻痹选项
12.修复、优化及完善了多处已有功能相关细节...

【2022-11-12更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UI升级工具.exe
1.修复了攻击速度+会影响组合动作停顿时间的问题
2.修复了客户端相关错误导致显示异常问题
3.修复了53类宝石在关闭0级不显示佩戴条件的情况下还会显示需要等级的问题
4.修复了宠物的一处错误导致wIdent:20063报错
5.完善了宝宝和英雄多处细节处理
6.增加检测目标是否为宝宝CheckCurrTargetSlave
7.增加英雄攻击目标主人名称获取变量<$H.CurTargetMasterName>
8.完善了新行会多处相关细节
9.完善了摆摊的几处相关处理
10.增加了英雄方向变量<$H.DIR>
11.增加组队开启后图标点亮功能

【2022-11-11更新:】
本次更新文件：全套程序
1.扩展releasemagicEX 和 releasemagic参数支持不伤害触发
2.扩展HUMANHP参数7支持万分比扣血
3.增加TakeBagItemColor命令按数据库Color颜色值进行回收
4.怪物属性扩展：Envir\MonSpAbilList.txt增加怪物支持暴击抗性
5.增加PrintUseTime脚本运行间隔检测命令,可用于性能检测进行脚本优化
6.增加镖车相关操作命令
7.暴击几率和暴击抗性允许突破100%
8.增加攻击伤害抗性元素并允许突破100%
9.增加角色视野大小调整(参数设置-坐标范围)
10.增加行会战优先显示红名功能(参数设置-游戏选项1)
11.增加并完善复古类实用性功能及选项
12.增加检测魔法盾、武力盾、道力盾是否开启状态命令
13.增加退出行会前触发和终止退出行会操作命令
14.聊天框增加支持脚本功能及自动寻路、传送功能
15.扩展ChangeHumAbility增加参数5(值是否为百分比;0:固定值；1:百分比)
16.修复传统复古相关规则已知多处细节设定错误
17.优化英雄、宝宝以及角色大量细节相关处理
18.优化内挂相关操作
19.优化并处理其他多处不合理的地方

【2022-11-01更新:】
本次更新文件：全套程序
1.扩展 Npc文字：Text增加字号/字体 ， 并支持Messagebox
2.扩展 DoTaunt 嘲讽命令
3.扩展H.TakeBagItem最后增加参数是否回收至主人背包
4.扩展H.OpenAutoDropItemToBag 增加参数是否进入主人背包
5.扩展H.OpenAutoPickItem 增加参数是否进入主人背包
6.扩展扩展个人商店购买触发增加叠加物品变量
7.扩展商铺购买物品触发
8.扩展CheckMapMonInfo参数5支持获取改名怪物坐标
9.扩展 SetItemState 项目7：禁止取下
10.扩展MAKEPOSION 增加参数5 是否千分比计算威力
11.扩展TextSplit 命令增加返回分割数量
12.扩展MonDropItems 命令增加参数4支持爆出物品到怪物身边
13.扩展HumanHP 增加参数5是否飘血,参数6支持自定义漂血
14.扩展GETRANDOMLINETEXT行数支持
15.扩展Kill 支持清理尸体
16.扩展COUNTDOWN新增参数M
17.扩展背包物品对比条件支持自定义属性、重量、等级
18.扩展GoHome支持范围
19.扩展塑造天下第一雕像命令支持英雄
20.扩展自定义属性悬浮框支持40条显示
32.扩展GOTO将传递参数返回值保存到变量
22.流星火雨增加命令调整伤害次数
23.天下第一雕像支持英雄
24.角色交易系统增加自动召唤英雄选项，方便查看英雄装备
25.英雄设置增加锁定目标距离限制（宝宝锁定共享此参数）
26.界面UI设置中装备提示修改为删除不留空格
27.地图事件增加英雄爆出物品触发
28.个人商店增加正在出售中物品禁止改价选项
29.参数设置-价格费用页面增加是否保存NPC缓存选项
30.宠物设置--》参数设置--》增加选项"杀怪触发[@GamePetKillMon]"
31.PAK批量转换工具支持批量修改密码
32.内挂同步物品数量扩展至10000
33.浑水摸鱼参数将人形怪纳入（参数对人物、英雄、人形怪有效）
34.野蛮冲撞增加选项“允许隔位野蛮”
35.裂神符增加了分裂后威力衰减参数设置
36.怪物爆率支持变量
37.登录器增加自定义动画设置
38.摆摊文字颜色支持自定义
39.变量扩展并支持Z变量（字符类定时清理）
40.<$PICKDROPITEM>支持在GuildNoticeMsg中查看装备属性
41.StopPlayEffect 和ClearPlayEffect 支持停止PLAYEFFECT播放再怪物身上特效
42.自定义怪物自身特效支持绘制顺序和特效2
43.修改自定义怪物根据职业计算伤害时，如果有主人，则按主人的职业算伤害，否则以DC为准
44.修改mondropitems和mondropitemsEX掉落的装备当前持久随机
45.个人店铺禁止修改价格加入禁止个人商店仓库中物品价格
46.增加套装生效全局触发和检测命令
47.releasemagicEX增加参数5 (是否检测冷却间隔)
48.changeState 增加效果代码13和14
49.增加地图参数TimeMap用于限制地图时间
50.增加宠物攻击触发、魔法触发
51.增加宠物被攻击、被魔法触发
52.增加宠物攻击和被攻击掉血前触发
53.增加采集类怪物
54.增加隐身状态属性
55.增加刷怪支持G变量刷怪，Mongen.txt的最后拓展三个参数，分别是G变量 操作符(>,<,=,>=,<=) 数值
56.增加修改宝宝属性值命令
57.增加数学表达式运算命令
58.增加服务端目录变量<$GameDirectory>
59.增加M2所在目录变量<$M2Directory>
60.增加获取指定位置的物品数量，并放入到变量中
61.增加英雄幸运值变量：<$H.LUCK>
62.增加变量：<$CurTargetMasterName>，当前攻击目标的主人名
63.增加上下马脚本命令
64.增加复制文件脚本命令
65.增加调整怒气值命令
66.角色出售界面增加查看英雄装备
67.增加MonDropItemsEx支持怪物掉落提示和掉落触发
68.增加当人物/英雄取下装备前进行触发
69.增加个人商店上架/下架物品触发
70.增加捡取他人打怪爆出物品，未到可捡取时间则屏幕显示剩余多少时间可捡取选项
71.增加宝宝攻击前触发@SlaveAttackDamage 掉血前触发@SlaveStruckDamage
72.增加切换攻击模式触发(Ctrl+H，不含命令修改模式）QF触发@AttatckModeChange
73.增加回收指定位置装备：TakePosW 物品位置
74.ChangeModeEx 增加模式14，传送
75.增加将背包物品放到仓库/无限仓中命令
76.增加英雄怒气值变量<$H.AngryValue>
77.增加检测英雄怒气值命令
78.增加ExchangeLineText文本字符交替命令
79.增加人物/英雄穿戴装备前触发以及中止穿戴命令
80.增加检测背包是否有列表中物品命令
81.增加获取NPC坐标命令
82.增加获取地图怪物坐标命令
83.增加NPC获取文件行数命令
84.Npc对话框元素，多个元素前增加&，命令中原有的偏移坐标加了&后表示绝对坐标
85.更新合区工具支持批量合区
86.增加$strU变量显示数字单位，类似$Str
87.增加检测装备元素属性
88.增加缓存指令AddCacheNameList、DelCacheNameList、ClearCacheNameList、CheckCacheTextList
89.增加人物/英雄临时数据模式命令
90.增加地图参数：禁止召唤英雄，已召唤的英雄不受影响
91.合击技能:雷霆一击支持伤害范围调整
92.怪物掉落触发支持坐标显示
93.增加隔位野蛮冲撞命令
94.增加地图范围缩小相关命令可用于吃鸡
96.属性突破42E支持922G（人物属性怪物HP暂不对外,其他均开放,属性超过42E则强行限制为42.95E）
97.增加多元数组元素变量
98.本次更新API插件接口有改变，请同步更新
99.NewopUI.Pak有更新,改变了普通漂血素材位置,弃用原编号90-101 修改位置到340-356(如不更换PAK文件，请注意检查替换您的漂血素材)
100.增加切割行数命令ExtractStringEx 支持自定义变量并支持自动写如入变量数
101.内挂增加遇到障碍自动绕行选项
102.内挂增加主人背包对比英雄佩戴装备选项
103.内挂挂机遭遇玩家攻击时增加自动反击
104.配置器增加内挂血量单位需要大于多少HP才显示参数设置
105.优化游戏延时问题和游戏流畅度,真正实现开飞机和无限刀
106.血量显示单位增加配置器上自定义设置最低触发参数
107.增加按照背包对比规则进行装备自动替换命令
108.增加无缓存模式微端服务程序（缓存模式占硬盘空间，无缓存占CPU使用）,并优化部分素材首次更新显示不全的细节处理
109.增加强制攻击模式和显示国家名字颜色地图参数
110.金币\元宝和金刚石扩展支持9223372036854775807（日志程序同步更新，新日志程序不兼容原日志记录）
111.自动清除无人物地图怪物关联列表信息1中禁止清理怪物列表
112.Npc对话框元素增加编号及容器编号并支持ListView （ListView容器请不要嵌套使用）
113.个人商店和摆摊物品售价支持千分符，和背包千分符共享选项
114.增加按给定概率随机获取分割后的字符串
115.优化了技能伤害延迟和间隔相关
116.优化并完善了若干细节问题

为了更好的兼容第三方工具（如自动开区 ,数据库编辑工具等）本引擎数据库按照V8M2引擎数据库名进行扩展，使用V8引擎直接替换本引擎，GEE引擎则需修改数据库名称或启动本套引擎生成全新数据库文件
本次更新NewopUI.Pak默认密码修改和资源读取规则中默认密码修改为V8M2

注：本引擎完美支持V8引擎,为更换引擎更简单，大部分按照V8更新记录更新并进行相关优化,更新请全套程序更新，请勿有遗漏....
因功能性扩展需要，本引擎仅提供64位引擎,停止32位程序供应（如M2,合区,数据管理不在提供32位程序,请在64位系统下运行这些程序）
ID数据库、角色数据库、个人商店数据库文件\三个文件均作修改，如果全新开区直接删除原来数据库让本程序生成全新的数据库文件
如果你是GEE的引擎转换本引擎，请修改物品数据库名或使用本引擎包的DBC数据库转Sqlite工具重新转换

注意：已经开区的全套更新后，启动一次程序会生成全新的数据库文件，复制文件名称后删除掉新生成的数据库文件，将原数据库文件名进行重命名即可
未开区的直接删除LoginSrv\IDDB 、DBServer\FDB、Mir200\M2Data三个文件夹的所有文件，启动程序会自动生成数据库文件
对应数据库文件名更改：
Account.db ---> ApexID.DB
RoleData.DB-----> ApexMir.DB
M2Data.DB----->ApexM2Data.DB
;以上三个文件如果全新开区请直接删除无需转换，正在开区请重命名
GEEM2.DB --> ApexM2.DB ;;;;;;;;;;此文件为物品、怪物、技能数据库直接重命名或重新转换

【2021-04-10-1更新:】
本次更新文件：M2Server.exe
1.修正SetArrBuff一处错误

【2021-04-10更新:】
本次更新文件：M2Server.exe、RunGate专业版.exe
1.修正自定义增益技能的一处内存错误
2.修正专业版网关对自定义开关技能造成并发的问题（需更新专业版网关）
(集成的自定义技能未处理，需M2发送的自定义技能到客户端，或用多线程网关也可解决)
3.列表信息2-怪物设置-怪物掉落规则“已爆物品“支持修改

【2021-04-06更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UI升级工具.exe
1.修正个人商店取款后文字依然显示取款的问题
2.修正人物无法叠加HP给人形怪宝宝
3.修正自定义属性设置在套装信息下单列显示的一处错误
4.增加宝宝自身坐标、宝宝当前攻击目标坐标变量
5.宝箱增加循环脚本命令自定义UI编辑

【2021-03-27更新:】
本次更新文件：M2Server.exe
1.增加循环脚本命令，用于替代高频次数的GOTO循环，可防止GOTO递归层次多时产生栈溢出
2.优化其他几处细节

【2021-03-17更新:】
本次更新文件：M2Server.exe
1.优化引擎几处细节

【2021-03-13更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正A G全局变量保存的一处细节问题
2.修正自定义技能一个坐标点只可以释放一个技能的问题
3.修正31类物品改名后$G_UseItemName依旧显示原名称的问题
4.修正POWERRATE调整攻击力后攻击目标的一处伤害计算问题

【2021-03-12更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正装备改名后在沙巴克武器升级导致名称错位的问题
2.修正MonDropItems 爆出物品不会记录到爆出数量得问题
3.修正RangeHarm 和 RangeHarmEx 命令参数使用变量不支持的问题
4.修正人物改名 和 英雄的改名字符变量长度检测的一处问题
5.修正WRITELINE 命令不支持常规路径 如： ..\QuestDiary\aaaa.txt 1 写入一段文字
6.修正给英雄使用 H.TakeOnItem 或H.AutoTakeOnItem穿戴命令替换装备后，内观上不实时刷新问题
7.修正掉血前触发@AttackDamage ，在护身装备时的一处问题
8.修正个别机器倒计时命令无法显示的问题
9.物品规则，增加禁止放入“宠物背包”功能

【2021-03-06更新:】
本次更新文件：M2Server.exe
1.修复sqlite多线程支持对个人商店的造成的异常问题（20210302开始）

【2021-03-04更新:】
本次更新文件：M2Server.exe、LogDataServer.exe、LoginSrv.exe
1.修正上版引擎的一处报错
2.修正登陆验证码的一处错误
3.优化远程日志服务器程序

【2021-02-24更新:】
本次更新文件：M2Server.exe、LogDataServer.exe
1.增加掉落身上装备命令
2.优化其他相关细节
3.优化日志服务程序

【2021-02-11更新:】
本次更新文件：MakeGameLogin.exe
1.优化大退延迟相关细节

【2021-02-09更新:】
本次更新文件：M2Server.exe、LogDataServer.exe、远程日志查询工具.exe
1.修正英雄技能相关细节
2.增加加入行会前触发
3.增加远程日志查询

注意：64位引擎需在64位系统上运行，服务端插件和客户端插件接口改变,引擎不再支持DBE数据库，32位升级需全套更新！！！！

【2021-02-01更新:】
本次更新文件：M2Server.exe
1.处理仿Herom2摆摊的一处错误
2.处理引擎启动加载
注意：64位引擎需在64位系统上运行，服务端插件和客户端插件接口改变,引擎不再支持DBE数据库，32位升级需全套更新！！！！

【2021-01-30更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正自定义技能目标效果持续播放无效的问题
2.修正物品规则允许拍卖无效的问题

注意：64位引擎需在64位系统上运行，服务端插件和客户端插件接口改变,引擎不再支持DBE数据库，需全套更新！！！！

【2021-01-29更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正配置器上及时雨内挂修改文字或隐藏内挂文字，内挂个别选项文字会换行的问题（需要删除NEWUI文件夹JSY.INI配置文件后重新配置内挂）
2.增加变量：当前日期：<$Date> 格式：2021-01-11；当前时间<$Time> 格式：10:00:00
注意：64位引擎需在64位系统上运行，服务端插件和客户端插件接口改变,引擎不再支持DBE数据库，需全套更新！！！！

【2021-01-28更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正自定义安全区的一处错误
2.修正SetArrBuff的一处错误
3.修正自定义怪物飞行和目标效果的问题
4.修正宝箱系统的一处错误
5.完善SetThrowItemFrom设置物品来源相关
注意：64位引擎需在64位系统上运行，服务端插件和客户端插件接口改变,引擎不再支持DBE数据库，需全套更新！！！！

【2021-01-27更新:】
本次更新文件：全套更新
1.角色交易增加下架指定角色的GM命令
2.增加英雄使用技能前，自身触发：@H.BeginMagic
3.浑水摸鱼增加隐藏顶戴花翎参数
4.增加登录器变量推广标识:<$GamePromotionFlag>
5.英雄刷新背包间隔同步人物间隔
6.增加刷新透视爆率命令PreviewMonDropItemRefresh 最多显示数量 刷新条件（0：仅刷新有间隔的透视怪；1：无条件刷新）
7.增加地图参数 NoAutoDropItemToBag 禁止物品自动入包,NoAutoRangePickItem 禁止范围拾取
8.列表信息1增加禁止范围拾取和禁止自动入包禁止列表
9.任务系统支持鼠标滚轮
10.配置器版本不符弹出页面修改为默认浏览器
11.增加支持杀英雄者的变量：<$HeroKiller>
12.MonDropItems 怪物名 物品名 物品数量,增加支持怪物掉落触发M2DropItem，MonDropItems日志服务器记录完善
13.增加检测使用的物品来源于哪个背包
14.增加NPC对话框标记UserItem(类似ITEMSHOW:>，调用人物身上的装备信息
15.增加使用ThrowItem命令放置物品之前修改物品的来源
16.神佑首饰盒物品支持装备对比和背包对比（物品必须是只允许首饰盒和只允许神佑才行）
17.加抵御暴击几率：暴击抗性（暴击几率 - 防御几率 = 暴击打出几率）
18.配置器读取列表索引支持自定义修改，配置器- 登录器选项
19.为方便WIN10写脚本，支持UTF-8编码的TXT脚本
20.数库修复工具增加支持ID数据库数据
21..随机验证码命令setrandomno 扩展参数
22.修正已知BUG
23.优化其他几处相关细节处理
注意：本版引擎开始为64位引擎，需在64位系统上运行，服务端插件和客户端插件接口改变,引擎不再支持DBE数据库，需全套更新！！！！

【2020-11-30更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正获取自定义装备属性类型=3 无效的问题
2.魔血石回血模式增加单次恢复总持久的万分比
3.优化其他几处细节处理

注意：因20201106更新旧模式支持自定义文字，装备属性显示方式为旧模式的需在配置器自定义文字中调整属性，手动去掉属性后面 “：”冒号(使用悬浮框的装备属性显示模式请无视本条！！！！！1106之前引擎更新本版引擎并且装备属性显示为旧模式需手动在配置器处理)

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-11-25更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.盾牌特殊属性数据库参数Shape 修改为AniCount
2.配置器增加技能书职业的自定义
3.骑马时修改为禁止使用野蛮冲撞
4.其他几处细节优化处理

注意：因20201106更新旧模式支持自定义文字，装备属性显示方式为旧模式的需在配置器自定义文字中调整属性，手动去掉属性后面 “：”冒号(使用悬浮框的装备属性显示模式请无视本条！！！！！1106之前引擎更新本版引擎并且装备属性显示为旧模式需手动在配置器处理)

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-11-24更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正英雄锁定目标的一处细节处理
2.增加查看他人装备触发
3.增加沙巴克丢失和占领行会在线所有成员触发
4.增加自定义武器砍击声

注意：因20201106更新旧模式支持自定义文字，装备属性显示方式为旧模式的需在配置器自定义文字中调整属性，手动去掉属性后面 “：”冒号(使用悬浮框的装备属性显示模式请无视本条！！！！！1106之前引擎更新本版引擎并且装备属性显示为旧模式需手动在配置器处理)

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-11-23更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.MonGen.txt 刷怪触发增加变量支持
2.增加传送戒指(坐标传送)传送前QF触发: @BeginTeleport和中止传送戒指传送：StopTeleport
3.怪物改名增加ChangeMapMonNameEX命令
4.恢复穿衣服性别不同提示
5.优化记忆石和国家怪物的细节

注意：因20201106更新旧模式支持自定义文字，装备属性显示方式为旧模式的需在配置器自定义文字中调整属性，手动去掉属性后面 “：”冒号(使用悬浮框的装备属性显示模式请无视本条！！！！！1106之前引擎更新本版引擎并且装备属性显示为旧模式需手动在配置器处理)

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-11-18更新:】
本次更新文件：M2Server.exe、DBServer.exe
1.增加当前攻击主目标坐标和HP变量
2.优化了引擎其他几处相关细节处理

注意：因更新旧模式支持自定义文字，装备属性显示方式为旧模式的需在配置器自定义文字中调整属性，手动去掉属性后面 “：”冒号(使用悬浮框的装备属性显示模式请无视本条！！！！！)

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-11-11更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、LoginSrv.exe、自定义UI升级工具.exe
1.将特殊字段 @@ 修改为 @_@ ,因@@影响自带的脚本，如创建英雄和创建行会
2.内挂人物简装分为 武器简装 和衣服简装
3.修改MonSpAbilList.txt 、自定义怪物物理攻击无视防御、元素忽视防御 ，去掉无视魔法盾 护体神盾
4.完善旧模式自定义文字相关
5.增加技能锁定目标名<$ATTACKMONSTER_NAMEEX>（有可能为空，比倚天辟地等无鼠标指向 、点击、魔法锁定的目标时）
6.优化其它几处细节

注意：因本版更新旧模式支持自定义文字，装备属性显示方式为旧模式的需在配置器自定义文字中调整属性，手动去掉属性后面 “：”冒号(使用悬浮框的装备属性显示模式请无视本条！！！！！)

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-11-08更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.优化设置绑定命令相关细节
2.优化自定义技能增益相关细节
3.优化怪物麻痹的的一处细节
4.开放登录器插件

注意：因本版更新旧模式支持自定义文字，装备属性显示方式为旧模式的需在配置器自定义文字中调整属性，手动去掉属性后面 “：”冒号(使用悬浮框的装备属性显示模式请无视本条！！！！！)

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-11-06更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复宠物背包系统叠加物品相关的一处严重BUG(有叠加物品，只要引擎支持宠物，不管你有没使用都必须更新)
2.增加暂停游戏刷怪命令
3.配置器装备属性自定义文字支持旧模式
4.配置器增加关闭技能快捷键拖出至游戏界面的选项
5.配置器增加取消技能鼠标指向图标时，显示冷却间隔的文字提示
6.列表信息2-装备技能威力增加合击技能
7.登录器增加选项恢复关闭登录器后关闭所有游戏窗口选项
8.扩展ChangeSlaveLevel命令支持所有宝宝名
9.组队模式增加不询问请求选项（老模式，功能设置-其他设置开启）
10.去掉SetItemBind CheckItemBind 多余的绑定命令(使用此命令的请更换为SetItemState 和CheckItemState)
11.增加个人商店购买触发
12.自定义倒计时SetClientBuff 扩展至 200
13.优化微端缓存相关
14.优化其它几处细节

注意：因本版更新旧模式支持自定义文字，装备属性显示方式为旧模式的需在配置器自定义文字中调整属性，手动去掉属性后面 “：”冒号(使用悬浮框的装备属性显示模式请无视本条！！！！！)

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-10-31更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe
1.增加组队队长检测命令
2.优化客户端设置技能相关的一处细节
3.优化怪物相关的一处细节

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-10-29更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe、UI升级工具.exe
1.自定义UI英雄背包增加整理按钮
2.连击技能完成后增加QF触发
3.内挂增加自动连击选项
4.内挂增加隐藏顶戴花翎选项
5.完善@StruckDamage获取变量的一处细节
6.OpenAutoDropItemToBag支持怪物掉落触发和掉落提示
7.扩展支持清理地图所有物品ClearItemMap命令支持地图所有物品
8.扩展获取队员数量GetGroupCount命令 支持范围
9.增加GetRankLevelByNo根据排名获取等级命令
10.增加GetRankLevelByName 根据玩家名称获取排名中的等级
11.优化其他几处细节
本版自定义UI涉及UI升级！！！
0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-10-24更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe
1.Bugfix
2.扩展减少技能CD命令支持英雄技能和连击技能
3.扩展第三方骑马衣服素材
4.扩展人物发型连击动作支持
5.完善透视爆率的一处细节处理
6.完善装备对比的相关细节
7.完善人物物攻击和被攻击掉血前触发

本版登录器与引擎需配套使用！！！
0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-10-22更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe、LoginSrv.exe、合区工具、PAK批量转换工具
1.Bugfix
2.扩展MoveMapMonToPos命令（详见文档）
3.增加调整宝宝、分身、宠物攻击人物威力值命令以及获取值得命令
4.增加怪物爆率透视命令
5.增加修改指定账号的注册信息命令
6.优化其他几处细节处理

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-10-05更新:】
本次更新文件：M2Server.exe
1.修正分身的一处报错
2.修正50级以下怪物遭遇魔法攻击对怪物攻击无减缓作用
3.修正脚本命令召唤分身多出后缀的问题

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-10-01更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe、DBServer.exe、GameCenter.exe
1.修正法师内置挂机使用灭天火技能会近身物理攻击的问题（单独只有灭天火技能时，不要勾选道法不躲避，不然技能未冷却人物傻站着还不如物理攻击）
2.修正聚灵珠经验保留对英雄无效的问题
3.同步内挂拾取选项细节化，人物和英雄同步均在列表信息2-内挂捡取开启，宠物依然在宠物设置内开启
4.itemshow扩展参数支持首饰发光特效
5.扩展RecallSelf 、RecallMob 、RecallMobEx命令（详见文档说明）
6.增加命令修改宝宝身体颜色命令
7.增加修改地图怪物名称命令
8.攻击触发支持分身检测类型
9.部分命令扩展支持分身多级运用FS.
10.增加改变怪物脸型（外观）命令
11.增加人物宝宝数量和人物分身数量的变量
12.增加获取地图上分身数量命令
13.增加调整分身攻击人物的威力倍率
14.增加分身攻击和被攻击触发
15.引擎-选项-怪物设置-物品掉落规则修改完善细节
16.增加禁止物品掉落命令
17.增加怪物掉落/爆出物品命令
18.增加修改当前伤害血量命令
19.增加从文本里随机获取一组不同行的字符命令
20.增加获取一组不相同的随机数的命令
21.增加穿戴和脱装备统一触发命令
22.增加人物释放技能前自身触发命令
23.增加获取地图人数命令
24.扩展GOTOLABEL 命令，模式=8 模式触发指定范围
25.扩展CheckHpPer、CheckMpPer、AddHpPer、AddMPPer 支持千分比
26.增加AddHpPerEx、AddMPPerEx当前HP百分比加减HP\MP
27.完善StdMode=31且Shape=50/51的物品对叠加的支持
28.DelLinkItem扩展参数支持叠加物品
29.宝宝叛变命令GETCALLMOB扩展支持分身
30.增加移动指定地图坐标的怪物到新的地图位置命令
31.增加获取当前攻击目标的全体属性命令
32.增加购买摆摊物品后触发
33.增加宝箱获取物品触发
34.优化其他几处细节处理

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-09-18更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe、DBServer.exe、合区工具.exe、数据管理工具.exe、RunGate.exe
1.自定义技能增加破防御，破魔御，破魔法盾设置
2.增加物品标识功能
3.分身召唤命令时间单位由分钟修改为秒
4.增加被怪物攻击伤害吸收命令
5.增加百分比防秒杀命令
6.刷怪文件增加扩展刷新怪物触发QF字段
7.自定义技能数量扩展至300个（RunGate.exe和DBServer.exe需同步更新）
8.优化其他几处细节处理

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-09-13更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe、DBServer.exe、合区工具.exe、数据管理工具.exe
1.修正怪物仇恨的一处错误
2.增加英雄杀怪触发独立选项
3.增加英雄暴击和致命一击触发
4.增加英雄战斗力计算变量
5.ReleaseMagic, ReleaseMagicEx支持英雄 H.ReleaseMagic H.ReleaseMagicEx
6.扩展POWERRATE 支持独立调整对人物和怪物的威力倍数
7.优化其他几处细节处理

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-09-10更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe、GameCenter.exe
1.怪物数据库：Monster表，新增字段：DisableSimpleActor禁止怪物简装（默认值0），当值为0时，怪物支持简装显示；为1时不支持内挂中怪物简装
2.无极真气增加3级后威力调整
3.分身继承攻击加速、魔法加速和真视秘籍获取经验修改
4.当关闭英雄忠诚度触发技能时，忠诚度低于100不再触发技能降级
5.浑水摸鱼增加隐藏称号参数
6.优化其他几处细节

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-09-09更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe、微端网关
1.关联控制连击动作隐藏发型 即 DB expand5 设置为1 使用连击动作时(包括自定义技能中的自定义动作)则不显示发型 设置为0 则显示发型
2.分身继承角色元素属性
3.StdMode=31，支持叠加的计时物品 Need=103/Need=104，设置爆一个时，会爆出多个问题解决（红包：StdMode=31 DuraMax=99 Need=104 NeedLevel=10080，OverLap=2； 爆率：1/1 红包）
4.修改致命一击对怪物有效（修改前只对人物英雄有效，对怪物无效）
5.KillMapMon 增加参数7，是否清尸体
6.微端网关支持域名解析
7.优化其他几处细节

0815之前引擎更新到本版注意：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-08-24更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe
1.增加获取和设置技能快捷键命令
2.增加人物变身怪物命令
3.优化其它几处细节处理

0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-08-18更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe
1.优化了NPC相关
2.优化了登录器相关

注：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-08-15更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe、Dbserer.exe、合区工具.exe、数据管理工具.exe
1.修正内挂挂机红药用完保护无效的问题
2.修正宠物系统已知的BUG
3.修正微端重连的一处细节处理
4.修正套装技能百分比单独修改后不能点击保存的问题
5.完善宠物相关并增加相关操作命令以及QF触发（详细参阅宠物文档）
6.配置器支持自定义属性值文字（配置器目录介绍：属性自定义显示详解.docx）
7.增加47类物品（详细参阅文档）
8.增加删除文本指定行
9.增加宝宝、宠物多级脚本应用
10.增加攻击加速总和（装备+脚本）变量：<$AttackSpeed>
11.自定义属性支持自定义位置
12.完善并优化其他几处细节处理和参数设置以及脚本命令相关
13.修正其他几处细节问题

注：由于装备提示文字显示发生了变更，如果你使用了自定义文字，可以将配置器下面的 ItemHintText.ini 删除，让装备提示文字还原成默认值后再修改
0501之前引擎更新到本版注意查阅0501版本号文档中更新日志

【2020-08-05更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe、UpdateServer.exe
1.修正战斗力计算输入值的一处错误
2.修正摆摊期间取回物品的一处逻辑错误
3.修正物品规则将首饰盒、神佑物品设置为英雄物品后角色依然可以佩戴的问题
4.修正回收装备获取泡点客户端不刷新显示的问题
5.修正配置器自定义属性名字繁体字的一处错误
6.修正自定义属性名称后ASK悬浮框的属性值会靠左显示的问题
7.修改血条图层的一处细节
8.浑水摸鱼增加脚本命令并在期间修改为隐藏斗笠
9.优化微端相关细节（需更新微端程序）

注：0501之前引擎更新到最新注意查阅0501版本号文档中更新日志

【2020-08-01更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe
1.屏幕震动脚本扩展参数是否受内挂“屏幕震动”选项控制
2.增加对非法修改登录器游戏速度参数检测

注：0501之前引擎更新到最新注意查阅0501版本号文档中更新日志

【2020-07-31更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe
1.修正回收英雄正在使用的称号后属性还在的问题
2.修正登录器选择角色界面的一处细节处理问题
3.修正脚本播放声音微端不更新的问题
4.修正ChangeState解除禁锢无效问题
5.修正角色交易系统查看他人仓库无法翻页的问题
6.增加替换行会掌门人命令
7.修改技能替换ConvertSkill 命令与addskill一样学习后默认开启技能

注：0501之前引擎更新到最新注意查阅0501版本号文档中更新日志

【2020-07-25更新:】
本次更新文件：MakeGameLogin.exe、M2Server.exe、GuiEdit.dll
1.修正诱惑之光技能的一处细节处理
2.修正自定义技能减准确、敏捷、躲避无效的问题
3.修正手动半月弯刀内挂不能隔位刺杀问题
4.自定义UI增加连击快捷键图标设定
5.其他细节优化
注：本版涉及更新GuiEdit.dll，另0501之前引擎更新到最新注意查阅0501版本号文档中更新日志

【2020-07-22更新:】
本次更新文件：MakeGameLogin.exe
1.修正登录器加载素材的一处细节处理，部分不达标素材载入可能导致游戏画面出现白块、以及无响应的问题

【2020-07-15更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正极品装备在地面时候的特效坐标计算的问题
2.修正自定义技能在无模式状态下的一处问题
3.AddDlg对话框内使用倒计时增加可执行COUNTDOWN倒计时的触发
4.完善ADDdlg、ADDdlgEx的一处细节处理
5.自定义按钮的几个命令均增加支持神佑和首饰盒位置
6.扩展刷怪文件MonGen.txt 支持QF触发
7.默认血条支持可替换
8.大血条支持多血管模式
9.优化并完善其他几处细节

【2020-07-11更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修改镜像副本地图可获取剩余时间
2.完善自定义技能和自定义怪物几处细节
3.增加英雄忠诚度变量
4.怪物大血条支持血管显示
5.修复已知BUG

【2020-07-08更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UI升级工具.exe
1.修正劈星斩的伤害计算的一处细节处理
2.修正穿戴和脱下装备触发的一处问题
3.修正预留自定义技能名称UI内挂界面编辑后不保存的问题
4.修正英雄称号栏不能添加自定义按钮
5.内挂挂机道法修改为不主动攻击石化怪物
6.忠诚度触发4级技能取消魔法盾
7.增加内挂-物品增加极品装备在地面特效（配置器上编辑特效）
8.属性计算LockUpdateAbil、UpdateAbil使用这2条命令配合可以非常显著的提高脚本效率！
9.拍卖行物品数据库Overlap字段为2、4 分类到特殊物品栏
10.扩展一键回收支持装备名颜色检测
11.增加给自己播放地图魔法特效命令
12.优化引擎数据发送数据
13.完善其他几处细节处理

【2020-06-28更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、GameCenter.exe
1.修正角色死亡掉落物品和UPGRADEITEMEX破碎不会触发取下装备的问题
2.火龙之心修改为0持久不消失
3.怪物名称显示可探索，可在配置器上设置为图片显示(需更新控制器扩展怪物DB数据库)
4.增加CheckCacheContainsTextList 和GetCacheRandomText 同CheckContainsTextList和GetRandomText用法一致，更为高效
5.SuperMoveMsg、SendNewLineMsg、SENDDELAYMSG、SendCenterMsg命令扩展支持X坐标设置
6.优化npc执行脚本和部分命令
7.登录器内嵌链接改为默认浏览器访问

【2020-06-20更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、GameCenter.exe、LoginGate
1.修正自定义OK框删除物品数量大于实际数量不会删除的问题
2.修正称号和首饰盒物品备注使用PlayImg，他人查看为静止状态的问题
3.扩展31类物品支持关联操作
3.宠物相关操作命令增加和细节完善
4.增加字符检测命令GetStringPosEX
5.增加封一键多技能功能(功能设置-技能魔法-技能参数)
6.新诅咒术到时间聊天框增加提示信息
7.神圣战甲术和幽灵盾强化技能威力倍数修改为防御和魔御提升（原为时间提升，如您的服务端有使用到这2个技能强化，更新时需注意您服务端该技能强化参数设置）
8.扩展新爆率格式支持多变量检测和OR模式 并支持QF触发
9.M2插件API相关细节完善，引擎插件开发交流群：373336344
10.引擎多处细节优化
注：本版设计UI升级，请使用升级工具升级UI，另0501之前引擎更新到最新注意查阅0501版本号文档中更新日志

【2020-06-11更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginSrv.exe、DBServer.exe
1.修正暴击触发的是致命一击字段
2.修正非连击界面英雄技能开关点击图标显示错误
3.修正AddDlg AddDlgEx 属性栏状态栏的图层问题
4.修正英雄技能设置自定义技能后英雄使用的一处问题
5.修正自定义技能的一处细节错误
6.修正聚灵珠显示信息缺少半个刮号的问题
7.修正控制器"定时启动"选项与“控制器启动后自动启动服务端”选项冲突的问题
8.修正天关宝宝和人物宠物的一处错误
9.修正登陆网关版本号验证的一处问题
10.修正初始化等级属性提示死循环的问题
11.修正心灵召唤间隔的一处判断问题
12.修正自定义怪物抓人无视人物等级问题
13.修正配置器自定义微端状态位置不保存的问题
14.修正AddArrButton和SetArrBuff 自动排列按钮执行脚本可能出现死循环的问题
15.修正引擎重新加载离线挂机人物的一处问题
16.自定义UI中装备栏宠物、神佑、首饰盒按钮支持鼠标提示信息
17.优化月灵相关

【2020-05-29更新:】
本次更新文件：MakeGameLogin.exe
1.修正微端更新地图偶尔存在黑块滴问题

【2020-05-23更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、Wzl编辑器
1.修正WZL编辑器的一处细节问题导致部分机器无法导入的问题
2.自定义技能配置项增加安全区禁止使用选项
3.WZL编辑器支持多选图片批量调整素材左边

【2020-05-21更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正自定义UI聊天框后，滚动条鼠标不能滑动聊天框内容的问题
2.修正微端更新的一处细节问题
3.优化其他几处细节

【2020-05-19更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、Wzl编辑器
1.修正优化NPC解析导致NPC顶戴不支持滴问题
2.修正MONGENEX怪物名字颜色为空时名称是黑色的问题
3.修正勾选“持久为0时消失”魔血石类物品持久为0不消失的问题
4.修正内挂自定义默认BOSS名不支持默认内挂的问题
5.修正releasemagicex命令触发自定义开关技能的一处问题
6.修正噬血术和死亡之眼技能伤害偶尔异常的问题
7.WZL编辑器批量导入导出支持自动格式
8.AddDlg,AddDlgEx增加详细属性位置,宠物界面位置
9.POWERRATE 和 KILLMONEXPRATE扩展参数不显示提示信息

【2020-05-18更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正ReleaseMagicEx触发的技能声音问题
2.修正自定义技能减防御无效问题
3.修正SendCenterMsg一处细节问题
4.修正人形怪挖取物品的一处报错
5.优化自定义战士技能（部分战士技能可能需要重做）
6.日志记录增加叠加物品减少和增加日志
7.优化引擎脚本解析相关提升流畅度

【2020-05-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、UI升级
1.修正脚本命令修改装备幸运值的一处细节
5.修正地图参数浑水摸鱼时英雄的一处细节处理
2.英雄取名禁用字符修改为共享DBserver中角色名禁用字符过滤
3.增加脚本命令ReleaseMagicEx ，参数同 ReleaseMagic，释放技能不改变自身动作（不支持默认就绑定自身动作的技能）
4.修改自定义战士技能多处细节，并增加自动使用自定义技能选项开关
6.引擎控制台增加是否显示CHANGEPERMISSION修改角色权限日志
7.修正其他几处细节问题

【2020-05-01-1更新:】
本次更新文件：Wzl编辑器.exe、Pak资源批量优化工具.exe、GuiEdit.dll
1.修正WZL导入的一处细节错误
2.修正Pak批量优化工具的一处问题
3.修正配置器打开新Pak的一处问题

【2020-05-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、Wzl编辑器.exe、微端程序、UI升级工具.exe、Pak批量转换工具.exe、Pak资源批量优化工具.exe
1.修正引擎因设计扩展功能限制的Key逻辑，导致无Key文件人数被限制的问题
2.修正网关消息过滤触发无效的问题
3.修正PAK批量优化工具不能优化空白图片问题
4.修正自定义技能几处细节问题
5.修正内挂自定义药品相关细节
6.mongenex 名字颜色支持变量
7.自定义UI按钮提示文字支持绝大多数按钮，支持\换行，支持自定义颜色
8.MAXHP MAXMP支持战斗力计算
9.背包检测CheckItem 物品名 ，修改为不带数量为检测数量1
10.增加致命一击打出触发
11.内挂物品增加编辑模式可复制粘贴
12.配置器增加默认自定义保护使用物品设置
13.配置器增加默认自定义的内挂BOSS名设置
14.配置器UI界面-其他坐标 增加微端状态自定义默认位置
15.默认内挂保护项增加自定义物品设置
16.更新登录器优化游戏加载流畅度
17.更新微端程序 优化微端更新相关
18.优化其他几处细节处理
因为更新需要，本版更新需使用PAK批量转换工具转换PAK文件，不转换的情况下微端更新巨卡（转换后请修改自定义补丁文件夹名字，防止客户端新老PAK混合,改名的目的是为了让玩家需重新更新补丁）老的WZL编辑器无法打开新的Pak文件，请同步更新WZL编辑器和微端程序

提示：不是非常大的带宽做微端，建议配置器上线程数设置1或者2，带宽大则可以设置6或以上，线程越多，单用户连接微端连接数量越多，更新速度越快！前提带宽得充足，不然带宽跑满后服务器远程进入都困难

******本地制作版本转换好补丁后，删除原Resources中的PAK文件，使用最新格式的PAK文件******

开区中，转换为最新格式PAK文件后：
1.配置器上更换Resources文件夹名称，不要和老PAK一样的文件夹名
2.将转换后的新PAK文件放入新的Resources自定义文件夹中
3.配置器读取规则配置文本中修改文件路径或者读取规则重新读取
4.微端服务器同步更新Resources文件夹的名称和新的PAK文件
******5.然后使用最新登录器让玩家重新微端更新新的PAK文件，不要让新登录器加载老的PAK ，老登录器也无法识别新的PAK文件，需要登录器和微端同步更新******

部分重复名称PAK 需要手动输入密码
也就是
Graphics内的
Human\1001.Pak
Weapon\1001.Pak
这种他只载入第一个1001.PAK的密码 ，第二个也是输入的第一个的密码·如果第二个密码不一样则需要手动输入

【2020-04-05更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginSrv.exe、远程账号管理工具.exe
1.修正PlayImg上版改动引起的几处细节问题
2.修改角色范围自动拾取禁止捡ThrowItem放置物品
3.修改英雄和宠物当勾选只捡怪物爆出物品后不再捡ThrowItem防止物品
4.账号服务器和远程账号管理工具更新增加空连接和超时处理，防止连接数10个满载后无法连接

【2020-03-31更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正登录器一处细节处理问题
2.修复宠物的一处细节处理错误
3.修正字母技能快捷键拖出的一处问题
4.完善人物地面范围捡物几处细节
5.修正其他几处细节问题

【2020-03-28更新:】
本次更新文件：全套程序
1.修正衣服特效绘制的一处细节问题
2.修正远程账号管理工具不支持20190715后的引擎问题
3.修正Pak批量优化工具优化素材不会优化空白图的问题
4.修正当宝宝RACE为140时，修改宝宝属性后防御攻击等都无效问题
5.修正宠物不受任何攻击勾选后大刀依然会攻击的问题
6.修正对方佩戴护身戒指，使用魔法攻击对方，对方只掉蓝时qf里的魔法攻击触发不生效的问题
7.修正ScatterMonItem不能爆金币的问题
8.修正自定义UI制作的大背包游戏中打开后，无法打开可视化商店的问题
9.修正隐身术的几处细节处理
10.修正自定义怪物 设置苏醒或石化怪物后，苏醒后瞬间攻击速度快
11.修正开启内挂的怪物简装，M.SetBodyColor改变怪物身体颜色后会让怪物显示出原型
12.修正十步一杀+雷霆剑法会卡刀
13.修正列表信息2特效列表会丢失的问题
14.修正自定义技能设置开关模式或者无模式，按住快捷键不松角色移动存在卡位问题
15.修正配置器上的及时雨界面对于控件隐藏和显示操作的一处bug
16.修正NPC复活命令Setreborn生效后，触发QF的[@NpcRevival]字段 无效
17.修正内挂挂机不会攻击石化怪物
18.修正智能刷怪清理怪物后 游戏中所有怪物变慢的问题
19.修正AddDlg加入到人物状态且包含PlayImg时一处细节处理
20.修正Run网关一处严重问题
21.修正微端相关并解决微端已知问题
22.修正M.SetArrBuff目标人物界面触发的图标会显示到自己的游戏窗口问题
23.修正引擎报处理怪物异常的问题，宠物的相关报错修复
24.修正自定义技能变量释放检测的参数不显示的问题
25.修正及时雨内挂保护特殊药品吃完后会解包普通药品的错误
26.修正GiveMine命令制造的物品M2控制台显示记录，日志服务器也不记录的问题
27.优化行会战角色名称颜色刷新的一处细节处理
28.英雄的设置“人物攻击英雄威力” ，排除掉英雄和英雄宝宝
29.微端服务器增加暗桩触发功能防止通过微端偷素材
30.你离镖车距离太远提示，修改到String.ini中可自定义修改文字
31.自定义UI中新行会的掌门图标 和成员图标 设置为可编辑，在UI中可见
32.护体神盾技能选项中关闭提示信息选项，修改为勾选后一并关闭掉“护体神盾被击破”的提示
33.自定义UI详细属性增加毒物躲避、魔法躲避可编辑
34.左侧组队坐标偏移修改支持可以设置负值，设置后可靠左边显示
35.自定义UI中默认内挂和13周年内挂增加支持修改音量条
36.配置器增加拖出设置有快捷键技能图的标保存到本地内挂配置文件选项(双击拖出图标可关闭)
37.自定义怪物攻击模式增加伤害延时设置
38.远程NPC服务器修改当M2请求不存在的资源时不显示请求日志
39.扩展ChangeDressEffect支持绘制模式
40.恢复账号注册资料变量使用
41.性能参数中刷怪间隔参数修改为可保存
42.增加捡起他人打怪爆出的未到冷却时间物品秒捡命令(可用于空自定义技能触发)
43.增加杀怪爆出的物品角色可范围内拾取命令（需开启英雄或宠物同步内挂选项生效，按照内挂设置捡起）
44.英雄捡物品支持同步内挂捡物设置(内挂物品设置“特殊”为优先捡起，设置“自动拾取”为捡起)
45.宠物捡物品支持同步内挂捡物设置(内挂物品设置“特殊”为优先捡起，设置“自动拾取”为捡起)
46.增加角色打怪爆出物品直接入包命令(内挂物品设置“特殊”为优先入包，设置“自动拾取”为入包，背包满后剩余物品正常爆出)
47.增加角色交易买卖系统
48.优化其他几处细节处理

【2020-02-12更新:】
本次更新文件：M2Server.exe
1.修正火龙守护兽同时发光的问题
2.修正GamePoint 一处细节处理
3.修正引擎启用脚本加密插件后引擎报错
4.修正引擎再Server 2019系统参数设置部分参数修改后点击保存引擎会卡顿几秒问题
5.修正外显时装对勋章(天使翼)特效影响的问题

【2020-01-19更新:】
本次更新文件：MakeGameLogin.exe、LoginGate.exe
1.修正偶尔登录游戏，游戏窗口显示游戏关闭的英文字母
2.修改登录器的细节问题

【2020-01-08更新:】
本次更新文件：MakeGameLogin.exe
1.优化地面物品显示细节
2.优化内挂挂机寻怪、捡物(内挂物品设置"特殊"打完怪后优先捡)
3.其他相关细节优化

【2020-01-02更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正地面物品的几处细节问题
2.修正扩展背包交易的细节处理问题
3.修正主人背包负重满还能捡物品的问题
4.优化几处细节处理

【2019-12-27更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正内挂解包的问题
2.修正魔法技能在物理攻击时长按快捷键偶尔施展2次的问题
3.优化内挂挂机相关
4.优化自定义技能已知的细节问题
5.扩展ChangeItemDura命令
6.扩展ChangeModeEx命令支持12、13
7.增加NPC对话框点击复制文字
8.优化其它几处细节

【2019-12-21更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginGate.exe、UI升级工具
1.修正了上版引擎的一处报错
2.修正了攻城期间飞到攻城区域角色名字颜色显示白色的问题
3.增加内挂控制宝宝简装选项
4.增加数据库设置悬浮框装备背景图
5.登录网关和角色网关更新扩大默认参数值
6.个人商店购买支持回车键确定
7.宝石镶嵌光标支持自定义修改
8.优化了引擎的CPU占用
9.优化了登录器的CPU占用
10.优化了宠物捡物品速度
11.修复了已知其他多处细节问题

【2019-11-26更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.优化客户端地面物品过多 的CPU占用
2.拍卖行、个人商店、摆摊的禁止货币，由原来的隐藏客户端显示改为隐藏显示+引擎关闭此类货币交易
3.修改宠物属性叠加给主人的一处相关细节
4.增加技能快捷键支持单字母
5.自定义技能相关细节完善
6.优化多处细节相关处理
7.丢在叠加物品相关的一处严重BUG
8.修正其它几处已知问题

【2019-11-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UI升级工具.exe
1.修正前几版引擎和登录器因升级内存管理器导致程序内存混乱问题，出各种错误及游戏花黑屏
2.修正地图参数THUNDER(10)和LAVA(10)音爆问题
3.修正十步一杀允许穿越人物会和目标重叠问题
4.修正UI升级工具每次升级后几处选项会重置问题
5.修正<$CurSlaveFullName>不显示完整(含数字)名字问题
6.修改自定义OK框 GiveBoxItem 8~31 细节
7.增加英雄本次获取经验变量为:<$H.GetExp>
8.宠物增加无实体选项 和 受宝宝休息快捷键控制选项
9.宠物相关操作命令增加（详见宠物文档）
10.自定义技能相关扩展优化
11.优化其他几处细节

【2019-10-27更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginGate.exe、DBServer.exe、GameCenter.exe、SelGate.exe、合区工具.exe、数据管理工具.exe
1.修正自定义UI的登录器，进入游戏窗口注册账号TAB的问题
2.修正骰子不流畅的问题
3.修正英雄野蛮冲撞无伤害的问题
4.修正H.ChangeModeEx 10英雄无法被锁定的问题
5.修正自定义技能刺杀类技能隔位能麻痹目标的问题
6.修正自定义UI组队界面中队长名字设置居中显示无效问题
7.修正宝石镶嵌叠加宝石时元素的一处细节问题
8.修正支持宝宝修改属性引起的的细节BUG，如命令召唤的宝宝比技能召唤的宝宝攻击速度快
9.增加宠物捡物品功能选项
10.增加英雄致命一击的三个变量：element21 element22 element23
11.宠物增加设置当前召唤的宠物是否可捡物的命令
12.增加怪物不攻击宠物和宠物不被攻击选项
13.46类物品(宝石)支持叠加
14.扩展自定义UI预留按钮支持他人点击
15.增加获取技能信息命令
16.取下装备触发支持关联物品
17.更新登录网关
18.增加数据库异常错误修复工具
19.优化假人随机登录
20.气血石类支持自定义设置持久比例
21.自定义属性增加支持全身百分比
22.自定义属性增加根据Text变量行数查看全身无绑定属性的合计值
23.修改组队对话框出现时可以正常游戏自由操作（之前角色不可控）
24.增加收回宠物NPC命令:RetakeGamePet
25.地图参数增加禁止召唤宠物,已有宠物自动收回
26.优化英雄捡物品和修复修正英雄优先捡取物品无效
27.修改其他几处细节

【2019-10-12更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正游戏注册界面TAB换行的一处细节错误
2.修正技能替换后出现MISS，需小退恢复正常的问题
3.装备对比已装备修改为图片显示
4.ChangeHumAbility 和 ChangeHumAbilityex支持修改自身属性
5.修改诱惑之光和招魂术宝宝数量计算RECALLMOB命令给的宝宝
6.扩展ChangeModeEx支持护身属性
7.扩展ChangeState 支持禁锢自己
8.镶嵌成功后触发BagUseStoneItemOK支持物品关联LinkPickupItem
9.去掉原有的修改怪物属性命令，更换新的命令支持
10.内功药品和百分比药品吃药间隔纳入特殊药品时间限制
11.DUMMYLOGON 支持随机登录假人
12.宝宝攻击触发增加检测宝宝完整名称变量：<$CurSlaveFullName>
13.优化其他几处小细节

【2019-10-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UpdateServer.exe
1.修正RandomKillMon 杀死怪物无法实时执行
2.更新微端程序支持单个客户端多开程序
3.Getplayinfo应用（以前加的也许个别不支持）
4.假人支持穿戴触发和套装触发特效
5.RangeHarm、RangeHarmEx附加伤害支持暴击、忽视等元素
6.RangeHarm、RangeHarmEx支持伤害类型参数设置
7.扩展take 支持关键词收回物品
take 物品 数量 是否检测装备改名（0或空：不检测，1：检测） 物品名匹配方式(0或空：完整匹配，1：部分匹配）
#act
TAKE 灵石 2 1
SendMsg 5 你销毁了2个带有灵石文字的装备
8.修正并优化几处细节问题

【2019-09-28更新:】
本次更新文件：M2Server.exe、DBServer.exe、MakeGameLogin.exe、LoginGate.exe、GameCenter.exe、管理工具、LoginSrv.exe、SelGate.exe、ScriptServer.exe、Tcp列表服务器.exe、合区工具、数据管理工具
1.修正技能CD减少命令对开天斩的一处细节处理问题
2.登录器注册增加验证码功能
3.死亡触发增加检测是否被NPC命令杀死
4.调整宝宝属性命令ChangeSlaveAbility 支持单独调整移动速度
5.增加修改佩戴装备触发指定技能命令，用于修改物品的 Expand3 Expand4值，主要用于实时修改佩戴装备触发指定技能功能
6.内挂的血量单位支持怪物
7.远程NPC服务器程序增加设置指定IP请求更新项，M2上增加是否保存用户名
8.TCP列表服务器程序增加显示连接日志
9.重写角色网关，解决个别机器出现角色网关无响应问题
10.修复其他几处细节处理
全套更新，本版更新程序较多并涉及自定义UI，升级工具与配置器同目录

【2019-09-22更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginGate.exe、合区工具、管理工具、Dbserver.exe
1.修正默认内挂显示页游小地图雷达的一处细节问题
2.修正英雄雷霆剑法的CD的一处错误
3.修正物品备注特效在装备对比界面会偏移问题
4.修正宠物的升级经验和背包物品的细节问题
5.将倍攻、经验倍数、爆率倍数恢复默认后聊天框提示文字支持String.ini修改
6.扩展ChangeHumAbilityEX、ChangeHumAbility 参数23调整内力值上限
7.修改RECALLMOB 召唤宝宝不受M2技能召唤宝宝数量控制
8.屏蔽扫号器脱机扫号，更新登录协议，本次需登录器和LoginGate.exe同步更新
9.更新假人支持位置30-35 40-41的装备
10.扩展有冷却时间的自定义技能，失败提示空则技能图标转圈，有文字（请在%d秒后使用该技能）则显示剩余CD时间
11.修正其他几处小细节

【2019-09-18更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UI升级工具
1.修正DB衣服外观特效时，当衣服是计时装备到期后特效还在的问题
2.修正自定义UI背包货币名称变量不同步引擎自定义设置的问题
3.修正免SHIFT时鼠标左键攻击目标存在几率性停止问题
4.修正<$PKPOWER> <$StruckHP> 远程魔法攻击不赋值的问题
5.修正ChangeHumAbility 属性(1-22) ChangeHumAbilityEX 属性(1-22) ，属性22 时无法正常在人物内功属性栏显示增加的数值
6.修正英雄经验设置1000级后固定经验无效的问题
7.修正假人随机登录选项无效问题
8.攻击触发、魔法攻击触发、被攻击触发修改为造成伤害才触发，解决部分技能没造成伤害也会触发问题
9.控制器-配置向导加长服务器名称显示
10.英雄增加烈火近身参数设置
11.连击启动、获取经验文字String.ini自定义修改
12.优化其他几处细节

【2019-09-09更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UI升级工具
1.修正技能替换后ConvertSkill无法实时生效的问题
2.修正自定义技能自身魔法出现动作缓慢
3.修正自定义技能一处细节(提示：若登录器集成自定义技能，请重新生成自定义技能集成文件)
4.修正人形怪对英雄没仇恨的问题
5.自定义UI预留按钮支持内功位置
6.String.ini 增加自定义修改内力不足释放技能提示文字
7.拍卖行增加货币分类和价格区间搜索
8.自定义技能增加内功值释放选项
9.增加宠物学习技能时触发QF
10.修改攻城期间攻城区域内排除GM
11.扩展修改怪物属性支持地图坐标范围
12.道士人形怪支持DB新技能
13.修改背包货币显示多数设置转移到自定义UI （支持UI屏蔽货币名称）
14.修改<$PKPOWER>miss,不掉血就得刷新为0(提示：NPC变量测试，勿用攻击触发测试，因为攻击触发有伤害才会触发)
15.优化其他几处细节
本版更涉及自定义UI，升级工具与配置器同目录，升级文件选择配置器目录的NEWUI文件夹

【2019-08-31更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UI升级工具
1.修正丢弃金币的一处逻辑错误引起的金币被刷BUG
2.修正逐日剑法近身破防破盾无效
3.修正自定义UI的任务界面标签修改无效
4.修正英雄切换地图后等级显示错误的问题
5.修正自定义UI内功界面标题修改无效问题（UI升级）
6.修正英雄不攻击大血条怪物的问题
7.修正自动寻路遇到障碍后停止的问题
8.修正上一般解决攻击速度快时第一刀有点停顿引起的物品丢弃角色会走一步问题
9.修正元素防全毒和套装属性防全毒会防御十步一杀麻痹的问题
10.修改双人骑马时屏蔽被邀请人称号
11.扩展自定义OK框支持32个
12.增加修改怪物属性命令
13.增加减少技能冷却时间命令
14.NPC标签带参数使用方式注意事项
15.扩展自定义UI中预留按钮触发支持神佑和首饰盒
16.优化多处拍卖行细节处理 并 支持限价设置，和修改拍卖行上架数量限制为：已经上架 + 正在拍卖中 + 流拍
17.优化其他几处细节
本版更涉及自定义UI，升级工具与配置器同目录

【2019-08-19更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正投保信息文字颜色控制无效问题
2.修正攻击速度快的时候SHIFT出刀的一处问题
3.修正GOTOLABEL模式6的一处错误
4.修正页游小地图关闭时，M地图传送后小地图关闭后的按钮消失问题

【2019-08-17更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正技能备注不显示的问题
2.增加头盔位置可在自定义UI调整,无需修改素材坐标偏移 （M2-客户端控制-装备信息 开启）
3.增加极品属性项全绿显示（M2-客户端控制-装备信息 ）
4.技能备注修改为图标右下显示
5.怪物等级鼠标指向提示 和一直显示 修改为不需要攻击即可显示
6.优化其他几处细节

【2019-08-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正打开小地图时候设置技能存在延迟或设置不上的问题
2.修正查看别人称号显示详细信息的一处错误
3.优化攻击伤害延迟 （客户端设置--内挂控制--速度控制 ： 进度条调整开始到结束动作来决定伤害提前或延时，按自己游戏速度适当调节，一般在-100和 +100之间）
4.技能参数页面增加人物四级技能威力设置
5.技能参数页面增加允许同时召唤神兽和圣兽
6.修改诱惑之光和招魂术共享宝宝计数
7.招魂术增加禁止召唤不死系怪物选项
8.悬浮框宽度修改为4面自定义调整
9.增加道士宝宝全局数量限制（限制仅限于控制技能召唤）
10.传统摆摊信息增加背景图（NewopUI.Pak 编号102）

【2019-08-14更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正连击技能的几处参数设置无法保存的问题
2.优化登录器自身封挂导致游戏不流畅问题

【2019-08-11更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正飞行魔法伤害延迟的问题
2.修正四级灵魂火符击中目标特效无爆炸声
3.修正丢弃金币的一处判断异常的BUG
4.修正内挂快捷键自定义输入会多显示一个字母的问题
5.修正页游小地图右键传送会关闭小地图的问题
6.修正召唤的骷髅 攻击会受技能施展影响的问题
7.修改强化盾的参数设置
8.修改连击几处相关细节
9.自定UI悬浮框标题支持普通悬浮框
10.怪物设置内增加自定义50级怪被攻击减缓速度参数设置
11.增加修改内力值 命令
12.增加内力恢复 值药品
13.修改优化其他多处细节

【2019-08-02更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LogDataServer.exe、合区工具.exe、数据管理工具.exe、DBServer.exe、UI升级工具
1.修正护体神盾的细节处理
2.修正禁止穿人穿怪卡位问题
3.修正日志服务器并发大量存入时无响应问题
4.修正360误报线程注入
5.完善自定义UI诸多细节（涉及UI升级工具）
6.增加切换地图QF触发 脚本
7.增加背包负重调整命令及变量
8.PLAYSOUND playsoundExt 播放次数设置为0为不限次数
9.checkitem增加参数4(是否检测改名的装备0：否; 1: 是）
10.提示窗口(装备属性悬浮框)增加边框宽度修改
11.战斗力计算增加幸运/诅咒
12.更改英雄图标在NewopUI.Pak内位置
13.优化其他几处细节处理

【2019-07-23更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UI升级工具
1.修正ChangeSlaveAbility对宝宝加攻速后到时间不恢复问题
2.修正宝石镶嵌控制的细节问题
3.修正登录验证码无法在UI内调整坐标问题
4.修正自定义UI启用边框自适应方式的一处问题
5.修正治愈术、群疗技能的客户端设置界面相关参数无效
6.摆摊期间自动屏蔽摆摊角色血条、封号、顶戴、称号等信息
7.乾坤大挪移增加禁止飞装备选项
8.ChangeHumAbility 和 ChangeHumAbilityEx 增加属性22内功伤害+
9.M2扩展设置增加禁止怪物攻击英雄 、禁止英雄攻击怪物选项
10.addbutton、addArrButton、addNumberButton增加位置21：详细属性位置22：宠物界面
11.背包扩展修改为UI调整背包单页数量适用于大背包，可将其他页面的物品在第一页显示
12.优化其他几处细节

【2019-07-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正首饰发光新增扩展内观特效与衣服武器冲突问题
2.装备基础属性名称可自定义修改
3.增加NPC开启和关闭外显时装

【2019-07-15更新:】
本次更新文件：全套程序
1.修正获取怪物源数据库属性无法获取自定义扩展字段数据
2.修正自定义技能持续播放自身特效切换无法看到他人持续特效的问题
3.修正H.ChangeModeEx 模式(2隐身) 英雄隐身主人也看不到的问题
4.修正可视化仓库翻页会关闭NPC对话框的问题
5.修正刺杀隔位攻击 <$PKPOWER> 不会赋值 ，会延用上次攻击变量的问题
6.修正了穿人穿怪攻城区域全部禁止勾选后会产生反弹问题
7.修正自定义怪物帧数播放速度的一处问题
8.修正自定义技能自身播放特效的一处细节问题
9.修正 releasemagic 如果脚本释放技能后人物移动了那么本次释放的技能就没有伤害的问题
10.修正倒计时按钮关闭后依然会触发脚本的问题
11.修正人形怪未配备装备时只有最低攻击的问题
12.修正人形怪不受MP最低伤害限制
13.修正配置器内挂默认选项，默认勾选了血量单位， 进入游戏实际没勾选的问题
14.修正MAPEFFECT播放延时问题
15.修正镜像地图人物BXXX所在地图未找到的问题
16.修正放烟花时候声音难听的问题
17.修正神佑这些新增位置脱下触发时取当前位置不为空处理的问题
18.修正浑水摸鱼 CTRL+R 宝宝锁定人物就显示出了锁定人物名字的问题
19.修正行会战开始，英雄名字不变色。修正行会战结束，人物/英雄名称颜色不还原
20.修正重新加载NPC，镜像地图内的NPC失效
21.修正连续使用物品播放烟花的问题
22.修正人形怪死亡后移位的问题
23.修正DB怪物飞行类攻击怪物无飞行效果
24.修正登录器对输入法兼容的一处问题
25.修正给人物指定爆率文件命令LoadMonItems的新格式爆率支持的一处问题
26.修正CHANGESTATE 禁锢执行脚本角色（自己）也会被禁锢的问题
27.修正最小化窗口久SendNewLineMsg信息疯狂提示的问题
28.修正MAKEPOSION 命令的绿毒伤害，在淡出方式飘血下不会显示飘血
29.修正怪物简装后，带攻击距离的怪物非近身攻击时攻击显示错误
30.修正破护体神盾一处细节错误
31.修正物品规则勾选宝箱提示同时会勾选禁止捡起的问题
32.修正拍卖行个人同时参与竞拍物品数量限制参数设置无效的问题
33.修正切换地图火墙消失选项无效
34.修正INPUTTEXT 这命令输入的大写字母会自动转换为小写
35.修正WZL编辑器部分损坏的补丁文件打开什么也看不到的问题，当损坏后打开增加损坏图片编号提示
36.修正ADDMAPGATE最后一个参数为传送门式样1-5 式样为5时显示传送门为雕像的问题
36.内挂增加自动凝聚技能选项，类似于LEG的开天斩 烈火 逐日 人物在线就凝聚
37.开天斩、逐日剑法支持SHIFT强制释放（去掉人物开天斩轻击，英雄分轻击和重击，增加英雄开天斩技能压制选项）
38.人物、怪物、NPC支持名称坐标偏移调整
39.人物、怪物、NPC支持血条坐标偏移调整
40.增加刺杀、开天、逐日、断空斩破魔法盾参数设置
41.登录网关版本号可在配置器自定义设置（启用后登录器的设置的版本号必须和网关版本号一致）
42.怪物简装、人物简装增加自定义设置
43.内挂战斗选项增加攻击不卡功能选项
44.登陆器增加客服服务按钮
45.扩展首饰发光特效增加headgearEffect3.wzl -- headgearEffect6.wzl 分别对应399-699
46.在线消息页面各选项修改为可保存，无需每次打开都需要重新设置
47.增加新的忽视防御和伤害反弹元素选项
48.英雄支持自定义双击触发物品，主要用于内挂吃药
49.相同属性的镶嵌宝石支持可以叠加镶嵌不占位置
50.物品来源显示增加控制选项
51.仿Hero摆摊修改为支持多货币且摆摊期间可以向摊位放物品
52.冰咆哮、灵魂火符、裂神符增加技能威力调整
53.客户端控制-装备信息增加移动物品时是否显示物品IDX序列号
54.登录器列表支持背景色
55.KillMonExpRate 支持不显示提示文字（String.ini中修改)
KillMonExpRateMsg=
KillMonExpRateForeverMsg=
56.PowerRate 支持不显示提示文字（String.ini中修改)
ChangePowerRateMsg=
ChangePowerRateForeverMsg=
57.悬浮框属性自定义多排显示支持排序
58.星星数量在功能设置中增加单行数量显示设置
59.增加爆怪物物品（免去杀怪过程直接触发爆率文件）
60.扩展自定义属性文字显示到128字符
61.扩展第三方马支持特效（详见说明）
62.扩展物品名称为60字符
63.扩展Changeitemname支持图片（悬浮框）
64.扩展：自定义属性扩展为20个
65.扩展：自定义属性的值扩展为3个
66.扩展：自定义属性绑定显示扩展为80个字符
67.扩展：设置自定义装备文字内容为128个字符
68.修改：自定义属性显示变量$$修改为$$1, $$2, $$3，如果有显示中有变量，请将$$改为$$1（详见自定义属性说明）
69.增加自己被攻击减少的HP变量<$StruckHP>, <$H.StruckHP>
70.增加人物全身星星数量变量:<$UpgradeCount><$H.UpgradeCount>
71.增加TakeBagItemex命令用于回收指定物品数据库IDX物品
72.增加使用数据库IDX回收多个物品，编号之间用|分隔 支持多个连续的物品编号（详见回收说明）
73.扩展优化HumanHP命令操作
74.扩展SetClientBuff 自定义按钮倒计时触发支持到50个
75.扩展 RangeHarm 和RangeHarmEx命令增加参数7参数8参数9参数10参数11参数12参数13参数14参数15
76.扩展AddButton参数9支持换行，支持图片，支持颜色设置
77.增加悬浮框字体支持改变装备名称字体
78.TakeEx、takew、ChangeItemName增加支持全身所有位置装备操作
79.增加清掉地图某范围的怪物命令KillMapMon
80.增加人形怪支持 CTRL+右键查看尸体装备
81.微端单张图片大小限制扩大和小地图图片大小限制扩大
82.增加人物和英雄属性发生变更时触发QF脚本字段@HeroRecalcAbilitys、@RecalcAbilitys(触发严禁修改属性)
83.增加扩展取随机值 非伪随机 命令：RANDOMEX 参数1 参数2
84.配置器增加角色创建框固定位置选项
85.人形怪增加“不攻击模式”
86.添加新对话框命令：AddDlg(可用于主界面任务引导)----详见说明文档
87.J变量可以自己控制（自定义设置时间0-23点）清零时间（参数设置 -- 时间控制 默认每晚24点清零，可自行修改清除时间）
88.增加飘血位置偏移和飘血速度设置
89.增加技能转换命令ConvertSkill 、 H.CONVERTSKILL （详见说明文档）
90.增加清空变量命令ClearVar
91.增加变量<$RecallRemainingTime> 显示延时TIMERECALL还剩多少秒。
92.增加设置技能伤害/防御脚本命令 （详见说明文档）
93.增加获取技能伤害/防御脚本命令（详见说明文档）
94.增加获取地图中某怪物的坐标命令CheckMapMonInfo （详见说明文档）
95.增加获取某地图怪物数量命令GetMapMonCount（详见说明文档）
96.增加获取某地图人物数量命令GetMapHumanCount（详见说明文档）
97.增加分割字符串命令TextSplit 分割符 源字符串 保存变量(只指定第一个，后面的递增）（详见说明文档）
98.增加取字符串长度命令TextLength（详见说明文档）
99.增加获取背包中某物品的数量命令GetBagItemCount（详见说明文档）
100.增加在文件的固定行替换写入内容命令WriteLine（详见说明文档）
101.增加在文件的指定行插入一行内容命令InsertLine（详见说明文档）
102.增加漂血分开模式(自定义UI界面设置)
103.增加按照角色自身MAXHP百分比进行恢复的药品
104.增加当前攻击主目标特效 用于方便区分当前攻击目标（内挂战斗页面+必备补丁特效）
105.星星支持5组动态星星，每组10张图（星星素材自找，配置自定义UI界面设置）
106.增加商铺批量购买数量自定义
107.增加左侧显示组队信息
108.增加自动排列自定义按钮倒计时触发
109.增加NPC对话框内倒计时显示
110.增加小地图中地图可寻路选项
111.增加进入游戏是否默认打开小地图选项
112.增加自定义按钮分组自动排序命令和相关配置( M2--客户端控制)
113.增加打开客户端界面功能
114.增加支持小地图边框
115.增加物品掉落触发
116.增加背包扩展功能
117.增加战斗力计算设置页面
118.增加装备动态对比选项（默认静态，配置器上设置是否动态）
119.增加英雄魔法触发功能
120.增加英雄宝宝攻击触发
121.增加英雄相关操作命令用于捡起触发
122.改进了自定义技能自身特效播放
123.改进了背包显示元宝信息
124.自定义属性增加了参数控制是否隐藏显示
125.远程NPC脚本支持QuestDiary文件夹
126.个人商店名称增加过滤字符设置，包含字符的店铺名字禁止创建！
127.<$PKPOWER> 改为只主目标生效
128.自定义怪物修改为设置DC为物理攻击，SC MC为魔法攻击，怪物攻击触发对应
129.修改SuperMoveMsg和SENDMOVEMSG 字体大小最小支持8，最大支持20
130.修改嘲讽命令可以嘲讽超出怪物视觉范围外怪物来攻击自己
131.修改配置器定时器启动的时间输入规则
132.修改诱惑之光技能对超高等级可诱惑怪物(可修改技能设置中怪物HP)
133.修改SetNewItemValue 属性 1，7，8，10可以超过100
134.修改主人叠加属性给宝宝为下限+上限，叠加的属性随主人属性变化而改变
135.开放拍卖行、可视化商店、掉落规则、自定义安全区
136.完善宠物诸多细节
137.优化其他多处细节
全套更新...自定义UI涉及升级，升级工具与配置器同目录

【2019-02-19更新:】
本次更新文件：M2Server.exe、数据管理工具.EXE、合区工具.EXE
1.修正合区前拍卖数据在合区后无人购买流拍状态下变成拍卖成功问题(本问题需更新M2Server.exe)
2.修正合区工具和数据管理工具定义的长度不够，导致人物名称被截断，拍卖的数据绑不到人的身上，导致合区后拍卖物品丢失问题(需更新使用最新合区或最新管理工具查看)
3.优化个人商店相关操作处理
4.M2的sqlite数据库的驱动升级到最新官方版

【2019-02-01更新:】
本次更新文件：M2Server.exe
1.扩展check命令支持批量检测标识
2.扩展动态创建一个镜像地图AddMirrorMap命令增加参数9人物退出时返回的地图编号，准确坐标(X.Y)
3.增加取下镶嵌宝石命令ItemoffStone 装备位置 孔位置（1-8）

【2019-01-31更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、SelGate.exe、合区工具.exe、数据管理工具.exe
1.修正在勾选装备持久为0消失选项的前提下Stdmode为53的装备，当持久变为零时，受到怪物攻击后，该装备会消失。
2.修正自定义技能暴击BUG
3.修正自定义怪物攻击方式和增加自定义怪物攻击距离选项
4.修正武器诅咒和脚本加幸运不能互相抵消的问题
5.修正英雄死亡不爆身上物品的问题
6.优化获取HTTP列表
7.修改角色网关的特殊防御默认为关闭状态
8.增加英雄复活剩余时间变量：<$H.RevivalTime>
10.扩展检查字符串命令CheckTextList是否在指定文件中,支持绝对路径，具体搜索说明文件
11.配置器增加关闭登录器自动更新功能选项
12.增加增加百分比计算命令
13.增加增加替换字符命令

【2019-01-26更新:】
本次更新文件：M2Server.exe
1.修正[Exception] TUserEngine::ProcessHumans 错误

【2019-01-20更新:】
本次更新文件：M2Server.exe
1.修正叠加物品被刷的BUG
2.修正 [Exception] TPlayObject::Run -> Operate 1 Code=1005 错误

【2018-12-22更新:】
本次更新文件：M2Server.exe、DBServer.exe、LoginSrv.exe、GameCenter.exe.exe
1.修正引擎一处消息处理死循环一旦触发导致引擎崩溃的BUG
2.修正商铺赠送数量只能一件的问题
3.修改验证码清晰度
4.发布MYSQL数据库测试版

【2018-12-09更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LogDataServer.exe
1.修正日志服务器个别服务器报错的问题
2.修正脚本伤害吸收的几处细节错误
3.修正修正引擎几处细节报错
4.修正其他几处细节问题

【2018-11-18更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、Tcp列表服务器.exe、DBServer.exe
1.优化数据库加载
2.修正英雄排行榜的一处错误
3.修正英雄勾选杀人不加诅咒后导致吃祝福油也不加诅咒的问题
4.同步更新控制器
5.更新并开放TCP列表，本包内含TCP列表服务器（已修复TCP不自动刷新列表）
6.修正其他几处细节错误

【2018-09-28更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UpdateServer.exe
1.修正被禁锢野蛮可以撞出去的问题.
2.修正十步一杀、冰霜群雨、死亡之眼的麻痹属性打自己英雄麻痹时主号会灰名的问题
3.修正GROUPMAPMOVE 组队传送时队长点击后NPC，会只传送队长队员不会传送问题
4.修正月灵释放动作结束后中间会停顿的问题
5.修正客户端设置勾选禁用卷轴保护后修复神水不能自动修理的问题
6.修正佩戴装备触发指定技能，用takeex命令取下装备后技能不会删除的问题
7.修正护体神盾主号和英雄的强化后技能图标错误
8.修正千里传音被怪物持续攻击会掉持久并去掉千里传音内挂持久警告
9.修正极个别电脑多开一段时间小退后进入卡的问题
10.修正前几月优化刷怪引起怪物刷新不受刷怪配置文件时间控制的问题
11.修正物品规则禁止修理的物品依然可以使用战神油和修复油进行修复的问题
12.修正当开启护身蓝条后神佑盒内的护身属性装备不触发护身蓝条的问题
13.修正登录器搜索到客户端后部分网吧系统自动移动登录器失败问题
14.修正复古部分老怪物远程攻击飞行特效丢失的问题，如：半兽勇士
15.修改引擎自定义怪物，自定义技能，自定义NPC列表被选中后颜色
16.修改屏幕上经验提示、技能提示为底层显示
17.修改道道合击噬魂沼泽细节
18.四级魔法盾特效增加LEG模式
19.配置器上增加纯微端模式选项自行设置自定义客户端名称
20.优化切换地图后显示NPC、怪物、角色
21.优化微端更新下载速度相关细节
22.优化其他几处细节

【2018-08-29更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正元宝寄售细节问题。
2.修正GiveOnItem佩戴物品不能触发首饰盒神佑套装属性
3.修正人形怪被麻痹或冰冻后有几率走动的问题
4.修正游戏窗口偶尔无响应的问题(特别是多开的时候)
5.修正游戏窗口个别电脑存在几率性黑屏问题
6.修正地图内怪物被杀死后偶尔存在假象的问题
7.修改内挂持久警告排除25类和7类物品为不提示
8.去掉CTRL+Q停止守护功能，改为只守护，取消守护更改英雄攻击模式即可
9.流星火雨使用间隔增加英雄单独控制CD
10.去掉一些文字提示多余的感叹号
11.增加包裹元宝灵符金刚石千位分割符。
12.增加包裹元宝灵符金刚石可单独控制显示。
13.增加英雄道法不躲避目标，勾选后避免道法英雄拖怪的问题。
14.自定义怪物支持疾光电影类攻击效果
15.引擎包工具文件夹增加PAK批量优化工具，支持坐标的PAK素材建议优化
16.宝宝锁定目标增加禁止锁定人物/英雄
17.自定义技能增加支持开天斩类远距离释放技能
18.死亡之眼增加麻痹几率
全套同步更新。如果登录器是集成自定义技能，则要重新生成配置文件后集成！

【2018-08-10更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正主号月灵有几率攻击英雄的细节。
2.修正在线改名报错的细节
3.修正英雄诱惑之光的细节
4.修正仍物品会触发两次的细节
5.修正自定义怪物自身魔法有几率不播放的细节
6.修正镜像地图报错导致引擎无响应问题
7.优化英雄守护细节
8.优化分身智能
9.优化战士英雄野蛮
10.优化道法英雄智能躲避
11.增加怪物后仰速度控制

【2018-07-17更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正已知多处细节错误
2.优化多处细节处理
3.优化英雄相关
本次更新主以优化为主，本版更新移动速度机制，并改进游戏加速命令相关，更新本版后注意重新调整游戏速度

【2018-07-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UpdateServer.exe、DBServer.exe、LoginSrv.exe、GameCenter.exe
1.修正人形怪的几处细节错误
2.修正英雄自定义技能的几处问题
3.英雄和分身增加支持技能库默认的几个技能
4.修改自定义怪物守护模式
5.优化英雄多处细节
6.优化内挂导入功能
7.修正其他几处已知细节问题
8.完善其他几处已知细节处理

【2018-06-22更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、合区工具.EXE、数据管理工具.EXE、
1.修正物品名字改名后在个人商店出售的一处细节错误
2.修正不能正确获取数据库字段值的一处错误
3.修正设置英雄设置内 设置攻击倍数 对近身刺杀无效问题
4.修正攻击速度为负时属性面板显示错误的问题
5.修改任何攻击模式下都不允许攻击NPC造成伤害
6.修正偶尔合击不恢复怒气的问题
7.修正英雄偶尔打主人宝宝的问题
8.修正主号带宝宝英雄偶尔出现不打怪的问题
9.修正自定义技能加血%控制失效，不管设置 多少，都是按 加100%血 计算的问题
10.修正人物被禁锢时十步一杀可以飞出去的问题
11.修正自定义UI 内挂几处页面缺滚动条 ，和任务界面缺滚动条素材
12.修正小退和大退文字错误的问题
13.修正英雄当前经验显示不同步的问题
14.修正设置近身攻击威力倍数的一处细节问题
15.修正英雄休息时怒气停止增加的问题
16.修正引擎几处报错
17.修正伤害吸收的一处处理细节错误
18.修正引擎一处死循环
19.修正称号系统的一处错误
20.修正投保物品的一处细节错误
21.修正镜像地图已知细节错误
22.修正极个别电脑游戏中移动时三步一小卡的问题
23.优化月灵 分身
24.恢复升级触发
25.去掉背包Ait+r 文字提示，改为整理按钮
26.修改经验值显示顺序为向上滚动
27.引擎-客户端控制-增加是否隐藏背包整理按钮选项
28.优化攻击时内挂自动技能速度不及时的问题
29.优化一些细节处理
30.称号最大数量扩展至60个
31.优化攻击施展技能过于迟钝几率低的问题
32.拍卖行支持多种货币(必备补丁拍卖行相关素材更新)
33.内挂自动合击支持道法合击
34.优化合击操作相关
35.ThrowItem命令 最后的参数叠加物品是否叠加（0或空：叠加；1非叠加）
36.自定义怪物、自定义技能目标效果播放及爆炸效果播放扩展增加特效2
37.自定义UI部分界面增加预留默认自定义按钮
38.优化其他几处细节

【2018-05-19更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、LoginGate.exe、LoginSrv.exe、RunGate.exe、合区工具.exe、数据管理工具.exe
1.修正2003系统下引擎刷怪数量过大时，显示的怪物数量大幅度浮动的问题
2.修正仿页游天关系统奖励叠加物品数量的一处细节问题
3.修正挖肉动作跳帧的问题
4.修正内挂挂机时的几处细节BUG
5.修正引擎的几处报错
6.修正MOBPLACE扩展参数的攻击指定怪物会被人物攻击影响的问题
7.修正自定义怪物作为宝宝时候使用增益效果会给怪物增加属性问题
8.修正日志网关不记录声望增减记录数据的一处问题
9.修正人物改名对伴侣名称显示的一处细节处理
10.修正师徒系统的细节错误
11.修正自定义技能使用调整技能点数的一处细节错误
12.修正技能设置 -- 使用佩戴的符或毒 不会自动佩戴的问题
13.修正地图爆叠加物品入背包的一处细节错误
14.修正假人捡物品期间攻击无效的问题
15.修正当怪物使用新爆率格式会影响传统爆率的问题
16.修正套装显示不勾选装备改名后支持套装属性，套装的一件改名后 佩戴在身上 套装备注上不能正确显示已佩戴装备 (属性是有效的)的问题
17.修正自定义技能的自定义瞬移，瞬移效果在鼠标指向物品、或者地图障碍的时候不播放但是有伤害问题
18.修正HUMANHP - 飘血，当本次脚本减血的值可以让目标死亡的情况下，将不会显示脚本减血的飘血效果
19.修正国战模式退出国家命令ExitNation 国家编号(参数1作废)，退出国家无需参数
20.修正道士宝宝每升一级增加属性参数设置无效问题（启用选项后注意修改数据库默认宝宝：排骨、旺财、月灵的移动和攻击速度）
21.修正M2——管理——无限仓库管理，无法获取玩家无限仓库的问题
22.修正当NPC名字是变量名时重新加载NPC后NPC名字变成变量的问题
23.修正个人商店不支持显示改名装备的问题
24.修正当改名物品ShowItem在掉落物品时候显示名字为数据库名字问题
25.修正releasemagic释放不了断空斩的问题
26.修正ThrowItem 叠加物品爆一地的问题
27.修正内挂手动地狱火默认勾选无效
28.修正<$HITSPD> 没有计算脚本加的攻速
29.修正GM命令开启攻城无法占领的问题
30.修正怪物属性上限属性大于下限属性时攻击伤害异常的问题
31.修正引擎开启10天后离线挂机角色异常的问题
32.修正双倍经验和真视秘籍设置相同时间显示却一样问题
33.优化内挂关于毒符相关以及修复使用佩戴毒符时切换问题
34.优化引擎怪物CPU占用以及优化智能刷怪和地图相关
35.优化内挂自动战士技能释放
36.修改账号服务器登录器验证码为输入验证码成功后才可以输入账号密码并改进验证码算法
37.修改自定义技能和自定义怪物回血比例改为按照最高血量百分比计算
38.修改 ChangeSpeed 攻击加速为叠加
39.修改个人商店出售物品如果超期，由于“禁止存仓”或仓库数量原因无法放到仓库的物品，还在自己的出售列表，并显示过期，但别人购买的时候看不到，也买不了
40.扩展检测宝宝命令参数CHECKSLAVECOUNT 控制符(<.=.>) 数量 怪物名 是否检查名称数字(0:不检查名称数字[骷髅1,骷髅2都按包骷髅算], 1:算数字)
41.增加英雄速度调整命令H.CHANGESPEED
42.登录器找回密码和修改密码支持验证码，更新NewopUI.Pak更新图片编号：435、442
43.增加人物和英雄限时装备到期(到时间)触发
44.雷电/群雷加上威力倍数和群雷范围设置
45.增加获取装备宝石数量命令：GetItemStoneCount 装备位置 宝石名称(不分名称可用 * 或 all） 变量
46.增加获取身上所有装备宝石数量命令：GetItemStoneCount 宝石名称(不分名称可用 * 或 all） 变量
47.扩展SCREENEFFECT最后增加一个参数（0或空，在对话框下怪播放，1：在对话框上层播放
48.配置器自定义UI默认界面增加是否完全自定义UI布置内挂选项（勾选后 M2打开或者关闭内挂功能后 内挂界面文字排版不变）
49.修复了其他几处细节问题
注意：本次更新请全套替换使用，切记！

【2018-04-25更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正了商铺批量购买物品货币价格超过21E溢出的BUG
2.修正了商店出售物品框拿回物品的一处细节错误

【2018-04-12更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正引擎的一处漏洞
2.修正人物死亡、回城可能在原地存在假象的BUG
3.修正引擎几处错误

【2018-04-04更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正上版属性点漏洞的遗漏的一处细节
2.修正近半年来网关反外挂插件加载卡顿和偶尔加载无响应、蓝屏的问题（需更新登录器和多线程网关）
3.优化其他几处问题

【2018-03-21更新:】
本次更新文件：M2Server.exe、LogDataServer.exe
1.日志服务器增加属性分配点\临时属性\永久属性调整导致角色属性变动日志记录
2.引擎修复刷属性点BUG,和刷商铺BUG和个人商店的BUG,以及一处报错

【2018-03-02更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1、修正个人商店判断是否允许使用的一处细节提示问题
2、修正引擎的一处报错
3、修正假人的英雄不支持英雄技能问题
4、优化游戏窗口CPU占用过高的问题
5、修正其它几处细节问题

【2018-02-28更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1、修正自定义技能界面部分功能参数设置被遮挡问题
2、修正挖肉动作出现跳帧的问题
3、修正引擎的一处死锁
4、DELNPC 扩展参数3支持删除指定地图的NPC

【2018-02-13更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、Dbserver.exe、合区工具.EXE、数据管理工具.exe
1、修正关闭可视仓时，仓库不恢复到左边
2、修正劫持导致游戏窗口闪退问题
3、修正自定义技能小退后，客户端技能CD时间与服务器同步
4、修正自定义技能刺杀类第2格无伤害问题
5、修正自定义技能攻杀类会强制关闭自定义刺杀类技能问题
6、修正旧模式（复古）下鼠标移动到背包物品无法看到装备信息问题
7、修正自定义技能飞行魔法的一处细节错误
8、修正DBSERVER设置排行榜过滤名字无效
9、修正聊天输入框鼠标操作的细节问题
10、修正杀怪触发[@KillMon]的细节错误会导致杀人人物也触发怪物的问题
11、修正调整宝宝命令ChangeSlaveLeve无法调整技能召唤的宝宝问题
12、修正自定义技能增益模式的隐身无法消除怪物仇恨的问题
13、修正新版合区的一处错误
14、修正老行会删除成员的一处细节
15、修正合区后英雄忠诚度清空的问题
16、recallmob 增加技能参数7：召唤数量
17、增加NPC命令：endloop中止loopgoto
18、自定义装备属性绑定显示支持值后面加单位（$$代表数值）：如: 自定魔防2: +$$点

【2018-02-08更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、Dbserver.exe、合区工具.EXE、数据管理工具.exe
1.修正数据库特效和自定义特效共存的一处细节
2.修正自定义按钮提示有PlayImg不能持续播放的问题
3.修正最小化或非活动窗口时，背景音乐有声音输出的问题
4.修正自定义技能不支持九重以后强化威力设置
5.修正登录器获取列表的一处细节
6.修正地图参数 PKLOSTLEVEL 无效的问题
7.修正战士自定义技能的熟练度不受数据库等级限制
8.修正BONUSPOINT 减少属性分配点的一处细节问题
9.修正会员等级SETMEMBERLEVEL 不保存问题（因本项更新需要更新DBSERVER.EXE和合区以及数据管理工具）
10.自定义技能增加战士攻杀类技能
11.装备技能威力增加对自定义技能支持
12.自定义技能增加对不死系怪物伤害加成
13.烈火剑法增加支持延时处理参数设置

【2018-02-05更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正英雄自动使用药品，收到伤害没达到设置值依然吃药的问题
2.修正"系统插件.INI" 中脚本加密和远程脚本开关设置反了的问题
3.修正启用远程脚本后关闭引擎时卸载插件报错的问题
4.修正非连击装备栏英雄新增技能不显示图标问题
5.修正部分Win10系统下游戏走路和跑步会停顿的问题
6.修正登录器列表对Https支持的一处细节问题
7.修正登录或切换地图保护参数的一处细节错误可能几率性导致个别玩家出现GM模式

【2018-02-03更新:】
本次更新文件：M2Server.exe、RunGate.exe、MakeGameLogin.exe
1.修正召唤人形怪为宝宝后无法召唤分身的问题
2.修正物品备注PlayImg再装备栏称号位置的一处细节问题
3.修正内挂挂机的一处细节问题
4.增加断空斩技能
5.增加血魄一击技能
6.修正其他几处细节错误
7.关闭引擎插件，必备插件集成到引擎内部，请参阅MIR200目录内“系统插件.INI”进行开关（MIR200目录无需DLL，PlugList.txt也无需设置，清空即可）

【2018-01-26更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正内挂挂机状态下中蜘蛛网的一处细节BUG
2.修正国战模式下人形怪在GM隐身模式下的一处细节BUG
3.修正内挂技能噬血术的一处BUG
4.修正魔法触发火墙的一处细节
5.修正英雄的几处细节
6.修正自定义技能无法触发镶嵌装备特殊属性
7.修正TestStatus取消魔法盾后属性还在问题
8.修正部分服务端沙巴克城墙配置会变成怪物的问题
9.修正CHANGEHUMNAMEFILE角色改名时修改文本无效问题
10.修正配置器上元素颜色设置无法设置目标人物爆率颜色问题
11.修正登录器加载反外挂插件在异常情况下的一处问题
12.CHECKITEMW 物品名 数量 是否装备名部分匹配(空或0，完全匹配。 不等于0部分匹配)
13.配置器增加支持付过模式叠加物品样式显示选项
14.配置器增加shift+左键点击物品发送属性支持不显示关闭按钮，鼠标移走自动关闭！
15.技能数据库中，自定义技能 EffectType = 0 的就是战士技能。自定义技能-基本设置-开关模式 勾选就是战士技能，不勾选就是魔法技能
16.修正其他几处细节

【2018-01-20更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、WZl编辑器.exe
1.修正出师触发无效问题
2.修正施毒术的一处问题
3.修正自定义特效不能和扩展特效共存的问题
4.修正自定义OK返回物品的一处细节处理
5.修正脚本运用的一处细节
6.修正WZL编辑器优化素材时会造成坐标偏移的问题
7.优化多处默认细节
8.扩展自定义属性(无属性)
9.增加内挂英雄状态数字显示
10.NPC字体描边增加选项
11.优化其他多处细节及默认设置

【2018-01-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBserver.exe
1.修正U变量赋值的一处细节问题
2.修正复活时候的一处细节问题导致报错
3.修正聚灵珠获得的经验不支持<$GetExp>
4.修正内挂挂机设置挂机点小地图打开时候在当前地图，随机飞消失的问题
5.修正自定义OK框的细节处理问题
6.修正变量运算的BUG
7.修正镜像地图报错
8.修正拆分物品的一处可能被封包利用的BUG
9.修正GIVEIDX命令给予的物品非编号对应物品
10.修正全体攻击模式下主号攻击宝宝 宝宝会还击的问题
11.修正十三周年自定义UI的几处细节问题
12.修正无极真气会计算套装属性的问题
13.修正铸造物品功能显示缺少材料不完整的问题
14.修正英雄不能佩戴 Need=104，限时物品
15.修正战士幸运值计算问题
16.修正物品快捷栏的一处细节
17.修正自定义技能的一处细节
18.修正登录器在WIN10自带杀毒误报病毒问题
19.修改分身术支持计算首饰盒和神佑的收拾特殊属性（如特戒）
20.修改可诱惑的自定义怪物相关细节
21.修改NPC文字相关去掉描边
22.修改血球位置百分比显示时为精简模式（去掉.00,原：100.00% 现：100%）
23.增加英雄使用自定义技能demo版
24.优化INPUTTEXT支持复制粘贴，并修正当输入状态时候聊天栏不能输入的问题
25.恢复内挂基本里面的自动捡取
26.扩展准确和敏捷支持到65535
27.法师技能魔法设置增加群雷攻击范围和升级范围设置
28.增加检测技能点数命令 CheckTranPoint 技能名称 比较符(<>=) 值
29.增加取指定排行榜指定排名的玩家名字 和 检测人物在指定排行榜中的名次
30.引擎-管理-在线消息增加发送消息后禁止操作选项
31.战士技能十步一杀增加禁止飞装备选项
32.优化英雄的相关细节
33.本版为英雄系统发布正式版，彻底解决影响智商和已知细节问题

【2017-12-21更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、WZL编辑器.exe
1.修正怪物Mon33-6;104;45;323 ，弓箭怪物没有射箭效果
2.修正人形怪超出守护范围不返回问题
3.修正定时器时间不准确的问题
4.修正WZL编辑器的一处细节错误
5.修正假人捡物品的一处错误
6.增加复活剩余时间变量
7.优化其他细节

【2017-12-19更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginSrv.exe、WZL编辑器.exe
1.修正WZL编辑器的一处错误
2.修正修改宝宝属性不支持名称带数字的问题
2.修改元素图标，属性栏改为不显示
3.账号数据库程序增加密码限制选项
4.隐藏封号同时隐藏顶戴花铃修改为不隐藏怪物和NPC的顶戴
5.优化英雄躲避速度
6.增加内功伤害增加、减少变量
7.降低32位微端程序缓存线程进行避免达到程序内存占用峰值
8.修正其他细节问题

【2017-12-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、数据管理工具.exe、合区工具.exe
1.修改英雄安全区内的一处走位细节
2.修改英雄连击的的技能细节
3.修正其他细节
4.修正仿Herom2摆摊的一处错误
5.修正自定义内观特效的一处错误
6.修正自定义技能的几处细节
7.修正组合变量不支持检测的问题
8.修正MISSION刷怪参数8设置名字颜色对人形怪的一处错误
9.修正M2在线人物修改T变量 不能保存问题
10.修正自定义自定义技能“服务器端设置”-“攻击减属性”下面的减攻击，递增项，改成“秒” 无法保存的问题
11.修正打开自定义怪物.攻击模式1 选用增益模式 对魔御和增益范围这栏填入任意数值..重启后后此数值会乱变
12.修正自定义NPC与自定义怪物设置冲突
13.修正无限复活命令Setreborn的算法
14.登录器增加支持HTTPS域名访问
15.优化合区和数据管理工具打开大体积数据库需要很长时间问题
16.优化其他多处细节

【2017-12-08更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、Wzl编辑器.exe
1.修正背包负重的一处细节问题
2.修正战士开了自动技能攻击时，按F1释放自定义技能成功率低
3.修正引擎的一处死锁
4.修正镜像地图宝宝休息的一处BUG
5.修正页游天关命令 SetGuardianLevelInfo的细节问题和其他细节处理
6.修正自定义技能偶尔出现不播放自身特效和不播放飞行效果的问题
7.修正非正常角色名，DBSERVER强制纠错
8.修正英雄攻击走位参数设置1000依然会走位的问题
9.修正角色捡物品的一处细节问题
10.修正战士部分技能在攻击状态时偶尔播放不完整的问题
11.修正站与跑的飘血淡出速度不一致的问题
12.修正WZL编辑器的一处错误导致入个别图片失败
13.修正镜像地图一处细节处理导致报错
14.修正地图参数 DROPITEMADDUSERBAG的一处细节导致报错
15.修改ADDMIRRORMAP，在人物小退后再次进入游戏，返回到参数5设置的地图
16.增加魔血石类恢复HP\MP是否瓢血选项
17.英雄增加扩展参数设置
18.英雄支持多级脚本HM.和HL.
19.增加减少怒气增加间隔命令
20.增加解除英雄强制和平模式限制（当扩展设置强制英雄和平模式时可用）
21.增加英雄几个变量
22.增加麻痹状态禁止传送选项
23.攻城期间攻城区域非沙成员小退回城
24.扩展MOBPLACE命令最后一个参数，为空表示可攻击所有可攻击的对象，指定名字表示只攻击指定名称的可攻击对象
25.完善并修改英雄多处相关细节
26.修正其他几处小问题

【2017-11-26更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、LoginSrv.exe、RunGate.exe、GameCenter.exe、数据管理工具.exe、合区工具.exe
1.修正游戏速度浮动的问题
2.修正噬血术提示语错误
3.修正人形怪配置文件过多时候保存会小卡一下的问题
4.修正连击技能的几处错误
5.修正英雄的几处细节
6.修正自定义UI 详细属性的细节
7.修正个人商店购买物品，物品不显示出处的问题
8.修正SCREENEFFECT停止命令 当播放次数是0或者-1时候报错的问题
9.修正跑步穿地图后的细节
10.扩展了一个 RangeHarmEx支持伤害触发
11.配置器-内挂设置-增加物品全部拾取 默认是否开启选项
12.账号服务器增加账户批量禁用模式（合区工具修改为合区时候默认清理已经禁用的账户）
13.修改DBSERVER 恢复和禁用机制： 角色登录器删除的角色必须使用登录器恢复，如果在DBSERVER上禁用的人物必须在DBSERVER上恢复
14.控制修改配置完毕后实时加载最新配置信息无需重启
15.修正登录器对反外挂插件支持的一处BUG
16.自定义UI增加及时雨内挂自定义编辑（自定义内挂或及时雨UI，一定要重排，不然界面可能很难看）
17.自定义UI增加13周年界面编辑
18.M2-客户端控制-其他控制 增加内挂隐藏称号时是否同时隐藏顶戴花铃选项
19.内挂的背包对比，对比方案改为只对比物品最高属性！
20.自定义UI -内挂-物品-增加可以关闭 传送 特殊 选项
21..WriteConfigFileItem ReadConfigFileItem 增加支持绝对路径，注意使用绝对路径参数必须完整！
22.修正H.PickUpItemEX 不触发问题
23.修正ChangeItemName 1 {绿色的|250}屠龙 类似这种改名地上显示的一处问题
24.SetMirrorMapTime增加参数3 1为重新计算时间 留空则为重新设置的时间减少已使用时间
25.完善其他细节处理
注意：本次更新请全套替换使用，无论您是引擎包网关、专业版、IOCP版游戏网关也必须同步更新，切记！

【2017-10-31更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UpdateServer.exe、LogDataServer.exe
1.修正M2在线管理仓库搜索不存在的角色名字的一处错误
2.修正微端已知问题
3.修正带有封号的角色不能开通个人商店的问题
4.修正组队请求的细节错误
5.修正近身物理攻击目标掉血延时问题
6.修正挑战压元宝的一处错误
7.修正怪物大血条中的归属人会显示宝宝名字的问题
8.优化战士技能：烈火、开天斩、逐日技能客户端响应间隔
9.修正检测人物星星数量，物品位置-2时检测全身，不包含首饰盒的装备星星的问题
10.修正CheckTakeOffItem命令错误。鼠标右键换装备检测不正确，手动拖拽换装备检测也不正确的问题
11.修正分身攻击力的一处错误
12.修正半月弯刀伤害延迟的问题
13.修正人形怪的一处细节处理
14.修正个人商店 出售物品时间限制无效
15.修正合击技能的几处细节问题
16.修改非安全区角色禁止穿越自己的英雄
17.修正英雄使用狮子吼的几处细节错误
18.修正英雄持续开盾的一处问题
19.修正野蛮对目标造成伤害漂血的一处错误
20.修正英雄自动吃药时的几处细节问题
21.修正USEBONUSPOINT的一处细节
21.配置器增加复古登录音乐选项
22.优化完善英雄多处细节
23.内挂-物品 增加全部拾取
24.引擎-功能设置-假人设置增加跑步穿设置
25.引擎-功能设置-英雄设置-扩展设置增加跑步穿设置
26.优化NPC变量相关代码
27..内挂物品增加多选操作
28.扩展 ChangeHumNameFile 文件名 是否绝对路径(1:绝对路径; 0或空：相对路径) 前缀 后缀
29.宝宝攻击触发和魔法攻击触发中获取本次触发的宝宝名称变量<$CurSlaveName>
30.新增扩展NPC点击触发带参数
31.游戏中组队加确认按钮
32.修改race=92的怪的细节
33.修改假人、英雄寻路细节处理
34.引擎在线管理增加个人商店名称管理
35.优化客户端之间延时200毫秒
36.重写日志记录和分析工具，新的日志工具需和引擎配套使用，日志记录更详细
37.修正其他细节问题

【2017-09-30更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UpdateServer.exe
1.修正 GETCALLMOB 无参数叛变所有宝宝报错的问题
2.修正一键回收takebagitem命令 回收叠加物品货币为0的问题
3.修正血量单位显示少一个单位的问题
4.修正自定义技能【自身播放魔法效果】图片数量计算错误
5.修正自定怪物 - 目标播放 【多目标播放】时，多个目标受到攻击但只放一个
6.修正镜像地图倒计时显示后，SetMirrorMapTime修改镜像地图存活时间，不刷新倒计时显示的bug
7.修正正先打开背包，再打开大对话框，大对话框会和背包重叠
8.修正正攻击的角色佩戴护身显示MISS的问题，修改为掉蓝漂血模式
9.修正无极真气计算问题
10.修改自定义采集进度条居顶显示
10.调整技能伤害延迟
11.SAVEVAR HUMAN 支持绝对路径
12.及时雨内挂增加血量单位选项
13.修正完善其他细节问题

【2017-09-19更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UpdateServer.exe、LogDataServer.exe
1.修正微端程序已知问题
2.修正拍卖系统人物改名后的一处BUG
3.修正合区工具人物改名后拍卖数据未同步的问题
4.修正日志查询工具不记录仓库取回物品日志
5.修正隔位刺杀武器不掉持久的问题
6.修正魔法攻击练功师弯腰的问题
7.修正giveidx 命令BUG
8.修正ChangeHumAbility ChangeHumAbilityEX 增加幸运无效问题
9.修正Loopgoto死循环
10.修正足球DB
11.修正技能冷却特定情况无提示问题
12.修正药品多次解包的一处处理问题
13.修正魔法盾强化无效果
14.修正护身装备属性BUG
15.修正外挂关闭数字显血，道士心灵启示无效
16.优化道士人形怪
17.MapQuest.txt功能建议改进支持当地图号为*时表示所有地图
18.淡出绘制模式漂血增加暴击飘血功能选项（M2-客户端控制-功能选项2）
19.祝福罐 类的可用次数 更改为：数量 50/50
20.道士的毒掉得血改为不漂血选项（M2-客户端控制-功能选项2）
21.增加体力恢复、魔法恢复、幸运值、中毒恢复等属性变量
22.支持绝对路径欠了个清空文本内容的
ClearNameList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）
AddNameDateList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）
DelNameDateList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）
23.顶戴花翎命令扩展支持仅自己可见
24.自定义UI 人物加属性点的面板建议增加可以编辑添加人物属性数值那小框框可以设置移动
25.修正IOCP网关地图验证码无法排除镜像地图问题
26.增加内挂选项：血量单位 满10万级别测字母显示
27.SortVarToList、SortHumVarToListEx、GetListString、GetStringPos 支持绝对路径,参数齐全情况下最后个参数1表示绝对路径，留空则默认
28.增加@OnSlaveDie宝宝死亡触发和死的宝宝名字，不去数字：<$DIESLAVENAME>
29.修正其他细节

【2017-09-02更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、UpdateServer.exe
1.修正浑水摸鱼的已知错误
2.完善部分技能升级设置
3.改进微端的一处细节
3.优化其他几处细节

【2017-08-31更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LogDataServer.exe、Wzl编辑器.exe、UpdateServer.exe、MirUpdateGate.exe
1.修正几处细节问题
2.优化日志查询速度
3.WZL编辑器更新换代
4.微端服务器程序更新换代
5.本次更新含UI升级，微端相关等程序，请全套更新！

【2017-07-31更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、Dbserver.exe、合区工具.exe
1.修正国家怪物设置不允许攻击本国，英雄依然可以攻击
2.修正死亡触发的一处错误
3.修正治愈戒指放入首饰盒再拿掉治愈术还在技能栏
4.修正掉落规则清零一处BUG
5.修正英雄会间接伤害友军的问题
7.修正群毒强化无效果
8.修正自定义怪物增益攻击推动的一处错误和自定义怪物瞬移的一处处理问题
9.修正非合击界面打开神佑和首饰盒的时候小退窗口不关闭
10.取消checkmapmove寻路代码，此命令改为专门检测坐标是否可以达到
11.合区工具更新:同名国家不单独命名新国家
12.SETICON 支持素材坐标
13.ChangeSlaveAbility支持人形怪宝宝
14.SetItemShape ,SetItemLooks 支持天使翼
15.增加幸运规则计算和诅咒计算修改
16.地图参数增加 禁止使用拍卖行的参数 NOAUCTION
17.增加了NPC对话框提示文字命令SENDMOVEHINTMSG 信息内容1111\222222222 249 0 10 60
18.增加Npc对话框动态进度条功能ProgressBar(特别注意符号 ／ ,不要写成/ ，/后面是接命令的)
19.elseact后增加支持call脚本
20.修改NewopUI.PAK配置器同目录，启动释放到自定义目录...另外自定义UI文件全部存放到自定义目录data内
21.Dbserver增加导入导出角色数据
22.DELTEXTLIST和GETRANDOMLINETEXT支持绝对路径
23.修正其他多处细节处理

【2017-07-22更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LogDataServer.exe
1.修正装备对比的一处问题
2.修正新行会的一处问题
3.修正拍卖行的一处问题
4.修正配置器NPC对话框文字Y坐标设置为负数不保存的问题
5.内挂增加背包物品对比身上(必备补丁1182)
6.祝福罐可用次数支持旧模式属性显示
7.脚本死循环限制 排除 LOOPGOTO 命令循环
8.摆摊购买物品 选中的物品属性最下面额外显示该物品的售价
9.掉落规则时间控制修改计算方式
10.日志查询工具 NPC给予的物品 单独记录~
11.增加复活命令: Setreborn 参数一（复活次数） 参数二 （有效时间）
12.优化其他细节处理

【2017-07-11更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正一些BUG，优化一些细节
2.拍卖行上架物品修改为默认过滤不显示禁止拍卖物品
3.增加祝福罐（魔族令）DB
4.增加火龙之心填充物 DB
5.增加当前攻击怪物坐标变量 <$ATTACKMONSTER_X> <$ATTACKMONSTER_Y>
6.完善其他细节
7.本版登录器修复搜索客户端的一处BUG会导致即使搜索到客户端也判断没客户端，和特定情况下登录器搜索到客户端会改名的问题（重要）

【2017-07-05更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正了一些BUG、优化了多处细节！

【2017-07-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正了一些BUG、优化了多处细节！

【2017-06-29更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe、数据管理工具.exe
1.修改无需人物先攻击，宝宝攻击即可实现触发多级脚本
2.修改狮子吼范围为官方模式（可自行修改参数）
3.修改无极真气威力倍数为官方模式（可自行修改参数）
4.气血石、魔血石、幻魔石增加仿官方加点选项
5.修改宝宝规则模式为盛大模式
6.M2重新加载数据库(技能、怪物、物品)支持sqlite数据库加载
7.技能设置增加半月弯刀的威力倍数设定
8.客户端控制增加魔法攻击是否角色朝向目标方向选项
9.心灵召唤增加CD时间设置
10.CheckItem扩展参数4，是否检查改名后的名称（0：不检查；1：检查）
11.take 扩展参数3，是否检查改名后的名称（0：不检查；1：检查）
12.MAPEFFECT，DelMAPEFFECT 扩展第11个参数，ID，为空，
13.CheckRangeMonCountEx命令最后扩展一个参数：0：不算宝宝；1：算宝宝
14.扩展DoTaunt命令增加参数二，怪物等级需要小于参数2设置的等级才能被嘲讽。
15.自定义怪物支持魔王岭怪物和宝宝设置并完善魔王岭相关(详见说明)
16.增加装备掉落详细控制（暂未公开）
17.增加天使翼翅膀功能
18.增加获取怪物原始各项参数
19.增加给人物指定爆率文件命令
20.优化道法英雄多处细节处理（本版修复重点）
21.修正并优化其他多处细节

【2017-06-13更新:】
本次更新文件：全套更新
1.修正普通仓库第4页最后一格物品不保存
2.修正giveidx命令报错
3.修正内部地址OpenWebSite无法切换输入法的问题
4.修正第一次掉落触发不可以查看装备属性
5.修正自杀式攻击的自定义怪物攻击宝宝时自杀会对宝宝造成加血效果的bug
6.修正新行会功能不同国家人物可以加入的问题
7.M2物品装备—新增属性增加灵玉类和时装首饰
8.物品、怪物、技能数据库支持Sqlite数据库
9.增加拍卖行功能
10.无限仓库、个人商店、拍卖行数据存储改为保存到Mir200文件夹的M2Data.DB 保存！
注意：本次更新如果您的服务端有使用无线仓库或者个人商店，请使用工具转换数据！

【2017-05-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBserver.exe
1.修正假人相关
2.修正人形怪半月技能相关
3.修改英雄部分细节
4.完善普通可视仓库视觉相关
5.修正并完善其他细节

【2017-05-13更新:】
本次更新文件：全套更新
1.修正套装改名后单列显示情况下提示错误的问题
2.修正ThrowItem坐标为0会偏移一个坐标丢弃物品的问题
3.修正套装备注 在背包时正常显示，放入OK框后套装备注不显示
4.修正登录器游戏内控制声音相关细节
5.修正默认药品支持同时支持物品31类 2类问题
6.修正npc对话框中的2个ItemShow相隔较近时，鼠标从一个移到另一个提示不刷新
7.DBSERVER上允许设置只允许创建一个角色
8.2个内挂自定义快捷键 增加支持英雄状态快捷键设置（装备栏）
9.功能设置增加宝宝无后仰选项
10.增加嘲讽命令： DoTaunt 参数1，比如 DoTaunt 5 可以吸引范围5格内的怪物对你攻击。
11.增加根据物品数据库ＩＤＸ直接得到物品
12.增加宝宝攻击触发
13.增加组队后操作的相关命令
14.增加通过物品数据库IDX字段获取物品原始各项数据库字段值参数
15.修正其他细节和优化完善自定义UI相关

【2017-05-08更新:】
本次更新文件：全套更新

本次更新修复多处细节，优化多出细节，修正多处错误，不一一列举！！！

【2017-04-21更新:】
本次更新文件：全套替换
1.修正多处细节问题
2.扩展ThrowItem

【2017-04-19更新:】
本次更新文件：全套替换
1.修正DelMirrorMap的细节处理导致报错的问题
2.修正ItemAddStone参数为空报错的问题
3.修正RangeHarm的设置掉血的一处错误
4.修正releasemagic触发合击技能卡顿问题
5.修正装备改名套装物品后，套装属性显示套装装备数量错误
6.修正ChangeSlaveAbility 的一处问题导致部分怪物做宝宝调整无效
7.修正SCREENEFFECT后面数值为 1=所有人无效的问题
8.修正日志查询工具无法查询金币增加日志
9.修正主人的月灵和自己分身的月灵PK的问题
10.修正勾选”宝宝叛变死亡“后，不死亡
11.修正CHECKMAPMOVE判断不准确问题
12.修正GetListString命令的一处错误
13.修正特效列表文件显示的一处错误
14.修正副本地图显示剩余时间的一处问题
15.修正英雄超出攻击范围攻击无伤害问题
16.修正RECALLMOB设定为1分钟叛变到时间后不会叛变的问题
17.修复查看称号的一处细节错误
18.增加设置暴击威力倍数的命令
19.内挂默认药品增加支持StdMode2类31类型物品
20.增加加入行会触发命令
21.增加NPC对话框默认输入框功能
22.增加隐藏/显示屏幕Buff图标命令
23.增加英雄对目标伤害输出值： <$H.PKPOWER>
24.增加类似富贵兽怪物（新控制器启动扩展怪物DB）
25.增加霹雳弹物品专攻富贵兽类怪物
26.安全区扩展支持不规则形状
27.增加游戏内点击链接使用外置浏览器打开命令
28.十步一杀增加个麻痹机率
29.扩展Img、text、PlayImgEx、ImgEx、PlayImg支持输入框提交
30.ADDMIRRORMAP增加参数8（为0：剩3分钟显示剩余时间，1：一直显示剩余时间）
31.M2全局G/A变量管理增加备注，方便管理变量
32.M2在线人物增加管理角色的U\T变量
33.宝宝叛变后增加是否满血选项
34.修改控制器支持启动的程序在服务窗运行
35.安全区光柱增加支持自定义
36.扩展U/T变量到255
37.扩展FILTERGLOBALMSG为新模式，已使用此命令的请更新脚本！
38.修改BUFF图标的时间显示为简洁模式
39.修改BUFF支持2100000秒时间，-1为不显示时间
40.修改BUFF支持同时20个图标显示
41.修改M2标题在关闭引擎时候为不显示，仅显示保存数据信息
42.修改设置人物下一次伤害倍数支持魔法伤害
43.ID、人物数据存储库修改为Sqlite数据库（全套替换）
--------------------------------------------------------------------------------------
1、关闭所有服务器程序
2、运行DB2Sqlite，转换数据库，转换后的数据库存在于DB目录中
3、将DB\Account.db放到LoginSrv\IDDB\中
4、将DB\RoleData.db放到DBServer\FDB\中
5、替换服务器程序并运行，也可以清理数据！
新程序全明文存储，有编程经验的可以自己写第三方合区或者数据管理工具！！！
--------------------------------------------------------------------------------------

【2017-03-02更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正上版引擎技能威力保存的一处错误
2.优化打开列表信息二的速度
3.增加调整下次攻击伤害百分比命令：SetNextDamage
4.增加调整角色附加属性命令：RangeHarm

【2017-03-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe、WZL编辑器.exe、微端服务器程序.EXE
1.修正WZL编辑器的一处错误
2.修正合区工具的一处错误
3.修正微端服务器程序的一处错误
4.增加无需宝石给物品镶嵌宝石的脚本命令
5.增加摆摊最低售价限制控制
6.增加脚本释放技能命令
7.支持恶魔盾防火墙
8.特别注意：更新本套必须全套更新使用，包含微端程序，PAK文件建议使用本版的WZL编辑器重新制作！

【2017-02-26更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe、WZL编辑器.EXE、脚本加密插件生成器.EXE
1.修复ItemShow调用装备信息PlayImg只播放第一张图片，后面的不继续播放的问题
2.修复地图参数里用了NOSHOP控制商铺的一处细节错误
3.修复装备出处显示卖给商店价格在摆摊内显示错误的问题
4.修复合区工具合并文本的一处细节错误导致合区进度停顿不前的问题！
5.修复角色在线改名后个人商店的BUG
6.修复物品规则内死亡必爆无效的问题
7.修复假人杀怪爆出装备，真人站上去，假人会进入假死状态的问题
8.修复英雄神佑盒里的装备物品备注 PlayImg 的多图片播 BUG
9.修改脚本命令刷新背包效果和快捷键一致
10.扩展文本读取、写入等功能 （最后加个参数 1为绝对路径，，0或者留空为默认的相对路径
GetRandomText
AddTextListEx
CHECKTEXTLIST
GETRANDOMLINETEXT
CHECKTEXTLIST ..\QuestDiary\充值系统\10元卡号.txt <$STR(S2)>
默认的相对路径
--------
下面为绝对路径 后面加个参数1
E:\数据文件\充值系统\10元卡号.txt 1
11.增加关键字<$const(); 地图名为n3，也就是变量头为ANG字母时会二次解析问题，执行下面脚本跳转不正确： #act
VAR string global 假人_盟重省地图编号
;★★★★★★★★★★★注意下面一行，n3是一个常量，而非变量，用 <$const(n3)> 来表示常量
calcvar global 假人_盟重省地图编号 = <$const(n3)>
SendMsg 0 <$global(假人_盟重省地图编号)>
map <$global(假人_盟重省地图编号)>
12.强化脚本加密插件算法并支持QuestDiary文件内容加密>
13.修改PAK加密算法，需新算法PAK请使用最新编辑器重新创建PAK并导入

【2017-01-19更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe
1.修正上版登录器的一处问题
2.修正自定义技能设置半月弯刀类技能时攻击不会刀刀扣蓝.
3.修正自定义开关技能设置动作以后保存不了问题
4.修正自定义开关技能无视目标敏捷问题
5.修正SetItemShape命令修改人物外观后打造的雕像还是原始外观问题
6.修正游戏内打开的网页不可以切换输入法的问题
7.修正DBSERVER的一处运算错误
8.修正加入禁言列表存在重复加入问题
9.修正Percent NPC命令无效的问题
10.NewopUI.Pak增加MISS素材
11.增加经验猪类型怪物DB（详见说明文档）
12.自定义技能增加支持某个变量达到XX才能使用选项
13.引擎增加个人商店物品最低售价限制Envir\LowestSellingPrice.txt
14.增加修改宝宝外观命令（详见文档）
15.增加调整宝宝属性命令（详见文档）
16.内挂部分选项增加鼠标提示
17.修正其他细节...

【2017-01-14更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正一处细节导致活动按钮打开后无法退出游戏问题
1.SETITEMEFFECT命令支持地上物品特效
2.内挂物品选项增加隐藏特效选项
3.修改勋章宝石支持细节并支持升级下限属性
4.修改自定义技能切换技能规则
5.完善改名备注后的如果没有匹配则以DB备注为准
6.自定义UI支持HP\MP百分比显示

【2017-01-13更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginSrv.exe
1.修正攻击速度+时候使用脚本改攻速判断的一处问题
2.修正新技能速度异常的问题
3.修正人物属性叠加宝宝的细节问题
4.修正<$H.CURRRTARGETFULLNAME>变量名字显示问题
5.修正检测地图坐标是否可以到达BUG
6.修正假人秒捡物品玩家物品BUG
7.修正跑动中持续按烈火剑法快捷键会卡顿
8.修正PLAYEFFECT在角色后面播放无效的问题
9.修正上版扩展CreateNPC 参数后固定坐标无效问题
10.修正勋章宝石显示错误
11.修改血灵教主视觉范围为8
12.修改账号服务器上版遗漏的邮箱地址改为禁止包含/
13.修改不进入到游戏界面禁止呼出内挂
14.修改半月弯刀技能为手动开启后空砍不施展技能
15.MAPEFFECT 命令增加删除命令：DelMapEffect 参数同 MapEffect一样，参数一样的删除
16.增加PlayMusicEx命令不受声音关闭影响（只能关闭电脑喇叭方式关闭）
17.自定义输入和聊天输入强制过滤具有风险的特殊字符
18.自定义特效增加地上物品特效
19.增加强制英雄和平模式，勾选后游戏中英雄一直和平模式，不跟随主人攻击模式变动
20.宝宝选项增加怪物显名时候是否显示宝宝名字选项
21.宝宝选项增加是否叠加主人下限攻击给宝宝
22.怪物设置中怪物显示等级增加是否鼠标指向才显示等级，选择后默认只显怪名不显等级，鼠标指向后显示等级
23.新绿色信息显示取消等级、金币、元宝的显示，只显示属性！
24.套装属性、套装备注、物品备注增加是否支持改名后物品显示备注和套装触发！
25.修正其他细节！！！

【2017-01-11更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正勋章宝石属性显示错误的问题
2.修正跑动中按住技能快捷键不动偶尔卡顿问题
3.修正假人秒捡他人打怪爆的物品问题
4.修正检测地图坐标是否可以到达的BUG
5.修正<$H.CURRRTARGETFULLNAME>变量显示的问题
6.修正PLAYEFFECT命令的播放顺序在角色后面不显示的问题
7.修正手动半月弯刀无目标空砍会释放的问题
8.修正未完全进入游戏可以呼出内挂的问题
9.修正技能播放速度异常问题，如倚天辟地
10.增加PlayMusicEX 声音无法被关闭 ，必须关闭电脑音箱的电源开关！
11.增加PlayMusicEX 关闭游戏声音依然播放，关闭内挂的背景音乐就不播放！扩展参数1决定
12.增加MAPEFFECT终止播放命令
13.自定义特效增加地面物品特效
14.新绿字信息去掉等级、金币、元宝显示
15.宝宝选项增加是否需鼠标指向显示名字
16.怪物设置中怪物等级增加是否鼠标指向才显示怪物等级
17.修正其他几处细节

【2017-01-10更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe、数据管理工具.exe、GameCenter.exe
1.修正NPC乱码+游戏花屏（需测试）
2.修正屏幕震动时候周围不显示的BUG
3.修正称号超过30个引擎报错卡死问题
4.修正英雄背包物品不可以双击佩戴问题
5.修正英雄跟随主人会反方向跑的问题
6.修正英雄合击空降问题
7.修正优化数据发送到网关存在乱码的问题（多线程网关专用）
8.修正自定义UI用自己设置的密码无效
9.修正ALT物品发送到聊天栏套装属性不会按照设置的单列显示
10.修正列表信息2的套装属性中负载无效
11.修正生肖对话框打开后，人物小退时不会自动关闭
12.修正个人商店存仓库提示信息显示错误问题
13.完善BUG版块提交的自定义技能开关
14.优化合区工具和数据管理载入速度
15.宝宝选项增加宝宝杀人主人是否增加PK值选项
16.控制器增加一键改端口
17.宝宝选项内的宝宝升级属性修改为是否启用新属性，默认未启用！
18.人物改名同步修改个人商店，系统自带功能的涉及人物名字地方一并修改
19.列表信息2的技能威力增加支持技能库已有技能
20.增加动态创建一个镜像地图ADDMIRRORMAP命令（详见文档）
21.增加装备投保功能（详见文档）
22.增加登录二级密码（详见文档）
23.扩展CreateNPC命令（详见文档）
24.修正其他细节BUG！

【2016-12-27更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正安全区可以吸血的问题
2.增加人物切换地图、登录游戏后的保护时间参数
3.掉落提示分开，分别为怪物掉落提示和角色（人、假人及英雄）掉落提示！
4.增加获取当前NPC名字命令
5.QM\QF触发漏掉禁止NPC进行补充（重要更新）
6.优化引擎脚本执行能力
7.浑水摸鱼地图修改宝宝名称不显示主人名字
8.增加施展技能的脚本命令
9.修正并完善其他细节问题

【2016-12-16更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginSrv.exe、UI升级
1.修正勾选了宝宝不攻击人物，使用宝宝锁定目标依然攻击人物的问题
2.修正带英雄地图事件触发的一处问题
3.修正英雄装备对比无效
4.修正假人练功问题
5.修正m.PLAYEFFECT对怪物播放特效的一处问题
6.修正自定义技能持续伤害对人物威力倍数计算错误导致伤害过大的问题
7.修正合区和数据管理工具的一处细节处理BUG
8.修正攻击触发显示英雄名字问题
9.修正神兽趴下状态血量的一处细节
10.修正人物移动时候特效比站立慢的问题
11.修改4级灵魂火符缺少自身特效
12.修改噬血术为无视障碍
13.修改账号服务器的一些细节判断
14.取消账号资料密保变量
15.增加新的顶部绿字显示选项
16.增加终止采集命令：StopCollect
17.增加国王变量和修改国家几个命令扩展
18.M2增加验证码功能
19.自定义输入长度修改到M2参数设置内自定义长度
20.修改游戏攻击速度计算（更新此版如果您的游戏有速度+的装备请重新调试封速参数）

【2016-11-11更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginSrv.exe、GameCenter.exe、合区工具、UI升级、DBServer.exe、合区工具
1.修正死亡之眼技能的一处BUG
2.修正物品快捷栏 第6格的物品，小退会回到背包的问题
3.修正ChangeModeEx 2 0需1秒的隐身状态，而非立即清除
4.修正登录器的基础细节
5.修正M.PLAYEFFECT 怪物无效问题
6.修正英雄的一处报错
7.修正命令镶嵌的宝石需要重新配置才刷新属性的问题
8.修正人物隐身后自定义怪物攻击不掉血！
9.修正元宝、灵符、金刚石等原本支持42E属性，不支持检测超过21E问题！
10.修正首饰盒掉持久问题
11.修正人形怪仇恨问题
12.修正假人登录报错
13.增加假人自动练功
14.修正一键回收命令不受最高等级经验限制问题
15.修改雷电术声音为一声
16.修改巡逻弓箭手和巡逻卫士不互相PK
17.修改ThrowItem不受M2爆物品可见时间控制
18.扩展MISSION命令并修正已知细节
19.增加二级密码功能！必备补丁442 435图片有变动，请自行查看并修改！
20.登录网关增加扫号处理
21.增加清空P变量命令 :ClearVarp
22.增加限制物品时间代码 104，不管人物在不在线，都会计算时间
23.控制器增加清理时候判断，防止一些人误清错数据
24.扩展ChangeState增加参数3（详见说明）
25.增加给人物直接加元素的命令：AddHumNewValue（无需装备，直接给人物）
26.完善国战系统
27.修正其他细节问题

【2016-10-21更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginSrv.exe、UpdateServer.exe
1.修正M2勾选了怪物不攻击离线挂机人物对群攻怪物无效的问题
2.修正聊天框输入栏提示文字会遮挡输入的文字
3.修正宝石镶嵌对话框的按钮问题
4.修正开天斩类的技能伤害吸收2次的问题
5.修正自定义UI详细信息按F10 F11无法关闭问题
6.修正ITEMSHOW 命令显示聚灵珠信息显示经验聚满得错误
7.修正CHECKHITMONNAME命令检测怪物会检测人物名字问题
8.修正微端无响应问题
9.增加遗漏的怪物伤害封顶攻击模式
10.加载离线挂机人物到土城增加自定义土城地图代码
11.增加防劫持内核配置器模式
12.个人商店增加出售物品时候提示货币
13.增加浑水摸鱼模式
14.增加远程账号管理工具
15.增加无需宝石直接脚本命令镶嵌和拆除宝石命令
16.LoginSrv增加需要密码全对才可以找回密码选项，传统密码找回默认为：问题1+密码1+生日、问题2+密码2+生日、2组方式，有一组是对的就可以找回！
17.完善其它细节....
提示：本次更新包含合区工具和数据管理工具，修复个人商店物品在合区时候一处问题导致会误删装备的问题（合区工具适用于0728后引擎数据通用）
注：本次更新NewopUI.Pak素材有变动，更新前请确定新增素材在您的客户端是否被占用，如被占用请转移素材！

【2016-09-06更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正足球的DB的一处错误
2.修正地图参数禁止穿人和禁止穿怪无效的问题
3.修正一键回收命令TakeBagItem在角色满级后经验限制无效的问题
4.裂神符增加是否允许攻击人物和分裂几率
5.群毒增加使用时间控制和只允许使用绿毒选项
6.增加外显时装时候是否显示斗笠外观的选项

【2016-09-03更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.EXE、数据管理工具.EXE
1.修正自定义技能的一处视觉细节！
2.修正上版部分怪物血量的一处错误

【2016-09-02更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.EXE、数据管理工具.EXE
1.修正合区和数据管理工具清理数据的一处细节！
2.修正勋章特效不支持万能登录器
3.修正寄售系统查询交易日志显示错误
4.滚动公告SENDMOVEMSG支持插入颜色
5.地图参数增加浑水摸鱼模式
6.默认内挂增加导出和导入物品，方便玩家快捷设置内挂捡取

【2016-09-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.EXE
1.修正自定义特效删除特效列表后的一处细节处理
2.修正怪物顶戴、人物顶戴不读取素材坐标的问题
3.修正合区工具合并行会后成员列表格式错误的问题
4.修正EQUAL A6 <$USERNAME>变量对比的一处错误
5.修正个人商店和摆摊的已知细节问题
6.修正英雄攻击怪物主人不显示大血条
7.修正简装女性服装显示为男性的问题
8.修正SETRANKLEVELNAME 给封号后人物不可以摆摊和个人商店的问题
9.修正WZL编辑器在XP系统下无响应的问题
10.修正h.ClearStoneUpgrade无效的问题
11.修正装备改名后会影响物品备注显示的问题
12.修正其他细节错误！！！
13.修改M.PLAYEFFECT支持怪物
14.修改分身属性和主人一模一样
15.自定义大血条增加一个参数设置是否水平对齐
16.宝宝升级功能增加每级宝宝后升级属性设置
17.增加检测身上所有位置镶嵌指定的宝石数量命令
18.装备栏头盔支持内观特效
19.物品来源增加获取和修改来源信息
GetItemFrom 装备位置 类型(0-4) 变量名
类型：
0：物品来源（0：未知；1：GM制造；2：NPC制造；3：商店购买；4：杀怪掉落；5：系统给予；6：挖矿获取；7：宝箱获取；8：宝箱获取；9：挖肉获取；10：捕捉获取）
1：地图
2：杀死怪物
3：经手人
4：时间
--------------------------
SetItemFrom 装备位置 类型(0-4) 值1 值2
0：物品来源（0：未知；1：GM制造；2：NPC制造；3：商店购买；4：杀怪掉落；5：系统给予；6：挖矿获取；7：宝箱获取；8：宝箱获取；9：挖肉获取；10：捕捉获取）
1：地图
2：杀死怪物
3：经手人
4：时间
当 类型 = 4时，值2填时间，其他类型时，留空
当 类型 = 4时，值1为日期（2016-08-31），值2填时间（22:54:10），其他类型时，留空

【2016-08-30更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.EXE
1.修正当ASK模式悬浮框开宝箱时，宝箱内物品悬浮框不显示图片
2.修正新合区工具合并行会的问题
3.修正UI中编辑的自定义输入框按钮位置在游戏内无效问题
4.修正自定义技能的细节
5.修正窗口最小化时间久了后切换到游戏有时候没声音的问题
6.修正H.ChangeModeEx 9 英雄无效的问题
7.修正自定义技能的伤害 不能被setherosuckdamage伤害吸收
8.修正自定义技能选DC计算伤害，实际还是魔法伤害的问题
9.修正英雄setherosuckdamage伤害吸收没有人物明显问题
10.修正假人会绕过允许捡起时间间隔秒捡其他玩家打出来的物品
11.修改ChangeModeEx 10 时增加几个禁止操作
12.修正自定义UI 排行榜的分页按钮显示状态保存不了
13.内挂增加人物简装选项
14.英雄时装首饰增加变量
$H.FASHIONDRESS // 时装衣服
$H.FASHIONWEAPON // 时装武器
$H.FASHIONNECKLACE // 时装项链
$H.FASHIONHELMET // 时装头盔
$H.FASHIONARMRINGL // 时装左手镯
$H.FASHIONARMRINGR // 时装右手镯
$H.FASHIONRINGL // 时装左戒指
$H.FASHIONRINGR // 时装右戒指
$H.FASHIONRIGHTHAND // 时装照明物品
$H.FASHIONBELT // 时装腰带
$H.FASHIONBOOTS // 时装鞋
$H.FASHIONCHARM // 时装宝石

【2016-08-29更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、数据管理工具.EXE、合区工具.EXE
1.修正个人商店的一处细节问题
2.修正人物达到限制级别后，不勾选Changeexp限制经验依然会被限制的问题
3.修正H.take 叠加物品 1 不支持英雄的问题
4.修正新版合区工具合并英雄数据的一处错误(0818版有英雄的请使用这个合区)
5.修正SETITEMEFFECT特效为0时无效的问题
6.修正英雄使用群体技能一处细节
7.修正自定义技能已知的几个问题
8.修正数据管理和合区工具关于无限仓库合并的细节错误(0818版有使用无限仓的请使用工具)
9.增加地狱火模式自定义技能支持
10.宝石相关配置器增加2个变量
11.首饰盒增加设置允许放指定位置和所有位置的物品

【2016-08-18更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginGate.exe、SelGate.exe、数据管理工具.EXE、合区工具.EXE
1.修正自定义UI的几处问题并完善已知细节！
2.修正数据管理工具释放内存的一处问题
3.推出最新版合区工具，并推出64位合区，且修正老版合区工具排列物品序列号的一处细节和已知细节问题

【2016-08-05更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginGate.exe、SelGate.exe、数据管理工具.EXE
1.修正playeffect命令的一处播放问题
2.修正装备在持久为0且不消失的情况下,依旧会计算属性
3.修正法师英雄关闭单体技能后不会使用群体攻击攻击单个怪物
4.修正\Graphics\Human服装绘制的一处问题
5.修正英雄名字会触发MONSAYMSG.TXT配置的怪物说话文件的问题
6.修正勾选允许穿怪后不能穿人形怪的问题
7.修正武器和衣服默认内观图层的一处细节
8.修正攻城期间左上角的攻城区域会被绿字信息遮挡的问题
9.修正物品来源不人形怪爆出时候不显示击杀者的问题
10.修正自定义技能的几处问题
11.修正自定义大对话框命令不支持登录脚本
12.修正NPC对话框文字不支持聖的问题
13.修正人物达到最高等级并限制经验后英雄打怪分配的经验不受此项控制和泡点经验不受此项控制的问题
14.修改英雄安全区丢物品的一处细节
15.修改英雄攻击怪物规则和英雄守护规则
16.修改死亡之眼中毒时间同步施毒术
17.列表信息1中怪物爆物品限制，增加 清零天数。
18.MESSAGEBOX对话框增加各标价签支持和文字颜色等(不支持按钮 ，支持NPC大部分脚本大部分运用)
19.特效勋章特效支持底层播放
20.增加复古GM需求的招魂术(只可以召唤死尸)数据库查看技能DB！
21.数据管理工具增加货币总额统计
22.取消顶戴花翎和内挂隐藏封号关联！

【2016-08-02更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、LoginSrv.exe、SelGate.exe
1.修正怪物爆出物品范围无效的问题
2.修改内挂BOSS提示颜色
3.修正人形怪宝宝攻击同国家的怪物
4.修正角色网关的一处BUG
5.修正英雄跑步的一处BUG
6.修正ask模式下，套装属性没有分隔条
7.修正GiveStateItem 制造多个叠加绑定的“丢弃消失”物品，丢一部分不消失的问题
8.修正M2自带的仓库密码等输入任意6位数均判断为正确密码的问题
9.修改聚灵珠提示信息
10.修改自定技能，自定义怪物，持续时间可设置为1
11.装备来源显示信息增加标题
12.内挂挂机被攻击使用随机后， 会停止挂机，正确应该随机传送卷或者随机传送石后只要没离开挂机地图 继续挂机！
13.召唤神兽和召唤骷髅增加“强化配置优先高级设置”选项
14.人物和英雄在线改名系统修改为改名检测DBSERVER设置的禁用字符和英雄名字禁用字符
15.M2-物品装备中 装备极品属性，极品属性几率：增加0表示无几率
16.KillCallMob, KillSlave 增加一个参数，是否清理尸体
17.M2查看在线人物支持无限仓库
18.人物和英雄顶戴纳入隐藏封号
19.增加调用安全区光圈特效命令

【2016-07-31更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe、数据管理工具.exe
1.修正英雄属性显示的一处问题
2.修正CHECKMAPMOVE检测坐标的一处问题
3.修正数据管理工具对部分数据库兼容问题

【2016-07-28更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBServer.exe、数据升级工具.exe、数据管理工具.exe
1.修正假人自动登录的一处错误
2.关闭客户端插件接口
3.优化DBServer.exe数据存储（更新需数据转换）
4.数据管理工具更新换代，并推出64位管理工具
注意：必须全套更新替换使用（特别提醒：必须先使用数据转换工具转换数据以后再启动游戏，否则数据无法恢复！更新前请备份数据！！！）！！！

【2016-07-15更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、LoginSrv.exe
1.修正及时雨内挂打开后快捷键无效问题
2.修正及时雨内挂手控十步一杀无法隐藏问题
3.修正组队系统的BUG
4修正组队成员变量显示的问题
5.修正合击技能噬魂沼泽 的目标中绿毒不再同步此技能威力调整改变，改为同步人物中毒伤害
6.修正禁止穿NPC情况下勾选了安全不受控制，然后又勾选你下方安全区禁止穿NPC选项后，穿安全NPC会反弹的问题
7.修正自定义怪物攻击距离大于1格时候会找攻击位置的问题
8.修正M2的一个内存释放报错
9.修正限时物品的一个BUG导致人物红名死亡后偶尔上线获取的数据不对的问题
10.修正人形怪仇恨
11.修正设置了穿人穿怪后，不能穿人形怪
12.修改注册ID只允许注册数字和英文
13.修改自定义输入限制输入长度为40字符
14.修改登录器为不搜索客户端情况下，自动在最大剩余空间的磁盘创建一个自定义文件夹作为客户端目录！
15.扩展一键回收命令增加是否显示回收货币聊天框显示参数，参数1为不显示，0或者空为显示
16.修改血灵教主目标减血20%降低为普通伤害的1.5倍

【2016-07-01(B）更新:】
本次更新文件：M2Server.exe
1.修正0701版本公布的修复中未完美修复的问题.
2.修正封包跳转刷QF,QM的严重BUG
重要更新：务必更新到本版，否则后果自负（需全套更新.涉及数据转换的请逐步转换，转换前备份数据）

【2016-07-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正打开了LoginSrv.exe的登录验证码后，当验证码里面包含字母M时候的一处细节处理
2.修正登录器配置器上的内挂设置的其中一个选项（外显时装）对男性失效的问题
3.修正吸血设置勾选按攻击伤害吸血以后攻击伤害超过21E 吸血会把自己给吸死的问题
4.修正给予绑定状态的GiveStateItem命令失效
5.修正自动寻路时候被一个怪或者人挡着了去路，就停止了寻路的问题
6.修正开了隐藏尸体后人形怪尸体显示的一处BUG
7.修正SetItemLooks修改了物品包裹和内观改了，但是地上的还是原来的的问题
8.修正十步一杀技能在距离目标1格时候不能施展的问题，另外内挂增加手控十步一杀选项
9.修正日志网关货币只显示数量而不显示增加或者减少的问题（如有遗漏货币请论坛补充）
10.修正13周年UI界面微端更新问题
11.修改指定物品禁止显示来源时候别人查看自己装备依然可以看到来源的问题
12.修改依然战战合击乱放问题（需要测试）
13.修改杀怪经验倍数提示为string.ini内的文字
14.修改消免助跑游戏中人物的4步跑降为3步跑
15.近身物理攻击和攻杀剑术增加威力设置

【2016-06-06更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBSERVER.exe、RUNGATE.EXE
1.修正怪物和NPC顶戴的问题
2.修正自定义技能 隐身后自身不播放特效的问题
3.修正诱惑之光杀死的怪物爆出的物品不显示来源
4.修正强化魔法盾没有实际效果的问题
5.自定义技能增益模式的加血增加和吃药一样的画满回血
6.修改英雄在攻击模式情况下为不主动攻击怪物，守护模式主动攻击
7.修正自定义怪物选择SC,MC,DC为伤害时候的一处判断错误
8.修正物品快捷栏速度过快时候会到背包的问题
9.扩展HumanHP调整血量的命令
10.增加在线修改装备的SHAPE和LOOKS视觉效果的命令

【2016-06-05更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正网关设置专用加密模式时候，登录验证码不可用的问题
2.修正宠物按钮会遮挡特效问题
3.修正H.ChangeModeEx 更改英雄状态命令无效
4.修正目标中毒会被其他状态干扰的问题
5.修正五雷轰新加的DB技能强化无效 ,强化到多少重都无效
6.修正HumanHP和攻击伤害一起瓢血会覆盖攻击伤害的问题
7.修正法师英雄隔墙攻击目标，目标无伤害的问题
8.修改神兽站立和爬下血量显示和热血一致！
9.修改HighLevelKillMonFixExp支持下线是否保存的参数
10.修改自定义技能攻击触发规则为：威力计算如果设置DC 就触发物理攻击触发，设置SC MC就是魔法攻击触发
11.日志工具上增加双条件查询
12.改进登录器获取列表规则，获取列表更快速、准确
注意：必须全套更新替换使用（特别提醒：必须先使用数据转换工具转换数据以后再启动游戏，否则数据无法恢复！更新前请备份数据！！！）！！！

【2016-06-02更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正自定义怪物攻击1-5无视防御的问题
2.修正个人商店已知问题
3.修正物品快捷栏的问题
4.修正加速吸血武器导致零血不死的问题
5.修正合击伤害元素无效果的问题
6.修正自动挖肉时，如果旁边有怪先死鹿后死会自动挖旁边的怪的问题
7.修正挖的装备提示不支持%ShowItem的问题
8.修正僵尸3和僵尸30的死亡后付过爬起的问题
9.修正自定义UI翻页按钮图层问题
10.修正自定义特效的附加特效播放不流畅的问题
11.怪物设置内增加神兽/圣兽站立到爬下的时间间隔
12.自定义技能增加直线攻击伤害叠增和跌减效果 类似：开天斩和逐日剑法的伤害
13.修改伤害反弹不触发[@Attack]
14.爆率路径文件支持#CALL
15.ctrl+r锁定目标 修改目标怪物不显示名字后面的数字
16.修改传送戒指如果不写坐标直接传送的话 则为随机传送
17.增加英雄100忠诚度是否触发四级技能（M2忠诚度设置20000为关闭）
18.修正上版引擎已知明显细节

【2016-06-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、RunGate.exe、数据升级工具.EXE、UI升级工具.EXE、合区工具.EXE、数据管理工具.EXE
1.修正移动时间久了会出现卡顿问题
2.修正自定义UI得几处错误
3.修正微端更新WZL格式的一处错误
4.修正自定义怪物对目标MP伤害限制的一处错误
5.修正自定义怪物大血条超过21E血显示负数
6.修正佩戴魔血石后人物无法被秒杀死亡
7.修正战战合击特效和距离问题
8.修正首饰特效影响小地图的问退
9.修正顶戴和自定义附加特效播放不均匀的问题
10.掉落提示[%ShowItem]支持文字自定义颜色
11.背包上刷新背包文字支持Y坐标大于10000为不显示
12.自定义内观特效支持在物品的底层播放
13.自定义外观特效支持勋章特效
14.SCREENEFFECT命令支持无限次数播放
15.修正其他几处细节问题
注意：必须全套更新替换使用（特别提醒：必须先使用数据转换工具转换数据以后再启动游戏，否则数据无法恢复！更新前请备份数据！！！）！！！

【2016-05-18更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正SuperMoveMsg命令当Y坐标设置大于350时坐标归0的问题
2.修正怪物大血条X坐标导致关闭引擎报错的问题
3.修正播放界面的魔法球效果命令PLAYMAGICBALLEFFECT对双血球支持的问题
4.修正上版扩展首饰盒造成的一处细节问题
5.PLAYMAGICBALLEFFECT增加支持普通绘制

【2016-05-17更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正自定义UI选择服务器设置的一处错误会导致配置器选择不显示开门动作后无法开门的问题！
2.修正商铺批量购买计算价格的一处错误
3.修正战士分身使用技能的一处细节处理
4.修正下属杀死怪物触发变量一处细节处理问题
5.修正聚灵珠释放后累加到当前升级经验的一处BUG

【2016-05-16更新:】
本次更新文件：全套程序！！！
1.修正人物伤害吸收命令超过21E吸收值会变成负数的问题
2.修正人物攻击属性使用命令翻倍攻击超过21E会变成负数的问题
3.修正悬浮框限时物品文字位置错误
4.修正人物随机传送的一处问题
5.修正登录器添加游戏报错
6.修正英雄分身的几处细节问题
7.修正聚灵珠不能再物品快捷栏使用的问题
8.修正H.ClearPlayEffect 和 H.StopPlayEffect无效的问题
9.修正自定义NPC的图层BUG
10.修正sendNewLineMsg命令Y坐标超过350归0的问题
11.修正自定义技能设置需要佩戴身上毒符时需要释放2次才行的问题
12.修正火把类照明物英雄佩戴不会掉持久的问题
13.修正引擎调整人物游戏点后需要小退才刷新显示的问题
14.修正英雄隔离障碍时候不会使用非飞行魔法进行攻击目标的问题
15.改进数据管理工具清理数据时候和无限仓库相关
16.改进合区工具清理数据对无限仓库的清理
17.完善自定义UI的部分功能缺陷
18.三大网关和微端网关增加链接安全认证选项
19.修改RUN网关将机器码拉黑后人物立即掉线，链接列表对应IP增加显示人物名
20.优化人物和无限仓库的深度细节
21.称号物品去掉重量、持久、需要等级显示
22.增加怪物大血条显示：D:\Mirserver\Mir200\Envir\MonHPProgress.txt 设置怪物血条（需更新必备补丁才可以看到素材）
23.增加无限仓库扩展命令
说明: 调整人物无限制仓库存放物品的数量.
格式: SetBigStorageCount 操作符(+ - =) 数量(0-65535)
24.增加无限仓库扩展调整变量： 可以使用变量检测无限仓库数量
#act
GetBigStorageCount N1
SendMsg 5 扩展无限仓库数据为<$STR(N1)>
25.完善伤害吸收脚本命令支持吸收所有技能和怪物的伤害
26.自定义技能增加是否允许被魔法躲避选项
27.增加捡起物品QF触发命令@PickUpItemEX ，此触发不需要任何物品规则，捡起任何物品都触发
28.技能魔法的施毒术控制增加2个选项来设置是否红毒降低目标魔御和绿毒是否让目标禁止系统回血
29.商铺购物增加批量购买参数设置
30.修改了部分魔法技能受了魔法障碍影响导致影响在有障碍的情况下不会使用
31.外显时装增加是否显示角色盾牌外观参数选项
32.优化英雄相关细节
33.完善其他细节！
本版需全套更新替换使用

【2016-05-07更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、合区工具.exe
1.修正英雄复活命令无效问题
2.修正英雄二次锁定后使用合击以后自动变成一次锁定的问题
3.修正挂机点设置时候地图怪物多的情况下无法设置坐标的问题
4.修正关系系统打开后人物小退不会自动关闭的问题
5.修正人物名字带阿拉伯数字时候人物宝宝不能CTRL+R锁定的问题
6.修正挖肉动作的一处细节错误
7.修正神兽爬下后名字颜色变成0级颜色的问题
8.修正英雄升级闪的问题
9.修正自定义怪物魔法攻击推动后攻击延迟的问题
10.修正内挂保护值超过21E后保护无效的问题
11.修正自动吃药时候手动介入吃药会卡药的问题
12.修正自定义UI等级显示只能斜体的问题
13.修正单独启动引擎没和DBSERVER连接情况下引擎操作会间隔性卡的问题
14.修正了绑定物品英雄背包操作的一处细节问题
15.修正自定义技能持续伤害和多目标伤害无视怪物MP限制的问题
16.修正MON100后的自定义怪物死亡有获得金币的声音的问题
17.修正英雄会主动攻击52、53.157类非主动攻击怪的问题
18.修正自定义技能伤害值为双倍的问题（有自定义技能的请先调试好参数再正式使用）
19.修正英雄受到攻击反击目标的一处细节错误
20.修正合区工具的一处细节问题
21.修正0501版本移动速度异常的问题

【2016-05-01更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、WZL编辑器.exe
1.修正21类项链的一处细节问题
2.修正自定义怪物一处细节导致偶尔会速度异常问题
3.修正自定义技能偶尔会出现速度延迟的问题
4.修正挖肉动作不自然的问题
5.修正WZL编辑器打开13周年素材的一处错误
6.修正天下第一雕像的发型不受DB控制的问题
7.修正自定义UI的几处细节问题
8.修正斜体字体不正确的问题
9.修正英雄会主动攻击巡逻弓箭手的问题
10.修正神兽以及宝宝锁定的几处相关细节
11.完善13周年界面几处细节
12.修改SuperMoveMsg、SendNewLineMsg命令支持队列发送
13.列表信息1内增加设置哪些物品不需要显示出处
14.增加支持风盾防火墙
15.增加PlayImgEx命令
16.扩展顶戴花铃命令SetIcon支持播放次数
17.优化英雄几处细节

【2016-04-21更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修正自定义技能偶尔会出现人物速度异常问题
2.修正0419修正自定义技能导致游戏内速度异常问题
3.修正英雄合击时候的一个报错
4.修正英雄有时候打怪会傻B几秒的问题
5.修正自定义技能不被怪物DB数据库的MP字段最大伤害值限制的问题
6.修正WZL编辑器的一处BUG
7.删除自定义怪物反应速度调试数值显示！

【2016-04-19更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBSERVER.EXE、数据管理工具.exe、数据合并工具.EXE、数据转换工具.EXE
1.修正英雄一处穿装备细节处理
2.修正商店缓存导致引擎占用内存高的问题
3.修正NPC鼠标提示不支持空格的问题
4.修复QF内打开仓库不会自动关闭的问题
5.修复列表地址如果被杀软误报风险后登录器也不能读取列表的问题
6.修复设置装备发光特效命令不读取是否居中和是否普通绘制的参数
7.修正自定义技能已知细节BUG
8.修正自定义怪物已知细节BUG
9.修正数据管理工具清理数据的一处BUG
10.修正解包叠加物品细节问题
11.修改摆摊的个人商店的图标图层为顶层
12.调整个人商店物品名字的长度支持30字符
13.悬浮框属性分类名称支持自定义修改和设置为不显示
14.悬浮框属性中元素属性支持自定义每个元素的颜色显示
15.增加悬浮框物品名字下面显示物品备注
16.镶嵌宝石属性中“未镶嵌宝石”支持自定义修改
17.镶嵌后的宝石增加支持是否显示宝石名称选项
18.扩展KILLMONBURSTRATE支持第4个参数
19.扩展物品DB数据库字段expand5 = 0表示衣服内观和外观带头发。 =1则表示内外观不带发型（取消引擎时装是否显示发型选项）
20.列表信息2 物品备注 增加装备名字下面显示备注 ！
21.功能设置增加禁止首饰位置佩戴毒符选项（176界面勿选）
22.修正挖取得物品没有来源提示 并将脚本制造修改为NPC制造
23.参数设置-PK控制内增加选项：英雄杀人不诅咒武器
24.修正人物达到最高等级限制后英雄杀怪无法获得经验的问题
25.GetDBItemFieldValue支持提取自定义数据库字段值！
26.物品备注 套装备注 自定义属性文字均支持单行文字颜色自定义
27.增加英雄复活触发（需到 M2-功能设置-其他设置中开启复活触发，和人物共用是否开启选项）
28.SetCustomItemText 扩展支持到64个字符
29.优化其他部分细节.
注意：必须全套更新替换使用（特别提醒：必须先使用数据转换工具转换数据以后再启动游戏，否则数据无法恢复！更新前请备份数据！！！）！！！

【2016-04-03更新:】
本次更新文件：M2Server.exe、DBServer.exe
1.修复了BUG
注意：本次更新为0331修复版，其他程序请配合0331程序包使用！！！

【2016-03-31更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe
1.修复了地图事件触发为9时候挖矿不触发的问题
2.修复了偶尔被攻击MP会清空的问题
3.修复了英雄的一处报错
4.修复了假人可以快速捡起别人打怪刚刚爆出装备的问题
5.修复了其他所有关于NPC调用变量时候变量值开头字母为N.D.S等开头导致可能产生的冲突）
6.修复了自定义技能威力不受技能控制提升的问题
7.修复了勋章特效会屏蔽掉衣服特效的问题
8.完善个人商店系统的操作细节
9.修复并优化其他细节

【2016-03-30更新:】
本次更新文件：M2Server.exe
1.修复了宝箱系统金刚石获取问题并处理经验这些会显示图标的问题
2.修复了聚灵珠的一处细节处理问题
3.修复了NPC自定义文字坐标在没跳转情况下自定义颜色无效的问题
4.修复了42E满血情况下吸血会爆血的问题
5.修改药品不足时聊天框提示默认1秒改为默认5秒提示一次（需更新登录器）！
6.扩展MOBPLACE刷怪支持国家模式

【2016-03-29更新:】
本次更新文件：M2Server.exe
1.修正召唤英雄得一处问题
2.修正TakeBagItem回收装备货币类型不同步配置文件的货币名称
3.修正Throwitem命令刷在地上物品捡起后不显示来源
4.吸血武器增加按照攻击伤害值吸血选项
5.扩展刷怪命令MonGen、MONGENEX、刷怪文件和GM命令刷怪
6.增加了技能破防比例设置
7.优化引擎加载自定义技能、自定义怪物的速度

【2016-03-27更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、DBSERVER.EXE、数据管理工具.exe、数据合并工具.EXE、数据转换工具.EXE
1.修正商店购买物品（药品）的一处细节处理
2.修正商铺翻页后会出现默认选择上页所选择的物品的问题
3.修正DBSERVER查看和修改U和T变量的细节问题
4.修正英雄神佑和英雄首饰盒自动穿戴的BUG
5.修正命令调整人物内功经验会同时改变英雄内功经验的问题
6.修正英雄打怪切换到相同地形的镜像地图后依然空砍的问题
7.修复配置器集成了自定义技能无法进入游戏
8.DB数据库Light字段支持扩展内观特效支持
9.增加装备来源出处，，引擎-客户端控制-装备显示信息选择开启
10.增加勋章shape字段显示衣服翅膀（同衣服设置Anicount字段值一样，效果一样只是设置字段不同）
11.优化DBserver.exe存储和通讯
注意：必须全套更新替换使用（特别提醒：必须先使用数据转换工具转换数据以后再启动游戏，否则数据无法恢复！更新前请备份数据！！！）！！！

【2016-03-23更新:】
本次更新文件：M2Server.exe、MakeGameLogin.exe、自定义UI升级工具.exe、数据合并工具.EXE
1.修正CheckTakeonItem和CheckTakeOffItem支持神佑的一处细节处理
2.修正人物切换地图后状态显示的一处细节处理
3.修正合区工具清理数据的一处细节处理
4.修正强化技能对死亡之眼类支持的细节处理
5.修正sethumattcakmode命令中地图号支持无效的问题
6.修正修正穿人穿怪选项的一处细节处理问题
7.修正SetSuckDamage和SetHeroSuckDamage命令不会吸收自定义怪物魔法技能和附加伤害的魔法攻击的问题
8.修正神兽状态切换素材读取错误的问题
9.修正SENDDELAYMSG切换地图消失无效的问题
10.修正叠加药品解包的一处细节BUG
11.修正宝宝会将人物挤出安全区的问题
12.配置器内挂默认选项增加外显时装是否勾选
13.NPC对话框文字支持设置X、Y坐标显示
14.修正英雄已知BUG和优化英雄相关细节
15.增加人物等级自定义属性控制
16.CHANGESPEED支持魔法速度微调（值：-1000 - 1000）
17.ini读写配置增加删除项命令
18.自定义属性 无属性扩展到14个
19.增加自定义NPC功能
20.修复并优化其他细节问题！

【2016-03-16更新:】
本次更新文件：M2Server.exe、DBServer.exe、 MakeGameLogin.exe
1.修正天下第一对话框框脚本自定义文字颜色用在变量下的一处细节
2.修正个人商店物品价格、物品类型、和已经出售的物品的缓存BUG
3.修正了自定义技能如果DB数据库中effecttype等于0时的几处细节问题
4.修正内挂挂机战士不开隔位刺杀时候偶尔返弹的问题
5.修正施毒术的一处细节问题
6.OpenHumDlg和OpenHeroDlg增加坐标支持参数2 参数3
7.自定义特效修改为保存后立即生效(需脱下装备再佩戴)
8.人物吃聚灵珠提示取消，改为备注吃的时候不再弹出提示
9.修改BB不攻击人物选项了后命令召唤的的宝宝也不攻击
10.ADDBUTTON命令增加支持行会界面
11.增加标签将数字转换为图片显示（支持0-9的10组图片）
12.增加命令将数字转换为图片支持0-9的10组图片，支持自定义按钮所支持的所谓位置）
13.M2增加全局G变量和全局A变量管理
14.M2增加无限仓库管理
15.连击版本界面商人购买、出售、修理与对话框去掉缝隙间隔！
16.摆摊增加货币类型控制（仅限：元宝和金币选择）
17.增加英雄在线改名脚本命令
18.英雄守护和休息状态下主人使用合击目标的方案
19.修改合击可以先不锁定目标合击，然后攻击目标即为合击目标
20.增加CTRL+R控制宝宝锁定目标（功能设置-宝宝设置内开启）

【2016-03-11更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、DBServer.exe、LoginSrv.exe、合区工具.exe
1.修复战士人形怪攻击目标锁定的的问题
2.修复引擎D语言插件支持最新引擎
3.修复道士隐身后周边怪物对宝宝视觉的太小的问题
4.修复登录器自动更新不下载特长地址文件的问题(如：阿里云存储的地址)
5.修改禁止穿人模式下人物可以穿自己英雄
6.功能设置-其他设置：吸血武器最高5倍改为5000倍，适合超变版本！
7.LoginSrv增加禁止密保问题和答案相同的选项
8.DBserver增加查看和修改角色的U变量和T变量
9.增加英雄攻击所使用的技能ID变量<$H.CURRRUSEMAGICID>
10.修改人物背包多个聚灵珠，一次给的经验多了按顺序增加到剩余的聚灵珠
11.功能设置-其他设置-其他设置三增加：经验保留选项（详细描述请查看鼠标提示）
12.微端服务器增加安全过滤功能
13.合区工具增加清理数据功能
14.增加英雄当前经验变量<$H.exp>
注意：0309以前的版本更新到此版或者后续版本需要扩展数据或者清理数据！！！

【2016-03-09更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、合区工具.exe、数据管理工具.exe、数据转换工具.exe、数据转换工具.exe、GameCenter.exe
1.修正首饰盒计算持久的一处计算问题
2.修正OPENMERCHANTBIGDLG连续打开会闪的得问题
3.修正自定义雕像站台颜色显示的一处问题
4.修正英雄计算武器速度无效的问题
5.修正限时物品=102 、103时 英雄无法佩戴问题
6.修正任务栏NPC备注占行的问题
7.修正32位系统下配置器上部分文字有重影问题
8.修正控制器修改服务端路径时候有遗漏的问题
9.修正穿人穿怪控制中一些选项可能会导致返弹的问题
10.自定义按钮扩展至支持50个
11.扩展自定义按钮支持放在装备栏更多页面
12.游戏窗口标题默认显示分区名称
13.增加NPC命令打开装备栏其他页面（称号、时装、出战等）
14.增加佩戴装备触发技能功能（类似火焰戒指）
15.聚灵珠支持英雄背包采集经验和英雄分配经验！英雄背包吃的时候（扣主人元宝、金币等）经验全部计算给英雄，主人吃的话当英雄在线则按照设置的分配比例进行分配
16.增加打开英雄背包的脚本命令
17.ChangeHumAbility和ChangeHumAbilityEX扩展功能参数
18.优化引擎性能回收
注意：必须全套更新替换使用（特别提醒：必须先使用数据转换工具转换数据以后再启动游戏，否则数据无法恢复！！！！）！！！

【2016-03-05更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修正登录器一处错误导致内存占用被限制的问题
2.修正英雄死亡后的一处错误
3.修正自定义技能火墙类触发提示的一处错误
4.修正人形怪召唤的宝宝，宝宝身上显示主人名字的一处错误
5.修正人形怪使用噬血术秒杀一切的问题
6.修正副本地图不支持地图杀怪触发(MAPQUEST.TXT)
7.修正首饰盒和生肖盒自动穿戴不触发套装属性的问题
8.修正<$MAP>变量获取地图号开头字母和变量冲突的BUG
9.修正隐藏时装的细节处理问题
10.修正<$BOXITEM[X].Y> 不支持 Need 和 Needlevel字段
11.修正攻击弓箭手后人物切换地图后回来弓箭手依然还会攻击的问题
12.修正加载脱机人物后 脱机人物如果是和人物或者NPC重叠不会分开的问题
13.修正人物学习内功，英雄不学习，，杀内功怪物英雄会获得内功经验的问题
14.修正技能强化升级 一个账号下2个人物，进入一个人物进入强化技能后 另外个人物技能栏会出现升级按钮
15.修正神兽在老万能登录器下会变成大刀的问题
16.修正怪物顶戴的一处问题
17.修正英雄在安全区主人在外面锁定目标英雄依然站在安全区不动的问题
18.修正人物和人形怪重叠后人形怪傻B的问题
19.优化内核绘制纹理
注意：必须全套更新替换使用（特别提醒：登录器和引擎必须配套）！！！

【2016-03-01更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、UpdateServer.exe、数据管理工具.exe
1.修复<$exp>变量超过21E不显示的问题
2.修复限制素材大小导致小地图尺寸大的无法显示
3.修复客户端一处内存泄露并优化客户端绘制
4.修复微端一处内存泄露并优化微端相关
5.修复自定义按钮装备栏一处问题可能会导致装备栏自定义按钮透明的问题
7.修复僵尸2地上钻出来的洞的一处细节问题
8.修复人物施展技能期间被麻痹的两处处理问题
9.修复物品规则中永不掉落的一处细节问题
10.首饰盒增加掉持久选项
11.首饰盒和生肖盒支持双击穿戴
12.隐藏时装修改为区分隐藏英雄和人物
13.修改神兽/圣兽攻击按照传统引擎设置修改为魔法攻击
14.修改游戏内行会界面人数显示为行会配置文件中的限制人数
15.配置器特殊集成增加神佑备注集成
16.优化登录器获取列表速度
17.数据管理工具增加几个小功能
18.扩展命令参数ChangeSlaveLevel 名字 操作符(+ = -) 等级(1-7) 参数4（1：调整单个宝宝；0：调整所有宝宝）
19.优化引擎修复原始代码逻辑导致会出现一些未知漏洞被人恶意利用攻击的问题，取消防攻击插件
20.优化其他细节！
必须全套更新替换使用！！！

【2016-02-06更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、UpdateServer.exe
1.修复英雄的几个细节问题
2.修复脚本命令刷新包裹的BUG
3.GETNEWITEMVALUE、CHECKNEWITEMVALUE命令扩展支持所有位置
4.优化其他多处细节增强稳定性

【2016-02-01更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、UpdateServer.exe
1.修复自定义怪物使用飞行魔法和爆炸效果的BUG
2.修复引擎启动时候遇到错误没成功启动必须结束进程才可以关闭的问题
3.修复X-.dll防攻击插件的一处错误(必须更新)
4.修复等级设置42亿，私聊显示等级为负数的问题
5.修复刷新包裹有延迟的问题
6.修复人形怪宝宝为骷髅时候速度异常的问题
7.登录网关限制版本号登录后非指定版本号提示后弹出网页（列表设置网页地址）
8. CheckTakeOffItem增加支持所有装备位置检测
9.装备星星M2增加数量控制（设置多少星星升级为月亮，默认：10） 需要更新：NewopUI.Pak 增加了星星素材
10.内挂增加怪物简装显示（勾选后所有怪物显示为稻草人）
11.优化其他细节！！！

【2016-01-31更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、合区工具、引擎控制器.exe、RunGate.exe
1.修复开天斩提示施展距离不够的问题
2.修复人形怪不能隐藏尸体的问题
3.当宝宝（召唤的属下）是人形怪的时候 当宝宝死了 飞随机 或回城 尸体会跟着飞 小退上线才停止的问题（正常死了就是死了不应该灰）
4.装备名字设置15个汉字，人形怪佩戴后可能因为人形怪不支持这么长的装备名字导致引擎报错
5.13周年装备栏称号界面上下箭头补丁按钮错误
6.合区工具修复不合并行会繁荣度的问题
7.修正计时物品在神佑、首饰盒不计算时间的问题
8.修正道士打人形怪法师，法师人形怪只打道士的宝宝。不打人物，宝宝死了才打人物的问题
9.M2英雄设置里面的英雄名称设置-后缀修改后重启M2不保存的问题
10.修正53类宝石在英雄状态栏丢魔血石无法修复石头的问题
11.修改怪物数据库MP字段设置怪物封顶伤害为不管是谁攻击伤害最高峰值多少
12.修正人物捡叠加物品不会计算叠加物品重量的问题
13.功能设置-英雄设置-其他设置增加打开NPC对话框英雄状态图标是否移动选项（不移动则和官方一样图标被对话框遮挡）
14.修改骑马时候人物名字向下调整
15.更新二次加密（原加密素材更换登录器必须重新加密）
16.支持最新版安全盾采集（取消风盾支持）
17.增加元素值变量：<$ELEMENT>，<$ELEMENT1> - <$ELEMENT20>
18.增加英雄攻击触发
[@HeroMagicStruck]
[@HeroMagicAttack]
[@HeroStruck]
[@HeroAttack]

【2016-01-12更新:】
本次更新文件：M2Server.exe、DBServer.exe、LoginSrv.exe、 MakeGameLogin.exe、MirUpdateGate.exe、UpdateServer.exe、合区工具、UI升级工具
1.修正微端程序所有已知BUG错误并优化！
2.修正合区工具合并行会目录会多创建一个目录的错误
3.修正#OR使用的一处问题
4.修正一处错误导致开天斩部分服务端内轻击会2次伤害的问题
5.修正万能登录器情况下行会掌门没有管理权限的错误
6.修正合击界面查看自己英雄装备按钮遮挡武器的问题
7.修正查看别人装备延迟的问题
8.修正限制物品103类无效的问题
9.修正英雄雷达、合击后进度条、斗笠和头盔同时佩戴显示错误的问题
10.修正四级和强化魔法盾只有自慰效果的问题
11.修正强化1-3重技能效果显示错误
12.修正人形怪挖物品报错的问题
13.修正施毒术的一处错误
14.优化客户端解决各种卡或者无响应
15.优化英雄相关操作
16.去掉技能书籍的"需要职业"
17.修改摆摊期间自己和鼠标指向摆摊人物的摊位信息均绿色字体区分显示
18.增加多个小细节功能
19.修正其它多处细节错误.

【2015-12-24更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、UpdateServer.exe、合区工具、数据管理工具
1.修正微端程序一处错误导致无响应的问题
2.修正只一个角色情况下，连续点击创建人物的一处细节处理
3.修正及时雨内挂输入时候会触发快捷键功能
4.修正自定义技能的几处细节BUG(挂机使用自定义技能提示的问题和远程推动的问题)
5.修正playsound 和 playsoundex ，播放的模式修改为窗口是否活动均播放，不活动窗口只播放没声音，活动后出现声音！
6.修正ASK悬浮框装备名字加大显示以后，悬浮框内的装备图片会下移遮挡星星的问题
7.修正13周年界面的行会公告编辑和查看时候向上按钮无效的问题
8.修正内挂挂机时候间隔时钟导致挂机速度比实际速度快的一处问题
9.修正施毒术怪物掉血的时候怪物会后仰的问题
10.修正ChangeHumAbility减HP或MP时，当HP/MP小于减去的值时，HP/MP会变成 6553X
11.修正人物死亡后爆出装备，物品规则中使用 掉落触发，触发的人物名字不显示名字后面的数字的问题
12.修正任意怪物设置 100W防御后人物所有攻击都无效了的问题
13.修正假人道士攻击目标会不停的退。减少法师假人火墙的使用几率，当法师假人打怪的，有几率往自己打的火墙中走
14.修正H.CHECKFENGHAO 检测英雄无效的问题
15.修正一键回收包裹物品的脚本命令TakeBagItem 不支持聚灵珠的问题
16.修正<$JADE> 灵玉不支持改名后的变量 <$G_JADE>此变量无效的问题
17.修正检查字符串是否在指定文件中的命令 ：CHECKTEXTLIST 的一处问题
18.修正登录器下拉式列表一次显示条数太多
19.修正道道合击目标中毒时间计算的问题
20.修正骑马状态可以使用合击的BUG
21.修正人形怪守护模式的一处BUG
22.修正英雄召唤分身不受分身召唤间隔控制
23.修正57类宝石的一处细节处理问题
24.修正不勾选：在公告显示之前显示资源加载进度信息 或 启动时显示带有进度条红色背景对话框时，强制16位色无效的问题
25.修正自定义技能内挂挂机不能锁定目标和无法使用技能距离的问题
26.修改人物装备栏：元宝、灵符、金刚石、声望文字同步!setup内的自定义名字
27.修改挂机后切换地图，自动停止挂机
28.修改 M.HumanHP - 30， M.AddHPper - 30，支持2种飘血样式飘血
29.扩展可视化仓库命令和打开任务框命令 增加坐标参数
30.数据管理工具增加金币查询
31.修改自定义技能召唤宝宝，同步人物技能技能召唤等级的怪物 ·和神兽一样即可！
32.自定义技能使用间隔提示增加坐标调整参数
33.GOTOLABEL 模式 @触发字段 范围【新加支持0-7支持范围】不填写范围则和以前一样！
34.计时物品增加物品Need=102时限时物品,NeedLevel=时间(分钟)，计算时间方式为： 穿戴即刻计算时间，就是丢背包也结算时间！
35.计时物品增加物品Need=103时限时物品,NeedLevel=时间(分钟)，计算时间方式为： 物品出现的一秒开始计算！
36.修改登录器下拉式列表增加默认显示列表第一条信息
37.微端服务器程序增加载入PAK密码（读取配置器目录的PAK.TXT）
38.MapEvent地图事件触发，增加触发条件 7：骑马走动 8：骑马跑动
39.增加支持PAK二次加密功能
40.普通技能冷却时间提示增加坐标调整
41.SENDMOVEMSG滚动公告命令增加调整字体大小和滚动速度和信息类型模式控制
42.SuperMoveMsg向上缓消公告命令增加信息类型模式控制
43.SendNewLineMsg公告命令增加信息类型模式控制
44.聚灵珠增加字段AC2设置使用等级控制
45.时装的下三格增加名字变量和改名后的名字变量
46.修改合区工具合并后按照合区前目录位置摆放合区后的数据

【2015-12-06（2）更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修改ChangeHumAbility支持减自身基础属性
2.引擎配置文件!Setup.txt中增加英雄出生背包自带物品参数
3.修改账号没角色情况下一直点创建人物会存在一个假象的问题

【2015-12-06更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、DBServer.exe、RunGate.exe、selgate.exe、合区工具.exe、数据管理工具.exe、数据转换工具.exe
1.修正道士、法师英雄勾选了无技能时使用物理攻击时 在无技能时锁定怪物后不会跑，只会走的问题
2.修正人形怪召唤的宝宝名字带有人形怪名字隐藏的数字问题
3.修正改名装备卖给NPC以后再买回来恢复改名前的名字了问题
4.修正13周年界面在角色选择界面，无角色时多点几次创建人物，显示错误
5.修正NPC代码33和34的NPC显示错误
6.修正多级脚本对象不存在时，脚本不再执行的问题
7.修正假人攻击人物目标经常改变目标为宝宝和怪物和不捡起物品的问题
8.修正禁止骑马地图人物骑马进入游戏不自动下马的问题
9.修正及时雨内挂在输入状态下输入法不介入的问题
10.修正角色网关勾选 未通过验证视为攻击时，某些老登录器创建角色速度过快时失败时会断开
11.修正个人商店的一处错误
12.修正ChangeSpeed 命令攻击减速无效的问题
13.修改采集命令SHOWPROGRESSBARDLG 当玩家同时点多条采集时候则以最后一个采集为准
14.增加增加命令Loopgoto @脚本 脚本运行次数（为空或0时，运行1次）
15.增加获取数据库字段值命令 GetDBItemFieldValue 物品名称 字段名 变量
16.镶嵌功能增加AC字段设置22 为麻痹 23为复活 24为护身 25为魔道麻痹 26冰冻 27蜘蛛网
17.增加解除绑定命令：clearLinkItem 主要是解决绑定到-1后，alt+R刷新包裹和捡起触发改名不刷新的问题
18.RUN网关超速日志增加显示超速玩家的名字
19.修改假人回血功能，增加选项控制
20.自定义技能增加远程群推功能
21.任务栏增加支持NPC标签备注功能
22.任务栏不支持彩色字体的功能如{<$STR(A302)>/FCOLOR=150}
23.修改MON100以后扩展怪物的数据库APPR值算法为 (MonXX-1)*10 ，比如MON100.WZL 算法位100-1= 99*10=990 ，，MON105.WZL为：105-1-104*10 = 1040 （每个文件支持10个怪物，每个怪物360张图，详细参考MON3.WZL的格式布局，特殊怪物请使用自定义怪物实现）
24.增加无绑定属性函数总和的常量 GetAllCustomItemValue 属性位置 变量1 变量2
25.增加获取装备宝石属性命令GetItemStoneInfo 装备位置 宝石位置（0-7） 属性类型(0-5) 变量
26.增加读写ini项：读取: ReadConfigFileItem 文件名 节名称 配置项名称 变量 ,写配置: WriteConfigFileItem 文件名 节名称 配置项名称 值
27.扩展人物私有变量U变量、T变量为100个
28.扩展宝石镶嵌：ItemFluteStoneEx 装备位置 宝石名
29.增加聊天信息监控支持白字、黄字、组队信息
30.增加调整宝宝攻击人物威力倍数命令：SetSlaveAttackHumPowerRate 神兽 500
31.修正引擎报错和优化其他细节....
注意：更换程序后请备份数据，需要扩展数据库，如果更新后商店物品出售错乱请删除NPC缓存后再启动引擎

【2015-11-30更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修正KILLMONEXPRATE命令设置永久有效保存的问题
2.修正假人使用人形怪宝宝会报错的问题
3.修正自定义技能使用自定义动作的一处瑕疵
4.修正NPC标签备注功能在任务栏无效的问题
5.优化怪物超过4万后占CPU的问题
6.set、check、reset标示增加变量支持
7.增加停止所有屏幕播放ClearScreenEffect 模式（0：自己；1：屏幕上所有人）
8.WIL列表增加 修改按钮
9.修改游戏内只要非输入模式下，输入法不介入（原需要启用自定义按钮才生效）
10.数据库ID：25修改为不可打孔
11.人物后仰增加无视护身，勾选后佩戴护身戒指后被攻击一样会后仰
12.TakeBagItem回收命令增加支持变量
13.增加大退游戏命令ExitGame （支持多级，但多级目标只能是玩家）
14.自定义技能增加远程群推模式
15.优化其他几处细节

【2015-11-25更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、DBServer.exe
1.修正转动宝箱金币超过100000，显示错误
2.修正新武力盾，新道力盾大退不消失的问题
3.修正装备改名后 发送到聊天框的装备不显示套装备注
4.修正自定义技能制作的施毒术的一处细节问题
5.修正物品规则英雄物品的细节问题
6.修正法师英雄分身术的BUG和报错
7.修正数据库物品颜色的一处问题导致公告乱码
8.增加英雄杀死怪物命令变量：$H.KILLMONNAME
9.修改道士英雄在跟随状态下可以给主人和自己加血和打魔、防
10.自定义雕像名字增加自定义文字颜色控制，第一项为NPC名字，第2项为雕像名字！ NPC名称勿用换行符号！
11.脚本命令调整杀怪经验命令 KILLMONEXPRATE 和攻击倍数命令 POWERRATE 恢复使用时候文字提示
12.修改PAK规则对微端的判断，现在改为游戏列表微端端口大有0则表示启用微端，等于0着关闭微端
13.自定义特效 （外观、内观、包裹） 均加上普通绘制选项
14.自定义怪物增加了特效2的绘制方式
15.修改英雄合击时候为快速合击
16.修改分身术的移动间隔和攻击间隔均调用英雄相关参数
17.增加主人死亡后英雄存活时间控制，主人死亡后英雄在存活期间主人除不允许控制合击外，其他操作均可控制！
18.修改游戏时候非输入状态时候，输入法会介入而影响游戏体验问题，修改后只要不是输入状态输入法不再介入！
19.改变人物衣服翅膀效果命令ChangeDressEffect修改为可以保存
20.增加检查正在穿身上装备的名字名：CheckTakeonItem 装备名字
21.修改CheckItemNameColor、CheckItemBind（支持多级）、CheckItemState（支持多级）、CheckItemDura支持所有装备位置！
22.幽灵盾和神圣战甲术增加下线是否保存附加的属性选项
23.优化人形怪智能化，达到80分以上水平
24.ChangeHumAbility和ChangeModeEx 命令支持多级脚本
请使用最新全套程序，如果使用中有任何问题请发论坛，我们将在第一时间解决！

【2015-11-21更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、DBServer.exe
1.修正13周年界面包裹物品发光时，包裹上的自定义按钮显示不对
2.修正调整属性点界面，命中和躲避显示错误
3.修正触龙神攻击范围的一处问题
4.修正多处给玩家背包增加物品时不增加负重的问题
5.修正变量<$PHONE> 显示取值错误的问题
6.修正M键大地图图层问题
7.修正T49变量、ChangeHumAbilityEX永久增加的属性值不保存的问题
8.修正自定义装备属性的几处细节问题
9.扩展泡点命令setautogetexp命令增加参数8为等级限制
10.扩展强制人物的攻击模式命令SetHumAttackMode增加参数3为地图号(*为任何地图)
11.扩展设置攻击力倍数命令POWERRATE，增加保存模式
12.扩展设置杀怪经验倍数命令：KILLMONEXPRATE增加保存模式
13.PLAYEFFECT支持多级脚本 H.PLAYEFFECT
14.PlayMusic, PlaySound，playsoundExt 增加参数4，是否在关闭声音后依然有效播放
15.CheckItemHasStone 增加参数3（数量），检测指定名称的宝石数量是否>参数3的数量
16.调整连击界面任务对话框文字显示位置
17.增加地图参数 DROPITEMADDUSERBAG(破魂|降魔)，怪物死亡掉落物品直接进入玩家背包
18.增加杀怪爆率倍数脚本命令和相关变量
19.增加变量<$PKPOWER> 人物的对攻击目标的伤害输出值
20.增加在线人数变量：<$DUMMYCOUNT> 假人数，<$ONUSERCOUNT> 真人在线数
21.增加选项：关闭NPC命令提示：你身上没有戴指定装备 （功能设置——》其他控制——》其他控制三）
22.增加命令GetHumVar获取指定人物的变量 到 自己的变量中
23.增加设置指定人物的变量值命令SetHumVar对方的名字对方的变量值
24.自定义怪物增加选项：随目标数递增攻击
25.十三周年界面神佑盒物品升级按钮必备补丁内移动到素材编号：380-382
26.增加脚本命令打开任务窗口OpenMissionDlg
27.增加关闭装备打孔： CloseItemFlute 装备位置 关闭的打孔数量
28.修改捡到和丢弃物品名字变量原<$PICKDROPITEMNAM>改为<$PICKDROPITEMNAME>
29.增加命令：LINKGIVEITEM，绑定给予的装备(类似 LinkPickupItem，当类似 give, GiveOnItem 等命令给予多个装备时，只记录最后一个，如果给予的装备丢到了地方，将不会记录)
30.自定义OK框支持遗漏的几处数据库字段变量
31.增加命令：锁定人物属性更新 LockUpdateAbil，更新人物属性 UpdateAbil，可用于自定义属性全局调整
32.增加命令：锁定装备更新：LockUpdateItem 装备位置，更新装备到客端： UpdateItem 装备位置，可用于自定义属性全局调整
33.增加字符串分隔命令EXTRACTSTRING
34.叠加物品丢在地上的物品修改显示叠加物品数量
35.优化微端连接数和内存占用
36.修正已知所有细节BUG
37.注意涉及使用自定义OK框的，更新此版请务必查看刷新到客户端命令updateitem的装备位置有改动！！！

【2015-11-14更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、LoginSrv.exe
1.修正周边怪多比较多时，刚开始进入系统声音会比较大
2.修正登录器皮肤的按钮对png半透明支持有问题
3.修正道道合击施毒时间不受施毒时间上限限制
4.修正 MAKEPOSION 命令提示不带时间和点数
5.个人商店增加 摆摊文字信息长度限制
6.合击技能劈星斩增加选项：无视魔法盾防御
7.增加选项，控制英雄宝宝休息
8.自定义按钮ADDBUTTON参数8扩展6-9
9.自定义OK框增加：
将OK框的物品放回到包裹后，触发[@ItemOutBoxX],X值为0~7
检测包裹中物品的数量(排除已经放入自定义OK框的物品)
CHECKBAGITEMCOUNTEX 物品名称 数量
GiveOnItem 装备位置 物品名称 数量默认写1(数量大于1时只对OK框叠加物品有效) 参数4 参数5 参数6 参数7 参数8 参数9
物品位置：
-1升级框
0--29：装备栏和时装栏
30-35：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框
参数4-参数9 参考 扩展的GIVE命令> 10.增加捡到物品的数据库名称变量： <$PICKDROPITEMNAME>

11.增加一些变量：
<$PASSWORD> 注册账号时用户输入的密码
<$BIRTHDAT> 注册账号时用户输入的生日
<$QUIZ1> 注册账号时用户输入的问题1
<$ANSWER1> 注册账号时用户输入的答案1
<$QUIZ2> 注册账号时用户输入的问题2
<$ANSWER2> 注册账号时用户输入的答案2
<$EMAIL> 注册账号时用户输入的邮箱
<$PHONE> 注册账号时用户输入的电话
<$MOBILEPHONE> 注册账号时用户输入的手机
<$ACCOUNTUSERNAME> 注册账号时用户输入的用户名
<$G_DRESS> 衣服 改名名称
<$G_WEAPON> 武器 改名名称
<$G_RIGHTHAND> 蜡烛 改名名称
<$G_HELMET> 头盔 改名名称
<$G_NECKLACE> 项链 改名名称
<$G_RING_R> 右戒指 改名名称
<$G_RING_L> 左戒指 改名名称
<$G_ARMRING_R> 右手镯 改名名称
<$G_ARMRING_L> 左手镯 改名名称
<$G_BUJUK> 护身符 改名名称
<$G_BELT> 腰带 改名名称
<$G_BOOTS> 鞋子 改名名称
<$G_CHARM> 宝石 改名名称
<$G_HAT> 斗笠 改名名称
<$G_DRUM> 军鼓 改名名称
<$G_HORSE> 马牌 改名名称
<$G_SHIELD> 盾牌 改名名称
<$G_FASHIONDRESS> 时装衣服 改名名称
<$G_FASHIONWEAPON> 时装武器 改名名称
<$G_FASHIONNECKLACE> 时装项链 改名名称
<$G_FASHIONHELMET> 时装头盔 改名名称
<$G_FASHIONARMRINGL> 时装左手镯 改名名称
<$G_FASHIONARMRINGR> 时装右手镯 改名名称
<$G_FASHIONRINGL> 时装左戒指 改名名称
<$G_FASHIONRINGR> 时装右戒指 改名名称

12.增加对捡取的物品进行关联 LINKPICKUPITEM
刷新关联物品UpdateItem
[@PickUpItems10]
#IF
#ACT
LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚捡取的物品进行检测，或操作
;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253
;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1
;修改后的参数，刷新到客户端
UpdateItem
break

【2015-11-12更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、RunGate.exe、DBServer.exe、合区工具.exe、数据管理工具.exe、数据转换工具.exe、LoginSrv.exe
1.修正彻地钉威力倍数调整的一处BUG
2.修正1.85界面查看别人装备稍微有点错位细节
3.修正连击技能准备计算问题导致准确度低的问题
4.修正自定义UI几处小细节调整
5.修正摆摊换衣服的一处细节
6.修正骑马时候内挂不勾选显示人名情况下，鼠标移动到马匹身上不会显示人物名字的问题
7.修正RUN网关一处报错
8.修正列表信息一 怪物爆物品记录不保存的问题
9.修正使用脚本命令给人物衣服增加翅膀或者武器特效后换装备特效还在的问题
10.修正非连击界面悬浮模式查看他人装备时，PlayImg:不播放
11.修正个人店铺的几处细节处理
12.修改英雄死亡后尸体清理修改最大设置10万毫秒
13.修改分身名字只显示名字和增加自定义名字颜色设置
14.默认内挂的英雄保护药品值参数调整
15.默认内挂快速组队快捷键支持自定义 （因为ALT+W和QQ冲突，默认内挂改为可自定义快捷键，原增加的ALT+S也可使用）
16.changestate命令定身状态修改支持多级
17.帐户密码由最低4位改为最低3位
18.内挂增加选项：禁止交易
19.TestStatus增加新魔法盾支持
20.悬浮框增加自定义进度条功能
21.悬浮框增加自定义属性功能
22.修正其他细节和调整多处细节操作
注意：本次需要扩展人物数据库！！！！
请使用最新全套程序，如果使用中有任何问题请发论坛，我们将在第一时间解决！

【2015-11-05更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修复BUG
2.修改其他几处细节
3.增加几处体验优化
请使用最新全套程序，如果使用中有任何问题请发论坛，我们将在第一时间解决，请抓紧提交修复！

【2015-11-04更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、引擎控制器.exe、DBServer.exe、合区工具.exe、数据管理工具.exe、数据转换工具.exe
1.修正改名自定义前缀修改后重启引擎又恢复成【改】
2.修正选项和人物弯腰选项冲突的问题
3.修正PlayImg悬浮框内非透明的参数无效的问题
4.修正自定义怪物血条的一处问题
5.修正英雄扩展数据库错误的问题（需要更新DBSERVER.EXE）
6.修正道士英雄没有需要毒符技能时，攻击的情况下 会提示毒符用完的问题
7.修复小地图绘制黑底的问题
8.修正称号系统超过22个称号M2重启的问题
9.修正韩国3地图图层绘制导致地图魔法绘制不全问题
10.修改心灵召唤技能
11.修改UPGRADEITEMEX 最后个参数是否显示信息 增加同步关联失败提示信息
12.修改人形怪支持自定义技能
13.禁锢术增加允许禁锢同等级目标选项
14.攻击模式增加鼠标左键切换攻击模式
15.自定义按钮文字支持彩色字体
16.增加过滤全服提示信息命令
17.增加新武力盾和道力盾
18.增加检测经络等级命令
19.修复其他几处细节和增加一些小细节功能(不一一列举各自测试，有遗漏重新提交至论坛)
注意：本次需要扩展人物数据库！！！！
本版开始不再增加新功能，请不要提交功能增加，只接收BUG修复以及性能优化，和加速、外挂处理！感谢您的支持！
请使用最新全套程序，如果使用中有任何问题请发论坛，我们将在第一时间解决！

【2015-10-29更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.称号备注 修改读取 resources/data 这个目录的fenghao.dat(限连击界面使用）
2.称号增加支持物品备注
3.修正登录器自动刷新列表无效
4.修复关于怪物的三个常量在自定义按钮内显示问题
5.修改心灵召唤技能效果
6.修正分身会攻击主人宝宝的问题
7.修正分身会频繁使用倚天辟地的问题
8.修正M2的一处读取如不存在会导致弹出数字的问题
9.修正道士英雄没有学习需要毒符技能时候会提示毒符不足的问题

【2015-10-28更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、M2引擎控制器.exe、DBServer.exe、合区工具.exe、数据管理工具.exe、数据转换工具.exe
1.修正骑马状态自动寻路时候的一处错误
2.修正引擎设置禁止穿怪时候内挂挂机会导致客户端无响应的问题
3.修正行会系统编辑时输入数字会使用物品栏的物品
4.修正仿ASK模式悬浮框缺少一个分界线
5.修正自定义怪物魔法效果渲染的一处问题
6.修正13周年界面购买物品鼠标点击不精准的问题
7.修正套装备注在英雄界面上显示的一处细节
8.修正调整爆裂火焰技能威力导致冰咆哮同时调整的问题
9.修改黑名单系统禁止接收黑名单的所有信息
10.修改人形怪守护模式下攻击模式
11.修改攻击人物重叠怪物、人物、NPC的伤害处理方式
12.修改骑马的数据参数，取消overlap字段控制，相关字段请参考说明书修改！（需要控制器扩展数据库）
13.修改13周年界面的神佑按钮图片到必备补丁，方便大家PS或者删除图片不显示按钮
14.降低 101 类型的魔龙教主麻痹几率
15.增加SCREENEFFECT增加停止播放命令 :StopScreenEffect，格式同 screeneffect
16.增加技能禁锢术，可以禁锢低于自己等级的玩家和低于自己等级所有怪物，和平攻击模式下则只禁锢怪物
17.扩展人物和英雄的数据结构，将最大支持30个技能修改为48个技能（需要扩展DB数据）！
18.ADDBUTTON文字备注增加彩色支持
19.增加转生QF触发
20.增加LEG模式飘血
21.优化小地图寻路
22.优化战士英雄
23.优化分身术技能处理和修复分身会攻击宝宝的问题
24.增加英雄装备改名命令：H.ChangeItemName
25.完善套装备注显示在英雄身上的显示细节
26.修正其他几处小细节错误
注意：本次需要扩展人物数据库！！！！

【2015-10-18更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、DBServer.exe
1.修正背包显示元宝数量勾选和不勾选坐标读取不同步的问题
2.修正客户端传统小地图，在没有打开小地图情况下按M键无效的问题
3.修正吸收伤害命令SetSuckDamage 几率控制无效
4.修正连击界面交易按钮没有按下图片
5.修正改名系统 能改 禁止创建人名的敏感字
6.修正挂机系统的几处细节处理
7.修正recallmob命令召唤的宝宝的一处细节
8.修正自定义雕像的在特效不分男女情况下的一处问题
9.修改所有技能伤害和怪物魔法伤害不区分权限
10.增加检测称号是否激活的命令：CheckActiveFengHao H.CheckActiveFengHao
11.自定义按钮ADDBUTTON扩展支持30个
12.增加支持MON30-3的镖车（详见说明书怪物数据库）
13.CHANGESTATE命令扩展几项BUFF（详见说明书）
14.脚本图标新增加 格式: <ImgEx:F:U:H:D:X:Y/@Label>
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
U=默认显示的图片序号
H=鼠标放上去时显示的图片序号
D=鼠标点下去时显示的图片序号
X和Y这两个坐标可以使图片显示的坐标更加精准.
@Label是点击图片时需要触发的脚本标签.

【2015-10-16更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修正背包元宝数量显示调整坐标同步的问题
2.修正攻城区域禁止传送的一处细节
3.修正英雄称号属性的一处BUG
4.修正配置器一些选项保存的问题
5.修正自定义特效不分男女时雕像显示的一处错误
6.修正内挂挂机战士使用烈火频率的问题
7.增加horse2.wzl读取为horse字段3-19（限官方类型单人马）
8.优化客户端.

【2015-10-11更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、 DBServer.exe、 UpdateServer.exe、 WZL编辑器.exe
1.修正升级经验修改为21亿以上，不能保存
2.修正勾选复古地图时，按M键弹出大地图不对
3.修正挂机时候会攻击英雄分身的问题
3.修正内挂挂机时候触发回城后还乱跑的问题
4.修正套装备注单列显示英雄无效的问题
5.修正13周年UI 活动日志按钮没有鼠标提示的细节问题
6.修改参数设置中攻城期间禁止传送选项效果为：攻城期间禁止向区域内传送和区域内禁止传送（限传送戒指、传送符）
7.修正参数设置中 允许穿过守卫控制的一处细节问题
8.修正勾选复古地图时，按M键弹出大地图不对
9.修正参数设置中 允许穿过守卫控制的一处细节问题
10.修正内挂BOSS提示的一处细节
11.修正经验和负重为空时显示错误
12.修正巡逻卫士单勾选攻击宝宝不攻击的问题
13.修正悬浮框使用playimg时查看别人或英雄装备显示的一处细节错误
14.修正13周年界面游戏内没小地图时候按TAB切换小地图导致屏幕右上角地图名字不显示的问题
15.修正计次数使用物品使用增加持久命令的一处细节处理
16.宝石镶嵌触发：@BagUseStoneItemOK 卸下宝石触发：@RemoveStoneItem
17.修正WZL编辑器导出13周年UI黑边问题(必须PNG格式导出)
18.检测装备是否镶嵌宝石 CheckItemHasStone 装备位置 宝石名称
19.checkitemw 增加支持首饰盒和新加的装备位置
20.增加人物改名系统
21.支持韩国传奇3地图
22.完善其它细节
注意：本次必须全套更新

【2015-09-23更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、gamecenter.exe、DBServer.exe
1.修复人物先攻击人形怪或人形怪宝宝时候会灰名的BUG
2.修正地图参数在副本地图无效的问题
3.修正挂机会攻击英雄分身的问题
4.修正沃玛教主和沃玛战将名字偏移的问题
5.修正自定义特效列表的备注信息重启后不保存的问题
6.修正会员系统增加30天时间显示为31天的问题
7.修正13周年界面卧龙笔记按钮错位的问题
8.修正关闭内挂卷轴保护和小退保护的细节处理问题
9.修正DBSERVER.EXE意外关闭不主动和M2连接的问题
10.修正M2标准经验563-831级默认不是42亿的问题
11.修正新行会玩家编辑封号名字可以很长被卡住的问题
12.修正新行会系统如果修改了默认的行会成员封号，新加入的成员看不到，只有重新编辑或创建封号才能显示出来的问题
13.修正H.ChangeItemDura命令依然是加的本体的护身符位置的持久，不会加英雄持久的问题
14.修正通过脚本改变角色性别后，时装界面的性别依然是原来的，必须小退进来才会变为新的性别
15.修正部分合击技能声音不正确和施展响应慢的问题
16.修正人物战士和道士组队，战士去引怪情况下合击施展后目标不会中毒的问题
17.修正非连击界面查看别人装备 称号不显示属性的问题
18.修正人物自定义技能元素暴击几率无效的问题
19.修正人物怪物宝宝很容易与人物重叠站在一起与怪物一样人形怪宝宝攻击怪物偶尔会和怪物重叠的问题
20.修正一处细节处理导致一台电脑挂多个号最后登录的角色偶尔为出现无响应游戏假死的问题
21.修正聊天框查看发送装备信息 悬浮框后面空余太多的问题
22.修正基本剑术加准确时候不及时显示的问题
23.修正复活触发无效的问题
24.修正内挂挂机红使用完用回城卷或者盟重传送石不会立刻触发的问题
25.修正称号DB数据库的price字段数值会增加内功恢复速度
26.修正个人商店不显示镶嵌属性的问题
27.修正副本地图剩余时间会被英雄图标遮挡的问题
28.修正连击和英雄设置参数的几处重启引擎不保存的问题
29.增加摆摊界面的脚本命令:OpenUserShop
30.增加支持心灵召唤技能作用是将不在自己所有宝宝拉到自己身边
31.扩展任务标记支持英雄H.CHECK和 H.SET
32.去掉背包显示元宝信息时候的文字"数量"
33.扩展一键回收装备支持多件一起回收
34.加快登录器微端请求响应时间
35.支持韩国传奇2地图
36.注意：本次必须全套更新，DBSERVER和M2SERVER需配套

【2015-09-08更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、自定义UI升级工具
1.修正假人会主动攻击巡逻弓箭手的问题
2.修正内挂挂机的多处细节问题并增加挂机点设置
3.修正检测当前玩家登陆的分辨率变量无效的问题
4.修正KILLSLAVE 在有分身和宝宝的情况下使用此命令清理宝宝引擎报错的问题
5.修正怪物数据库中race代码 96 死亡复活后的怪也会掉落物品的问题
6.修正战士英雄无刺杀时，锁定怪物在刺杀位会来回跑动，直到触发走位或跑位到近身时候才攻击的问题
7.修正英雄装备栏不能手动佩戴盾牌的问题
8.修正自定义OK框[@ItemIntoBoxX] 在QF脚本使用过的不能在PNC脚本中使用的问题
9.修正任务系统的几处细节处理
10.修正杀死怪物的脚本命令 RandomKillMon 会杀死禁止清理的怪物的问题
11.修正英雄捡取可叠加物品时不会叠加的问题
12.修正自定义怪物石化苏醒后原地不动远程攻击的一处问题
13.调整13周年界面多处细节
14.组队传送命令GROUPMAPMOVE和组队随机传送命令GROUPMOVE扩展增加范围控制参数
15.修改挂机为触发为QF命令触发（见说明书）
16.增加英雄死亡QF触发命令@HeroDie
17.增加怪物不攻击离线挂机人物选项
18.连击界面聊天框文字搞成原来的满屏显示并可以清屏留一行
19.修改原怪物数据库APPR设置1000开始每个怪物文件只读取一个怪物的问题，目前APPR支持到21E，每个怪物文件全部可以支持10个怪物！
20.完善新行会系统
21.扩展57类宝石为支持所有装备升级
22.修改GETITEMADDVALUE命令支持升级框和自定义OK框
23.优化登录器集成补丁解压
24.修改挂机时候内挂基本设置中自动捡起无效，除非勾选挂机栏允许自动捡起，防止挂机捡起一包垃圾导致药品无法解包
25.取消英雄使用佩戴毒符选项
26.英雄增加装备持久提示

【2015-08-31更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、DBServer.exe、RunGate.exe、GameCenter.exe
1.修复攻击佩戴加速后被麻痹或中毒状态解除后速度异常的问题
2.修复4级后的灵魂火符特效变成3级问题，修改为除强化外，4级后的火符特效延续4级的！
3.修复英雄前3刀攻击速度快的问题
4.修复疾光电影的朝向和施展方向的一处问题
5.修复倚天辟地施展方向的一处问题
6.修复Mon23-1没有石化状态，修改后RACE字段改为101即可
7.修复挖取可叠加类物品时，第一个获得的会有提示“你获得了XXX”，但是之后的都没有提示的问题
8.修复大刀名字颜色设置22以下会读取NPC名字颜色问题
9.修复自定义技能会伤害安全区人物的问题
10.修复镶嵌元素不计算物品天生元素的问题
10.修改内挂保存配置只保存内挂捡起的设置，适合本区所有角色读取，免得一个玩家几个号，每个号都要单独繁琐设置
11.修改英雄锁定模式规则
12.修改StdMode为31指定字段为1 可以放入物品栏（详细搜索引擎说明）
13.修改StdMode为31的情况下增加数据库字段控制允许死亡后使用（详细搜索引擎说明）
14.修改微端PAK规则（详细查看配置器读取规则选项查看）
15.连击和倚天辟地技能在物品数据库expand3字段控制是否使用自定义的指定的素材（详见说明文档）
16.M2在线人物增加支持查看所有装备
17.checkitem 支持检测当前使用QF触发的物品（也就是当前使用物品）
18.内挂支持自动吃修复药水（药水名称需玩家内挂中手动填写）
19.内挂增加持续挖取选项
20.DBSERVER增加宕机检测分配
21.自定义技能增加2种推动类型和冷却时间提示选项
22.开天斩修改为距离越远伤害越高
23.强化盾倍数调整为可设置更小的数值
24.改进机器码读取
25.增加13周年界面支持
26.增加新行会系统
27.完善其他多处细节！
28.修正多处小问题

【2015-08-01更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、RunGate.exe、微端程序
1.修复客户端偶尔闪屏的问题
2.修复RunGate计算速度不准确的问题
3.修复武力盾没声音问题
4.修复非连击界面查看别人装备，装备栏上的名字没居中的细节问题
5.修复英雄打死人行怪物后掉落的物品主号有时候不能捡取的问题
6.修复微端更新的一处导致游戏无响应的严重BUG
7.修复自定义技能黑夜一处BUG
8.修复自定义技能无法实现类似幽灵盾的技能
9.修复主副将英雄名字长度导致评比时候英雄数据出问题
10.修复对自己施放魔法导致卡魔法的问题
11.修复SetItemsLight 发光位置的一处问题
12.修复修复内挂吃药间隔参数调整不人性化以及百分比情况下不保存吃药设置
13.修复箱子开经验,如果人物经验已经大于22亿,那不管开多少经验会直接升级
14.修复M2-列表信息2-技能威力-增加技能防御百分比-火墙,增加了之后只有站在火墙上面不动才有效的问题
15.修复CTRL+右键查看别人装备时候点击行会名字时候 行会名字不到聊天输入栏显示 导致申请行会战的时候 行会名字符号太多无法完整正确输入的问题
16.修复摆摊··不同分辨率错位问题
17.修复地图魔法配置文件（MapMagicEvent.txt）最后面增加个参数为时间间隔 留空为 1秒间隔，设置5则为5秒一次
18.修复戴上隐身戒指以后打什么怪都不还击的问题
19.修改火龙教主的火龙气焰为单体攻击
20.修改功能设置其他控制中的禁止记忆传送安全区人物选项关联 师徒传送、夫妻传送、行会传送，勾选后以上均不可传送安全区人物
21.修改CHECKITEMADDVALUE、CheckItemAddValueEx 、 CHANGEITEMADDVALUE OK框和升级框位置·如版本有更新时候检查下脚本 -1 升级框，， 自定义OK框为：boxitem0 -boxitem7
22.降低魔龙教主麻痹攻击方式
23.增加新版魔法盾和新强化盾 (M2 技能魔法设置)
24.增加诅咒术（经典版）技能 按技能等级降低目标的攻、魔、道 （原版则为降低防御,更新DB库）
25.配置器-内挂默认设置-增加客户端默认吃药间隔控制最小设置值
26.增加地图参数：NOHEROPROTECT,作用:禁止英雄守护
27.列表信息二内挂捡起增加多选批量操作设置功能
28.增加商铺里的赠送系统。是否开启可以在M2上控制
29.增加大刀的名字颜色控制
30.地图触发魔法系统增加时间控制
31.完善配置器多处细节问题

【2015-07-07更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修复优化几处细节.

【2015-07-04更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修复优化几处细节.

【2015-07-01更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修复查看别人称号的一处问题
2.修复MonSpAbilList.txt文件的细节问题
3.修复聊天框信息多的时候拉动不流畅问题
4.优化其他细节

【2015-06-30更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、RunGate.exe、、DBSERVER.exe、合区工具、数据管理工具、数据转换工具
1.优化完善修复等等等............

需要数据转换工具转换数据，更新前请备份数据...
需要数据转换工具转换数据，更新前请备份数据...
需要数据转换工具转换数据，更新前请备份数据...
需要数据转换工具转换数据，更新前请备份数据...
需要数据转换工具转换数据，更新前请备份数据...
需要数据转换工具转换数据，更新前请备份数据...
需要数据转换工具转换数据，更新前请备份数据...

【2015-06-20更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、RunGate.exe
1.修正宝宝HP叠加时，只改了最大血量，而没有修改宝宝本身的血量值
2.修正当装备持久到0后，当直接在身上用修复神水或npc修复装备，装备对应的属性没有计算到人物身上
3.增加设置天下第一雕像有效时间命令：SetNpcImageTime 操作符（=，+，-） 时间（为空，小于或等于0为永久有效，大于0为指定分钟）
4.增加登录器版本号不匹配时登录游戏提示信息
5.优化引擎数据包处理
如果是0614以前版本请查看更新日志进行数据转换...

【2015-06-18更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修复删除雕像命令的一处错误
2.修复人形怪守护模式的一处问题
3.修复设置多少级玩家死亡不掉落装备参数不保存的问题
4.自定义雕像增加雕像有效时间，到时间自动破碎

【2015-06-17更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修复角色在树荫或者建筑物影子下移动时候自身影子闪动的问题
2.修复骑马一步三格背后方向屏幕边缘绘制有黑边的问题
3.修复裂神符攻击目标的一处细节问题
4.修复内挂智能半月判断的一处问题
5.修复自定义怪物一处问题
6.修复英雄未受到伤害主动还击的问题
7.修复内功技能的经验点不能实时显示的问题
8.修复DB库设置怪物伤害封顶不能控制施毒术伤害的问题
9.修复道士英雄无技能物理攻击存在真空区的问题
10.修复裂神符攻击目标分裂后，目标攻击自己声音的一处错误
11.修复部分内功技能经验点不会增长的问题
12.自定义外观特效增加设置播放数量
13.查看别人称号增加显示称号属性
14.英雄合击增加空降模式选项
15.道法英雄增加支持二次锁定是否不躲避选项

【2015-06-14更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、DBSERVER.exe、合区工具、数据管理工具、数据转换工具
1.修复道法英雄在无技能攻击目标时不会跑的问题
2.修复带刀护卫攻击无特效问题
3.修复删除自定义按钮的功能DELBUTTON删除个人的编号1会删除全服人物图标问题
4.修复非连击界面技能经验点会遮挡快捷键的问题
5.修复不勾选“英雄杀人增加PK值”时，英雄杀人不增加主人的PK值
6.PLAYEFFECT命令增加播放效果参数控制
7.完善排行榜功能（支持人物、英雄、名师）
8.增加人物的伤害吸收值变量：<$SUCKDAMAGE>
9.增加禁止交易和禁止商铺的地图参数
10.装备栏增加灵玉装备格
11.时装增加支持时装头盔、项链、手镯、戒指 （M2-客户端控制内选项开启）
12.DB数据库增加支持所有元素天生属性，控制器启动提示扩展
注意：本次更新装备位置有变动，凡是使用首饰盒、神佑功能的请务必更新脚本中装备位置，新装备位置查看说明书
本次更新需转换数据库（（（程序包内\工具\数据转换工具目录内）））！！！！！！！！

【2015-06-11更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、 RunGate.exe
1.修复狗狗的一处问题
2.修复包裹满后31类卷触发的一处问题
3.修复自定义按钮没补丁时的一处细节问题
4.修复开宝箱的显示装备属性的一处问题
5.修复OK框检测星星数据的一处问题(CheckUpgradeCount命令修改检测全身星星位置代码，有用到此命令的请注意看说明书)
6.修复英雄守护模式当主人不在范围内不攻击怪物的问题
7.修复内功伤害增加对魔法攻击无效的问题
8.修复内功等级会影响刺杀、开天斩、逐日伤害的一处问题
9.修复53类宝石可以使用修复水修复的问题
10.取消客户端快捷键“K”
11.增加战士英雄二次锁定相同目标英雄攻击该目标则停止走位
12.彻地钉技能增加禁止PK选项
13.全面优化引擎数据发送(本次更新必须更新全套程序)

【2015-06-09更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修改悬浮框装备名字细节
2.修改神兽攻击的细节
3.修改setautogetexp 地图*为任意地图的一处问题
4.个人商店增加出售时间限制
5.修改聊天框的一处细节处理

【2015-06-08更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修改部分细节提示
2.修改怪物和人物身体颜色支持变色

【2015-06-01更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、 RunGate.exe、 SelGate.exe、UpdateServer.exe
1.修正摆摊的一处严重BUG
2.修正挑战功能的一处细节处理
3.修正使用隐身后对宝宝不攻击怪物的问题
4.修正GM命令清理包裹的存在假象的问题
5.修正背包挡住人物属性框时查看装备的一处问题
6.修正聊天框偶尔会全部清除信息的一处问题
7.修改强化神兽细节
8.加强RUN网关对加速处理
9.加强M2和角色网关的防攻击能力
10.优化M2和网关通讯
11.更新D语言插件源码
12.完善其他细节

【2015-05-23更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修正人物小退后再退出游戏内挂配置会重置的问题
2.修正商铺特效同步背包特效
3.修改英雄锁定目标后当主人被攻击英雄会改变目标的问题
4.修改解毒术特效
5.修改诅咒术技能特效
6.增加仿ASK悬浮框
7.解毒术增加effect：32
8.群体施毒术增加effect：33
9.完善其他细节

【2015-05-20更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、RunGate.exe
1.修复人物分身召唤宝宝后对主人宝宝判断的一处细节
2.宝石镶嵌增加限制相同IDX的数量
3.优化英雄PK处理几处细节
4.优化网关在大字节发送时候的数据处理
5.优化战士英雄
6.完善其他细节问题

【2015-05-17更新:】
本次更新文件：M2Server.exe
1.修复人物取怪物名字会爆怪物的物品的严重BUG
2.修复自定义技能勾选效果持续播放情况下一处问题
3.增加调整人物永久属性值命令：ChangeHumAbilityEX
注意：更换程序后请备份数据，查看你当前使用引擎版本号与本次更新版本号之间更新内容，有需要扩展的请按更新顺序逐个扩展，如果更新后商店物品出售错乱请删除NPC缓存后再启动引擎

【2015-05-16更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、RunGate.exe
1.修复连击时候看不到斗笠问题
2.修复自定义技能一处选项导致道士使用身上佩戴毒符不能自动切换问题
3.内功等级提升支持到65535
4.英雄内功完善
5.修改宝箱功能扩展相关细节处理
6.优化网关数据处理

【2015-05-14更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.完善连击界面内功系统
2.优化完善自定义技能细节
3.修复人物红名不及时显示的问题
4.修复雷霆剑法、龙影剑法威力计算的一处错误
5.修复盾牌特效的一处错误
6.增加支持英雄当前地图和坐标变量

【2015-05-12更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修正商铺特效问题
2.修正道法职业的英雄合击后施展技能不流畅问题
3.修正安全区光圈的处理
4.修正英雄名称变量的一处问题
5.修正人物死亡掉落装备件数设置后不保存问题
6.修正其他细节处理BUG

【2015-05-09更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、合区工具.exe、数据管理工具.exe、数据扩展工具.exe
1.修正摆摊时候部分方位显示不正确的问题
2.修正自定义特效读取素材坐标的一处计算导致部分特效飘动（例如：StateEffect.wzl 720 - 745）
3.修正特殊药水问题提示的文字错误
4.修正夫妻攻击模式下不能攻击怪物的问题
5.修正人形怪宝宝会主动攻击和平的怪物如羊、鹿
6.修正卧龙笔记传送的问题
7.修正沙巴克攻城的一处错误
8.自定义特效支持盾牌外观特效
9.增加衣服特效和武器特效的DB数据扩展
10.自定义怪物增加不主动攻击怪物物品必须挖（类似鸡、鹿）怪物数据库字段设置Race：157 Raceimg:156
11.装备改名不在保存在Envir\ItemNameList.txt里，直接保存在人物数据“Mir.DB”“HeroMir.DB”(使用转换工具，会自动处理在ItemNameList.txt的改名数据)
12.巡逻怪物增加巡逻弓箭手
13.巡逻怪物列表信息1增加允许捡起物品列表和相关选项
14.增加支持盛大模式安全区光环代码：2
15.修改安全区配置文件StartPoint.txt地图代码不区分大小写
16.增加OK框里是否有物品的检测命令CheckBoxItemCount
17.DELBOXITEM OK框编号(0~7) 删除数量(该参数只有是叠加物品时才会有效，如果没有全部删除掉，需要使用UpdateItem命令进行刷新，否则客户端不能立即显示删除掉的数量。如果该参数为空时，表示该OK框里的叠加物品不管有多少数量，只删除1个)
18.扩展支持数量giveboxitem 0-7 物品 数量（叠加物品有效）
19.修改新护身血条图层为蓝色表层
20.优化其他细节处理
注意：更换程序后请备份数据，然后使用0508扩展工具扩展数据库后再用0509扩展，扩展后清理NPC缓存后再开引擎

【2015-05-05更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、UpdateServer.exe
1.修正PlayImg不读取素材文件的XY坐标
2.修正在“战斗”地图下杀死英雄，英雄会爆装备，武器还会增加诅咒
3.修正月灵死后地上会显示月灵的名字的问题
4.修正英雄和英雄宝宝攻击模式以及相同攻击模式情况下可以攻击英雄的问题
4.修正士英雄在大刀卫士处，英雄宝宝（比如月灵）被大刀杀了，然后道士英雄会主动攻击大刀
5.修正新账号首次创建人物·窗口标题上不显示人物名字的问题
6.修正扩展的小地图在M键大地图中不能显示的的问题
7.修正宝宝乱攻击的问题
8.修正摆摊物品使用TAKE命令收走后存在假象的问题
9.修正打开声音的按钮没有音效的问题
10.修正自定义技能的几处问题
11.修正护体神盾的一处错误
12.修正连击技能的一处错误
13.修正顶戴花翎的一处错误
14.修正技能时间参数无效的问题
15.修改神佑元素处理的一处细节处理
16.修改流星火雨技能伤害的增加选项
17.修改假人英雄不受攻击模式的控制，SetHumAttackMode命令和H.SetHumAttackMode对其无效。
18.修改假人英雄攻击模式和主人一致
19.修改安全区配置地图代码为不区分字母大小写
20.修改CHANGEITEMUPGRADECOUNT命令支持升级框
21.增加地图参数 NOSWITCHATTACKMODE 禁止切换攻击模式
22.自定义特效修改计算解决官方部分素材飘动问题
23.玩家命令增加@拒绝公聊和@拒绝喊话命令
24.优化微端程序读取PAK密码速度
25.优化英雄让英雄更灵活
26.修复其他细节问题以及关于宝宝的问题
27.注意：更换程序后请删除NPC缓存再启动引擎

【2015-04-29更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe
1.修正英雄重新上线看不到后面6格的神佑，收回英雄时关闭神佑和首饰盒
2.修正53，63类物品不支持升级
3.修正宝石升级触发@ItemUpgrade后，在脚本中 SetUpgradeFail 设置升级失败时，还会减宝石
4.斗笠扩展
5.优化引擎数据处理
6.修复其他细节问题

【2015-04-26更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、RunGate.exe、UpdateServer.exe
1.修改网关机器码算法
2.修改微端程序计算发送大小显示的一处错误
3.修正镶嵌生命值时当M2设置42亿HP时候的一处错误
4.修正可视仓库的多处错误
5.修正合击技能播放过快
6.修正死亡后执行AddhpPer、HumanHP的命令，人物小退再上不在安全区
7.增加英雄支持 H.CHANGEITEMADDVALUE 和 H.GETITEMADDVALUE
8.M2宝石镶嵌页面增加禁止鼠标右键镶嵌宝石选项
9.增加镶嵌命令：ItemFluteStone 装备在OK框中的位置(0-7) 宝石在OK框中的位置(0-7)
10.增加退出行会触发
11.增加沙巴克行会触发
12.更新程序后删除服务端中的NPC缓存！

【2015-04-22更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、数据管理工具.exe、数据合并工具.exe、数据转换工具.exe、DBServer.exe
1.细节优化、完善与BUG修复！
2.大家自行测试检查提交的问题是否得到解决、如果问题依旧存在请及时论坛发帖！！！
3.升级程序注意扩展数据库，扩展前请备份数据！！！！！！
3.升级程序注意扩展数据库，扩展前请备份数据！！！！！！
3.升级程序注意扩展数据库，扩展前请备份数据！！！！！！
4.升级程序注意扩展数据库，扩展前请备份数据！！！！！！
5.修复没学习连击技能，但是按ctrl+d会有提示
6.修复优化机器码获取
7.修复背包物品使用自定义 OK框自动放入命令后有假象问题
8.修复人物游戏中消耗了金刚石后 装备栏的金刚石不会及时刷新 必须小退才行
9.修正客户端控制——》其他控制——》显示在属性框中，新增加的元素属性支持自定义显示
10.修正可挖取物品的怪物每次挂提示未获取物品 (比如鸡 鹿)
11.修正内挂周围人物 、怪物信息为实时刷新
12.修复内挂下4格小退-再大退-然后重新进入游戏后雷达选项的一处问题
13.修复封包可刷脚本段的一处问题
14.增加显示行会老大名字的2个变量,从左到右分别是老大1 和老大2,和一个 成员数量 变量(请看脚本变量大全)

15.增加#or 脚本处理(详情请看说明书)
比如:
#or
CHECKLEVEL 85
checkgamegold > 49999
#ACT
两个条件只有一个成立.即可往下继续执行

16.增加检测身上是否有指定名称的装备，并获取looks到变量中：(详情请看说明书)
17.增加及时雨内挂，保护支持31类物品的使用
18.增加支持npc3.npc4(详情请看NPC代码)
19.增加及时雨内挂传送捡起功能（注意:M2可控制是否开启此功能）
20.增加10中新元素属性：(请见说明书)
21.增加巡逻卫士：请自行修改Envir文件夹下的GuardList.txt文件.原格式不再支持 (请见说明书)

【2015-04-16更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe、 GameCenter.exe
1.细节优化与BUG修复！
2.大家自行测试检查提交的问题是否得到解决、如果问题依旧存在请及时论坛发帖！！！

【2015-03-31更新:】
本次更新文件：M2Server.exe、 MakeGameLogin.exe 、RunGate.exe
1.修复网关一处错误导致弹出关闭网关提示的问题
2.修复looks变量读取素材文件错误的问题
3.修复内挂百分比吃药的一处错误
4.修复勋章类std=30不能镶嵌宝石的问题
5.修复元素属性靴子和腰带设置反了的问题
6.修复自定义怪物血值偏移无效
7.修改好友近身提示频率
8.修改SETRANKLEVELNAME封号功能恢复以前
9.修复元素叠加的一处计算问题
10.时装系统支持勾选外显时装触发和是否显示外观发型的选项
11.修改神圣战甲术和幽灵盾增加属性的计算
12.修复神圣和强度会显示极品+0
13.修改ChangeModeEx模式的一处错误
14.修改特效列表中勾选不分男女保存错误和备注记录的问题
15.修改InPutString增加包含禁止字符触发以及一处细节处理
16.修改登录器背景音乐为内挂控制
17.聊天框 CTRL+左键发装备信息
18.增加支持传音筒以及修改传音筒的一处细节
19.修改数据库怪物名字支持15个汉字
20.修改客户端一处绘制细节处理
21.修改支持查看骑马人物的装备（双人坐骑只显示邀请者）
22.修改UPGRADEITEMEX命令失败后为及时刷新属性
23.修改人物向英雄背包转移物品后负重为实时显示
24.修正神佑触发的一处问题
25.修正隐藏称号后查看英雄、分身装备不显示时装文字的问题
26.修改CHECKITEMTYPE支持位置-1默认OK框和自定义OK框
27.修正SetSuckDamage设置的伤害吸收无法吸收远程物理攻击的问题
28.修改强化半月弯刀技能为不提升主目标伤害
29.修正沙巴克雇佣的护卫重启服务器会攻击沙巴克所属行会的人
30.修正屏幕震动命令：SCENESHAKE参数的一处问题
31.修正changestate的蛛网效果对假人无效的问题
32.人形怪增加支持军鼓和修改人形怪基础细节
33.修改分身术为人物当前形象
34.假人增加支持支持军鼓、时装武器、时装衣服位置（配置文件中：ShowFashion=1（0,1）是否外显时装）
35.修改技能等级控制宝宝最高等级算法
36.修正UPGRADEITEMEX升级失败破碎后的一处细节处理
37.修改SETNEWITEMVALUEEX支持所有位置
38.修改人物和英雄背包互放物品时负重的处理
39.修改54类腰带属性的的一处错误
40.宝石升级系统增加几处变量
41.增加自定义技能功能

【2015-03-20更新:】
本次更新文件：M2Server.exe
1.修复首饰盒刷物品的BUG（未启用首饰盒的可不更新）

【2015-03-13更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe 、RunGate.exe、合区工具.exe、数据管理工具.exe、数据转换工具.exe、DBServer.exe、MirUpdateGate.exe
1.修正技能冷却时间提示0秒的问题
2.修正元素属性设置的几处的问题
3.修正反弹伤害导致角色灰名问题
4.修正野蛮冲撞允许推动同等级人物选项不能保存的问题
5.修正网关并发连接以及脚本触发无效的问题
6.修正裂神符鞭尸的问题
7.修正新技能不能攻击触发的问题
8.修正套装触发命令@GroupItem不支持首饰盒物品
9.修正套装技能威力无法保存的问题
10.修正并完善黑夜效果的几处细节处理
11.修正PLAYEFFECT、MAPEFFECT 命令魔法特效重复的问题
12.修正非连击界面头盔斗笠显示的一处问题
13.修正战士狮子吼技能麻痹基础时长修改后无法保存
14.修正客户端读取规则顺序的问题
15.修正龙影剑法和开天斩内挂自动使用时有时候图像错乱的问题
16.修正查看人形怪装备栏显示名字最后面数字的问题
17.修正微端网关会分配用户到不在线的微端服务器
18.修正无限可视仓库物品存多了 如果翻页过快 会导致仓库变成0页
19.修正装备镶嵌最多设置的3件同类宝石。 镶嵌第2件宝石的时候就提示已经超过3件。
20.修正检查宝宝的等级的命令：CHECKSLAVELEVEL的一处判断的问题
21.修正RACE怪物代码为125的怪物对防毒的玩家无限施毒的问题
22.修正人物用命令：SETRANKLEVELNAME <神>·%s获取称号后个人店铺不能用和不能申请个人店铺的问题
23.修正开天斩、逐日无视防御和魔法盾的一处错误
24.修正race = 100的怪物（新骷髅），不可以设置移动速度及攻击速度
25.修正英雄死亡爆的物品不能捡的问题
26.修正小地图雷达的两处问题
27.修正防石化前提下麻痹状态控制的问题
28.修正隐身戒指使用隐身术后失效的问题
29.修正角色血条读取怪物血条的BUG
30.修正套装技能威力增加伤害只对怪物有用，对人物没用（增加选项）
31.修改套装属性叠加计算方式
32.修改角色名字处理的一处细节
33.修改M键呼出大地图·小地图不关闭（M键为单独大地图控制）
34.修改蜘蛛网和凝冰效果放入必备补丁
35.修改TakeBagItem回收叠加物品的处理
36.修改修改Objects和Tiles扩展都支持到65535
37.修改悬浮框图片展示的图层
38.修改宝石加星的几处细节
39.修改冰霜群雨和死亡之眼等技能 快速麻痹、冰冻处理逻辑
40.修改装备加星使用图片绘制
41.修改角色中蜘蛛网为禁止跑动
42.修改分身出现位置随鼠标控制
43.修改SendCenterMsg命令替换模式方式(详见说明文件)
44.修改内挂默认药品设置方式(详见说明文件)
45.修改及时雨内挂自动小退、卷轴保护和M2设置关联
46.修改及时雨技能页中英雄技能和M2内挂控制英雄选项关联
47.修改并完善黑夜系统几处细节
48.修改并完善58类宝石升级
49.修改角色背包栏位置不受OPENMERCHANTBIGDLG影响
50.修改SETRANKLEVELNAME 称号长度支持128字符
51.修改刷新包裹为：不刷新下面6格物品栏
52.修改客户端控制-装备信息显示中装备名字的字号可调整为9号
53.修改元素攻击伤害点数控制
54.扩展命令：ADDBUTTON支持装备栏和背包栏（详见说明文件）
55.扩展ChangeState命令和ChangeModeEx使用
56.技能魔法中法师技能：冰霜群雨的冰冻增加几率控制
57.绑定物品文字前增加图片显示
58.镶嵌宝石进装备后增加QF命令
59.增加增检测镶嵌XX个宝石的命令
60.增加自定义输入框字符过滤
61.增加英雄当前获取经验值变量：<$HeroGetExp>
62.增加刷新英雄包裹快捷键
63.扩展个人商店支持灵符、泡点、金刚石购买，并独立增加税收控制、并支持自定义货币名称
64.商铺增加灵符、金刚石购买
65.列表信息1一禁止取下物品增加支持首饰盒和神佑盒
66.宝石镶嵌显示图标增加控制：客户端设置-装备信息显示
67.内挂默认药品修改读取规则(详见说明文件)
68.自定义怪物增加自定义数字（血值）坐标调整
79.增加斗笠、盾牌、蜡烛、马牌、军鼓、宝石、时装支持宝石升级
70.增加变量以显示完整名（不去数字）$CURRRTARGETFULLNAME
71.优化完善仿及时雨外挂并支持百分比血量保护
72.增加传统时装展现选项
73.自定义特效增加不分男女选项
74.自定义特效增加普通绘制选项
75.人物属性栏增加支持显示荣誉值显示
76.元素属性增加反弹伤害倍率设置
77.扩展角色防御、魔御、攻击、魔法、道术支持21亿
78.扩展角色HP、MP支持42亿以及怪物属性支持42E
79.增加检测装备星星数量命令
80.修正并完善其它细节

【2015-02-07更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe 、RunGate.exe、合区工具.exe、UpdateServer.exe
1.修正神佑套装显示的一处问题
2.修正宝宝叠加HP的一处问题
3.修正怪物身上爆出的聚灵珠的一处问题
3.修改老网关封挂功能
4.优化微端以及相关程序
5.优化合区工具对无限仓库合并
6.修复其他细节

【2015-01-31更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe 、数据管理工具.exe、合区工具.exe、UpdateServer.exe
1.修正检测身上装备持久命令的错误
2.修正其他细节问题
3.更新合区工具 和数据管理工具

【2015-01-30更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe 、DBServer.exe 、数据库转换.exe
1.修正学习功能偶尔不及时显示内功界面的问题
2.修正英雄无极真气的问题
3.修正PLAYEFFECT播放人物特效时候人物移动时候特效不播放的问题
4.修正SENDMOVEMSG过一段时间背景区域错误
5.修正选择使用身上毒符时内挂毒符互换无效的问题
6.修改悬浮框Looks支持物品背景框
7.修改悬浮式装备显示排列
8.TestStatus命令参数分钟修改为秒
9.首饰盒和神佑盒增加爆出几率控制
10.扩展SetItemState绑定物品命令增加丢弃消失
11.注意：更新数据结构，更换程序请备份数据并扩展
11.注意：更新数据结构，更换程序请备份数据并扩展
11.注意：更新数据结构，更换程序请备份数据并扩展
11.注意：更新数据结构，更换程序请备份数据并扩展
11.注意：更新数据结构，更换程序请备份数据并扩展
11.注意：更新数据结构，更换程序请备份数据并扩展

【2015-01-29更新:】
本次更新文件M2Server.exe、LoginSrv.exe、RunGate.exe、MakeGameLogin.exe
1.修正SCREENEFFECT命令的一处错误
2.修正骑马准备时间的一处细节
3.修正万能登陆器查看他人装备属性显示错误
4.修正关闭自定义大对话框命令CLOSEMERCHANTBIGDLG关闭后出现传统对话框的问题
5.修正OPENMERCHANTBIGDLG命令的一处细节错误
6.修正宝石镶嵌的几处细节处理
7.修正安全区不受控制（禁止穿人的模式下）不能穿英雄的问题
8.修正新魔龙城地图灯柱的特效错位的问题
9.修正修开天斩、逐日类的技能点NPC会自动开启的问题
10.修正部分公告被游戏素材遮挡的问题br> 11.修正GM命令调整角色元宝数量的一处BUG
12.修正非连击界面下盾牌略微错位的问题
13.修正刷怪时间导致无限刷新BOSS的问题
14.修改登陆器各提示细节文字
15.修改普通仓库和无限仓库分开读取
16.修改并完善人形怪相关功能
17.修改并完善网关几处细节
18.修改手动吃药自动解包的问题
19.修改人物在安全区外，英雄在安全区内可以丢物品的问题
20.刷新包裹间隔后面增加个提示开关
21.扩展NPC对话框支持物品图片以及展示属性参数
22.扩展悬浮式装备显示框支持图片显示支持图片播放
23.增加Ctrl+鼠标左击可以把物品名字复制到聊天框发送出去，其他玩家可以查看物品属性
24.增加获取当前人物形象为雕像的功能
25.增加可视化仓库功能
26.丢弃和捡起指定物品ID触发增加支持显示物品属性信息
27.掉落提示增加支持物品属性信息查看：物品%ShowItem从[%Name]身上掉落在地图%Map(%X,%Y)处
28.修改首饰盒和神佑盒放入规则
29.修正其他几处细节问题

【2015-01-13更新:】
本次更新文件M2Server.exe
1.修正M2查看他人装备属性显示问题
2.修正M2天生暴击属性问题

【2015-01-12更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe、MirUpdateGate.exe、updateserver.exe、DBServer.exe、合区工具.exe、数据管理工具.exe、数据转换工具.exe
1.修改使用微端时登陆器自动创建不存在的文件夹
2.修改Graphics目录到PAK目录中保存，如：Resources/Graphics
3.修改MAPEFFECT命令支持同时播放多个不同序号特效
4.修改登陆器连接微端网关支持域名地址解析((((((((((((((((需测试)))))))))))))))))))
5.修改刷新包裹物品排列类型规则
6.修改微端程序Graphics路径并优化微端更新速度
7.修改CheckNewItemValue命令相关处理
8.修改播放烟花效果绘制图层
9.修正人物被挤下线聊天框没有提示的问题
10.修正合成系统给物品不带天生暴击的问题
11.修正天生暴击属性的一处问题
12.修正62.63.64增加穿戴负重显示的一处问题
13.修正捡起和丢弃物品名字<$PICKDROPITEMNAM>变量对假人无效的问题
14.修正师徒系统的一处BUG
15.修正非连击界面隐藏不了称号的BUG
16.优化网关数据处理
17.增加丢弃和捡起指定物品ID触发
18.修正9901及以上的新小地图一处错误
19.修正老界面技能经验被快捷键按钮遮挡的问题
20.修正英雄最高等级限制以及经验限制无效的问题
21.修正仿及时雨内挂自定义添加的药品退出游戏再进药品项没有自定义药的问题
22.修正带特效的物品在物品栏铸造框特效混乱的问题
23.修正包裹栏绘制有Light字段的物品时，有时候会出现错误
24.修正部分技能会出现卡特效问题
25.修正英雄宝宝不能升级的问题
26.增加NPC对话框支持物品图片以及展示属性
27.配置器增加：必备补丁(NewopUI.Pak)的名字可以自定义
28.增加宝石镶嵌系统
29.配置器登陆器默认选项增加：公告显示前显示资源加载进度，如果不集成情况下靠引擎发送数据过多时建议开启
30.参数设置-时间控制增加上马准备时间控制
31.扩展悬浮式装备显示框支持图片显示
32.修复其他细节问题

【2015-01-01更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe、RunGate.exe
1.扩展数据库 Anicount增加62、63、64类装备穿戴负重属性
2.修改地图参数NOTALLOWUSEITEMS提示为聊天框提示
3.修改英雄生肖盒的一处问题
4.修正SendCenterMsg 替换模式无效的问题
5.修正英雄攻击状态的一处BUG
7.更新网关封挂功能并完善多出细节
8.增加宝宝属性叠加功能
9.修复客户端无法创建纹理的错误
10.修正检测幸运值命令的一处BUG
11.内挂保护使用的物品支持配置器上自定义
12.修正关系系统的一处BUG
13.修正英雄经验分配的一处问题
14.扩展SETITEMEFFECT支持首饰盒和生肖盒并增加英雄操作命令H.SETITEMEFFECT
15.增加H.RestRenewLevel清除英雄转生数据的命令
16.增加英雄转生等级变量<$H.RELEVEL>
17.增加英雄可佩戴转生需求的装备(计算方式和人物一样)
18.修正元素属性怒气恢复无效的问题！
19.修正其他细节问题

【2014-12-10更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修正AddTextListEx命令错误
2.修正当主人快捷键命令让宝宝休息，月灵还是会打着怪物
3.修正魔龙教主的一处BUG
5.修正LineNotice.txt公告的一处问题
6.修正挂机捡物的错误
6.修正修正登陆器鼠标右键登陆器界面看不到按钮的问题
7.MON24-7增加物理攻击声音

【2014-12-09更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.优化非800*600分辨率下游戏地图数据刷新
2.修正月灵速度异常的问题(需更改DB具体参考说明书示范DB)
3.修正非连击界面长按F10的一处BUG
4.修改MAPEFFECT命令支持无限次数播放
5.增加地图参数DECGAMEPOINT进入地图后减游戏点（泡点）
6.完善63类宝石和53类宝石支持暴击等新增属性
7.修正客户端音效开关的一处BUG
8.修正SETRANKLEVELNAME命令的一处BUG
9.修正武器升级遗漏的一处细节处理
10.优化内挂挂机系统
11.优化客户端内存处理

【2014-12-06更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修正组队队友列表显示的一处BUG
2.修正客户端控制中“刷新包裹提示”选项不能保存的问题
3.修正非连击界面查看他人装备栏发型偏右的问题
4.修正合击界面（1.85， 1.76）装备信息随鼠标位置时查看他人装备显示的一处BUG
5.修正并优化了挂机几处细节
6.优化其它细节方面

【2014-11-26更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.叠加物品可以设置中爆部分数量
2.支持英雄穿脱装备触发：@HeroTakeOnXX @HeroTakeOffXX
3.改变人物当前模式支持英雄、命令： H.ChangeModeEx
4.增加调整英雄属性命令： H.ChangeHumAbility
5.魔龙教主新增加攻击方式及修正攻击特效BUG
6.DB支持MON41神兽2种状态
7.MON24-7及MON38-13怪物增加各状态的声音
8.CHECKUSEITEM命令增加支持检查首饰盒生肖盒
9.修正自定义怪物上版引起的一处BUG错误
10.增加内挂挂机功能(测试)
11.增加元宝转账目标名称变量支持：<$DEALGOLDPLAY>

【2014-11-18更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.怪物 MON23-3（81,101,223)增加音效，增加race=206以支持攻击方式；怪物代码改成 （206,101,223）
2.怪物 魔龙石碑（81,75,216)增加race=207以支持攻击方式；怪物代码改成 (207,75,216）
3.怪物 MON35-0（138,113,340）增加音效支持
4.魔龙教主（101,78,218）增加攻击方式及攻击特效，修正死亡物效错误，修正石化苏醒效果错误
5.修正MON26-6（123,106,256）召唤怪物错误
6.修正牛魔祭司火球攻击，缺少目标效果
7.修正Race=200的怪物，GM隐身或戴隐身戒指默认是的一个错误
8.修正M2上调技能威力倍数100-150以下 技能威力无效
9.修正自定义怪物发送到客户端有时候会延时，导致第一次上线后提示怪物没有配置信息
10.修正GM命令的复活命令会提示两次
11.修正清除宝宝命令有时会失效的问题
12.修正假人上线HPMP的百分比参数调整后重启引擎还原为60%的问题
13.修正自定义怪物走路特效播放不完整的问题
14.修正自定义怪物使用半月攻击的问题
15.修正自定义怪物血条偏移x,y输入框过小的问题
16.修改自定义怪物血条x,y坐标后，血条移动，但显血数字没动的问题
17.修正引擎一处报错

【2014-11-10更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.优化并修复多处不该存在的细节问题

【2014-11-08更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.关闭烈火剑法技能冷却提示
2.播放人物特效命令：PLAYEFFECT增加支持 X Y坐标
3.修改自定义UI多处细节
4.修改允许穿怪的勾选后的一处逻辑错误
5.修正自定义怪物的永恒冻结的一处错误
6.优化其他多处细节

【2014-11-03更新:】
本次更新文件MakeGameLogin.exe
1.修改SuperMoveMsg、SuperMoveMsg、SENDDELAYMSG、SendNewLineMsg命令支持自定义颜色
#if
#act
SuperMoveMsg 1 251 0 20 100 3 这个是{个人|253:0:1}屏幕信息~坐标在100||欢迎使用翎风世界传奇游戏引擎|| 引擎官方网站：||http://www.lfm2.com
2.优化其他细节！

【2014-11-02更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修正微端的一处细节问题
2.修正套装属性一处错误导致防全毒无效
3.修正自定义UI最下面透明时会出黑边
4.修正自定义UI血球位置修改无效
5.修正自定义UI聊天框高度较低时，聊天框文字显示行数过多
6.自定义UI增加血球右边的一竖列功能按钮Y坐标偏移及Y间隔
7.修改及时雨内挂雷达显示的一处细节问题
8.登录器增加客户端搜索功能（默认搜索修改为秒搜,原搜索修改到登陆器游戏设置）

【2014-10-31更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe、MakeScriptTool.exe
1.修正道士英雄的一处问题
2.修正加密插件DLL文件保存密码的一处问题
3.扩展Give命令使用
4.UPGRADEITEMEX命令增加是否显示升级信息
5.修复了程序个别参数不能保存的问题

【2014-10-29更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修正文字绘制纹理导致文字（NPC）乱码（需测试）
2.修正徒弟数量设置后不能保存的问题
3.修改心灵启示技能兼容普通登陆器

【2014-10-28更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe、合区工具、数据管理工具
1.修正禁止穿怪、穿人时候角色偶尔角色错位的问题
2.修正引擎一处报错
3.修正其他细节BUG

【2014-10-26更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修正人物的宝宝杀死其它人物不触发QF里的[@KillPlay]
2.修正SENDTOPCHATBOARDMSG命令前面带玩家名字的问题
3.修正护身血条显示的一处问题
4.修正丢物品会丢到NPC脚下
5.修正宝宝不攻击练功师的问题
6.修正系统时间：<$DATETIME>变量秒显示错误
7.修正一处BUG导致角色错位
8.怪物属性扩展Envir\MonSpAbilList.txt增加冰冻、蜘蛛网

【2014-10-23更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修复引擎一处报错
2.优化客户端几处细节

【2014-10-22更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修正导致称号图片绘制失败一处问题
2.修正自动寻路提示的一处BUG
3.修正一个客户端报错
4.修正配置器上窗口最大化无效
5.未勾选禁止英雄挂机前提下英雄不能挂机的问题
6.优化客户端占用内存
7.增加控制NPC点击时间参数和修正控制点击NPC对话框按钮时间无效
8.修正道士的召唤技能时填怪物名错误时，无法定义哪里错

【2014-10-19更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe、DBServer.exe、WZL编辑器
1.修正WZL编辑器导出加密后的pak无法导出空白图片
2.修正绘制问题：技能 比如 雷电术 火球术 等目标效果偏左以及物品鼠标需要移动到相当准确才可以显示物品名字
3.修正穿戴护身戒指、复活戒指后，满MP受到攻击，当攻击伤害>MP，还有HP时，会复活
4.自定义怪物自定义怪中的爆炸播放效果那增加效果始终跟随目标的选项
5.师徒系统增加几项变量脚本
6.增加强制组队命令：@CreatGroup 用户名称和获取组队成员数量命令
7.增加私人变量：
U0-U49 (数字型) 可保存。（存放在人物数据库Mir.db里面）、数值正负21亿
T0-T49 (字符型) 可保存。（存放在人物数据库Mir.db里面）、字符长度限制100（1汉字为2字符、1字母为1字符）
8.增加DBServer扩展工具-加U变量和T变量

【2014-10-17更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修正上版遗漏修复的一些问题
2.修正攻击自己英雄的宝宝，名字会变灰的问题
3.修正怪物不会攻击英雄召唤出来的宝宝的问题
4.修正内挂勾选了毒符互换，幽冥火符不会自动换符的问题
5.修正M2客户端设置勾选有双龙斩、龙影剑法但内挂上还是没有这两个选项
6.修正自定义怪物生成登录器配置文件保存的一处问题
7.修正复活相关的一处问题
8.修正GM命令转职会触发@PlayLevelUp
9.修正在MAPINFO文件中添加盛大客户端的音效文件的一处问题
10.修正游戏中角色（自己）显示靠上和靠左的问题
11.修正DX绘图的一处BUG
12.增加多师徒系统和一些相关命令
13.修复并完善其他细节问题

【2014-10-10更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe、DBServer.exe
1.修复英雄守护状态不能合击的问题
2.优化微端更新当前区域内素材时间
3.修复DBserver.exe人物数据管理按钮无效的问题
4.修复勾选客户端红绿毒互换无效以及相关提示问题
5.修复半闭免助跑后，按住右键不放直到不跑发技能，可达到免助跑
6.修复附加属性点面板，在增加属性点时，有时会造成上下限数值显示错误
7.修复登陆网关选了专用加密后游戏内不可以修改密码的问题
8.修复自定义怪系统制作出来的怪死亡后地上的尸体，在玩家小退再上线后会发现怪物尸体会跳动的问题
9.修复Envir\MonSpAbilList.txt扩展怪物属性，物理攻击减免有问题.近身物理可以减免.隔位攻击(如刺杀等)不能减免 龙影剑法 逐日剑法等也不能减免
10.修复火墙伤害时间的一处问题
11.增加骑马时候声音（程序包内第三方补丁文件内查看）

【2014-09-29更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe、LoginSrv.exe
1.修复Envir\MonSpAbilList.txt扩展怪物有两个属性无效的问题
2.修复仿及时雨内挂保护吃药栏毫秒的秒字被遮挡了一半的问题
3.修复setautogetexp给玩家经验后，当玩家的等级到达指定等级时，不能触发QF里的@PlayLevelUp的问题
4.修复LoginSrv.exe——》选项——》基本设置——》测试模式去掉勾选，保存后重启勾选仍然存在的问题
5.修复英雄在守护状态下无法释放合击技能的问题
6.修复配置器分辨率设置成1024*768-1024*768；但还是会包括800*600的分辨率的问题
7.修复绑定叠加物品相关问题
a、包裹中有绑定的苹果（叠加数量未达到最大数量），用npc命令或管理员命令创建一个苹果（非绑定），会叠加包裹中已有的绑定苹果上面
b、包裹中有绑定的苹果，和未绑定的苹果，将绑定的苹果丢掉，再捡起，会叠加到不绑定的苹果上面
c、解包绑定苹果时，会生成未绑定的苹果
8.修复引擎麻痹控制中的选项失效的问题、前提勾选客户端内挂控制选项：防止石化
9.修复十步一杀会和攻击目标重叠
10.修正自定义怪物在未勾选“石化苏醒计算方向”时，自定自怪发生攻击后永远背对方向
11.自定义怪物优化多目标播放效果（多目标播放更同步）
12.自定义怪物增加目标播放效果始终跟随目标选项：“效果始终跟随目标”
13.M2客户端控制——》功能选项2——》增加选项“显示新护身血条”，默认为不勾选
14.默认内挂和及时雨内挂、增加保存玩家自己添加滴物品（捡起、提示、特殊）删除列表物品只允许删除玩家添加的。引擎发送或集成不允许删

【2014-09-26更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修复十步一杀允许穿越障碍勾选后人物叠加到目标身上的问题
2.修复CHECKSLAVELEVEL命令无效的问题
3.修复仿及时雨内挂不能保存配置的问题
4.修复并完善自定义怪物的几处问题
5.扩展马牌数据库Expend2控制（详细见说明）
6.修复其他BUG

【2014-09-24更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修复全屏游戏退出后登录器不显示背景
2.修复首饰盒、神佑袋中的物品不显示套装属性
3.修改自身技能不受魔法施展距离控制
4.增加npc命令：DelGuildMember 删除行会成员

【2014-09-23更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修复角色游戏中出现莫名出现中毒状态
2.修复NOHORSE禁止骑马参数无效的问题
3.修正并完善其他细节问题

【2014-09-22更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe、DBServer.exe
1.修复已知引擎报错
2.修改读取和保存人物数据（需更新DBServer.exe）
3.修复其他细节问题

【2014-09-21更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe、微端程序、RunGate.exe
1.修复微端自定义PAK目录，更新时当PAK文件不存在不会自动创建
2.修复微端不更新声音文件
3.修复人形怪不能挖取物品问题
4.修复内功怪物目前只获取内功经验的问题
5.修复自定义特效在使用连击或倚天劈地技能时不会显示特效的问题
6.修复技能鼠标提示不能换行，使用符号 \ 换行无效的问题
7.修复技能双龙斩召唤不消耗MP的问题
8.修复自定义怪物特效2显示错误的问题
9.修复不勾选“英雄计算武器速度”后，召唤出的英雄还有武器速度
10.使用GM命令调整人物经验会触发QF升级脚本
11.群体施毒术威力强化同步施毒术
12.登陆器快捷键ICO图片同步支持EXE格式（图标必须是32*32，256色)
13.iocp网关在线人物鼠标右键增加复制机器码 和复制IP地址
14.增加登录器集成自定义怪物配置文件
15.修复并完善其他细节问题

【2014-09-15更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修复了自定义怪物关于死亡特效的问题
2.修复了自定义怪物设置吸蓝，攻击目标不掉蓝的问题
3.自定义怪物增加16方向攻击
4.扩展PlayImg（增加绘制模式和备注文字）
5.冰冻，冰封，蛛网，0防御，0魔御 增加/修改状态提示，并增加时间显示 （如要显示时间，请修改或删除sting.ini中的配置【时间用%d表示】）

【2014-09-14更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe 、GameCenter.exe
1.修复了并完善自定义怪物
2.修复了SETITEMEFFECT 命令增加特效不及时显示的问题
3.修复了英雄攻击加速属性佩戴装备后属性栏不及时更新的问题
4.修复了安全区不能攻击自己宝宝的问题
5.修复了护身符会掉持久的问题
6.修复了倚天辟地攻击不到人形怪的问题
7.修复了配置器独立武器和衣服PAK文件读取路径问题
8.修复了清除人物属性点命令会触发QF中升级触发的问题
9.修复了使用包裹毒符不会自动切换红绿毒的问题
10.修复了旋风斩没有声音的问题
11.修复提示[TPlayObject.ClientHit] 人物(xxxx)攻击延时
12.修改群毒威力调用施毒术
13.修复了挖取提示为全服公告
14.修改称号颜色不受M2里客户端控制-装备信息显示-物品颜色控制
15.控制台增加显示当前游戏区名称
16.扩展播放人物特效 PLAYEFFECT 命令
17.增加血灵教主相关怪物DB数据
18.修复了挖取提示为全服公告
19.NPC血条排除代码为15的 怪物
20.控制台增加显示当前开区名称

【2014-09-03更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe
1.修复了宝宝死亡后名字颜色的问题
2.修复了幽冥火符的伤害值在道术超过2000的情况下造成的伤害为固定的2770的问题
3.修复了假人不攻击隐身状态玩家的问题
4.修复了修复开天斩不流畅的问题
5.修复了追心刺技能的图像错位的问题
6.修复了CheckTakeOffItem命令无效的问题
7.顶戴花翎功能扩展播放顺序参数设置
8.登陆器注册界面问题和答案增加长度限制
9.引擎游戏速度限制增加开关控制是否开启速度控制,关闭后请使用网关控制游戏速度
10.增加检测服务器最高属性人物命令
11.增加OPENGAMESHOP打开游戏商铺命令

【2014-08-24更新:】
本次更新文件M2Server.exe、 MakeGameLogin.exe、LoginSrv.exe
1.修复自定义怪物攻击附带的效果里面，0防御勾选后，魔防和防御会同时减少为0
2.修复自定义怪物推动无效
3.修复当服务器自定义怪物超过152个时，服务器会卡死
4.自定义怪物增加自杀式攻击选项（用于实现类似幻影蜘蛛召唤的小蜘蛛）
5.自定义怪物支持自定义血条
6.注册ID修改最小为3位
7.修正登录器误报检测到外挂
8.增加npc命令CheckOnHorse检测是否处于骑马状态
9.增加npc命令CheckKillByHum检测是否被人物杀死
10.扩展启动次数参数：SETONTIMER 定时器索引(0-255) 定时间隔（单位为秒）3(为空默认为不限次数，可以设置定时器启动次数)
11.修正非连击界面下无法进行双人骑马，Ctrl+L邀请无效，无提示不出对话框
12.修复在攻击目标跑动时，人形怪倚天劈地技能有时打不中目标
13.修复在全体攻击模式下，无法攻击自己的宝宝
14.修复宝宝死亡后名字颜色为白色，应该和未死亡前一样的颜色
15.修复杀人后，武器诅咒有时候会出两次
16.登陆器配置器增加4个选项
17.IOCP网关增加几个完善项
18.增加变量 杀死自己的怪物：$MonKiller 杀死自己的人：$HumKiller
19.修复时装不能在npc修理
20.登录界面支持png
21.盾牌在非连击界面下无法看到对方装备栏的盾牌
22.增加清除人物经络命令：ClearAllPulse等级和英雄经络等级命令：H.ClearAllPulse

【2014-08-10更新:】
1.修正KillMonName变量无效的问题
2.修正英雄攻击模式的一处BUG
3.修正骑马遗留一处关于一步三格问题
4.修正登陆器不搜索C盘客户端的问题
5.修正英雄的宝宝打的怪没有经验的问题
6.修正人形怪在安全区就不会被宝宝攻击，同时也不会攻击别人
7.修正如果自己站在召唤的人形怪宝宝的刺杀位，人物会被自己宝宝给砍到
8.修正M2查看人物属性修改后保存不能超过2E金币的问题
9.修正内挂自动捡起勾选后捡起其他物品提示过于频繁的问题
10.修正CHECKONLINE命令无效的问题
11.修正<$RUNDATETIME>开区间隔时间变量无效的问题
12.修改网关报错问题
13.修复登陆器内存处理一处问题导致游戏花屏
14.自定义怪物增加几种攻击模式
15.自定义怪物添加自定义声音支持
16.优化并完善其他小细节

【2014-07-27更新:】
1.修正NPC命令转换职业(CHANGEJOB)会触发QF中的升级触发
2.CheckNewItemValue位置增加OK框位置支持
3.增加 <$DEALGOLDPLAY> 交易对像用取对面人物名：GetOppositeHumName变量
4.修正人物正在采集,小退的话,不会关闭这个采集框
5.修正GMEXECUTE ClearMon 调用有问题的.如果地图代码是字母开始的不能执行.
6.修正刺杀技能伤害计算错误（隔位刺杀）
7.修正道士的红毒(减少双防)对怪物无效.对人物和弓箭有效.
8.修改英雄为不主动攻击鸡鹿羊等反击型的怪物
9.修正坐骑L-Horse2.Pak错误的问题
10.修正RandomKillMon随机杀怪数量不对
11.修正登录器配置器读取规则后登陆器优先读取的一处问题
12.修正设置最高攻击幸运值无效（依然最大为9）的问题
13.称号相关触发修改（详见称号说明）
14.增加自定义怪物系统

【2014-07-09更新:】
1.更新IOCP运行网关程序
如要运行网关启用多线程模式，请在控制台中---> 配置向导 ---> 游戏网关 ---> 勾选“使用多线程网关”
2.修正[网关]有会时候会把人物卡住以及人物站着不动有时候会掉线
3.修复剩余MP与技能消耗点数相等时，提示没有足够的魔法点数
4.修复非合击界面，马牌会戴上勋章位置，但点击骑马会显示未戴马牌的提示
5.修复[双龙斩]技能不加技能熟练点
6.修复人形怪使用灭天火技能对目标无伤害
7.修复P0-P999 (私人变量，数字型)关闭对话框重置为0
8.修正蛛网(特戒)对人形怪使用无任何减速
9.修复自定义对话框有时会变成默认对话框
10.修正魔法躲避的首饰在登陆器里显示是魔法防御
11.修复店铺超过5个物品不能翻页
12.修复在NPC里重新分配人物附加属性点RESTBONUSPOINT命令会触发QF中升级触发
13.修正地图代码为D701、H301等字母打头MAPMOVE无效
14.优化pak读取png
15.修复弓箭怪来回走来走去不打目标
16.修复查看等级属性会触发@PlayLevelUp
17.修正交易金币文字改为居左显示
18.修正NPC修理上面的标题改为居左显示
19.修正野蛮冲撞必须大于数据库设置的等级时才涨经验
20.修正战士刺杀剑术0、1、2、3级伤害威力无加成
21.修复当数据库把月灵攻击速度设置为0时，攻击目标后导致M2直接重启
22.修正界面选择合击时，M2设置[关闭NPC对话?按钮]游戏中点击NPC按F10，NPC对话框又显示出
23.修正SendCenterMsg如果连续发送，可以达到刷屏的效果
24.修正NPC交易、修理、卖物品时，物品栏坐标不统一问题
25.修正技能冷却时间，全部显示在屏幕左上角，如经验显示。
26.修正并优化其他相关细节

【2014-06-06更新:】
1.修正CHECKTEXTLIST ..\QuestDiary\装备升星\战士装备.txt <$BOXITEM[0].NAME> 此命令，无法检测装备名字是否在文本
2.修正 健康公告板，字写多了就不能显示的问题
3.修正重新加载NPC后，“交易NPC配置”中的非城堡NPC会变成城堡NPC。
4.修正addbatch ns0110 会飞到比奇，addbatch 可指定坐标
[@移动]
#IF
#act
batchDelay 3
addbatch 1
addbatch 2
addbatch 3 333 333
batchmove

5.取消三方马上的人物外观由source来控制，改为衣服的Horse控制；不穿衣服时，男为0，女为1
例如：当衣服的Horse段为6，骑马时就显示L-HumHorse.wil中的第6个外观

6.setautogetexp在最后增加一个参数（泡点有效时间[单位：秒]）

时间 经验 是否安全区（0为任何地方） 地图号（*为任何地图） 是否允许英雄分配经验（0为禁止） 是否允许将经验存放聚灵珠（1为允许，留空或0为不允许） 泡点有效时间（秒；为0或空表示泡点一直有效）

【2014-06-04更新:】
1.修复人形怪不能挖物品的问题
2.修复宝箱叠加物品的问题
3.修复登录器误报外挂
4、LineNotice.txt支持字号设置
[253,0]自定义字体颜色公告！
<252,255>窗口顶部滚动公告！
格式1：[253,0]聊天框公告 0为背景色 253前景色
格式2：<252,255,190> 窗口顶部滚动公告,255为背景色 252前景色 190为背景条颜色（背景条颜色留空为不显示）
格式3：<252,255> 9 公告内容 255为背景色 252前景色，9(9两边用tab键隔开)为公告字体大小(9号不加粗)
格式4：<252,255,190> 10b 公告内容 255为背景色 252前景色 190为背景条颜色，10b(10b两边用tab键隔开)为公告字体大小(10号加粗)

【2014-05-31更新:】
1.修复客户端聊天框输入文字错误
2.优化登陆器搜索客户端目录速度
3.优化客户端pak读取资源一处存在的问题

【2014-05-29更新:】
1.修复叠加物品被客户端利用的问题
2.修复数据库价格大于65535的物品，在NPC处购买显示价格错误
3.修复叠加物品在NPC处购买价格错误
4.修复修正地图参数：NOHORSE 无效的问题
5.修复登陆器只读取主列表而不读取备用列表的问题。
6.完善自定义UI的几处细节问题
7.修改法师分身死亡后为直接消失
8.修改登陆器优先读取列表然后才是内嵌网页
9.增加骑马可捡物品（双人骑马的话被邀请的不可以捡）
10.增加调整人物金币数量 命令：GOLDCOUNT 控制符(=,+,-) 金币值
11.增加称号功能
12.护身物品增加伤害吸收 MagicShieldItemList.txt 第三个参数；如
护身戒指 40 20
当受到100的攻击伤害时，吸收20，即还有100 - (100 * 20%) = 80的伤害，掉蓝80 * 40% = 32，掉血 80 - 32 = 48
13.完善并修复其他细节问题

【2014-05-21更新:】
1.修正并完善多处细节问题

【2014-05-19更新:】
1.修正几处细节问题

【2014-05-18更新:】
1.修正WZL编辑器批量导出PAK格式文件无法导出空白图片问题
2.修正关闭声音按钮不流畅的问题
3.修正地上物品鼠标位置偏上的问题
4.修正一处逻辑错误导致引擎报错（非本地图角色）
5.修正引擎一处访问不一个不存在对象的SearchViewRang报错问题
6.修正法师开盾上马盾位置仍然是人物站地面上的位置，双人坐骑，骑马带另外个人，另外个人会出现卡屏情况
7.修正技能ID 201 -210强化后无图标以及图标错乱的问题
8.修正UI几处错误
9.修正治愈术、群体治愈术技能的一处错误
10.修正护身血条相关的一处错误
11.修正设置绑定物品GiveStateItem命令对于叠加物品使用的问题
12.修改创建自定义OK框下一页物品会自动返回包裹的问题
13.增加检测检测玩家窗口模式大小的命令
14.增加护身类物品（Shape 118）可再MagicShieldItemList.txt的自定义控制
15.优化并完善其他细节问题
16.扩展UnbindList.txt针对叠加物品支持
;强效金创药为叠加物品，最大叠加数99
;
100 强效金创药 //// 这里解开会有6个叠加数为1强效金创药（原始默认）
100 强效金创药 16 //// 这里解开16个叠加数为99的强效金创药(叠加)

【2014-05-06更新:】
1.修正PAK格式真彩地图卡的问题
2.修正人物移动地砖会更随移动（暂时关闭骑马一步三格待下版优化）
3.修正RECALLMOB 使用此命令召唤的BB的一处问题
4.修正炼药NPC点击炼药后药品上会出现 X56的字样
5.修正收取英雄背包命令H.TAKE无效的问题
6.修正MONGENEX；范围无法设为0的问题
7.修正ROUPMAPMOVE 可组队传送，但组内所有成员均无法触发脚本的问题
8.修正需要声望才可以穿戴的装备，当声望不足时，装备提示没有显示红色 （转生等级)
9.修改NOMANNOMON 智能刷怪，当地图无人时清理怪物，有人时重新刷怪；该地图参数无效，M2已经钩选智能刷怪设置，但依然无效的问题
10.修改喝祝福油效果及时刷新到客户端（原官方为需要拿下显示、不知道那个提交要修改为这样...）
11.修改PLAYEFFECT指定播放次数65535为永久播放（1-65534为指定时间）
12.增加停止人物特效播放命令：StopPlayEffect，参数和 PLAYEFFECT 一致
13.增加清空人物特效播放命令：ClearPlayEffect
14.战士技能彻地丁，增加选项“允许空目标攻击”
15.增加NPC命令: 收英雄 HeroLoginOut
16.更新合区工具、数据管理工具、提供人物数据库升级工具（将0427前引擎DB数据扩展到最新引擎支持）

【2014-04-30更新:】
1.修正人物切换地图有时候看不到怪物不攻击，只掉血（需测试）
2.修正穿人控制里面，设置安全区不受控制，穿不了英雄的问题
3.修正关闭显示神秘人，英雄如果带着斗笠上线依然为神秘人，取下重带后不显示神秘人的问题
4.修正道士英雄攻击目标为不优先上毒得问题
5.修正毒物躲避通过套装属性增加无效果的问题
6.修正战士英雄隔位打人不掉血的问题
7.修正骑马一步三格绘图的一处问题
8.修改TakeBagItem 金币/元宝/经验/泡点增加的提示文字放在string.ini中；为空表示不提示
9.修改@mob 怪物名字 数量 等级，怪物颜色与宝宝颜色一致

【2014-04-27更新:】
1.修正自定义UI不做修改生成登陆器后1.76、1.85界面技能图标偏移的问题
2.修改SendCenterMsg命令坐标位置下调
3.修改LineNotice.txt公告文件顶部公告扩展支持是否显示背景
4.修改十步一杀技能为可选择穿障碍物
5.修正排行榜的部分按钮也无法自定义图片
6.修正商铺购买叠加物品没有判断包裹空间是否够用
7.修正列表信息2中的合成后给予叠加物品不会自动叠加
8.修正Give命令叠加问题
9.修正区域性地图绘制花屏问题
10.修正地图NPC遮挡的问题
11.修正自定义OK框的几处错误
12.修正女法师、女道士选择角色时会偏移
13.修正特殊属性200-209需求数据库字段AniCount和Shape相反的问题
14.修正并优化及扩展骑马相关功能
15.修正拍卖行中特效错乱的一处问题
16.修正NPC对话框切换的一处问题
17.修改地图魔法事件对宝宝无效
18.修改String.ini中等号后面为空则不提示信息
19.修改公告板文字行间隔调整
20.首饰盒及生肖盒增加装备位置以及变量
21.装备条件数据库字段Need条件10、11、12、13增加需求显示
22.集成登陆器：物品备注、内挂捡起、套装备注修改路径至Resources/data
23.配置器增加物品快捷栏编号坐标
24.配置器增加自定义元素新属性文字
25.配置器增加登陆界面验证码框坐标修正
26.聊天框文字 获得xx点经验改为 xx 经验值增加
27.增加神佑袋（十二生肖）功能
28.客户端控制，功能选项2增加是否开启刷新包裹提示
29.【活动日记】按钮增加QF脚本触发命令.(@ActionLogClick)
30.技能数据库魔法编号为：[45]灭天火和[57]噬血术增加使用间隔时间
31.修复并完善其它细节...

【2014-04-15更新:】
1.修正群毒无威力的问题
2.修正商城购买叠加物品(物品的数量设置为多个)的错误
3.修正修正Make指令制造叠加物品时，数据多于最大叠加数量制造数量不对的问题
4.修正生成器打开UI不做修改生成自定义UI，显示错误的问题
5.修正商铺购买叠加物品不扣元宝
6.修改强化灵魂火符有一定的几率触发成裂神符

【2014-04-14更新:】
1.修正自定义血条的几处错误
2.修正攻击伤害，伤害吸收，魔法防御当伤害超过一定的值时计算错误
3.修正离线挂机命令 SETOFFLINEPLAY ON/OFF
4.修正检测当前人物是否佩带指定物品 CHECKITEMW命令无效的问题
5.修正 <$map>变量的一处错误
6.修正物品数据库分类号为28马牌、63宝石、65军鼓、SHAPE字段添加特殊属性编号无效问题
7.修正客户端的一处兼容性错误
8.修正CHECKNEWITEMVALUE命令的一处问题
9.修正登录器远程无法访问列表地址时等待时间过久的问题
10.修改保存复活时间控制对英雄进行关联
11.增加TAB键盘是切换小地图与获取角色名控制
12.M2中物品装备的极品几率增加分类号22的极品控制
13.完善叠加物品的一处问题
14.配置器增加人物框的名字调整位置功能
15.配置器增加NPC对话框文字、物品框位置坐标调整功能
16.自定义UI增加Ctrl + 方向键 （移动控件1个像素），Ctrl + Shift + 方向键（移动控件10个像素）
17.完善自定义UI的多处不可移动调整的问题
18.完善D语言API插件获取图片函数的一些处理

【2014-04-08更新:】
1.修正掷斧骷髅无血条的问题
2.修正地图魔法触法事件无魔法特效的问题
3.复活属性增加保存复活时间选项
4.修改血条保存到NewopUI.Pak 170-176详见NewopUI说明

【2014-04-07更新:】
1.修正配置器部分设置勾选后无效的问题
2.修正传送门NPC播放时快时慢的问题
3.修正英雄增加多倍攻击、经验不提示的问题
4.修正M2内挂取消了英雄持续开盾和副英雄持续开盾在游戏中还显示的问题
5.UI编辑器器增加是否显示时间选项（屏幕右下方）
6.UI编辑器器增加自定义修改攻击模式文字

【2014-04-04更新:】
1.修改无限仓库发送数据包数量
2.修正引擎上元素排列顺序错误的问题
3.修正默认内挂帮助显示不出内容的问题
4.修正StdMode分类号25会获取元素属性的问题
5.修正地图参数CHECKQUEST执行任务脚本命令无效的问题
6.修正盾牌特效不跟随装备栏移动的问题
7.修正TakeBagItem命令偶尔会产生假象的问题
8.重新封装并深度优化HGE绘图引擎
9.增加首饰盒内饰品可选是否计算套装属性

【2014-03-17更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修正登陆器兼容老版普及型引擎仓库的一处问题
2.修正可能导致登陆器白屏的已知问题
3.动态地图ADDMAPGATE有时间不会删除传送门的问题
4.修改CheckMonMap命令为只检测怪物不检测宝宝
5.修改窗口游戏标题显示
6.修正属性分配点增加的HP，一些情况下会恢复原始的问题

【2014-03-06更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修正偶尔正常游戏时偶尔出现读取人物数据失败（需测试）
2.修正自定义OK框的一处提示问题
3.修正包裹满后金币无法拾取的问题
4.修正偶尔客户端小退到角色界面和死亡均没有相应的背景音乐的一处问题
5.修正包裹里的金刚石显示和属性框里的金刚石不能及时显示剩余数目问题.
6.修正商铺关于购买数量扣费的一处问题.
7.修改功能设置-宝宝升级 增加0级颜色控制.
8.修改屏幕显示升级经验文字描述.
9.修改客户端内核描述
10.修改其它部分细节问题

【2014-03-05更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修正无限仓库的一处问题
2.修正人物死亡后看不见GuildNoticeMsg和SENDMSG的全服广播的一处问题
3.修正老登陆器原地复活出现麻痹问题
3.修正裂神符自动换符的一处问题
4.修正老登陆器不能正常用仓库的一处问题
5.修改火墙不计算在魔法冰冻、魔道麻痹之内..
6.修正其它细节问题

【2014-01-17更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修复英雄背包物品丢弃需点2次的问题
2.修复道法英雄关于安全区攻击的2处问题
3.修正在优化怪物时怪物处理的遗漏修改导致怪物缓慢的问题
3.修正封包处理的几处BUG导致游戏大卡或无法小退的问题
4.修正商铺物品描述不能带空格的问题
5.修正英雄锁定移动目标过于困难的问题
6.修正武器升级成功后背包存在假象的Bug
7.修正小退进入游戏后偶尔会自动小退并卡屏的Bug
8.修正商店出售和购买物品无金币声音
9.修正老登陆器在游戏中封包处理的一处问题导致角色变色并不可移动的问题
10.修正道法分身在安全区可攻击安全区外目标的一处问题
11.修正登陆器检测到加速器只提示不关闭游戏的问题
12.修正镖车在休息状态下被攻击无伤害和死亡效果的问题
13.修正MONGENEX不支持多行刷怪的问题
14.修正SetBodyColor人物身体变色在线永久有效果参数无效问题
15.修正英雄在战斗时更换武器不及时显示更换武器外观的问题
16.修改声望+等级装备当不符合佩戴等级的玩家 查看装备时信息显示红色
17.增加进入游戏时确定公告支持人物ID和名字变量显示
18.增加人物高等级经验不变脚本命令：HighLevelKillMonFixExp 时间

【2014-01-08更新:】
本次更新文件 :全套程序
1.修正NOMANNOMON地图参数智能刷怪无效问题.
2.修正新属性文字显示错误的一处问题
3.修改军鼓装备位置为：14
4.修改地图参数Safe显示"安全"图标
5.修正升级触发增加的刺杀剑术不会自动开启问题
6.修改引擎控制取消Shift开关后游戏中默认为关闭开关
7.修改增加持久的一处问题方便制作捆药绳
8.修改MON35-2金龙怪物DB，支持三种攻击效果
9.完善MON38部分怪物的细节
10.优化登陆器搜索客户端速度
11.登陆器增加读取本地列表,可集成在登陆器中.
12.再次改进游戏开宝箱功能一些细节处理,String.ini中BoxKeyError删除生成新格式
13.修正英雄在安全区攻击状态下不主动攻击怪物的问题
14.修正引擎在老客户端情况下人物偶尔出现麻痹状态的问题
15.修正rungate网关处理数据的一处BUG
16.修正微端网关一处问题并完善微端网关
17.修正道法英雄魔法攻击准确度以及遇到障碍的问题
18.修复并完善其他细节

【2014-01-06更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修正宝宝跟随以及人物复活后打怪的一处问题.
2.修正清理宝宝命令清理不了带复活装备宝宝的问题
3.完善宝箱几处细节
4.增加禁止挑战地图参数：NOCHALLENGE
5.增加QF里挖取怪物时触发 [@ButchCloneItem鸡]
6.内挂控制增加SHIFT开关显示与隐藏
7.改进脚本发千里传音功能
8.改进元宝使者几处细节处理以及增加税收控制
9.改进特殊条件佩戴装备要求（NeedLevel可使用APPLE引擎工具）
10.增加怪物MON38怪物DB
11.修改首饰盒资源图片到NewopUI.Pak
12.配置器增加是否显示游戏健康公告
13.修正引擎几处报错
14.修复其他小细节

【2013-12-27更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修正SetMonColort永久有效一处错误
2.修正开天斩攻击距离的问题
3.修正近身砍龙影剑法没有任何伤害的问题
4.修正法师英雄锁定的一处错误
5.修正道士英雄使用技能控制处理的一处错误
6.修正SETITEMSLIGHT首饰特效装备栏无效果的一处错误
7.增加调整人物、英雄内挂等级GM命令
8.增加4级魔法盾(技能等级为4即可,防御威力共用强化盾)
9.修复引擎一处报错
10.完善其他细节问题

【2013-12-26更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe、LoginGate.exe、DBServer.exe
1.修正隐身模式下人物变黑的问题
2.修正英雄锁定目标显示怪物名字的一处问题
3.修正英雄锁定目标追杀攻击无效的一处问题
4.修正狮子吼允许麻痹人物选项不保存的问题
5.修正引擎部分命令不能修改保存和无描述的情况
6.修正脚本震动的一处问题导致客户端崩溃的问题
7.修正1.76界面查看他人装备显示的一处问题
8.修正并完善元宝使者功能
9.修正网络连接差客户端看不到背包和技能的一处错误
10.修改叠加物品颜色和显示位置
11.修改英雄不主动攻击非锁定主人或自身怪物
12.登陆网关增加限制客户端版本号登陆
13.引擎-性能设置恢复压缩数据包发送到网关
14.优化怪物对Cpu的占用
17.元素增加命令调整增加元素属性时间控制
19.NeedLevel增加同时限制等级和声望代码
20.特修命令前增加检测可修装备数据库价格统计、价格*引擎设置的特修价格倍数
21.修正1-9级宝宝名字颜色的一处错误
22.配置器增加shift开关选项
23.修复其他细节错误...

【2013-12-21更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修正SetClientBuff倒计时超过1小时出错的问题.
2.改进夫妻在线检测命令
3.气血石按点数增加HP/MP控制
4.修正引擎几处报错
5.完善其它若干细节问题

【2013-12-20更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe、GameCenter.exe、合区工具
1.修正配置器自定义PAK目录的一处问题.
2.修正月灵攻击速度调整无效的问题
3.修正沙巴克攻城期间对商人停止营业的一处处理
4.修改非连击界面的英雄图标以及其他英雄相关完善和修复
5.修改沙巴克攻城提示到String.ini自定义修改
6.修改攻城期间英雄名字同主人名字一个颜色
7.修正控制器自定义清理的一处错误
8.修正中蜘蛛网提示修改不保存的问题
9.修正GM在观察模式下的一处错误
10.修正人物跑步穿-安全区不受控制的一处错误
11.修改麻痹戒指和魔道麻痹目标人物被麻痹提示与施毒术分开提示中毒
12.技能数据库增加MaxupgradeLv字段控制技能栏强化技能图标多少重后不再显示升级按钮
13.修改合区工具合并文本为添加文件夹方式
14.增加单独隐藏副将英雄按钮选项
15.完善改进其它相关细节

【2013-12-19更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修正英雄首次使用逐日剑法的一处问题.
2.修正雷霆剑法单目标经常发挥不出来的问题
3.修正开天斩轻击不增加技能点的问题
4.改进英雄在非休息状态下的相关动作处理
5.聊天框彩色信息增加文字描边
6.增加脚本加密插件工具
7.增加合区数据提取工具
8.完善微端网关的几处BUG

【2013-12-17更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修正非连击界面无法看到衣服属性.
2.修正非连击界面英雄图标文字颜色
3.修正非连击界面查看他人、英雄装备不显示斗笠信息
4.修正非连击界面强化技能升级按钮过低挡住技能点的问题
5.修改连击界面刷新按钮只显示元宝
6.增加1.85界面英雄装备栏
7.道法分身还原为需要设置快捷键才使用技能（只使用设置快捷键的技能）
8.完善MON36、Mon37怪物DB代码
9.修改冰冻、蜘蛛网、石化提示信息在String.ini自定义设置修改
10.增加检测夫妻一方是否在线和是否在同一地图的脚本命令
11.增加GETNEWITEMVALUE获取元素增加值命令
12.增加 H.CHECKTRANPOINT、H.CHANGETRANPOINT、H.checkmagicname、 H.CHANGEEXP等英雄相关多级命令
13.修复登陆器窗口模式时使用其他登陆器全屏游戏导致窗口白屏问题（需测试）
14.优化引擎处理代码并完善其他小细节

【2013-12-12更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修正真人打假人不变灰名也不红名的问题.
2.修正假人PK或跑步时经常消失和经常站一个地方不动的问题
3.修正法师分身攻击自身的问题
4.修正道、法分身需要设置快捷键才使用技能问题
5.修正人形怪对攻击速度处理的一处问题
6.修正摆摊引起报错的一处错误
7.修正CHANGESPEED对攻击速度计算的一处错误
8.增加支持MON36、MON37怪物（需测试完善）
9.增加假人支持开天斩、逐日、倚天辟地
10.改进英雄在非休息状态下的相关动作处理
11.游戏参数-PK控制增加假人杀人获得PK值控制，设置0为不增加PK值

【2013-12-11更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe
1.修正套装隐身属性自身没有隐身特效.
2.修正内挂吃回城卷会吃掉卷轴的问题
3.修正1.85界面顺序的问题
4.修改新增强化技能图标
5.技能魔法-强化技能增加冰咆哮控制参数设置
6.强化召唤骷髅、神兽增加召唤等级控制
7.增加几条英雄相关多级脚本，如H.TAKE
8.修正战士分身使用技能使用刺杀和半月需要主人开启的问题
9.增加人形怪、英雄可以使用开天斩、逐日剑法和倚天辟地
66,英雄开天斩,0,23,0,0,0,8,0,0,0,34,50,36,100,40,200,44,400,48,800,52,1600,57,3200,62,6400,68,12800,74,25600,81,51200,89,102400,97,204800,106,409600,116,819200,0,英雄,3,
114,英雄倚天辟地,2,55,0,10,20,0,12,25,99,60,100,60,200,60,300,60,400,60,500,60,700,60,800,60,900,60,1000,60,1200,60,1400,60,1600,60,1800,60,2000,60,2500,0,英雄,3,
56,英雄逐日剑法,0,53,0,0,0,7,0,0,0,35,50,37,100,40,200,44,400,48,800,52,1600,57,3200,62,6400,68,12800,74,25600,81,51200,89,102400,97,204800,106,409600,116,819200,0,英雄,3,
10.地图参数增加宝宝不攻击人物、英雄参数
11.优化进入游戏速度
12.修复并完善其它细节问题

【2013-12-10更新:】
本次更新文件 ： 全套程序
1.修正列表信息一在XP系统下卡死的问题..
2.发布合区工具
3.优化假人占用CPU
4.修改MON26-7怪物数据库101;201;257
5.修改MON33-10（孤月天珠）攻击方式，召唤属下请在!Setup.txt文件FoxBeas1 - FoxBeas4设置召唤怪物名字
6.改进4级烈火、4级火符、4级灭天火特效
7.增加强化骷髅、强化神兽、强化冰咆哮
8.修复战士强化6重技能特效错误问题
9.继续扩展脚本刷怪命令支持内功怪物和国家怪物
10.增加刷新包裹脚本命令：@RefreshBag
11.自定义OK框新增命令:GiveBoxItem 0~7系统将人物背包物品直接放入到指定OK框中
12.修改悬浮框中的分界线路径放到NewopUI.pak的00046中
13.增加<$POWERRATE>当前攻击力倍数 <$POWERRATETIME> 当前攻击力倍数剩余时间
14.改进检测地图相同怪物数的命令 增加是否忽略怪物名称后面的数字
15.增加变量当前组队人数：<$GROUPMEMBERCOUNT>
16.改进CHANGEEXP、setautogetexp增加经验命令
17.物品装备-特殊属性增加暴击、伤害增加两元素攻击伤害倍数调整
18.功能设置-宝宝升级 增加宝宝不攻击人物、英雄选项
19.增加在线修改宝宝名字脚本命令
20.改进在一定时间内修改人物身体颜色脚本命令
21.增加在一定时间内修改怪物身体颜色脚本命令
22.修复窗口模式的一处问题
23.强化技能支持技能栏升级触发
24.修复副本地图人物死亡倒计时还存在的问题
25.修正商铺巨额交易的一处问题
26.修复安全区可以攻击假人英雄宝宝的问题
27.修改高亮显血为仅自己以及自己相关BB有效
28.修正狮子吼声音错误
29.mapmove定点传送命令增加范围控制
30.修改千里传音、传音筒背景为聊天框所有长度
31.修正并修复其他小细节！

【2013-11-25-B更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe、UpdateServer.exe、数据管理工具.exe
1.修正商铺显示问题..
2.修正战士人形怪刀刀刺杀问题
3.修正连击装备栏查看装备属性的一处问题
4.修改手镯、戒指为负重
5.修改英雄锁定目标追敌范围以及锁定的问题
6.修改内挂智能半月的问题
7.修改并优化装备技能威力和套装读取

【2013-11-25更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe、UpdateServer.exe、数据管理工具.exe
1.修正道士召唤宝宝控制的一处问题
2.修正战士连击的一处问题
3.修正CheckMine命令不支持其他物品持久检测的问题
4.修改圣兽代码（详见数据库）
5.修正Mon26-5怪物受到威胁时释放暗黑冰冻术无冰冻效果的问题
6.修正无限仓库一处问题（保存路径为服务端：UserData\Storage）
7.mongenex刷怪支持刷出怪物的名字颜色（为空时默认白色）
9.配置器增加不显示登陆器版本号并修正已知皮肤和UI的问题>
10.数据管理工具支持显示盾牌、马牌等数据显示
10.扩展触发变量使用，并增加L.当前共自己 多级脚本调用
11.微端服务器支持智能网关分配
12.MDParalysisItemList.TXT为魔道麻痹调用（和普通麻痹一样设置）
13.冰冻、蜘蛛网增加允许使用魔法攻击有效选项
14.修正宝宝安全区会相互攻击一处问题
15.优化英雄相关处理
16.修复其它Bug....

【2013-11-21更新:】
本次更新文件 M2Server.exe、MakeGameLogin.exe、DBServer.exe、LoginGate.exe
1.修正部分怪物攻击特效问题
2.修正武器神圣+作用(可以抵御不死系怪物带来的部分伤害)
3.修正月灵会攻击自己的问题
4.修正UI不可以调整天气图标和标签的问题
5.完善客户端私聊系统
6.增加魔道麻痹、冰冻戒指、蜘蛛网戒指代码
7.增加魔道麻痹、冰冻戒指、蜘蛛网防御代码
8.套装规则增加魔道麻痹、冰冻戒指、蜘蛛网选项以及防御选项
9.引擎修改在线人物查看支持显示金刚石和灵符、数据支持调整灵符
10.引擎查看在线人物支持编辑英雄数据实时生效
11.DBserver 支持调整金刚石和灵符、人物信息支持显示盾牌、马牌、时装
12.DBserver 支持查看编辑英雄数据（需被修改者不在线）
13.登陆器网关增加机器码黑名单过滤表自动加载、机器码变量<$MACHINEID>
14.增加GM命令封闭玩家机器码（类似命令封IP，配合登陆网关可从登陆网关禁止登陆）
15.优化修复道士英雄已知问题
16.修改小地图读取参数规则
17.增加人物内观发型扩展
18.修复其它Bug....

【2013-11-19更新:】
本次更新文件 M2Server.exe MakeGameLogin.exe RunGate.exe
1.修正外显时装特效的一处问题.
2.修正武器攻击速度调整对英雄、人形怪、假人无效的问题
3.修正登陆器创建快捷方式的一处问题
4.修正盾牌的一处问题
5.修正开天斩和龙影剑法图标
6.修正部分技能声音错误的问题
7.修正骑马被邀请人退出游戏时的一处问题
8.修正道士英雄在某些攻击模式下释放技能错误的问题
9.修正登陆器补丁进度不能自定义位置的问题
10.修正配置自定义补丁读取顺序的一处问题
11.修正登录游戏配置外挂大退后又恢复默认的问题
12.修正勾选允许同时召唤多种宝宝后召唤出现无法召唤的问题
13.修改内挂开启魔法盾支持武力盾和道力盾（详见数据库）
14.增加界面播放魔法球效果
15.修改引擎查看在线人物显示方式
16.重新定义各类装备在装备栏负重与腕力分配
17.优化引擎数据包发送、删除无用代码、修复引擎几处报错
18.修复客户端内存泄露并优化客户端
19.修复其它细节...

【2013-11-16更新:】
本次更新文件 M2Server.exe 登录器生成器.exe
1.修正道士英雄一处问题导致引擎报错
2.修正护体神盾的一处问题
3.修正mon23.wzl- mon35.wzl部分怪物错误问题，部分怪物需要更改DB
注：部分怪物涉及远程魔法功能如果无伤害请调整怪物数据库MC值来提高伤害
Mon26-2;124;252;252;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-3;125;252;253;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon26-4;126;252;254;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon27-6;147;117;265;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
Mon29-0;148;118;280;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;

【2013-11-15更新:】
本次更新文件 M2Server.exe 登录器生成器.exe
1.修正自定义OK框的一处问题.
2.修正物品规则-丢弃消失在英雄包裹丢弃不会消失的问题
3.修正商铺的一个问题
4.修正1.76界面自动更换毒符的一处问题
5.修正记忆石显示坐标的一处问题
6.修正内挂隐藏衣服特效无效的问题
7.修正ThrowItem命令的一处问题
8.修正takew命令的一处问题（并支持h.多级脚本）
9.修正聊天框的一处问题
10.修正店铺按钮和宝石升级按钮再次按不会关闭的问题
11.修正追心刺速度太快并增加破魔法盾功能
12.修正SENDMOVEMSG命令公告速度过快
13.修正英雄状态栏的一处问题
14.修改英雄连击技能栏和人物一致
15.修改@Reconnection命令使用
16.增加GM命令@ChangeGate将指定网关所有人物转移到另外个网关
17.修改AddhpPer相关命令增加支持如：M.AddhpPer多级脚本
18.修改聚灵珠支持英雄包裹
19.增加悬浮式装备名字体大小控制
20.客户端控制-内挂控制-速度控制增加内挂自动捡起物品时间控制
21.优化引擎通讯...
22.完善其它部分细节
23.修正其它小BUG...

【2013-11-11更新:】
本次更新文件 M2Server.exe 登录器生成器.exe
1.界面UI增加几处完善..
2.连击界面增加英雄连击功能
3.配置器增加登陆器自定义图标功能
4.修改SetClientBuff命令支持自定义坐标
5.扩展检测矿石纯度命令
6.脚本震动增加次数设置
7.完善部分细节不足之处
8.修正若干BUG...

【2013-11-01更新:】
本次更新文件 M2Server.exe 登录器生成器.exe
1.动态地图链接支持传送门显示
2.增加一键回收包裹物品命令
3.分身术、召唤骷髅、召唤神兽、召唤月灵增加召唤间隔
4.增加创建行会成功触发和沙巴克被占领触发
5.增加检测人物多少时间没有移动命令
6.扩展命令：KICK 修正掉线和小退处理
7.配置器增加客户端资源自定义读取顺序
8.优化英雄智能及噬魂沼泽伤害修正
9.修正战士英雄基本剑术威力的一个问题
10.修正英雄锁定目标和守护的一处问题
11.增加检测自身、英雄血量百分比和按最大HP、MP值的百分比来加减HP、MP脚本命令
12.增加自定义OK框功能
13.配置器增加自定义UI功能
14.扩展L-Horse1.wil：读取为29-50
15.修正其它Bug...

【2013-10-27更新:】
本次更新文件GameCenter.exe M2Server.exe MakeGameLogin.exe
1.修复英雄的HP、MP控制调整后无效问题
2.修复战士英雄不会自动刺杀以及跑步攻击的一些问题
3.修复英雄图像的一处问题
4.修复法英雄攻击宝宝或他人英雄的一处问题
5.修复信息前缀BUG取消不了组队的前缀的问题
6.修复战士英雄刺杀攻击偏位的问题
7.修复自定义变量扩展时遗留的一处问题
8.修复英雄锁定攻击目标后还会被周围的怪物影响的问题
9.修复刷怪命令修改后不能保存的问题
10.修复英雄跟随状态 合击怒气槽里的怒气不上涨的问题
11.修复管理模式下英雄会攻击管理的问题
12.修复部分合击技能无动作的一处问题
13.修复怒气糟在跟随状态不上涨的问题
14.修复引擎-客户端控制对内挂英雄开盾相关无效的问题
15.修复战士英雄学习刺杀后攻杀无效的问题
16.旋风斩增加对英雄、人形怪断筋选项
17.修改涉及战士合击范围为3格内，怒糟控制：技能魔法-合击技能
18.物品规则增加“丢弃消失”选项
19.修复内挂吃药的一处问题
20.内挂增加魔法攻击自动下马选项
21.马牌在非连击界面支持勋章位置和修改马牌在数据库参数以及双人骑马被邀请人偶尔掉队问题
22.游戏界面增加骑马按钮快捷键、时间控制增加上下马间隔
23.人物和英雄分别增加首饰盒功能，启用基础属性：功能设置-其它设置-其它设置三
24.人物英雄分别增加时装和时装武器功能
25.施毒术增加施毒者下线、死亡、换地图消失选项
26.斗笠、马牌、军鼓、盾牌、时装武器、时装衣服支持元素
27.极品几率增加 马牌、军鼓、盾牌、时装武器、时装衣服
28.单独爆装备支持马牌、军鼓、盾牌、时装武器、时装衣服
29.数据库扩展Element字段支持天生元素“暴击几率”
30.怪物爆率增加2种新格式
31.增加自定义采集功能
32.修复完善其它功能细节BUG...

【2013-10-17更新:】
本次更新文件 M2Server.exe 登录器生成器.exe WIL编辑器.exe RunGate.exe
1.修复游戏速度调整负数后引擎重启后不保存的问题
2.修复连击界面查询对方装备，点击名字无法进入聊天编辑区域
3.修复非主动攻击怪物（鸡 鹿等）必须按Shift才可以攻击的问题
4.修复神兽攻击状态卡死的问题
5.客户端显示增加控制界面荣誉显示
6.配置器增加窗口模式时是否允许最大化选项
7.配置器增加启动和关闭游戏后登陆器不弹出选项
8.增加马牌以及仿官方骑马和第三方HEROM2引擎骑马
9.发布E语言API插件代码和修复程序部分提示错误

【2013-10-11更新:】
1.修复并完善英雄相关
2.修复部分合击技能的一些问题
3.增加套装备注英雄状态下可单列显示
4.NPC命令增加：石化或冰冻 中毒效果 蛛网效果
5.程序变量P、D、M、N、S、I、G、A全部扩展至999
6.优化个人自定义变量
7.客户端速度控制修改为可微调
8.修复并发布api插件代码（暂发布DELPHI版代码）
9.修复其他BUG

【2013-09-16更新:】
1.继续优化英雄和修复已知并完善英雄相关
2.支持盾牌（支持外观）
3.修复魔法施展超过范围其他玩家视觉错误问题
4.增加<$DEARNAME>配偶名字变量
5.NPC备注增加使用图标功能
6.套装备注增加显示在装备属性下方选项（列表信息二 --->物品备注）
7.增加SENDMSG命令自定义颜色控制
8.修复已知若干BUG和不完善的地方

【2013-09-14更新:】
1.着重优化英雄及完善英雄相关
2.功能设置->技能魔法:增加魔法忽略魔法障碍选项
3.功能设置->技能魔法:增加提高魔法精确度
4.修改护体神盾显示和声音
5.功能设置->其它设置->其他设置：增加攻击速度控制（自行设置极限速度所需装备+速）
6.微端配置TXT文件将PAK密码修改为动态加密方式保存
7.怪物设置->增加怪物爆物品范围控制
8.摆摊增加显示个人商店称号选项
19.悬浮式背景宽度修改为自适应属性宽度
10.修改连击技能和倚天辟地内力值时按魔法值释放扣除技能数据库spell、defspell字段设置的值
11.断岳斩、倚天辟地技能增加屏幕震动效果并增加脚本震动命令
12.修复DB数据库639武器特效内观坐标错位
13.修复进出安全区提示延时的问题
14.改进优化副本地图相关一些功能
15.地图触发魔法事件增加泉水效果
16.扩展缓消公告参数支持淡显淡消缓慢显示和消失
17.增加旋风斩、五雷轰、幽冥火符三职业技能
18.增加防御、魔御倍数特殊物品代码
19.完善其它小细节...

【2013-09-11更新:】
1.修复英雄遭遇多个目标攻击时不确定打击目标的问题
2.修复战士英雄使用半月频率过高的问题
3.修复地上物品偶尔不显示名称的问题
4.修复英雄图标当主人跑出范围后会消失的问题
5.修改网关清除动态过滤列表所需日志等级提高
6.副本地图增加脚本刷怪和副本地图专用组队传送命令
7.引擎内挂控制增加控制是否显示内功黄条
8.仿及时雨内挂增加喊话功能
9.内挂战斗选项增加好友近身提示、黑名单近身提示（对应游戏关系系统）
10.增加变量支持目标攻击怪物总血量以及当前血量
11.护体神盾增加效果和声音控制
12.增加登陆器支持集成物品备注 内挂物品 套装备注，引擎控制是否由引擎发送到客户端
13.参数设置-座标范围-增加进出安全区提示选项

【2013-09-10更新:】
1.修复OPENMERCHANTBIGDLG命令无效
2.修复人物偶尔变黑的问题
3.修复地图事件触发
4.英雄泡点获取经验修改为按脚本分配
5.引擎增加控制内挂药品不显示英雄相关加血选项
6.内挂物品支持删除和增加物品以及特殊物品相关选项
7.内挂BOSS支持变色提示和魔法自动锁定
8.法师被攻击开盾修改为接近开盾
9.内挂增加显示和关闭内功黄条
10.怪物设置增加显示怪物等级选项
11.控制器支持动态IP登陆游戏
12.增加副本地图功能,地图参数增加 FB(40,祖玛副本,0,1)

【2013-09-07更新:】
1.重写登陆网关、角色网关、运行网关
2.微端增加系统服务选项，防止机器意外重启微端服务器失效
3.重写登陆器PAK密码算法以及修复优化登陆器若干问题
4.地图参数增加 NOTSTONE 当前地图魔血石、气血石、幻魔石无效
5.地图参数增加 DIETIME 当前地图人物死亡多长时间后自动掉线,DIETIME(时间秒),加入此项后,M2上的时间设置对当前地图无效
6.地图参数增加 NOTHROWITEM 禁止丢物品(连金币都不可以)
7.增加人物复活QF脚本触发[@Revival]复活间隔变量<$REVIVALTIME>
8.修复若干小BUG

【2013-08-29更新:】
1.连击技能和倚天辟地增加需要内力值释放
2.完善怪物爆率问题
3.修复当仅reserved值为8时，功能无效的问题
4.修复武器加攻击速度极品时当武器速度为负值时加极品负指更高的问题
5.物品规则增加开启宝箱提示选项
6.去掉武器有1/3几率攻击速度+10以上的代码
7.修改穿戴斗笠后不再显示头盔
8.修改聊天框显示信息支持自定义颜色（功能详见说明书）
9.增加53类宝石的气血石功能 Anicount=1,2,3 分别对应三种石头（功能详见说明书）
10.优化主副将英雄评定
11.增加创建英雄时英雄名字输入小于3个字符给予提示
12.增加释放连击和倚天辟地增加使用内功值选项
13.增加ADDMAPGATE创建动态地图链接坐标(详见说明书)
14.增加ADDBUTTON命令创建顶部图标和DELBUTTON关闭图标功能(详见说明书)
15.增加SetClientBuff图标倒计时触发和CloseClientBuff脚本命令(详见说明书)
16.增加功能：显示一个放大的虚影 SHOWPHANTOM 透明度(0~255) 时间(秒)

【2013-08-25更新:】
1.完善创建英雄流程（详见说明书）
2.完善脚本修理物品处理
3.修复双龙斩目标攻击无伤害的BUG
4.增加逐日剑法攻击跳跃动作
5.修改噬血术攻击动画效果
6.修改强化魔法盾效果
7.修复无极真气提示增加点数与实际不符的问题
8.修改开天斩声音以及普通和重击效果修复
9.诅咒术增加声音读取
10.龙影剑法增加攻击范围
11.乾坤大挪移几率控制
12.修改人物毒粉用完后为分开提示
13.完善分身术 增加控制显示和不显示后缀.增加和主人攻击同一目标
14.增加行会名字长度和封号长度控制
15.增加英雄人物获取全部怪物经验选项
16.增加杀死英雄增加pk值选项
17.增加杀英雄加诅咒几率控制

【2013-08-23更新:】
1.优化人形怪
2.重写宝箱配置(详见说明书)

【2013-08-21更新:】
1.增加地图魔法触发功能:Envir\UserData\MapMagicEvent.txt 使用详见说明书
2.String.ini增加多项提示信息,可按自己想法修改提示内容
3.修复神水修复禁止修理装备的时候给予红字提示
4.修改护体神盾 魔法盾 无极真气等 排除魔法范围提示
5.修复强化技能显示重数的一些问题
6.修复英雄图标显示问题以及忠诚度调整命令完善

【2013-08-20更新:】
1.修改连击技能暴击几率按技能技能计算
2.修改人形怪配置相关操作
3.改进火龙神的攻击效果，修改恶魔蝙蝠和其他官方一样效果。增加支持火龙守护兽
4.增加卧龙书卷打开命令：OPENBOOKS 0 （0-5分别代表不同的书卷）进入卧龙山庄触发卧龙笔记脚本：@heromap
5.修改镖车相关的已经知BUG
一级镖车,128,19,290,130,0,100,2000,15000,0,200,200,380,30,45,10,20,50,500,1,0,500,
二级镖车,128,19,291,150,0,100,4000,22000,0,300,300,480,60,45,10,20,50,400,1,0,400,
三级镖车,128,19,292,180,0,100,8000,32000,0,450,450,550,120,45,10,20,50,300,1,0,300,
火龙守护兽;145;95;802;999;1;1000;0;18000;0;30;30;40;45;0;0;17;15;900;1;0;2000
火龙教主;144;83;800;200;1;0;10000;12000;0;70;100;120;170;0;0;25;30;0;1;0;1500
恶魔蝙蝠;146;19;80;999;0;1000;2000;400;0;1000;1000;40;45;0;0;17;15;900;1;0;2000

【2013-08-18更新:】
1.魔法盾强化后的图标
2.原隐藏英雄相关按钮客户端控制合击版隐藏出战，修改控制到隐藏出战
3.Light字段增加首饰特效，代码9-14（11-13如需要固定发光需提供所有图标修正后坐标）
4.特效列表增加 备注显示 方便识别时那个特效 附图 （限制显示的数量 防止别人备注长）
5.物品规则增加禁止捡起和下线必掉（必爆）选项
6.修复点住右键跑动时，鼠标经过小地图（屏幕右上角雷达地图）回来后就不会跑了的问题
7.修复随机传送石在禁止使用的地图里双击，也掉使用次数
8.增加斗笠脚本变量显示当前所佩戴斗笠名称，变量名：$HAT
9.增加使用双倍卷轴下线再上线双倍经验时间提示
10.增加法师魔法盾防御威力倍数(同时调整魔法盾对物理伤害和魔法伤害的防御力)
11.完善强化技能相关功能和9重后威力控制，如9重设置150%的威力9重后每重增加5%，那么10重威力为155，11重为160以此类推，其它技能强化并非所有技能可以需测试
12.增加刺杀剑术、开天斩、 逐日剑法破防御控制（限人物）
13.增加刺杀剑术、开天斩、 逐日剑法破魔法盾的控制
14.修复人物飘血会叠加显示的问题
15.怪物设置增加对挖取怪物延长时间消失控制）

【2013-08-17更新:】
1.修改连击技能等级需冲脉方可提升，经脉级别对应相应的连击技能等级
2.修复新老引擎以及新老客户端互相兼容的几个问题
3.修复内挂法师英雄自动持续开盾和低血躲避
4.增加当魔法攻击范围不够提示默认开启此项
5.在线人物增加显示金刚石和调整参数
6.增加穿戴斗笠后是否显示神秘人选项
7.修复千里传音内容不能带空格的问题
8.修改增加属性点的标示为循环闪烁
9.控制器增加扩展的Light字段
10.摆摊期间增加无敌模式选项
11.英雄设置增加最高等级限制和1000级后固定经验值
12.人物升级经验增加几项组队经验分配的选项
13.增加杀人武器诅咒几率控制
14.英雄设置增加英雄无弯腰动作和英雄自己不弯腰选项
15.修复斗笠不计算极品属性问题
16.特效列表增加备注显示,方便识别的时候知道是那个特效

【2013-08-16更新:】
0.重写英雄和增加英雄相关控制
1.增加商铺增加页面显示和回车键确认购买
2.增加道士英雄自动换毒选项 仅对使用身上毒符有效果
3.增加英雄计算武器速度（英雄可使用狂风之类装备）
4.增加英雄杀人增加pk值 以人物PK值设置为准
5.增加英雄四级技能触发 【烈火，灭天火，灵魂火符】
6.增加英雄使用野蛮冲撞选项（限战士）
7.增加英雄忠诚度设置
8.增加声望装备英雄按等级计算选项
9.增加英雄三职业血量设置
10.增加清理英雄尸体间隔
11.增加英雄不同屏回到主人身边
12.增加主副将英雄出生等级设置
13.增加禁止英雄安全区守护
14.增加英雄休息时不随主人移动
15.道法无技能时使用物理攻击选项
16.增加700HP以下目标道士物理攻击选项
17.增加英雄死亡掉经验设置
18.增加允许使用英雄合击选项和合击部分技能增加选项
19.修复道士英雄的BB在安全区可以攻击目标人物英雄的问题
20.增加英雄登陆触发QManage的字段@HeroLogin
21.增加英雄无毒符以及HP/MP药品时候提示
22.修改英雄攻击模式随人物更改以及怒气糟的一些问题
23.修复英雄一些相关功能
24.CHANGEEXP给人物增加经验脚本命令扩展当经验值后面为0或空时只给人物增加经验，为1时候为和英雄分享经验，比例在英雄设置内控制

【2013-08-03更新:】
1.修改斗笠外观当Shape值为-1时 人物外观不显示斗笠，显示人物戴斗笠之前的发型..
2.修改强化技能威力计算方式
3.修改经验配置保存到Exps.ini，全局变量保存到GlobalVal.ini
4.修改内挂对怪物NPC的一些相关设置
5.道士技能无极真气修改案技能技能设置威力倍数和最长持续时间
6.修复自定义特效不实时生效的问题
7.首饰放光的效果需要在物品数据库中增加Light字段,效果是1-8
8.扩展2个文件为首饰发光专用：headgearEffect.wzl headgearEffect2.wzl 都取为每20张图片为一组 分别读取代码为100-199 110-199 不足20张为都到空图片止
9.修复一些小的细节问题
10.stateitem.wzl衣服武器内观特效 Light字段计算代码为 500-527 ,StateEffect.wzl衣服武器内观特效 Light字段计算代码为600-641(详见说明书)
11.增加2种屏幕显示信息分个人和全局

【2013-07-30更新:】
1.支持扩展武器特效和衣服特效数据库DB支持
2.!SetUp.txt修改脚本循环次数默认: ScriptGotoCountLimit=9999
3.修复默认不显示人物名字信息进去名字还闪一下名字的问题
4.修复特效过亮导致颜色失真的问题
5.支持 Mon-kulou.wzl文件内3个骷髅..

【2013-07-27更新:】
1.修复新引擎老登陆器登陆显示数字问题
2.修复新客户端在老引擎 职业等级显示无效问题
3.修改套装属性防御、魔御、攻击、魔法、道术增加点控制，增加经验倍数选择
4.冰霜雪雨增加威力倍数控制
5.修改默认登陆器默认界面为1.85样式
6.铸造物品失败 一样会提示成功的问题（提示问题）.合成成功触发 @FoundryOK
7.修复m键的小地图寻路部分电脑上不正常的问题
8.修复中毒时间最大只能调到100秒的问题
9.修复AddTextListEx命令错误
10.修复GM调整和查看他人转生等级信息显示错误
11.修复左手镯戴传送符无效的问题
12.增加捡物品和丢物品触发,在物品规则控制所要触发的物品.分别触发@PickUpItem和@DropItem<

【2013-07-26更新:】
1.修复等级为负数处理流程
2.修复54-58传送门不可以走路穿的问题
3.为方便设置,在功能设置其他控制增加属性点分配选项
4.护体神盾增加关闭消失提示选项
5.增加npc标签功能，支持自定义颜色，颜色和备注之间使用#号隔开
6.修复控制器有可能导致引擎鼠标提示不显示的问题
7.优化代码.

【2013-07-25更新:】
1.增加调整技能经验点数命令：CHANGETRANPOINT 控制符(+,-,=) 点数
2.增加脚本命令CHECKTRANPOINT检测技能修炼点数 > < = 点数
3.修复非英文输入法下(比如智能ABC输入法状态下)，按“~”键，以及z键无法捡取物品
4.冰霜群雨 十步一杀 死亡之眼 增加攻击范围控制
5.冰霜雪雨增加攻击范围以及威力倍数控制
6.神圣战甲术和幽灵盾增加基数控制
7.野蛮冲撞增加可推动同等级选项
8.地狱雷光、爆裂火焰、灭天火增加威力倍数调整
9.烈火剑法增加个关闭失败提示
10.修复龙影剑法和双龙斩威力调整后不能保存的问题
11.增加快速组队快捷键 ALT+S ，原热键ALT+W保留但是在开启QQ后会冲突无法使用
12.修复道士狗狗叫的太频繁
13.增加英雄名字、装备改名、行会名字、行会封号字符过滤功能位置于列表信息1--字符过滤列表
14.修复MISSION地图参数失效的问题
15.地图参数增加NODROPITEM禁止死亡爆装备、物品(怪除外)
16.引擎增加1.76装备界面选择

【2013-07-24更新:】
1.增加禁止吸血武器吸npc血的选项
2.增加禁止记忆传送安全区人物
3.增加攻城区域不掉落身上物品选项
4.增加自动替换队长 选项
5.增加新人上线和平模式选项
6.增加大刀不攻击人形怪、分身选项
7.增加吸血武器吸血倍率调整
9.修复飘血偶尔会叠加显示的问题
10.商铺增加、删除 、修改后和客户端实时同步

【2013-07-22更新:】
1.交易npc增加2项功能
2.增加信息台显示玩家私聊、行会聊天信息控制
3.修复神水修改为按修复持久计算,StdMode值分别为7，2，25默认禁止修理
4.增加npc对话框、英雄状态图标是否可自由移动选项
5.增加商铺界面可自由移动功能选项，开启后界面默认居中显示,每次关闭时保存界面位置状态,大退后恢复默认
6.修复人物持毒素武器在安全区使用雷霆剑法、龙影剑法、逐日剑法等技能安全区攻击人物中毒的问题
7.狮子吼增加麻痹范围控制默认可麻痹范围2
8.龙影剑法修改为不需要有攻击目标一样可以释放技能
9.修复雷霆剑法调整攻击百分比保存后重启恢复默认的问题
10.增加特殊修理命令为 RepairAll ，在物品规则列表中限制物品的不会被修理
11.施毒术和怪物毒在String.ini文件YouPoisoned 增加d%秒，d%点显示
12.修复武器Source字段客户端不显示神圣以及强度的问题.设置正数为强度（1-10），负数为神圣（-1至-50）
13.时间控制增加控制:记忆传送间隔、夫妻传送间隔、师徒传送间隔
14.密码保护系统增加禁止召唤英雄、禁止商铺、禁止挑战、禁止摆摊商店相关 控制
15.重写挑战功能,并增加挑战时间控制以及附加币选项, 增加玩家命令@LetChallenge 禁止/允许挑战
16.修复魔血石检测问题.
17.修复下雪等特效判断地图错误和播放音乐增加路径 wav\刮风声音.wav

【2013-07-20更新:】
1.完美修复个人店铺的一些问题
2.重写仿herom2摆摊功能
3.增加开启宝石升级开关
4.增加人物身上是否显示行会名称选项
5.修改gm命令权限不够的提示信息
6.引擎增加客户端默认攻击动作间隔和魔法间隔控制
7.优化代码并更改颜色值控件

【2013-07-18更新:】
1.增加攻城区域允许穿英雄选项
2.增加攻城区域禁止使用传送戒指、传送符
3.增加安全区禁止穿摆摊人物、NPC、离线挂机人物
4.修复武器攻击加速(狂风 药水类)无效
5.增加人物、怪物、npc、卫士的雷达显示颜色设置以及增加老雷达小地图功能
6.修复战士转职后不小退，还能砍出刺杀的问题
7.手动学习刺杀 和脚本增加刺杀后 技能自动开启
8.处理选择服务器直接退出时内存泄露

【2013-07-17更新:】
1.装备显示信息 增加显示分界线 开关 默认开启
2.装备信息随鼠标移动 修改为 默认开启
3.增加行会人数上线 默认260人
4.清理人型怪可挖尸体的怪物时间
5.增加数据读取保存超时间隔控制
6.修复破护身破复活失效的问题
7.增加防毒146、防诱惑147、防火墙148详见说明书内特殊物品解释
8.修改气血石之类加血计算方式
9.增加禁止离线挂机摆摊 禁止英雄和宝宝离线挂机选项
10.游戏跑步穿增加几项控制
11.细化人物、英雄、怪物体力恢复和吃药间隔
12.修复引擎内存泄露

【2013-07-15更新:】
1.增加NPC 文字鼠标经过和按下颜色控制,选项-参数设置-文字颜色
2.修复刺杀 烈火 高攻击倍数 计算错误的问题
3.修复地上物品名称颜色兼容老登陆器的一些问题
4.悬浮装备信息显示增加选择随鼠标位置显示,客户端控制选择开关
5.游戏界面显示攻击模式更改为当关闭英雄相关按钮后 此文字显示英雄按钮位置 开启后复位
6.修复地图参数 LAVA 雷电和岩浆无效的问题
7.修复播放花瓣和下雪显示的一些问题
8.修复新技能威力倍数调整的bug
9.增加英雄登陆、退出提示、时间限制显示
10.修改客户端删除技能错误假象
11.修复女英雄发型有时候变光头?装备栏身材回变男人的的问题
12.对天气效果进行扩展.
13.解决客户端内存泄露问题

【2013-07-12更新:】
1.增加 冰霜雪雨 冰霜群雨 死亡之眼 十步一杀 裂神符 技能
2.倚天劈地增加攻击范围控制调整默认8*8
3.狮子吼修改麻痹时间控制 基础麻痹时间默认3秒,每升一级增加多少点
4.月灵增加攻击距离控制控制
5.完善施毒术中绿毒效果
6.擒龙手允许抓获宝宝,英雄的选项
7.修复火墙不会消失
8.魔法值不够 使用需要魔法的技能 提示:魔法值不够!!!--增加个在聊天栏现实的选项
9.彻地钉增加攻击范围控制
10.武器 数据库字段anicount 在代码201时候 获得倚天劈地技能
11.戒指在 数据库shape 代码为200 获得流星火雨技能 如果技能不增加技能经验，请修改数据库流星火雨job字段为1 -- 原库为2有误
12.已经练习触发技能不可使用 -----练习技能会消失
13.更新仓库功能可设置为无限仓库.
14.增加月灵攻击音效
15.增加月灵死亡音效
16.修复英雄女性发型再更换装备后会错乱的问题

【2013-07-09更新:】
1.继续修复发型问题.
2.扩展人物发型Hair10.wzl Hair11.wzl 脚本控制发型 计算方式为每600张图为一个发型.每个文件内可放10种发型.分别从50-59 60-69开始算
扩展的就按顺序读取 如50 就读Hair10.wzl 第一种发型 ，69就读Hair11.wzl 第10种发型(扩展的只需新登陆器支持)
3.修复人物转向不灵活的问题
4.修复内挂召唤烈火频繁提示失败
5.修改注册人物名字限制14位
6.修复需要毒符技能在没有毒符和没目标攻击的时候速度变快的问题.
7.增加毒符技能在没有毒和符的情况下给予提示信息开关.
8.修复新登陆器显示发型错误的问题.

【2013-07-07更新:】
1.修复月灵报错，月灵死亡状态以及月灵可以和其他宝宝一起召唤的问题.
2.完善烟花的燃放效果
3.增加客户端esc关闭NPC对话框控制
4.修复文字颜色边上显示颜色问题
5.增加dbserver 关闭了允许找回删除人物后找会人物提示：服务器禁用角色找回功能.
6.增加禁止包含一下字符人物名字 如建立时候有此内的禁止符号 将提示信息：创建的角色名包含禁用字符
7.增加账号服务器LoginSrv 如果设置禁止创建账号 则在注册输入完信息后点注册 给提示信息 ：服务器禁止创建ID账号

【2013-07-06更新:】
1.修改LoginSrv 验证码功能设置为默认关闭
2.修复技能书练习后经验值显示错误
3.修复登陆老引擎区新客户端人物跑步显示变色
4.普通登陆器登录新引擎回程卷,药品非叠加物品一次只能买一个问题
5.修改内挂尸体清理过滤城门城墙
6.修复如果NPC物品缓存目录不存在，会不保存物品缓存的问题
7.完善新旧沙巴克的信息!
8.修复老登陆器登陆新引擎买药或杂货 一次只可以买一件的问题

【2013-07-05更新:】
1.修复客户端默认获得物品显示信息坐标为30 40
2.修改新客户端登陆老引擎区时候不显示多余按钮
3.修复经验值在聊天栏显示字体的颜色 文字255 背景颜色249
4.修复新客户端1.85界面按F11 依然显示合击 必须按F10
5.修复新客户端和新引擎恢复人物不能及时显示出来的问题
6.完善客户端注册相关信息长度
7.修改自定义命令保存文件名修改为UserCmd.txt

【2013-07-02更新:】
1.修复老客户端(2010登陆器)登陆新引擎后武器显示错乱.
2.修复老客户端(2010登陆器)登陆新引擎后 人物装备属性错误
3.修复老客户端(2010登陆器)登陆新引擎后 当登陆一个角色身上穿了装备 然后小退后登陆另外个角色装备栏会显示第一个登陆的脚色的装备信息，前提是此角色没穿任何装备 穿了装备就不会出现这个现象
4.修复老客户端(2010登陆器)登陆新引擎后 商店不能购物 相反新的登陆器进老的一样显示不出来
5.修复老客户端(2010登陆器)登陆新引擎后 背包物品过多 小退或大退上线不显示背包物品
6.修复新客户端登陆老herom2引擎 NPC窗口显示脚本名字
7.修复新登陆器使用老客户端设置为默认为185界面和传统装备显示信息,默认不显示如英雄 商铺等多余按钮以及杀怪经验在聊天栏显示
8.修复引擎功能设置--技能魔法----野蛮冲撞-禁止使用提示信息 修改 为显示提示信息 (因为勾选后才回显示提示)
9.修复新客户端无论是登陆老herom2引擎还是新的引擎 NPC传送以及回城随机时无声音无特效
10.修复新客户端登陆老herom2引擎 女性职业发型外观显示错误

【2013-04-21更新:】
1. 增加盛大Npc2.wzl中最后15个NPC。代码:211~225
2. 增加检测组队人数的脚本命令 CHECKGROUPMEMBERCOUNT (<,>,=) 数量
3. 增加7200网关，是否开启检测登录器密码的选项
4. 增加连击登录器显示旧连击的界面的选项(旧连击界面暂时不支持内功连击)
5. 修改CHECKITEMADDVALUEEX命令，只检测附加属性AC MAC DC MC SC这5个属性
6. 修复GOTOLABEL范围触发的问题
7. 修复月灵报错的问题

【2013-04-18更新:】
1. 增加点击小地图自动寻路功能(可以在M2关闭或开启该功能，使用小地图按键或M键打开)
2. 增加怪物名称颜色自定义功能
3. 增加改名后的装备变量.例如衣服名称变量<$DRESS> 改名变量<$G_DRESS> 英雄的<$H.G_DRESS>
4. 修改装备属性框的文字描边
5. 修改断岳斩攻击为线性攻击
6. 修复杀怪后英雄获取不到内功经验的问题
7. 修复攻击后仰的问题

【2013-04-16更新:】
请同时更新全套程序，否则无法正常游戏

1. 兼容HeroM2命令ChangeHeroJob
2. 兼容HeroM2变量，扩展D和P变量。支持P0~P99 D0~D99
3. 登录器注册帐号，每次打开自动输入一个随机的生日
4. 增加装备升级触发,执行脚本功能.升级成功时执行@UpgradeOKX,升级失败时执行@UpgradeFailX,
属性被清除时执行@UpgradeClearX,其中X代表装备位置,例如:衣服=0,武器=1
5. 增加支持更换网关的命令@Reconnection
6. 增加包裹刷新速度控制(M2-功能设置-其他控制)
7. 修复野蛮的问题
8. 修复其他BUG

【2013-04-14更新:】
1. 修复及时雨内挂喝蓝药的问题
2. 修复英雄和人形怪刺杀会麻痹的问题
3. 修复卡魔法的问题
4. 攻击速度恢复以前的

【2013-04-13更新:】
1. 修复及时雨内挂自动解包的问题
2. 修复剔除离线挂机人物有机率会踢掉在线人物的问题
3. 修复月灵和英雄攻击分身的问题
4. 修复技能一些问题
5. 增加人形怪支持强化技能

【2013-04-11更新:】
1. 修复使用野蛮后地图名称消失的问题
2. 修复武器升级不破碎的选项勾上后，还有个可能会破碎的问题
3. 修复自动解包的一个问题
4. 修复顶号不提示的问题
5. 增加网关2个选项，用于加速检测
6. 增加调整装备升级次数的脚本命令(ChangeItemUpgradeCount 位置(0~15,-1时为OK框物品) (+,-,=) 次数(0~255))

【2013-04-10更新:】
1. 修复升级经验的问题
2. 修复分身术不计算装备属性的问题
4. 增加NPC常量杀怪经验倍数<$KILLMONEXPRATE> 时长<$KILLMONEXPRATETIME>
5. 增加毒素武器的2个控制(M2-功能设置-其他设置)
6. 增加包裹上是否可以直接显示元宝信息的选项

【2013-04-09更新:】
请同时更新全套程序，否则无法正常游戏

1. 修复登录器荣誉和国战荣誉的问题
2. 修复魔法锁定控制的问题
3. 修复分身术召唤的宝宝会攻击主体的问题
4. 修复帐号服务器的密码找回控制无效的问题
5. 修复equal命令的一个问题
6. 修复自动半月开启后，不会自动关闭的问题
7. 增加中毒后是否提示人物中毒的信息的选项
8. 增加检测装备的附加属性总和(武器的诅咒不在计算范围之内) 格式: CheckItemAddValueEx 位置(0-15) 操作符(> = <) 附加值(0-65000) 新属性(0,1)
9. 增加吃药恢复时间间隔控制
10. 增加体力恢复和魔法恢复间隔控制
11. 增加蜡烛是否随着持久的改变而改变亮度的选项
12. 增加物品规则增加 禁止商铺打折
13. 增加一个经验百分比控制,和经验够可连续升级控制。
14. 增加怪物说话支持%m 地图名称 %x=X坐标 %yY坐标
15. 增加人物英雄、升级、获取经验、获得物品的显示位置和文字颜色控制
16. 增加元素属性可以显示在人物属性框中(只可以在连击版登录器显示)
17. 增加可以控制连击版登录器中的，时装、称号、出战是否显示
18. 增加MapQuest.txt文件中怪物类,支持变量操作 例:F008 [089] 0 <$STR(S4)> * Q004
19. 增加怪物伤害封顶，封顶数值等于怪物BD中的MP数值，若DB中怪物MP值=0则不计算伤害封顶
20. 增加怪物属性扩展：Envir\MonSpAbilList.txt，
格式：怪物名 忽视防御(0~100) 增加伤害(0~255) 伤害反弹(0~100) 物伤减少(0~100) 魔伤减少(0~100) 麻痹-几率-时间(0~1 0~10 0~10) 防麻痹(0~1) 防全毒(0~1) 防火墙(0~1) 防诱惑(0~1) 破复活(0~1) 破护身(0~1)
21. 增加毒素武器(兼容HeroM2) 使用方法:\Envir\UserData\PoisonWeapon.txt
格式: 武器名称 成功几率 减HP值 基本时间 扩展时间
成功率100以下时设置多少就是多少的成功率例如:80就是80%的成功率50就是50%的成功率
扩展时间是一个随即值,假如设置为10那么它的值就是1-10之间的值. 持续时间=基本时间+扩展时间所产生的随机值
例如:木剑 90 10 10 5

【2013-04-03更新:】
请同时更新全套程序，否则无法正常游戏

1. 修复野蛮后不能立即攻击的问题
2. 修复道士毒抢物品的问题
3. 修复CheckItemUpgradeCount命令无效的问题
4. 修复GetUserItemName命令无效的问题
5. 修复微端偶尔会卡死的问题(需测试)
6. 修复启动控制器无法清理帐号和人物数据的问题
7. 修改SendCenterMsg字体大小
8. 修改注册帐号长度限制在10
9. 增加野蛮不能使用时的提示信息的选项
10. 增加黄字信息的前缀控制
11. 增加扔叠加物品时，全部扔掉。不显示输入数量的对话框(功能设置-其他设置)
12. 增加物品的技能伤害和防御威力百分比功能，支持装备和套装
13. 优化假人和英雄
14. 更新插件API

【2013-03-29更新:】
1. 修复人物说话不显示名称的问题
2. 修复假人AUTOGOTOXY自动行走的问题

【2013-03-28更新:】
1. 增加军鼓变量<$DRUM>
2. 增加假人支持AUTOGOTOXY自动行走命令，目的地不能太远否则会失败
3. 增加跑步时可以自动绕障碍物
4. 增加人物死亡控制暴物品数量
5. 增加登录器分辨率控制
6. 修改点击游戏区，不在刷新公告
7. 修改可以启动多个不同的登录器
8. 修改人物下线后关闭个人商店，无法搜索到该商店的物品
9. 修改开启助跑,被攻击后仰后需要重新助跑
10. 修改蜡烛、火把的持久值为亮度，10000持久亮度为1最高亮度5，会根据持久的降低,降低亮度。
11. 修复诅咒术信息提错误
12. 修复购买商城物品失败时提示信息错误
13. 修复M2一个报错
14. 修复龙影剑法使用间隔不保存
15. 修复宝宝会被挤出安全区的问题
16. 修复传送符无效的问题
17. 修复安全区砍宝宝灰名的问题
18. 修复内挂被攻击开盾无效的问题
19. 修复地图参数NOTALLOWUSEMAGIC和NOALLOWUSEITEMS物品或魔法名称有括号时会失效
20. 修复神秘人说话和杀人时会出现真实名字
21. 修复其他一些问题
22. 优化英雄人形怪

【2013-03-18更新:】
1. 优化客户端微端更新速度
2. 改进KICK命令自动小退
3. 改进MAPEFFECT命令，后面在增加一个灯光亮度的参数(该参数值范围0~5，0表示没有亮度，在关闭禁止免蜡时有效)
4. 修复外挂检测误封的问题
5. 修复SCREENEFFECT命令失效的问题
6. 修复M2龙影剑法威力倍数无效的问题
7. 修复其他一些问题

【2013-03-13更新:】
1. 修复刺杀的问题
2. 增加千里传音的文字过滤

【2013-03-12更新:】
1. 修复使用THROWITEM命令，掉落物品提示错误的问题
2. 修复登录器登录偶尔会提示连接失败的问题
3. 修复套装系统先增加属性点再增加百分比的选项失效
4. 修复GM命令，增加技能报错的问题
5. 修复及时雨内挂吃蓝药不正常
6. 修复魔法盾技能等级越高防御反而越低
7. 修改套装物品只能输入50个汉字的问题
8. 修复技能使用的问题
9. 修复NPC商店购买物品不删除的问题
10. 增加所有GM命令支持英雄
11. 增加逐日剑法信息提示
12. 增加流星火雨使用间隔控制
13. 增加复活血量百分比控制
14. 增加获取用户自定义命令输入参数<$PARAM(0)> <$PARAM(1)> <$PARAM(2)> <$PARAM(3)> <$PARAM(4)> <$PARAM(5)> <$PARAM(6)>

【2013-03-08更新:】
1. 增加远程列表支持百度空间
2. 增加麻痹装备麻痹机率控制，护身装备掉蓝控制，复活装备复活间隔控制，
启动M2后在Envir目录，会生成3个文件ParalysisItemList.txt MagicShieldItemList.txt RevivalItemList.txt
3. 特效编号增加到65535个
4. 修改点击小地图透明切换
5. 修复WIN7~8使用CTRL+ALT+DEL，登录器会卡死的问题
6. 修复其他已知BUG
7. 修改远程列表加密格式

【2013-03-05更新:】
1. 修复宝宝或施毒术杀死怪物不触发[@KillMon]的问题
2. 修复购买NPC商店物品子项翻页无效的问题

【2013-03-03更新:】
1. 增加仿HeroM2国战系统
2. 修复地图参数FIGHT2不掉装备的问题
3. 修复地图参数NORANDOMMOVE随机石还可以使用的问题

【2013-02-28更新:】
请同时更新M2和登录器，否则游戏会出错
1. 增加狮子吼的使用间隔控制
2. 增加内挂开天斩自动使用控制
3. 增加千里传音、传音筒的使用间隔
4. 增加武器升级失败不破碎的选项
5. 修复保存杀怪经验倍数的选项无效的问题
6. 修复英雄刷装备的问题
7. 对内挂吃药做了修改

【2013-02-26更新:】
1. 野蛮和抗拒火环，目标位置不动的问题
2. 升级经验最高设置超过21亿报错的问题
3. 修复别人看不到自己吃药加血
4. 增加双击取回宝箱

【2013-02-20更新:】
1. 优化M2的CPU占用
2. 优化M2的流量占用(修复大型PK时会大卡的问题，流量只占原来的三分之一)
3. 增加内挂物品捡取、物品备注、套装备注直接在M2中配置
4. 改进变量使用规则。在脚本命令中使用变量时，有没有括号都可以正常使用。(注:自定义变量必须要括号 脚本命令:Mov Inc Dec Sum Equal如果第二个参数使用变量，也必须要括号)。
5. 增加物品掉落提示信息可以修改，在String.ini文件DropItemHint=物品[%Item]从[%Name]身上掉落在地图%Map(%X,%Y)处
6. 增加杀怪经验倍数可以保存
7. 修复反弹卡位的问题
8. 修复其他一些问题

【2013-01-03更新:】
1. 修复上版出现的所有问题
2. 增加一个脚本命令GOTOLABEL

【2013-01-02 更新:】

1. 对引擎核心做了大量优化改进
2. 仿HeroM2摆摊功能集成到引擎中，不再使用插件。摆摊QF触发也兼容HeroM2(M2-功能设置-个人商店)
3. 对游戏速度功能做了调整
M2-游戏参数-游戏速度中间隔控制。控制的是人物动作的频率，也就是二次动作之间的间隔。如果出现卡顿，需要调整这里的间隔参数
选项-客户端设置-内挂控制中的速度控制。控制的是人物动作开始到结束的速度。

4. M2-列表信息二中的数据不在保存到MDB数据库中(商铺、套装、特效等等要重新设置)
5. 改进套装系统
6. 改进物品特效
7. 改进变量使用规则。在脚本命令中使用变量时，有没有括号都可以正常使用。(注:自定义变量必须要括号)。

旧：
[@Main]
#ACT
GetListString ..\QuestDiary\数据文件\通缉名单.txt 1 <$STR(S1)>
#SAY
<$STR(S1)>

新：
[@Main]
#ACT
GetListString ..\QuestDiary\数据文件\通缉名单.txt 1 S1
#SAY
<$STR(S1)>

7. 改进扩展字符变量S和数字变量N。需要在S或者N后面加符号$
8. 兼容HeroM2(详见说明书)
9. 修复若干BUG

【2012-11-30更新:】

功能增加：
1. 增加掉落物品提示文字颜色控制
2. 增加FIGHT2地图标志PK不加PK值
3. 增加脚本命令CHECKMAPDUMMYCOUNT检测地图假人数量

问题修复：
1. 修复了人物会被挤出安全区的问题
2. 修复了人物无弯腰动作打钩，PK看不见对方掉血

【2012-11-28更新:】

功能增加：
1. 增加套装可以直接增加属性点(兼容以前的百分比)

问题修复：
1. 修复了重新加载NPC后，M2会报发现非本地图角色的错误
2. 修复了仿HeroM2摆摊插件导致不能拆分叠加物品的问题(需要同时更新登录器和插件)
3. 修复了道士技能自动练功时不能自动毒符互换的问题
4. 修复了宝石升级的一些问题
5. 修复了CHECKMONMAP命令不支持变量的问题
6. 修复了仿及时雨内挂中英雄退出保护选项不受控制的问题
7. 修复了其他已知BUG

【2012-11-22更新:】

问题修复：
1. 修复了经验百分百显示不正确的问题
2. 修复了装备改名后套装备注不显示的问题
3. 修复了WIL编辑器图片花的问题
4. 修复了准确和敏捷超过255会变成1的问题
5. 修复了包裹刷新失败的问题
6. 修复了只显人名的情况下选择自己会看见别人的封号。

功能改进：
1. 优化引擎内存占用

【2012-11-19更新:】 需要在论坛单独下载

问题修复：
1. 多线程网关登录黑屏的问题

【2012-11-18更新:】

新增功能：
1. 增加同一坐标允许爆出物品数量的选项(功能设置-其他控制)
2. 增加NPC对话框字体黑色描边

问题修复：
1. 修复了宝石升级失败无提示的问题

功能改进：
1. 优化引擎CPU占用

【2012-11-16更新:】

新增功能：
1. 增加扩展Npc10.wil。Npc代码从1000

问题修复：
1. 修复了微端有时候会更新不了的问题
2. 修复了宝石升级失败，清除属性点机率低的问题
3. 修复了CheckSlaveInRange命令失效的问题

功能改进：
1. 修改摆摊名称太长的问题，并对名称进行过滤
2. 改进小地图扩展mmap10.wil从10001开始
3. 改进WIL编辑器和微端
4. 优化引擎CPU占用

【2012-11-13更新:】

问题修复：
1. 修复了登录器启动不了的问题
2. 修复了WIL编辑器导出Pak文件时空白图片导不出来的问题
3. 修复了大刀和弓箭手会攻击镖车的问题

功能改进：
1. 修改ThrowItem命令

【2012-11-12更新:】

新增功能：
1. 增加幸运发挥最高威力的选项
2. 增加Pak文件也支持微端更新(原来只支持Wzl文件，必须是2012-09-13以后更新的WIL编辑器创建的Pak文件才支持微端)
3. 增加Pak文件密码绑定登录器，需要配置登录器的时候设置Pak文件的密码否则登录器不能正常读取
4. 增加Wil Wzl Pak文件读取规则
5. 增加清除SendCenterMsg倒计时命令CLEARDELAYGOTO
6. 增加检测人物的吸收伤害剩余点数

问题修复：
1. 修复了灵魂火符强化技能威力不正常的问题
2. 修复了聚灵珠释放经验不消失的问题
3. 修复了GiveMine默认权限为0的问题
4. 修复了技能一些问题
5. 修复了金刚石的名称在!Setup.txt文件中不保存的问题
6. 修复了宝石升级装备的一些问题
7. 修复了镖车无敌的问题

功能改进：
1. 升级宝石和军鼓冲突，军鼓的StdMode已由55改为65
2. 修改一些脚本命令不支持变量
3. 修改CheckPKPointEx检测PK点(原来检测的是PK等级)

【2012-11-06更新:】

新增功能：
1. 增加登录器数字签名解决报毒问题
1. 增加反外挂黑名单功能
2. 增加噬血术攻击威力倍数控制
3. 增加抗拒火环和气功波可以推动同等级的选项
4. 增加摆摊可以自定义名称

问题修复：
1. 修复了无极真气威力倍数无效的问题
2. 修复了寒冰掌不推动目标的问题
3. 修复了物品规则对摆摊插件的摆摊物品无效的问题
4. 修复了技能一些问题
5. 修复了上左下右4个方向鼠标点击范围偏窄

功能改进：
1. 改进DELTEXTLIST和ADDTEXTLIST命令支持双变量用法和CHECKTEXTLIST一样

【2012-10-31更新:】

新增功能：
1. 增加开启关闭客户端反外挂功能(管理-客户端模块白名单)
2. 增加自动上传白名单功能(管理-客户端模块白名单)

问题修复：
1. 修复了个别机器杀不死怪的问题

功能改进：
1. 优化英雄智能
2. 优化WIL编辑器批量导入的速度
3. 改进CHECKTEXTLIST命令，兼容旧的格式

【2012-10-28更新:】

新增功能：
1. 增加仿HeroM2摆摊功能插件(配置登录器需要使用最新的NewopUI.Pak)

问题修复：
1. 修复了英雄刺杀无威力的问题
2. 修复了英雄守护时不走向守护目的地问题
3. 修复了一处翅膀会变色的问题

功能改进：
1. 优化英雄智能

【2012-10-22更新:】

问题修复：
1. 修复了界面上多了个白点

功能改进：
1. 改进误报率高的问题

【2012-10-20更新:】

问题修复：
1. 修复了WIN764位系统误报

【2012-10-19更新:】

新增功能：
1. 增加客户端模块白名单功能(防止外挂误报。M2-管理-客户端模块白名单，把模块MD5值加入即可)
2. 增加易语言客户端插件API

问题修复：
1. 修复了M2文字过滤失效的问题
2. 修复了英雄的穿脱装备触发失效问题

功能改进：
1. 修改PLAYEFFECT、MAPEFFECT、SCREENEFFECT可以播放图片资源超过65535的WIL
2. 修改SCREENEFFECT

格式: SCREENEFFECT 屏幕坐标X 屏幕坐标Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 模式(0=自己，1=所有人) 播放效果(0=普通，1=魔法效果)

【2012-10-15更新:】

新增功能：
1. 增加施毒术和无极真气的参数控制
2. 增加客户端插件API

问题修复：
1. 修复了已知外挂误报的问题
2. 修复了挖肉时引擎一个报错

功能改进：
1. 降低M2的CPU占用

【2012-09-30更新:】

问题修复：
1. 修复了PlayEffect跑动时播放速度变慢的问题
2. 修复了M2启动时的一个错误
3. 修复了0血不死的问题
4. 修复了中毒翅膀变色的问题

功能改进：
1. 修改军鼓HP和MP的显示位置
2. 降低M2的CPU占用
3. 加强反外挂系统检测能力

【2012-09-18更新:】

新增功能：
1. 增加支持军鼓，需要在StdItems.DB中增加新的字段HP和MP，可以使用最新的游戏启动控制器自动增加这2个字段。
除了军鼓支持这2个字段，其他装备也支持

问题修复：
1. 修复了合区工具的一个问题
2. 修复了组队杀怪会重复触发的问题

【2012-09-13更新:】

新增功能：
1. 增加合区后的人物第一次登录的检测命令,该命令和检测是否是新人命令一样，只有第一次登录有效
2. 增加支持PNG通道

问题修复：
1. 修复了组队刷经验的问题
2. 修复了合区后有的人物无法登录的问题
3. 修复了归来国际新地图的问题
4. 修复了英雄不守护的问题
5. 修复了Mon19的问题

功能改进：
1. 去掉吃药超速的提示

[@Login]
#IF
ISNEWSERVER 1
#SAY
合区后主区人物登录
break
#IF
ISNEWSERVER 2
#SAY
合区后从区人物登录
break

【2012-09-07更新:】

问题修复：
1. 修复了由于增加新地图导致全屏切换卡死的问题
2. 修复了新地图瀑布不动的问题

【2012-09-05更新(优化测试版):】

新增功能：
1. 增加支持归来国际的新地图。
2. 增加徒弟出师后师父触发.Q-Function中@MasterOK
3. 增加引擎参数设置-游戏速度中增加几个新的选项，防止加速外挂控制失效。
4. 增加免助跑功能，内挂中无此选项，在M2中控制
5. 增加假人优先捡物列表

问题修复：
1. 修复了挖肉难的问题
2. 修复了毒死的怪物偶尔不爆的问题

【2012-08-31更新(优化测试版):】

新增功能：
1. 增加单个装备的爆率设置。

问题修复：
1. 修复了人物中毒翅膀不变色的问题
2. 修复了战士偶尔不攻击的问题

功能改进：
1. 放开登录器检测，可以给登录器加数字证书

【2012-08-30更新(优化测试版):】

问题修复：
1. 修复了挑战地图吃药引擎报错的问题
2. 修复了会出现假怪的问题

功能改进：
1. 优化通讯流量和内存

【2012-08-29更新(优化测试版):】

新增功能：
1. 增加禁止双烈火的选项。
2. 增加支持登录器补丁集成功能。
3. 增加治愈术恢复点数控制
4. 增加治金创药和魔法药恢复点数控制
5. 增加宝宝叛变时立即死亡的选项

问题修复：
1. 修复了合区工具的问题
2. 修复了登录器一个内存错误
3. 修复了刺杀的问题
4. 修复了<$SCATTERITEMNAME>捡取物品时不正确的问题
5. 修复了复活戒指偶尔不复活的问题

功能改进：
1. 优化通讯流量和内存

【2012-08-23更新:】

问题修复：
1. 修复了Race=108的怪物引擎会报错的问题
2. 修复了无法自动登录脱机人物的问题
3. 修复了登录器禁止多开失效的问题
4. 修复了安全区重叠人物不弹开的问题

【2012-08-18更新:】

新增功能：
1. 增加脚本检测命令取反NOT

问题修复：
1. 修复了商铺购买叠加物品不扣元宝的问题
2. 修复了远程脚本读取插件会加载失败的问题
3. 修复了M2中有个参数不保存的问题
4. 修复了由于下线触发挂机导致人物无法踢下线
5. 修复了远程列表显示乱序的问题

功能改进：
1. 修改刺杀攻击威力
2. 修改若干细节

【2012-08-13更新:】

新增功能：
1. 增加支持输入框标题自定义
2. 增加支持IP加速器
3. 增加易语言格式API
4. 增加人物下线关闭个人商店的选项(关闭后无法购买该商店的物品)

问题修复：
1. 修复了登录器透明皮肤在16位色有些花屏的问题
2. 修复了备用列表无效的问题

[@main]
输入框标题自定义\
<输入/@@InputInteger1(请输入元宝数量：)>\

[@InputInteger1]

【2012-08-08更新:】

新增功能：
1. 增加远程脚本读取插件
2. 增加一些脚本命令支持变量
3. 增加和修改引擎一些API

问题修复：
1. 修复了吃药后客户端不实时显示的问题
2. 修复了限制装备开始计时后，时间没有变化的问题
3. 修复了ADDTEXTLIST不能增加相同名称的问题
4. 修复了多线程网关导致CPU高的问题
5. 修复了人物死亡先出背景音乐才倒地
6. 修复了铸造物品里的机率不保存的问题

【2012-08-05更新:】

新增功能：
1. 公布引擎脚本加密插件和功能插件代码
2. 增加新的反外挂系统

问题修复：
1. 修复了一个怪物引起引擎报错的问题
2. 修复了SortVarToList“人物名称:变量值”这样保存
3. 修复了商铺购买叠加物品会给一个叠加满的物品
4. 修复了荣誉的问题
5. 修复了假人可以捡钱
6. 修复了装备改颜色后扔地上颜色不变的问题
7. 修复了21E血人物会死亡的问题

【2012-07-29更新:】

新增功能：
1. 增加重复召唤道士宝宝自动回到主人身边
2. 增加脚本命令SortVarToList
3. 增加师徒名称变量<$STNAME>

问题修复：
1. 修复了商铺物品重启后乱序的问题
2. 修复了离线挂机在上线包裹中有机率会出现属性乱套的装备
3. 修复了120类型怪物会走动的问题

功能改进：
1. 优化M2内存占用

【2012-07-27更新:】

新增功能：
1. 增加脚本命令删除内功DELETESKILLNG
2. 增加登录器配置文件名称自定义

问题修复：
1. 修复了捡取物品后延时一会才会消失的问题
2. 修复了特效坐标的问题
3. 修复了GETLISTSTRING的问题
4. 修复了假人的一些问题
5. 修复了人物走路检测格数太大的问题
6. 修复了红绿毒互换的问题
7. 修复了分辨率的问题

功能改进：
1. 优化M2通讯流量
2. 优化M2内存占用

【2012-07-23更新:】

新增功能：
1. 增加内挂中红绿毒互换的选项

问题修复：
1. 修复了套装属性HP超过256%会不正常的问题
2. 修复了看见别人杀死的怪物还是站着的问题
3. 修复了GETLISTSTRING第二个变量获取不到值
4. 修复了DELNPC不会立刻消失的问题

【2012-07-22更新:】

新增功能：
1. 增加脚本变量人物登录使用的分辨率。宽:<$SCREENWIDTH> 高:<$SCREENHEIGHT>

问题修复：
1. 修复了英雄血条不正常的问题
2. 修复了不能连续买物品的问题
3. 修复了人物视觉范围的问题
4. 修复了内挂默认设置有几个选项不正确的问题

功能改进：
1. 优化NPC脚本执行

【2012-07-20更新:】

新增功能：
1. 增加登录器支持显卡所有分辨率。
2. 增加登录器内挂默认设置。

问题修复：
1. 修复了套装备注显示的问题
2. 修复了叠加物品的问题

【2012-07-18更新:】

新增功能：
1. 增加合区工具支持合并文本功能。

问题修复：
1. 修复了播放怪物声音的错误。
2. 修复了Shape=154的衣服会有护身属性的问题
3. 修复了登录器默认拒绝接受行会喊话信息的问题
4. 修复了地图参数HITMON(@XXX)无效的问题
5. 修复了商店物品不翻页的问题。
6. 修复了MonGen.txt不能超过7个汉字的怪物
7. 修复了不能看到被攻击的人物等级
8. 修复了装备改名后套装备注不显示的问题
9. 修复了装备改名后地面物品捡取提示名称显示无效的问题
10. 修复了自动寻路一卡一卡的问题
11. 修复了英雄H.TAKE无效的问题
12. 修复了英雄或分身被弓箭手攻击不还击的问题
13. 修复了宝石升级的问题
14. 修复了人物走路检测格数太大的问题
15. 修复了内挂魔法加速太慢的问题

功能改进：
1. 人物死亡触发无需延时命令，可以直接使用复活命令复活
2. 改进套装显示方式和套装的男女识别
3. 捡到叠加物品自动叠加
4. 解包后的叠加物品自动叠加

例1. 223/套装名称|2|116/木剑|116/青铜头盔:253/攻魔道提升
例2. 223/套装名称=0|2|116/木剑|116/龙天魔甲:253/攻魔道提升
例3. 223/套装名称=1|2|116/木剑|116/凤天魔衣:253/攻魔道提升
例4. 223/套装名称|2|116/木剑|116/(龙天魔甲,凤天魔衣):253/攻魔道提升

例1 不检测性别
例2 男性套装
例3 女性套装
例4 根据鼠标选择的装备自动显示男女

【2012-07-10更新:】

新增功能：
1. 增加物品特效支持坐标。
2. 增加支持安全盾防火墙采集功能(需要配套防火墙)。
3. 增加支持登录密码功能，登录器和游戏网关密码相同才能正常登录。

4. 增加LineNotice.txt公告文件 字体颜色设置

5. 增加以下变量
<$KILLMONNAME>杀死怪物名
<$KILLMONX> 杀死怪物X坐标
<$KILLMONY> 杀死怪物X坐标
<$STATSERVERTIME> 显示M2启动时间
<$RUNDATETIME> 开区间隔时间

6. 更新反外挂特征码列表
7. 增加野蛮冲撞使用间隔控制
8. 增加装备掉持久倍率控制(选项-功能设置-其他控制)
9. 增加计时物品
限时物品带到身上开始计时,到期后必须在身上时才会自动消失.(每分钟检测一次)
物品Need=101时限时物品,NeedLevel=时间(分钟)
问题修复：
1. 修复了地图会出现假怪的问题(需测试)。
2. 修复了M2一个参数不保存的问题

功能改进：
1. 内挂中NPC名称显示控制,改由人物的名称显示控制
2. 登陆器顶部绿字信息，增加当前等级，升级经验，当前经验，元宝数量

【2012-07-02更新:】

问题修复：
1.修复了英雄不主动攻击的问题。

【2012-07-01更新:】

问题修复：
1. 修复了半月攻击力小的问题。
2. 修复了隔位刺杀会麻痹的问题。
3. 修复了地图怪物或尸体过多，杀怪不爆的问题。
4. 修复了地图连接有机率进不去的问题。
5. 修复了列表信息二-铸造物品无效的问题
6. 修复了英雄的一些问题
7. 修复了GetRandomText命令的一个问题
8. 修复了神秘装备的一个问题
9. 修复了WIL编辑器转换WZL格式的问题

【2012-06-25更新:】

新增功能：
1. 增加以下变量
<$HIT> 准确
<$SPD> 敏捷
<$HITSPD> 攻速
<$MapTitle> 取地图名称
<$USERID> 人物登录帐号
<$KILLER> 杀人者名字

2. 增加倚天辟地技能
3. 增加登录器皮肤支持导入png文件

问题修复：
1. 修复了使用连击M2有机率会产生一个报错的问题。
2. 修复了会员检测命令CHECKNAMEDATETIMELIST失效的问题。
3. 修复了顶戴花翎设置一张图片时不显示的问题。
4. 修复了地面物品名称有机率会产生乱码的问题。
5. 修复了QMapEvent触发中使用SENDMSG %s显示错误
6. 修复了人形怪的一些问题
7. 修复了多机负载的一个问题

功能改进：
1. 功能: 打开一个自定义NPC对话框

【2012-06-18更新:】

需要更新全部程序否则不能正常登录

新增功能：
1. 增加兼容HeroM2脚本命令 CheckItemBind SetItemBind CheckItemState SetItemState GiveStateItem
2. 增加玩家机器码变量 <$MACHINEID> <$USERMACHINEID>

问题修复：
1. 修复了荣誉值不保存的问题。
2. 修复了英雄的一些问题。
3. 修复了假人的一些问题。
4. 修复了数字飘血的问题。

功能改进：
1. DEC对字符型变量操作命令。
2. MOV命令做了一些改进。

<$MACHINEID> 机器码，和登录的角色无关，只要是该机器登录的角色，这个机器码就一样。
<$USERMACHINEID> 该机器当前登录的角色的机器码。不同的角色名称或不同的机器登录生成的机器码不一样。

配合以下命令可以限制角色登录游戏

CheckTextList 文件位置 字符串
AddTextList 文件位置 字符串
DelTextList 文件位置 字符串

增加脚本命令
CheckItemBind,检测物品是否已经绑定
格式:CheckItemBind 装备位置(-1~13,-1时为OK框中物品)
增加脚本命令
SetItemBind,设置物品和人物绑定 绑定后物品属性会显示“已绑定”
格式:SetItemBind 装备位置(-1~13,-1时为OK框中物品) 绑定(0-1)
说明:参数2 0=取消 1=绑定

增加:CheckItemState SetItemState GiveStateItem命令,
功能:给予带绑定状态装备。主要方便设置不能配带的装备绑定状态
格式:GiveStateItem 物品名称 项目1 项目2 项目3 项目4 项目5 项目6(0为正常,1为绑定)

;项目1--禁止扔，项目2--禁止交易，项目3--禁止存，项目4--禁止修，项目5--禁止出售,项目6--禁止爆出的装备

功能：设置装备绑定状态。
格式：SetItemState 装备位置(-1~13,-1时为OK框中物品) 项目(0-5) 属性(0为正常,1为绑定)
项目: 0 禁止扔 1 禁止交易 2 禁止存 3 禁止修 4 禁止出售 5 禁止爆出
功能：检查装备绑定状态
格式：CheckItemState 装备位置(-1~13,-1时为OK框中物品) 项目(0-5)
项目: 0 禁止扔 1 禁止交易 2 禁止存 3 禁止修 4 禁止出售 5 禁止爆出

【2012-06-16更新:】

新增功能：
1. 增加兼容HeroM2脚本命令 CheckHeroJob CheckHeroOnline CheckInWarArea TakeOn TakeOff ChangeHeroLevel ChangeHeroPkPoint

问题修复：
1. 修复了NPC名称使用变量的问题。
2. 修复了仿及时雨内挂免负重没有效果的问题。
3. 修复了鼠标左键点起英雄装备,再点右键,装备就假消失的问题。
4. 修复了英雄的一些问题。
5. 修复了CHANGEPULSELEVEL报错的问题。
6. 修复了登录器皮肤是否透明控制无效的问题。
7. 修复了登录器界面使用大图片显示不全的问题。

【2012-06-11更新:】

问题修复：
1. 修复了一个轻客户端更新的问题。

【2012-06-09更新:】

新增功能：
1. 增加WIL编辑器PAK、WIL、WZL相互转换的功能
2. 增加轻客户端更新密码功能

问题修复：
1. 修复了内挂页面控制错误的问题。
2. 修复了输入框粘贴的问题。
3. 修复了经络打通的问题
4. 修复了<%Item>无效的问题
5. 修复了WIL编辑器导入BMP文件失真的问题

【2012-06-06更新:】

新增功能：
1. 增加边下边玩轻客户端功能
2. 增加登录器搜索客户端条件设置
3. 增加WIL编辑器支持WZL编辑功能
4. 增加转生等级变量:<$RELEVEL>

问题修复：
1. 修复了新界面有个地方会挡住大装备的问题。
2. 修复了声望不保存的问题。
3. 修复了ThroughHum命令无效的问题
4. 修复了偶尔会卡位问题
5. 修复了戴上蒙面面巾头盔不显示的问题

功能改进:
Weapon.wzl Shape 1~99

【2012-05-26更新:】

新增功能：
1. 增加备用远程列表地址

问题修复：
1. 修复了刺杀的问题。
2. 修复了连击的问题。
3. 修复了ThroughHum命令无效的问题

【2012-05-22更新:】

新增功能：
1. 完善内挂中自定义快捷键功能

问题修复：
1. 修复了连击的一些问题。
2. 修复了心灵启示不能看血条的问题。
3. 修复了杀怪不能获取经验的问题。
4. 修复了高等级负重会出现负数的问题。
5. 修复了英雄会攻击弓箭手和大刀的问题。
6. 修复了1000以后经验设置不正确的问题。
7. 修复了装备属性越高价格越低的问题。
8. 修复了关闭隔位刺杀还会隔位刺杀的问题。
9. 修复了ChangeHumAbility 减属性无效的问题。

【2012-05-21更新:】

新增功能：
1. 增加开启第四个连击技能的命令

问题修复：
1. 修复了客户端一个内存错误。
2. 修复了英雄数据不保存的问题。
3. 修复了其他已知BUG。

【2012-05-20更新:】

更新后请先使用人物数据扩展工具进行数据扩展后才可以正常运行

新增功能：
1. 增加盛大新人物属性界面(配置的时候选择连击版才会显示)，酒馆、双英雄、内功、连击。
2. 增加新怪物支持Mon23~35。

问题修复：
1. 修复了一个不能解包的错误。
2. 修复了多线程网关一个内存错误。
3. 修复了其他已知BUG。

【2012-04-07更新:】

新增功能：
1. 增加宝箱功能。

问题修复：
1. 修复了查看别人时斗笠显示错误。
2. 修复了多线程网关一个错误。
3. 修复了M2一些参数不保存的问题。
4. 修复了学习背包里面的技能书，点确定，会向前走一步。
5. 修复了登录网关和角色网关一个错误。
6. 修复了NPC显示变量过多显示不出来的问题。
7. 修复了传奇归来不显示物品的问题。
8. 修复了其他已知BUG。

功能改进：
1. 地图参数NORANDOMMOVE可以使用瞬息移动

【2012-03-31更新:】

问题修复：
1. 修复了多线程网关一个错误。

【2012-03-30更新:】

新增功能：
1. 增加斗笠。

问题修复：
1. 修复了套装属性包裹不显示的问题。
2. 修复了黑夜功能无效的问题。
3. 修复了ChangeModeEx命令中的隐身无效的问题。
4. 修复了多线程网关会自动关闭的问题(需测试)。
5. 修复了其他已知BUG。

功能改进：
1. 改进个人商店(需要使用新的NewopUI.Pak 配置登录器)

【2012-03-28更新:】

新增功能：
1. 增加多线程网关测试版(启动器里需要重新配置一下，在启动器里选择多线程网关)。

问题修复：
1. 修复了会卡住的问题。
2. 修复了神秘装备在包裹中也可以看到属性的问题。
3. 修复了排行榜只能显示第一页的问题。
4. 修复了物品掉落会提示怪物名称显示数字的问题。
5. 修复了其他已知BUG。

【2012-03-22更新:】

新增功能：
1. 增加编辑器支持WZL格式。

问题修复：
1. 修复了会卡住的问题。
2. 修复了RepairALL命令无效的问题。
3. 修复了抗拒火环可以推开同等级的玩家的问题。
4. 修复了刺杀强化空砍没有强化的效果。
5. 修复了登录器自动更新的问题。
6. 修复了叠加物品出售价格的问题。
7. 修复了其他已知BUG。

【2012-03-18更新:】

问题修复：
1. 修复了M2一个错误。
2. 修复了新建组按钮无效的问题。
3. 修复了176版包裹物品显示有些错位的问题。
4. 修复了NPC名字调用变量的问题。

【2012-03-15更新:】

问题修复：
1. 修复了飓风破的问题。
2. 修复了宝石升级的问题。
3. 修复了怪物名称显示错乱的问题。
4. 修复了TAKE命令收回叠加的问题。
5. 修复了个人商铺中Looks大于10000的物品不显示属性的问题。

【2012-03-14更新:】

新增功能：
1. 增加飓风破。

问题修复：
1. 修复了食人花绘制错误的问题。
2. 修复了僵尸Race;95 从地下钻出来后留下的洞显现缓慢的问题。
3. 修复了装备等显示有点错位的问题。
4. 修复了TAKE命令收回叠加的问题。
5. 修复了其他已知BUG。

【2012-03-04更新:】

新增功能：
1. 增加登录验证码功能，在LoginSrv.exe中控制关闭。
2. 增加月灵与召唤圣兽是否可以同时召唤的选项。
3. 增加脚本命令GetOppositeHumName。
4. 增加脚本命令CheckNationCredit
5. 增加一个新游戏点<$GAMEGOLDEX>。

问题修复：
1. 修复了解毒术锁定怪物的问题。
2. 修复了ESC键会关闭英雄左上角窗口问题。
3. 修复了噬血术强化4-6重会卡一下的问题。
4. 修复了逐日剑法技能点不增长的问题。
5. 修复了其他已知BUG。

功能改进：
1. 修改使用宝石装备升级提示方式
2. 修改人型怪属性根据DB数据库中设置防御 魔防 攻击 道术 魔法。
3. 修改checkitem命令支持检测叠加物品
4. 修改加载安全区挂机人物,安全区随机坐标登录

【2012-02-26更新:】

问题修复：
1. 修复了怪物偶尔会有错乱的顶戴花翎。
2. 修复了人形怪不会读取顶戴花翎的问题。
3. 修复了及时雨内挂重复音乐控制无效的问题。
4. 修复了一处内存泄漏

【2012-02-22更新:】
问题修复：
1. 修复了自动脱装备AutoTakeOffItem 装备位置 无效的问题。
2. 修复了查看别人装备时不看不见头盔发光效果。
3. 修复了地图参数中播放音乐，内挂的重复音乐控制无效的问题

功能改进：
1. RepairAll 操作命令改为检测命令修理全身装备时，检测修理需要的金币

【2012-02-18更新:】
问题修复：
1. 修复了套装失效触发[@GroupItemOffX]不触发的问题。
2. 修复了内挂不显示保护的物品。

【2012-02-16更新:】

新增功能：
1. 增加诱惑之光的设置。
2. 增加烈火剑法设置。
3. 增加及时雨内挂中玩家自己输入药名。
4. 增加杀死人物宝宝时触发[@KillSlave]
5. 增加脚本命令检测杀死的宝宝的名称CheckKillSlaveName
5. 增加脚本命令检测是否是指定行会的成员CheckGuildMember
6. 增加脚本命令改变人物宝宝名字颜色.ChangeSlaveNameColor 格式: ChangeSlaveNameColor 宝宝名字 颜色(0-255)
7. 增加脚本命令增加限次使用物品的次数.AddFunItemDura
8. 增加GM命令给定指定纯度的矿石.@GiveMine
9. 增加地图参数 REVIVALREVIVAL(X:N) 当前地图人物可复活的次数,
X表示复活次数,N表示人物在当前地图已经复活次数的自动清零间隔(最小30秒).具体表示:每经过指定秒人物在当前地图复活过的次数自动减1.
10. 增加地图参数 NODROPUSEITEMS 当前地图人物死亡不掉落身上的物品
11. 增加地图参数 NOSAFEPOSITIONMOVE 禁止在当前地图安全区中使用传送戒指
12. 增加GM命令给定指定纯度的矿石.@GiveMine 数量 纯度

功能改进：
1. playsound和playmusic命令修改 文件位置 循环次数 播放模式(0播放给自己,1播放给全服,2播放给同一地图,3播放给同一行会,4播放给同屏人物)
2. ChangeSpeed 速度类型 速度值 有效时间(秒，该参数为空时表示不限制时间)
3. 套装生效触发[@GroupItemOnX],套装失效触发[@GroupItemOffX],英雄对应[@HeroGroupItemOnX],[@HeroGroupItemOffX] X表示套装序号
4. 人型怪HP和MP按DB中数据设置

问题修复：
1. 修复了装备攻击速度无变化的问题。
2. 修复了雷霆剑法的问题。
3. 修复了内挂背景音乐重复播放的问题。
4. 修复了移行换位会锁定怪物的问题。
5. 修复了转换性别发型的问题。
6. 修复了除法、乘法、百分比脚本命令的问题。
7. 修复了传奇续章界面药框界面错位的问题。

【2012-02-08更新:】
修正交易完成后负重不变的问题
修正ChangeNationCredit脚本命令
修正毒死怪物，物品不会掉落
增加TakeOnItem和TakeOffItem脚本命令支持变量
TakeOnItem <$STR(S3)> 12
TakeOffItem <$STR(S3)> 12

增加地图参数SAYLEVEL(等级),可限制当前地图人物说话等级.
增加地图参数DELDROPITEM,人物(英雄)死亡后掉落的身上物品立即消失(不掉落在地图中).

【2012-02-08更新:】
修正交易完成后负重不变的问题
修正ChangeNationCredit脚本命令
修正毒死怪物，物品不会掉落
增加TakeOnItem和TakeOffItem脚本命令支持变量
TakeOnItem <$STR(S3)> 12
TakeOffItem <$STR(S3)> 12

增加地图参数SAYLEVEL(等级),可限制当前地图人物说话等级.
增加地图参数DELDROPITEM,人物(英雄)死亡后掉落的身上物品立即消失(不掉落在地图中).

【2012-02-05更新:】
修正群毒消耗计算错误
修正宝石升级的问题,支持装备加星
修正CHECKVAR和CALCVAR脚本命令
修改GROUPMOVE和GROUPMAPMOVE脚本命令
修正其他已知BUG
增加变量清除功能(管理-文件管理)

;只有组长，才可以使用
GROUPMOVE 地图号 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空)
GROUPMAPMOVE 地图号 X Y 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空)

增加脚本命令

命令 ClearItemMap
功能:清理地图上指定名字的物品.
格式:ClearItemMap 地图 坐标X 坐标Y 范围 物品名字
说明:物品名字等于*时表示指定范围内的所有物品.

ChangeNationCredit
调整人物的荣誉值

AddGuildMemberCount
功能: 调整当前行会的人数上限.说明: 只能由行会老大使用.
每个行会会自动读取!Setup.txt中的行会人数限制,
之后可以用此命令重新调整行会人数限制,也就是说调整后不受!Setup.txt中行会人数限制参数的限制.
格式: AddGuildMemberCount 操作符(+ - = ) 数量(0--1000)

格式：Gotonow X坐标 y坐标 [地图名]自动寻路
注：地图名可省略，加上后引擎自动判断人物当前地图是否相同。

【2012-01-15更新:】
出现问题时：
(1)请首先检查你出现问题的全套程序和登录器是不是我们最后更新的。
(2)检查是不是脚本写错了或引擎没设置好，可以搜索说明书和更新记录。
(3)还没有解决问题，可以到论坛或找技术求助。
修正挖不到高品质肉
修正登录器公告不显示的问题
修正宝石升级问题(需测试)
修正有机率卡住的问题(需测试)
修正英雄装备绘制遮盖的问题
修正其他已知BUG
增加以下功能
点击界面帮助按钮触发

功能: 改变人物公聊时的文字信息颜色.

功能: 杀死怪物时触发

【2012-01-10更新:】
修正血条绘制错误
修改人物死亡可以点击NPC
修改人物命令@TestStatus增加第三个参数,1时提示,0不提示.例如:Gmexecute TestStatus 5 1
增加私聊等级显示控制(选项-参数-信息控制)
增加以下脚本命令

增加技能检测

功能: 改变当前人物的穿人,穿怪模式.

功能: 组队相关触发.

功能: 装备持久消失时触发,位置0-12

【2012-01-07更新:】
修正火墙时间计算错误
修正掉落物品提示的问题
修正降级导致血条绘制错误

【2012-01-05更新:】
此次更新程序 IPLocal.dll HeroM2Convert.exe M2Server.exe m2登录器生成器.exe 请同时更新否则不能正常游戏

修正滚动命令无效
修正点住自定义NPC对话框会闪的问题
修正IP插件无效的问题
修正ChangeItemName脚本命令的问题
修正全屏登录没有声音的问题
修改若干细节
增加ESC关闭所有打开的窗口

【2011-12-30更新:】
此次更新程序 M2Server.exe m2登录器生成器.exe 请同时更新否则不能正常游戏

修正使用NORANDOMMOVE地图参数，还可以使用瞬息移动的问题
修正登录会闪一下的问题
修正MMAP1.WIL调用小地图无效
修正极品提示只有一个方向
修正其他已知BUG
修改自动放药方式

增加装备持久为0时是否消失选项
增加火墙的时间和威力倍数控制
增加掉落物品提示规则
增加脚本命令(兼容HeroM2)
OFFLINEPLAY
GETSTRINGPOS
SENDCENTERMSG
ChangeItemName

功能: 新的装备改名

功能: 在专用登录器屏幕的中间显示公告.

【2011-12-26更新:】
此次更新程序 M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正一个卡的问题
修正机器人使用THROWITEM命令M2报错的问题
修正流星火雨秒怪的问题
修正内挂不显示地上的勋章和四格物品的名字
修正HeroM2Convert转换工具的一个错误(转换Hum3.wil错误)
修正其他一些细节
增加小地图mmap1.wil(800~999)
增加支持读取Graphics放在Resources目录里
增加火墙换地图消失
增加脚本命令(兼容HeroM2)
ForbidMyShop
CheckMine
TakeMine
CheckHeroCount
SetSuckDamage
SetHeroSuckDamage

CheckMine
功能: 检测背包中物品的纯度(持久,品质).
格式: CheckMine 物品名称 数量(1-45) 纯度(1-65)

例子: 检测背包中是否有5个纯度20的黑铁矿石,并且回收.
[@main]
#IF
CheckMine 黑铁矿石 5 20
#ACT
TakeMine 黑铁矿石 5 20
#SAY
背包中有5个纯度20的黑铁矿石.
#ELSESAY
没有.

检查人物当前召唤了几个分身

SetSuckDamage

说明:设置人物可吸收收到的攻击伤害.
格式: SetSuckDamage 操作符(+ - =) 总吸收直(1-2000000000) 吸收比例(1-1000) 成功率(1-100)
吸收比例 1=0.1% 500=50% 1000=100%
例子: 设置总共吸收1000点伤害,每次吸收20%伤害,成功率95%

SetHeroSuckDamage
说明:设置英雄可吸收收到的攻击伤害.
格式: SetHeroSuckDamage 操作符(+ - =) 总吸收直(1-2000000) 吸收比例(1-1000) 成功率(1-100)
吸收比例 1=0.1% 500=50% 1000=100%

【2011-12-24更新:】
此次更新程序 M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正一个黑屏问题
修正挑战传送的问题
修正SENDMSG发送的信息不能包含空格的问题
修正CheckLuckPoint检测幸运不正确的问题
修正M2在64位系统不能运行的问题
修正内挂部分按钮不能控制的问题
增加脚本命令清除附加属性ClearStoneUpgrade

【2011-12-23更新:】
此次更新程序 M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏
修正已知BUG
增加HeroM2版本转换工具
增加挑战功能(兼容HeroM2)
增加宝石升级系统(兼容HeroM2)

增加支持
武器和衣服时可按照一件武器一个.wil文件的方式配置.
武器放在传奇目录的\Graphics\Weapon\
衣服放在\Graphics\Human\下.
物品数据库中单个武器和衣服的Shape值从1000开始算起.
单个武器和衣服素材的文件名必须和物品数据库中的Shape值一样,
例如:数据库中设置Shape=1000,那么单个武器或者素材的文件就是1000.wil,如果Shape=1001那么文件名就是1001.wil

兼容HeroM2脚本命令，增加或以下脚本命令
CHECKKILLMONNAME
CHECKHITMONNAME
CHECKOFFLINE
CHECKITEMNAMECOLOR
KILLBYHUM
CHECKRANDOMNO
CHECKFOUNDRYITEM
CHECKGUILDMEMBERCOUNT
CheckUpgradeItemName

OFFLINE
SENDTOPMSG
CHANGESLAVELEVEL
SETHUMATTACKMODE
GETLISTSTRING
GETUSERITEMNAME
GETCALLMOB
KILLCALLMOB
ADDATTACKSABUKALL
CHANGEITEMNAMECOLOR
SETRANDOMNO
GIVEFOUNDRYITEM
SHOWFOUNDRYITEM
CHALLENGMAPMOVE
GETCHALLENGEBAKITEM
CREATENPC
DELNPC
PLAYMUSIC
OpenUpgradeDialog
SetUpgradeFail

【2011-12-20更新:】
此次更新程序 RunGate.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏
增加仿及时雨内挂
增加登录器支持盛大wzl新格式读取
修正登录器会卡死的问题

新格式读取说明:
以读取Prguse.wil为例，
先读取Resources\Data\Prguse.pak,如果Resources\Data\Prguse.pak不存在,读取Data\Prguse.wil,如果Data\Prguse.wil不存在,读取Data\Prguse.wzl。

【2011-11-18更新:】
此次更新程序 DBServer.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正套装列表错乱的问题
修正GETITEMADDVALUE和CHANGEITEMADDVALUE命令不能使用变量的问题
增加脚本命令RecallSelf召唤自己的分身

【2011-11-16更新:】
此次更新程序 RunGate.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正矿石纯度越低价格越高,纯度越高价格越低
修正GIVE命令给叠加物品的问题
修正其他已知BUG
增加白天黑夜时间点控制
增加人形怪可以挖物品选项
补丁规律查看
动态地图连接查看
脚本使用图标功能查看
检查当前地图中的人物是否属于同一行会

【2011-11-12更新:】
此次更新程序 WIL编辑器.exe RunGate.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正WIL编辑器转换大WIL文件时出错的问题
修正使用CHANGEMODEEX锁定后还可以走的问题
修正NPC对话框中所有包含“<>”或者“{}”的总会比原本的字符稍微长一点点
修改网关封加速，误封率下降
增加登录器配置可以自定义客户端核心文件名称
增加IP所在地禁止登录列表D:\MirServer\Mir200\Envir\DenyIPLocalList.txt
增加支持“<>”里再次使用变量

例:

[@main]
<调整颜色{FCOLOR=<$STR(G0)>}/@调整颜色>\

变量S<$STR(G0)>值:<$STR(S<$STR(G0)>)>\

[@调整颜色]
#IF
large G0 255
#ACT
MOV G0 0
GOTO @MAIN
#ELSEACT
INC G0 1
GOTO @MAIN

【2011-11-09更新:】
此次更新程序 LoginSrv.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正登录器显示天气效果时内存占用高的问题
修正聚灵珠的问题
修正收取重叠物品的错误
修正NPC彩色字体
增加数据管理工具
增加支持个人商店数据合区
增加假人配置文件中自动捡物的参数

【2011-11-03更新:】
此次更新程序 DBServer.exe LoginSrv.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正英雄穿装备的问题
修正物品"死亡必爆"规则无效的问题
修正穿脱装备不触发的问题
修正176登录器的一个错误
修正其他已知BUG
M2增加一个新的反加速外挂功能,使用外挂触发QFunction-0脚本里[@UsePlugin]字段
增加禁止免蜡功能天气效果(免费版不支持)
增加假人功能(免费版限制登录10个假人)
修改SETICON脚本命令，增加播放效果参数。人物设置NPC和怪物的顶戴花翎也相应的修改NPC和怪物设置
外挂触发字段外挂触发
更新NewopUI.Pak补丁

NewopUI.Pak 说明：
如果不使用个人商店功能，可以清空NewopUI.Pak中104~163的图片
如果不使用禁止免蜡功能，可以清空NewopUI.Pak中210~215的图片
这样可以减小登录器的大小

【2011-10-24更新:】
修正使用16位色登录游戏时，个别机器会出现白块的问题
修正M2关闭内挂，人物说话不显示的问题
修正其他已知BUG
修改PLAYSOUND命令支持循环次数 PLAYSOUND 文件路径(不能有空格) 循环次数
优化资源读取速度
增加NPC和怪物支持顶戴花翎功能NPC和怪物设置

【2011-10-18更新:】
此次更新程序 游戏启动控制器.exe LoginGate.exe SelGate.exe LoginSrv.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正读取Weapon2.wis的问题
修正使用大NPC对话框调用PAK文件的问题
修正内挂保存配置文件的问题
修正人物死亡地图不是灰色的问题
修正双线一区配置的问题

修改GETRANDOMLINETEXT命令
修改MAPEFFECT命令
格式: MAPEFFECT 地图名称 X Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 播放效果(0普通 1特效)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

【2011-10-13更新:】
此次更新程序 游戏启动控制器.exe LoginGate.exe SelGate.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正不能双开游戏的问题
修正全屏切换后物品显示不正常

【2011-10-12更新:】
此次更新程序 游戏启动控制器.exe LoginGate.exe SelGate.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正使用NPC彩色字体时排列不正确的问题
修正地图触发时脚本命令无法对人物进行操作的问题
修正战士使用技能的问题
修正小退会出现无法认证的问题(小退速度过快导致的)
修正英雄召唤神兽的问题
修正其他已知BUG
增加双线一区配置功能
增加聊天记录过滤按钮的控制
增加特殊命令的控制
增加反外挂特征码功能
使用外挂触发QFunction-0脚本里[@UsePlugin]字段

【2011-10-04更新:】
此次更新程序M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正月灵的问题
修正技能护体神盾施放后不加点问题
修正群体施毒术不自动换毒符
的问题
修正CheckRangeHumCount命令报错
增加登录器获取列表失败时，提醒用户是否重新获取
增加Items1.wil DnItems1.wil StateItem1.wil 数据库Looks起始编号10000开始
增加补丁读取

【2011-10-01更新:】
此次更新程序DBServer.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正M2强化技能的一个报错信息
修正CheckHumInRange命令报错
修正英雄技能书的问题
修改若干细节
修正一些其他问题
优化客户端，CPU占用下降，流畅性提高

【2011-09-25更新:】
此次更新程序LogDataServer.exe DBServer.exe M2Server.exe 登录器生成器.exe 请同时更新否则不能正常游戏

修正M2一个报错信息
修正英雄一些问题增加忠诚度
修正群毒无效的问题(需要更换我们提供的技能数据库)
优化引擎数据传输速度
增加极品装备属性点数更加详细的控制
增加日记服务器日记查询功能
增加人物找回功能
加快小退的速度
修改若干细节
修正一些其他问题

【2011-09-18更新:】
修正地图禁止使用物品和魔法无效的问题
修正挖肉的一个问题
修正会秒杀人物的问题
修正偶尔死亡不触发的问题
修改176版交易物品属性显示样式
加快人物的后仰速度
增加魔法锁定范围的选项，在技能魔法选项里，可以提高锁定精度，防止人物跑动时，打不到人物
修正一些其他问题

【2011-09-08更新:】
修正有的机器登录器自动更新完成后不能自动打开新登录器的问题
修正获取最高等级可能产生的内存错误
修正英雄打怪的时候，不跟着人物回城
修正英雄包裹的问题
修正一个卡技能的问题
修正读取WIS文件一个错误
修正挖肉时会导致包裹里肉的品质下降的问题
修改176仓库物品属性显示样式
加快小退的速度
限制输入框输入文字的长度
修正其他一些问题

【2011-09-05更新:】
修正角色名有拖尾的问题
修正魔法锁定神兽，神兽变身后，解锁的问题
修正地图事件触发的一些问题
修正176版本戴不上传音筒
修正英雄升级不能正确显示等级
修正CHECKNAMEDATETIMELIST命令过期记录自动删除的问题
OPENUPGRADEDLG做了一些改进
输入框做了一些改进
增加个人商店出售物品和仓库数量限制
增加地图参数ALLOWUSEMYSHOP允许使用个人商店，没有该参数的地图只能搜索查看，无法出售购买存仓操作
增加个人商店物品规则设置
增加人形怪爆物品机率的设置
增加使用魔法触发QFunction脚本 [@MagicX] X表示魔法ID
增加最高等级限制

【2011-09-02更新:】
修正一个会产生地图产生白块的问题
修正英雄增加魔法命令的问题
修正内挂的一些问题
修正CheckStringlength的问题
修改ADDTOCASTLEWARLIST脚本命令
修改攻击触发兼容HEROM2
增加爆物品触发
更新说明书

格式：CheckStringlength 字符串 检测符(<,>,=) 位数

;============================================================

格式: ADDTOCASTLEWARLIST 城堡名称 行会名称(行会名称为空时所有行会加入到攻城列表) 天数(几天后开始攻城，该参数可以为空，为空时按照引擎设置的天数)

[@main]
#ACT
ADDTOCASTLEWARLIST 沙巴克 1

魔法和物理攻击触发

地图事件配置详解 必须在M2-选项-功能设置-基本设置-启用地图事件触发勾上才有效

【2011-08-29更新:】
修正装备特效造成地图产生白块的问题
修正人形怪不爆包裹装备
修改M2内挂的一些控制方式

【2011-08-23更新:】
修正交易看不到对方名称
修正死亡复活后关闭背景音乐
修正脚本命令SENDMOVEMSG无效的问题
修正脚本命令SENDTOPCHATBOARDMSG无效的问题
修正脚本命令OPENUPGRADEDLG可能会产生复制装备
修正删除不了物品特效的问题
修正客户端一些绘图错误。
修正开门会闪的问题
修正读取某些资源会产生CPU高的问题
修正内挂自动吃药的一个问题
修正包裹物品偶尔刷新不正常的问题
修正仓库偶尔存取不正常的问题
修正隐身翅膀也隐藏了
修正其他若干BUG
修改一些细节

【2011-08-11更新:】
修正登录器有开门动作时，角色选择界面不显示职业等级
更新说明书

【2011-08-10更新:】
修正地图连接的一个问题
修正定时器的问题
内挂中增加怪物名称显示的选项
登录器配置器增加是否显示开门效果的选项

修正新属性的设置没有保存，导致无法爆出有新属性的装备
修正个别机器全屏登录失败的问题
修正战士没有强化技能效果
修正野蛮冲撞，会触发反外挂系统
修正一些老地图会花屏的问题
修正连续玩几个小时后，由于程序释放内存太慢，造成卡的问题
修正脚本命令CHECKNAMEDATETIMELIST和ADDNAMEDATETIMELIST
修改若干细节
修正其他已知BUG

【2011-08-04更新:】
修正看不见弓箭手射的箭，包括弓箭手和祖玛弓箭手等等怪物。
修正可以同时召唤骷髅和神兽。M2增加一个选项，可以选择是否可以同时召唤
修正移动加速无效的问题
修改装备显示的一些细节
增加WIL编辑器支持PNG和TGA文件的导出和导入
-------------------------------------------------------------
新增兼容HERO的命令或功能
QManage.txt中增加一个新的脚本段[@Startup],此脚本段只在服务器开启后执行一次.

-------------------------------------------------------------
增加脚本命令ChangeModeEx
-------------------------------------------------------------
增加脚本命令MoveMapPlay 原地图 新地图 X Y
把某个地图中的玩家全部移动到另外一个地图.
#IF
#ACT
MoveMapPlay 0 3 333 333
#SAY
地图0中的人物已经全部移动到地图3中.

-------------------------------------------------------------
应用户要求重新修改以下素材读取

【2011-08-02更新:】
开放登录器的必备补丁修改的。提供专用的WIL编辑器，支持设置密码功能
增加各职业一些技能的细节控制
增加暴击的魔法效果
增加护体神盾、乾坤大挪移、擒龙手、召唤圣兽、召唤月灵等技能
扩展物品数据库物品名称支持到30个字符
扩展怪物数据库怪物名称支持到30个字符，扩展HP和MP字段支持到21亿
优化客户端数据处理
修改装备备注支持颜色设置
修正人物死亡屏幕效果
修正套装显示的错误
修正装备加速无效的问题
修正登录器在有的情况下会初始化失败
修正流星火雨和噬血术效果错误
修正其他已经BUG
装备及套装备注说明

【2011-07-28更新:】
优化登录器核心
增加道士可以直接使用包裹中毒符选项
增加千里传音和传音筒文字颜色控制
增加浏览器地址可以在M2自定义
增加内挂中自动吃药的物品可以在M2上控制
增加各职业强化技能
增加套装显示备注
修正技能幽灵盾和神圣战甲术没有符飞行的效果
修正重新加载NPC后，QFunction-0 字段触发引擎会报错的问题
修正脚本命令CHANGEEXP,调整的经验值不正确的问题
修正内挂中物品过滤框向下滚动按钮点不了的问题
修正关闭背景音乐，登录的时候会响一秒的问题
修正读取Wis文件会花屏的问题
修正反外挂误封的问题
修正一些技能没有声效的问题
修正人形怪和英雄装备攻击翻倍没有效果的问题
修正PlaySound脚本命令无效的问题.例: PlaySound Wav\1.wav
修正叠加物品会暴出很多个
修正自动行走有人挡着无法行走的问题
修改内挂中隐藏尸体只隐藏怪物的尸体
修改以下素材读取

强化技能说明:

CHECKSKILL 魔法名称 检测符(+,-,=) 等级 是否检测强化技能(0或为空时为技能等级,1为强化技能等级)
SKILLLEVEL 魔法名称 调整符(+,-,=) 等级 是否调整强化技能(0或为空时为技能等级,1为强化技能等级)
例：
[@main]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重

【2011-07-15更新:】
更换老版的网关，多线程网关会造成卡的问题。
修正脚本命令MAPEFFECT。在地图上播放特效，不能控制播放次数的问题
修正脚本命令CHANGEITEMADDVALUE，修改成功后不能立即显示的问题
修正客户端背景音乐 MUSIC(Wav\music1.mp3)，放到地图参数中。(目录名称和音乐文件名称不能有空格)
修正自动练功速度快了，会触发反外挂系统
修正装备显示的BUG

【2011-07-12更新:】
修正人物属性下限不正常的问题
修正抓屏会卡一下的问题
优化素材载入速度
优化播放音效造成CPU过高的问题
增加装备显示附加属性,可以在M2上控制是否显示
增加脚本命令CHECKITEMADDVALUE,检测物品的附加属性值
增加脚本命令CHANGEITEMADDVALUE,修改物品的附加属性值
增加脚本命令GETITEMADDVALUE, 获取物品的附加属性值

CHECKITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) (符号 < > =) 值
CHANGEITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) (符号 + - =) 值
GETITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性位置(0-14) 保存变量

【2011-07-09更新:】
修正英雄血量不正常的问题
修正没有魔法时还在自动使用技能
修正创建人物界面显示的一些问题
修正一些图片显示不正常的问题
修正个别机器对纹理压缩支持不好的问题（会造成有的按钮不能点的问题）
修正右键不能开关组的问题
修正命令GuildNoticeMsg无效的问题
修改登录器搜索客户端算法,提高搜索客户端的速度
增加登录器自动记录最后一个游戏区，下次打开的时候，自动选择上次最后登录的区
增加登录器自动记录最近登录的游戏区
增加登录器自动刷新远程列表功能
增加脚本命令ChangeHumAbility
增加脚本命令SetStringBlank

调整人物属性.
格式: ChangeHumAbility 属性(1-12) 操作符(+ = -) 效果(1-65535) 时间秒
说明: 属性1-10分别对应人物 防御下限 防御上限 魔御下限 魔御上限 攻击下限 攻击上限 魔法下限 魔法上限 道术下限 道术上限 MaxHP MaxMP
注意:调整后的属性效果只在人物在线时有效.
不带时间为在线一直有效

例子:
#IF
#ACT
ChangeHumAbility 2 + 10 60
#SAY
你的防御上限增加10点.60秒后恢复

功能: 给字符串在前面或者后面增加指定个数的空格.
格式: SetStringBlank 变量(S,A) 长度(1-100) 格式(0, 1)
说明: 可支持人物S变量或者全局A变量,格式0=前面,1=后面
注意: 第二个参数长度是指增加空格后整个字符串的长度,例如字符串翎风引擎长度是9,
如果第二个参数设置1 那么实际增加6个空格.
注意: 英文字母和数字占用1个字节(长度),汉字占用2个字节(长度).

例子:
[@main]
#IF
#ACT
MOV S10 翎风引擎
SetStringBlank <$STR(S10)> 15 0
SendMsg 5 <$STR(S10)>

MOV S10 翎风引擎
SetStringBlank <$STR(S10)> 15 1
SendMsg 5 <$STR(S10)>

【2011-07-07更新:】
更新引擎帮助文件
增加自动登录离线挂机人物
使用DBServer导出数据，导出的文件保存到X:\MirServer\Mir200\Envir\AutoLoadOffline.txt
然后在M2操作-控制-加载脱机人物
增加装备旧的显示模式
修正5600端口不能修改的问题
修正SENDCENTERMSG 命令无效的问题
完善WebBroser命令，使用客户端内置浏览器打开网站

【2011-07-03更新:】
增加脚本命令SetIcon，在人物头顶显示一个头像。
增加摆摊控制命令[@ShopStall]

【2011-07-01更新:】
增加客户端装备显示框可以在M2上控制
增加免费版可以增加5个WIL文件(用于装备特效)
增加支持900 * 600宽屏分辨率
重新制作的内挂，M2可以详细控制,支持隔位刺杀，走位刺杀等等
增加脚本命令 CHECKNEWITEMVALUE 检测装备新增属性
增加登录器上分辨率选择和窗口模式选项
增加吃药间隔控制(选项-参数设置-游戏速度)
修正快捷键退出游戏时会弹出2次对话框
修正纹理压缩模式时，按钮有时候无法点击的问题
修正人物属性框中，某些衣服会挡着项链戒指等装备

例：
CHECKNEWITEMVALUE 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 检测符(>,<,=) 值(1-100)
属性(0-10)
(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

【2011-06-20更新:】
增加脚本命令改变人体颜色支持0~255中颜色
SETBODYCOLOR 颜色(0~255)255时清除颜色 改变时长(秒)

增加脚本命令改变人物状态
MAKEPOSION 类型(0-5,0和1是绿毒和红毒 5是麻痹 其他无效) 时间(秒) 威力

例：
#ACT
MAKEPOSION 5 10 10
#SAY
你被麻痹了

【2011-06-19更新:】
增加界面按钮的显示控制，可以在M2设置是否显示
增加人物或怪物的等级，HP,MP最高支持到21亿,在M2参数设置-游戏选项(1)
修改装备发光特效，可以使用脚本命令SETITEMEFFECT控制

增加装备以下新属性

(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

增加脚本命令：

;打开可以放物品的对话框，也就是装备修理或出售物品的那个对话框
OPENUPGRADEDLG 装备升级(显示的名称)

;收回OK框中的物品
TAKEDLGITEM

;返回OK框中的物品到包裹
RECLAIMITEM

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>\
OK框中物品的StdMode:<$DLGITEM.STDMODE>\
OK框中物品的持久:<$DLGITEM.DURA>\
OK框中物品的最大持久:<$DLGITEM.DURAMAX>\
<升级/@升级>\

[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM

SetNewItemValue 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)

属性(0-10)
(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%

;设置装备发光特效
SETITEMEFFECT 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 特效编号(0-255,0为清除特效)

【2011-06-09更新:】
修正延时公告坐标不正确的问题
修改176版的登录背景音乐
修改装备显示方式
修改个人商店的一些细节
增加启动控制器数据备份功能
增加新沙巴克的资料
增加Alt + R 刷新包裹
增加每个行会限制最高成员的功能

;检测行会最高成员
CHECKGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示检测自己所在的行会) 检测符(<,>,=) 数量
;调整行会最高成员
CHANGEGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示调整自己所在的行会) 调整符(+,-,=) 数量

<$GUILDMEMBERMAXLIMIT> 显示你的行会最高成员数

【2011-06-05更新:】
修正CHECKUSERDATE报错的问题
修正个人商店的问题（程序包有详细脚本）
修正客户端内存一个错误
修正客户端播放声音的内存泄漏
修正1.76版，双击戴不了毒符的问题
修正右手镯偶尔戴不上的问题
修正内挂隐藏尸体无效的问题
增加毒符的持久比例(功能设置-技能魔法)

【2011-06-02更新:】
修正数字飘血关闭不了的问题
修正仓库物品取不了的问题
修正行会窗口错误
修正交易信息文字错位
修正装备持久信息显示错误
修正数据库服务器刷新排行榜的错误
修正其他已知BUG
增加窗口模式下，可任意拖动窗口，改变窗口大小

【2011-05-26更新:】
完善所有NPC
兼容HeroM2增加脚本命令

格式: GuildNoticeMsg 255 233 发送自定义颜色的文字信息. Self

参数一是前景颜色,参数二是背景颜色,参数三是要发送的文字信息,参数四等于'Self'时只发送给自己, 等于'Group'时发送给组队,
等于'Map'时发送到当前地图中的人物.如果省略参数四表示全服发送.

支持的参数: %s(玩家名字) %d(NPC名字) %m(地图名字) %x%y(坐标)

;MESSAGEBOX支持确定和取消触发
MESSAGEBOX 是否确认要删除 @确定 @取消

[@确定]
点击的确定

[@取消]
点击的取消

;指定人物触发字段
HCALL 人物名称 触发字段

;自动穿装备
AutoTakeOnItem 装备名称 装备位置

;自动脱装备
AutoTakeOffItem 装备位置

;获取文本字符
GetRandomText 文件路径 变量

;定时触发
DelayCall 时间毫秒 触发字段

;检查是否在某地图
ISONMAP 地图名称

;打开自定义NPC对话框
OpenBigDialogBox WIL文件编号 图片编号

;关闭自定义NPC对话框
CloseBigDialogBox

;复活
Relive

;检测宝宝是否在指定范围
CheckSlaveInRange 宝宝名称 范围

;检测指定范围内的人物数量
CheckRangeHumCount 地图名称 X Y 范围 (<,>,=) 数量

;检测人物是否处在地图的某个范围之内
CheckHumInRange 地图 坐标X 坐标Y 范围(0 -- 500)

;检测城堡是否正在攻城
CHECKCASTLEWAR 沙巴克

【2011-05-23更新:】
增加数字飘血功能
美化装备显示框
增加个人商店功能.拍卖，无限仓库，摆摊功能的合并
修正已知BUG

【2011-05-08更新:】
登录器采用新的优化算法，CPU占用率大幅度下降，整体性能比以前提高几倍。
修正全屏切换会出错的问题
修正登录器有的机器无法关闭的问题

【2011-04-29更新:】
修正有的机器会调整系统音量的问题
增加支持盛大新的土城地图(地图花屏问题)

;检测是否进入攻城的范围

CHECKCASTLEWARAREA 城堡名称

;检测是否正在攻城

CHECKUNDERWAR 城堡名称

;检测地图相同怪物数

CheckMapSameMonCount 地图名称 怪物名称 控制符(<,>,=) 数量

【2011-04-26更新:】
修正骰子不显示的问题
增加游戏的整体登录速度
增加以下脚本命令

;修理所有装备
REPAIRALL

;回城
GOHOME

;复活
REALIVE

;把人物加入行会
ADDGUILDMEMBER 行会名词 人物名称(人物名称为空时把自己加入到行会)

;把行会加入攻城列表
ADDTOCASTLEWARLIST 城堡名称 行会名称(行会名称为空时所有行会加入到攻城列表)

;在地图上放物品
THROWITEM 地图名称 X坐标 Y坐标 范围 数量 物品名称
THROWITEM 3 336 336 12 2000 金币

;检测地图怪物数量
CHECKRANGEMONCOUNTEX 地图名称 怪物名称 X坐标 Y坐标 范围 控制符(=,>,<) 数量

增加攻击触发 QFunction-0

【2011-04-21更新:】
修正人物捡物品和扔物品负重不变的问题
修正使用某些技能会原地走路的问题
修正登录器浏览器的尺寸修改不了的问题
修正右键会停止自动追杀
修正在商店购买的物品会产生多个叠加(老版本升级重新启动前，需要删除 Market_prices和Market_saved目录下的文件)
修正1.76毒符的位置放到左手镯上
DBServer增加可创建角色数量的选项(用于传奇外传创建三角色)
增加游戏速度功能

ChangeSpeed 速度类型 速度值
速度类型 1为 移动速度 2为攻击速度 3为魔法速度
速度值(-10和10之间 小于0为减速 等于0不变速)

CHANGESPEED 1 5

【2011-04-13更新:】
增加支持传奇外传。
增加登录器皮肤自定义编辑
去掉登录时的开门动画
修正客户端一些图片错误
修正其他已知BUG

【2011-04-03更新:】
增加1.76、1.85、英雄版本、传奇续章。传奇外传正在制作中。
目前引擎支持1.76、1.85、英雄版本、传奇续章、传奇归来。

增加商铺支持元宝，金币，泡点三种货币购买。
增加任务对话框的页面可以在引擎自由设置。详见引擎：工具-任务NPC配置
增加人形怪配置。详见引擎：选项-怪物设置-人形怪设置
增加装备的发光特效，可以设置读取任意WIL资源的效果图片,可以设置装备的外观、内观，包裹中的效果。详见引擎：查看-列表信息(二)-物品特效
增加物品在地面颜色的显示设置，在物品数据库中增加字段Color
增加物品叠加功能，在物品数据库中增加字段OverLap
增加控制器自动配置数据库功能，有些用户不会配置数据库和增加数据库字段。启动控制台就可以自动配置。
增加好友功能
增加脚本命令：

金刚石
CHECKGAMEDIAMOND (<,>,=) 值
GAMEDIAMOND (+,-,=) 值
<$GAMEDIAMOND>

灵符
CHECKGAMEGIRD (<,>,=) 值
GAMEGIRD (+,-,=) 值
<$GAMEGIRD>

荣誉
CHECKGAMEGLORY (<,>,=) 值
GAMEGLORY (+,-,=) 值
<$GAMEGLORY>

检测字符串长度
CHECKSTRINGLENGTH (<,>,=) 值

检测是否有英雄
HAVHERO

创建文件
CREATEFILE ..\QuestDiary\名称列表.txt

PLAYEFFECT 人物效果 所有人可见 可以制作凤天魔甲的光环等效果
MAPEFFECT 地图效果 所有人可见 可以制作泉水喷溅、地图魔法等效果
SCREENEFFECT 屏幕效果 自己可见

PLAYEFFECT WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒)
MAPEFFECT 地图名称 X Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒)
SCREENEFFECT 屏幕坐标X 屏幕坐标Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 模式(0=自己，1=所有人)

播放声音
PLAYSOUND 1.wav

打开NPC大对话框
OPENMERCHANTBIGDLG WIL文件序号 图片序号 是否可以移动(0,1)

关闭NPC大对话框
CLOSEMERCHANTBIGDLG

英雄脚本命令使用在原来人物的脚本命令前面加“H.”
例:
检测英雄等级
H.CHECKLEVELEX > 0

【2011-02-16更新:】
增加魔法修炼等级，最高可以修炼到15级，需要更换最新的魔法数据库，
否则M2无法启动。MaxTrainLv字段为可以修炼的最高等级

修改魔法等级显示方式和盛大一样

跑步卡的用户，需要修改M2参数。选项-参数设置-游戏速度-间隔控制
数字越大越容易卡，如果发现跑步卡，把数值调小点就可以。

修正其他已知BUG

【2011-01-28更新:】
修改纹理压缩模式，默认使用最高压缩模式，进一步降低内存占用
修正不能自动换毒的问题
修正传音筒看到的是自己的名字
修正小地图雷达点小的问题
修正组队快捷键 组第一个人物，组不上的问题
修正其他已知BUG
修改登录器皮肤
修改客户端自动解包配置，药品数据库的Anicount=打包物品的Shape，这样才可以自动解包
例如：
强效金创药 Anicount=100 超级金创药 Shape=100
疗伤药 Anicount=115 疗伤药包 Shape=115
回城卷 Anicount=108 回城卷包 Shape=108

支持2次打包
例如：
可以把“疗伤药包”再次打包
疗伤药包 Anicount=120 超级疗伤药包 Shape=120

【2011-01-24更新:】
修正红屏的问题
修正滚动信息出错导致卡屏的问题
修正其他已知BUG
进一步降低内存占用

【2011-01-22更新:】
修正黑屏的问题
修正看不到别人头盔的属性
修正组队看不到队员
修正其他已知BUG
增加聊天框可以鼠标拖动调整高度

【2011-01-10更新:】
使用D3D绘图引擎重新编写客户端内核，支持硬件加速渲染模式，
执行效率高，游戏更加流畅，CPU占用更低

修正其他已知BUG

【2010-09-25更新:】
修正人物跑动慢的问题
增加新魔法数据库

【2010-09-22更新:】
重新编写了客户端内核，支持16位和32位真彩，游戏更加流畅，CPU占用更低
增加聊天框可拉伸高度
增加噬血术，逐日剑法，流星火雨
修改物品说明现改为随鼠标悬浮说明
修改物品备注信息不在写入登录器，直接读取Data\ItemDesc.dat
增加魔法备注信息显示，读取Data\SkillDesc.dat
修正没有声卡的机器无法启动客户端的问题
修正计次物品显示错误

【2010-09-18更新:】
增加KILLERRACE命令，检测杀人者是人物还是怪物
增加<$KILLER>杀人者名称变量
增加会员命令
增加记忆石功能
增加千里传音和传音筒功能

扩展字符变量S和数字变量N，除了支持0~499以外，可以在S变量或N变量后面增加任意字符，使用如下：

【2010-09-08更新:】
增加脚本加密插件和脚本加解密工具
重新编写了登录器配置
优化客户端更加流程
修正杀毒软件误报
修正其他已知BUG
---------------------------------------------------------------------------------------------
【2010-07-05更新:】
1:发送聊天框固顶信息

2:增加1024*768大界面模式

3:修正若干BUG

【2010-01-01更新：】 请同步更新
=========================================================================================================
自动行走 地图名称 X坐标 Y坐标
AUTOGOTOXY 3 330 330
=========================================================================================================
延时跳转 跳转字段 延时时间(毫秒)
DELAYGOTO @跳转 1000
=========================================================================================================
设置定时器 定时器序号(0-9) 触发时间(毫秒)
在登陆脚本里触发[@OnTimerX]X是定时器序号
SETONTIMER 0 1000
=========================================================================================================
关闭定时器 定时器序号(0-9)
SETOFFTIMER 0
=========================================================================================================
发送屏幕滚动信息 信息类型代码(0-1)0全局发送1发送给个人 字体颜色(0-255) 背景颜色(0-255) Y坐标 滚动次数 信息内容
SENDMOVEMSG 1 253 255 350 1 这个是屏幕滚动信息坐标在350
=========================================================================================================
发送延时触发信息 信息内容 时间(秒) 字体颜色 换地图是否删除 跳转字段
SENDDELAYMSG 你的礼物在%s后到达 10000 255 0 @给礼物
[@给礼物]
#ACT
GIVE 回城卷 1
=========================================================================================================
改进SENDMSG
SENDMSG 信息类型代码 %s信息内容%d 字体颜色 背景颜色
=========================================================================================================
穿装备 装备名称 装备位置(0-12)
TAKEONITEM 布衣(男) 0
=========================================================================================================
脱装备 装备名称 装备位置(0-12)
TAKEOFFITEM 布衣(男) 0
=========================================================================================================
获取随机字符 文件名 保存变量
GETRANDOMLINETEXT ..\QuestDiary\文件.txt S1
=========================================================================================================
创建文件命令
CREATEFILE ..\QuestDiary\文件.txt
=========================================================================================================
增加地图参数不允许使用技能 NOTALLOWUSEMAGIC(雷电术,火墙)
增加地图参数不允许使用物品 NOALLOWUSEITEMS(回城卷,随机传送卷)
扩展G变量为G0-G499
扩展A变量为A0-A499
变量运算
除法 格式: DIV N1 N2 N3 即N1=N2/N3
乘法 格式: MUL N1 N2 N3 即N1=N2*N3
百分比 格式: PERCENT N1 N2 N3 即N1=(N2/N3)*100
[@MAIN]
#IF
#ACT
Mov M2 10
MUL N1 M2 <$LEVEL>
SENDMSG 1 恭喜∶<$STR(N1)>，获得金刚<$STR(M2)>石锻造附赠品∶<$LEVEL>
=========================================================================================================
自动穿装备命令
穿装备 TakeOnItem 装备名称 位置(0-12)
脱装备 TakeOffItem 装备名称 位置(0-12)
=========================================================================================================
检查字符长度
格式：CheckStringlength 字符串 操作符(<,>,=) 位数
=========================================================================================================
气血石 幻魔石 魔血石 回城石 随机传送石 修复神水，数据库如下
StdMode = 7
Shape = 1 //+HP
Shape = 2 //+MP
Shape = 3 //+HMP
StdMode = 2
Shape = 2 随机传送石
Shape = 3 回城石
Shape = 9 修复神水
=========================================================================================================
金刚石和灵符
GAMEDIAMOND +/-/= 数字 //金刚石(0-65535) 操作(支持变量，如同GAMEGOLD命令)，保存到DB数据，支持新登陆器刷新显示
GAMEGIRD +/-/= 数字 //灵符(0-65535) 操作(支持变量，如同GAMEGOLD命令)，保存到DB数据，支持新登陆器刷新显示
<$GAMEDIAMOND> <$GAMEGIRD> //金刚石,灵符变量
CHECKGAMEDIAMOND >/=/< 数字 //检测金刚石，数字支持变量
CHECKGAMEGIRD >/=/< 数字 //检测灵符，数字支持变量
所有NPC命令支持运用变量，如GIVE $STR(S0) $STR(N8) //$STR(S0)、$STR(N8)
可以选择是否带<>，如：GIVE <$STR(S0)> $STR(N8)
=========================================================================================================
改进SENDMSG命令
改进：SENDMSG 类型 发送信息 字体颜色(0..255) 背景颜色(0..255) //字体颜色 背景颜色 不为空，则发送自定义颜色文字
实例:
#IF
#ACT
SENDMSG 1 祝贺大家新年快乐！ 249 47
=========================================================================================================
说明:
聚灵珠在人物背包中杀怪时获得经验时自动聚集经验,当经验聚满时双击可获得经验.
人物英雄在线时也可获得经验.
设置:
1.物品数据库中聚灵珠StdMode=49.
2.DuraMax表示聚灵珠可聚集的最大经验值,1点表示1W经验值,例如DuraMax设置20那么实际
可聚集20W经验.DuraMax设置100那么最大可聚集100W经验值.
3.AniCount=0时使用元宝提取经验,=1时使用金币提取经验.
4.Reserved表示聚灵珠最多可使用的天数,当超过使用天数后不再聚集经验,没有聚集经验时不计算天数.
5.Need=提取经验时所需的元宝数量或者金币数量.
6.AC等于0时表示不限制人物等级,大于0时人物等级超过AC设定的等级时无法使用.
7.使用GM命令@Make制造聚灵珠时第三个参数代表聚灵珠的经验,第四个参数代表最多可使用的天数.例如:@Make 聚灵珠 1 10 365 ;10表示10W经验.365表示可以使用365天
如果第四个参数为空时，默认使用DB数据库里Reserved设置的天数


官方主页

概 述

本M2游戏主程序汇编代码全新编写，在保持原来的所有功能前提下，修正大量原程序中的BUG，优化数据引擎，内置防外挂系统，彻底防止恶性外挂，增加大量新功能...

翎风世界反外挂系统简介:

 本反外挂系统，采用全新智能行为侦察技术，在服务器端对客户端发送来的的操作行为在进入数据处理引擎之前进行智能判别，重新对操作行为数据重组，以消除网络延迟造成的数据重叠现象，从而有效的控制游戏速度，将非法操作行为拦截于数据引擎之外，对于堆集数据攻击将直接踢除连接，以保护服务器不受攻击影响。
完善的脚本引擎，完全杜绝因脚本编写问题出现漏洞而刷物品问题。

客户端的行为数据控制完全于服务器端控制，反外挂系统控制的相关数据绝对不可能有被绕过的现象，与客户端没有任何关系
现已有效控制以下各外挂功能：

1、加速控制
有效防止加速攻击、魔法、跑、走等，包括双倍、三倍、四倍加速，组合操作控制，各种暗杀（延迟），游戏装备速度控制。
防加速基本达到完美程度，完全杜绝反弹、卡位、掉线问题。

2、麻痹穿人
麻痹攻击、麻痹魔法、麻痹跑、麻痹走控制。
穿人控制(可选择穿人、穿怪、穿NPC、攻城区域穿人控制)。

3、脚本控制
完善脚本处理机制，杜绝利用脚本跳转绕过命令控制刷物品。包括通买，通卖，通存，通取，特修等。
本反外挂系统，结合全新游戏数据处理引擎，实现大量的游戏新功能，并不断的在增加大量的新游戏功能创意，大大的丰富了游戏的内容，提高了游戏的可玩性。

一、实现数据格式革命性突破，扩展不再有原来老游戏中数据储存大小的限制。

 人物属性由原来 255 扩展到高达65535（包括人物等级，攻击力，魔法、道术、防御、魔法防御等，最高限制数字由版本不同而不同，详细数字参照版本功能定义）。

二、怪物说话功能，支持更丰富的说话内容

三、完美的游戏密码

四、游戏新规则

 支持PK升级，得经验规则

五、人物饥饿系统

六、完善的脚本系统

新增加大量的脚本命令，通过这些脚本命令可更多的对游戏进行控制，实现大量丰富的游戏任务。

七、游戏机器人引擎

新增机器人引擎，通过机器人以实现大量的自动化游戏内容，这些机器人通过脚本控制宝时执行脚本等任务。
（简单实例：通过定时执行脚本控制，定时开展怪物攻城活动，整个过各完全有脚本控制，不需人工参与。）

八、实现数据引擎内核参数外部参数化，大量游戏内核参数可以自行设置，并支持动态修改设置加载参数，以打造各种风格的游戏。

数据动态加载，游戏魔法、怪物、物品数据库运行动态加载，调试游戏变得特别轻松容易，不必多次重新启动程序来检查数据的正确性，运行中的游戏增加怪物、物品不再需要重新启动。所有的配置设置信息全部支持动态加载，不需要重启程序立即生效。

游戏命令配置，所有游戏命令全部由配置文件设置，里面的命令可根据自己的要求改成自己风格的命令。修改后通过动态加载功能立即就可以生效而不必重启程序。

游戏内容提示方案信息，大部份游戏中提示的文字可通过配置文件设置，文字内容可以根据要求改成自己风格的提示信息。

九、可用脚本实现显示在线人物的各种排名（最高等级、最高攻击、最高魔法、最高道术、最高PK值等等）

数据处理引擎内核参数，大量的引擎内核参数可通过配置文件来控制，这些参数可以根据自己的要求进入更改。
以下为可设置参数列表：

红名村位置
红名死亡回城点
PK加PK点数
PK减幸运点数
照明物减持久间隔

安全区大小
新人出生点控制

升级武器点数机率控制
升级武器取回时间
清除过期升级武器时间
升级武器费用

炼药费用
建行会费用
申请行会战费用
申请攻城天数
攻城开始时间
攻城结束提示时间

沙城雇用卫士费用
修理城门费用
修理城墙费用
沙城金币上限
沙城一天收入上限
沙城位置
攻城区域大小
NPC税收率

人物身上金币数上限
人物数据保存间隔时间
显示公告间隔时间
公告文字颜色
GM发红字广播控制
人物退出清除时间
清理尸体时间
清除地面物品时间
怪物爆物品可捡时间

发送文字长度控制

人物登录权限控制，支持1 - 10级GM控制

刷怪倍率
杀怪经验倍率
高等级杀怪控制

各等级升级经验设置

客户端程序版本号日期
控制台上显示在线人数时间

召唤魔法控制，运行10级控制，不同等级召唤不同等级数量的怪物。


NPC代码

 | 代码：0
 | 代码：1
 | 代码：2
 | 代码：3
 | 代码：4
 | 代码：5
 | 代码：6
 | 代码：7
 | 代码：8
 | 代码：9
 | 代码：10
 | 代码：11
 | 代码：12
 | 代码：13
 | 代码：14
 | 代码：15
 | 代码：16
 | 代码：17
 | 代码：18
 | 代码：19
 | 代码：20
 | 代码：21
 | 代码：22
 | 代码：23
 | 代码：24
 | 代码：25
 | 代码：26
 | 代码：27
 | 代码：28
 | 代码：29
 | 代码：30
 | 代码：31
 | 代码：32
 | 代码：33
 | 代码：34
 | 代码：35
 | 代码：36
 | 代码：37
 | 代码：38
 | 代码：39
 | 代码：40
 | 代码：41
 | 代码：42
 | 代码：43
 | 代码：48
 | 代码：49
 | 代码：50
 | 代码：51
 | 代码：52
 | 代码：54 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：55 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：56 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：57 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：58 传送门，不可点击，可在MapInfo.txt添加门点，走过去直接移动到其他地图
 | 代码：59
 | 代码：60
 | 代码：61
 | 代码：62
 | 代码：63
 | 代码：64
 | 代码：65
 | 代码：66
 | 代码：67
 | 代码：68
 | 代码：70
 | 代码：71
 | 代码：72
 | 代码：73
 | 代码：74
 | 代码：75
 | 代码：76
 | 代码：77
 | 代码：78
 | 代码：79
 | 代码：80
 | 代码：81
 | 代码：82
 | 代码：83
 | 代码：84
 | 代码：90
 | 代码：91
 | 代码：92
 | 代码：94 传送门，可以点击。
 | 代码：95 传送门，可以点击。
 | 代码：96 传送门，可以点击。
 | 代码：97 传送门，可以点击。
 | 代码：98 传送门，可以点击。
0 | 代码：99
1 | 代码：100
1 | 代码：101
1 | 代码：102
1 | 代码：200
1 | 代码：201
1 | 代码：202
1 | 代码：203
1 | 代码：204
1 | 代码：205
1 | 代码：206
1 | 代码：207
1 | 代码：208
 | 代码：209
 | 代码：210
 | 代码：211
 | 代码：212
 | 代码：213
 | 代码：214
 | 代码：215
 | 代码：216
 | 代码：217
 | 代码：218
 | 代码：219
 | 代码：220
 | 代码：221
 | 代码：222
 | 代码：223
 | 代码：224
 | 代码：225
 | 代码：226
 | 代码：227
 | 代码：228
 | 代码：229
 | 代码：230
 | 代码：231
 | 代码：232
 | 代码：233
 | 代码：234
 | 代码：235
 | 代码：236
 | 代码：237
 | 代码：238
 | 代码：239
 | 代码：240
 | 代码：241
 | 代码：242
 | 代码：243
 | 代码：244
 | 代码：245
 | 代码：246
 | 代码：247
 | 代码：248
 | 代码：249
 | 代码：250
 | 代码：251
 | 代码：252
 | 代码：253
 | 代码：254
 | 代码：255
 | 代码：256
 | 代码：257
 | 代码：258
 | 代码：259
 | 代码：260
 | 代码：261
 | 代码：262
 | 代码：263
 | 代码：264
 | 代码：265
 | 代码：266
 | 代码：267
 | 代码：268
 | 代码：269
 | 代码：270
 | 代码：271
 | 代码：272
 | 代码：273


颜色值列表

0 | 1 | 2 | 3 | 4 | 5
6 | 7 | 8 | 9 | 10 | 11
12 | 13 | 14 | 15 | 16 | 17
18 | 19 | 20 | 21 | 22 | 23
24 | 25 | 26 | 27 | 28 | 29
30 | 31 | 33 | 34 | 35 | 36
37 | 38 | 39 | 40 | 41 | 42
43 | 44 | 45 | 46 | 47 | 48
49 | 50 | 51 | 52 | 53 | 54
55 | 56 | 57 | 58 | 59 | 60
61 | 62 | 63 | 64 | 65 | 66
67 | 68 | 69 | 70 | 71 | 72
73 | 74 | 75 | 76 | 77 | 78
79 | 80 | 81 | 82 | 83 | 84
85 | 86 | 87 | 88 | 89 | 90
91 | 92 | 93 | 94 | 95 | 96
97 | 98 | 99 | 100 | 101 | 102
103 | 104 | 105 | 106 | 107 | 108
109 | 110 | 111 | 112 | 113 | 114
115 | 116 | 117 | 118 | 119 | 120
121 | 122 | 123 | 124 | 125 | 126
127 | 128 | 129 | 130 | 131 | 132
133 | 134 | 135 | 136 | 137 | 138
139 | 140 | 141 | 142 | 143 | 144
145 | 146 | 147 | 148 | 149 | 150
151 | 152 | 153 | 154 | 155 | 156
157 | 158 | 159 | 160 | 161 | 162
163 | 164 | 165 | 166 | 167 | 168
169 | 170 | 171 | 172 | 173 | 174
175 | 176 | 177 | 178 | 179 | 180
181 | 182 | 183 | 184 | 185 | 186
187 | 188 | 189 | 190 | 191 | 192
193 | 194 | 195 | 196 | 197 | 198
199 | 200 | 201 | 202 | 203 | 204
205 | 206 | 207 | 208 | 209 | 210
211 | 212 | 213 | 214 | 215 | 216
217 | 218 | 219 | 220 | 221 | 222
223 | 224 | 225 | 226 | 227 | 228
229 | 230 | 231 | 232 | 233 | 234
235 | 236 | 237 | 238 | 239 | 240
241 | 242 | 243 | 244 | 245 | 246
247 | 248 | 249 | 250 | 251 | 252
253 | 254 | 255 |  |  |


游戏速度延时调整解说

游戏速度延时说明(因图片过大，看不到图请使用F5刷新)：

针对不同版本进行自定义调整游戏延时至满意状态

位置：选项 - 功能设置 - 技能魔法 技能伤害延时时间

说明：因市面上各种速度的服务端种类很多，该参数为调整游戏中基础速度，当游戏中出现攻击速度+，引擎将在基础值上自动减少对应参数

飞行： 如灵魂火符 火球术
普通： 如雷电术 五雷轰
物理： 砍击均为物理

图解：

以上为在你游戏的基础速度上进行调整（正常游戏速度、无任何加速属性），参数越大延时越长，负数越大越提前，用户根据自己游戏将参数调整至满意值
通常情况下游戏攻击速度越快的服负值越高，如超快速的无限刀可以设置-250左右 ，复古服可以0或100，具体根据自己喜好测试并调整参数到满意值

;===================================================

位置：选项 - 性能参数

推荐值： 点击默认设置后 将数据块大小修改为 8000 自检数据块 设置为20000 （当然还可以继续翻倍），数据发送过大的服务端可以勾选“数据压缩后发送到网关”
PS：何为数据过大？什么情况下需要勾选“数据压缩后发送到网关” ？ 答案就是 当引擎界面下方网关链接信息中频繁出现大额队列数据时就需要勾选“数据压缩后发送到网关”

怪物处理控制 - 处理间隔 复古服一般默认200左右即可，攻击速度超快的服可以设置为50左右或最低值，具体根据自己游戏基础速度来攻击怪物进行视觉判断来调整至最佳状态（数值越低CPU使用相对越高）

图解：

;===================================================

位置：选项 - 怪物设置

怪物后仰： 自定义怪物被攻击后仰延时时长，通常默认值即可，个别无限刀（超快速度）的服可以调整此参数来降低怪物后仰时间，数值越大后仰时间越长...

图解：

;===================================================

位置：选项 - 参数设置- 游戏速度

此处参数为限制游戏速度，设置游戏速度在选项-客户端设置-速度控制中

网关限速说明：使用网关封速需关闭引擎的速度限制，各项速度限制的参数改为10，然后取消“限制超速”选项。 如下图

图解：

然后打开组合速度限制，取消里面所有勾选

总结：以上各参数设置选项，用户根据自己服的游戏速度使用参数将延时调整至最佳状态


31类物品扩展设置

31类物品扩展设置，支持放入物品框和死亡使用

StdMode为31类物品数据库reserved字段设置为：不等于0（即大于或小于0） 则限制死亡后才可以使用

StdMode为31类物品数据库source字段为：-2 可以放入物品栏

************************************以下为2020-06月份扩展********************************************

-----------------------------------------------------------
1406 31类一次性物品1 31 50 1 1 100 0 1230 1 0 0 0 0 0 0 0 0 0 0 0 0 1 5 255 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1407 31类多次物品 31 51 1 2 0 0 1230 1 0 0 0 0 0 0 0 0 0 0 0 0 1 5 255 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
-----------------------------------------------------------

StdMode=31扩展物品
Shape=50，物品使用一次后消失
Shape=51，物品可以一直使用，直到手动删除

触发：
以上扩展2种类型的物品
人物触发 QF中的 [@StdModeFuncExX] X=物品的Anicount
英雄触发 QF中的 [@HeroStdModeFuncExX] X=物品的Anicount

-----------------------------------------------------------

增加NPC变量:
当前使用物品名：<$UseItemName>, <$H.UseItemName>
当前使用物品唯一ID：<$UseItemMakeIndex> <$H.UseItemMakeIndex>
以上2个变量仅限用于触发 [@StdModeFuncX]，[@StdModeFuncExX]，[@HeroStdModeFuncExX]

-----------------------------------------------------------

增加NPC命令：
关联背包物品 LinkBagItem 物品MakeIndex(唯一ID)
将关联物品从背包删除 DelLinkItem 物品数量(用于叠加物品，0整个物品删除，大于0从叠加中删除指定数量)-----20200927支持叠加

-----------------------------------------------------------

[@StdModeFuncEx1]
#act
SendMsg 6 当前使用的物品名:<$UseItemName>，唯一ID:<$UseItemMakeIndex>；本物品使用完后会直接消失

[@StdModeFuncEx2]
#if
Random 3
#act
SendMsg 6 人物当前使用的物品名:<$UseItemName>，唯一ID:<$UseItemMakeIndex>；本次删除
LinkBagItem <$UseItemMakeIndex>
DelLinkItem
#elseact
SendMsg 6 人物当前使用的物品名:<$UseItemName>，唯一ID:<$UseItemMakeIndex>；本物品还可以使用
LinkBagItem <$UseItemMakeIndex>
ChangeItemName -1 新的名字3
UpdateItem -1
ClearLinkItem

[@HeroStdModeFuncEx2]
#act
#if
Random 10
#act
SendMsg 6 英雄当前使用的物品名:<$H.UseItemName>，唯一ID:<$H.UseItemMakeIndex>；本次删除
H.LinkBagItem <$H.UseItemMakeIndex>
H.DelLinkItem
#elseact
SendMsg 6 英雄当前使用的物品名:<$H.UseItemName>，唯一ID:<$H.UseItemMakeIndex>；本物品还可以使用
H.LinkBagItem <$H.UseItemMakeIndex>
H.ChangeItemName -1 新的名字3
H.UpdateItem -1
H.ClearLinkItem

注：shape=1可能不利于英雄使用，建议31-1类物品禁止放入英雄背包！


Magic详解

magicdb:是你所修炼的法术和各种技能.
序号 字段 说明

(1)MagID 技能序号
(2)MagName 技能名字
(3)EffectType 使用技能时角色的动作效果
(4)Effect 技能产生的动画效果
(5)Spell 每次使用技能使用的魔法值
(6)Power 技能的伤害值下限
(7)MaxPower 技能的伤害值上限
(8)DefSpell 每次技能升级后增加使用的魔法值
(9)DefPower 每次技能升级后增加的伤害值下限
(10)DefMaxPower 每次技能升级后增加的伤害值上限
(11)job 可以学习技能的职业（0-战士，1-法师，2-道士）
(12)NeedL1 技能升到1级 需要玩家达到的人物等级（默认数据到15级别）
(13)L1Train 技能升到1级 需要的熟练度（默认数据到15级别）
(14)Delay 使用完当前技能后再次使用其他任意技能之间的延时（单位：毫秒）
(15)descr 简单备注
(16)MaxTrainLv 可以修炼的最高等级


英雄合击技能[!]

功能：技能
格式：无
说明：技能数据库设置,请直接使用我们提供的数据库既可
例：

60;破魂斩;4;3;1;60;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
61;劈星斩;4;3;1;61;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
62;雷霆一击;4;3;1;62;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
63;噬魂沼泽;4;3;1;63;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
64;末日审判;4;3;1;64;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;
65;火龙气焰;4;3;1;65;0;0;1144;43;0;0;0;0;0;0;0;0;0;0;0;0;1000;5;255;0;99;


Monster详解

monsterdb: 是关于怪物的攻击,经验,还有等级方面的东西
怪物CoolEye 是否主动攻击(反隐形范围,并和等级有关)调到100 ，再用隐身戒指也没用了
(1)sid 怪物代号
(2)name 怪物名称
(3)race 行动模式及死亡时的效果代码
race代码---81 对象进入范围自动攻击
11 无敌加瞬移攻击主动攻击怪物和红人（大刀）
12 多坐标巡逻卫士 无敌加瞬移攻击主动攻击怪物和红人（巡逻卫士）
51 不主动攻击*后物品不掉落要割的
52 不主动攻击*后物品不掉落有一定几率会逃跑
53 主动攻击物品不掉落
81 普通的攻击进入范围自动攻击 82 2x2范围内毒液攻击-弱
85 地下钻出来原地攻击*后物品不掉落
87 主动攻击射程5
90 贴身麻痹石化攻击-弱
92 遇到攻击对象在范围外时会瞬移
93 边攻击边躲避
94 主动攻击直线攻击
95 对象进入攻击范围内会从地下爬出来
96 自动复活(类似僵尸，每次复活后经验减半)
100 召唤的骷髅
101 进入范围会从石像状态激活
102 在攻击的同时召唤mir200\!setup.txt文件里的zuma1~4里特定的怪
103 自身不移动，通过释放mir200\!setup.txt文件里的bee特定的怪来攻击对象
104 主动攻击射程8
105 麻痹石化攻击-强
106 麻痹石化攻击-弱
107 全屏攻击+麻痹+中毒
108 此代码必须配合怪物攻城命令MOBPLACE刷怪命令使用，怪物不攻击人，也不被攻击伤害.自己按需使用
112只主动攻击红名射程11
114 召唤的神兽-大
115 自身不移动，通过地刺来攻击对象
116 自身不移动，通过释放mir200\!setup.txt文件里的spider特定的怪来攻击对象
117 自身没有攻击力，通过自暴来攻击对象
118 2格攻击距离 和81类似(1格)
124 远程放绿毒+冰咆哮，冰咆哮和绿毒的伤害均受攻击影响
125 远程红毒加灭天火，伤害效果受攻击影响
126 远程寒冰掌，带推开玩家的效果。
210 自身不能移动，攻击方式类似大刀卫士。瞬移过去打一下回到原位。
211 自身可以移动，攻击方式类似大刀卫士。瞬移过去打一下回到原位。

(4)racelmg 攻击模式代码
racelmg代码：
0 怪物不动，不攻击，形状不变
1 裸男状态，近身物理攻击
9 配合120(足球)
10 配合83(森林雪人)
11 近身物理,配合52(鹿);配合51(鸡)
12 配合11(卫士)
13 配合85(食人花)
14 物理攻击,配合86,88,89(骷髅)
15 抛斧攻击,配合87(抛斧骷髅)
16 近身喷毒,配合90(洞蛆)
17 近身物理,配合81(多钩猫)
18 近身物理,死亡时冒火,配合83(稻草人)
19 近身物理,配合81(沃玛战士)
20 喷火攻击,配合91(火焰沃玛) 21 电火花攻击,配合92(沃玛教主)
22 射针攻击,配合93(暗黑战士)
23 物理攻击,配合100(变异骷髅)
24 刀划出的锋芒,配合11(带刀护卫)
30 近身物理
31 物理攻击,配合81(蝙蝠)
32 物理攻击,配合84(蝎子)
33 大范围喷毒攻击,配合107(触龙神)
34 全屏地刺攻击,配合115(赤月恶魔)
35 配合116(幻影蜘蛛)
36 配合117(暴烈蜘蛛)
37 近身物理,配合81(虹魔教主)
40 极光电影攻击,配合94(雷电僵尸)
41 物理攻击,配合95(僧侣僵尸),有洞
42 物理攻击,配合96(其他僵尸),能复活
43 物理攻击,配合103(角蝇),能释放特定的怪
45 射箭效果,配合104(弓箭手)
47 物理攻击,配合101(祖玛卫士),从石像中释放自己
49 火球攻击,配合102(祖玛教主)
50 铁匠NPC形态
52 高空喷毒效果
53 低空喷毒效果
54 配合113(神兽小)
55 喷火攻击,配合114(神兽大)
60 击电攻击+近身物理(虹魔蝎卫的新效果)
61 挥斧的魔法效果(虹魔猪卫的新效果)
62 挥拳的魔法效果+变身成牛的效果(虹魔教主的新效果)
63 挥杖的魔法效果(骷髅教主的新效果)
64 喷毒效果(恶灵尸王的新效果)
65 骷髅刀斧手死亡时的效果
66 骷髅长枪兵死亡时的效果
67 骷髅锤兵死亡时的效果
68 骷髅弓箭手死亡时的效果
70 雷电术+近身挥杖效果(牛魔法师)
71 小火球+近身挥杖效果(牛魔祭司)
72 和传奇3相同的牛魔王的新攻击效果
78 魔龙教主攻击效果
触龙神外形编号 140 攻击动作编号 33
祖玛教主外形编号 63 攻击动作编号 49
火焰沃玛外形编号 31 攻击动作编号 20
沃玛教主外形编号 34 攻击动作编号 21
83火龙专用的群雷攻击效果(超爽),配合107.
注意：以上数据位收集于网络

(5)appr 怪物形象代码
(6)lvl 怪物等级
(7)undead 是否属不死系 0-否，1-是[不死系不可招，死系可召]也就是说设置0的话诱惑之光有几率诱惑，和怪物等级有关]
(8)cooleye 是否主动攻击(反隐形范围,并和等级有关)
(9)exp 怪物的经验值
(10)hp 怪物生命
(11)mp 怪物魔法
(12)ac 怪物防御力
(13)ac2 防御力上限
(14)mac 魔法防御力
(15)dc 攻击力
(16)dcmax 最大攻击力
(17)mc 魔法攻击力
(18)sc 道士精神力
(19)speed 敏捷（怪物敏捷高于角色准确时，角色物理攻击出现MISS越频繁）
(20)hit 攻击命中率(又名：准确)
(21)walk-spd 行走速度间隔
(22)walkstep 行走步伐
(23)walkwait 行走等待时间
(24)attacr-spd 攻击速度间隔


Stditem详解

stditemdb：物品属性修改
1.选中最底下的那个装备名，然后点图中所示1的位置那个+号，这样就会在你所选中的装备前面插入一列横向表单，点了+号后，在右边就会出现一个“对号”标记的按钮，按一下这个“对号”就表示确定插入这一横列。
(1)idx属性表示数据库的序列号(记住序号不要重复)
(2)name属性表示：
物件的名称
(3)stdmode装备属性：
10-男衣
11-女衣
5-单手
6-双手
30-蜡烛类
22-毒药，符类
42-制作原料
=======================================================

(4)shape这个属性(衣服显示穿上得样子,首饰代表其特殊功能)
“5”表示“灵魂战衣”的样子。
“4”表示“魔法长袍”的样子。
“3”表示“重盔甲”的样子。
19~21 ：项链
为19时，ac2和mac2代表魔法躲避和幸运
为20时，ac2为准确，mac2为敏捷
为21时，ac为攻击速度+,ac2为体力恢复，mac为攻击速度-,mac2为魔法恢复
24~26 ：手镯
为24时，ac2代表准确，mac2代表敏捷
为26时，ac和ac2分别代表物理防御上限和下限，mac和mac2分别代表魔法防御上限和下限
22~23 ：戒指
为22时，ac和ac2分别代表物理防御上限和下限，mac和mac2分别代表魔法防御上限和下限
为23时，ac代表攻击速度+ ， ac2代表中毒躲避+ ，mac为攻击速-, mac2代表中毒恢复+
shape值：
记忆头盔125
记忆戒指122
记忆手镯124 天地合一
记忆项链123
魔血戒指133 虹魔戒指136
魔血项链134 mp转hp 虹魔手镯137 吸hp
魔血手镯135 虹魔项链138
神秘戒指130 祈祷戒指128
神秘腰带131 随机属性 祈祷手镯126
神秘头盔132 祈祷头盔129
隐身戒指111 传送戒指112
麻痹戒指113 复活戒指114
火焰戒指115 治愈戒指116
幸运戒指117 护身戒指118
负载戒指119
技巧项链120
探测项链121
恢复hp/mp113
对于武器来说： 当shape值和reserved值分别为 30 和 12 时，武器一旦拿上就不能取下，只到死后消失 (血剑)
当仅reserved值为 8 时，武器拿上可以取下，但是一旦战斗死亡，就会消失
当Source值为1-10时为武器强度增加1至10,Source值为-1至 -50时为神圣增加1至50(强度可降低武器掉持久,神圣破不死系怪物(Undead 0=死系;1=不死系)的防御 魔御和一些对人物来说未知的神秘功能)
=====================================================================================

(5)weight属性是物件重量.

(6)looks属性(显示衣服物品栏里样子和在装备栏里的样子)
"重盔甲(男)"or"战神盔甲(男)"or"钢盔甲(男)" 62
"魔法长袍(男)"or"恶魔长袍(男)"or"圣龙魔袍(男)" 63
"灵魂战衣(男)"or"幽灵战衣(男)"or"泰坦战衣(男)" 64
"重盔甲(女)"or"战神盔甲(女)"or"钢盔甲(女)" 82
"魔法长袍(女)"or"恶魔长袍(女)"or"圣龙魔袍(女)" 83
"灵魂战衣(女)"or"幽灵战衣(女)"or"泰坦战衣(女)" 84
(7)duramax物件持久的属性：这里的变量中"1000"表示1个持久度,那么"40000"就表示40个持久度了!
(8)衣服和武器的属性:
"ac" 防御力下限
"ac2" 防御力上限
"mac" 魔防下限
"mac2" 魔防上限
"dc" 物理攻击力下限
"dc2" 物理攻击力上限 超过了255带在身上攻击是会减成0
"mc" 魔法攻击力下限
"mc2" 魔法攻击力上限
"sc" 道术下限
"sc2" 道术上限
"needlevel" 需要等级
"price" 价格
(9)物品是首饰时：
"ac2" 表示准确
"mac2" 表示敏捷
"ac" 表示防御下限
"ac2" 表示防御上限
"mac" 表示魔御下限
"mac2" 表示魔御上限
药剂的属性：
强效金疮药：hp +90
数据库体现：
ac 90
强效太阳水：hp +50 mp +80
数据库体现：
ac 50
mac 80
这样看来，这里的
ac 表示 hp前值（注 hp：200/300，200为前值，300为后值。）
mac 表示 mp前值
特殊的:
一些不常见的特殊药剂：
生命强化水：生命力暂时提升120秒（120秒内hp后值+50）
数据库体现：
ac 50
mac2 120
魔法强化水：魔法力暂时提升120秒（120秒内mp后值+50）
mac 50
mac2 120
那么这里的
ac 表示hp后值
mac 表示mp后值
mac2 表示时间了
大家知道 苹果 是每项属性都暂时增加240秒，他的ac2中是2，那么应该和武器一样，ac2表示准确了！
(10)stock 是否为库存品
(11)need表示限制种类：
0 为等级限制
1 为攻击限制
2 为魔法限制
3 为道术限制
18-21为增加内功恢复速度
(12)needlevel表示了(need)限制的具体数量.
另外上面的 stock处网上有说不是库存的意思是是否容易暴出后物品比较极品的意思,大家可以自己测试

字段Color 物品在地面颜色的显示设置
字段OverLap 物品叠加功能

60:在DB库增加新装备新怪的方法和技巧:
传奇4F在DB库增加新装备新怪的方法和技巧
大家一定玩腻了盛大所定的那些装备了把，一定也想在自己的4F里增加一些独创的装备把。
告诉大家一个技巧多利用COPY而让创建的装备100%成功，又不会出错！
具体操作：
比如我想要一件[狂神布衣（男）]
用DB Commander Shortcut打开StdItems.DB后首先找到原来的布衣（男）的数据单击成兰色后，选择DB Commander Shortcut上面的EDIT出现下拉菜单，点里面的COPY RECORD后下拉菜单消失。再点EDIT这时出现的下拉菜单里面原来是灰色不能选择的2个选项成了可选项，选择PASTE RECORD APPEND后他会自动在库的最下面拷贝了一份布衣的资料。IDX是物品编号改成上面物品的编号的后一位就可。NAME是名称呀改成[狂神布衣（男）]因为是COPY布衣（男）同样都是男用衣服所以装备属性和外观属性等都不用修改，现在要修改的只是：
DURAMAX：这是持久，注意这里的1000=游戏中的1点持久，如要40的持久那么就是40000。
AC和AC2就不用我多说了把是 防御和防御上限。
MAC和MAC2是魔防和魔防上限。
DC和DC2是攻击和攻击上限。
MC和MC2是魔法力和魔法力上限。
SC和SC2是道术和道术上限。
这里就自己看着改吧，都改成225的话呵呵。。。。。自己试试。
注意最高只能改到225！！！！！！！！！！！

=====================================================================================

数据库分类号：62、63、64 支持负重属性，数据库Anicount字段设置负重属性值


盾牌相关资料

Stdmode值12，物品位置16，变量<$SHIELD>

数据库Stdmode值12，内观和背包和其他装备一样读取DnItems.wil，Items.wil，stateitem.wil (数据库LooKs值和其他装备一样计算) 外观读取Shield.wil Shape从1开始计算


可探索怪设置

功能：

增加客户端怪物可探索识别（可在配置器上将文字修改为图片）

EXPLORELTEM(当EXPLORELTEM为1时怪死亡显示可探索)

鸡;51;11;160;5;0;0;5;0;0;0;1;1;0;0;10;3;1400;1;0;3000;250;0;0;1;
鹿;52;11;161;12;0;0;15;0;0;0;2;4;0;0;12;4;1400;1;0;3000;750;0;0;1


特殊物品设置[!]

物品名称(Name) | StdMode | Shape | Anicount | Source | 说明
气血石 | 7 | 1 | 0 | 0 | 自动增加HP,增加数量为 持久*10
幻魔石 | 7 | 2 | 0 | 0 | 自动增加MP,增加数量为 持久*10
魔血石 | 7 | 3 | 0 | 0 | 自动增加HP和MP,增加数量为 持久*10
例如： 气血石(小);7;1;1;0;0;0;991;4000;1;0;0;0;0;0;0;0;0;0;0;0;5000;5;
气血石(中);7;1;2;0;0;0;992;9000;1;0;0;0;0;0;0;0;0;0;0;0;5000;5;
气血石(大);7;1;3;0;0;0;993;20000;1;0;0;0;0;0;0;0;0;0;0;0;5000;5;
幻魔石(小);7;2;1;0;0;0;995;6000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
幻魔石(中);7;2;2;0;0;0;996;14000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
幻魔石(大);7;2;3;0;0;0;997;32000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
魔血石(小);7;3;3;0;0;0;1028;10000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
魔血石(中);7;3;3;0;0;0;1027;15000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;
魔血石(大);7;3;3;0;0;0;1026;20000;0;0;1;0;0;0;0;0;0;0;0;0;5000;5;

物品名称(Name) | StdMode | Shape | Anicount | Source | 说明
随机传送石 | 2 | 2 | 0 | 0 | 随机在当前地图上移动，使用次数为 持久/1000
盟重传送石 | 2 | 1 | 59 | 0 | 双击返回盟重.查看脚本. 持久/1000
修复神水 | 2 | 9 | 0 | 0 | 修复身上所穿装备持久，修复点数为 持久/100
千里传音 | 7 | 0 | 1 | 0 | 可以使用 @传 向全服喊话，使用次数为 持久/1000
火龙之心 | 25 | 9 | 0 | 0 | 英雄配带，合击物品.
召唤强化卷 | 2 | 1 | 0 | 0 | 装自己的宝宝升级为七级宝宝(适用于道士)，使用次数为 持久/1000
斗笠 | 16 | 0 | 0 | 0 | 配带后可以隐藏人物名称，支持双头盔配带，并支持人物属性增加 Shap 0~7
聚灵珠 49 0 0时使用元宝提取经验,=1时使用金币提取经验. 0 说明:聚灵珠在人物背包中杀怪时获得经验时自动聚集经验,当经验聚满时双击可获得经验.
人物英雄在线时也可获得经验.

设置:1.物品数据库中聚灵珠StdMode=49.
2.获取当前经验的倍数Shape/100,设置0则只收集脚本命令给的经验
3.DuraMax表示聚灵珠可聚集的最大经验值,1点表示1W经验值,例如DuraMax设置20那么实际
可聚集20W经验.DuraMax设置100那么最大可聚集100W经验值.
4.AniCount=0时使用元宝提取经验,=1时使用金币提取经验.
5.Reserved表示聚灵珠最多可使用的天数,当超过使用天数后不再聚集经验,没有聚集经验时不计算天数,值为0时不限制天数
6.Need=提取经验时所需的元宝数量或者金币数量.
7.AC等于0时表示不限制人物等级,大于0时人物等级超过AC设定的等级时不加经验.
8.AC2等于0时表示不限制人物等级,大于0时人物等级超过AC2设定的等级时不能使用.
9.使用GM命令@Make制造聚灵珠时第三个参数代表聚灵珠的经验,第四个参数代表最多可使用的天数.例如:@Make 聚灵珠 1 10 365 ;10表示10W经验.365表示可以使用365天
如果第四个参数为空时，默认使用DB数据库里Reserved设置的天数
传送符 | 25 | 6 | 0 | 0 | 类似于传送戒指，使用一次减100点持久
自定义记次物品 | 2 | 1 | X | 0 | 自定义物品，使用次数为 持久/1000 ，使用成功后调用 QFunction-0脚本中的 [@StdModeFuncX] 其中X为Anicount
例如： 随机传送石;2;2;1;0;0;0;1025;50000;0;0;0;0;0;0;0;0;0;0;0;0;50000;1;255;0;99;
回城石;2;3;1;0;0;0;120;10000;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;
修复神水;2;9;1;0;0;0;120;10000;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;
千里传音(小);7;0;1;1;0;0;1000;5000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
千里传音(大);7;0;1;1;0;0;1000;10000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
传音筒;7;0;1;2;0;0;1000;5000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
超级传音筒;7;0;1;2;0;0;1000;10000;0;0;0;0;0;0;0;0;0;0;0;0;5000;1;255;0;99;
火龙之心;25;9;1;0;0;0;1148;30000;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;
召唤强化卷;2;1;1;7;0;0;998;5000;0;0;0;0;0;0;0;0;0;0;0;0;6000;5;
斗笠;16;0;2;0;0;0;1188;30000;0;0;0;0;0;0;0;0;0;0;0;7;20000;5;
回城石;2;3;1;30;0;0;1024;60000;0;0;0;0;0;0;0;0;0;0;0;0;20000;5;255;0;99;
聚灵珠(小);49;100;1;0;0;0;820;25;0;0;0;0;0;0;0;0;0;0;5;0;25000;5;255;0;0;0;
聚灵珠(大);49;100;1;0;0;0;820;50;0;0;0;0;0;0;0;0;0;0;10;0;50000;5;255;0;0;0;
计时物品 限时物品带到身上开始计时,到期后必须在身上时才会自动消失.(每分钟检测一次)
物品Need=101时限时物品,NeedLevel=时间(分钟)
计时物品 | 计时物品增加物品Need=102时限时物品,NeedLevel=时间(分钟)，计算时间方式为： 穿戴即刻计算时间，就是丢背包也结算时间(使用才计算时间)！
计时物品 | 计时物品增加物品Need=103时限时物品,NeedLevel=时间(分钟)，计算时间方式为： 给予(物品刷或者爆出开始计算)时即刻计算时间，无论是穿戴或放在背包（在线就计算时间）！
计时物品 | 计时物品增加物品Need=104时限时物品,NeedLevel=时间(分钟)，计算时间方式为： 给予(物品刷或者爆出开始计算)时即刻计算时间，无论角色是否在线，物品正常计算时间（无论是否使用，是否在线都计算时间）！


为了减少使用自定义特效以及方便添加装备，对衣服武器的外观特效进行DB数据库支持
由于武器2-3的特效均放在衣服HumEffect2.wzl和HumEffect3.wzl里面，武器特效DB数据字段支持为：

武器特效：Anicount
HumEffect2.wzl中武器特效代码分别为：1000-1006 （7件武器特效）
HumEffect3.wzl中武器特效代码分别为：1007-1015 （9件武器特效）
WeaponEffect.wzl 中特效代码为：1025-1049
WeaponEffect4.wzl 中特效代码为1100-1124
WeaponEffect5.wzl 中特效代码为1125-1149
--------------------------------------------------------------------------------------------

衣服翅膀特效：Anicount 字段
HumEffect2.wzl 1000-1024 需要排除武器，此文件第一件翅膀为1002 ，后面分别为1003,1004,1006，1010(1010只有女性项圈)
HumEffect3.wzl 1025-1049 需要排除武器，此文件第一件翅膀为1025 ，1026,1027,1031,1035,1036
HumEffect4.wzl 1050 - 1074
HumEffect5.wzl 1075 - 1099
--------------------------------------------------------------------------------------------

备注：由于HumEffect2.wzl HumEffect3.wzl 中夹武器特效所以计算比较复杂，特效代码为数据库字段 Anicount
能使用DB数据库支持的特效尽量使用db数据库来支持,这样可减少服务器压力...(男女特效数值一样，程序自动区分性别)

=============================================以下为武器和衣服内观特效计算=====================================================================================================================

武器和衣服内观特效计算：
内观发光效果,一行对应一个特效 对应数据库 Light字段

文件 stateitem.wzl (计算代码 500-527)
1403 ------------500
1890-1899 ------------501
2425 ------------502
2426 ------------503
2427 ------------504
2530-2537 ------------505
2541 ------------506
2543 ------------507
2550-2559 ------------508
2560-2569 ------------509
2600-2619 ------------510
2850-2865 ------------511
3480-3493 ------------512
3500-3513 ------------513
3520-3533 ------------514
3550-3559 ------------515
3570-3579 ------------516
3610-3627 ------------517
3630-3647 ------------518
3650-3667 ------------519
3680-3687 ------------520
3690-3697 ------------521
3800-3807 ------------522
3820-3837 ------------523
3840-3857 ------------524
3860-3877 ------------525
3950-3967 ------------526
3968-3987 ------------527
注：Light字段528-599保留....

DB数据库Light字段支持扩展内观特效支持
扩展名： Light字段值：
StateEffect5.wzl 1000-1099
StateEffect6.wzl 1100-1199
StateEffect7.wzl 1200-1299
StateEffect8.wzl 1300-1399
StateEffect9.wzl 1400 -1499
StateEffect10.wzl 1500-1599

内观特效扩展统一图片张数为10张一组，一个扩展文件内100组，也就是1000张图，如果不是10张就自定义内观特效

注意一些页游素材本身就是特效效果了，请使用自定义特效的普通绘制，扩展的字段只支持特效绘制！！！

------------------------------------------------------------------------------------------------------

文件 StateEffect.wzl 武器，衣服内观发光效果,一行对应一个特效 对应数据库 Light字段 (计算代码 600-641)
760-767 ----------600
770-777 ----------601
780-787 ----------602
800-809 ----------603
810-819 ----------604
820-829 ----------605
840-849 ----------606
850-859 ----------607
860-869 ----------608
880-897 ----------609
900-917 ----------610
920-937 ----------611
950-967 ----------612
970-987 ----------613
990-1007 ----------614
1020-1037 ----------615
1040-1057 ----------616
1060-1077 ----------617
1090-1099 ----------618
1100-1109 ----------619
1120-1130 ----------620
1140-1150 ----------621
1170-1179 ----------622
1180-1189 ----------623
1200-1209 ----------624
1210-1219 ----------625
1230-1239 ----------626
1240-1249 ----------627
1260-1269 ----------628
1270-1279 ----------629
1290-1297 ----------630
1300-1307 ----------631
1310-1321 ----------632
1330-1341 ----------633
1350-1361 ----------634
1370-1381 ----------635
1390-1401 ----------636
1410-1421 ----------637
1430-1441 ----------638
1450-1459 ----------639
1460-1477 ----------640
1480-1497 ----------641
注：Light字段642-699保留

--------------------------------------------------------------------------------------------

扩展衣服翅膀特效：Anicount 字段
HumEffect6.wzl 1100 - 1124
HumEffect7.wzl 1125 - 1149
HumEffect8.wzl 1150 - 1174
HumEffect9.wzl 1175 - 1199
HumEffect10.wzl 1200 - 1224
HumEffect11.wzl 1225 - 1249
HumEffect12.wzl 1250 - 1274
HumEffect13.wzl 1275 - 1299
...................以此类推扩展至65535

扩展武器特效:
WeaponEffect6.wzl 1150-1174
WeaponEffect7.wzl 1175-1199
WeaponEffect8.wzl 1200-1224
WeaponEffect9.wzl 1225-1249
WeaponEffect10.wzl 1250-1274
WeaponEffect11.wzl 1275-1299
...................以此类推扩展至65535


天生元素字段说明

数据库设置天生元素方式

装备 时装 称号 都支持天生元素 显示元素须在M2开启新属性才显示

element: 暴击几率(暴击几率增加 1~1000%)
element1: 攻击伤害(增加攻击伤害 1~1000%)
element2: 伤害吸收(物理伤害减少 1~100%)
element3: 魔法防御(魔法伤害减少 1~100%)
element4: 忽视防御(忽视目标防御 1~100%)
element5: 伤害反弹(所有伤害反弹 1~100%)
element6: 人物暴率(增加目标暴率 1~100%)
element7: 体力增加(人物体力增加 1~100%)
element8: 魔力增加(人物魔力增加 1~100%)
element9: 怒气恢复(怒气恢复增加 1~100%)
element10: 合击伤害(合击攻击增加 1~100%)
element11: 怪物暴率
element12: 防暴几率
element13: 防止麻痹
element14: 防止护身
element15: 防止复活
element16: 防止全毒
element17: 防止诱惑
element18: 防止火墙
element19: 防止冰冻
element20: 防止蛛网
element21: 致命一击几率
element22: 致命一击伤害增加
element23: 致命一击防御
element24: 暴击抗性(对方暴击几率 - 暴击抗性 = 对方暴击打出几率)1~1000%
element25: 攻击伤害抗性(对方攻击伤害倍数 - 攻击伤害抗性 = 对方攻击伤害增加的倍数) 1~1000% ..........本抗性对应元素属性1 增加攻击伤害
几率大于100%则按照100%计算，如暴击几率300%，目标暴击抗性270%，那么攻击这个目标的暴击几率只有30% ，，目标抗性为10% ，就是300-10=290 ，也为100%
element26: 杀怪经验倍率 1~100000% [算法相加：自身倍数(自身倍率含特殊物品倍数*经验倍数命令 ） + 元素倍率]

变量： <$ELEMENT>，<$ELEMENT1> - <$ELEMENT26>

英雄变量： <$H.ELEMENT>，<$H.ELEMENT1> - <$H.ELEMENT26>


物品代码表

物品代码(Stdmode) | 物品类型 | 相关说明
0 | 药品 |
1 | 食物 |
2 |  |
3 | 卷类 |
4 | 技能书 |
5 | 武器 |
6 | 武器 |
7 | 技能书 |
8 |  |
9 |  |
10 | 衣服(男) |
11 | 衣服(女) |
12 | 盾牌 | (支持外观)位置代码=16 变量<$SHIELD>
15 | 头盔 |
16 | 斗笠 |
19 | 项链 |
20 | 项链 |
21 | 项链 |
22 | 戒指 |
23 | 戒指 |
24 | 手镯 |
25 | 符、毒药 |
26 | 手镯 |
28 | 马牌 | (支持外观)位置代码=15 变量<$HORSE>
29 | 天使翼 | ----翅膀
30 | 照明物 | 物品数据内Source字段为1时不随时间掉持久，为0随时间掉持久
31 | 捆装物品 |
40 | 宝箱钥匙 | 游戏开宝箱功能，宝箱所需的钥匙
46 | 宝石镶嵌 | 装备打孔镶嵌的宝石
49 | 聚灵珠 |
53 | 宝石 | 有气血石功能 Anicount=1,2,3 分别对应三种石头
55,56,57,58,59 | 宝石 | 宝石升级所需物品
62 | 鞋子 | Anicount控制腰带、靴子、宝石的负重属性
63 | 宝石 | Anicount控制腰带、靴子、宝石的负重属性
64 | 腰带 | Anicount控制腰带、靴子、宝石的负重属性
65 | 军鼓 | 装备位置 14
90 | 灵玉 | 物品位置代码=17
66 | 时装衣服(男) | 物品位置代码=18
67 | 时装衣服(女) | 物品位置代码=18
68、69 | 时装武器 | 物品位置代码=19
70 - 74 | 称号系统 | 称号系统
75、76、77 | 时装项链 | 物品位置代码=20
78 | 时装头盔 | 物品位置代码=21
79、80 | 时装左手镯 | 物品位置代码=22
79、80 | 时装右手镯 | 物品位置代码=23
81、82 | 时装左戒指 | 物品位置代码=24
81、82 | 时装右戒指 | 物品位置代码=25
83 | 时装勋章 | 物品位置代码=26
84、85 | 时装腰带 | 物品位置代码=27
86, 87 | 时装靴子 | 物品位置代码=28
88, 89 | 时装宝石 | 物品位置代码=29
96 | 祝福罐 | 祝福罐、魔族指令、火龙之心填充物数据库设置

物品特殊属性设置:
武器 蜡烛 衣服 类型物品 使用物品数据库字段 AniCount 注:如自身学习了流星火雨请不要佩带触发此技能首饰,否则拿下首饰原流星火雨戒指将被删除!
首饰 头盔 类型物品 使用物品数据库字段 Shape

属性代码 | 属性功能 | 功能介绍
111 | 隐身 | 人物进入隐身状态，普通怪物看不到人物，破隐身的怪物可以看到人物
112 | 传送 | 人物可以使用命令在传送到指定座标上(@UserMove)
113 | 麻痹 | 人物物理攻击时可以将对方麻痹
114 | 复活 | 人物具备复活功能，人物在死亡时起作用，生效一次掉一个持久
115 | 火焰 |
116 | 治愈 |
117,170 | 不掉物品 | 人物死亡时不会掉任何物品，包括背包里的及身上戴的
118 | 护身 | 人物在被攻击时，先降MP，MP为0时才降HP
119 | 超负载 | 人物可以戴上超过自己负重的物品
120 | 技巧 | 人物在练技能时，得到双倍的练习点
121 | 探测 | 可以查找指定人物当前位置
122 | 记忆戒指 |
124 | 记忆手镯 |
125 | 记忆头盔 |
126 | 祈祷手镯 |
127 | 祈祷项链 |
128 | 祈祷戒指 |
129 | 祈祷头盔 |
130 | 神秘戒指 |
131 | 神秘腰带 |
132 | 神秘头盔 |
133 | 魔血戒指 |
134 | 魔血手镯 |
135 | 魔血项链 |
136 | 虹魔戒指 |
137 | 虹魔戒指 |
138 | 虹魔项链 |
139 | 防麻 | 防麻痹功能，可以使被攻击方的麻痹功能失效(不防怪物麻痹）
140 | 无敌(未完全) |
141 | 经验 | 杀怪所得经验为指定倍数(倍数为持久除以 10000)，如果物品持久太小，所得经验将比正常还低
142 | 力量 | 人物攻击力倍数(倍数为持久除以 10000)，如果物品持久太小，所得攻击力将比正常还低
182 | 经验 | 杀怪所得经验为指定倍数(倍数为持久除以 10000)，不受物品持久太小影响
183 | 力量 | 人物攻击力倍数(倍数为持久除以 10000)，不受物品持久太小影响
143 | 防护身 |
144 | 防复活 |
145 | 行会召唤 | 有传送装备 或者 权限>=6时，就可以行会传送
146 | 防红绿毒 | 穿戴此属性首饰可对红绿毒进行免疫
147 | 防诱惑 | 穿戴后自己诱惑的宝宝不会被他人诱惑
148 | 防火墙 | 可防止法师火墙,对火墙有绝对的免疫能力
150 | 麻痹护身 |
151 | 麻痹火球 |
152 | 麻痹防御 |
153 | 麻痹负载 |
154 | 护身火焰 |
155 | 护身防御 |
156 | 护身负载 |
157 | 传送麻痹 |
158 | 传送护身 |
159 | 传送探测 |
160 | 传送复活 |
161 | 复活麻痹 |
162 | 护身复活 |
171 | 不掉背包物品 |
172 | 不掉身上装备 |
201 | 倚天辟地技能(武器) | 学习了倚天辟地技能请不要佩带触发此技能的武器,否则拿下武器原练习的技能将消失
200 | 流星火雨技能(首饰) | 如果技能不增加技能经验，请修改数据库流星火雨job字段设置为1即可
202 | 防御 | 人物防御倍数(倍数为持久除以 10000)，不受物品持久太小影响,限武器、蜡烛、衣服 类型物品数据库字段AniCount
203 | 魔御 | 人物魔御倍数(倍数为持久除以 10000)，不受物品持久太小影响,限武器、蜡烛、衣服 类型物品数据库字段AniCount
204 | 魔道麻痹 | 适合道法的魔法攻击麻痹戒指，麻痹戒指在引擎-物品装备-特殊属性设置
205 | 冰冻 | 有一定几率将目标冰冻（物品装备-特殊属性设置几率）
206 | 蜘蛛网 | 一定几率让目标中蜘蛛网（物品装备-特殊属性设置几率）
207 | 防冰冻 | NPC命令除外、可抵御所有外来冰冻伤害
208 | 防蜘蛛网 | NPC命令除外、可抵御所有外来蜘蛛网伤害
209 | 魔道麻痹+复活 | 拥有麻痹和复活功能


物品极口属性详解

物品极品属性详解

重要注意事项，请在使用本功能前务必详细阅读，否则将有可能带来严重后果
当所需要升级的项链、手镯、戒指、在DB数据库中因 SHAPE 值的不同，而升级
出来得到的结果也不同，所以使用者请按照以下属性变化列表进行详细设置！
其中涉及的体力恢复、魔法恢复、毒物躲避、中毒恢复、如升级成功“1”点属性，则表示为 10%

项链属性：
当SHAPE值为19时：属性位置“0”升级出来表现为“魔法躲避”、属性位置“1”升级出来属性表现为“幸运”
当SHAPE值为20时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当SHAPE值为21时：属性位置“0”升级出来表现为“体力恢复”、属性位置“1”升级出来属性表现为“魔法恢复”

手镯属性：
当SHAPE值为24时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当SHAPE值为26时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”

戒指属性：
当SHAPE值为22时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”
当SHAPE值为23时：属性位置“0”升级出来表现为“毒物躲避”、属性位置“1”升级出来属性表现为“中毒恢复”

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久


物品所需条件设置

使用物品所需条件设置:

物品数据库字段:（字段包括二个参数的需要用字段计算器算出具体数字（计算工具位于“工具”文件夹））

StdItems.Need | StdItems.NeedLevel
0 | 需要指定等级以上才可以戴上
1 | 需要指定攻击力以上才可以戴上
2 | 需要指定魔法力以上才可以戴上
3 | 需要指定道术以上才可以戴上
4 | 需要指定转生等级以上才可以戴上
40 | 需要指定转生等级及指定等级以上才可以戴上
41 | 需要指定转生等级及指定攻击力以上才可以戴上
42 | 需要指定转生等级及指定魔法力以上才可以戴上
43 | 需要指定转生等级及指定道术以上才可以戴上
44 | 需要指定转生等级及指定声望点以上才可以戴上
45 | 需要指定转生等级及指定刺术力以上才可以戴上
46 | 需要指定转生等级及指定箭术力以上才可以戴上
47 | 需要指定转生等级及指定武力以上才可以戴上
5 | 需要指定声望点以上才可以戴上
50 | 所需等级&声望
51 | 所需攻击力&声望
52 | 所需魔法力&声望
53 | 所需道术&声望
54 | 所需刺术力&声望
55 | 所需箭术力&声望
56 | 所需武力&声望
6 | 加入了行会的人才可以戴上
60 | 行会掌门才可以戴上
7 | 沙城成员才可以戴上
70 | 沙城城主才可以戴上
8 | 会员才可以戴上
81 | 指定类型会员，及大于或等于指定会员等级，字段设置
82 | 指定或大于类型会员，及大于或等于指定会员等级字段设置
10 | 需要指定职业及指定等级以上才可以戴上
11 | 需要指定职业及指定攻击力以上才可以戴上
12 | 需要指定职业及指定魔法力以上才可以戴上
13 | 需要指定职业及指定道术以上才可以戴上
14 | 固定等级(必须为指定等级配戴)
15 | 需要指定职业及指定刺术力以上才可以戴上
16 | 需要指定职业及指定箭术力以上才可以戴上
17 | 需要指定职业及指定武力以上才可以戴上

StdItems.Job | 含义（仅限制武器、时装武器、衣服、时装衣服、盾牌、斗笠）
0 | 战法道装备
1 | 战士装备
2 | 法师装备
3 | 道士装备
4 | 刺客装备
5 | 弓箭手装备
6 | 武僧装备
99 | 全职业装备


祝福罐、魔族指令设置

说明: 祝福罐、魔族指令、火龙之心填充物数据库设置

DB记录（StdMode = 96; 祝福罐，Horse = 0：双击释放后减总数量，Horse = 1:双击释放不减数量）
133 祝福油 3 4 1 10 0 0 26 1 0 0 0 0 0 0 0 0 0 0 0 0 1000 5 255 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1380 祝福罐 96 10 1 0 0 1174 20000 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1381 火龙补品 97 0 1 0 0 0 1224 5000 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

UnbindList.txt
10 祝福油

注意：

祝福罐的Shape要对应释放出来的物品的 AniCount，并且要在UnbindList中添加数据。

魔族指令和祝福罐一样使用！！！！

魔族令和祝福罐使用：佩戴人物毒符位置，将祝福油（魔族指令）从背包拖动到装备栏祝福罐内！

火龙填充物用法一样，拖动填充物到英雄装备栏火龙之心上面，补充火龙之心的持久，或者人物佩戴也可以填充的哦！


 自定义回城石

以下脚本放如QFunction中.具体需要根据自己服务器的情况设置.

;盟重回城石
[@StdModeFunc59]
#IF
#ACT
MAPMOVE 3 330 330

;比奇回城石
[@StdModeFunc60]
#IF
#ACT
MAPMOVE 0 330 270

;苍月回城石
[@StdModeFunc61]
#IF
#ACT
MAPMOVE 5 140 338

;封魔回城石
[@StdModeFunc62]
#IF
#ACT
MAPMOVE 4 240 202

注：MAPMOVE 支持坐标范围内传送，如：MAPMOVE 4 240 202 3 则传送到地图：4 X坐标：240 Y坐标：202 范围3内随机坐标


自定义连击素材

解决一些人自己增加了装备又要使用连击或者倚天辟地技能却看不到动作的问题

连击技能数据库expand3字段控制是否使用自定义的指定的素材（大家自己增加装备又不想制作连击动作的素材，那么就这个字段控制统一显示素材）

说明：
衣服：cbohumdiy.wzl 和 cboHumEffectdiy.wzl
武器 cboweapondiy.wzl 和 cboweaponeffectdiy.wzl
数据库的 expand3 = 1-30时，读上面diy中的资源。默认0则读取官方或者理解为官方一样的格式
注意：数据库的 expand3 = 1-30时 技能倚天辟地也是DIY素材，DIY指定可解决自己制作添加的装备没有连击素材·施展时候看不到人物动作问题！
衣服为2000张素材为一件（详见官方cbohum3.wzl进行参考，设置1读取0-1999，设置2读取2000-3999 . . . .设置30读取 58000-59999）

DIY武器和衣服设置不同，武器分男女设置1男的读取0-1999，女的读取2000-39999，数据库任意一件武器的expand3字段设置1-15，那么施展连击和倚天辟地则读取指定的DIY素材：cboweapondiy.wzl
如果你衣服增加特效也需要按照顺序导入cboHumEffectdiy.wzl，武器有特效请对应 cboweaponeffectdiy.wzl（需和cboweapondiy.wzl对应）即可！,倚天辟地位于每组素材资源中400-599编号，自己参考官方的cbohum.wzl文件

DIY文件和官方格式一模一样，读取方式也一模一样，目的是给一些人给自己游戏增加了很多装备，又不想给每套装备制作连击动作，那么你可以每个职业每个性别各制作一套连击动作，或者直接将官方的连击动作导出然后导入到DIY文件（2000张图）

比如你的衣服补丁文件cbohum19.wzl ，当EXPAND3=0（默认）时候，连击动作对应： cbohum19.wzl（官方素材），衣服特效对应：cboHumEffect19.wzl（官方素材），，当EXPAND3=1 时候，连击动作对应： cbohumdiy.wzl，衣服特效对应：cboHumEffectdiy.wzl（顺序：1-30）

武器和衣服设置方式一样，不懂的就慢慢想吧

注意衣服不分男女，参数为1-30。。。武器区分男女，参数：1-15（衣服为1个编号为2000张图片，不区分男女、、、、武器1个编号4000张图片，区分男女）

============================================================

精简介绍：
如果连击和倚天辟地用官方素材那么物品（衣服或者武器）数据库expand3字段默认0即可
如果要给指定衣服和武器进行自定义设置的话那么就在该武器或者衣服的数据库expand3字段设置指定数值
expand3数值可设置1-30，每个数值2000张图片！（设置1读取0-1999，设置2读取2000-3999 . . . .设置30读取 58000-59999）

自定义素材说明：

衣服：cbohumdiy.wzl 对应 cboHumEffectdiy.wzl（不要特效可以忽略这个文件，需要特效那么这2个素材文件图片编号必须对应一致）
武器 cboweapondiy.wzl 对应 cboweaponeffectdiy.wzl（不要特效可以忽略这个文件，需要特效那么这2个素材文件图片编号必须对应一致）

什么叫素材对应一致：

比如cbohumdiy.wzl 0-1999 衣服没特效，那么cboHumEffectdiy.wzl文件中0-1999留空， cbohumdiy.wzl素材中图片编号2000-3999的衣服有编号，那么cboHumEffectdiy.wzl素材文件中的2000-3999的特效需要对应！可参考官方文件！


53类宝石(封印)介绍[!]

功能：
53类宝石介绍

功能：石头拥有气血石功能 Anicount=1,2,3 分别对应三种石头的回血功能.

说明

石头拥有气血石功能 Anicount=1,2,3 分别对应三种石头的回血功能..另外拥有 防御 魔御 攻击 魔法 道术的属性，另可增加特殊属性，如Shape值设置116将获取治愈术技能

此类装备装备持久为0了后不消失 不显示防御 魔御 攻击 魔法 道术的属性，人物属性不在增加这些属性（属性失效）

此宝石不可以修理 必须用对应 Shape=1,2,3三种气血石石头来恢复 53类Anicount=1,2,3的石头.丢入石头当前剩余多大持久给予增加多少持久，当丢入石头持久大于此类宝石持久，只将持久加满剩余的持久被系统吃掉..

注：持久为0的时附加属性全部失效（包括附加特殊属性）


神佑袋

神佑袋（十二生肖）介绍

功能：佩戴12生肖物品.

数据库

234;子鼠神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;1;;
235;丑牛神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;2;;
236;寅虎神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;3;;
237;卯兔神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;4;;
238;辰龙神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;5;;
239;巳蛇神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;6;;
240;午马神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;7;;
241;未羊神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;8;;
242;申猴神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;9;;
243;酉鸡神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;10;;
244;戌狗神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;11;;
245;亥猪神佑;22;0;0;0;0;0;130;10000;1;2;3;4;5;6;7;8;9;10;0;50;123123;5;253;;;;;;;12;;

放入条件

物品允许装备的位置（只限于可以装备的物品）数据库字段：Overlap

Overlap值 | 位置
0 | 只允许穿身上
1 | 只允许穿身上 【基础位置】
2 | 只允许首饰盒【基础位置】
4 | 只允许神佑【基础位置】
8 | 只允许时装首饰盒【基础位置】
16 | 只允许时装神佑【基础位置】
25 | 1+8+16；身上+时装首饰盒+时装神佑

其他位置在此不逐个列举，比如，希望一个物品能放置在以下位置，只需要将基础位置相加：
身上+首饰盒+时装首饰盒 = 1 + 2 + 8 = 11

神佑物品的DB字段Expand1（0时不能放入，1时放入第一个神佑格以此类推，13为可放入任意格子）

NPC操作命令

以下几个命令均支持英雄操作，也就是H.

  • 功能命令：显示或隐藏装备界面神佑图标

    命令格式：ShowGodBless 0/1(0:隐藏;1:显示) 是否时装神佑0/1(0:普通神佑;1:时装神佑)

  • 功能命令：开启神佑格，开启后才能放物品

    命令格式：OpenGodBless 格子位置(0-11, all) 是否时装神佑0/1(0:普通神佑;1:时装神佑)

  • 功能命令：关闭神佑格

    命令格式：CloseGodBless 格子位置(0-11, all) 是否时装神佑0/1(0:普通神佑;1:时装神佑)

  • 检测命令：检测神佑图标是否显示

    命令格式：CheckShowGodBless 是否时装神佑0/1(0:普通神佑;1:时装神佑)

  • 检测命令：检测神佑格是否开启

    命令格式：CheckOpenGodBless 格子位置(0-11) 是否时装神佑0/1(0:普通神佑;1:时装神佑)

示例脚本

[@main]
玩家神佑: <开神佑/@开玩家神佑>  <关神佑/@关玩家神佑>  <开时装神佑/@开玩家时装神佑>  <关时装神佑/@关玩家时装神佑> \
英雄神佑: <开神佑/@开英雄神佑>  <关神佑/@关英雄神佑>  <开时装神佑/@开英雄时装神佑>  <关时装神佑/@关英雄时装神佑> \

[@开玩家神佑]
#IF
#ACT
ShowGodBless 1
OpenGodBless 0

[@关玩家神佑]
#ACT
CloseGodBless 0

[@开玩家时装神佑]
#IF
#ACT
ShowGodBless 1 1
OpenGodBless 0 1

[@关玩家时装神佑]
#ACT
CloseGodBless 0 1

[@开英雄神佑]
#IF
#ACT
H.ShowGodBless 1
H.OpenGodBless 0
H.OpenGodBless 1

[@关英雄神佑]
#IF
#ACT
H.CloseGodBless 0
H.CloseGodBless 1

[@开英雄时装神佑]
#IF
#ACT
H.ShowGodBless 1 1
H.OpenGodBless 0 1
H.OpenGodBless 1 1

[@关英雄时装神佑]
#IF
#ACT
H.CloseGodBless 0 1
H.CloseGodBless 1 1
[@main]
玩家神佑: <开神佑/@开玩家神佑>  <关神佑/@关玩家神佑>  <开时装神佑/@开玩家时装神佑>  <关时装神佑/@关玩家时装神佑> \
英雄神佑: <开神佑/@开英雄神佑>  <关神佑/@关英雄神佑>  <开时装神佑/@开英雄时装神佑>  <关时装神佑/@关英雄时装神佑> \

[@开玩家神佑]
#IF
#ACT
ShowGodBless 1
OpenGodBless 0

[@关玩家神佑]
#ACT
CloseGodBless 0

[@开玩家时装神佑]
#IF
#ACT
ShowGodBless 1 1
OpenGodBless 0 1

[@关玩家时装神佑]
#ACT
CloseGodBless 0 1

[@开英雄神佑]
#IF
#ACT
H.ShowGodBless 1
H.OpenGodBless 0
H.OpenGodBless 1

[@关英雄神佑]
#IF
#ACT
H.CloseGodBless 0
H.CloseGodBless 1

[@开英雄时装神佑]
#IF
#ACT
H.ShowGodBless 1 1
H.OpenGodBless 0 1
H.OpenGodBless 1 1

[@关英雄时装神佑]
#IF
#ACT
H.CloseGodBless 0 1
H.CloseGodBless 1 1

QF触发：

人物未开启时，点击神佑格QF触发
[@GodBlessItemClick0-11]

英雄未开启时，点击神佑格QF触发
[@HeroGodBlessItemClick0-11]

人物未开启时，点击时装神佑格QF触发
[@FashionGodBlessItemClick0-11]

英雄未开启时，点击时装神佑格QF触发
[@HeroFashionGodBlessItemClick0-11]

人物神佑袋界面图片按钮触发-图片位于必备补丁-文字自行PS增加
[@GodBlessUpgradeClick]

英雄神佑袋界面图片按钮触发-图片位于必备补丁-文字自行PS增加
[@HeroGodBlessUpgradeClick]

人物时装神佑界面图片按钮触发-图片位于必备补丁-文字自行PS增加
[@FashionGodBlessUpgradeClick]

英雄时装神佑界面图片按钮触发-图片位于必备补丁-文字自行PS增加
[@HeroFashionGodBlessUpgradeClick]

鼠标提示文字：

;——————————————————客户端补丁集成文件名（放入Resources/data）
;当然这个Resources目录不是绝对的，因配置器上可以自定义此目录名称，均以自定义名称为准~
GodBlessItems.dat

;——————————————————普通神佑格子标题名称
title1=子鼠神佑格
title2=丑牛神佑格
title3=寅虎神佑格
title4=卯兔神佑格
title5=辰龙神佑格
title6=巳蛇神佑格
title7=午马神佑格
title8=未羊神佑格
title9=申猴神佑格
title10=酉鸡神佑格
title11=戌狗神佑格
title12=亥猪神佑格

;——————————————————普通神佑未开启时内容介绍
1=116/当前子鼠神佑格未开启状态\116/使用100元宝即可立即开启！
2=116/当前丑牛神佑格未开启状态\116/使用100元宝即可立即开启！
3=116/当前寅虎神佑格未开启状态\116/使用100元宝即可立即开启！
4=116/当前卯兔神佑格未开启状态\116/使用100元宝即可立即开启！
5=116/当前辰龙神佑格未开启状态\116/使用100元宝即可立即开启！
6=116/当前巳蛇神佑格未开启状态\116/使用100元宝即可立即开启！
7=116/当前午马神佑格未开启状态\116/使用100元宝即可立即开启！
8=116/当前未羊神佑格未开启状态\116/使用100元宝即可立即开启！
9=116/当前申猴神佑格未开启状态\116/使用100元宝即可立即开启！
10=116/当前酉鸡神佑格未开启状态\116/使用100元宝即可立即开启！
11=116/当前戌狗神佑格未开启状态\116/使用100元宝即可立即开启！
12=116/当前亥猪神佑格未开启状态\116/使用100元宝即可立即开启！

;——————————————————普通神佑开启后内容介绍
101=223/*******249/子鼠神佑格/*******已经开启！放入物品后属性将生效！
102=223/丑牛神佑格已经开启！放入物品后属性将生效！
103=223/寅虎神佑格已经开启！放入物品后属性将生效！
104=223/卯兔神佑格已经开启！放入物品后属性将生效！
105=223/辰龙神佑格已经开启！放入物品后属性将生效！
106=223/巳蛇神佑格已经开启！放入物品后属性将生效！
107=223/午马神佑格已经开启！放入物品后属性将生效！
108=223/未羊神佑格已经开启！放入物品后属性将生效！
109=223/申猴神佑格已经开启！放入物品后属性将生效！
110=223/酉鸡神佑格已经开启！放入物品后属性将生效！
111=223/戌狗神佑格已经开启！放入物品后属性将生效！
112=223/亥猪神佑格已经开启！放入物品后属性将生效！

;——————————————————时装神佑格子标题名称
title2001=子鼠神佑格(时装)
title2002=丑牛神佑格(时装)
title2003=寅虎神佑格(时装)
title2004=卯兔神佑格(时装)
title2005=辰龙神佑格(时装)
title2006=巳蛇神佑格(时装)
title2007=午马神佑格(时装)
title2008=未羊神佑格(时装)
title2009=申猴神佑格(时装)
title2010=酉鸡神佑格(时装)
title2011=戌狗神佑格(时装)
title2012=亥猪神佑格(时装)

;——————————————————时装神佑未开启时内容介绍
2001=116/当前(时装)子鼠神佑格未开启状态\116/使用100元宝即可立即开启！
2002=116/当前(时装)丑牛神佑格未开启状态\116/使用100元宝即可立即开启！
2003=116/当前(时装)寅虎神佑格未开启状态\116/使用100元宝即可立即开启！
2004=116/当前(时装)卯兔神佑格未开启状态\116/使用100元宝即可立即开启！
2005=116/当前(时装)辰龙神佑格未开启状态\116/使用100元宝即可立即开启！
2006=116/当前(时装)巳蛇神佑格未开启状态\116/使用100元宝即可立即开启！
2007=116/当前(时装)午马神佑格未开启状态\116/使用100元宝即可立即开启！
2008=116/当前(时装)未羊神佑格未开启状态\116/使用100元宝即可立即开启！
2009=116/当前(时装)申猴神佑格未开启状态\116/使用100元宝即可立即开启！
2010=116/当前(时装)酉鸡神佑格未开启状态\116/使用100元宝即可立即开启！
2011=116/当前(时装)戌狗神佑格未开启状态\116/使用100元宝即可立即开启！
2012=116/当前(时装)亥猪神佑格未开启状态\116/使用100元宝即可立即开启！

;——————————————————时装神佑开启后内容介绍
2101=223/*******249/子鼠神佑格/*******已经开启！放入物品后属性将生效！
2102=223/(时装)丑牛神佑格已经开启！放入物品后属性将生效！
2103=223/(时装)寅虎神佑格已经开启！放入物品后属性将生效！
2104=223/(时装)卯兔神佑格已经开启！放入物品后属性将生效！
2105=223/(时装)辰龙神佑格已经开启！放入物品后属性将生效！
2106=223/(时装)巳蛇神佑格已经开启！放入物品后属性将生效！
2107=223/(时装)午马神佑格已经开启！放入物品后属性将生效！
2108=223/(时装)未羊神佑格已经开启！放入物品后属性将生效！
2109=223/(时装)申猴神佑格已经开启！放入物品后属性将生效！
2110=223/(时装)酉鸡神佑格已经开启！放入物品后属性将生效！
2111=223/(时装)戌狗神佑格已经开启！放入物品后属性将生效！
2112=223/(时装)亥猪神佑格已经开启！放入物品后属性将生效！

装备位置

  • 普通神佑：40 --- 51
  • 时装神佑：80 --- 91

相关变量

  • 人物变量（普通神佑）：<$GODBLESSITEM1> --- <$GODBLESSITEM12>
  • 英雄变量（普通神佑）：<$H.GODBLESSITEM1> --- <$H.GODBLESSITEM12>
  • 人物变量（时装神佑）：<$FASHION_GODBLESSITEM1> --- <$FASHION_GODBLESSITEM12>
  • 英雄变量（时装神佑）：<$H.FASHION_GODBLESSITEM1> --- <$H.FASHION_GODBLESSITEM12>


登录游戏时的聊天框最上方显示公告

功能：登录游戏时的聊天框最上方显示公告
和普通公告一样属于聊天框滚动公告，只是显示位置靠前
------------------------------------------------

*登录游戏时的聊天框最上方显示公告

格式：脚本放入QManage.txt
读取QM中[@BeforeLogin]字段

[@BeforeLogin]
#ACT
SENDMSG 1 在登录后“攻击模式”提示前面显示文字<$USERNAME>

图示：


NPC对话框调用背包物品信息（支持物品图片以及展示属性）

NPC对话框调用背包物品信息

功能：NPC对话框调用背包物品信息
说明： NPC对话框按照物品唯一序列号调用背包物品信息

脚本调用：

<makeindexitem:D:F:X:Y:Z:W:G/@Label>

参数说明：
d= 物品IDX唯一序号
F= 数量(数量设置小于1则不显示)
X Y = 微调坐标 排版的
Z= 是否显示物品框，0为不显示，1为显示(当为1时，读取NewopUI.pak:250)，值>1 (NewopUI.pak中指定素材)
W= 首饰发光代码，代码与light一样（不需要则可忽略不填写这个参数 ，或填写0）
G= 灰化显示(0或空=正常，1=灰化)
U= 数量是否显示单位（0为不显示单位；1:超过10000时显示单位W)
鼠标放上去显示物品属性。类似<Img>图标的用法
@Label是点击图片时需要触发的脚本标签. (不需要跳转则可不需填写，如：<ItemShow:D:F:X:Y:Z:W:G:U>)

效果展示：

.


CallEx支持多个同样的@地址

功能说明: 原来多次Call@地址只能调用一个地址，新增CallEx支持多个同样的@地址

CALLEX说明:原来多次Call@地址只能调用一个地址，新增CallEx支持多个同样的@地址

--------------------------------------------------------

示例脚本：

[@main]
<充值1/@1> <充值2/@2> <充值3/@3> \

[@1]
#IF
#ACT
#CALLEX [\脚本1.txt] @充值链接
break

[@2]
#IF
#ACT
#CALLEX [\脚本2.txt] @充值链接
;前面有1个@充值链接，本次解析会将@充值链接自动换成[@充值链接~1]
break

[@3]
#IF
#ACT
#CALLEX [\脚本3.txt] @充值链接
;前面有2个@充值链接，本次解析会将@充值链接自动换成[@充值链接~2]
break

说明：原CALL使用以上脚本全部读取一个脚本的@充值链接，CALLEX读取准确路径中的@充值链接


IF多条件检测[!]

功能: #IF 多条件检测，#if(3) // 如果众多条件中只需要满足3个条件，即可执行#act , #say.....等

简易示例：
;在其中一个地图均可通过检测
#if(1)
ISONMAP 0
ISONMAP 3
ISONMAP 5
#say
你再规定的地图内

;满足其中2个条件即可通过检测
#if(2)
check [100] 1
CheckLevel 51
CHECKGAMEGOLD > 19
#act
SENDMSG 满足条件


LineNotice.txt彩色滚动公告[!]

例：
[253,0]自定义字体颜色公告！
<252,255>窗口顶部滚动公告！

格式1：[253,0]聊天框公告 0为背景色 253前景色
格式2：<252,255,190> 窗口顶部滚动公告,255为背景色 252前景色 190为背景条颜色（背景条颜色留空为不显示）
格式3：<252,255> 9 公告内容 255为背景色 252前景色，9(9两边用tab键隔开)为公告字体大小(9号不加粗)
格式4：<252,255,190> 10b 公告内容 255为背景色 252前景色 190为背景条颜色，10b(10b两边用tab键隔开)为公告字体大小(10号加粗)


NPC标签备注功能[!]

功能：
NPC标签备注功能

格式：

[@main]
<翎风世界引擎官方网站|253#翎风引擎官方网站：^254#www.lfm2.com>\
<翎风世界引擎官方网站|249#翎风引擎官方网站：^250#www.lfm2.com/@打开>\
<Img:210:3:0:0|254#翎风引擎官方网站：^253#www.lfm2.com>\
<Img:210:3:0:0|249#翎风引擎官方网站：^250#www.lfm2.com/@打开>\

[@打开]
#if
#ACT
SENDMSG 6 按钮事件触发成功


Npc对话框绝对坐标元素

功能：
Npc对话框绝对坐标

功能：Npc对话框元素，多个元素前增加&，命令中原有的偏移坐标加了&后表示绝对坐标

示范：

[@main]
这是一行文字\
下面的文字是绝对坐标\
<&Img:18:25:19:55/@Main>

以下均支持绝对坐标：

前面加&，表示绝对坐标（未加&保持原样即偏移坐标）；支持元素:
&Img:
&PlayImg:
&ItemShow:
&UserItem:
&ImgEx:
&ImgNum:
&Text:
&PlayImgEx:
&InputNum:
&InputText:
&Progressbar:
&Looks:
&DnItems:
&StateItem:
&NewOPUI:
&CountDown:
&ImgCountDown:
&Layout:


NPC对话框内倒计时

-----------------------------------NPC对话框内倒计时---------------------------

说明：NPC对话框内倒计时显示

格式：<COUNTDOWN:倒计时时间(秒):次数(0无限次):颜色:X:Y:M/@触发>
参数M为显示格式：
以90秒和50秒为例
0或空时 默认显示方式 00:01:30 00:00:50
1 根据是否有小时/分动态显示 01:30 50
2 以秒显示 90 50

---------------------------------------------------

示列：
倒时计：<COUNTDOWN:10:3:251:0:0/@倒计时结束>\

;触发放在当前NPC
[@倒计时结束]
#act
SendMsg 5 倒计时结束触发

---------------------------------------------------
图片数字倒计时（按需使用 ，因图转换数字不支持：）

格式：<IMGCOUNTDOWN:倒计时时间(秒):次数(0无限次):开始图片:数字图片间隔:X:Y:M/@触发>
说明：数字图片读取Newopui.pak中的开始图片(图片顺序为0-9:) 第10张图为：号图，以下面示列计算图片编号1330为：号图片，素材自行添加

示列：
图片数字倒时计：<IMGCOUNTDOWN:10:3:1320:10:10:-6/@倒计时结束>\

注意:当在ADDDLG 、ADDDLGEX对话框中需要使用COUNTDOWN倒计时的话，那么触发脚本就不在NPC中，则在QF中，触发字段必须为ADDDLG的专用触发字段
如下：
;ADDDLG对话框中脚本
倒时计：<COUNTDOWN:10:3:251:0:0/@1000> \

qf触发：
[@DlgButtonClick1000]
#act
SendMsg 5 倒计时结束触发


NPC对话框调用身上装备信息（支持物品图片以及展示属性）

脚本调用：

<UserItem:D:X:Y:Z:W/@Labell>

参数说明：
d= 装备位置（0-29:身上装备; 30-35:首饰盒; 40-51:神佑)
X Y = 微调坐标 排版的
Z= 是否显示物品框，0为不显示，1为显示 (当为1时，读取NewopUI.pak:250)，值>1 (NewopUI.pak中指定素材)
W= 首饰发光代码，代码与light一样（不需要则可忽略不填写这个参数 ，如去掉:W）
鼠标放上去显示物品属性。类似 [image] 图标的用法
@Label是点击图片时需要触发的脚本标签. (不需要跳转则可不需填写，如：)

-------------------------------------

英雄（需英雄在线）：

<HeroUserItem:D:X:Y:Z:W/@Labell>

-------------------------------
效果展示：

.

*英雄格式同人物的一样，区别就是英雄变量增加Hero...


NPC对话框调用装备信息（支持物品图片以及展示属性）

脚本调用：

<ItemShow:D:F:X:Y:Z:W:G/@Label>

参数说明：
d= 数据物品ID
F= 数量(数量设置小于1则不显示)
X Y = 微调坐标 排版的
Z= 是否显示物品框，0为不显示，1为显示(当为1时，读取NewopUI.pak:250)，值>1 (NewopUI.pak中指定素材)
W= 首饰发光代码，代码与light一样（不需要则可忽略不填写这个参数 ，或填写0）
G= 灰化显示(0或空=正常，1=灰化)
U= 数量是否显示单位（0为不显示单位；1:超过10000时显示单位W)
鼠标放上去显示物品属性。类似<Img>图标的用法
@Label是点击图片时需要触发的脚本标签. (不需要跳转则可不需填写，如：<ItemShow:D:F:X:Y:Z:W:G:U>)

效果展示：

.


NPC获取文件行数命令

功能：
读取文件行数命令

功能：NPC获取文件行数命令

示范：

命令：GetTextLineCount 路径 保存变量

[@main]
#if
#act
GetTextLineCount ..\QuestDiary\装备回收.txt N$行数
Sendmsg 5 提示:装备回收.txt文件共有<$STR(N$行数)>行内容


NPC命令打开装备栏及其他页面[!]

功能：NPC命令打开任务和英雄的装备栏，属性栏，技能栏，时装栏，称号栏，出战栏
格式：命令 参数1 参数2 参数3
详细说明：

人物命令：OpenHumDlg 页面 （0：装备，1：状态， 2：属性， 3：技能；4：时装，5：称号，6：出战，7：人物包裹 8：首饰盒 9：神佑 10：时装首饰盒 11：时装神佑）

英雄命令：OpenHeroDlg 页面（0：装备，1：状态， 2：属性， 3：技能；4：时装，5：称号，6：英雄包裹 8：首饰盒 9：神佑 10：时装首饰盒 11：时装神佑）

列子：
#if
#act
OpenHumDlg 5

命令支持设定打开坐标： OpenHumDlg 位置 X坐标 Y坐标 如果不设置坐标为打开默认位置！


Npc文字Text使用

功能：
Npc对话框文字Text运用

功能：设置文字在对话框中坐标、颜色、字体大小、字体、粗体显示.

说明：

格式：Text:文字:提示:X:Y{FCOLOR=250;FSIZE=14;FNAME=黑体;FBOLD=1}/@测试

示范： <Text:文字内容|提示:0:0{FCOLOR=250;FSIZE=14;FNAME=黑体}/@测试> \ \

绝对坐标示范： <&Text:绝对坐标|提示:0:0{FCOLOR=250;FSIZE=14;FNAME=黑体}/@测试> \ \

字体25号，加粗，楷体，变色显示
<Text:绝对坐标|提示:30:20{AUTOCOLOR=254,251,168,191,250,70,245,249,253;FSIZE=25;FNAME=楷体;FBOLD=1}/@测试> \ \\ \\ \

颜色253，字体25号，宋体
<Text:测试下这段文字的显示|提示信息:10:20{FCOLOR=253;FSIZE=25;FNAME=宋体}/@测试>

参数说明:
AUTOCOLOR 彩色字体设置
FSIZE 字体大小
FNAME 字体类型
FBOLD 字体加粗
FCOLOR 字体颜色


ThrowItem在放置物品之前修改物品的来源

功能说明：使用ThrowItem命令放置物品之前修改物品的来源

命令：SetThrowItemFrom 物品来源(0-9) 地图号 怪物人 杀人者 日期(yyyy-mm-dd) 时间(hh:nn:ss)

物品来源代码：
0未知; 1:GM制造; 2:脚本; 3:商店购买; 4:打怪掉落; 5:系统给予; 6:挖矿得到; 7:宝箱取得; 8:挖肉得到; 9捕捉得到

说明：本命令只对设置后的一条ThrowItem生效。执行一次ThrowItem后，设置还原。

-----------------------------------------------------------------------------

示范：

[@物品]
#if
#act
SetThrowItemFrom 4 3 白野猪 杀人者 2021-01-11 10:00:00
ThrowItem <$map> <$x> <$y> 1 屠龙 1|0

[@KillMon]
#if
#act
SetThrowItemFrom 4 3 白野猪 杀人者 <$Date> <$Time>
THROWITEM <$MAP> <$KILLMONX> <$KILLMONY> 1 力量戒指 1|120 2 1
sendmsg 7 测试下放置物品修改来源
SENDMSG 6 当前日期：<$Date>；当前时间<$Time>


变量支持数字单位

功能：
 变量支持数字单位,922京,大数值单位

使用方法：

[@main]
#ACT
Mov N0 1234567891234567
#SAY
N0的值为:<$stru(N0)>\

;---------------

NPC对话框增加BigNum:元素（用于将大数值进行单位显示）
<BigNum:数值:X:Y:{FColor=249;FSize=9;FName=微软雅黑}>

[@示例]
#IF
#ACT
Mov N1 10000000000
#SAY
<$STRU(N1)>\
<BigNum:<$STR(N1)>:X:Y:{FColor=249;FSize=9;FName=微软雅黑}>\

;---------------

悬浮框增加BigNum元素：（常用于自定义属性数字转换为单位显示）
<BigNum:数字值:文字颜色>


创建副将英雄脚本

;@@BuHero 是创建和删除副将英雄的标志

;@HeroNameFilter 当创建英雄输入名称中有禁止字符或者名称超过14个字符触发此脚本

;以下是酒馆_辰星的脚本

(@@BuHero @PlayDrink )
[@main]
魔法不单是华丽的攻击，更需要在战斗中感受它的使用技巧。现\
在是时间让年轻的卧龙英雄们去体会战斗中的艰辛了。如果能在修\
行中遇到值追随一生的伙伴，对他们来说也许就更有意义！\ \
<召唤卧龙英雄/@召唤卧龙英雄>\
<寄存领回英雄/@寄领英雄> \
<主将副将英雄培养/@主副英雄培养> \
<我不想再带领卧龙英雄/@不带英雄>\

[@召唤卧龙英雄]
<我想找卧龙英雄做为我的历练伙伴/@领取卧龙英雄>\ \
<返回/@main>

[@寄领英雄]
<我想找您帮个忙，我想寄放英雄/@寄放英雄>\
<我想领回英雄/@领回英雄> \ \
<返回/@main>

[@主副英雄培养]
#if
CheckHeroAutoPractice
#say
看来你的副将英雄正在进行自我修炼....\ \
<我要停止副将英雄的自我修炼/@停止自我修炼>\ \
<查看副将英雄修炼时间/@查看修炼时间>
#elsesay
随着我们多年以来对英雄的训练，我们发现了一种新的培养方式和\
战斗方式。新的培养方式能够让同一英雄以三职业不同状态出战。\
新的战斗方式能够让你在战斗中召唤第二个英雄替换英雄进行战斗，\
从而对战局产生变化。\
当然，要想实现这一切的前提是必须对你的卧龙英雄和白日门英雄\
进行评定，选出主将和副将，才能够进行新的培养方式。\
<主将副将英雄评定/@主副将评定> <副将英雄自我修炼/@自我修炼> <英雄的历史/@英雄历史>\
<主将副将英雄指南/@英雄指南>\
<返回/@main>

[@停止自我修炼]
#if
#ACT
StopHeroAutoPractice
Close

[@StopHeroAuto]
#if
#ACT
give 金创药 1
Close

[@查看修炼时间]
你的副将英雄本次的修炼时间为:<$HEROAUTOTIME>秒\
<返回/@主副英雄培养>

[@主副将评定]
#if
#act
ASSESSMENTHERO

[@自我修炼]
#if
CheckDeputyHero
;检测当前在线的是卧龙英雄
#say
请注意：副将英雄的等级上限为主将英雄当前等级减三，副将\
英雄的内功等级上限为主将英雄当前内功等级减三。一旦副将\
英雄的等级或内功等级达到上限，自动修炼将不能获得相应的\
经验或内功经验。\
当且仅当副将英雄自动修炼满2小时，且在酒馆英雄NPC处终止\
训练时，将有几率带回训练过程中拾取的物品。\ \
<副将英雄自动修炼/@自动修炼>
#elsesay
请先召唤出你的副将英雄吧......\

[@自动修炼]
#if
#ACT
OpenHeroAutoPractice
Close

[@领回英雄]
<$USERNAME>,想和你的英雄一起闯荡玛珐大陆吗？\ \
<是的，我是来接他走的/@GetHero>\ \
<不了，还要托你照顾一段时间/@exit>\

[@GetHero]
#if
#act
GetHero

[~PlayDrink_Already]
#if
#act
#Say
嗯......真是香醇的美酒,令我心情舒畅。\<寄放英雄/@SaveHero>

[~PlayDrink_Already_NotHero]
#if
#act
#Say
你没喝多吧？你身边空无一人，还说要把英雄\托付我？\

[~PlayDrink_Already_HeroBegin]
#if
#act
#Say
你没喝多吧？你身边空无一人，还说要把英雄\托付我？\<重新寄放英雄/@SaveHero>

[@领取卧龙英雄]
#if
HAVHERO TRUE
#say
你已经有卧龙英雄了,还想再领取?\
#elsesay
<$USERNAME>，休息一下吧。不要忽视声明中的美好。\
如同杯中的美酒一般，一起喝吗？\
   \
<没有问题，我这里有上好的美酒/@请喝酒>\
   \
<我不会喝酒……/@exit>\

[@请喝酒]
#if
HAVHERO
#say
你精力有限,只能带领一位英雄在玛法大陆历练。\
如果你想再带领一位英雄,可以先将身边的英雄安顿在我们这里\
#elsesay
好！好！快拿酒来，让小二倒进六个坛中。\
每个坛里的酒有多有少，喝多喝少就看运气。\
我们就来拿这六坛酒来斗一斗！\ \
<好的，来吧/@斗酒规则>\

[@斗酒规则]
#if
#act
Mov M0 1
#say
<斗酒规则提示>：双方猜拳胜者，将有权选择桌面上的一坛酒，\
让双方的任一个人饮下，并会根据其酒精浓度，在酒量槽中相应显示。\
在桌面上的全部饮完后，\
且在双方均未喝醉（不超过酒槽内红线）的情况下，\
如果玩家酒槽内酒值不超过NPC酒值，便可赢得斗酒。\
<操作提示>：在选择出拳型后，点击出拳按钮，\
双方将出猜拳胜负，如果赢了，\
请单击桌面上的任一坛酒，并指定双方任一人喝下。\
<我明白了,摆酒吧/@PlayDrink>\

[@PlayDrink]
请把酒放上去

[~PlayDrink_Game]
#if
#act
OPENPLAYDRINK 2 晨星 DRINK
PLAYDRINKMSG 1 <$USERNAME>，酒之道也可以算作我修行的一部\分，让我看看你的表现吧。
PLAYDRINKMSG 2 嘿嘿……我可不会比你先醉倒，保管陪\你喝爽了！

[~PlayDrink_Self_Loss]
#if
#act
PLAYDRINKMSG 1 这点酒量，我怎么放心让我的弟子\跟随你啊！
PLAYDRINKMSG 2 惭愧惭愧，我一定努力!\<招幕英雄/@CrHero>

[~PlayDrink_SelfToNpc]
#if
#act
PLAYDRINKMSG 1 好！
PLAYDRINKMSG 2 就这坛了！请前辈来喝!

[~PlayDrink_SelfToSelf]
#if
#act
PLAYDRINKMSG 1 ……
PLAYDRINKMSG 2 就这坛了！我自己喝！

[~PlayDrink_NpcToSelf]
#if
#act
PLAYDRINKMSG 1 就这坛了！你来喝吧！
PLAYDRINKMSG 2 谢谢前辈！

[~PlayDrink_NpcToNpc]
#if
#act
PLAYDRINKMSG 1 就这坛了！我来喝！
PLAYDRINKMSG 2 前辈尽管喝！

[~PlayDrink_Dogfall]
#if
#act
PLAYDRINKMSG 1 那再来一局吧。
PLAYDRINKMSG 2 来就来！

[~PlayDrink_NpcWil]
#if
#act
PLAYDRINKMSG 1 嗯，不错，那我选了。
PLAYDRINKMSG 2 真倒霉，我就不信赢不了你。

[~PlayDrink_PlayWil]
#if
#act
PLAYDRINKMSG 1 <$USERNAME>，你选吧。
PLAYDRINKMSG 2 哈哈哈，还是我厉害吧~\选哪一坛好呢？

[~PlayDrink_Self_Drunk]
#if
#act
PLAYDRINKMSG 1 看你这么努力，英雄我就交给你了\！
PLAYDRINKMSG 2 惭愧惭愧，我一定努力!\<招幕英雄/@CrHero>

[~PlayDrink_Npc_Drunk]
#if
#act
PLAYDRINKMSG 1 呃,看来令天我是有点喝多了……！
PLAYDRINKMSG 2 啊……前辈,您别醉呀……\<招幕英雄/@CrHero>

[@CloseDrink]
#if
#act
CLOSEDRINK

[~PlayDrink_Npc_Loss]
#if
equal M0 1
#act
PLAYDRINKMSG 1 好久没有这种感觉了,酒意可谓"点到\即止",看来你也深明其理啦.！
PLAYDRINKMSG 2 呵呵,这次陪前辈喝酒,前辈已经喝得\尽兴,不知可否帮我个忙?\<招幕英雄/@CrHero>!
#elseact
PLAYDRINKMSG 1 好久没有这种感觉了,酒意可谓"点到\即止",看来你也深明其理啦.！
PLAYDRINKMSG 2 呵呵,这次陪前辈喝酒,前辈已经喝得\尽兴,不知可否帮我个忙?\<删除英雄/@DelMyHero>!

[@CrHero]
#if
#act
CLOSEDRINK
#say
恩……好酒啊，既然你请我喝酒了。\
请先给您的卧龙英雄取个名字吧。\
<英雄起名/@@buHero>\

[@@buHero]
你要带一个男法师还是法师士卧龙英雄呢？\
<卧龙男法师英雄/@CREATEHERO_TAOS_MAN>\
<卧龙女法师英雄/@CREATEHERO_TAOS_WOM>\
\

[@CREATEHERO_TAOS_MAN]
#ACT
CREATEHERO 1 0 TRUE
[@CREATEHERO_TAOS_WOM]
#ACT
CREATEHERO 1 1 TRUE
//返回消息

[@HAVHERO]
您已经有英雄了。\ \
<噢，也许是我记错了/@exit>

[@SetHeroName]
请先给您的卧龙英雄取个名字吧。\ \
<关闭/@exit>

[@寄放英雄]
<$USERNAME>，休息一下吧。不要忽视声明中的美好。\
如同杯中的美酒一般，一起喝吗？\
   \
<没有问题，我这里有上好的美酒/@Drink>\
   \
<我不会喝酒……/@exit>\

[@Drink]
#if
#act
OPENPLAYDRINK 2 辰星
PLAYDRINKMSG 1 酒意需要品味，生命的动人之处常会在不经意\之间显现。我们在小酌中慢慢体会\吧。
PLAYDRINKMSG 2 小提示：请将包裹栏中的酒放至酒碟上。

[~PlayDrink_Ok]
#if
#act
PLAYDRINKMSG 1 天道自然，在自然之中追寻平衡本百易事，但\这酒令我有了一些顿悟。\<寄放英雄/@SaveHero>

[@SaveHero]
#if
#act
SAVEHERO

[@NoSaveHero2]
还是不要寄放了吧，让你的主将英雄同你一起战斗吧......

[@NoSaveHero3]
还是不要寄放了吧，让你的副将英雄同你一起战斗吧......

[~PlayDrink_HeroOk]
#if
#act
CLOSEDRINK

[~PlayDrink_NotHero]
#if
#act
CLOSEDRINK
PLAYDRINKMSG 1 你没喝多吧？你身边空无一人，还说要把英雄\托付我？\

[~PlayDrink_HeroBegin]
#if
#act
PLAYDRINKMSG 1 你你没喝多吧？你身边空无一人，还说要把英雄\托付我？\<重新寄放英雄/@SaveHero>

[@不带英雄]
你想把你的伙伴送回卧龙山庄？\
你要知道，修行结束回到卧龙山庄的子弟,\
不可能再次像现在这样随你一同探索玛法大陆了。\
你真的想这样么？你要是决定了，我们就来斗上一盘酒!\
待我喝好了，我就帮你的伙伴送回山庄。\
<是的，拜托你了/@是的> \
   \
<我还想与我的伙伴一起继续战斗/@exit>\

[@是的]
好！好！快拿酒来，让小二倒进六个酒坛中。\
没个酒坛中的酒有多有少，喝多喝少就看运气了。\
我们就拿这六个酒坛中的酒来斗一斗！\ \
<好的，来吧/@DJSM>\

[@DJSM]
#if
#act
Mov M0 2
#say
<斗酒规则提示>：双方猜拳胜者，将有权选择桌面上的一坛酒，\
让双方的任一个人饮下，并会根据其酒精浓度，在酒量槽中相应显示。\
在桌面上的全部饮完后，\
且在双方均未喝醉（不超过酒槽内红线）的情况下，\
如果玩家酒槽内酒值不超过NPC酒值，便可赢得斗酒。\
<操作提示>：在选择出拳型后，点击出拳按钮，\
双方将出猜拳胜负，如果赢了，\
请单击桌面上的任一坛酒，并指定双方任一人喝下。\
<我明白了/@PlayDrink>\

[@DelMyHero]
#ACT
DELETEHERO
[@NotHAVHERO]
你没有英雄。\ \
<噢，也许是我记错了/@exit>
[@LogOutHeroFirst]
请将英雄设置下线！在来找我吧！\
     \
<好的/@exit>
[@NotDelHero]
评定主副将英雄后，不能进行删除英雄！\
     \
<好的/@exit>

[@DeleteHeroOK]
既然你请我喝酒了，那我就答应你的要求。\
我会尽快把你的英雄送回山庄的\\
<那谢谢你了/@exit>

[@英雄历史]
玛法大陆上有两个重要的势力，白日门和卧龙山庄。\
在这两个地方，勇士们都能够召唤到英雄来协助自已。\
每一个势力最多只能领取一个英雄。一直以来，勇士们只能率领一\
名英雄征战玛法。另一名的英雄被寄存在酒馆外的翔天等人处。\
勇士们通过苍月岛仓库里的神秘人找到英雄地的长老，在他那里召\
唤<白日门英雄/fcolor=249>，通过酒馆外的翔天等人处召唤<卧龙英雄/fcolor=249>。\
现在，当你同时拥有两个英雄后，可以在酒馆外的翔天等人接受\
<新的英雄培养/fcolor=249>。新英雄时代即将来临！\
<返回/@主副英雄培养>

[@英雄指南]
《主将副将英雄指南》\ \
1、<如何将卧龙英雄、白日门英雄评定为主将英雄、副将英雄？/@如何评定>\
2、<主将、副将英雄有何特色？/@有何特色>\
3、<副将英雄的操作与训练。/@如何操作>\
4、<什么时候是复仇模式?/@复仇模式>\ \
<返回/@主副英雄培养>

[@如何评定]
必须首先拥有白日门英雄和卧龙英雄，才能够对其进行评定，成为\
主将英雄和副将英雄。白日门英雄可以通过苍月岛的仓库内神秘人获\
得。卧龙英雄，可以通过酒馆外的翔天等人处召唤。拥有两名英雄名，\
将其寄放在酒馆外的翔天等人处，即可使其参与英雄评定，\
从而决定主将英雄和副将英雄的人选。\
<请注意：一旦评定成功，将不可更改，且英雄无法删除！/fcolor=249>\ \
<我知道了/@英雄指南>

[@有何特色]
一旦成功评定主将英雄和副将英雄，两个英雄将可轮流召唤出战。\
主将英雄的实力决定了副将英雄成长的空间。只有当主将英雄的等级、\
内功等级比副将英雄高3级，副将英雄才能分别获得经验、内功经验。\
副将英雄可以战、法、道的不同形态出战。主将英雄累积的经验、\
内功经验等，在召唤出副将英雄时，能够直接向副将英雄传功。\ \
<我知道了/@英雄指南>

[@如何操作]
在英雄包裹按键右侧新增副将英雄的召唤按钮，也可在F12辅助\
工具中，设置召唤的快捷键。成功评定出主将英雄和副将英雄后，\
必须在酒馆外的翔天等人处参与副将英雄的初次训练后，\
才能开始副将英雄的自我修炼。初次训练过程中获得的经验奖励\
与副将英雄的等级相关，等级越高，获得的经验奖励越多。\
副将英雄的自我修炼可根据不同的修炼地图和强度，选择适合的\
修炼方式 。小退或下线将不计入修炼时间。\ \
<我知道了/@英雄指南>

[@复仇模式]
当主将英雄死亡时，开始1分钟复仇倒计时。在倒计时时间内，\
成功召唤出副将英雄，则副将英雄进入到复仇状态，\
其基础属性将获得大幅提升，提升效果持续3分钟。\ \
<我知道了/@英雄指南>

[@HeroNameFilter]
创建英雄失败，名字中包含禁止字符或长度超过14位字符……\ \

<关闭/@exit>


[@main]
这里是比奇城堡宫殿.我是管理各种事情的国王.你有什么事情吗？\
请注意:您在填写行会名称时一定要慎重。如果包含不健康、\
有悖于社会精神文明的字眼，我们可以在不通知的情况下\
做删除处理。我们愿与您共建网络文明，谢谢您的配合！\
<请求创建行会./@@buildguildnow>\
<申请行会战争./@guildwar>\
<如何建立行会./@buildguildexp>\
<有关行会战争./@guildwarexp>\
<申请攻城战争./@requestcastlewar>\

[@buildguildexp]
建立行会你应该证明你有资格。必须支付100万金币作为基础\
而且要取得位于沃玛寺庙底部深处的沃玛教主所拥有的号角!\ \
<返回/@main>

[@guildwar]
填写与你交战的敌对行会的名字，申请行会战争必须支付3万金币\ \
<立即申请行会战争/@@guildwar>\
<返回/@main>\

[@guildwarexp]
<行会战/@guildwar2>是一种合法的战争，因为目前有许多行会和\
玩家都同意，这是<合法的/@warrule>的行会间战争。\
你是否<请求/@guildwar>行会战争?战争将进行3小时,\你必须支付<$GUILDWARFEE>所规定的申请费用.\ \
<返回/@main>

[@guildwar2]
当你请求行会战争的时候,相同行会成员的名字将会出现在蓝色的。\
在另一方面,敌人的行会成员名字将会变成橘色的.开战中的行会\
成员在此期间登录,信息窗口会有[××在与你行会进行行会战]\
的信息出现，在这个时候，如果你杀敌了人的行会某一个成员,\
系统对你的行为将不会被视为 PK 。 \ \
<返回/@guildwarexp>

[@warrule]
行会战争在城市中不能发生,它在城市某范围外或内部竞赛区\
域(一些建筑物之内)被启动.否则你 PK 你的身份将会是红色\
的!甚至在战争期间。\ \
<返回/@guildwarexp>

[@requestcastlewar]
请求对沙巴克作战你应该有祖玛教主的头像,你有它吗?战争将会在\
申请日期的第 三 天内开始。\ \
<给祖玛头像/@requestcastlewarnow>\
<返回./@main>\

[~@request_ok]
你的请求被许可, <$CASTLEWARDATE> 战争将会发生在这个值得回忆\
的日子...剩下的时间不多了，祝你好运!\ \
<关闭./@exit>\

[@@donate]
已经记下了你提出的建议，请等待管理员回复，谢谢.\
<关闭./@exit>\

[@GuildNameFilter]
#if
#act
sendmsg 7 行会创建失败！名称中包含系统禁用字符！！
break

; @GuildNameFilter 为创建行会失败触发，如果引擎设置了禁止创建行会字符限制，建议加上此脚本....


创建主将英雄脚本

;@@CreateHero 是创建和删除主将英雄的标志

;@HeroNameFilter 当创建英雄输入名称中有禁止字符或者名称超过14个字符触发此脚本

(@@CreateHero)

[@main]
体验真正的英雄:<[创建英雄]/@@CreateHero> 千万不要乱点哈:<[删除英雄]/@删除英雄>\
英雄也需要学习技能的嘛，选择英雄职业领取英雄的技能书籍:\
<[战士英雄技能书]/@mirhhyxjn01> <[法师英雄技能书]/@mirhhyxjn02> <[道士英雄技能书]/@mirhhyxjn03>\
合击书籍也需要技能书的哦，请选择你人物的职业以及英雄的职业:\
战士+战士合击:<[破 魂 斩]/@hj1> 道士+道士合击:<[噬魂沼泽]/@hj2>\
法师+法师合击:<[火龙气焰]/@hj3> 战士+法师合击:<[雷霆一击]/@hj4>\
道士+法师合击:<[末日审判]/@hj5> 战士+道士合击:<[劈星斩]/@hj6>\ \
合击的必备物品:<[火龙之心]/@hj7> <[练习内功]/@READSKILLNG> \

[@READSKILLNG]
#if
#ACT
READSKILLNG
SENDMSG 6 恭喜您领练习内功！！

[@hj7]
#if
#ACT
SENDMSG 6 恭喜您领取合击必备物品火龙之心成功！！
give 火龙之心 1

[@hj1]
#if
#ACT
SENDMSG 6 恭喜您领取战士+战士英雄合击[破魂斩]成功！！
give 破魂斩 1

[@hj2]
#if
#ACT
SENDMSG 6 恭喜您领取道士+道士英雄合击[噬魂沼泽]成功！！
give 噬魂沼泽 1

[@hj3]
#if
#ACT
SENDMSG 6 恭喜您领取法师+法师英雄合击[火龙气焰]成功！！
give 火龙气焰 1

[@hj4]
#if
#ACT
SENDMSG 6 恭喜您领取战士+法师英雄合击[雷霆一击]成功！！
give 雷霆一击 1

[@hj5]
#if
#ACT
SENDMSG 6 恭喜您领取道士+法师英雄合击[末日审判]成功！！
give 末日审判 1

[@hj6]
#iF
#ACT
SENDMSG 6 恭喜您领取战士+道士英雄合击[劈星斩]成功！！
give 劈星斩 1

[@mirhhyxjn01]
#if
CheckHaveHero
#act
#ELSEACT
MESSAGEBOX 对不起，您没有英雄！
BREAK
#if
CHECKHEROONLINE
#act
#ELSEACT
MESSAGEBOX 对不起，您的英雄不在线！
BREAK
#if
CHECKHEROJOB WARRIOR
#act
H.ADDSKILL 英雄基本剑术 3
H.ADDSKILL 英雄攻杀剑术 3
H.ADDSKILL 英雄刺杀剑术 3
H.ADDSKILL 英雄半月弯刀 3
H.ADDSKILL 英雄野蛮冲撞 3
H.ADDSKILL 英雄烈火剑法 3
H.ADDSKILL 英雄狮子吼 3
break
#Elsesay
你英雄职业不为战士

[@mirhhyxjn02]
#if
CheckHaveHero
#act
#ELSEACT
MESSAGEBOX 对不起，您没有英雄！
BREAK
#if
CHECKHEROONLINE
#act
#ELSEACT
MESSAGEBOX 对不起，您的英雄不在线！
BREAK
#if
CHECKHEROJOB WIZARD
#act
H.ADDSKILL 英雄火球术 3
H.ADDSKILL 英雄大火球 3
H.ADDSKILL 英雄地狱火 3
H.ADDSKILL 英雄诱惑之光 3
H.ADDSKILL 英雄瞬息移动 3
H.ADDSKILL 英雄爆裂火焰 3
H.ADDSKILL 英雄抗拒火环 3
H.ADDSKILL 英雄疾光电影 3
H.ADDSKILL 英雄雷电术 3
H.ADDSKILL 英雄火墙 3
H.ADDSKILL 英雄地狱雷光 3
H.ADDSKILL 英雄魔法盾 3
H.ADDSKILL 英雄冰咆哮 3
H.ADDSKILL 英雄灭天火 3
H.ADDSKILL 英雄寒冰掌 3
H.ADDSKILL 英雄火龙烈炎 3
H.ADDSKILL 英雄圣言术 3
H.ADDSKILL 英雄群雷术 3
H.ADDSKILL 英雄流星火雨 3
break
#Elsesay
你英雄职业不为法师

[@mirhhyxjn03]
#if
CheckHaveHero
#act
#ELSEACT
MESSAGEBOX 对不起，您没有英雄！
BREAK
#if
CHECKHEROONLINE
#act
#ELSEACT
MESSAGEBOX 对不起，您的英雄不在线！
BREAK
#if
CHECKHEROJOB taoist
#act
H.ADDSKILL 英雄治愈术 3
H.ADDSKILL 英雄精神战法 3
H.ADDSKILL 英雄施毒术 3
H.ADDSKILL 英雄召唤骷髅
H.ADDSKILL 英雄隐身术 3
H.ADDSKILL 英雄集体隐身
H.ADDSKILL 英雄神圣战甲 3
H.ADDSKILL 英雄幽灵盾 3
H.ADDSKILL 英雄困魔咒
H.ADDSKILL 英雄心灵启示
H.ADDSKILL 英雄群体治疗
H.ADDSKILL 英雄解毒术
H.ADDSKILL 英雄群毒术
H.ADDSKILL 英雄召唤神兽 3
H.ADDSKILL 英雄灵魂火符 3
H.ADDSKILL 英雄无极真气 3
H.ADDSKILL 英雄气功波 3
break
#Elsesay
你英雄职业不为道士

[@CreateHero]
#if
CheckHaveHero
#ACT
#SAy
你已经领取了英雄!!\ \
<返回/@main>
#Elsesay

选择需要的英雄职业性别.\<选取后终身将不能变更/FCOLOR=253> <返回/@main>\ \
<男英雄战士/@CREATEHERO_WARR_MAN> <女英雄战士/@CREATEHERO_WARR_WOM>\ \
<男英雄法师/@CREATEHERO_WIZA_MAN> <女英雄法师/@CREATEHERO_WIZA_WOM>\ \
<男英雄道士/@CREATEHERO_TAOS_MAN> <女英雄道士/@CREATEHERO_TAOS_WOM>\ \
<关闭/@exit>

[@CREATEHERO_WARR_MAN]
#Act
CREATEHERO 0 0
Goto @CreateingHero
[@CREATEHERO_WARR_WOM]
#Act
CREATEHERO 0 1
Goto @CreateingHero
[@CREATEHERO_WIZA_MAN]
#Act
CREATEHERO 1 0
Goto @CreateingHero
[@CREATEHERO_WIZA_WOM]
#Act
CREATEHERO 1 1
Goto @CreateingHero
[@CREATEHERO_TAOS_MAN]
#Act
CREATEHERO 2 0
Goto @CreateingHero
[@CREATEHERO_TAOS_WOM]
#Act
CREATEHERO 2 1
Goto @CreateingHero

;//返回消息
[@HeroNameFilter]
创建英雄失败，名字中包含禁止字符或长度超过14位字符……\\<关闭/@exit>

[@CreateingHero]
系统正在接受申请，请稍候……\
<关闭/@exit>

[@HaveHero]
您已经有英雄了。\
<关闭/@exit>

[@SetHeroName]
请先给您的英雄取名字。\
<关闭/@exit>

[@删除英雄]
是否确认删除英雄\
<是，我确认删除英雄/@DelMyHero> <我考虑下/@exit>

[@DelMyHero]
#ACT
DELETEHERO
;//返回消息

[@NotHaveHero]
你没有英雄。\\<关闭/@exit>

[@LogOutHeroFirst]
请将英雄设置下线！<关闭/@exit>

;---------------------------------------------------------------------

;请将以下放入X:\MirServer\Mir200\Envir\Market_Def\QFunction-0.txt内

[@CreateHeroOK]
创建英雄成功\<关闭/@exit>

[@HeroNameExists]
英雄名称已被使用\<关闭/@exit>

[@CreateHeroFail]
创建英雄失败\<关闭/@exit>

[@DeleteHeroFail]
删除英雄失败\<关闭/@exit>

[@DeleteHeroOK]
删除英雄成功\<关闭/@exit>

[@HeroNameFilter]
该名字存在非法字符！\ \
<关闭/@exit>\

[@HeroNameExists]
该名字已经被其他玩家占用，请选择其他名字\ \
<关闭/@exit>\


达到多少人在线不允许离线挂机脚本

[@离线挂机]
{
#IF
checklevelex < 35
#act
MessageBox 等级35级以上才能使用离线挂机功能!
break

#if
ISONMAP 0
#act
goto @HumanCount0
break

#if
ISONMAP 3
#act
goto @HumanCount3
break

#if
ISONMAP 5
#act
goto @HumanCount5
break

#elseact
MessageBox 此地图无法使用离线挂机功能!
break

[@HumanCount0]
#IF
checkhum 0 300
#act
MessageBox 此地图挂机人数已满，请选择其他地图挂机!
break
#elseact
goto @开始离线挂机

[@HumanCount3]
#IF
checkhum 3 300
#act
MessageBox 此地图挂机人数已满，请选择其他地图挂机!
break
#elseact
goto @开始离线挂机

[@HumanCount5]
#IF
checkhum 5 300
#act
MessageBox 此地图挂机人数已满，请选择其他地图挂机!
break
#elseact
goto @开始离线挂机

[@开始离线挂机]
目前您只需要花费30万金币即可享受挂机涨经验,泡点的服务\
点击下面的挂机功能后即可回家睡觉了,人物自动挂在安全区泡\
经验.能量及泡红名,还可设置自动回复信息,给好友留言！ \
<注意:>在游戏中输入指令[@挂机].同样可以享受挂机服务!\
原则上本区不发展挂机，不希望活死人现象，开区一定成形后\
将逐渐销减离线挂机成分，努力做到让大家聊天有个伴，PK有对象！\
<我要挂机/@@offlinemsg>　<--点击后输入留言给好友留言.>\ \
<关闭/@exit>

[@@offlinemsg]
#if
checkgold 300000
#act
take 金币 300000
OFFLINE 60 2000
#elseACT
MessageBox 对不起您的金币不够30万，无法启用离线挂机功能!
break

}


打开个人店铺（摆摊）

功能：
打开个人店铺（摆摊）脚本命令

格式：

[@打开店铺]
#IF
#ACT
OpenGameShopDlg


大退游戏命令

 [@main]
<退出游戏/@ExitGame>\
<关闭/@exit>

[@ExitGame]
#IF
#ACT
ExitGame

ExitGame，客户端大退 （支持多级，但多级目标只能是玩家）


当前目标变量取值操作[!]

功能: 当前目标变量取值操作C. （C.变量必须目标不为空且对象为人物）

当前目标变量取值操作C. （C.变量必须目标不为空且对象为人物）
当前对象的所有私人的常量都可以使用在前面加“C.”的方式
当前对象的所有私人的变量使用<$C.STR(S1)>和查看自己的变量<$STR(S1)>多一个“C.”
比如在攻击触发，被攻击触发，死亡触发，还有查看出售角色的其他信息的触发时
当前对象的常量，例如：<$C.HP> <$C.PKPOINT> <$C.GOLDCOUNT> <$C.GAMEGOLD>
当前对象的变量，例如：<$C.STR(S1)> <$C.STR(A1)> <$C.STR(T1)> <$C.STR(U1)> <$C.HUMAN(QQQQ)> <$C.GUILD(WWWW)>

;SetCurrTarget 名称 (名称空的情况下表示清空当前对象;设置指定人物为当前对象，要求和执行脚本的玩家在同一地图且坐标在20格以内)
;使用命令 ： SetCurrTarget设置当前对象

简易示例：
#IF
CHECKCURRTARGETRACE = 0
#ACT
;使用MOV命令调整当前对象的变量 ---MOV对象变量只可读不可写，所以不支持！！！！
;MOV <$C.STR(S1)> <$STR(S1)>
;SENDMSG 6 把我的S1变量值传递给当前对象的S1变量里，MOV不支持这样操作，可用SetHumVar变量传递进行修改,如下
SetHumVar <$C.USERNAME> S1 S2
SENDMSG 6 把我的S2变量值传递给当前对象的S1变量里

#IF
CHECKCURRTARGETRACE = 0
#ACT
;使用MOV命令将自己的变量改为当前对象的变量
MOV <$STR(N1)> <$C.STR(N1)>
SENDMSG 6 把对方的的N1变量值传递给我的的N1变量里，使用“C.STR”代表当前对象的变量比自己的“STR”前面多一个“C.”

;查看他人装备触发：
[@QueryUserState]
#ACT
MOV S1 <$UserStateName>
;SetCurrTarget 名称 (名称空的情况下表示清空当前对象;设置指定人物为当前对象，要求和执行脚本的玩家在同一地图且坐标在20格以内)
;使用SetCurrTarget设置当前对象
SetCurrTarget S1

#IF
CompareText <$C.USERNAME> S1
;检测设置的对象是否成功
#say
当前对象名称：\
【<$C.USERNAME> 】等级=【<$C.LEVEL> 】攻击=【<$C.DC> - <$C.MAXDC> 】PK值=【<$C.PKPOINT> 】\
#ELSESAY
对象获取失败。


动态地图连接[!]

增加动态地图连接命令
ADDMAPGATE 连接名称(为了区别其他连接) 地图号 X(小于0时随机坐标) Y(小于0时随机坐标) 范围 到达地图号 到达地图坐标X(小于0时随机坐标) 到达地图坐标Y(小于0时随机坐标) 有效时间秒(时间到了自动删除该连接,该参数为空时不限时间)

删除动态地图连接命令
DELMAPGATE 连接名称 地图号

获取动态地图连接坐标
GETMAPGATE 连接名称 地图号 变量1(保存X坐标) 变量2(保存Y坐标) 变量3(保存到达地图号) 变量4(保存到达地X坐标) 变量5((保存到达地Y坐标))

[@AddMapGate]
#ACT
AddMapGate 连接 3 335 330 1 0 335 268 30
GetMapGate 连接 3 <$STR(G10)> <$STR(G11)> <$STR(S10)> <$STR(G12)> <$STR(G13)>
SENDMSG 6 增加地图新连接30秒后删除:[<$STR(G10)>:<$STR(G11)>]到达地图:<$STR(S10)>到达坐标[<$STR(G12)>:<$STR(G13)>]

[@DelMapGate]
#ACT
DelMapGate 连接 3

===================================================================================================================================

脚本命令添加动态地图链接

格式：

[@main]
<增加地图连接1/@main1>\

[@main1]
#if
#ACT
;连接名称为了区别其他的可以随便 地图名称 地图坐标X 地图坐标Y 入口范围 到达地图名称 到达地图坐标X 到达地图坐标Y 链接点有效时间（秒） 传送门样式(1--5,0或空为无传送门)
ADDMAPGATE 盟重省到比奇城 3 330 330 0 0 346 186 100 1

[@DelMapGate]
#ACT
DelMapGate 盟重省到比奇城


发送聊天框固顶信息

SENDTOPCHATBOARDMSG 发送模式(0发送给所有人,1发送给自己) 字体颜色 背景颜色 时间(秒) 信息

[@Main]
SENDTOPCHATBOARDMSG 0 149 235 30 %s:聊天框固顶信息


复活触发[!]

功能：
复活时触发.

说明：QFunction-0.txt脚本触发

示列：
复活剩余时间变量：<$RevivalTime>

[@Revival]
#IF
#ACT
Sendmsg 6 剩余复活时间 <$RevivalTime>
SendMsg 5 你复活了！

[@H.Revival]
#IF
#ACT
SendMsg 5 你的英雄复活了！


副本地图相关参数

功能：
副本地图

格式：

命令参数：

MapInfo.txt中地图参数增加 FB(40,祖玛副本,0,1) 创建40个祖玛副本地图 第3个参数：0:限制队友必须有三职业; 1:不限制职业，队友都可进; 2:只允许自己进入; 3:允许行会进入
第4个参数：副本创建1分钟后(未收回时)，允许延时进入副本时间(分)系统默认时间为1分钟.此参数为在1分钟时间基础上延长多少分,第5个参数为当退出副本地图，没人时候系统删除该副本时间，留空默认10秒

FB(40,祖玛副本,0,1,50) 50 意思是玩家创建副本后，进入后又退出地图，50秒内没人则回收副本地图！

==================================================================
CANMOVEECTYPE 此命令为检测是否已经创建副本 格式：CANMOVEECTYPE 副本名称
CREATEECTYPE 此命令为创建副本，格式：CREATEECTYPE 副本名称 有效时间
====================================================

示列脚本：
[@main]
<创建副本地图/@gon1> <传送到副本地图/@gon12>\
<创建镜像副本/@gon111> <传送到镜像副本/@gon112>\

[@gon1]
#IF
CANMOVEECTYPE 白日门副本
#ACT
SENDMSG 5 你已创建了一个白日门副本，不能重复创建....
#ELSEAct
;----------------------↓---此处的5为副本有效时间
CREATEECTYPE 白日门副本 5

[@gon111]
#IF
CANMOVEECTYPE 镜像副本
#ACT
SENDMSG 5 你已创建了一个镜像副本，不能重复创建....
#ELSEAct
CREATEECTYPE 镜像副本 3

[@gon12]
#IF
#ACT
MOVEECTYPE 白日门副本 38 42

[@gon112]
#IF
#ACT
MOVEECTYPE 镜像副本 331 270

[@CreateEctype_NoExists]
#IF
#ACT
MESSAGEBOX 创建副本地图失败，副本不存在！

[@CreateEctype_Fail]
#IF
#ACT
MESSAGEBOX 创建副本失败，副本人数已满，请稍候再试！

[@CreateEctype_Fail_GroupMaster]
#IF
#ACT
MESSAGEBOX 创建副本失败，必须组队队长才能创建！

[@CreateEctype_Fail_GuildMaster]
#IF
#ACT
MESSAGEBOX 创建副本失败，必须行会掌门才能创建！

[@CreateEctype_IN]
#IF
;此为如掌门或队长创建副本后,队友 行会成员创建时提示....
#ACT
SENDMSG 5 副本地图已经创建完成，可以直接进入了。

[@CreateEctype_IN_Time]
#IF
#ACT
;此为如掌门或队长创建副本后，成员或队友继续创建提示..
SENDMSG 5 副本已经存在..无法创建。

[@CreateEctype_OK]
#IF
#ACT
;副本创建成功提示..创建成功后默认已经初始化地图怪物和时间..
SENDMSG 5 副本地图创建成功，并初始化地图怪物成功
SENDMSG 5 副本地图创建成功，并初始化地图事件成功。

[@MoveEctype_Fail_Time]
#IF
#ACT
;当传送到副本地图超出设置时间给予提示........
SENDMSG 5 传到副本地图失败，超过可传送时间

[@MoveEctype_Fail]
#IF
#ACT
;当没有创建副本或者没有相关副本（组队，行会副本，坐标错误）进入时给予提示........
SENDMSG 5 传到副本地图失败

[@MoveEctype_OK]
#IF
#ACT
;成功进入副本地图给予提示......
SENDMSG 5 已传送到副本地图

;==============npc=====================================
;MerChant.txt 增加以下（和增加普通NPC一样增加）
副本地图 $g005副本 30 40 副本地图 0 12 0 0 0

Market_Def内脚本文件名不需要$如：副本地图-g005副本.txt

;======================================================
组队传送：
副本组队传NPC命令 MoveGroupEctype 副本地图名 X Y
;======================================================

副本地图的名称（NPCMAP = 取NPC所在地图， SELF = 取人物当前所在地图， FBMAP = 取人物所在和创建的副本地图)
[@祖玛副本_触发刷怪]
#ACT
;MobEctypeMon 副本名称 X坐标 Y坐标 怪物名称 数量 范围 名称颜色
MobEctypeMon SELF 94 72 祖玛雕像 1 5 --------人物当前所在副本刷怪
MobEctypeMon FBMAP 94 72 祖玛雕像 1 5 --------人物创建的副本刷怪，可在创建成功触发刷怪
Break
;======================================================

通过刷怪文件MonGen.txt刷怪：;副本地图刷怪不会重复刷新..进入一次刷怪.退出副本清理怪(如G005地图允许生成副本50个，分别为$g005副本_1----$g005副本_50 只需要下面一个刷怪文件即可)
;--------------------------------------------------
;副本名字 X坐标 Y坐标 怪物名称 范围 数量
$g005副本 36 44 暗之双头血魔 25 10
$g005副本 36 44 暗之双头血魔 25 10
$g005副本 36 44 暗之虹魔教主 25 10
$g005副本 36 44 暗之双头金刚 25 10
$g005副本 36 44 暗之沃玛教主 25 10
;======================================================


改变人物状态脚本

功能：
改变人物状态.

说明：TestStatus 此命令可在M2自定义修改为你需要的命令

示列：
TestStatus 0 0 (参数0为状态类型、参加2为时间 0为清空所有颜色)
状态类型颜色： 1 红色 2 蓝色 3 黄色 4 紫色 5 麻痹 8 隐身 11 盾

[@main]
#IF
#ACT
Gmexecute TestStatus 5 1


会员系统详解

会员系统主要用来对一些加盟玩家的特殊控制。可以用IP地址，登录帐号，角色名，之类的为标志控制。

相关脚本命令

设置会员类型：SETMEMBERTYPE
设置会员等级： SETMEMBERLEVEL

检查会员类型：CHECKMEMBERTYPE
检查会员等级：CHECKMEMBERLEVEL

相关脚本会员物品

物品使用条件：8、81、82

增加会员时间 文件名称 天 时 分
[@main]
#ACT
ADDNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 30 2 3
#ACT
SENDMSG 6 增加30天2小时3分 255 253

检测会员剩余时间 文件名称 过期是否删除(0不删除 1删除) 变量1(到期时间 字符变量) 变量2(剩余天数 数字变量) 变量3(剩余小时 数字变量) 变量4(剩余分钟 数字变量)
[@main]
#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 S1 N1 N2 N3
#ACT
SENDMSG 6 你的会员到期时间是<$STR(S1)>【剩余天数=<$STR(N1)>】【剩余小时=<$STR(N2)>】【剩余分钟=<$STR(N3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253

删除会员还是使用原来的老命令DELNAMEDATELIST

[@main]
<输入需要充值的人物名称/@@InputString1>\ \ \
<关闭/@EXIT>\

[@InputString1]
#IF
;S1.CHECKONLINE
CheckOnline <$STR(S1)>
#ACT
ADDNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 30 2 3
SENDMSG 6 <$STR(S1)>充值成功，增加30天2小时3分！ 255 253
#ELSEACT
SENDMSG 6 <$STR(S1)>不在线！ 255 253

;----------------------------------------------------------------

以下命令支持绝对路径

ClearNameList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）
AddNameDateList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）
DelNameDateList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）


获取徒弟列表

GetMasterList 变量名

[@GetMasterList]
#if
#act
GetMasterList S1
#SAY
你当前的徒弟有<$STR(S1)>


获取徒弟数量

GetMasterCount 变量名

[@GetMasterCount]
#if
#act
GetMasterCount P1
#SAY
你当前的徒弟有<$STR(P1)>人


获取指定位置的物品数量

GetItemCount 位置(0:背包;1:装备; 2:首饰; 3:神佑; 4:普通仓库; 5:无限仓; 6:摆摊) 物品名称 变量

[@获取背包屠龙数量]
#act
GetItemCount 0 屠龙 N0
sendmsg 6 背包中屠龙的数量为<$STR(N0)>


获取组队成员数量(组队相关命令)

获取组队成员数量

GETGROUPCOUNT 变量名 范围(当范围为空或0时，获取所有队员数量，当范围>0时，获取队长指定范围内队员的数量）

[@GETGROUPCOUNT]
#if
CheckGroupLeader
#act
GETGROUPCOUNT P1
sendmsg 6 你当前组队的队友有<$STR(P1)>人
#elseact
sendmsg 6 你不是队长

[@GETGROUPCOUNT]
#if
CheckGroupLeader
#act
GETGROUPCOUNT P1 5
sendmsg 6 你5格范围内当前组队的队友有<$STR(P1)>人
#elseact
sendmsg 6 你不是队长

自动退出组队命令(个人通过脚本执行)

#act
exitGroup
SENDMSG 6 你已经主动离开了队伍

删除队友功能: （只有队长才能用此命令,才会生效 ）

#if
CheckGroupLeader
#act
DELETEGROUPMENBER 成员名
SENDMSG 6 你被队长踢出了队伍！
#elseact
sendmsg 6 你不是队长


机器人脚本

功能：
系统机器人，可以定时做一些指定操作
相关配置目录:
\Envir\Robot_def\

相关文件:
\Envir\Robot.txt 机器人配置文件
\Envir\Robot_def\RobotManage.txt 机器人运行脚本文件

机器人配置文件格式:
;Robot.txt
;机器人名称 脚本名称
系统控制 AutoRunRobot

脚本格式:
;AutoRunRobot.txt
#AutoRun NPC SEC 10 @SendRedMsg
SEC：按秒运行
MIN：按分运行
HOUR：按小时运行
DAY：按天运行
RUNONWEEK：按星期几及时间运行
#AutoRun NPC RUNONWEEK 5:15:55 @SendRedMsg
星期五15点55分运行

实例：
Robot.txt内容：该文件在\Envir\下
;==========================
Test Test
;==========================

Test.txt内容：（每8秒钟运行脚本一次）该文件在\Envir\Robot_def\下
;==========================
#AutoRun NPC SEC 8 @DHB
;==========================

RobotManage.txt内容（内容即普通脚本内容）该文件在\Envir\Robot_def\下
;==========================
[@DHB]
#if
#act
SENDMSG 0 双头金刚怪物攻城了......
MISSION 3 330 330
PARAM1 360
PARAM2 340
PARAM3 10
PARAM4 1
MOBPLACE 双头金刚
;==========================

;====================================================2016-03-30扩展支持如下=========================================================

增加了关于国家参数设置

MISSION 3 330 330
PARAM1 360
PARAM2 340
PARAM3 10
PARAM4 5
PARAM5 国家
PARAM6 同国家名玩家是否可攻击(0,1)
PARAM7 不国家名怪物是否PK(0,1)
MOBPLACE 半兽勇士


记忆石设置方法[!]

功能演示：

物品分类号:31
SHAPE 值:1
AN字段是触发.这个根据自己版本设置.我们以设置为99为例子
QFunction-0.txt脚本下面

[@StdModeFunc99]
;#act
;关闭自定义NPC大对话框
;CloseBigDialogBox
;#say
一： <记录当前坐标/@TAGMAPINFO1> <移动到/@PMOVE1> -> <$TAGMAPNAME1> <$TAGX1> <$TAGY1>\
二： <记录当前坐标/@TAGMAPINFO2> <移动到/@PMOVE2> -> <$TAGMAPNAME2> <$TAGX2> <$TAGY2>\
三： <记录当前坐标/@TAGMAPINFO3> <移动到/@PMOVE3> -> <$TAGMAPNAME3> <$TAGX3> <$TAGY3>\
四： <记录当前坐标/@TAGMAPINFO4> <移动到/@PMOVE4> -> <$TAGMAPNAME4> <$TAGX4> <$TAGY4>\
五： <记录当前坐标/@TAGMAPINFO5> <移动到/@PMOVE5> -> <$TAGMAPNAME5> <$TAGX5> <$TAGY5>\
六： <记录当前坐标/@TAGMAPINFO6> <移动到/@PMOVE6> -> <$TAGMAPNAME6> <$TAGX6> <$TAGY6>\ \
<成功传送后才会消失一点.安全无毒.放心使用>\
[@PMOVE1]
#ACT
TAGMAPMOVE 1
[@PMOVE2]
#ACT
TAGMAPMOVE 2
[@PMOVE3]
#ACT
TAGMAPMOVE 3
[@PMOVE4]
#ACT
TAGMAPMOVE 4
[@PMOVE5]
#ACT
TAGMAPMOVE 5
[@PMOVE6]
#ACT
TAGMAPMOVE 6
[@TAGMAPINFO1]
#ACT
TAGMAPINFO 1
GOTO @StdModeFunc99
[@TAGMAPINFO2]
#ACT
TAGMAPINFO 2
GOTO @StdModeFunc99
[@TAGMAPINFO3]
#ACT
TAGMAPINFO 3
GOTO @StdModeFunc99
[@TAGMAPINFO4]
#ACT
TAGMAPINFO 4
GOTO @StdModeFunc99
[@TAGMAPINFO5]
#ACT
TAGMAPINFO 5
GOTO @StdModeFunc99
[@TAGMAPINFO6]
#ACT
TAGMAPINFO 6
GOTO @StdModeFunc99


技能栏升级强化技能[!]

功能：
技能栏升级强化技能.

格式：技能数据库 CanUpgrade字段设置0或留空则不显示升级按钮 ，设置1允许升级，设置2不允许升级（显示升级按钮） MaxupgradeLv字段为强化多少重后不再显示升级按钮

示列：
技能面板上点击"升级"按钮，结合Messagebox命令，可关联到QF内容中，如触发[@SkillLevelExX]段 X为技能ID编号

人物技能升级触发：QF中，[@SkillLevelExX]段 X为技能ID编号......英雄技能升级触发：QF中，[@HeroSkillLevelExX]段 X为技能ID编号

[@SkillLevelEx11]
#IF
CheckSkill 雷电术 > 8 1
#ACT
Sendmsg 7 强化雷电术已升至最高等级九级，无法继续升级！
#ELSEACT
MESSAGEBOX 是否确定使用10张书页，升级强化雷电术至下一等级？ @确定11 @取消
Break

[@确定11]
#IF
checkitem 书页 > 9
#ACT
SKILLLEVEL 雷电术 + 1 1
MESSAGEBOX 提示：恭喜您的雷电术又熟练提升了1级
break
#ELSEsay
你没有学习此技能或者没有10张书页，请您达到条件了再来吧！

注：以上为简单模式，仅供参考，也可以做的更精细点，如每次升级需要的材料数量分别设置；技能exp经验值升满才允许强化

 ===========================================================================================================
备注文件：SkillUpgradeDesc.Dat 位于客户端DATA目录，编写好集成到登陆器即可！
;技能类型(普通技能/内功技能),技能名,需要强化等级,强化描述
普通技能,攻杀剑术,1,111111111111
普通技能,攻杀剑术,2,222222222222
普通技能,攻杀剑术,3,333333333333333
普通技能,攻杀剑术,4,44444444444444444
普通技能,攻杀剑术,5,5555555555555555555555
普通技能,攻杀剑术,6,6666666666666666666666
普通技能,攻杀剑术,7,77777777777777777
普通技能,攻杀剑术,8,8888888888888888888
普通技能,攻杀剑术,9,升到9级要好多毛线的,你确定要升级????????
注：技能备注为技能等级后描述，换行使用,号换行


假人登录脚本实例

[@Login]
#IF
;检测是否是假人
ISDUMMY
#ACT
;从配置文件列表中随机获取一个配置文件
GETRANDOMLINETEXT ..\QuestDiary\智能陪练\假人配置文件列表.txt <$STR(S10)>

SETDUMMYCONFIGFILENAME <$STR(S10)>

LOADDUMMYCONFIGFILE

MOVR D0 6
ChangeAttatckMode <$STR(D0)>

;从配置文件列表中随机获取一个配置文件,给英雄使用
GETRANDOMLINETEXT ..\QuestDiary\智能陪练\假人英雄配置文件列表.txt <$STR(S11)>

;从假人列表或假人英雄列表中获取一个没有登录过的名称
GETDUMMYNAME <$STR(S11)> 1 1

;格式 SETDUMMYHERONAME 英雄名称
SETDUMMYHERONAME <$STR(S11)>

RECALLHERO

DUMMYSTART

[@HeroLogin]
#IF
;检测是否是假人英雄
H.ISDUMMY
#ACT
;<$STR(S11)> 是主人登录随机获取的一个配置文件
H.SETDUMMYCONFIGFILENAME <$STR(S11)>

H.LOADDUMMYCONFIGFILE


假人自动摆摊

============================================================================================================================

假人摆摊 写点大点省的看不到了

[@假人上线自动摆摊]
#IF
ISDUMMY
#ELSEACT
BREAK
;检测是否已经创建过个人商店
#IF
CHECKMYSHOP
#ACT
;停止挂机
DUMMYSTOP
;开始摆摊
SHOPSTALL
#ELSEACT
;如果没有个人商店开始用自己的名字做为商店的名字创建个人商店
CREATEMYSHOP <$USERNAME>
;停止挂机
DUMMYSTOP
;开始摆摊
SHOPSTALL


功能：
检查人物是否移动.可以制作任务或者封闭网站挂机人物

格式：
CHECKSTATIONTIME 控制符(<、>、 =) 分钟
;==========================================

示例一：
#IF
CHECKSTATIONTIME > 50
#SAY
你已经有50分钟没有移动了，系统将你踢下线！
#ACT
KICK

示例二
#IF
CHECKSTATIONTIME > 50
#SAY
你已经有50分钟没有移动了，系统将在5秒后将你小退游戏！
#ACT
DelayCall 5000 @Kick

[@Kick]
#IF
#ACT
Kick 1


检查人物的职业 [!]

功能：
检查人物的职业

格式：

#IF
CheckJob Warrior
#SAY
你是武士.

#IF
CheckJob Taoist
#SAY
你是道士.

#IF
CheckJob Wizard
#SAY
你是魔法师.


脚本初始化

格式：
    [@Startup]

说明：
登陆脚本QManage.txt与所有NPC脚本里都可以添加
当M2启动后[@Startup]下的脚本会自动加载一次，而且只加载一次。
适用于全局变量读取。

示例：
[@Startup]
#IF
#ACT
INC G35 20


脚本发送屏幕震动[!]

功能：
脚本发送屏幕震动[脚本命令：SCENESHAKE 0-4[0自己，1所有地图，2屏幕范围内，3.当前地图 4.指定地图 地图ID] 次数（留空默认1次） 是否受内挂选项“屏幕震动”选项控制(1为受控，空为不受)

格式：

[@main]
<自己震动0/@SceneShake> \
<所以地图震动1/@SceneShake1> \
<可视范围震动2/@SceneShake2> \
<当前地图震动3/@SceneShake3> \
<比奇省屏幕震动/@SceneShake4>\

[@SceneShake]
#IF
#ACT
SceneShake 0 3
;自己震动3次，后面参数不要的话为自己震动一次 break

[@SceneShake1]
#IF
#ACT
SceneShake 1
break

[@SceneShake2]
#IF
#ACT
SceneShake 2 1 1
;屏幕范围内震动1次，本次震动需勾选内挂"屏幕震动"选项，否则看不到震动效果
break

[@SceneShake3]
#IF
#ACT
SceneShake 3
break

[@SceneShake4]
#IF
#ACT
;命令 参数 地图
SceneShake 4 0
break


脚本控制怪物攻城

功能：
实现由脚本控制怪物攻城。

格式：
 ;怪物集中位置，怪物会自动向此位置集中
MISSION 地图名 座标X 座标Y

;刷新怪物座标X
PARAM1 X

;刷新怪物座标Y
PARAM2 Y

;刷新怪物数量
PARAM3 数量

;刷新怪物范围
PARAM4 范围

;刷新怪物名称
MobPlace 怪物名称

;=======================================
[@MobMission]
#if
#act
MISSION 3 330 330
PARAM1 360
PARAM2 340
PARAM3 10
PARAM4 5
MOBPLACE 半兽勇士
;
;
; ============================================2016-03-30扩展参数================================================
;
;
; 增加国家 国家相关控制参数
;
; MISSION 3 330 330
; PARAM1 360
; PARAM2 340
; PARAM3 10
; PARAM4 5
; PARAM5 1 国家编号
; PARAM6 同国家名玩家是否可攻击(0,1)
; PARAM7 不国家名怪物是否PK(0,1)
; PARAM8 怪物名字颜色
; PARAM9 禁止相同国家的人员攻击怪物（1：禁止；0：不禁止）用禁止可以保留以前的逻辑
; MOBPLACE 半兽勇士
;
;
; --------------------------------------------------------------------------------------------------------------
;
; 此命令支持怪物巡逻坐标攻击，设置多个指定坐标后，怪物会沿途巡逻(按照设定坐标行走到最后一个坐标停止)如下：
; 格式: MISSION 地图 x1;x2;x3...xn y1;y2;y3...yn (x和y的数量要一致）
;
; 示范：
; [@玄武刷怪5]
; #act
; MISSION 1v1 141;173;190;206;201 135;102;85;85;70
; PARAM1 102
; PARAM2 174
; PARAM3 10
; PARAM4 0
; PARAM5 1
; PARAM6 0
; PARAM7 1
; PARAM8 242
; PARAM9 1
; MOBPLACE 战士人形怪
;
;
;
;
;
; ============================================2017扩展参数================================================

;;;;;;;;;;;;;;;;;;;;刷怪命令扩展最后一个参数，为空表示可攻击所有可攻击的对象，指定名字表示只攻击指定名称的可攻击对象
MOBPLACE 怪物名称 目标名称

MISSION <$MAP> 320 351
PARAM1 330
PARAM2 355
PARAM3 1
PARAM4 4
;;;;;;;;;;;;;;;;;;;;下面命令扩展最后一个参数，为空表示可攻击所有可攻击的对象，指定名字表示只攻击指定名称的可攻击对象
MOBPLACE 白野猪 紫色暗灵

=======================================


脚本增加自定义按钮[!]

功能：
脚本增加自定义按钮

格式：命令 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8 参数9 参数10

命令：ADDBUTTON

[@main]
<自定义按钮/@main1>\

[@main1]
#IF
#ACT
ADDBUTTON 3 1 283 284 285 10 200 1 -1 自定义按钮1\测试增加按钮

参数说明：

参数1为WIL补丁序号，此序号在M2-查看-列表信息二-WIL资源 里面编辑
参数2为按钮点击后的脚本触发序号，触发QF里面的[@ButtonClickX]X即为触发序号
参数3为按钮默认图片
参数4为鼠标经过图片
参数5为按钮按下图片
参数6为距离窗口左边的距离(此参数建议用分辨率宽变量计算)
参数7为距离窗口顶边的距离(此参数建议用分辨率高变量计算)
参数8为按钮是否可以移动0=不能移动1=可以移动2=人物装备栏3=人物背包栏4=英雄装备栏5=英雄背包栏6=聊天框左侧龙界面7=聊天框右侧等级界面8=商铺界面9=时装界面,10=英雄时装，11=技能栏，12=英雄技能栏，13=称号栏，14=英雄称号栏，15=状态栏，16=英雄状态栏，17=属性栏，18=英雄属性栏，19=人物出战栏，20=行会界面,21=详细属性位置, 22=宠物界面,23=宠物背包，24=人物首饰，25=英雄首饰，26=人物神佑，27=英雄神佑，28=查看他人装备，29=查看他人时装，30=查看他人称号，31=查看他人首饰盒，32=查看他人神佑袋，33=M大地图
参数9为按钮上面显示的文字标题,-1时为空标题(用于不显示标题).换行符号 \ ，支持图片（详见下方参数9说明）
参数10为鼠标移动到按钮显示的悬浮框备注信息(如果需要文字颜色列如：250#，，列子如下：)
[@main2]
#IF
#ACT
ADDBUTTON 3 1 283 284 285 10 200 1 -1 251#自定义按钮1\250#测试增加按钮
ADDBUTTON 38 1 73 73 73 520 1 0 251#装备回收 251#在线回收\250#在线回收

---------------------------------------------------------------------------

其他说明：

按钮序号只能为1-200，因为最多就添加200个自定义按钮

格式：命令 参数1 参数2

命令：DELBUTTON

例子
#IF
#ACT
DELBUTTON 1 1

说明：参数1为按钮序号(1-200) 参数2(0或空的时删除自己的，1时删除全服用户的)

---------------------------------------------------------------------------

文字颜色支持插入自定义颜色： 插入：{文字内容|文字颜色0-255}

########################################################2019-3月扩展参数9说明########################################################

扩展AddButton支持图片
img:图片序号:文件序号:X:Y
Looks:图片:X:Y
DnItems:图片:X:Y
StateItem:图片:X:Y
NewopUI:图片:X:Y
PlayImg:文件序号:开始图片:播放张数:速度:X:Y:绘制模式(0:普通绘制:1:透明绘制)

AddButton 1 6 135 136 137 0 15 6 游戏\活动 这是一个提示信息

---------------------------------------------------------------------------

AddButton 支持图片+文字颜色
AddButton 1 6 135 136 137 10 15 6 这是第一行{文字|250}\{这是第二行|249}\这是第3行 这是一个提示信息

如需做任务引导类的对话框可使用命令AddDlg或AddDlgEx

########################################################2023-02-23月扩展支持M大地图说明########################################################

[@测试1]
#IF
#ACT
AddButton 1 2 135 136 137 0 15 33 测试按钮2 这是一个提示信息

命令 地图代码（大于-1时绘制指定地图 ，-1显示当前所在地图，-2关闭大地图绘制区域）

[@测试2]
#IF
#ACT
;Maptoggle 1
;SendMsg 6 切换到沃玛森林

;Maptoggle -1
;SendMsg 6 还原大地图为当前地图

Maptoggle -2
SendMsg 6 关闭大地图绘制区域（黑色一块）

####################################################位置太多，具体如下############################################################

0 主界面-不能移动
1 主界面-可以移动
2 人物装备栏
3 人物背包栏
4 英雄装备栏
5 英雄背包栏
6 聊天框左侧龙界面
7 聊天框右侧等级界面
8 商铺界面
9 时装界面
10 英雄时装
11 技能栏
12 英雄技能栏
13 称号栏
14 英雄称号栏
15 状态栏
16 英雄状态栏
17 属性栏
18 英雄属性栏
19 人物出战栏
20 行会界面
21 详细属性位置
22 宠物界面
24 人物首饰
25 英雄首饰
26 人物神佑
27 英雄神佑
28 查看他人装备
29 查看他人时装
30 查看他人称号
31 查看他人首饰盒
32 查看他人神佑袋
33 M大地图
34 英雄出战栏
35 查看他人出战栏
36 人物时装首饰
37 英雄时装首饰
38 他人时装首饰
39 人物时装神佑
40 英雄时装神佑
41 他人时装神佑


结婚脚本

[@main]
<我想结婚/@marry>\
<我想离婚/@unmarry>\ \
<离开/@exit>

[@marry]
求婚者必须是男性且拥有求婚戒指，\
你准备好求婚了吗？\ \
<准备好了/@agree>\
<下次再来/@exit>\ \ \
<返回/@main>

[@agree]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>
#if
checkposemarry
#say
对方已经结过婚了，是不是想犯重婚罪呀！！！\ \
<返回/@main>
#act
break

#if
gender man
#elsesay
只有男的向女的求婚，还没见过大姑娘向小伙子求婚的。\ \
<返回/@main>
#elseact
break

#if
checkposegender 男
#say
你变态呀！！！想搞同性恋！！！ \ \
<返回/@main>
#act
break

#if
checkposedir 2
#elsesay
你们二个面对面站好呀，不要乱动。\ \
<返回/@main>
#elseact
break

#if
checklevel 40
#elsesay
结婚要求你的等级必须40级或以上，小伙子努力练好级再来找我。\ \
<返回/@main>
#elseact
break
#if
checkposelevel > 34
#elsesay
你的对象还没成年，等她长大点再来吧！小伙子不要心急嘛！\ \
<返回/@main>
#elseact
break
#if
checkitemw 求婚戒指 1
#elsesay
你没求婚戒指，弄到求婚戒指再来找我吧！！！\ \
<返回/@main>
#elseact
break

#if
#act
takew 求婚戒指 1
marry

[@StartMarry]
#if
checkmarry
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>
#act
break

#if
gender man
#act
break
#say
婚礼现在正式开始。\ \
你愿意娶对方为妻，并照顾她一生一世吗？\ \
<我愿意/@RequestMarry>

#if
gender
#act
break
#say
婚礼现在正式开始。\ \
请耐心等待你心爱的人向你求婚\ \

[@RequestMarry]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#act
marry requestmarry
[@WateMarry]
你已向对方求婚，请耐心等待对方的答复。

[@RevMarry]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#say
对方向你求婚，你是否答应嫁给他？ \ \
<我愿意/@ResposeMarry> \
<我不愿意/@ResposeMarryFail>
[@ResposeMarry]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#act
marry responsemarry ok

[@ResposeMarryFail]
#if
checkmarry
#act
break
#say
你都结过婚了，还来注册结婚，想犯重婚罪呀！！！ \ \
<返回/@main>

#if
#act
marry responsemarry fail
[@EndMarry]
你们二个已经成为了一对全法夫妻了。\ \
<关闭/@exit>
[@EndMarryFail]
结婚失败！\ \
<关闭/@exit>
[@MarryDirErr]
对方没站好位置

[@MarryCheckDir]
请站好位置\\

[@HumanTypeErr]
你变态呀，既然选择一个非人类作为结婚对象。

[@MarrySexErr]
你变态呀，既然同性恋。

;==========================================
离婚开始
[@unmarry]
#if
checkmarry
#act
unmarry
#elsesay
你都没结婚离什么婚？？\ \
<返回/@main>

;=======================================================
;双方离婚时没面对面站好显示的信息
[@UnMarryCheckDir]
要离婚是吧？离婚是二个人的事，必须二个人对面对站好位置，\
如果人来不了你只能选择强行离婚姻了。\ \
<我要强行离婚/@fUnMarry>\
<返回/@main>
;=======================================================
;对面位置不是人物时显示的信息
[@UnMarryTypeErr]
你对面站了个什么东西，怎么不太象人来的。\ \
<返回/@main>

;=======================================================
;开始离婚程序后，双方显示的信息
[@StartUnMarry]
#if
gender man
#act
BREAK
#say
是否确定真的要与你共事多年的妻子离婚吗？\ \
<确定/@RequestUnMarry>

#if
gender
#say
你的老公现在向我请求离婚，是不是愿意协议离婚？ \ \
<确定/@RequestUnMarry>
#act
break

;=======================================================
;发出离婚请求
[@RequestUnMarry]
#if
checkmarry
#act
unmarry requestunmarry
;=======================================================
;回应离婚请求
[@ResposeUnMarry]
#if
checkmarry
#act
unmarry responseunmarry

;===============================================
;请求离婚后显示的信息
[@WateUnMarry]
你已向对方发出离婚请求，请耐心等待对方的答复。

;===============================================
;请求离婚后对方显示的信息
[@RevUnMarry]
对方向你离婚请求，你是否答应离婚？ \ \
<我愿意/@RequestUnMarry>
<返回/@main>

;===============================================
;没结过婚的人点离婚后出的提示信息
[@ExeMarryFail]
你都没结过婚，跑来做什么？ \ \
[返回/@main]

;==============================================
;强行离婚
[@fUnMarry]
#if
checkitem 金条 1
checkmarry
#act
take 金条 1
unmarry requestunmarry force
#elsesay
要收一根金条的手续费，你没有金条，\
我不能让你离婚。\
<确定/@exit>
;==============================================
;离婚完成后的提示信息
[@UnMarryEnd]
呵呵，你已经脱离苦海了！！！ \ \
<退出/@exit>
[@asktime]
你调查结婚时间的请求已发出，\
请稍后。\
<确定/@exit>


经验怪、经验猪

功能：
经验怪
经验怪： Race = 158， Exp：给攻击者经验； AC = 0：所有攻击均可得经验；AC=1：物理攻击得经验；AC=2，魔法攻击得经验。 ;------------------------------------------------

DB：
158 19 72
需要什么外观怪物修改APPR 也就是上面的72改成你需要的怪物APPR即可，其他自己DB设置，如果不需要DB控制就自己做攻击触发！自己看着办！
break


酒神弟子完整脚本[!]

以下为酒神弟子完整脚本:
[@Main]
我是玛法酒神的嫡传大弟子,也是这家酒馆的老板.\
这次回来正式受了师父的托付,将玛法的古老武学内功,在玛法大陆\
传播开来.当你学习内功并通过修炼,使内功等级逐渐升高后,你的\
战斗力会获得极大的提升.怎么样?有没有兴趣来学习内功?\
<我要学习内功/@学习内功> <兑换玛法珍酿>\
<内功是什么?/@内功说明> <兑换精元丹>\

[@学习内功]
哦?有心思学习这心法了?\
算你有眼光,学习了内功,实力大增,到时候莫说,\
击败肆虐玛法的邪恶生物,就是翻越过雪山,\
找到回家之路也不是不可能.\
那你是想自己学习还是你的英雄学习呢?\
请注意,只有你自己学会内功后,我才会教你的英雄内功.\
<我自己学习/@自己学习> <让我的英雄学吧/@英雄学习>\
<不,我是想将玛法内功心法还给你>\
<返回/@EXit>

[@自己学习]
#if
CHECKREADSKILLNG
#ACT
MESSAGEBOX 你还想再学习?
#ELSEACT
goto @自己学习1

[@自己学习1]
#IF
;检查所需物品
checkitem 玛法内功心法 1
#ACT
take 玛法内功心法 1
READSKILLNG
#ELSEACT
MESSAGEBOX 没有玛法内功心法,你还想学习?

[@英雄学习]
#if
H.CHECKREADSKILLNG
#ACT
MESSAGEBOX 英雄还想再学习?
#ELSEACT
goto @英雄学习1

[@英雄学习1]
#IF
;检查所需物品
H.checkitem 玛法内功心法 1
#ACT
H.take 玛法内功心法 1
H.READSKILLNG
#ELSEACT
MESSAGEBOX 没有玛法内功心法,你还想学习?

[@ReadNGOK]
你学会内功!

[@ReadNGHeroOK]
你的英雄学会内功!

[@ReadNGFail]
你的已经学会内功了呀!

[@ReadNGHeroFail]
你尚未招出你的英雄,或者你的英雄已经学会内功了呀!

[@内功说明]
三龙卫的神威早已铭记在了每个玛法人的心头,他们当年所使用的\
绚丽招式多已经流传于当今的玛法大陆,在不久前几种三龙卫的几乎\
失传的绝技也从藏经阁出世,再度扬威江湖.不过人们所不知道的是\
昔年三龙卫之所以能够扬威玛法,不仅仅靠他们精妙的招式,更是\
因为他们雄厚的内功.随着三龙卫的失踪,这些内功的秘密,也随之\
失传.但只有一种人,他们中间还依旧流传着三龙卫内功的秘密,\
他们,便是三龙卫的后裔!\\

<莫非你就是三龙卫的后裔?/@三龙卫的后裔>

[@三龙卫的后裔]
不,不,我当然不是那些英雄的后裔,我的师父才是!我师父的名号\
相信你一定听过,他就是玛法大陆上酒的传播者,三十年前的第一\
勇士玛法酒神.当年师父正是凭借着他内外双修的高深功力,\
在玛法大陆上横行无阻.这些年来,师父他一直在遵循着他的祖先\
三龙卫的遗志,试图翻越雪山,寻找回家的路.然而,自然之力并非\
人力可敌,师父花了三十年,也不过探索了大雪山一隅,\
为此,他决定从他这代开始,打破三龙卫家族的族规.\ \

<三龙卫的禁密武学从此可以外传了?/@禁密武学外传>

[@禁密武学外传]
不错,师父他相信人定胜天,只要敢于打破常规,必可以找出一条\
回家的道路.因此,师父派我,他的嫡传大弟子,来到盟重酒馆\
这个人来人往的地方,寻找有缘人,将内功的奥妙传播开来.\
一个人找不到回家的路,但相信一万人百万人,一定可以在绵延的\
雪山中,寻找到一条路,通向我们玛法文化的根源!\ \

<我相信我们会找到回家的路的> <返回>


开通元宝寄售服务

 功能: 开通元宝寄售服务
格式: OPENYBDEAL 数字 //开通元宝交易，数字表示需要的元宝数量 永久使用,保存入人物数据里
@@dealybme 寄售物品

QUERYYBSELL //查询正在出售的物品
QUERYYBDEAL //查询可以的购买物品

<$QUERYYBDEALLOG> //显示交易记录

下面是完整脚本实例

(@ybdeal )
[@main]
您好，有什么可以效劳的？我可以为您提供关于元宝的各类服务 \
现在已经开通了金刚石的元宝交易功能，\
点击交易栏的第十格可以放置金刚石进行交易，\
如果不更新客户端，<交易栏的第十格将不能使用>。\
<查询元宝交易协议/@rule1> <开通元宝交易/@rule>\
<查询元宝数/@askybnum> <出售物品/@@dealybme>\
<查询正在出售的物品/@askybsell> <购买物品/@askybdeal>\
<查询交易信息/@askybdeallog>\

[@askybsell]
#ACT
QUERYYBSELL

[@askybdeal]
#ACT
QUERYYBDEAL

[@askybdeallog]
<$QUERYYBDEALLOG>

[@askybnum]
你的帐号里元宝的总数是：<$GAMEGOLD>颗。\ \ \
<返回/@main>

[@rule]
人人都知道，我是玛法大陆最公正的人\
您要开通以元宝出售道具，必须向我支付1个元宝\
我将为您提供永久、公正的服务\ \
<我已阅读并同意元宝交易协议，支付一个元宝开通元宝交易/@openybsell>\
<不同意/@exit>

[@openybsell]
#ACT
//参数1 表示开通需要元宝
OPENYBDEAL 1

[@rule1]
您确定已仔细阅读了《元宝交易协议》并接受协议内的所有条款\
1、第一次使用元宝交易，必须开通元宝交易功能并向NPC支付1个元宝\
2、充值元宝是针对帐号进行的，\
该帐号下相同服务器的角色均可以使用这些元宝\
3、如果物品放在NPC处出售超过3天，交易将被终止，\
同时卖方取回物品时需额外再支付1个元宝。\
4、卖方在输入买方角色和元宝数量时，请注意输入正确的角色名\
因自己本身操作失误造成的损失系统将不进行补偿。\
<下一页/@rule2>

[@rule2]
5、在一笔交易未完成的情况下，交易双方均不可以再次进行元宝交易\
6、帐号在单组服务器携带元宝上限:9999个，\
元宝单次交易额最高不超过9999个，\
交易成功如果角色携带元宝数量超过上限，\
超过上限的元宝数量将被自动转换成游戏时间（天卡）\
7、交易成功，卖方将自动获得相应元宝\
8、玩家可在我这里查询最近一次的元宝交易记录\
在取消交易或接受交易物品时,若包裹栏无足够空间，则物品将不能取回\
<返回/@main>

[@AskYBSellFail]
没有查询到指定的记录\
<返回/@main>
[@AskYBDealFail]
没有查询到指定的记录\
<返回/@main>


捆药绳[!]

功能：
捆药绳.

格式：将多件物品捆绑为一件物品

示列：

DB：2 1 1 31 ....后面自己填写，持久为使用次数 注意：source = -1 时将不会被放入下面6格

[@STDMODEFUNC22]
#IF
CHECKITEM 强效太阳水 6
#ACT
TAKE 强效太阳水 6
GIVE 太阳水包 1
#ELSEACT
AddFunItemDura 1000


离线挂机[!]

(@@offlinemsg)
[@main]
欢迎使用我提供的挂机功能，使用此功能可以让你不必开电脑，\
就可以进行泡点。\
点击开始挂机后，可输入一段留言信息给你的朋友。\
<开始挂机/@@offlinemsg>
[@@offlinemsg]
#if
ISDUPMODE
#say
请找一个空位置，不能与别人站在一起。\ \
<返回/@main>
#act
break

#if
INSAFEZONE
#elseact
break
#elsesay
请在安全区找一个位置站好，不能会被人杀的。\ \
<返回/@main>

#IF
checklevelex > 0
#act
OFFLINEPLAY 100 100 100
;命令 秒 经验 分钟 （挂机多少秒获得多少经验，挂机多少分钟后踢出游戏）

------------------------------------------------------------------------------------------------------------------------------------

功能: 挂机命令

格式:ISDUPMODE (0或空时检测所有对象，1只检测人物)

范例地址：挂机范例脚本


聊天框自定义颜色

聊天框信息颜色自定义格式：

{信息|F:B:M}

F=字体颜色 B=背景颜色 M=模式(0绘制背景色,1字体描边)

例如：

[@main]
#ACT
SENDMSG 5 {<$USERNAME>|254:253}翎风引擎官方网站：http://www.lfm2.com
SENDMSG 5 {<$USERNAME>|250:0:1}翎风引擎官方网站：http://www.lfm2.com
SENDTOPCHATBOARDMSG 0 149 235 30 {<$USERNAME>|250:0}翎风引擎官方网站：http://www.lfm2.com

注意请在网关上设置过滤{信息|F:B}中任意字符，防止玩家发送彩色聊天信息


魔王岭脚本

天下第一脚本

修改MerChant.txt 配置文件

NPC名称支持变量显示(只能使用全局变量A和T两种字符串类型，其它类型无效，请参照天下第一设置)

直接给变量写值NPC就会自动更名

例如：

天下第一战士 3 321 340 A14 0 35 0 0 0
天下第一战士 3 324 340 A15 0 36 0 0 0
天下第一法师 3 327 340 A16 0 37 0 0 0
天下第一法师 3 330 340 A17 0 38 0 0 0
天下第一道士 3 333 340 A18 0 39 0 0 0
天下第一道士 3 336 340 A19 0 40 0 0 0

脚本

[@main]
#if
#act
MOV A14 <$USERALLNAME>\天下第一战士


强制组队脚本

功能：
强制组队脚本.

(@@InPutString @@InPutInteger)

[@强制组队]
#if
#act
mov S10
#say
\
<请直接输入对方的游戏角色名称即可强制他跟你组队！/SCOLOR=150>\
\ \
<请输入角色名字：/SCOLOR=253><点击此处输入名字/@@inputstring10(请正确输入需要组队的角色名字:)>\
\

[@inputstring10]
#if
#act
goto @开始组队
break

[@MsgFilter]
#ACT
MESSAGEBOX 输入数据中包含了非法字符,请重新编辑!

[@开始组队]
#if
CheckOnline <$STR(S10)>
#act
CreatGroup <$STR(S10)>
break
#elsesay
\　\
错误：<玩家『<$STR(S10)>』已经下线，只能针对在线人物使用。/SCOLOR=254>\
  \
<返回/@强制组队>\
<关闭/@exit>\　\

[@CreatGroupOK]
#say
\ 操作成功，玩家<$STR(S10)>已被你开始组队！
\
\
<返回/@强制组队>\
<关闭/@exit>\　\

★★★★★★★有禁止符号时执行当前npc的脚本@InputStringFilter, @InputIntegerFilter
禁止符号在M2-列表信息一设置


清除当前人物的拜师信息

功能：
清除当前人物的拜师信息。

格式：
 DELMASTER 徒弟序号(为空表示大徒弟、师傅清除指定徒弟使用，徒弟清除师傅以下是示例脚本)
;==========================================
[@Main]
#IF
#ACT
DELMASTER
#SAY
你已经和你师傅脱离关系了
;==========================================


人物登录脚本

功能：
即在人物进入游戏时自动执行的脚本，通过此脚本可对人物进行大量的功能控制。

格式：
在目录 Envir\MapQuest_def\ 中建立文件名为QManage.txt的脚本，按以下格式编写脚本：

========================================================================
;脚本例子
[@Login]
#IF
IsAdmin
#ACT
CHANGEMODE 2 1
CHANGEMODE 3 1
SENDMSG 5 %s，欢迎进入游戏，当前模式为GM管理模式。========================================================================
注：如该脚本更改后，不须重启M2使其生效，可用@ReloadManage命令重新加载该脚本。


人物显示一个放大的虚影[!]

功能：
人物显示一个放大的虚影

格式：

[@main]
<放大虚影/@main1>\

[@main1]
#if
#ACT
;显示幻象：第一个参数：透明度(0--255)，值越小越透明 10：显示时间（秒）
SHOWPHANTOM 255 10


人物颜色发型

[@HumFace]
请选择美容项目....\ \
『<名称颜色/@changcolor>』\
『<换 发 型/@ChangHair>』\ \
〖<返回/@main>〗

[@ChangColor]
是不是觉得自己名称的颜色太单调了，换换试试！\ \
『<复原/@Color255>』\
『<蓝色/@Color0>』 『<绿色/@Color1>』 『<黄色/@Color2>』 『<橙色/@Color3>』\
『<土黄/@Color4>』 『<红色/@Color5>』 『<淡兰/@Color6>』 『<淡绿/@Color7>』\ \
〖<返回/@MemberFace>〗 〖<关闭/@exit>〗

[@Color255]
#ACT
CHANGENAMECOLOR 255
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color0]
#ACT
CHANGENAMECOLOR 252
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color1]
#ACT
CHANGENAMECOLOR 217
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color2]
#ACT
CHANGENAMECOLOR 251
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗
[@Color3]
#ACT
CHANGENAMECOLOR 253
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗 〖<关闭/@exit>〗

[@Color4]
#ACT
CHANGENAMECOLOR 125
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗

[@Color5]
#ACT
CHANGENAMECOLOR 249
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗
[@Color6]
#ACT
CHANGENAMECOLOR 254
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗
[@Color7]
#ACT
CHANGENAMECOLOR 250
#SAY
呵呵，你的颜色已经改变。\ \
〖<返回/@ChangColor>〗
[@ChangHair]
#IF
gender man
#ACT
goto @ChangHairMan
#ELSEACT
goto @ChangHairWoman
[@ChangHairMan]
想不想来个光头呀，酷呆了！！！\ \
『<光头/@hairman0>』\
『<长头发/@hairman1>』\ \
〖<返回/@MemberFace>〗 〖<关闭/@exit>〗
[@hairman0]
#ACT
HAIRSTYLE 0
#SAY
呵呵，光头是不是很酷呀！！！ \ \
〖<返回/@ChangHairMan>〗
[@hairman1]
#ACT
HAIRSTYLE 1
#SAY
呵呵，你的发型已经改变了... \ \
〖<返回/@ChangHairMan>〗

[@ChangHairWoman]
『<短发型/@hairWoman0>』\
『<长发型/@hairWoman1>』\ \
〖<返回/@MemberFace>〗 〖<关闭/@exit>〗
[@hairWoman0]
#ACT
HAIRSTYLE 0
#SAY
呵呵，你的发型已经改变了... \ \
〖<返回/@ChangHairWoman>〗 〖<关闭/@Exit>〗
[@hairWoman1]
#ACT
HAIRSTYLE 1
#SAY
呵呵，你的发型已经改变了... \ \
〖<返回/@ChangHairWoman>〗 〖<关闭/@Exit>〗


人物转生[!]

功能：
人物转生控制

格式：
 RENEWLEVEL 转次数 转后等级 分配点数
转次数 代表一次转多少级(数值范围为 1 - 255)
转后等级 代表转生后人物的等级，0为不改变人物当前等级。
分配点数 代表转生后可以得到的点数，此点数可能按比例换成人物属性点(数值范围 1 - 20000)。
英雄转生命令为：H.RENEWLEVEL 转次数 转后等级

;==========================================
;将人物转生一次，后等级设为 28级，分配100点属性
[@RenewLevel]
#IF
#ACT
RENEWLEVEL 1 28 100
#SAY
转生成功。
;==========================================
功能：
 检测转生等级

检测英雄等级命令：H.checkrenewlevel

格式：
 控制符(=,>,<)
;==========================================
[@ViewRenLevel]
#IF
checkrenewlevel = 0
#act
break
#say
你还没转生！！！\ \
〖<返回/@ReNewLevel>〗 〖<关闭/@exit>〗
#IF
checkrenewlevel = 1
#act
break
#say
你的转生等级为第一重转生！！！\ \
〖<返回/@ReNewLevel>〗 〖<关闭/@exit>〗
;==========================================

功能：
清除人物转生数据(即人物转生后恢复到未转生状态)

清除人物转生数据(即人物转生后恢复到未转生状态,命令：H.RestRenewLevel

格式：
;==========================================
[@ClearRenewLevel]
#IF
#ACT
RestRenewLevel
;==========================================

英雄转生示列脚本：

[@herozs]
#IF
H.checkrenewlevel < 9
#Act
H.RENEWLEVEL 1
#SAY
您的英雄转生到<$H.RELEVEL>级了！！！
#ELSEACT
MESSAGEBOX 英雄转生次数已经<$H.RELEVEL>级了！
======================================================================

功能：
设置及更改转生人物显示的名称

格式：
配置文件：String.ini

以下为相关配置内容：
;==========================================
WarrReNewName=%chrname\*<圣>*
WizardReNewName=%chrname\*<神>*
TaosReNewName=%chrname\*<尊>*

WarrReNewName 　武士转生后名称显示
WizardReNewName 法师转生后名称显示
TaosReNewName 　道士转生后名称显示


任务脚本

 --------------------------------------------------------------
刷新任务页面

RefreshMissPage 页面名
;刷新任务页面时需使用close关闭当前NPC界面

--------------------------------------------------------------
打开任务窗口命令：
OpenMissionDlg

命令支持坐标调整打开的窗口位置如下：
OpenMissionDlg X坐标 Y坐标

--------------------------------------------------------------

;此脚为任务脚本放在Market_Def目录QMission-0.txt，人物每次登录时都会执行[@Login]
引擎-工具-任务NPC配置-增加任务NPC页面。例如：增加“主线任务”他对应的脚本字段就是[@主线任务]

[@Login]

[@主线任务]
传奇归来任务\
<传奇归来任务/@生存的诀窍>\
主线任务\
<生存的诀窍/@生存的诀窍>\

[@支线任务]
支线任务\
<等级2 寻找炼金师/@寻找炼金师>\
<等级3 王师弟子/@王师弟子>\
<等级4 新手大礼包/@新手大礼包>\
<等级5 进入庄园/@进入庄园>\
<等级5 天关寻宝/@天关寻宝>\

[@日常活动]
日常活动\
<玛法巡游（每日一次）/@玛法巡游>\
<地下夺宝/@地下夺宝>\
<除魔任务（每日一轮）/@除魔任务>\
<历练任务（每日一次）/@历练任务>\
<每日巡游任务/@每日巡游任务>\
<生存战（每日13：50，16：50开放）/@生存战>\
<每日探索任务（每日一次）/@每日探索任务>\
<闯关夺宝（每日18：30-19：00）/@闯关夺宝>\

[@生存的诀窍]
半兽人的贪婪和凶残打破了我们宁静的生活。\
战火蔓延到玛法大陆的每个角落。\
我们渴望驱除侵入者，我们期待重建家园。\
勇士，在这生死存亡的危机时刻，我们要团结\
在一起。为了帮助你成长，快去找你旁边\
的任务使者<比奇(333.262)/@比奇任务使者>或<边界村(287.614)/@边界村任务使者>或\
<银杏山谷(647.623)/@银杏山谷任务使者>吧！\

[@寻找炼金师]
在比奇（325，262），盟重（326，330），苍月岛\
庄园（65，72）处可以找到炼金师，在炼金师处使\
元宝可以获得大量经验、金刚石和组队卷轴。\
金刚石是锻造高级武器的必备物品。\
组队卷轴是去地下宫殿解救天工神剪的必须道具。\
<任务/FCOLOR=249>：到炼金师处查询元宝锻造的规则\
<完成任务NPC/FCOLOR=249>：比奇、盟重、苍月岛、庄园的炼金师\

[@王师弟子]
恭喜你已经达到了<$LEVEL>级，你可以到比奇（327，260）\
盟重（331，328）金牌尊者处领取一份王师弟子奖\
<任务/FCOLOR=249>：在武馆教头处了解“师傅如何收徒”\
<完成任务NPC/FCOLOR=249>：比奇、盟重的武馆教头\

[@新手大礼包]
比奇的书店老板（325，250）是个热心肠的人。\
尤其是对待新人的帮助。\
<任务/FCOLOR=249>：查看“5元宝换取新手大礼包”\
<完成任务NPC/FCOLOR=249>：比奇书店老板\

[@玛法巡游]
你每天可以在<盟重活动使者(339,335)/FCOLOR=249>处\
领取玛法巡游任务。\
只要在玛法大陆巡查两个小时后，\
就可以带<比奇国王/FCOLOR=249>那里领取大量的经验回馈。\
每日22点后，不可以接受巡查任务。\

[@地下夺宝]
你每天可以在<宫殿长廊送宝人偶(108，96)/FCOLOR=249>处\
参加地下夺宝活动。\ \

活动时间为：\
10：30-11：00\
13：30-14：00\
15：30-16：00\
20：30-21：00\
23：00-23：30\ \

活动细则：\
以上活动时间段内,通过<盟重镇魔首将(322,342)/FCOLOR=249>处\
携带地下组队卷轴选择单人或组队进入地下宫殿后\
点击送宝人偶，进入夺宝地图，\
活动时间结束前的5分钟宝物会出现在夺宝地图中，\
宝物出现后2分钟即可获得。\ \

有几率爆出以下宝物：\
<40级重装等高级装备/FCOLOR=249>\
<白金积分，热血积分/FCOLOR=249>\
<全系列藏宝图/FCOLOR=249>\
<47级新技能书，道士驯兽术/FCOLOR=249>\

[@除魔任务]
你每天可以在<盟重活动使者(339,335)/FCOLOR=249>处\
领取每日除魔任务。\
在一轮除魔任务（完成5次任务）中。\
每次完成任务后的奖励会越来越好。\
每天只能完成一轮的除魔任务。\ \

任务包括：\
前往石墓杀死<10只红野猪/FCOLOR=249>\
前往骨魔洞杀死<20只骷髅长枪兵/FCOLOR=249>\
前往霸者大厅杀死<3只白野猪/FCOLOR=249>\
前往兽人古墓杀死<15只骷髅/FCOLOR=249>\
前往赤月峡谷杀死<10只月魔蜘蛛/FCOLOR=249>\
前往比奇杀死<15只鸡/FCOLOR=249>\
前往毒蛇山谷杀死<5只虎蛇/FCOLOR=249>\
前往比奇杀死<8只食人花/FCOLOR=249>\
前往雷炎洞穴杀死<2只金杖蜘蛛/FCOLOR=249>\
前往死亡棺材杀死<2只邪恶钳虫/FCOLOR=249>\
前往魔龙西郊杀死<3只魔龙刀兵/FCOLOR=249>\ \

如果你觉得领取的任务太难，\
也可花费<50000金币/FCOLOR=249>在<盟重活动使者(339，335)/FCOLOR=249>处\
重新领取任务。\

[@历练任务]
你每天可以在盟重活动使者（339，335）处\
领取每日历练任务。\
按照指示前往各地找到恶魔看守人，支付一定的金币\
杀死指定的怪物即可完成历练任务领取奖励。\
每天只能只能完成一次历练任务。\ \

任务包括：\
25-29级：前往香石墓穴，杀四10只恶魔野猪\
香石墓穴恶魔看守人(37,30)，(84,47)\
任务奖励：500000经验\ \

30-34级：前往沃玛寺庙三层，杀死<10只恶魔沃玛/FCOLOR=249>\
沃玛寺庙恶魔看守人(46,46),(62,62)\
任务奖励：600000经验\ \

35-39级：前往地牢一层东，杀死<10只恶魔蜈蚣/FCOLOR=249>\
地牢一层恶魔看守人(75,108),(161,52)\
任务奖励：800000经验\ \

40-44级：前往石墓七层，杀死<10只恶魔楔蛾/FCOLOR=249>\
石墓恶魔看守人(30,72),(62,42)\
任务奖励：1000000经验\ \

45-49级：前往祖玛七层大厅，杀死<10只恶魔祖玛/FCOLOR=249>\
祖玛神殿恶魔看守人(11,13)\
任务奖励：1200000经验\ \

50-54级：前往牛魔寺庙大厅，杀死<10只恶魔牛魔/FCOLOR=249>\
牛魔寺庙恶魔看守人(15,16),(67,67)\
任务奖励：1200000经验\ \

55-59级：前往魔龙岭，杀死<10只恶魔魔龙/FCOLOR=249>\
魔龙岭恶魔看守人(213,117),(84,353)\
任务奖励：1500000经验\ \

60-70级：前往地下长廊，杀死<10只地下长廊恶魔/FCOLOR=249>\
地下长廊恶魔看守人(160,172)\
任务奖励：1500000经验\ \


沙城主公告

将下面的放到沙皇宫的NPC脚本里就行了

(@@sendmsg)
[@main]
沙巴克当前归<$OWNERGUILD>所有，由<$LORD>统治管理。\
现在金库中所存的金币数量为:<$CASTLEGOLD>，今天的收入为: <$TODAYINCOME>\ \

『<修改城名/@@castlename>』 『<城主公告/@@sendMsg>』\\
『<取回资金/@@withdrawal>』 『<存入资金/@@receipts>』\
『<控制城门/@treatdoor>』 『<修理城门和城墙/@repaircastle>』\
『<雇用弓箭手/@hirearchers>』\ \
〖<取消/@exit>〗\
[@@sendMsg]
#if
checkcastlegold ? 100000
#act
takecastlegold 100000
SETSENDMSGFLAG
#elsesay
城内资金不足，不要乱用钱。\ \
『<返回/@main>』

[@treatdoor]
城门当前状态为:『<$CASTLEDOORSTATE>』\ \
『<关城门/@closemaindoor>』\
『<开城门/@openmaindoor>』\ \
〖<返回/@main>〗\

[@openmaindoor]
城门已经打开。\ \
〖<返回/@treatdoor>〗\

[@closemaindoor]
城门已经关闭。\ \
〖<返回/@treatdoor>〗\

;--------------------------------------------------
;荐府 包访

[@repaircastle]
请选择要修理的位置？\ \
『<修理城门/@repairdoor>』\
『<修理城墙/@repairwalls>』\ \
〖<返回/@main>』\

[@repairdoor]
修理城门所需费用为:『<$REPAIRDOORGOLD>』金币。\ \
『<修理城门/@repairdoornow>』\
『<返回/@repaircastle>』\

[@repairwalls]
修理城墙所需费用为:『<$REPAIRWALLGOLD>』金币。\ \
『<修理城墙/@repairwallnow1>』\
『<修理城墙/@repairwallnow2>』\
『<修理城墙/@repairwallnow3>』\ \
〖<返回/@repaircastle>』\

[@hirearchers]
雇用弓箭手可保护城堡的安全，并维护城堡的治安。\
每个弓箭手的雇用费用为『<$ARCHERFEE>』金币。\
请选择要雇用弓箭手放置位置: \ \
『<城墙左弓箭手三/@hirearchernow1>』, 『<城墙左弓箭手二/@hirearchernow2>』, 『<城墙左弓箭手一/@hirearchernow3>』\
『<城墙右弓箭手一/@hirearchernow4>』, 『<城墙右弓箭手二/@hirearchernow5>』, 『<城墙右弓箭手三/@hirearchernow6>』\
『<城门左弓箭手/@hirearchernow9>』, 『<城门左弓箭手/@hirearchernow10>』, 『<城门右弓箭手/@hirearchernow11>』, 『<城门右弓箭手/@hirearchernow12>』\
『<皇宫左弓箭手/@hirearchernow7>』, 『<皇宫右弓箭手/@hirearchernow8>』\
『<返回/@main>』\


设置雕像有效时间[!]

功能：
设置雕像有效时间.

说明：使用：SetNpcImageTime 设置雕像有效时间，到时间后破碎，时间单位：分钟

SetNpcImageTime 操作符（=，+，-） 时间（为空，小于或等于0为永久有效，大于0为指定分钟） ，附：不用此命令为无限制时间，因为符合了小于0或等于0或为空

注意此命令只可以在ARP为273的NPC使用！！！！

示列：

[@SetNpc]
#IF
#ACT
SetNpcImageTime + 600
SendMsg 5 雕像维护成功，时间增加10小时！


使用脚本命令解毒[!]

功能：
使用脚本命令解毒（红绿毒）

格式：

[@main]
#if
#ACT
DETOXIFCATION
SENDMSG 6 提示：解毒成功！


收徒脚本

师徒信息保存在：Envir\MasterNo 目录

多徒弟系统（引擎上设置徒弟数量）多徒弟系统师傅身上不在显示是XXXX的师傅！
修改 string.ini 中下面的配置（不改也可以，但不会显示徒弟是第几个）
NoMasterName=%s的%n徒弟
MasterOnlineSelfMsg=你的%n徒弟%s当前位于%m(%x:%y)。
MasterNotOnlineMsg=你的%n徒弟%s现不在线！！！
MasterListOnlineMasterMsg=你的%n徒弟%s在:%m(%x:%y)上线了！！！。
MasterListLongOutMasterOnlineMsg=你的%n徒弟%s在:%m(%x:%y)下线了！！！。
YourMasterListUnMasterOKMsg=你的%n徒弟%d已经圆满出师了！！！
---------------------------------------------------------------------
出师触发 QFunction-0.txt
[@UnMasterEnd]
#IF
#ACT
SENDMSG 6 提示：师傅触发！

[@UnMasterEnd1]
#IF
#ACT
SENDMSG 6 提示：徒弟触发！

强制(脱离师徒)出师：
@ForceUnMasterEnd 师傅触发
@ForceUnMasterEnd1 徒弟触发

=======================================================================================

收徒脚本（和传统一致如您服务端又徒弟脚本无需修改）

[@main]
<我想拜师/@master>\
<我想出师/@unmaster>\ \
<离开/@exit>

[@master]
想拜师呀，你要拜的师父来了没有？\
与你师父面对面站好，开始拜师。\ \
<准备好了/@agree>\
<我知道了/@exit>\ \
<返回/@main>

[@agree]
;检查是不是已经是别人的师父
#if
checkismaster
#act
break
#say
没事别来这玩！！！\ \
<返回/@main>

;检查是不是已经拜师了
#if
checkmaster
#act
break
#say
你都都已经拜了别人为师，怎么还拜师！！！ \ \
<返回/@main>

;检查对面的人物是不是别人的徒弟
#if
checkposemaster
#say
你找了个什么人做师父，怎么现在还是别人的徒弟？\ \
<返回/@main>
#act
break

;检查二个有没站好位置
#if
checkposedir
#elsesay
你们二个面对面站好呀，不要乱动。\ \
<返回/@main>
#elseact
break

#if
checklevel 40
#say
你都40多级了还要找师父？\ \
<返回/@main>
#act
break

;检查对方等级
#if
checkposelevel > 50
#elsesay
你找个什么师父呀，等级这么低？\ \
<返回/@main>
#elseact
break
#act
master

[@StartGetMaster]
拜师仪式正式开始。\ \
你是否确认拜师？\ \
<确认/@RequestMaster>

[@StartMaster]
拜师仪式正式开始。\ \
对方已经向你提出拜师请求。\ \

[@RequestMaster]

;检查所需物品
#if
checkitemw 力量戒指 1
#elsesay
你都没信物，怎么拜呀！！！\ \
<返回/@main>
#elseact
break

#if
#act
takew 力量戒指 1
master requestmaster

[@WateMaster]
你已向对方请求拜师，请耐心等待对方的答复。

[@RevMaster]
对方想拜你为师，你是否想收此人为徒？ \ \
<同意/@ResposeMaster> \
<不同意/@ResposeMasterFail>

[@ResposeMaster]
#if
#act
master responsemaster ok

[@ResposeMasterFail]
#if
#act
master responsemaster fail
[@EndMaster]
你们二个已经是师徒关系了。\ \
<关闭/@exit>
[@EndMasterFail]
拜师失败！\ \
<关闭/@exit>
[@MasterDirErr]
对方没站好位置

[@MasterCheckDir]
请站好位置\\

[@HumanTypeErr]
此人不可以做你的师父。

;==========================================
开始
[@unmaster]
#if
havemaster
#act
unmaster
#elsesay
你都没师父，跑来做什么？？\ \
<返回/@main>

;=======================================================

[@UnMasterCheckDir]
按正常出师步骤，必须二个人对面对站好位置，\
如果人来不了你只能选择强行出师了。\ \
<我要强行出师/@fUnMaster>\
<返回/@main>
;=======================================================
;对面位置不是人物时显示的信息
[@UnMasterTypeErr]
你对面站了个什么东西，怎么不太象人来的。\ \
<返回/@main>
[@UnIsMaster]
必须由徒弟发出请求！！！\ \
<返回/@main>
[@UnMasterError]
不要来捣乱！！！\ \
<返回/@main>
;=======================================================
;开始程序后，双方显示的信息
[@StartUnMaster]
出师仪式现在开始！！！\ \
是否确定真的要脱离师徒关系？\ \
<确定/@RequestUnMaster>
[@WateUnMaster]
出师仪式现在开始！！！\ \

;=======================================================
;发出请求
[@RequestUnMaster]
#if
havemaster
#act
unmaster requestunmaster
;=======================================================
;回应请求
[@ResposeUnMaster]
#if
havemaster
#act
unmaster responseunmaster

;===============================================
;请求后显示的信息
[@WateUnMaster]
你已向对方发出请求，请耐心等待对方的答复。

;===============================================
;请求后对方显示的信息
[@RevUnMaster]
对方向你请求，你是否答应？ \ \
<我愿意/@RequestUnMaster>
<返回/@main>

;===============================================

[@ExeMasterFail]
你都没师父，跑来做什么？ \ \
[返回/@main]

;==============================================
;强行
[@fUnMaster]
#if
checkitem 金条 1
havemaster
#act
take 金条 1
unmaster requestunmaster force
#elsesay
要收一根金条的手续费，你没有金条，\
<确定/@exit>
;==============================================
;完成后的提示信息
[@UnMasterEnd]
呵呵，你已经脱


刷新包裹的命令

功能：
增加刷新包裹物品命令：RefreshBag 刷新包裹时间间隔以引擎（功能设置-其他控制）设置为准，可以做个空技能触发

示例：

[@GroupAttrib]
我要刷新包裹：\
<刷新/@GroupAttrib5>\ \
<退出/@exit>

[@GroupAttrib5]

#IF
#ACT
RefreshBag

MESSAGEBOX 刷新包裹成功！
CLOSE
#ELSEACT

[@GroupAttrib6]

#IF
#ACT
H.RefreshBag

MESSAGEBOX 英雄刷新包裹成功！
CLOSE
#ELSEACT


挑战功能

说明:没有等级限制,只在双方面对面,即可挑战,挑战时间5分钟,在挑战时间内没有分出胜负的,直接随机传送.
     增加地图参数 FIGHT4 (挑战地图),此参数禁止召唤英雄,死亡不掉落物品,不增加PK值.
     M2\查看\列表信息 中可设置禁止挑战的物品.
     挑战时双方都不可以使用英雄,所有药品
     挑战胜,所有之前押的物品归胜方所有

相关脚本命令:
功能:移动到挑战地图
格式:CHALLENGMAPMOVE 地图名 X Y

功能:没有挑战地图可移动,则退回抵押的物品
格式:GETCHALLENGEBAKITEM

//----------------------------------------------------------------------
QFunction-0.txt 文件

[@Challenge]
#IF
CHECKMAPHUMANCOUNT EM029A = 0
#ACT
CHALLENGMAPMOVE EM029A 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029B = 0
#ACT
CHALLENGMAPMOVE EM029B 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029C = 0
#ACT
CHALLENGMAPMOVE EM029C 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029D = 0
#ACT
CHALLENGMAPMOVE EM029D 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029E = 0
#ACT
CHALLENGMAPMOVE EM029E 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029F = 0
#ACT
CHALLENGMAPMOVE EM029F 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029G = 0
#ACT
BREAK
CHALLENGMAPMOVE EM029G 14 15
#IF
CHECKMAPHUMANCOUNT EM029H = 0
#ACT
CHALLENGMAPMOVE EM029H 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029I = 0
#ACT
CHALLENGMAPMOVE EM029I 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029J = 0
#ACT
CHALLENGMAPMOVE EM029J 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029K = 0
#ACT
CHALLENGMAPMOVE EM029K 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029L = 0
#ACT
CHALLENGMAPMOVE EM029L 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029M = 0
#ACT
CHALLENGMAPMOVE EM029M 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029N = 0
#ACT
CHALLENGMAPMOVE EM029N 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029O = 0
#ACT
CHALLENGMAPMOVE EM029O 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029P = 0
#ACT
CHALLENGMAPMOVE EM029P 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029Q = 0
#ACT
CHALLENGMAPMOVE EM029Q 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029R = 0
#ACT
CHALLENGMAPMOVE EM029R 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029S = 0
#ACT
CHALLENGMAPMOVE EM029S 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029T = 0
#ACT
CHALLENGMAPMOVE EM029T 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029U = 0
#ACT
CHALLENGMAPMOVE EM029U 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029V = 0
#ACT
CHALLENGMAPMOVE EM029V 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029W = 0
#ACT
CHALLENGMAPMOVE EM029W 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029X = 0
#ACT
CHALLENGMAPMOVE EM029X 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029Y = 0
#ACT
CHALLENGMAPMOVE EM029Y 14 15
BREAK
#IF
CHECKMAPHUMANCOUNT EM029Z = 0
#ACT
CHALLENGMAPMOVE EM029Z 14 15
BREAK
#IF
#ACT
goto @Challenge_Fail

[@Challenge_Fail]
#IF
#ACT
GETCHALLENGEBAKITEM
#SAY
当前地图人数已经满员!请稍后再试,谢谢!\

;挑战胜利者执行..
[@Challenge_Win]
#IF
#ACT
SendMsg 5 挑战胜利..
-------------------------------------------------------------------------------
MapInfo.txt文件

[EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029A|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029B|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029C|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029D|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029E|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029F|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029G|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029H|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG
[EM029I|EM029 挑战] NORECALL NOGUILDRECALL NODEARRECALL NOMasterRECALL NORANDOMMOVE RUNHUMAN NORECONNECT(0159) FIGHT4 NODRUG


跳转，延迟

DELAYGOTO 时间(毫秒) 触发字段 换地图是否删除此延时(0或为空时=不删除 1=删除)

DELAYGOTO 20 @火龙珠 表示20毫秒

实例：
----------------------------------------------------------------------------

[@main]
<延迟跳转/@DelayGoto> <清除延迟/@ClearDelayGoto> <得到物品/@giveonground>\ \
<返回/@main>
[@giveonground]
#if
#act
GIVEONGROUND 屠龙 5
[@DelayGoto]
#if
#act
DELAYGOTO 3 @DelayLabel
#say
<清除延迟/@ClearDelayGoto>
[@DelayLabel]
#say
延迟跳转测试成功！\ \
<返回/@next>
[@ClearDelayGoto]
#if
#act
CLEARDELAYGOTO
#say
延迟跳转已清除.\ \
<返回/@next>

------------------------------------------------------------------------;


屏幕显示信息分个人和全局

文字向上缓消模式SuperMoveMsg 信息类型代码(0-7)0全局发送1发送给个人 字体颜色(0-255) 背景颜色(0-255) 字体大小 Y坐标 滚动次数 信息内容 | 换行符号 范围

示列：

#if
#act
SuperMoveMsg 1 251 0 20 100 3 这个是个人屏幕信息~坐标在100|欢迎使用翎风引擎|引擎官方网站：|http://www.lfm2.com

#if
#act
SuperMoveMsg 0 251 0 20 200 5 这个是全局屏幕信息~坐标在200|欢迎使用翎风引擎|引擎官方网站：|http://www.lfm2.com

#if
#act
SuperMoveMsg 1 251 0 20 100 3 这个是{个人|253:0:1}屏幕信息~坐标在100，<Text:文字内容{FCOLOR=250;FSIZE=14;FNAME=黑体}>||图片数字测试<ImgNum:9:1234333:-3:0:0>看看效果|| 引擎官方网站：||http://www.lfm2.com

==========================================================================================================================================================

发送模式取值:
0: 所有在线人物
1：自己
2：对友(包含自己)； 范围=0；所有对友； 范围>0；在自己范围之内的队友
3: 行会所有成员(包含自己)； 范围=0；行会所有成员； 范围>0；在自己范围之内的行会成员
4: 同一地图所有人物(包含自己)； 范围=0；同一地图所有人物； 范围>0；在自己范围之内的人物
5: 对友(不包含自己)； 范围=0；所有对友； 范围>0；在自己范围之内的队友
6: 行会所有成员(不包含自己)； 范围=0；行会所有成员； 范围>0；在自己范围之内的行会成员
7: 同一地图所有人物(不包含自己)； 范围=0；同一地图所有人物； 范围>0；在自己范围之内的人物
8: 国家模式，仅对自己的国家成员

==========================================================================================================================================================

// 脚本命令：SendNewLineMsg 信息类型代码(0-7)0全局发送1发送给个人 字体颜色(0-255) 背景颜色(0-255) 字体大小 Y坐标 显示时间 绘制方式(0-2)0带透明框绘制 1淡入淡出绘制 2不带透明框绘制 信息内容|换行符号 范围

调用示例：

[@SuperMOVEMSG2]
#IF
#ACT
SendNewLineMsg 0 251 0 15 100 10 2 带透明框绘制测试|欢迎使用翎风引擎|官方网站：www.lfm2.com
break

[@SuperMOVEMSG0]
#IF
#ACT
SendNewLineMsg 0 251 0 15 100 10 0 带透明框绘制测试|欢迎使用翎风引擎|官方网站：www.lfm2.com
break

[@SuperMOVEMSG1]
#IF
#ACT
SendNewLineMsg 0 251 0 15 100 10 1 淡入淡出绘制测试|欢迎使用翎风引擎|官方网站：www.lfm2.com
break

[@SuperMOVEMSG3]
#IF
#ACT
SendNewLineMsg 0 251 0 15 100 10 0 图片数字测试<ImgNum:9:1234:-3:0:0>看看效果||这是一段自定义文字：<Text:文字内容{FCOLOR=250;FSIZE=20;FNAME=黑体}>：测试下||官方网站：www.lfm2.com

发送模式取值:
0: 所有在线人物
1：自己
2：对友(包含自己)； 范围=0；所有对友； 范围>0；在自己范围之内的队友
3: 行会所有成员(包含自己)； 范围=0；行会所有成员； 范围>0；在自己范围之内的行会成员
4: 同一地图所有人物(包含自己)； 范围=0；同一地图所有人物； 范围>0；在自己范围之内的人物
5: 对友(不包含自己)； 范围=0；所有对友； 范围>0；在自己范围之内的队友
6: 行会所有成员(不包含自己)； 范围=0；行会所有成员； 范围>0；在自己范围之内的行会成员
7: 同一地图所有人物(不包含自己)； 范围=0；同一地图所有人物； 范围>0；在自己范围之内的人物
8: 国家模式，仅对自己的国家成员


新增触发

以下QFunction-0.txt触发为2013年10月28号后增加的，为方面大家查找触发命令特保存在本页！！！

;沙巴克丢失仅掌门人（行会老大）触发：@LostCastle
;沙巴克占领仅掌门人（行会老大）触发：@GetCastle
;沙巴克被占领触发
[@GetCastle]
#IF
#Act
#SAY
break
沙巴克被占领!

;沙巴克被别人占领触发
[@LostCastle]
#IF
#Act
SENDMSG 0 提示：沙巴克老大<$USERNAME>要换人了

;以下为占领沙巴克和丢失沙巴克行会所有在线成员都触发（包括行会老大），和上面的仅掌门人触发按需使用

;---------------------------------------------------
;沙巴克丢失全员触发：@LostCastleEx
;沙巴克占领全员触发：@GetCastleEx
[@LostCastleEx]
#ACT
SENDMSG 5 你所在的行会丢失沙巴克

[@GetCastleEx]
#ACT
SENDMSG 5 你所在的行会已占领沙巴克

;---------------------------------------------------
;创建行会触发
[@CreateGuild]
#IF
#ACT
break
#SAY
行会已经创建!

;退出行会触发
[@exitGuild]
#IF
#SAY
你已经从行会中退出!
;---------------------------------------------------

出师触发 QFunction-0.txt
[@UnMasterEnd]
#IF
#ACT
SENDMSG 6 提示：师傅触发！

[@UnMasterEnd1]
#IF
#ACT
SENDMSG 6 提示：徒弟触发！

QF触发强制(脱离师徒)出师：
@ForceUnMasterEnd 师傅触发
@ForceUnMasterEnd1 徒弟触发

---------------------------------------------------

挂机触发 QFunction-0.txt
[@StartAutoOnline]
#IF
#ACT
SENDMSG 6 提示：开始挂机！

[@StopAutoOnline]
#IF
#ACT
SENDMSG 6 提示：停止挂机！

---------------------------------------------------

20170407增加加入行会触发

[@JoinGuild]
#IF
#Act
SENDMSG 6 你已经加入了<$GUILDNAME>行会！
SendCenterMsg 180 251你已经加入了<$GUILDNAME>行会 0 30

陆续增加中...........


新转职业变性脚本

最新转职业脚本变性(含英雄转职和清理合击技能)

[@变性转职]
{
欢迎你光临：<$SERVERNAME>\ \
你是否对自己的英雄职业不满意？是的，我想<变更英雄职业/@变更英雄职业>\ \
你是否对现在的职业已经厌烦？ 是的，我想<变更职业/@职业变更>\ \
你是否想尝试做异性的滋味？ 是的，我想<变更性别/@性别变更>\ \
                                           <版权所有/@1>:翎风引擎\

[@性别变更]
#IF
gender man
#SAY
是不是做猛男没什么意思呀，想不想尝尝做淑女的滋味呀！！！\ \
『<尝尝/@towoman>』\ \
〖<返回/@main>〗 〖<关闭/@exit>〗
#ELSESAY
是不是做淑女挺累的，想不想尝尝做猛男的滋味呀！！！\ \
『<尝尝/@toman>』\ \
〖<返回/@main>〗 〖<关闭/@exit>〗

[@toman]
#IF
CHECKGAMEGOLD > 19
#ACT
GAMEGOLD - 20
CHANGEGENDER 0
#SAY
呵呵，你已经变成一位猛男了。\ \
<返回/@main>
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足20颗。

[@towoman]
#IF
CHECKGAMEGOLD > 19
#ACT
GAMEGOLD - 20
CHANGEGENDER 1
#SAY
呵呵，你已经变成一位淑女了。\ \
〖<返回/@main>〗 〖<关闭/@exit>〗
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足20颗。

[@职业变更]
#IF
CHECKJOB warrior
#SAY
是不是战士不好玩呀，换换别的职业试试吧！\ \
『<玩玩法师/@法师>』\
『<玩玩道士/@道士>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
CHECKJOB wizard
#SAY
是不是法师不好玩呀，换换别的职业试试吧！\ \
『<玩玩战士/@战士>』\
『<玩玩道士/@道士>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
CHECKJOB taoist
#SAY
是不是道士不好玩呀，换换别的职业试试吧！\ \
『<玩玩战士/@战士>』\
『<玩玩法师/@法师>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break

[@战士]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
CLEARSKILL
CHANGEJOB warrior
ADDSKILL 基本剑术
ADDSKILL 攻杀剑术
ADDSKILL 刺杀剑术
ADDSKILL 半月弯刀
ADDSKILL 野蛮冲撞
ADDSKILL 烈火剑法
ADDSKILL 狮子吼
SKILLLEVEL 基本剑术 + 3
SKILLLEVEL 攻杀剑术 + 3
SKILLLEVEL 刺杀剑术 + 3
SKILLLEVEL 半月弯刀 + 3
SKILLLEVEL 野蛮冲撞 + 3
SKILLLEVEL 烈火剑法 + 3
SKILLLEVEL 狮子吼 + 3
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@法师]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
CLEARSKILL
CHANGEJOB WIZARD
ADDSKILL 火球术
ADDSKILL 大火球
ADDSKILL 抗拒火环
ADDSKILL 地狱火
ADDSKILL 雷电术
ADDSKILL 疾光电影
ADDSKILL 诱惑之光
ADDSKILL 瞬息移动
ADDSKILL 火墙
ADDSKILL 爆裂火焰
ADDSKILL 地狱雷光
ADDSKILL 魔法盾
ADDSKILL 圣言术
ADDSKILL 冰咆哮
ADDSKILL 寒冰掌
ADDSKILL 灭天火
SKILLLEVEL 火球术 + 3
SKILLLEVEL 大火球 + 3
SKILLLEVEL 抗拒火环 + 3
SKILLLEVEL 地狱火 + 3
SKILLLEVEL 雷电术 + 3
SKILLLEVEL 疾光电影 + 3
SKILLLEVEL 诱惑之光 + 3
SKILLLEVEL 瞬息移动 + 3
SKILLLEVEL 火墙 + 3
SKILLLEVEL 爆裂火焰 + 3
SKILLLEVEL 地狱雷光 + 3
SKILLLEVEL 魔法盾 + 3
SKILLLEVEL 圣言术 + 3
SKILLLEVEL 冰咆哮 + 3
SKILLLEVEL 寒冰掌 + 3
SKILLLEVEL 灭天火 + 3
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@道士]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
CLEARSKILL
CHANGEJOB taoist
ADDSKILL 治愈术
ADDSKILL 精神力战法
ADDSKILL 施毒术
ADDSKILL 灵魂火符
ADDSKILL 幽灵盾
ADDSKILL 神圣战甲术
ADDSKILL 困魔咒
ADDSKILL 召唤骷髅
ADDSKILL 隐身术
ADDSKILL 集体隐身术
ADDSKILL 心灵启示
ADDSKILL 群体治疗术
ADDSKILL 召唤神兽
ADDSKILL 气功波
ADDSKILL 无极真气
SKILLLEVEL 治愈术 + 3
SKILLLEVEL 精神力战法 + 3
SKILLLEVEL 施毒术 + 3
SKILLLEVEL 灵魂火符 + 3
SKILLLEVEL 幽灵盾 + 3
SKILLLEVEL 神圣战甲术 + 3
SKILLLEVEL 困魔咒 + 3
SKILLLEVEL 召唤骷髅 + 3
SKILLLEVEL 隐身术 + 3
SKILLLEVEL 集体隐身术 + 3
SKILLLEVEL 心灵启示 + 3
SKILLLEVEL 群体治疗术 + 3
SKILLLEVEL 召唤神兽 + 3
SKILLLEVEL 气功波 + 3
SKILLLEVEL 无极真气 + 3
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@变更英雄职业]
想把你的英雄变更为其它职业的英雄？\
只要你交纳50颗元宝，我即可将你的英雄成功转职。\
但是合击技能将会被删除，只给予新职业的部分技能、\
是否同意将英雄转职呢？\

<我同意将英雄转职业/@同意英雄转职>\

[@同意英雄转职]
#IF
CheckHaveHero
#ELSEACT
MESSAGEBOX 对不起，您没有英雄！
BREAK

#IF
H.CHECKONLINE
#ELSEACT
MESSAGEBOX 对不起，您的英雄不在线！
BREAK

#IF
CHECKGAMEGOLD > 49
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

#IF
H.CHECKJOB warrior
#SAY
是不是战士英雄不好玩呀，换换别的英雄试试吧！\ \
『<玩玩法师英雄/@法师英雄>』\
『<玩玩道士英雄/@道士英雄>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
H.CHECKJOB wizard
#SAY
是不是法师英雄不好玩呀，换换别的英雄试试吧！\ \
『<玩玩战士英雄/@战士英雄>』\
『<玩玩道士英雄/@道士英雄>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
H.CHECKJOB taoist
#SAY
是不是道士英雄不好玩呀，换换别的英雄试试吧！\ \
『<玩玩战士英雄/@战士英雄>』\
『<玩玩法师英雄/@法师英雄>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break

[@战士英雄]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
H.CLEARSKILL
H.CHANGEJOB warrior
H.ADDSKILL 英雄基本剑术 1
H.ADDSKILL 英雄攻杀剑术 1
H.ADDSKILL 英雄刺杀剑术 1
H.ADDSKILL 英雄半月弯刀 1
H.ADDSKILL 英雄野蛮冲撞 1
H.ADDSKILL 英雄烈火剑法 1
H.ADDSKILL 英雄狮子吼 1
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功将英雄转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@法师英雄]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
H.CLEARSKILL
H.CHANGEJOB WIZARD
H.ADDSKILL 英雄火球术 1
H.ADDSKILL 英雄大火球 1
H.ADDSKILL 英雄抗拒火环 1
H.ADDSKILL 英雄地狱火 1
H.ADDSKILL 英雄疾光电影 1
H.ADDSKILL 英雄雷电术 1
H.ADDSKILL 英雄诱惑之光 1
H.ADDSKILL 英雄瞬息移动 1
H.ADDSKILL 英雄火墙 1
H.ADDSKILL 英雄爆裂火焰 1
H.ADDSKILL 英雄地狱雷光 1
H.ADDSKILL 英雄魔法盾 1
H.ADDSKILL 英雄圣言术 1
H.ADDSKILL 英雄冰咆哮 1
H.ADDSKILL 英雄灭天火 1
H.ADDSKILL 英雄寒冰掌 1
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功将英雄转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK

[@道士英雄]
#IF
CHECKGAMEGOLD > 49
#ACT
GAMEGOLD - 50
H.CLEARSKILL
H.CHANGEJOB taoist
H.ADDSKILL 英雄神圣战术 1
H.ADDSKILL 英雄群疗术 1
H.ADDSKILL 英雄集体隐身 1
H.ADDSKILL 英雄精神战法 1
H.ADDSKILL 英雄施毒术 1
H.ADDSKILL 英雄召唤骷髅 1
H.ADDSKILL 英雄召唤神兽 1
H.ADDSKILL 英雄灵魂火符 1
H.ADDSKILL 英雄隐身术 1
H.ADDSKILL 英雄幽灵盾 1
H.ADDSKILL 英雄治愈术 1
H.ADDSKILL 英雄困魔咒 1
H.ADDSKILL 英雄心灵启示 1
H.ADDSKILL 英雄气功波 1
H.ADDSKILL 英雄无极真气 1
SENDMSG 0 恭喜:玩家「<$USERNAME>」成功将英雄转职。
#ELSEACT
MESSAGEBOX 对不起，您的元宝已经不足50颗。
BREAK
}

QManage.txt里的配置脚本

[@HeroLogin]
#if
H.CHECKNAMELIST ..\QuestDiary\数据文件\英雄名单.txt
#act
H.DELSKILL 破魂斩
H.DELSKILL 劈星斩
H.DELSKILL 雷霆一击
H.DELSKILL 噬魂沼泽
H.DELSKILL 末日审判
H.DELSKILL 火龙气焰
H.delnamelist ..\QuestDiary\数据文件\英雄名单.txt
#IF
H.ISNEWHUMAN
H.gender man
CHECKHEROJOB WIZARD
#ACT
CHANGEHEROLEVEL = 35
H.ADDSKILL 英雄先天元力
H.ADDSKILL 英雄酒气护体
H.give 恶魔长袍(男) 1
H.give 骨玉权杖 1
H.TakeOnitem 骨玉权杖 1
H.TakeOnitem 恶魔长袍(男) 0
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
CHECKHEROJOB WIZARD
#ACT
CHANGEHEROLEVEL = 35
H.ADDSKILL 英雄先天元力
H.ADDSKILL 英雄酒气护体
H.give 恶魔长袍(女) 1
H.give 骨玉权杖 1
H.TakeOnitem 骨玉权杖 1
H.TakeOnitem 恶魔长袍(女) 0
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender man
CHECKHEROJOB WARRIOR
#ACT
CHANGEHEROLEVEL = 35
H.ADDSKILL 英雄先天元力
H.ADDSKILL 英雄酒气护体
H.give 战神盔甲(男) 1
H.give 裁决之杖 1
H.TakeOnitem 战神盔甲(男) 0
H.TakeOnitem 裁决之杖 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
CHECKHEROJOB WARRIOR
#ACT
CHANGEHEROLEVEL = 35
H.ADDSKILL 英雄先天元力
H.ADDSKILL 英雄酒气护体
H.give 战神盔甲(女) 1
H.give 裁决之杖 1
H.TakeOnitem 战神盔甲(女) 0
H.TakeOnitem 裁决之杖 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender man
CHECKHEROJOB TAOIST
#ACT
CHANGEHEROLEVEL = 35
H.ADDSKILL 英雄先天元力
H.ADDSKILL 英雄酒气护体
H.give 幽灵战衣(男) 1
H.give 龙纹剑 1
H.TakeOnitem 幽灵战衣(男) 0
H.TakeOnitem 龙纹剑 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
CHECKHEROJOB TAOIST
#ACT
CHANGEHEROLEVEL = 35
H.ADDSKILL 英雄先天元力
H.ADDSKILL 英雄酒气护体
H.give 幽灵战衣(女) 1
H.give 龙纹剑 1
H.TakeOnitem 幽灵战衣(女) 0
H.TakeOnitem 龙纹剑 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break


修改怪物颜色[!]

功能：
修改怪物身体颜色.

说明：SetMonColor 地图名 怪物名 颜色(1~255) 时间(秒) 类型（0、1） 时间设置0则为不计算有效时间永久有效

示列：

[@SetMonColor]
#IF
CheckMapSameMonCount D2083 火龙教主 > 0
#ACT
SetMonColor D2083 火龙教主 151 0 1
SendMsg 5 D2083地图的火龙教主已经修改为七彩变色！

[@SetMonColor1]
#IF
CheckMapSameMonCount D2083 火龙教主 > 0
#ACT
SetMonColor D2083 火龙教主 151 0 0
SendMsg 5 D2083地图的火龙教主已经修改为黄色！

;---------------------------------------------------

请尽量不要在刷怪触发中使用怪物身体改色，特别是刷怪数量很多时触发
因为刷怪中写SetMonColor，该命令是对地图中很大一块区域进行的怪物进行操作，每刷一个怪就在遍历地图很大一块区域，效率低
如果需要可以考虑使用M.SetBodyColor

注：如内挂设置BOSS身体变色则以内挂设置为准


修改人体颜色,改变人体颜色

功能：
修改人体颜色.

说明：SetBodyColor 颜色(1~255) 时间(秒) 类型（0、1） 【时间设置为0则为无限制，类型0或留空为 指定颜色 。1则为转生设置的颜色在人物身体上进行变色】

示列：

[@SetBodyColor]
#IF
#ACT
SetBodyColor 151 120 0
SendMsg 5 你身体颜色更改为黄色，有效时间120秒！

[@SetBodyColor1]
#IF
#ACT
SetBodyColor 151 120 1
SendMsg 5 你身体颜色更改为七彩变色，有效时间120秒！

[@SetBodyColor2]
#IF
#ACT
SetBodyColor 151 0 1
SendMsg 5 你身体颜色更改为七彩变色，时间为在线永久有效！

[@SetBodyColor2]
#IF
#ACT
H.SetBodyColor 151 0 1
SendMsg 5 你英雄的身体颜色更改为七彩变色，时间为在线永久有效！


悬浮式装备信息窗口支持图片显示

物品备注悬浮式装备信息窗口支持图片显示(可使用到物品备注、套装备注)：

物品备注示例：
宝藏钥匙=250/<looks:1184>可用来开启卧龙山庄中的“神秘宝藏”\253/直接获得其中的宝物
火龙神甲=250/<StateItem:595>可用来开启卧龙山庄中的“神秘宝藏”\253/直接获得其中的宝物
文字均支持单行文字颜色自定义 插入：{文字内容|文字颜色0-255} 如：宝藏钥匙=250/<looks:1184<可用来开启{卧龙山庄|251}中的“神秘宝藏”\253/直接获得其中的宝物

.

支持以下方式展示：

1、Looks支持：读取Items或Items1.....
格式：<looks:N:X:Y:Z>
说明：N=图片位置；X=X偏移；Y=Y偏移 Z=是否显示物品背景框(0,1)
<looks:1184:0:0:1>

2、NewopUI支持；读取NewopUI.pak
格式：<NewopUI:N:X:Y>
说明：N=图片位置；X=X偏移；Y=Y偏移
<NewopUI:1184:0:0>

3、Img支持
格式：<Img:N:F:X:Y>
N表示显示文件中的第几个图片,F表示WIL文件序号,X是横向坐标,Y是纵向坐标.
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
X和Y这两个坐标可以使图片显示的坐标更加精准.
<Img:1:1:0:0>

4、PlayImg支持
格式: <PlayImg:F:N:C:T:X:Y:M>
F表示WIL文件序号,N表示播放开始图片,C表示播放张数,T表示播放速度(毫秒),X是横向坐标,Y是纵向坐标.
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
X和Y这两个坐标可以使图片显示的坐标更加精准.
M：绘制模式（0:原始绘制; 1:透明绘制; 2:底层原始绘制;3:底层透明绘制)

5、悬浮框物品备注属性栏将数字转换为图片

装备栏提示 ( 没有 提示信息/@脚本触发)
<ImgNum: 数字类型(0-9): 数字值: 字符间隔: X: Y>
图片位置：NewopUI.pak 1230开始---1329结束 （10组数字）


循环脚本

[@MAIN]
<111/@111> <222/@222> <$STR(N1)>

; ******************************************尽可能不要用这种写法，递归调用容易产生栈溢出
[@111]
#IF
SMALL N1 2000
#ACT
Inc N1 1
SendMsg 6 > $STR(N1)>
GOTO @111
BREAK
;这种脚本递归调用产生的 Stack overflow，堆栈溢出，递归层次多时有可能产生这样的问题。换成新的写法，用 while / endwhile

; ★★★★★★★★★★★★★★★★★★★★★★★★★★★★★★★★推荐这种写法
[@222]
#IF
#ACT
;为方便测试每次执行脚本前将变量设置为1，本示例脚本可无视MOV
;MOV N1 1
;循环开始，While 变量/值 比较符号(> < =) 变量/值；循环写在 #ACT中
While N1 < 1000
SendMsg 6 <$STR(N1)>
Inc N1 1
EndWhile
;循环结束 EndWhile
SendMsg 6 aaaaaa


烟花脚本实例[!]

数据库设置

一心一意;2;1;1;79;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
心心相印;2;1;1;80;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
飞火流星;2;1;1;81;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
浪漫星雨;2;1;1;82;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
绮梦幻想;2;1;1;83;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
如梦似雾;2;1;1;84;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
长空火舞;2;1;1;85;0;0;1016;10000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;
庆典蛋糕;2;1;1;86;0;0;1001;5000;0;0;0;0;0;0;0;0;0;0;0;0;50000;5;255;0;99;

SHOWEFFECT 类型(79~86)

这个范例支持持久就是次数10次。不想支持次数把类型2修改为31即可。

QFunction-0 下增加如下：

[@StdModeFunc79]
#IF
#ACT
Gmexecute showeffect 79
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc80]
#IF
#ACT
Gmexecute showeffect 80
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc81]
#IF
#ACT
Gmexecute showeffect 81
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc82]
#IF
#ACT
Gmexecute showeffect 82
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc83]
#IF
#ACT
Gmexecute showeffect 83
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc84]
#IF
#ACT
Gmexecute showeffect 84
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc85]
#IF
#ACT
Gmexecute showeffect 85
SENDMSG 0 <$USERNAME>在:%m%x:%y处放烟花咯、大家快去欣赏哦。

[@StdModeFunc86]
#IF
#ACT
Gmexecute showeffect 86
SENDMSG 0 <$USERNAME>在:%m%x:%y处放庆典蛋糕了!大家快去看拉


一键回收包裹物品[!]

一键回收包裹物品的脚本命令
格式：
TakeBagItem 物品名称(支持多个物品) 收取数量 增加元宝值 增加金币值 增加泡点值 增加经验值 变量(保存实际回收的物品数量) 聚灵珠经验(为空或0时不增加聚灵珠经验 1时同时聚灵珠经验) 是否显示提示信息(0或空：显示；1：不显示） 颜色值(空或*回收所有；0-255回收对应颜色物品,支持多个颜色值) 是否回收极品(为空或0回收；1不回收）是否回收改名(0或空回收;1不回收) 回收指定等级以下物品（0或空不限等级）

[@main]
#ACT
;分别为不区分颜色，回收指定物品指定颜色
TakeBagItem 木剑|布衣(男)|布衣(女) 46 0 0 0 10000 N1 0
;TakeBagItem 木剑|布衣(男)|布衣(女) 46 0 0 0 10000 N1 0 0 255|243|253|251
;TakeBagItem 木剑|布衣(男)|布衣(女) 46 0 0 0 10000 N1 0 0 251
SENDMSG 6 成功回收<$STR(N1)>个木剑，布衣(男)，布衣(女)，价格为10000经验

----------------------------------------------------------------------------------
回收命令增加支持物品名字变量操作：
TakeBagItem <$STR(S99)> 46 0 1000 0 0 N99 0

[@dddd]
#act
GetListString ..\QuestDiary\装备.txt 0 S1
TakeBagItem <$STR(S1)> 46 0 1000 0 0 N99 0
sendmsg 6 回收<$STR(n99)> 个物品

装备.TXT内容
力量戒指|紫碧螺|泰坦戒指|骑士手镯|龙之手镯|心灵手镯|阎罗手套|裁决之杖

下载更为详细的回收脚本进行参考：

点击下载回收脚本

######################################2019-03新增按照数据库IDX进行回收，支持多个编号回收################################

增加TakeBagItemex命令用于回收指定物品数据库IDX物品

;回收多个物品，编号之间用|分隔 支持多个连续的物品编号
TakeBagItemEx 物品编号 收取数量 增加元宝值 增加金币值 增加泡点值 增加经验值 变量(保存实际回收的物品数量) 聚灵珠经验(为空或0时不增加聚灵珠经验；1时同时聚灵珠经验) 是否显示提示信息(为空或0显示；1不显示） 颜色值(空或*回收所有；0-255回收对应颜色物品,支持多个颜色值) 回收极品(为空或0回收；1不回收）
TakeBagItemex 55|60-65|70|100-120|155 46 0 0 0 10000 N1 0
SENDMSG 6 成功回收<$STR(N1)>个物品，价格为10000经验

######################################新增按照数据库Color颜色值进行回收，支持多个编号回收################################

;回收多个物品，颜色之间用|分隔 支持多个连续的物品颜色
;格式：TakeBagItemColor 物品颜色 收取数量 增加元宝值 增加金币值 增加泡点值 增加经验值 变量(保存实际回收的物品数量) 聚灵珠经验(为空或0时不增加聚灵珠经验；1时同时聚灵珠经验) 是否显示提示信息(为空或0显示；1不显示）是否回收极品(为空或0回收；1不回收）
TakeBagItemColor 55|60-65|70|100-120|155 46 0 0 0 10000 N1 0
SENDMSG 6 按照物品颜色成功回收<$STR(N1)>个物品，价格为10000经验

回收英雄背包物品命令前加H. 比如：H.TakeBagItem ，参数相同，回收受益人为主人

*回收价格为单件物品价格，如设置元宝回收价格10，为单件物品回收可获得10元宝...


英雄攻击触发

 英雄攻击触发：

[@HeroMagicStruck]
[@HeroMagicAttack]
[@HeroStruck]
[@HeroAttack]

QFunction-0

;所有触发只有攻击到怪物才会触发，有些魔法不会触发，如魔法盾

;======================被魔法攻击触发==========================
[@HeroMagicStruck]
#IF
H.CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你的英雄被人物【<$H.CURRRTARGETNAME>】攻击了。使用魔法ID=<$H.CURRRUSEMAGICID> 255 253
BREAK

#IF
H.CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你的英雄被英雄【<$H.CURRRTARGETNAME>】攻击了。使用魔法ID=<$H.CURRRUSEMAGICID> 255 253
BREAK

#IF
H.CHECKCURRTARGETRACE = 151
#ACT
SENDMSG 6 你的英雄被分身【<$H.CURRRTARGETNAME>】攻击了。使用魔法ID=<$H.CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你的英雄被怪物【<$H.CURRRTARGETNAME>】攻击了。使用魔法ID=<$H.CURRRUSEMAGICID> 255 253
BREAK

;======================魔法攻击触发==========================
[@HeroMagicAttack]
#IF
H.CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你的英雄攻击了人物【<$H.CURRRTARGETNAME>】。使用魔法ID=<$H.CURRRUSEMAGICID> 255 249
BREAK

#IF
H.CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你的英雄攻击了英雄【<$H.CURRRTARGETNAME>】。使用魔法ID=<$H.CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你的英雄攻击了怪物【<$H.CURRRTARGETNAME>】。使用魔法ID=<$H.CURRRUSEMAGICID> 255 249
BREAK

;======================被物理攻击触发==========================
[@HeroStruck]
#IF
H.CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你的英雄被人物【<$H.CURRRTARGETNAME>】攻击了。使用魔法ID=<$H.CURRRUSEMAGICID> 255 253
BREAK

#IF
H.CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你的英雄被英雄【<$H.CURRRTARGETNAME>】攻击了。使用魔法ID=<$H.CURRRUSEMAGICID> 255 253
BREAK

#IF
H.CHECKCURRTARGETRACE = 151
#ACT
SENDMSG 6 你的英雄被分身【<$H.CURRRTARGETNAME>】攻击了。使用魔法ID=<$H.CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你的英雄被怪物【<$H.CURRRTARGETNAME>】攻击了。使用魔法ID=<$H.CURRRUSEMAGICID> 255 253
BREAK

;======================物理攻击触发==========================
[@HeroAttack]
#IF
H.CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你的英雄攻击了人物【<$H.CURRRTARGETNAME>】。使用魔法ID=<$H.CURRRUSEMAGICID> 255 249
BREAK

#IF
H.CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你的英雄攻击了英雄【<$H.CURRRTARGETNAME>】。使用魔法ID=<$H.CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你的英雄攻击了怪物【<$H.CURRRTARGETNAME>】。使用魔法ID=<$H.CURRRUSEMAGICID> 255 249
BREAK

;======================下面变量获取怪物完整名字==========================

增加变量以显示完整名（不去数字）：$H.CURRRTARGETFULLNAME

上面演示脚本中变量不获取怪物名字后面的数字：$H.CURRRTARGETNAME

提供2种变量大家自己按需使用！


元宝转账

(@@dealgold)
[@main]
<进行元宝转账/@dealgamegold>\
<关闭/@exit>

[@dealgamegold]
#IF
#ACT
STARTTAKEGOLD

[@startdealgold]
#IF
#SAY
<$DEALGOLDPLAY>与你交易，请<输入转账/@@dealgold>数量\
<返回/@main>

[@dealgoldpost]
对不起,需要交易的人没站好位置！\
<返回/@main>

[@dealgoldFail]
对不起，你的元宝数量没有这么多！\
<返回/@exit>

[@dealgoldInputFail]
非法操作，交易失败！

[@dealgoldPlayError]
转账失败！


召唤某个玩家到自己身边

功能：
召唤某个玩家到自己身旁,此玩家必须在线

格式：
 RECALLHUMAN 人物名

;==========================================
[@Main]
#IF
#ACT
RECALLHUMAN 翎风引擎
#SAY
翎风引擎玩家已经到你身边了
;==========================================


召唤指定怪物为宝宝,脚本召唤宝宝

功能：
脚本召唤宝宝。

格式：
RecallMobEx 怪物名称 X坐标 Y坐标 等级 数量 叛变时间 颜色类型(0:固定颜色,1:自动变色) 颜色值(0-255;0不改变颜色)
攻击力受自动变色颜色不同而不同
固定颜色攻击力受指定颜色不同而不同

注：如设固定颜色，自动变色参数必须设置为0

;==========================================
;召唤最多5个七宝宝，30分钟后叛变,七彩变色
[@recallmobEX]
#IF
CHECKSLAVECOUNT < 5
#ACT
RECALLMOBEX 神兽 <$X> <$Y> 7 5 30 1
#SAY
好好看着自己的宝宝，不要乱咬人。
#ELSESAY
你已经有5个或以上的宝宝，现在不可以再召宝宝。


祝福语脚本

[@@SendMsg]
#if
checkgold?10000
#act
take 金币 10000
SETSENDMSGFLAG
#elsesay
穷鬼，一边站着。\ \
<返回/@main>

注：只能在普通NPC上发祝福语，国王系NPC将不能使用


转生触发

功能：
转生触发。

QFunction-0.txt如下：

[@PlayReNewLevel]
#act
SENDMSG 6 转生成功了
break

[@HeroReNewLevel]
#act
SENDMSG 6 英雄转生成功了
break


转职业变性脚本

[@SexJob]
请选择转换项目....\ \
『<转换性别/@ChangSex>』\
『<转换职业/@ChangJob>』\ \
〖<返回/@Main>〗 〖<关闭/@exit>〗

[@ChangSex]
如何你想换性别，这里提供转性别服务\
『<换性别/@ChangGender>』\ \
〖<返回/@MemberSexJob>〗 〖<关闭/@exit>〗

[@ChangGender]
#IF
gender man
#SAY
是不是做猛男没什么意思呀，想不想尝尝做淑女的滋味呀！！！\ \
『<尝尝/@towoman>』\ \
〖<返回/@ChangSex>〗 〖<关闭/@exit>〗
#ELSESAY
是不是做淑女挺累的，想不想尝尝做猛男的滋味呀！！！\ \
『<尝尝/@toman>』\ \
〖<返回/@ChangSex>〗 〖<关闭/@exit>〗
[@toman]
#IF
;CHECKLEVEL 50
#ACT
CHANGEGENDER 0
#SAY
呵呵，你已经变成一位猛男了。\ \
<返回/@MemberSexJob>
#ELSESAY
你未到50级不能转性别！！！
[@towoman]
#IF
;CHECKLEVEL 50
#ACT
CHANGEGENDER 1
#SAY
呵呵，你已经变成一位淑女了。\ \
〖<返回/@MemberSexJob>〗 〖<关闭/@exit>〗
#ELSESAY
你未到50级不能转性别！！！
;=========================================================================
[@changjob]
如何你想换一换职业，这里提供转职业服务，\
<注:>会员才能具有转职业的功能！！！\ \
『<换职业/@Chang>』\ \
〖<返回/@main>〗

[@Chang]
#IF
checkjob warrior
#SAY
是不是做武士不好玩呀，换换别的试试吧！\ \
『<玩玩法师/@ToWizard>』\
『<玩玩道士/@Totaos>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
checkjob wizard
#SAY
是不是做魔法师不好玩呀，换换别的试试吧！\ \
『<玩玩武士/@Towarr>』\
『<玩玩道士/@Totaos>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
#IF
checkjob taoist
#SAY
是不是做道士不好玩呀，换换别的试试吧！\ \
『<玩玩武士/@Towarr>』\
『<玩玩法师/@ToWizard>』\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#ACT
break
[@Towarr]
#if
#ACT
CHANGEJOB Warrior
#SAY
呵呵，你已经变成一位武士了。\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#elsesay
你不是会员！！！\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
[@ToWizard]
#if
#ACT
CHANGEJOB Wizard
#SAY
呵呵，你已经变成一位魔法师了。\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
#elsesay
你不是会员！！！\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗
[@Totaos]
#if
#ACT
CHANGEJOB Taoist
#SAY
呵呵，你已经变成一位道士了。\ \
〖<返回/@changjob>〗〖<关闭/@exit>〗


装备加速功能

功能：
自定义设置装备速度所需攻速减多少时间

说明：

位置于引擎-->客户端控制-->内挂控制-->速度控制

如：速度+减少攻击间隔设置30毫秒，那么没增加一个增加速度攻击间隔减少30MS（实际多少以调试为准）


装备名称自定义系统

功能： 装备名称自定义系统 格式：
例脚本：
(@@useitemname)
[@main]
\ 请选择要改名的装备：(将要改名的装备戴身上)\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
◇◇◇『<盔　甲/@@useitemname0>』◇◇◇『<武　器/@@useitemname1>』◇◇◇\
◇◇◇『<项　链/@@useitemname3>』◇◇◇『<头　盔/@@useitemname4>』◇◇◇\
◇◇◇『<左手镯/@@useitemname5>』◇◇◇『<右手镯/@@useitemname6>』◇◇◇\
◇◇◇『<左戒指/@@useitemname8>』◇◇◇『<右戒指/@@useitemname7>』◇◇◇\
◇◇◇『<勋 章/@@useitemname2>』\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
〖<返回/@main>〗 〖<关闭/@exit>〗\

[@@useitemname0]
#ACT goto @ChangeName
[@@useitemname1]
#ACT
goto @ChangeName
[@@useitemname2]
#ACT
goto @ChangeName
[@@useitemname3]
#ACT
goto @ChangeName
[@@useitemname4]
#ACT
goto @ChangeName
[@@useitemname5]
#ACT
goto @ChangeName
[@@useitemname6]
#ACT
goto @ChangeName
[@@useitemname7]
#ACT
goto @ChangeName
[@@useitemname8]
#ACT
goto @ChangeName
[@@useitemname9]
#ACT
goto @ChangeName
[@@useitemname10]
#ACT
goto @ChangeName
[@@useitemname11]
#ACT
goto @ChangeName
[@@useitemname12]
#ACT
goto @ChangeName

[@ChangeName]
#if
checkgamegold > 0
#act
SETSCRIPTFLAG 1 1
sendmsg 7 改名成功！！！
Close
#elseact
sendmsg 7 没钱跑来做什么？

;装备改名失败调用： @UseItemName_Fail，改名成功调用 @UseItemName_OK
[@UseItemName_Fail]
#if
#act
sendmsg 7 装备改名失败！名称中包含系统禁用字符！！
break

[@UseItemName_OK]
#if
#act
gamegold - 1
sendmsg 7 装备改名成功！！！
break

;如果使用了装备改名禁止字符功能请在脚本内增加成功和失败的脚本，方便退换失败后所扣除的物品..


自定义按钮倒计时触发

功能：
自定义按钮倒计时触发

格式：

命令参数：

SetClientBuff WIL文件序号 序号(1~200) 图片序号 倒计时间(-1时按钮，大于0是倒计时) X坐标 Y坐标 文字备注 (开启)
倒时触发[@CloseClientBuffX]X是序号。

CloseClientBuff 序号(1~200) (关闭命令)

------------------------------------

注：倒计时最长时间为2100000秒，-1为不显示倒计时！

--------------------------------------

增加隐藏/显示屏幕SetClientBuff图标

隐藏指定编号BUFF图标：
ShowClientBuff 1-200 显示/隐藏(1：显示；0隐藏）

隐藏所有编号BUFF图标：
ShowClientBuff 0 显示/隐藏(1：显示；0隐藏）

示例：
;隐藏所有BUFF图标
ShowClientBuff 0 0

;显示所有BUFF图标
ShowClientBuff 0 1

;隐藏编号5的BUFF图标
ShowClientBuff 5 0

;显示编号5的BUFF图标
ShowClientBuff 5 1

--------------------------------------图片点击触发（不管是否按钮模式还是倒计时模式都触发）：

SetClientBuff 支持1-200，点击触发：[@ClientBuffClickX] X表示序号;


自定义命令输入参数[!]

获取用户自定义命令输入参数<$PARAM(0)> <$PARAM(1)> <$PARAM(2)> <$PARAM(3)> <$PARAM(4)> <$PARAM(5)> <$PARAM(6)>

借用群里的范例 无测试 自己斟酌后在用

[@usercmd1]
#IF
checkGold 9999
#ACT
MOV N9 0
MOV S9
GOTO @字符过滤
#ELSEACT
SENDMSG SENDMSG 7 提示：您的金币不足1W。
BREAK

[@字符过滤]
#IF
checkcontainstext <$PARAM(1)> <$Str(S9)>
#ACT
SENDMSG 7 提示：该信息包含敏感字符
BREAK

#IF
LARGE N9 50
#ACT
TAKE 金币 10000
SendCenterMsg 180 251 <$USERNAME>:<$STR(S9)> 0 30
BREAK
#ELSEACT
getrandomtext .\..\..\..\RunGate\WordFilter.txt S9 <$Str(N9)>
INC N9 1
SENDMSG 6 现在N9=<$Str(N9)>, S9=<$Str(S9)>
GOTO @字符过滤


自动排列自定义按钮倒计时触发

-----------------------------------自动排列自定义按钮倒计时触发---------------------------

注：SetArrBuff (是不指定坐标，而指定分组的)具体参阅 引擎--选项-》客户端设置-》按钮自动排列
自动排列自定义按钮倒计时触发 SetArrBuff
;参数1：分组编号(1-7)
;参数2：按钮序号(1-200)
;参数3：WIL文件序号
;参数4：图片序号
;参数5：倒计时间(-1时按钮，大于0是倒计时)
;参数6：剩余下多时间开始闪烁
;参数7：闪烁图片开始序号
;参数8：闪烁图片数量
;参数9：文字备注
;参数10：倒计时间X坐标
;参数11：倒计时间Y坐标
;参数12：配合倒计时使用参数大于0参数13生效
;参数13：倒计结束后 图片序号

示例：
SetArrBuff 1 1 1 130 10 3 130 4 测试倒计时功能
SetArrBuff 1 2 1 130 100 10 130 4 测试倒计时功能
SetArrBuff 1 3 1 130 80 10 130 4 测试倒计时功能
SetArrBuff 1 4 1 130 60 10 130 4 测试倒计时功能
SetArrBuff 1 5 1 130 30 10 130 4 测试倒计时功能

按钮点击触发（按需使用，不需要点击则无法增加点击触发）
SetArrBuff 支持1-200，点击触发: [@ArrBuffClickX]X表示序号 (点击触发，不管是按钮还是倒计时都可以点击触发)

关闭命令：（具体使用参考原到计时命令SetClientBuff）
CloseArrBuff

隐藏/显示屏幕SetArrBuff图标命令 （（具体使用参考原到计时命令SetClientBuff））
ShowArrBuff

;QF触发 点击触发
[@ArrBuffClick1]
#act
sendmsg 7 自动排列按钮点击1

;QF触发 到时间触发
[@CloseArrBuff1]
#act
sendmsg 7 自动排列倒计时1关闭

[@CloseArrBuff2]
#act
sendmsg 7 自动排列倒计时2关闭

[@CloseArrBuff3]
#act
sendmsg 7 自动排列倒计时3关闭

[@CloseArrBuff4]
#act
sendmsg 7 自动排列倒计时4关闭

[@CloseArrBuff5]
#act
sendmsg 7 自动排列倒计时5关闭


不能自动解包

客户端自动解包配置，药品数据库的Anicount=打包物品的Shape，这样才可以自动解包
例如：
强效金创药 Anicount=100 超级金创药 Shape=100
疗伤药 Anicount=115 疗伤药包 Shape=115
回城卷 Anicount=108 回城卷包 Shape=108

支持2次打包
例如：
可以把“疗伤药包”再次打包
疗伤药包 Anicount=120 超级疗伤药包 Shape=120

解包配置文件 Envir\UnbindList.txt 格式，兼容旧格式，升级新M2如果不需要修改解包数量的，可以不修改Envir\UnbindList.txt：

;物品DB字段shape的值 物品名称 解包数量 物品类型(0其他,1加红,2加蓝,3加红蓝,4卷轴)

100 强效金创药 6 1
101 强效魔法药 6 2
119 强效太阳水 6 3
120 万年雪霜 6 3
102 金创药(小量) 6 1
103 魔法药(小量) 6 2
104 金创药(中量) 6 1
105 魔法药(中量) 6 2
106 地牢逃脱卷 6 4
107 随机传送卷 6 4
108 回城卷 6 4
109 行会回城卷 6 4

3.药品支持自动二次解包。(以下为参考数据库资料)

DB如下：
1383 超级金创药包 31 110 20 0 1 0 313 0 0 0 0 0 0 0 0 0 0 0 0 0 3000 5 255 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
189 超级金创药 31 100 20 110 1 0 1473 0 0 0 0 0 0 0 0 0 0 0 0 0 3000 5 255 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
175 强效金创药 0 0 3 100 0 0 28 10 180 0 0 0 0 0 0 0 0 0 0 0 150 5 255 0 0 0 0 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

UnbindList.txt
110 超级金创药 2
100 强效金创药 3
-------------------------------------------------------------------------------------------------------------

内挂默认药品设置
数据库指定字段(Horse)设置如下为内挂默认药品：
1.普通HP药水
2.特殊HP药水
3.普通+特殊HP药水
4.普通MP药水
5.特殊MP药水
6.普通+特殊MP药水
7.HP/MP特殊药水
8.普通HP药水+普通MP药水+特殊HP药水+HP/MP特殊药水
9.特殊HP药水+HP/MP特殊药水

及时雨内挂默认对应如下：

第一个HP 为普通HP药水 数据库字段：1、3、8
第二个HP 为特殊HP药水 数据库字段：1、3、8、9
MP 为普通MP药水 数据库字段：4、6、8
HP/MP 为HP/MP特殊药水 数据库字段：7、8、9

默认内挂对应：

1.普通体力药
4.普通魔法药
2.7.9特殊体力药 （触发内挂吃药后只要背包中有2和7和9的药品自动吃）
5.7.9特殊魔法药（触发内挂吃药后只要背包中有5和7和9的药品自动吃）

如果你使用仿及时雨内挂不想将药品区分太多：药品字段全部设置8，或者普通HP和MP设置8，特殊HP和特殊HP/HP设置9

如果你使用默认内挂普通药的字段设置1和4，特殊药不想区分太细就全部设置9


登陆游戏黑屏

1.有可能是开的游戏网关(RunGate)有相同的端口。

解决方法：在控制器->配置向导->网关设置中调整设置

2.有可能是由于开了防火墙或者安全策略把你游戏网关(RunGate)端口给屏蔽了

解决方法：开放所要用到的端口

3.使用的登陆器和引擎不配套导致黑屏


看不见衣服翅膀和武器特效

1. M2里设置错误

2. 客户端没有相应的补丁

3. 内挂开启了隐藏衣服和武器特效的选项


内挂默认药品设置
数据库指定字段(Horse)设置如下为内挂默认药品：
1.普通HP药水
2.特殊HP药水
3.普通+特殊HP药水
4.普通MP药水
5.特殊MP药水
6.普通+特殊MP药水
7.HP/MP特殊药水
8.普通HP药水+普通MP药水+特殊HP药水+HP/MP特殊药水
9.特殊HP药水+HP/MP特殊药水

及时雨内挂默认对应如下：

第一个HP 为普通HP药水 数据库字段：1、3、8
第二个HP 为特殊HP药水 数据库字段：1、3、8、9
MP 为普通MP药水 数据库字段：4、6、8
HP/MP 为HP/MP特殊药水 数据库字段：7、8、9

默认内挂对应：

1.普通体力药
4.普通魔法药
2.7.9特殊体力药 （触发内挂吃药后只要背包中有2和7和9的药品自动吃）
5.7.9特殊魔法药（触发内挂吃药后只要背包中有5和7和9的药品自动吃）

如果你使用仿及时雨内挂不想将药品区分太多：药品字段全部设置8，或者普通HP和MP设置8，特殊HP和特殊HP/HP设置9

如果你使用默认内挂普通药的字段设置1和4，特殊药不想区分太细就全部设置9

-------------------------------------------------------------------------------------------------------

客户端自动解包配置，药品数据库的Anicount=打包物品的Shape，这样才可以自动解包
例如：
强效金创药 Anicount=100 超级金创药 Shape=100
疗伤药 Anicount=115 疗伤药包 Shape=115
回城卷 Anicount=108 回城卷包 Shape=108

支持2次打包
例如：
可以把“疗伤药包”再次打包
疗伤药包 Anicount=120 超级疗伤药包 Shape=120

默认药品支持同时支持物品分类号：2类、31类


泡点功能详解

泡点功能：
可以实现人物在线时间隔指定时间自动得到指定游戏点数，这些点数可以用来换取物品、经验、等级或其它。

实现方法：
泡点是基于地图的，可以指定那些地图可以有泡点功能，人物进入此地图后就会自动增加点数。时间越长得到的点数就越多。

地图配置文件 MapInfo.txt
以比奇省图为例

[0 比奇省 0] INCGAMEPOINT(60/1)

此设置代表人物在比奇地图中时，60秒会自动得到1个游戏点。

通过脚本玩家可以查到自己的游戏点数及兑换经验,例:
[@main]
当前系统时间<$LOGINTIME>，<你进入游戏时间>为：<$LOGINLONG>\
<$USERNAME>您好根据您进入的时间所累计的<$GAMEGOLDNAME>有<$GAMEPOINT>点\
<当前等级>：<$LEVEL>级 <当前PK点数>：<$PKPOINT>点，<泡点点数>：<$GAMEPOINT>点\
<当前声望>：<$CREDITPOINT>点 <当前经验>：<$EXP><当前升级经验>：<$MAXEXP>\ \
『<兑换经验/@GetExp>』--每100个游戏点可以换经验100W\ \
〖<返回/@back>〗 〖<关闭/@exit>〗
[@GetExp]
#if
CHECKGAMEPOINT > 100
#act
CHANGEEXP + 1000000
GAMEPOINT - 100
#say
兑换成功
#ELSESAY
你都没100游戏点数!!!
<返回/@main>


如何改变蜡烛类型装备掉持久类型

功能：
    自定义蜡烛物品掉持久控制，支持按时间掉持久或与普通装备一样受攻击掉持久。

用法：
    按时间掉持久：数品数据库中Source字段为：０
    受攻击掉持久：物品数据库中Source字段为：１

修改蜡烛、火把的持久值为亮度，10000持久亮度为1最高亮度5，会根据持久的降低,降低亮度


如何设置武器为吸血武器

功能：
可将武器设置成吸血武器；

用法：
在物品数据库中，将武器Anicount字段设为：138，
吸血量为武器的重量（如重量为10，即每刀吸血10点）


商铺购买不了元宝

商铺中的金币、元宝、声望、经验等等。

如果数据库中的物品名称以金币、元宝、声望、经验等等开头的，购买时不是给用户一个物品

而是根据物品的Need字段值直接给用户加点数。

例：

元宝100 这个物品，用户购买时，会根据这个物品的Need字段值直接给用户加元宝

如果想要给用户一个物品，可以把物品名称改成 100元宝


套装属性体力恢复和魔法恢复百分比

套装属性HP和MP恢复百分比疑惑解答

疑惑解答：套装属性体力恢复和魔法恢复百分比需要在“增加百分比”边上的“增加属性点”内的MP恢复和HP恢复设置点数 这个点数为基数 ，只有设置了点数增加百分比才有效
疑惑解答：套装属性体力恢复和魔法恢复百分比需要在“增加百分比”边上的“增加属性点”内的MP恢复和HP恢复设置点数 这个点数为基数 ，只有设置了点数增加百分比才有效
疑惑解答：套装属性体力恢复和魔法恢复百分比需要在“增加百分比”边上的“增加属性点”内的MP恢复和HP恢复设置点数 这个点数为基数 ，只有设置了点数增加百分比才有效
疑惑解答：套装属性体力恢复和魔法恢复百分比需要在“增加百分比”边上的“增加属性点”内的MP恢复和HP恢复设置点数 这个点数为基数 ，只有设置了点数增加百分比才有效
疑惑解答：套装属性体力恢复和魔法恢复百分比需要在“增加百分比”边上的“增加属性点”内的MP恢复和HP恢复设置点数 这个点数为基数 ，只有设置了点数增加百分比才有效


为什么我的NPC不能买、卖、修理物品？

NPC脚本的第一行加上指定的操作，就可以正常了。

;=================================
(@buy @sell)
%100
+5
+6
[@main]
欢迎光临！！！
<买/@buy>\
<卖/@sell>\ \
<关闭/@exit>
;================================

功能标志说明：
;买物品
@buy
;卖物品
@sell
;炼药
@makedrug
;存仓库
@storage
;取仓库
@getback
;升级武器
@upgradenow
;取回升级武器
@getbackupgnow
;修理
@repair
;特殊修理
@s_repair
;发祝福语
@@sendmsg


为什么我的沙城墙没血条

第一步.首先检查M2启动有没报错，如有检查怪物数据库(Monster.DB)有没设置城墙类型怪物名称，如没只需将城墙名称与怪物数据库相对应即可解决，错误信息如下：
[错误信息] 城堡初始化城门失败，检查怪物数据库里有没城门的设置: MainDoor，

第二步.检查怪物数据库内城墙名称的血量，不能超过5000，


为什么我原来数据库里的武器加速，现在乱了？

由于数据库格式有些改变，原数据库里组合数据字段会有所变化，大家按以下规则改一下数据就行了。

武器5,6
(AC2) 准确
(MAC2) 1-10 为攻击速度减 11或以上为攻击速加，点数为 x - 10 = 1


物品不能重叠

物品重叠功能不能使用在拥有持久、属性、品质、纯度等物品上。 StdMode等于 0, 2, 3, 40, 41, 42,46

物品重叠功能，StdItem.DB 中OverLap=1或2 表示可以重叠 0不叠加
OverLap=1 重量=重叠数量*单物品重量/10
OverLap=2 重量=重叠数量*单物品重量
OverLap=3 重量=无论叠加多少个物品，重量为单物品重量

DuraMax必须大于1


游戏中人物血和蓝数值不正确解决方法

打开\Mir200\!Setup.txt，将相应数值修改成下面一样即可。

[Setup]
LevelValueOfTaosHP=6
LevelValueOfTaosHPRate=2.5
LevelValueOfTaosMP=8
LevelValueOfWizardHP=15
LevelValueOfWizardHPRate=1.8
LevelValueOfWarrHP=4
LevelValueOfWarrHPRate=4.5

;以下是英雄的
HeroLevelValueOfTaosHP=6
HeroLevelValueOfTaosHPRate=2.5
HeroLevelValueOfTaosMP=8
HeroLevelValueOfWizardHP=15
HeroLevelValueOfWizardHPRate=1.8
HeroLevelValueOfWarrHP=4
HeroLevelValueOfWarrHPRate=4.5

修改后人物的血量和魔法值均恢复官方默认值，可调整以上数值增加游戏中hp和mp值...建议使用默认值..


自动吃背包的触发物品问题[!]

启动器有个捆绑DB转换一下就正常了


GetPlayInfo命令使用大全

说明: GetPlayInfo命令使用大全(部分可能无效，按需使用)

[@main]
<玩家名/@玩家名>
<玩家机器硬盘序列号/@玩家机器硬盘序列号>
<玩家机器网卡序列号/@玩家机器网卡序列号>
<当前登录器版本号/@当前登录器版本号> \
<玩家账号/@玩家账号>
<玩家登录IP/@玩家登录IP>
<玩家IP所在地/@玩家IP所在地>
<玩家当前地图编号/@玩家当前地图编号>
<玩家当前地图描述/@玩家当前地图描述> \
<玩家当前X坐标/@玩家当前X坐标>
<玩家当前Y坐标/@玩家当前Y坐标>
<玩家当前方向/@玩家当前方向>
<玩家英雄当前方向/@玩家英雄当前方向>
yin <玩家当前职业/@玩家当前职业>
<玩家性别/@玩家性别>
<玩家发型/@玩家发型> \
<玩家金币数量/@玩家金币数量>
<玩家灵符数量/@玩家灵符数量>
<玩家等级/@玩家等级>
<玩家当前经验值/@玩家当前经验值>
<玩家升级所需经验/@玩家升级所需经验> \
<玩家防御下限/@玩家防御下限>
<玩家防御上限/@玩家防御上限> <玩家魔御下限/@玩家魔御下限>
<玩家魔御上限/@玩家魔御上限> \
<玩家攻击下限/@玩家攻击下限>
<玩家攻击上限/@玩家攻击上限>
<玩家魔法力下限/@玩家魔法力下限>
<玩家魔法力上限/@玩家魔法力上限>
<玩家道术下限/@玩家道术下限> \
<玩家道术上限/@玩家道术上限>
<玩家当前HP值/@玩家当前HP值>
<当前最大HP值/@当前最大HP值>
<当前MP值/@当前MP值> \
<当前最大MP值/@当前最大MP值>
<当前负重量/@当前负重量>
<当前最大负重量/@当前最大负重量>
<当前穿重量/@当前穿重量>
<当前最大可穿重量/@当前最大可穿重量> \
<当前腕力/@当前腕力>
<当前最大腕力/@当前最大腕力>
<人物回城点地图编号/@人物回城点地图编号>
<人物回城点X坐标/@人物回城点X坐标> \
<人物回城点Y坐标/@人物回城点Y坐标>
<人物PK值/@人物PK值>
<人物声望值/@人物声望值>
<人物转生等级/@人物转生等级> \
<人物元宝数量/@人物元宝数量>
<人物游戏点/@人物游戏点>
<人物背包空格数/@人物背包空格数>
<人物在线时长(分)/@人物在线时长(分)> \
<会员类型/@会员类型>
<会员等级/@会员等级>
<宝宝数量/@宝宝数量>
<夫妻对方姓名/@夫妻对方姓名> \
<师父名字/@师父名字>
<玩家仓库密码/@玩家仓库密码>
<行会名/@行会名>
<行会封号的编号/@行会封号的编号>
<还未分配的属性点/@还未分配的属性点> \
<已分配的属性点/@已分配的属性点>
<玩家组队队员数/@玩家组队队员数>
<组队队长姓名/@组队队长姓名>
<攻击模式编号/@攻击模式编号> \
<镖车的名字/@镖车的名字>
<玩家挂机的留言/@玩家挂机的留言>
<玩家贡献度/@玩家贡献度>
<幸运值/@幸运值> \

[@玩家名]
#ACT
GetPlayInfo Name S1
SENDMSG 6 玩家名<$STR(S1)>

[@玩家机器硬盘序列号]
#ACT
GetPlayInfo IDE S1
SENDMSG 6 玩家机器硬盘序列号<$STR(S1)>

[@玩家机器网卡序列号]
#ACT
GetPlayInfo NIC S1
SENDMSG 6 玩家机器网卡序列号<$STR(S1)>

[@当前登录器版本号]
#ACT
GetPlayInfo VER S1
SENDMSG 6 当前登录器版本号<$STR(S1)>

[@玩家账号]
#ACT
GetPlayInfo ID S1
SENDMSG 6 玩家账号<$STR(S1)>

[@玩家登录IP]
#ACT
GetPlayInfo IP S1
SENDMSG 6 玩家登录IP<$STR(S1)>

[@玩家IP所在地]
#ACT
GetPlayInfo IPLOCAL S1
SENDMSG 6 玩家IP所在地<$STR(S1)>

[@玩家当前地图编号]
#ACT
GetPlayInfo Map S1
SENDMSG 6 玩家当前地图编号<$STR(S1)>

[@玩家当前地图描述]
#ACT
GetPlayInfo MapName S1
SENDMSG 6 玩家当前地图描述<$STR(S1)>

[@玩家当前X坐标]
#ACT
GetPlayInfo X N1
SENDMSG 6 玩家当前X坐标<$STR(N1)>

[@玩家当前Y坐标]
#ACT
GetPlayInfo Y N1
SENDMSG 6 玩家当前Y坐标<$STR(N1)>

[@玩家英雄当前方向]
#ACT
GetPlayInfo H.Dir N1
SENDMSG 6 玩家英雄当前方向<$STR(N1)>

[@玩家当前方向]
#ACT
GetPlayInfo Dir N1
SENDMSG 6 玩家当前方向<$STR(N1)>

[@玩家当前职业]
#ACT
GetPlayInfo Job N1
SENDMSG 6 玩家当前职业<$STR(N1)>

[@玩家性别]
#ACT
GetPlayInfo sex N1
SENDMSG 6 玩家性别<$STR(N1)>

[@玩家发型]
#ACT
GetPlayInfo Hair N1
SENDMSG 6 玩家发型<$STR(N1)>

[@玩家金币数量]
#ACT
GetPlayInfo Gold N1
SENDMSG 6 玩家金币数量<$STR(N1)>

[@玩家灵符数量]
#ACT
GetPlayInfo GameGird N1
SENDMSG 6 玩家灵符数量<$STR(N1)>

[@玩家等级]
#ACT
GetPlayInfo Level N1
SENDMSG 6 玩家等级<$STR(N1)>

[@玩家当前经验值]
#ACT
GetPlayInfo Exp N1
SENDMSG 6 玩家当前经验值<$STR(N1)>

[@玩家升级所需经验]
#ACT
GetPlayInfo MAXEXP N1
SENDMSG 6 玩家升级所需经验<$STR(N1)>

[@玩家防御下限]
#ACT
GetPlayInfo AC N1
SENDMSG 6 玩家防御下限<$STR(N1)>

[@玩家防御上限]
#ACT
GetPlayInfo MAXAC N1
SENDMSG 6 玩家防御上限<$STR(N1)>

[@玩家魔御下限]
#ACT
GetPlayInfo MAC N1
SENDMSG 6 玩家魔御下限<$STR(N1)>

[@玩家魔御上限]
#ACT
GetPlayInfo MAXMAC N1
SENDMSG 6 玩家魔御上限<$STR(N1)>

[@玩家攻击下限]
#ACT
GetPlayInfo DC N1
SENDMSG 6 玩家攻击下限<$STR(N1)>

[@玩家攻击上限]
#ACT
GetPlayInfo MAXDC N1
SENDMSG 6 玩家攻击上限<$STR(N1)>

[@玩家魔法力下限]
#ACT
GetPlayInfo MC N1
SENDMSG 6 玩家魔法力下限<$STR(N1)>

[@玩家魔法力上限]
#ACT
GetPlayInfo MACMC N1
SENDMSG 6 玩家魔法力上限<$STR(N1)>

[@玩家道术下限]
#ACT
GetPlayInfo SC N1
SENDMSG 6 玩家道术下限<$STR(N1)>

[@玩家道术上限]
#ACT
GetPlayInfo MAXSC N1
SENDMSG 6 玩家道术上限<$STR(N1)>

[@玩家当前HP值]
#ACT
GetPlayInfo HP N1
SENDMSG 6 玩家当前HP值<$STR(N1)>

[@当前最大HP值]
#ACT
GetPlayInfo MAXHP N1
SENDMSG 6 当前最大HP值<$STR(N1)>

[@当前MP值]
#ACT
GetPlayInfo MP N1
SENDMSG 6 当前MP值<$STR(N1)>

[@当前最大MP值]
#ACT
GetPlayInfo MAXMP N1
SENDMSG 6 当前最大MP值<$STR(N1)>

[@当前负重量]
#ACT
GetPlayInfo WEIGHT N1
SENDMSG 6 当前负重量<$STR(N1)>

[@当前最大负重量]
#ACT
GetPlayInfo MAXWEIGHT N1
SENDMSG 6 当前最大负重量<$STR(N1)>

[@当前穿重量]
#ACT
GetPlayInfo WEARWEIGHT N1
SENDMSG 6 当前穿重量<$STR(N1)>

[@当前最大可穿重量]
#ACT
GetPlayInfo MAXWEARWEIGHT N1
SENDMSG 6 当前最大可穿重量<$STR(N1)>

[@当前腕力]
#ACT
GetPlayInfo HANDWEIGHT N1
SENDMSG 6 当前腕力<$STR(N1)>

[@当前最大腕力]
#ACT
GetPlayInfo MAXHANDWEIGHT N1
SENDMSG 6 当前最大腕力<$STR(N1)>

[@人物回城点地图编号]
#ACT
GetPlayInfo HOMEMAP S1
SENDMSG 6 人物回城点地图编号<$STR(S1)>

[@人物回城点X坐标]
#ACT
GetPlayInfo HOMEX N1
SENDMSG 6 人物回城点X坐标<$STR(N1)>

[@人物回城点Y坐标]
#ACT
GetPlayInfo HOMEY N1
SENDMSG 6 人物回城点Y坐标<$STR(N1)>

[@人物PK值]
#ACT
GetPlayInfo PK N1
SENDMSG 6 人物PK值<$STR(N1)>

[@人物声望值]
#ACT
GetPlayInfo CREDITPOINT N1
SENDMSG 6 人物声望值<$STR(N1)>

[@人物转生等级]
#ACT
GetPlayInfo RELEVEL N1
SENDMSG 6 人物转生等级<$STR(N1)>

[@人物元宝数量]
#ACT
GetPlayInfo GAMEGOLD N1
SENDMSG 6 人物元宝数量<$STR(N1)>

[@人物游戏点]
#ACT
GetPlayInfo GAMEPOINT N1
SENDMSG 6 人物游戏点<$STR(N1)>

[@人物背包空格数]
#ACT
GetPlayInfo BAGSIZE N1
SENDMSG 6 人物背包空格数<$STR(N1)>

[@人物在线时长(分)]
#ACT
GetPlayInfo LOGINLONGMIN N1
SENDMSG 6 人物在线时长(分)<$STR(N1)>

[@会员类型]
#ACT
GetPlayInfo MEMBERTYPE N1
SENDMSG 6 会员类型<$STR(N1)>

[@会员等级]
#ACT
GetPlayInfo MEMBERLEVEL N1
SENDMSG 6 会员等级<$STR(N1)>

[@宝宝数量]
#ACT
GetPlayInfo SLAVECOUNT N1
SENDMSG 6 宝宝数量<$STR(N1)>

[@夫妻对方姓名]
#ACT
GetPlayInfo DEARNAME S1
SENDMSG 6 夫妻对方姓名<$STR(S1)>

[@师父名字]
#ACT
GetPlayInfo MASTERNAME S1
SENDMSG 6 师父名字<$STR(S1)>

[@玩家仓库密码]
#ACT
GetPlayInfo STORAGEPWD S1
SENDMSG 6 玩家仓库密码<$STR(S1)>

[@行会名]
#ACT
GetPlayInfo GUILDNAME S1
SENDMSG 6 行会名<$STR(S1)>

[@行会封号的编号]
#ACT
GetPlayInfo GUILDRANKNO N1
SENDMSG 6 行会封号的编号<$STR(N1)>

[@还未分配的属性点]
#ACT
GetPlayInfo BONUSPOINT N1
SENDMSG 6 还未分配的属性点<$STR(N1)>

[@已分配的属性点]
#ACT
GetPlayInfo BONUSPOINTEX N1
SENDMSG 6 已分配的属性点<$STR(N1)>

[@玩家组队队员数]
#ACT
GetPlayInfo GROUPCOUNT N1
SENDMSG 6 玩家组队队员数<$STR(N1)>

[@组队队长姓名]
#ACT
GetPlayInfo GROUPOWNER S1
SENDMSG 6 组队队长姓名<$STR(S1)>

[@攻击模式编号]
#ACT
GetPlayInfo ATTACKMODE N1
SENDMSG 6 攻击模式编号<$STR(N1)>

[@镖车的名字]
#ACT
GetPlayInfo CARNAME S1
SENDMSG 6 镖车的名字<$STR(S1)>

[@玩家挂机的留言]
#ACT
GetPlayInfo OFFTALK S1
SENDMSG 6 玩家挂机的留言<$STR(S1)>

[@玩家贡献度]
#ACT
GetPlayInfo CONTRIBUTE N1
SENDMSG 6 玩家贡献度<$STR(N1)>

[@幸运值]
#ACT
GetPlayInfo LUCK N1
SENDMSG 6 幸运值<$STR(N1)>


修理沙巴克城墙城门

功能：可在任何时间对沙巴克城门和城墙进行修理
-----------------------------------------------------------------

NPC命令：
修理城门：RepairDoor
修理城墙：RepairWall 参数1 (参数1、2、3分别对应3个城墙)

*例子

[@修复城墙]
#IF
#ACT
RepairDoor
RepairWall 1
RepairWall 2
RepairWall 3
SendMsg 6 沙巴克城墙和城门已全部修复.


自动穿戴指定物品唯一ID的物品到身上

自动穿戴指定序列号的装备到身上

功能：通用物品唯一ID自动穿戴装备到身上
格式：AutoTakeOnItemEx 物品唯一ID 穿戴位置
说明：自动穿戴指定序列号的物品（佩戴类型要和位置相符合，不能衣服穿到其它位置）

*例子

[@main]
#ACT
ChangeItemIndex 23123789 1
sendmsg 6 将序列号为23123789的武器穿戴到身上武器位置

物品位置代码 | 物品位置说明 (所有装备位置参考如下）
-1 | 升级框
boxitem0-boxitem7 | OK框
0 | 盔甲
1 | 武器
2 | 照明物（蜡烛，此物品属性升级无效）
3 | 项链
4 | 头盔
5 | 左手镯
6 | 右手镯
7 | 左戒指
8 | 右戒指
9 | 护身符
10 | 腰带
11 | 鞋子
12 | 宝石
13 | 斗笠
14 | 军鼓
15 | 马牌
16 | 盾牌
17 | 灵玉
18 | 时装衣服
19 | 时装武器
20 | 时装项链
21 | 时装头盔
22 | 时装左手镯
23 | 时装右手镯
24 | 时装左戒指
25 | 时装右戒指
26 | 时装勋章
27 | 时装腰带
28 | 时装靴子
29 | 时装宝石
30-35 | 首饰盒
40-51 | 生肖盒
70-75 | 时装生肖盒
80-91 | 时装生肖盒
200-249 | 自定义装备框


将指定位置物品转换为数据库对应的IDX物品

功能：将指定位置物品转换为数据库对应的IDX物品
格式：ChangeItemIndex 装备位置 数据库物品Idx
说明：该命令可以将指定位置物品的附加属性（含自定义属性）平移到新的物品中

*例子

//;当数据库IDX19为青铜斧时，将手上武器替换成青铜斧，同时附加属性平移到青铜斧
[@main]
#ACT
ChangeItemIndex 1 19
sendmsg 6 你身上的武器已经改成了青铜斧

物品位置代码 | 物品位置说明 (所有装备位置参考如下）
-1 | 升级框
boxitem0-boxitem7 | OK框
0 | 盔甲
1 | 武器
2 | 照明物（蜡烛，此物品属性升级无效）
3 | 项链
4 | 头盔
5 | 左手镯
6 | 右手镯
7 | 左戒指
8 | 右戒指
9 | 护身符
10 | 腰带
11 | 鞋子
12 | 宝石
13 | 斗笠
14 | 军鼓
15 | 马牌
16 | 盾牌
17 | 灵玉
18 | 时装衣服
19 | 时装武器
20 | 时装项链
21 | 时装头盔
22 | 时装左手镯
23 | 时装右手镯
24 | 时装左戒指
25 | 时装右戒指
26 | 时装勋章
27 | 时装腰带
28 | 时装靴子
29 | 时装宝石
30-35 | 首饰盒
40-51 | 生肖盒
70-75 | 时装生肖盒
80-91 | 时装生肖盒
200-249 | 自定义装备框


获取武器修炼次数

功能：获取武器修炼次数，检测装备修炼次数，修改武器修炼次数
格式：GetItemTrainingCount 装备位置 保存变量
说明：获取武器修炼次数，检测装备修炼次数，修改武器修炼次数

-----------------------------------------------------------------

NPC命令：
修改武器修炼次数：ChangeItemTrainingCount
命令格式：ChangeItemTrainingCount 装备位置 操作符(+-=) 修炼次数

获取武器修炼次数：
GetItemTrainingCount 装备位置 保存变量

检测装备修炼次数（支持H.)
格式:CheckItemTrainingCount 物品位置 (<,>,=) 修炼次数

-----------------------------------------------------------------

位置介绍：

物品位置:
-1 升级框中物品
boxitem0-boxitem7 自定义OK框
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 灵玉
18 时装衣服
19 时装武器
20 时装项链
21 时装头盔
22 时装左手镯
23 时装右手镯
24 时装左戒指
25 时装右戒指
26 时装勋章
27 时装腰带
28 时装靴子
29 时装宝石
30-35 首饰盒
40-51 生肖盒

*例子(如果需要按次数升级武器，请在引擎选项上启用)

[@测试]
#IF
CheckItemTrainingCount 1 < 4
#ACT
ChangeItemTrainingCount 1 + 1

#IF
#ACT
GetItemTrainingCount 1 N1
Sendmsg 6 你装备的武器修炼次数为<$STR(N1)>


查看人物/英雄装备

查看在线人物/英雄装备

功能：查看人物/英雄装备
说明：一共两条命令,其中无论目标人物是否在线均可查看,按需使用

功能：查看在线人物/英雄装备
格式：QueryUserState 用户名/英雄名
说明：当用户/英雄不在线时，会触发 当前Npc 中的@QueryUserStateFail

[@查看他人装备]
#ACT
QueryUserState dddd

;QF触发
[@QueryUserStateFail]
#ACT
sendmsg 6 用户不存在或不在线

================================================================

功能：查看人物/英雄装备（无论是否在线均可查看）
格式：QueryUserStateEx 用户名/英雄名
说明：当用户不存在时，会触发 当前Npc 中的@QueryUserStateExFail

[@查看他人装备]
#ACT
QueryUserStateEx dddd

;QF触发
[@QueryUserStateExFail]
#ACT
sendmsg 6 用户不存在


取两个时间之间的相差

功能：取两个时间之间的相差（时间2-时间1）
说明： GETINTERVAL 时间1 时间2 (0:年 1:月 2:星期 3:天 4:时 5:分 6:秒) 保存变量

功能: 取两个时间之间的相差（时间2-时间1）
格式: GETINTERVAL 时间1 时间2 (0:年 1:月 2:星期 3:天 4:时 5:分 6:秒) 保存变量

例子：
[@时间计算]
#IF
#ACT
GETINTERVAL <$datetime> <$YEAR>-<$MONTH>-<$DAY>,23:59:59 6 S$时间
SENDMSG 0 距离当天结束还剩余<$STR(S$时间)>秒

注意：服务器的时间格式修改为:yyyy-M-d,否则会提示该命令的时间格式错误


毫秒级个人定时器

功能：毫秒级个人定时器
说明： 由于人物运行间隔在200毫秒+，计时器在250毫秒内可能无法做到很精确

格式：
SETONTIMEREX 定时器索引(0-9) 定时间隔（单位为毫秒）执行次数（留空为无限制执行，需使用停止定时器方可关闭，填写3为执行3次后自动关闭定时器）
SETOFFTIMEREX 定时器索引(0-9) //停止定时器

设置定时器编号0的间隔为300毫秒
[@Test]
#IF
#ACT
SETONTIMEREX 0 300

QManage.txt:触发：
QM中的@OnTimerEx索引号
[@OnTimerEx0]
#ACT
SENDMSG 1 OnTimerEx0

停止编号0的定时器
[@Test]
#IF
#ACT
SETOFFTIMEREX 0


忽视目标防御

功能：同时忽视目标防御和魔御
说明：本命令支持按照数值或百分比同时忽视目标防御和魔御，当和元素忽视目标防御冲突时，优先命令操作后的防御属性再进行元素忽视

格式：SetIgnoreTargetDefense 值类型(0:百分比;1:固定值) 值 时间(单位秒,0为在线一直有效)

例子：
[@点数]
#act
SetIgnoreTargetDefense 1 80 20
SENDMSG 6 忽视目标防御80点，20秒有效

[@比例]
#act
SetIgnoreTargetDefense 0 50 10
SENDMSG 6 忽视目标防御50%，10秒有效


调整人物属性百分比

功能：调整人物属性百分比
格式：ChangeHumAbilityPercentage 属性(1-29) 操作符(+ = -) 数值 时间秒
说明: 属性1-29分别对应值
1、防御下限
2、防御上限
3、魔御下限
4、魔御上限
5、攻击下限
6、攻击上限
7、魔法下限
8、魔法上限
9、道术下限
10、道术上限
11、MaxHP
12、MaxMP
13、内功攻击伤害减
14、HP恢复
15、MP恢复
16、毒恢复
17、毒躲避
18、魔法躲避
19、准确
20、敏捷
21、幸运
22、内功伤害增加
23、内力值
24、刺术下限
25、刺术上限
26、箭术下限
27、箭术上限
28、武力下限
29、武力上限

*注意：调整后的效果只在人物在线时有效,不带时间在线一直有效

例子：
[@main]
#IF
#ACT
ChangeHumAbilityPercentage 2 + 10 60
#SAY
你的防御上限增加10%.60秒后恢复

注：ChangeHumAbilityPercentage支持多级脚本

[@main]
#if
#act
M.ChangeHumAbilityPercentage 2 = 90 10
#SAY
目标防御降低为90%,持续10秒。

注：支持调整人物原始属性，减少属性为累计属性，
如：人物100点攻击，命令减少100%，那么人物攻击变成0，更换装备都没有用，必须时间到或者恢复原始属性ChangeHumAbilityPercentage 2 = 100 即可

百分比降低目标防御尽量用=去做不然多次触发会累计降低或者累计增加


改变技能特效

功能：改变技能特效
格式：无
说明：持久性技能特效暂未支持

修改技能特效: SetMagicEffect 技能名称 特效编号(特效技能ID, ID为0则恢复默认)

****持久特效暂未支持
SetMagicEffect 雷电术 33
Sendmsg 6 雷电术变为冰咆哮特效了

SetMagicEffect 火球术 11
Sendmsg 6 火球术变为雷电术特效了

SetMagicEffect 刺杀剑术 66
Sendmsg 6 刺杀剑术变为开天斩特效了

SetMagicEffect 烈火剑法 25
Sendmsg 6 烈火剑法变为半月特效了

*****持久特效暂未支持”


开启跑步幻影效果

开启跑步拖影效果

功能：幻影移动
格式：SetShadowShow 开启/关闭(1:开;0:关) 开启时间(单位:秒；为0时表示在线一直生效)
命令：SetShadowShow 开启/关闭(1:开;0:关) 开启时间(单位:秒；为0时表示在线一直生效)

命令:

格式：SetShadowShow 开启/关闭(1:开;0:关) 开启时间(单位:秒；为0时表示在线一直生效)

==================================================

示例：

[@开启跑步拖影]
#ACT
SetShadowShow 1 60
sendmsg 6 你已开启跑步拖影效果60秒

英雄使用命令:H.SetShadowShow


设置假人捡物品列表

功能：设置假人捡物品列表
默认假人捡物品列表为：列表信息1中的允许捡取物品和优先捡取物品
本命令可对指定假人设置自定义指定列表进行捡物品，未定义的假人全部默认列表信息1

------------------------------------------------

*设置假人捡物品列表

格式：自定义设置假人捡物品列表
SetDummyPickItemFile 捡取列表文件名(一行一个物品名) 是否优先捡取(0或空：优先捡取列表;1:允许捡取列表）

[@设置捡物品列表]
#IF
#ACT
;优先捡物品列表
;弑神飞影.SetDummyPickItemFile D:\假人捡垃圾1.txt
SetDummyPickItemFile D:\假人捡垃圾1.txt
sendmsg 8 设置假人优先捡取列表为D:\假人捡垃圾1.txt

;允许捡物品列表
;弑神飞影.SetDummyPickItemFile D:\假人捡垃圾2.txt 1
SetDummyPickItemFile D:\假人捡垃圾2.txt 1
sendmsg 8 设置假人允许捡取列表为D:\假人捡垃圾2.txt

*PS：如果命令只设置了优先捡，那么假人就捡命令设置优先捡列表+列表信息1的允许捡列表

*PS：如果命令只设置了允许捡，那么假人就捡命令设置的允许捡+列表1的优先捡

*PS：如果全设置命令捡(不捡列表1)就和上述脚本一样同时使用命令设置优先和允许


开启/关闭假人捡物品功能

功能：开启/关闭假人捡物品功能
除假人配置文件可设置是否允许捡物品外，本命令可给指定假人开启或关闭捡物品
本命令可对指定假人设置开启或关闭捡物品

------------------------------------------------

*开启/关闭假人捡物品功能

格式：开启/关闭假人捡物品
SetDummyPickItem 1/0(1:开假人捡物; 0:关假人捡物)

[@设置捡物品]
#IF
#ACT
;弑神飞影.SetDummyPickItem 1
SetDummyPickItem 1
;弑神飞影.sendmsg 8 开了捡物功能

sendmsg 8 开了捡物功能


获取身上物品限时剩余时间

功能：获取身上限时物品剩余时间
获取身上物品限时剩余时间格式：GetItemRemainingTime 物品位置 保存变量(为-1时，表示非限时装备)
获取身上称号限时剩余时间格式：GetFengHaoRemainingTime 称号名称 保存变量(为-1时，表示非限时装备)

------------------------------------------------

*获取身上物品限时剩余时间

格式：GetItemRemainingTime 物品位置 保存变量(为-1时，表示非限时装备)
GetItemRemainingTime 1 N1

[@获取限时时间]
#IF
CheckUseItem 1
#ACT
GetItemRemainingTime 1 N1
;时间为-1时，表示非限时物品
SendMsg 6 武器剩余时间为：<$STR(N1)>分钟

*获取身上称号限时剩余时间

格式：GetFengHaoRemainingTime 称号名称 保存变量(为-1时，表示非限时装备)
GetFengHaoRemainingTime 沙巴克城主 N1

[@获取称号限时时间]
#IF
CheckFengHao 沙巴克城主
#ACT
GetFengHaoRemainingTime 沙巴克城主 N1
;时间为-1时，表示非限时物品
SendMsg 6 沙巴克城主剩余时间为：<$STR(N1)>分钟


交易前触发

功能：交易前触发和中止交易
格式：交易前触发@BeginDealTry
说明：中止交易命令StopDealTry

格式：简易例子

[@BeginDealTry]
#ACT
StopDealTry
SendMsg 6 脚本禁止交易

*交易前触发和中止交易...


键值对字典

功能说明: 字典
格式：{key1:value1,key2:value2}

; 取字典中的元素数量
GetDictKeyCount 字典名 变量

; 取字典中的Keys或Values
GetDictItems 字典名 字段类型(0:Keys;1:Values) 保存变量

;取字典中值最大的元素
GetDictMaxValue 字典名 Key变量 Value变量

;取字典中值最小的元素
GetDictMinValue 字典名 Key变量 Value变量

;检查字典中的所有值是否均为数字
CheckDictAllDigit 字典名

;检查字典是否存在key或value
;格式：CheckInDict 字典变量 待检查的值 参数3
;参数3： 0或空 检查key是否存在
;参数3： 1 检查value是否存在

脚本示例：
[@字典测试]
#ACT
;字典初始化
MOV D$测试 {张三:100,李四:200,王五:300}

;添加/修改字典元素
Mov D$测试[周八] 600

;添加/修改字典元素
Inc D$测试 赵六:400

;添加/修改字典元素
Inc D$测试 孙七:500

;删除字典元素
Dec D$测试 赵六
sendmsg 7 <$STR(D$测试)>

; 取字典中的元素数量
GetDictKeyCount D$测试 N1
sendmsg 7 字典中Key有<$STR(N1)>个

; 将字典中的Key放到 L$Keys中
GetDictItems D$测试 0 L$Keys

;将字典中的Value放到 L$Values中
GetDictItems D$测试 1 L$Values

sendmsg 7 Keys:<$Str(L$Keys)>
sendmsg 7 Values:<$Str(L$Values)>

#IF
;检查Key是否存在
CheckInDict D$测试 张三 0
#ACT
SendMsg 7 Key:张三在字典中

#IF
;检查Value是否存在
CheckInDict D$测试 200 1
#ACT
SendMsg 7 Value:200在字典中

#IF
CheckDictAllDigit D$测试
#ACT
;取字典中值最大的元素
GetDictMaxValue D$测试 S1 N1
sendmsg 7 <$STR(D$测试)>中，数值最大元素Key=<$STR(S1)>，Value=<$STR(N1)>

;取字典中值最小的元素
GetDictMinValue D$测试 S1 N1
sendmsg 7 <$STR(D$测试)>中，数值最小元素Key=<$STR(S1)>，Value=<$STR(N1)>
#ELSEACT
sendmsg 7 <$str(D$测试)>内有非法数值，取值失败

#ACT
MOV D$测试 {}
sendmsg 7 字典内容为:<$STR(D$测试)>

;示范脚本为简易脚本，具体自由发挥.......


通过技能ID获取技能数据库字段

功能：通过技能ID获取技能数据库字段
格式：GetDBMagicIDFieldValue 技能ID 字段名 保存变量
说明：GetDBMagicIDFieldValue 技能ID 字段名 保存变量

格式：GetDBMagicIDFieldValue 技能ID 字段名 保存变量

#act
GetDBMagicIDFieldValue <$CURRRUSEMAGICID> 元素技能变量 s$元素技能变量值
GetDBMagicIDFieldValue <$CURRRUSEMAGICID> 攻元素怪物对应元素 S$怪物对应元素
GetDBMagicIDFieldValue <$CURRRUSEMAGICID> 攻元素人物对应元素 S$人物对应元素

*通过技能ID获取技能数据库字段...


伤害吸收装备设置

使用脚本命令开启行会战命令

功能：使用脚本命令开启行会战命令
格式：如需掌门人才可以用的话请加入检测脚本命令
说明：GuildWar 参数1(目标行会名字) 任何有行会的玩家都可以使用(无行会则无效)

*例子：

[@main]
#IF
ISGUILDMASTER
#ACT
GuildWar 测试测试
#ELSESAY
只有行会掌门人才可以申请行会战！！！


获取宝宝所在位置信息

功能说明: 获取宝宝所在位置

格式：GetSlavePosition 名字 保存变量Map 保存变量X 保存变量Y 是否只匹配显示名(0不检测数字 1检测数字)

示范：
[@main]
#if
#act
GetSlavePosition 神兽 S$地图 N$X坐标 N$Y坐标
Sendmsg 5 提示：您的神兽在<$STR(S$地图)>坐标(<$STR(N$X坐标)>,<$STR(N$Y坐标)>)

;======================================================


打印个人标识

功能说明: 打印个人标识

[@打印个人标识]
<开关标识1/@开关标识(1)> <$flag(1)> << 显示 0 或 1\
<开关标识100/@开关标识(100)> <$flag(100)> << 显示 0 或 1\

[@开关标识]
#if
check [<$scriptparam1>] 0
#act
set [<$scriptparam1>] 1
sendmsg 7 ---------------标识:<$scriptparam1>，当前状态：<$flag(<$scriptparam1>)>（状态应显示为1）
goto @打印个人标识
#elseact
set [<$scriptparam1>] 0
sendmsg 7 ---------------标识:<$scriptparam1>，当前状态：<$flag(<$scriptparam1>)>（状态应显示为0）
goto @打印个人标识

;======================================================


设置物品悬浮框背景特效

功能说明: 设置物品悬浮框背景特效

说明：设置物品悬浮框背景特效

--------------------------------------------------------

特效设置位置：列表信息2——》悬浮框背景特效

--------------------------------------------------------

操作命令：
SetItemWindowEffectIndex 物品位置 特效位置(0-2) 特效编号(0为关闭)

物品位置:
-1 升级框
boxitem0-boxitem7 自定义OK框
0 盔甲.....
30-35 首饰盒
40-51 生肖盒

例子：
[@test]
#act
SetItemWindowEffectIndex 1 0 1
SetItemWindowEffectIndex 1 1 3
SetItemWindowEffectIndex 1 2 10

;PS:单物品最多设置3个特效

;固定坐标M2设置左、上参数
;平铺模式M2设置左、上、右、下参数

;固定模式时，图片会按照设置的坐标固定显示

;平铺模式时，图片会自动缩放绘制在整个装备悬浮框上，如果图片周围有空图片，需要设置空白的宽度对齐

--------------------------------------------------------

--------------------------------------------------------

悬浮框素材配置图解


获取全身装备的原始数据字段合计值

功能说明: 获取全身装备的原始数据字段指定值总和

说明：获取全身装备的原始数据字段指定值总和

--------------------------------------------------------

格式：
GetAllDBItemFieldValue 字段名 变量

--------------------------------------------------------

示例：

[@main]
#if
#act
GetAllDBItemFieldValue LFM2 N1
SendMsg 6 提示:你身上装备LFM2字段值总和共有<$STR(N1)>点！


不掉落身上装备

功能说明: 不掉落身上装备（含背包物品）

说明：不掉落身上装备（含背包物品）

--------------------------------------------------------

调整死亡不掉装备的次数
SetNoDropItemCount (+,-,=) 次数 下线是否保存

获取死亡不掉装备的次数
GetNoDropItemCount 变量1(次数) 变量2(下线是否保存,0或空不保存)

--------------------------------------------------------

例子：
[@test]
#ACT
SetNoDropItemCount = 5 1
SendMsg 6 你有5次机会死亡不掉装备
GetNoDropItemCount N1 N2
Sendmsg 6 你有<$STR(N1)>次机会死亡不掉装备；下线是否保存:<$STR(N2)>

--------------------------------------------------------

英雄操作：

调整死亡不掉装备的次数
H.SetNoDropItemCount (+,-,=) 次数 下线是否保存

获取死亡不掉装备的次数
H.GetNoDropItemCount 变量1(次数) 变量2(下线是否保存,0或空不保存)

--------------------------------------------------------

例子：
[@test]
#ACT
H.SetNoDropItemCount = 5 1
SendMsg 6 你英雄有5次机会死亡不掉装备
H.GetNoDropItemCount N1 N2
Sendmsg 6 你英雄有<$STR(N1)>次机会死亡不掉装备；下线是否保存:<$STR(N2)>


TAKE收回背包物品

功能说明: TAKE收回背包物品

格式：take 物品 数量 是否检测装备改名（0或空：不检测，1：检测） 物品名匹配方式(0或空：完整匹配，1：部分匹配） 是否回收自定义OK框物品(0或空:回收; 1:不回收) 检测持久(0或空:所有; -1:满持久; -2:未持久)

PS：参数5 是否回收OK框物品，仅限自定义OK框 ，不包含普通OK框

--------------------------------------------------------

示例：

[@test]
#if
#act
take 大手镯
SENDMSG 6 收回背包物品：大手镯，数量：1


删除仓库物品

功能说明: 删除仓库物品

说明：DelStorageItem 仓库类型(0:普通仓; 1:无限仓) 依据值的类型(0:物品唯一ID; 1:物品数据Idx; 2:物品名称) 值

--------------------------------------------------------

格式：DelStorageItem 仓库类型(0:普通仓; 1:无限仓) 依据值的类型(0:物品唯一ID; 1:物品数据Idx; 2:物品名称) 值

示例：

[@main]
#IF
#ACT
DelStorageItem 0 1 0
sendmsg 6 已删除普通仓库中，物品idx=0的所有物品

[@main1]
#IF
#ACT
DelStorageItem 1 2 屠龙
sendmsg 6 已删除无限仓库中的有所有屠龙

[@main2]
#IF
#ACT
DelStorageItem 0 2 *
sendmsg 6 已删除普通仓库中的所有物品


获取仓库物品数量

功能说明: 获取仓库物品数量（不计算叠加，叠加再多也只算一个）

格式：GetStorageItemCount 仓库类型(0:普通仓; 1:无限仓) 依据值的类型(0:物品唯一ID; 1:物品数据Idx; 2:物品名称) 值 变量

--------------------------------------------------------

格式：GetStorageItemCount 仓库类型(0:普通仓; 1:无限仓) 依据值的类型(0:物品唯一ID; 1:物品数据Idx; 2:物品名称) 值 变量
示例：

[@test]
#act
GetStorageItemCount 0 1 0 N1
sendmsg 6 普通仓库中，物品idx=0的物品数量为<$STR(N1)>

[@test1]
#act
GetStorageItemCount 1 2 屠龙 N1
sendmsg 6 无限仓库中的屠龙数量为<$STR(N1)>

[@test2]
#act
GetStorageItemCount 0 2 * N1
sendmsg 6 普通仓库中的物品数量为<$STR(N1)>


MobFireBurn地图光环效果

功能说明: MobFireBurn

格式：MOBFIREBURN 地图号 坐标X 坐标Y 光环效果 持续时间(秒) 伤害值 是否百分比（0或空为值 ，1为MAXHP百分比， 2为当前HP百分比）

--------------------------------------------------------

格式：MOBFIREBURN 地图号 坐标X 坐标Y 光环效果 持续时间(秒) 伤害值 是否百分比（0或空为值 ，1为MAXHP百分比， 2为当前HP百分比）
示例：

[@测试]
#IF
#ACT
MOBFIREBURN 3 320 348 5 60 50 2
MOBFIREBURN 3 320 349 5 60 50 2
MOBFIREBURN 3 320 350 5 60 50 2
MOBFIREBURN 3 320 351 5 60 50 2
MOBFIREBURN 3 321 348 5 60 50 2
MOBFIREBURN 3 321 349 5 60 50 2
MOBFIREBURN 3 321 350 5 60 50 2
MOBFIREBURN 3 321 351 5 60 50 2
SendMsg 0 盟重开火墙，有效1分钟，每次掉剩余血量一半的血

光环类型
1是僵尸钻的地洞
3是碎石块
4是困魔光
5是火墙
6是祖码教主裂开的石头
7是地刺
8是雷电
9-14是大雷电
15是流星火环
16是火龙泉
17是灵光
18是宝箱发光
19是光环门
20是光球
其他自己测试


GM命令刷怪

功能: GM命令刷怪

GM命令刷怪为引擎中管理员命令，命令根据你的服务端设置为准

GM命令刷怪格式

@MOB 怪物名称 数量 等级 国家代码 同国家玩家是否攻击 不同国家怪物是否PK 怪物颜色 体型大小（空或100为默认大小）


GOTO将传递参数返回值保存到变量，脚本参数回调

[@run]
#act
goto @test(1,2|N$返回值1,S$返回值2)
sendmsg 7 ...<$str(N$返回值1)>,<$str(S$返回值2)>

[@test]
#act
formulation <$scriptparam1>*2 N$计算结果1
formulation <$scriptparam2>*2 N$计算结果2
MOV S$计算结果 参数2返回值：<$str(N$计算结果2)>
return <$str(N$计算结果1)> <$STR(S$计算结果)>
;return返回N个参数保存到上面指定变量中，注意return等同break，脚本段使用return下方不再执行..
sendmsg 7 aaaaaaaaaaaaaaaaaaaaaaaaaaaaaa


HumanHP调整血量

格式: HumanHP 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8

参数1 操作符号(+ - =)
参数2 数值
参数3 延时扣血 (空或0表示无延时，延时单位：毫秒)
参数4 执行次数（0或或空扩展之前老模式，设置1为新模式执行1次 ，注：新模式如多条命令一起执行扣血会一起扣 漂血会叠加飘）
参数5 是否漂血 (0或空为默认漂血，1为不漂血 ，参数6大于0时本项无效)
参数6 是否自定义漂血（瓢血前缀 ：0或空为无前缀，自定义瓢血填写为NewopUI.pak中的图片编号，比如填写1810 此次瓢血采用1810-1827）参数6值大于0则按照参数6设置进行漂 参数等于0或空则按照参数5设置是否漂血）
参数7 数据单位(0:固定值，1:MaxHP%，2:MaxHP‰，3:MaxHP?)
参数7补充说明：0或空为按照参数2设置的数据值进行扣血，参数为1则按照参数2设置的值进行百分比扣血，参数为2千分比，参数为3万分比...设置万分之100也等于百分之一）

参数8 是否无视目标护身属性,参数设置0或留空为无视，1为目标护身有效
PS 参数6飘血图片：0，1，2，3，4，5，6，7，8，9，-，+，附加图片，. ，万， 亿， 兆，京

[@main]
#ACT
HumanHP - 500 300
;人物HP减少500，延时300毫秒生效！（1000毫秒为1秒）

例子2：
#IF
#ACT
HumanHP - 100 0 1 0 1810 3
;人物自定义漂血素材读取1810进行万分之100扣血，也相当于1%

例子3：
#IF
#ACT
HumanHP - 1 0 1 0 1810 2
;人物自定义漂血素材读取1810进行千分之一扣血

例子4：
#IF
#ACT
HumanHP - 1 0 1 0 1810 1
;人物自定义漂血素材读取1810进行1%扣血

例子4：
#IF
#ACT
HumanHP - 1000 0 1 0 1810
;人物自定义漂血素材读取1810,扣血1000点

MP格式:
HumanMP 操作符(+ - =) 数值 微秒延时时间(空或0表示无延时) 执行次数（0或或空扩展之前老模式，设置1为新模式执行1次 ，注：新模式如多条命令一起执行扣蓝会一起扣 漂蓝会叠加飘） 比例值(0:数值；1:MaxMP%; 2:千分之MaxMP; 3万分之MaxMP)

老模式（支持多条）：
HumanHP - 500 1000
HumanHP - 500 2000
HumanHP - 500 3000
HumanHP - 500 4000
HumanHP - 500 5000

新模式（支持单条 参数3为执行次数）：
HumanHP - 500 5000 5

英雄命令：
H.HumanHP
H.HumanMP

分身命令：
FS.HumanHP
FS.HumanMP

多级运用部分人不会，格式如下：
H.M.HumanHP
FS.M.HumanMP


Mongen.txt 增加刷怪触发

功能：
Mongen.txt 刷怪触发

格式：
 Mongen.txt 增加刷怪触发

Mongen.txt 文件内容如下：
3 180 275 毒蜘蛛 2 4 1 100 249 0 0 0 0 0 @刷毒蜘蛛

------------------
;QF触发：

[@刷毒蜘蛛]
#if
#act
SENDMOVEMSG 0 251 0 50 1 {【世界BOSS全服提示】:/SCOLOR=70}{『<$RegMonName>』/SCOLOR=250}已出世，位于地图<$RegMonMap>(<$RegMonMapDesc>)，坐标<$RegMonX>:<$RegMonY>，赶紧抢！！！

################################################满足G变量刷怪##################################################

G变量 操作符(>,<,=,>=,<=) 数值

Mongen.txt 文件内容如下：
3 180 275 毒蜘蛛 2 4 1 100 249 0 0 0 0 0 @刷毒蜘蛛 G9 > 9

;G9变量大于9刷怪
------------------
;QF触发：

[@刷毒蜘蛛]
#if
#act
SENDMOVEMSG 0 251 0 50 1 {【世界BOSS全服提示】:/SCOLOR=70}{『<$RegMonName>』/SCOLOR=250}已出世，位于地图<$RegMonMap>(<$RegMonMapDesc>)，坐标<$RegMonX>:<$RegMonY>，赶紧抢！！！

变量说明

<$RegMonName>：当前怪物
<$RegMonMap>： 地图号
<$RegMonMapDesc>：地图名
<$RegMonX>：刷怪X
<$RegMonY>：刷怪Y

适用于单个刷怪，或极少数刷怪，也就是BOSS刷新触发，如果刷怪数量太大，超过死循环设置数量将被提示死循环

。
;==========================================


Npc命令捡物同步内挂物品，同步内挂捡取

说明：Npc命令捡物同步内挂物品

---------------------------------------------------------------------------------------------

说明：

增加Npc命令捡物同步内挂物品: EnableUseClientPickItems 值(0:由系统参数决定 1:同步内挂; 2:禁止内挂同步)，本命令支持人物/英雄H./宠物PET.
参数0为根据引擎选项决定是否开启同步内挂捡
人物捡物同步内挂配置/英雄捡物同步内挂配置；位置：查看——》列表信息2——》内挂捡取
宠物捡物同步内挂配置; 位置：选项——》宠物设置——》参数设置

[@开启人物同步内挂]
#IF
#ACT
EnableUseClientPickItems 1
SENDMSG 6 你已开启同步内挂捡物

[@关闭人物同步内挂]
#IF
#ACT
EnableUseClientPickItems 2
SENDMSG 6 你已关闭同步内挂捡物

[@开启英雄同步内挂]
#IF
#ACT
H.EnableUseClientPickItems 1
SENDMSG 6 你的英雄已开启同步内挂捡物

[@关闭英雄同步内挂]
#IF
#ACT
H.EnableUseClientPickItems 2
SENDMSG 6 你的英雄已关闭同步内挂捡物

[@开启宠物同步内挂]
#IF
#ACT
PET.EnableUseClientPickItems 1
SENDMSG 6 你的宠物已开启同步内挂捡物

[@关闭宠物同步内挂]
#IF
#ACT
PET.EnableUseClientPickItems 2
SENDMSG 6 你的宠物已关闭同步内挂捡物

本命令主要用户同步内挂仅对部分玩家开放情况下使用，如所有玩家都同步内挂则直接引擎选项勾选启用即可！


按地图列表移动

功能：
先设定每一张地图停留的地间，再把地图列表添加一下，人物会
从第一张地图开始一张一张移动到最后一张

例子：

[@Test]
#IF
#ACT
batchDelay 1 ;(暂停时间)
addbatch B102 ;步进地图名1
addbatch B103 ;步进地图名2
addbatch B104 ;步进地图名3
addbatch B105 ;步进地图名4
addbatch B106 ;步进地图名5
addbatch B107 ;步进地图名6
batchmove ;开始从第一个步进地图移动到最后一个步进地图(这里是6)


按给定概率随机获取分割后的字符串

;======================================================

格式：RandomSplit 参数1 参数2 参数3 参数4(可为空) 参数5(可为空)

参数1：需要获取随机的字符串 字符串#概率|字符串#概率 字符串分割符“|” (字符串顺序无要求)
参数2：0~2（0=参数2返回“字符串” 1=参数2返回“概率值” 2=参数2返回“字符串#概率值”）
参数3：随机得到的结果所保存的变量
参数4：0~2（0=参数4返回“字符串|字符串|字符串” 1=参数4返回“概率值|概率值|概率值” 2=参数4返回“字符串#概率值|字符串#概率值”）
参数5：剩余的结果所保存的变量

示例：

[@测试]
#if
#act
RandomSplit 木剑#2|裁决#1|怒斩#3|屠龙#5 0 S$结果 2 S$剩余
;总事件数(概率分母)：11=2+1+3+5
SENDMSG 6 随机取到字符串：<$str(S$结果)>
SENDMSG 6 剩余的字符串值：<$str(S$剩余)>
;假设上述结果得到木剑(取得木剑的概率为2/11)
;<$str(S$结果)> = 木剑
;<$str(S$剩余)> = 裁决#1|怒斩#3|屠龙#5


把行会加入攻城列表

格式: ADDTOCASTLEWARLIST 城堡名称 行会名称(行会名称为空时所有行会加入到攻城列表) 天数(几天后开始攻城，该参数可以为空，为空时按照引擎设置的天数)

[@main]
#ACT
ADDTOCASTLEWARLIST 沙巴克 1


把人物加入行会

格式: ADDGUILDMEMBER 行会名称 人物名称(人物名称为空时把自己加入到行会)

[@main]
#ACT
ADDGUILDMEMBER 行会名称


百分比计算命令[!]

功能：
百分比计算命令.

格式: CalcPercent 值 百分比 结果变量

示列：

[@mail]
#ACT

CalcPercent 200 5 N1
SendMsg 6 200的5%为<$STR(N1)>


绑定给予的装备进行命令操作

;======================================================
绑定脚本给的物品进行命令操作，只绑定最后一个给的物品，比如GIVE 屠龙 10 ，一次给10把屠龙，只对最后一把生效！如果背包放不下掉在地上后该命令失效！

#IF
#ACT
give 屠龙 1
;给屠龙1把
LINKGIVEITEM
;绑定屠龙下面的操作只对绑定的装备生效
ChangeItemNameColor -1 253
;调整武器颜色
updateitem -1
;刷新到客户端
clearLinkItem
;解除绑定，不然刷新包裹物品不刷新
break

位置：
-1升级框
0--29：装备栏和时装栏
30-35：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框

说明：linkpickupitem和linkgiveitem都是绑定对象到升级框，调整属性后刷新-1位置即可！

注意：clearLinkItem 因为绑定必须给物品一个位置，目前以下2个命令强行绑定到OK框，请加上解除绑定命令，不然不能及时刷新背包物品属性，需要小退生效，加上后及时生效！！
主要是解决绑定到-1后，alt+R刷新包裹和捡起触发改名不刷新的问题，，身上或自定义OK框或者OK框只要有装备位置的不需要增加clearLinkItem，因为背包是没位置的所以需要增加！！！
特别注意：如果不解绑的情况下，会出现修改过属性的物品丢失，本命令绑定和解绑必须配套使用，只要绑定了，脚本执行不管成功还是失败，只要执行了绑定都必须执行解绑，切记！！！


宝宝攻击触发

说明: 宝宝攻击触发

[@SlaveMagicStruck]
#ACT
SENDMSG 6 你的宝宝被魔法攻击了
BREAK

[@SlaveMagicAttack]
#ACT
SENDMSG 6 你的宝宝魔法攻击了目标
BREAK

[@SlaveStruck]
#ACT
SENDMSG 6 你的宝宝被物理攻击了
BREAK

[@SlaveAttack]
#ACT
SENDMSG 6 你的宝宝物理攻击目标
BREAK

-----------------------宝宝攻击触发和魔法攻击触发中获取本次触发的宝宝名称-------------------

增加变量<$CurSlaveName>，仅用于[@SlaveAttack]及[@SlaveMagicAttack]中

[@SlaveAttack]
#ACT
SendMsg 5 当前攻击宝宝名为<$CurSlaveName>

[@SlaveAttack]
#IF
EQUAL <$CurSlaveName> 蜈蚣
#ACT
SENDMSG 6 你的蜈蚣宝宝在攻击目标

#IF
EQUAL <$CurSlaveName> 骷髅
#ACT
SENDMSG 6 你的骷髅宝宝在攻击目标

显示完整宝宝名称不去数字的变量：<$CurSlaveFullName> 按需使用

-----------------------宝宝攻击前\掉血前触发(含分身)-------------------

@SlaveAttackDamage 宝宝（含分身）
@SlaveStruckDamage 宝宝（含分身）

[@GamePetStruckDamage]
#ACT
;****** 宠物
SENDMSG 6 宠物被攻击，掉血量为<$Pet.DamageValue>，抵御掉血量的50%
Pet.ChangeDamageValue 1 - 50

[@SlaveStruckDamage]
#ACT
;****** 宝宝不像宠物或英雄，只有一个，可以用H.或Pet.直接访问到这个宠物；而宝宝可能存在多个，多级脚本中就不好处理，所以宝宝用人物的
;SENDMSG 6 宝宝被攻击，掉血量为<$DamageValue>，抵御掉血量的50%
ChangeDamageValue 1 - 50

[@SlaveAttackDamage]
#ACT
;****** 宝宝不像宠物或英雄，只有一个，可以用H.或Pet.直接访问到这个宠物；而宝宝可能存在多个，多级脚本中就不好处理，所以宝宝用人物的
SENDMSG 6 你的宝宝攻击【<$CURRRTARGETNAME>】。，锁定目标<$ATTACKMONSTER_NAMEEX>。坐标：<$ATTACKMONSTER_X>:<$ATTACKMONSTER_Y>掉血量为<$DamageValue>
;SENDMSG 6 宝宝攻击目标，掉血量为<$DamageValue>，攻击加成10点血量
ChangeDamageValue 0 + 10

------------------------------------------


宝宝死亡触发

格式: 宝宝死亡触发qf字段：@OnSlaveDie

[@OnSlaveDie]
#ACT
#sayv 宝宝死亡了

死的宝宝名字，不去数字：<$DIESLAVENAME>

格式: 分身死亡触发qf字段：@OnCloneDie

[@OnCloneDie]
#ACT
#say
分身死亡了


编组地图传送

GROUPMAPMOVE 地图号 X Y 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空) 范围（以队长为中心设置范围，只传送范围内的队友，留空或者0为不需要范围，大于0则按照范围传送）

[@main]
#IF
#ACT
GROUPMAPMOVE 3 333 333 @GROUPMAPMOVE

[@GROUPMAPMOVE]
#IF
#ACT
SENDMSG 6 组队传送

相关命令：
编组地图随机传送：GROUPMOVE
检查是否为组长：ISGROUPMASTER


编组地图随机传送

GROUPMOVE 地图号 可以传送最低等级(可以为空，为空时不检测队员的等级直接传送) 触发字段(可以为空) 范围（以队长为中心设置范围，只传送范围内的队友，留空或者0为不需要范围，大于0则按照范围传送）

[@main]
#IF
#ACT
GROUPMOVE 3 @GROUPMOVE

[@GROUPMOVE]
#IF
#ACT
SENDMSG 6 组队传送

相关命令：
编组地图传送：GROUPMAPMOVE
检查是否为组长：ISGROUPMASTER


变量传递说明

变量传递命令：

设置指定人物的变量值：
SetHumVar 对方的名字 对方的变量 值

获取指定人物的变量 到 自己的变量中：
GetHumVar 对方的名字 对方的变量 自己的变量

变量传递脚本示例：

[@main]
你要把你的防御力数值传给别人,让他知道你的防御力是多少吗\
请确保对方在线\
<请输入对方名字/@@InPutString1> \
对方名字：<$STR(S1)> \

你想知道对方防御力是多少吗,并且不让他知道\
请确保对方在线\
<请输入对方名字/@@InPutString3> \
对方名字：<$STR(S3)>
对方防御力：<$STR(S4)>\

;传递
[@InPutString1]
#IF
#ACT
SetHumVar S1 S2 <$MAXAC>
;S1为对方名字
SENDMSG 6 成功把你的防御力数值传递给对方的S2变量，对方已知道你的防御力多少

;获取
[@InPutString3]
#IF
#ACT
GetHumVar S3 <$MAXAC> S4
;S3 为对方名字 <$MAXAC>对方防御力
;S4 你的变量
SENDMSG 6 你已成功取得对方防御力为<$STR(S4)>


 播放地图魔法特效（仅自己可见）

格式: SelfMapEffect 地图名称 X Y WIL文件序号 开始图片数 播放图片张数 播放次数(-1为无限次数) 播放速度(毫秒) 播放效果(0普通 1特效) (该参数值范围0~5，0表示没有亮度，在关闭禁止免蜡时有效) ID

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

[@main]
#ACT
SelfMapEffect 3 330 330 1 10 20 1 200 1 3 1

=====================================================================================
停止地图魔法播放（停止哪个特效通过参数来判断，参数一致的特效将被停止）
关闭指定特效（参数同 SelfMapEffect 一样，参数一样的删除） 0 - n，指定id（为空表示-1）个特效id可以重复，删除时，指定id的全删

[@main]
#ACT
delMapEffect 3 330 330 1 10 20 1 200 1 3 1


播放人物效果

 设置人物特效播放

格式: PLAYEFFECT WIL文件序号 开始图片数 播放图片张数 播放次数（★ <=0 为永久播放 ★） 播放速度(毫秒) 播放顺序(0或空：对象上层 1：对象底层 2：所有对象上层) X坐标 Y坐标 （不需坐标可留空） 普通播放或特效播放(0或空：特效播放；非0普通播放

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

[@main]
#ACT
PLAYEFFECT 0 0 10 1 300 1

图层播放顺序说明：
0或空 在当前坐标对象的底层播放 (类似火墙)
1 在当前坐标对象的前面 (类似playeffect 效果, 置于对象会在顶层播放,置于坐标Y+1的对象时,会被其遮挡)
2 在全部图层的上方 (不会被其他目标遮挡，类似雷电术)

=====================================================================================
停止人物特效播放（停止哪个特效通过参数来判断，参数一致的特效将被停止）

格式: StopPlayEffect WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 播放顺序(0或空：在角色前面；非0：在角色后面)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

[@main]
#ACT
StopPlayEffect 0 0 10 1 300 1

=====================================================================================
清空人物特效播放（停止所有PLAYEFFECT命令播放的特效）

[@main]
#ACT
ClearPlayEffect

注：本命令支持多级脚本 H.PLAYEFFECT


播放网络MP3

说明: 播放网络上的MP3文件,或者本地MP3文件.
格式: PlayMP3 http://www.lfm2.com/123.mp3
注意: 如果是本地文件会自动搜索客户端Music目录中同名文件.

[@main]
#IF
#ACT
PlayMusic 100.MP3

新增：

PlayMusicEx命令不受声音关闭影响（只能关闭电脑喇叭方式关闭）

PlayMusicEx格式：
PlayMusicEx 文件 循环次数 模式(0:自己;1:所有人;2:当前地图人;3:队友;4:自己周边的人) 参数4
- 参数4: 0或空 多个文件同时播放时,所有声音叠加到一起(目前方式)
- 参数4: 1 上一段播放没结束时,中止声音,开始播放当前内容

[@main]
<播放/@播放>

[@播放]
#act
PlayMusicEX 歌1.MP3 1 0 1


播放音乐

格式: playsound 文件位置 循环次数（设置次数0为无限次数） 播放模式(0播放给自己,1播放给全服,2播放给同一地图,,4播放给同屏人物)

[@main]
#ACT
PLAYSOUND Wav\1.wav 1 0

格式: playsoundExt 文件位置 循环次数（设置次数0为无限次数） 播放模式(0播放给自己,1播放给全服,2播放给同一地图,,4播放给同屏人物)

[@main]
#ACT
playsoundExt Wav\1.wav 1 0

playsoundExt 这个命令只能同时播放一个音乐，播放当前音乐自动停止上一个


称号系统

功能：
完美称号系统
注：必须在!Setup.txt里把该功能打开：ShowRankLevelName= 1

格式：
 SETRANKLEVELNAME %s称号
想人物名字与称号分行显示，只需在%s后面加上\，如：%s\称号

;==========================================
[@NAME]
#IF
#ACT
SETRANKLEVELNAME %s[称号]
#SAY
你的名字后面已经加上[称号]了

英雄为H.SETRANKLEVELNAME
。
;==========================================


创建文件

格式: CREATEFILE 文件名称

[@main]
#ACT
CREATEFILE ..\QuestDiary\名称列表.txt
#SAY
名称列表创建成功


从文件中随机取文本

功能：
从文件中随机取文本。

格式：
 GETRANDOMLINETEXT 文件 字符串变量 指定行(0或空：随机一行；大于0：取指定行；小于0：取倒数第几行) 是否绝对路径(0:不是；1：是)

;==========================================
;示例脚本

[@Main]
#ACT
GetRandomLineText d:\aaa.txt S1 -1 1
SendMsg 4 d:\aaa.txt中倒数第1行内容为：<$STR(S1)>

[@Main]
#ACT
GetRandomLineText d:\aaa.txt S1 -3 1
SendMsg 4 d:\aaa.txt中倒数第3行内容为：<$STR(S1)>

[@Main]
#If
#Act
GETRANDOMLINETEXT ..\QuestDiary\装备列表.txt <$STR(S0)>
#Say
取回的文本是： <$STR(S0)>
;==========================================


从指定文件中删除字符串[!]

功能：
从指定文件中删除字符串和从指定文件中增加字符串。

格式：
 AddTextList 文件位置 字符串 是否绝对路径(0:不是，1：是)
DelTextList 文件位置 字符串

;==========================================
;增加字符串
[@Test老格式]
#IF
#ACT
AddTextList ..\QuestDiary\TestList.txt 您的名字

[@Test新格式]
#IF
#ACT
AddTextList ..\QuestDiary\TestList.txt 您的名字 您的性别
;==========================================

;==========================================
;删除字符串

[@Test老格式]
#IF
#ACT
DelTextList ..\QuestDiary\TestList.txt 您的名字

[@Test1新格式]
#IF
#ACT
DelTextList ..\QuestDiary\TestList.txt 您的名字 您的性别
;==========================================

新格式 老格式都可以使用

绝对路径注意：

DELTEXTLIST E:\哈哈.txt <$USERID> 30 1
DELTEXTLIST E:\哈哈.txt <$USERID> "" 1
如果第3个参数为空，又要指定第4个参数，将第三个参数设置为""
如果第三个参数不想填，又想填第四个参数，就把第三个参数设置为""
因为填第4个参数不能跳过第3个参数，所以特殊处理


打开NPC大对话框[!]

 功能说明：打开NPC大对话框

格式: OPENMERCHANTBIGDLG WIL文件序号 图片序号 是否可以移动(0,1) 显示位置(0=左上角,1=右上角,2=左下角,3=右下角,4=居中) 微调坐标X 微调坐标Y 是否显示关闭按钮(0,1) 关闭按钮坐标X 关闭按钮坐标Y 是否当前NPC对话一直使用此对话框(0和空为不延续，1则延续)

[@main]
#ACT
OPENMERCHANTBIGDLG 0 0


打开OK对话框

格式: OPENUPGRADEDLG 显示的名称

;打开可以放物品的对话框，也就是装备修理或出售物品的那个对话框
OPENUPGRADEDLG 装备升级(显示的名称)

;收回OK框中的物品
TAKEDLGITEM

;返回OK框中的物品到包裹
RECLAIMITEM

点击OK键后触发字段[@UpgradeDlgItem]

触发脚本为当前NPC脚本中的@UpgradeDlgItem

OK升级框位置 -1

例：
[@main]
#ACT
OPENUPGRADEDLG 装备升级(显示的名称)

[@UpgradeDlgItem]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM


打开摆摊（个人商店）脚本命令

命令: openusershop

[@main]
#ACT
openusershop


打开自定义NPC对话框

功能说明: 打开自定义NPC对话框

说明：使用OpenBigDialogBox命令创建自定义NPC对话框

--------------------------------------------------------

命令格式

OpenBigDialogBox 参数如下：

参数1：WIL文件序号
参数2：图片序号
参数3：是否可以移动
参数4：对话框在屏幕上的显示位置（0:左上角; 1:右上角; 2:左下角; 3:右下角; 4:居中)
参数5：对话框微调坐标X
参数6：对话框微调坐标Y
参数7：是否显示关闭按钮（不需要显示则需要填写0，显示为1）
参数8：关闭按钮 X
参数9：关闭按钮 Y

关闭自定义对话框命令：CloseBigDialogBox

--------------------------------------------------------

示例脚本：

[@测试1]
#IF
#ACT
Mov N$UI_N 24
OpenBigDialogBox <$STR(N$UI_N)> 0 1 0 0 0 1 590 26
#Say
这是测试脚本

[@测试2]
#IF
#Act
CloseBigDialogBox
;部分对话框运用可能需要用到先关闭再打开
OpenBigDialogBox 8 109 1 4 0 0 1 530 0
#Say
这是测试脚本


地图缩小，吃鸡

格式: SetMiniMapRange 参数1(地图编号) 参数2(点类型) 参数3(坐标点/中心点) 参数4(半径) 参数5(填色模式) 参数6(填色色号(0-255)) 边界类型 有效时间

SetMiniMapRange 参数1(地图编号) 参数2(点类型) 参数3(坐标点/中心点) 参数4(半径) 参数5(填色模式) 参数6(填色色号(0-255)) 边界类型 有效时间

点类型：
0：自定义坐标点，参数4半径无效。参数3为自定义坐标点，要求点必须按一个方向连续定义，且两2上点之间必须水平或垂直或45度角(X1:Y1;X2:Y2;X3:Y3......);
1：正方形(中心点X:Y + 半径)
2：正菱形(中心点X:Y + 半径)

填色模式
0: 线框围合范围内填充颜色
1: 线框围合范围外填充颜色

边界类型
-1: 不显示边界
1-11: 编号均可使用，主流2或4或5，自行测试设置适合自己的边界光圈

[@测试]
#IF
#ACT
;定义一个正方形形区域
;SetMiniMapRange 3 2 330:330 100 0 249 -1 60

;自定义坐标定义一个菱形区域
SetMiniMapRange 3 0 130:330;330:130;530:330;330:530 100 1 249 2 180

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

检测人物是否在小区域内
CheckInMiniMap，若没有定义小区域，也会返回真

[@检测区域]
#if
CheckInMiniMap
#ACT
SENDMSG 5 在小区域里
#ELSEACT
SENDMSG 5 在小区域外


读写配置项,读写ini配置项

说明：读写ini配置项

---------------------------------------------------------------------------------------------

说明：

WriteConfigFileItem 写配置项 （最后加个参数 1为绝对路径，，0或者留空为默认的相对路径)
功能说明：可以把一些数据进行配置保存 你也可以把它当成一种变量保存方式

ReadConfigFileItem 读配置项 （最后加个参数 1为绝对路径，，0或者留空为默认的相对路径)
功能说明：获取出配置文件中的配置项内容

此两个命令配合使用 就相当于变量保存操作

示例：
[@main]
<写配置项> <请输入你要写入配置项的内容/@@InPutString3>\
<读配置项内容/@读配置项> <$STR(S$配置项内容)>\

[@InPutString3]
#IF
#ACT
;写配置项
WriteConfigFileItem ..\QuestDiary\KEY.txt <$USERNAME> 内容 <$STR(S3)>
SENDMSG 6 你已经把你输入的内容写到配置文件中KEY.txt

[@读配置项]
#IF
#ACT
;读配置项
ReadConfigFileItem ..\QuestDiary\KEY.txt <$USERNAME> 内容 <$STR(S$配置项内容)>
SENDMSG 6 你已经把配置文件KEY.txt中的内容获取出
GOTO @main

删除配置文件中的一行：
DelConfigFileItem 文件名 设置 用户 （删除 用户 = aaaa 这一行）

删除配置文件中的一个区：
DelConfigFileSection 文件名 设置 （删除 [设置] 及设置以下的项）

WriteConfigFileItem ReadConfigFileItem 增加支持绝对路径，注意使用绝对路径参数必须完整！

;================================================================以下命令属高效率=============================

ReadCacheConfigFileItem
WriteCacheConfigFileItem
DelCacheConfigFileItem
DelCacheConfigFileSection

注：这4个是 Cache(缓存)，操作速度会比不带cache的快很多，问题就是，在M2运行过程中，只能用脚本操作，手动操作的无效。如果ini文件不存在手动操作的情况下，就用Cache
Cache的特点是，对ini的操作只打开一次，然后一直在内存缓存，所以只命令操作才有效，手动操作无效。关闭引擎时候才会保存到INI文件内，引擎运行期间一直内存中运行，所以启动引擎后手动修改INI文件信息是无效的

在没有手动操作ini的情况下，推荐用带cache的。不带cache的比较耗时。

比如提现：操作会删除提现记录属于手动操作，所以不能使用cache，但计算战斗力属于内部引擎操作无手动干预，可以使用带cache的！


多元数组元素变量

功能说明: 多元数组 or 元素变量

;-----------------------------------------【赋值元素变量】
;-----------------------------------------给元素变量赋值（非子元素），值两边必须加 []，不然报错。
MOV L$测试 [11,22,33,44,55,66,77,aa]
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[11,22,33,44,55,66,77,aa]
;-----------------------------------------【取各字元素（大于等于0从第一个往后取；小于0从最后一个往前取】
sendmsg 7 输出结果：<$str(L$测试[0])>,<$str(L$测试[1])>,<$str(L$测试[2])>,,,,,<$str(L$测试[-2])>,<$str(L$测试[-1])>,
;输出结果：11,22,33,,,,,77,aa,

;-----------------------------------------【修改子元素】
MOV L$测试[0] 00
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[00,22,33,44,55,66,77,aa]

;-----------------------------------------【增加子元素】
INC L$测试 bb
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[00,22,33,44,55,66,77,aa,bb]

;-----------------------------------------【删除子元素】
Dec L$测试 22
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[00,33,44,55,66,77,aa,bb]

;-----------------------------------------【修改子元素】
Mov L$测试2 [aa,bb,cc]
Mov L$测试[0] <$str(L$测试2)>
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[aa,bb,cc],33,44,55,66,77,aa,bb]

;-----------------------------------------【获取子元素的位置】
GetListVarIndex L$测试 aa N1
sendmsg 7 [L$测试]中"aa"位于第<$STR(N1)>个子元素

;-----------------------------------------【获取子元素数量】
GetListVarCount L$测试 N1
sendmsg 7 [L$测试]中有<$STR(N1)>个子元素

;-----------------------------------------【检查子元素是否存在】
#if
CheckVarInList L$测试 bb
#act
sendmsg 7 [L$测试]中存在"bb"
#elseact
sendmsg 7 [L$测试]中不存在"bb"

;-----------------------------------------【元素支持变量下标（示例）】
Mov N1 1
MOV L$测试[<$Str(N1)>] 23
sendmsg 7 输出结果：<$str(L$测试[<$Str(N1)>])>

;示例2
[@main]
<1.赋值/@mov测试> <2.inc测试/@inc测试> <3.dec测试/@dec测试>\

[@mov测试]
#act
MOV L$测试 [1,2,3,4,5,a]
sendmsg 7 首次赋值(L$测试)的值为：<$STR(L$测试)>
sendmsg 6 ----------------------------------

MOV L$测试[0] b
sendmsg 7 修改后(L$测试)的值为：<$STR(L$测试)>
sendmsg 7 当前(L$测试[0])的值为：<$STR(L$测试[0])>
sendmsg 6 ----------------------------------

MOV N$id 0
MOV L$测试[<$STR(N$ID)>] c
sendmsg 7 当前(L$测试[<$STR(N$ID)>])的值为：<$STR(L$测试[<$STR(N$ID)>])>
sendmsg 6 ----------------------------------

[@inc测试]
#act
inc L$测试 尾部增加元素
inc L$测试[0] 第1个元素增加内容

MOV N$id 1
INC L$测试[<$str(N$id)>] 第2个元素增加内容
sendmsg 7 当前(L$测试)的完整内容：<$STR(L$测试)>
sendmsg 7 当前(L$测试[0])的内容：<$STR(L$测试[0])>
sendmsg 7 当前(L$测试[<$STR(N$id)>])的内容：<$STR(L$测试[<$STR(N$id)>])>
sendmsg 6 ----------------------------------

[@dec测试]
#act
dec L$测试 尾部增加元素
dec L$测试[0] 第1个元素增加内容
sendmsg 7 当前(L$测试)的完整内容：<$STR(L$测试)>
sendmsg 7 当前(L$测试[0])的内容：<$STR(L$测试[0])>
sendmsg 6 ----------------------------------

注意：指定参数必须是变量名的暂不支持变量嵌套
mov N$当前行数 5
MOV L$变<$str(N$当前行数)>量 [赋值内容,赋值内容2]

;以下方法暂不支持,必要时再更新
;MOV N$id 1
;dec L$测试[<$str(N$id)>] 第2个元素增加内容
;sendmsg 7 当前(L$测试[<$STR(N$id)>])的内容：<$STR(L$测试[<$STR(N$id)>])>

[@清空]
#act
MOV L$测试 [11,22,33,44,55,66,77,aa]
sendmsg 7 输出结果：<$str(L$测试)>
Mov L$测试 []
sendmsg 7 输出结果：<$str(L$测试)>

OR

MOV L$测试 [1,2,3] ;----赋值123
MOV L$测试 ;------清空
sendmsg 6 <$str(L$测试)> ;----结果毛都没有 变量都不显示 什么都没

注意：
[@main]
#if
#act
MOV L$测试 [1,2,3]
goto @内容(<$Str(L$测试变量)>)
[@内容]
#if
#act
SENDMSG 6 <$scriptparam1>---显示为[1,2,3]

;-----------------------------------------------------------------相关操作命令--------------------------------
;======================================================
检所有子元素均是数字：
CheckListAllDigit 元素变量

#IF
#ACT
MOV L$测试 [11,22,33,44,55,ff]

#IF
CheckListAllDigit L$测试
#ACT
sendmsg 6 <$STR(L$测试)>中的各子元素全是数字
#ELSEACT
sendmsg 6 <$STR(L$测试)>中有子元素不是数字

;======================================================
获取元素中的最大数字值：
GetListMaxVar 元素变量名 保存变量

获取元素中的最小数字值：
GetListMinVar 元素变量名 保存变量

#IF
#ACT
MOV L$测试 [11,22,33,44,55,66,77,88]
#IF
CheckListAllDigit L$测试
#ACT
GetListMaxVar L$测试 S100
GetListMinVar L$测试 S101
sendmsg 7 输出结果：<$str(L$测试)>中的最大值为<$str(S100)>，最小值为<$str(S101)>
#ELSEACT
sendmsg 7 <$str(L$测试)>内有非法数值，取值失败
;输出结果：[11,22,33,44,55,66,77,88]中的最大值为88，最小值为11
****************** 以上2个命令必须要求元素中的所有子元素必须是数字，否则得到的结果是error

;======================================================
元素翻转（反序）：
ReverseList 元素变量名 保存元素变量
#IF
#ACT
MOV L$测试 [11,22,33,44,55,66,77,aa]
ReverseList L$测试 L$测试
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[aa,77,66,55,44,33,22,11]

;======================================================
元素排序：
SortList 待排序元素变量 保存结果元素变量 排序方式(空或0:升序-从低到高；1:降序-从高到低) 排序依据(0或空:根据数值排序；1:根据文本排序)
***** 当排序依据为数值时，元素中的所有子元素必须全是数字，否则会得到[error]

MOV L$测试 [11,33,22,44,55,66,77]
SortList L$测试 L$测试2 0 0
sendmsg 7 按数字升序排序输出结果：<$str(L$测试2)>
;按数字升序排序输出结果：[11,22,33,44,55,66,77]

MOV L$测试 [11,33,22,44,55,66,77,aa]
SortList L$测试 L$测试2 1 0
sendmsg 7 按数字降序排序输出结果：<$str(L$测试2)>
;按数字降序排序输出结果：[error]

MOV L$测试 [aa,cc,dd,bb,ee,ff]
SortList L$测试 L$测试2 0 1
sendmsg 7 按文本升序排序输出结果：<$str(L$测试2)>
;按文本升序排序输出结果：[aa,bb,cc,dd,ee,ff]

MOV L$测试 [aa,cc,dd,bb,ee,ff]
SortList L$测试 L$测试2 1 1
sendmsg 7 按文本降序排序输出结果：<$str(L$测试2)>
;按文本降序排序输出结果：[ff,ee,dd,cc,bb,aa]

;======================================================

################# 以下 2024-06月 重新整理的数组文档 （该文档和上面一样） ##################

变量操作
赋值：
直接赋值
↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓
MOV L$数组 [字符1,字符2,字符3,字符4]
MOV L$数组1 [1,2,3,4]
SENDMSG 6 数组的值为:<$STR(L$数组)>，<$STR(L$数组1)>

变量赋值
↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓↓
MOV S$字符串 [字符1,字符2,字符3,字符4]
MOV L$数组2 <$STR(S$字符串)>
SENDMSG 6 数组的值为:<$STR(L$数组2)>

取值：（中括号内的数字叫：下标，下标从0开始）
MOV L$数组3 [字符1,字符2,字符3,字符4]
MOV S$数组第一个值 <$STR(L$数组3[0])> ;输出得到：字符1
MOV S$数组第二个值 <$STR(L$数组3[1])> ;输出得到：字符2
MOV N$数组下标3 2
MOV S$数组第三个值 <$STR(L$数组3[<$STR(N$数组下标3)>])>;输出得到：字符3

修改值:
MOV L$数组4 [字符1,字符2,字符3,字符4]
MOV L$数组4[0] 张三 ;结果为[张三,字符2,字符3,字符4]
INC L$数组4[1] 李四 ;结果为[张三,字符2李四,字符3,字符4]
DEC L$数组4[1] 李四 ;结果为[张三,字符2,字符3,字符4]
DEC L$数组4 张三 ;结果为[字符2,字符3,字符4]
MOV N$数组下标1 1
MOV L$数组4[<$STR(N$数组下标1)>] 王五 ;结果为[字符2,王五,字符4]

----------------------------------------------------------------------------------------------------

数组命令
功能：获取值位置
格式：GetListVarIndex 数组变量 值 接收变量

例子：
[@数组例子]
#IF
#ACT
MOV L$数组4 [字符1,字符2,字符3,字符4]
GetListVarIndex L$数组4 字符3 N$值所在位置
SENDMSG 6 字符3在数组的第<$STR(N$值所在位置)>个位置。;结果为3

----------------------------------------------------------------------------------------------------

功能：获取数组值数量
格式：GetListVarCount 数组变量 接收变量

例子：
[@数组例子]
#IF
#ACT
MOV L$数组5 [字符1,字符2,字符3,字符4]
GetListVarCount L$数组5 N$数组元素数量
SENDMSG 6 L$数组内共存在<$STR(N$数组元素数量)>个元素。;结果为4

----------------------------------------------------------------------------------------------------

功能：检查值是否存在于数组中
格式：CheckVarInList 数组变量 值

例子：
[@数组例子]
#IF
#ACT
MOV L$数组5 [字符1,字符2,字符3,字符4]

#IF
CheckVarInList L$数组5 bb
#ACT
SENDMSG 6 [L$数组5]中存在"bb"
#ELSEACT
SENDMSG 7 [L$数组5]中不存在"bb"

----------------------------------------------------------------------------------------------------

功能：检查数组内所有值是否均为数字
格式：CheckListAllDigit 数组变量

例子：
[@数组例子]
#IF
#ACT
MOV L$测试 [11,22,33,44,55,ff]

#IF
CheckListAllDigit L$测试
#ACT
SENDMSG 6 <$STR(L$测试)>中的各子元素全是数字
#ELSEACT
SENDMSG 6 <$STR(L$测试)>中有子元素不是数字

----------------------------------------------------------------------------------------------------

功能：获取元素中的最大数字值
格式：GetListMaxVar 数组变量 接收变量
功能：获取元素中的最小数字值：
格式：GetListMinVar 元素变量名 接收变量
****************** 以上2个命令必须要求元素中的所有子元素必须是数字，否则得到的结果是error

例子：
[@数组例子]
#IF
#ACT
MOV L$测试 [11,22,33,44,55,66,77,88]

#IF
CheckListAllDigit L$测试
#ACT
GetListMaxVar L$测试 S100
GetListMinVar L$测试 S101
SENDMSG 7 输出结果：<$str(L$测试)>中的最大值为<$STR(S100)>，最小值为<$STR(S101)> ;最大值为88,最小值为11
#ELSEACT
SENDMSG 7 <$STR(L$测试)>内有非法数值，取值失败

----------------------------------------------------------------------------------------------------

功能：数组排序
格式：SortList 待排序数组变量 接收变量 排序方式(空或0:升序-从低到高；1:降序-从高到低) 排序依据(0或空:根据数值排序；1:根据文本排序)
****************** 以上命令要么全是数字,要么全是字符，否则得到的结果是error

例子：
[@数组例子]
#IF
#ACT
MOV L$测试 [66,77,11,33,22,44,55]
SortList L$测试 L$测试2 0 0
SENDMSG 7 按数字升序排序输出结果：<$STR(L$测试2)> ;按数字升序排序输出结果：[11,22,33,44,55,66,77]

MOV L$测试 [aa,cc,dd,bb,ee,ff]
SortList L$测试 L$测试2 1 1
SENDMSG 7 按文本降序排序输出结果：<$STR(L$测试2)> ;按文本降序排序输出结果：[ff,ee,dd,cc,bb,aa]

----------------------------------------------------------------------------------------------------

功能：数组翻转
格式：ReverseList 待翻转数组 接收变量

例子：
[@数组例子]
#IF
#ACT
MOV L$测试 [11,22,33,44,55,66,77,aa]
ReverseList L$测试 L$测试
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[aa,77,66,55,44,33,22,11]

################### 以下 2024-06月 新增的数组使用操作命令 ################

功能：数组追加元素
格式：AddToList 数组变量 值
等同于：Inc 数组变量 值

例子：
[@数组例子]
#IF
#ACT
MOV L$测试 [11,22,33,44,55,66,77,aa]
AddToList L$测试 bb
;***********等同于Inc L$测试 bb
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[11,22,33,44,55,66,77,aa,bb]
----------------------------------------------------------------------------------------------------

功能：数组插入元素(插入到某个元素之前)
格式：InsertToList 数组变量 值 插入位置(-1为数组最后一位)

例子：
[@数组例子]
#IF
#ACT
MOV L$测试 [11,22,33,44,55,66,77,aa]
InsertToList L$测试 bb 2
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[11,22,bb,33,44,55,66,77,aa]

----------------------------------------------------------------------------------------------------

功能：根据下标替换数组中的元素
格式：ReplaceListByIndex 数组变量 替换值 数组下标
等同于：Mov 数组[下标] 值
例子：
[@数组例子]
#IF
#ACT
MOV L$测试 [11,ab,AB,AB,55,66,77,aa]
ReplaceListByIndex L$测试 bb 2
;***********等同于 Mov L$测试[2] bb
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[11,ab,bb,AB,55,66,77,aa]

----------------------------------------------------------------------------------------------------
功能：根据值替换数组中的元素
格式：ReplaceListByContent 数组变量 旧值 新值 区分大小写(0:不区分;1:区分)

例子：
[@数组例子]
#IF
#ACT
MOV L$测试 [11,ab,bb,AB,55,66,77,aa]
ReplaceListByContent L$测试 ab ac 1
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[11,ac,bb,AB,55,66,77,aa]

----------------------------------------------------------------------------------------------------

功能：根据下标删除数组中的元素
格式：RemoveListByIndex 数组变量 数组下标
例子：
[@数组例子]
#IF
#ACT
MOV L$测试 [11,33,33,33,55,66,77,aa]
RemoveListByIndex L$测试 5
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[11,33,33,33,55,77,aa]

例子2：
[@数组例子]
RemoveListByIndex L$1 -1
sendmsg 7 当前结果：<$str(L$1)>
sendmsg 7 正确结果：[11,22,33]
;命令均支持大于等于0从第一个往后取；小于0从最后一个往前取
MOV L$1 [11,22,33,44]
RemoveListByIndex L$1 -2
sendmsg 7 当前结果：<$str(L$1)>
sendmsg 7 正确结果：[11,22,44]

----------------------------------------------------------------------------------------------------

功能：根据内容删除数组中的元素
格式：RemoveListByContent 数组变量 元素内容 区分大小写(0:不区分;1:区分)
***********注意：Dec 数组变量 元素内容，也可以删除数组中的元素值，Dec删除元素值时，但是只删第一个匹配到的值
例子：
[@数组例子]
#IF
#ACT
MOV L$测试 [11,33,33,33,55,66,77,aa]
RemoveListByContent L$测试 33
sendmsg 7 输出结果：<$str(L$测试)>
;输出结果：[11,55,66,77,aa]

----------------------------------------------------------------------------------------------------

功能：数组切片
格式：ExtractList 数组变量 保存变量(可为L、S、T、A等) 起点索引 终点索引 步长(可空，默认1)

例子：
[@数组例子]
#IF
#act
MOV L$测试 [0,1,2,3,4,5,6,7,8,9]
ExtractList L$测试 S$保存 0 3
sendmsg 7 当前输出：<$STR(S$保存)>
sendmsg 7 正确输出：[0,1,2,3]
;-------------------------------------------------
MOV L$测试 [0,1,2,3,4,5,6,7,8,9]
ExtractList L$测试 L$保存 0 3 2
sendmsg 7 当前输出：<$STR(L$保存)>
sendmsg 7 正确输出：[0,2]
;-------------------------------------------------
MOV L$测试 [0,1,2,3,4,5,6,7,8,9]
ExtractList L$测试 L$保存 5 8 1
sendmsg 7 当前输出：<$STR(L$保存)>
sendmsg 7 正确输出：[5,6,7,8]
;-------------------------------------------------
MOV L$测试 [0,1,2,3,4,5,6,7,8,9]
ExtractList L$测试 L$保存 -1 -5 1
sendmsg 7 当前输出：<$STR(L$保存)>
sendmsg 7 正确输出：[9,8,7,6,5]


发送屏幕滚动信息

功能:

发送屏幕滚动信息

格式:

SENDMOVEMSG 信息类型代码(0-7)0全局发送1发送给个人 字体颜色(0-255) 背景颜色(0-255) Y坐标 滚动次数 信息内容 字体大小 滚动速度 范围

[@测试]
#if
#act
SENDMOVEMSG 1 253 255 350 1 这个是屏幕滚动信息坐标在350 10 200 0

SENDMOVEMSG 0 253 0 130 5 {[双倍护送]/SCOLOR=251}振威镖局接镖已经开启{[双倍护送]/SCOLOR=251}，请各位玩家前往镇魔大陆请各位玩家前往镇魔大陆{[双倍护送]/SCOLOR=251}XXXXX..... 0 2 30 0

插入颜色：{内容/SCOLOR=颜色}

信息类型介绍：

0: 所有在线人物
1：自己
2：对友(包含自己)； 范围=0；所有对友； 范围>0；在自己范围之内的队友
3: 行会所有成员(包含自己)； 范围=0；行会所有成员； 范围>0；在自己范围之内的行会成员
4: 同一地图所有人物(包含自己)； 范围=0；同一地图所有人物； 范围>0；在自己范围之内的人物
5: 对友(不包含自己)； 范围=0；所有对友； 范围>0；在自己范围之内的队友
6: 行会所有成员(不包含自己)； 范围=0；行会所有成员； 范围>0；在自己范围之内的行会成员
7: 同一地图所有人物(不包含自己)； 范围=0；同一地图所有人物； 范围>0；在自己范围之内的人物


发送屏幕中间大字体信息

功能: 在专用登录器屏幕的中间显示公告.
格式: SendCenterMsg 前景色 背景色 消息文字 模式 显示时间 倒计时标签 是否替换模式（0或空为不替换，不等于0为替换模式) X坐标
模式: 0=发送给自己 1=发送所有人物 2=发送行会 3=无 4=发送当前地图.
说明: 设置倒计时标签时可执行自定义脚本功能.

例子:
[@main]
#IF
#ACT
SendCenterMsg 180 251 这是一个居中显示的公告. 0

例子:显示30秒.
[@main]
#IF
#ACT
SendCenterMsg 180 251 这是一个居中显示的公告. 0 30

执行倒计时标签(注意:文字提示中必须包含%d):
[@main]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d发放新手奖励. 0 30 @GiveNewHumanItem

QFunction中:
[@GiveNewHumanItem]
#IF
#ACT
Give 金条 1
Give 裁决之杖 1
Give 圣战戒指 2
Give 圣战手镯 2
Give 圣战头盔 1
Give 圣战项链 1
Give 天魔神甲 1

==============================================以下为2013-08-03新增仿官方屏幕公告=================================================================================================

屏幕显示信息分个人和全局

文字向上缓消模式SuperMoveMsg 信息类型代码(0-7)0全局发送1发送给个人 字体颜色(0-255) 背景颜色(0-255) 字体大小 Y坐标 滚动次数 信息内容||换行符号 范围 X坐标

示列：

#if
#act
SuperMoveMsg 1 251 0 20 100 3 这个是个人屏幕信息~坐标在100||欢迎使用翎风引擎|| 引擎官方网站：||http://www.lfm2.com

#if
#act
SuperMoveMsg 0 251 0 20 200 5 这个是全局屏幕信息~坐标在200||欢迎使用翎风引擎|引擎官方网站：||http://www.lfm2.com

信息类型代码介绍：
0: 所有在线人物
1：自己
2：对友(包含自己)； 范围=0；所有对友； 范围>0；在自己范围之内的队友
3: 行会所有成员(包含自己)； 范围=0；行会所有成员； 范围>0；在自己范围之内的行会成员
4: 同一地图所有人物(包含自己)； 范围=0；同一地图所有人物； 范围>0；在自己范围之内的人物
5: 对友(不包含自己)； 范围=0；所有对友； 范围>0；在自己范围之内的队友
6: 行会所有成员(不包含自己)； 范围=0；行会所有成员； 范围>0；在自己范围之内的行会成员
7: 同一地图所有人物(不包含自己)； 范围=0；同一地图所有人物； 范围>0；在自己范围之内的人物
8: 国家模式，仅对自己的国家成员

---------------------------------------------------------------------------------------------------------------------------------------------------------------------

// 脚本命令：SendNewLineMsg 信息类型代码(0-7)0全局发送1发送给个人 字体颜色(0-255) 背景颜色(0-255) 字体大小 Y坐标 显示时间 绘制方式(0-2)0带透明框绘制 1淡入淡出绘制 2不带透明框绘制 信息内容||换行符号 范围 X坐标

调用示例：

[@SuperMOVEMSG2]
#IF
#ACT
SendNewLineMsg 0 251 0 15 100 10 2 不带透明框绘制测试||欢迎使用翎风引擎||官方网站：www.lfm2.com
break

[@SuperMOVEMSG0]
#IF
#ACT
SendNewLineMsg 0 251 0 15 100 10 0 带透明框绘制测试||欢迎使用翎风引擎||官方网站：www.lfm2.com
break

[@SuperMOVEMSG1]
#IF
#ACT
SendNewLineMsg 0 251 0 15 100 10 1 淡入淡出绘制测试||欢迎使用翎风引擎||官方网站：www.lfm2.com
break

注：换行符号为“||” ，文字中间如果需要夹杂其他颜色则使用{信息|F:B:M}，具体请参考聊天框自定义颜色（说明书搜索：聊天框 ）

支持自定义颜色公告命令分别为：
SuperMoveMsg
SendCenterMsg
SENDDELAYMSG
SendNewLineMsg

调用示例脚本：

[@测试公告]
#if
#act
SuperMoveMsg 1 251 0 20 100 3 这个是{个人|253:0:1}屏幕信息~坐标在100||欢迎使用翎风世界引擎|| 引擎官方网站：||http://www.lfm2.com

信息类型代码介绍：
0: 所有在线人物
1：自己
2：对友(包含自己)； 范围=0；所有对友； 范围>0；在自己范围之内的队友
3: 行会所有成员(包含自己)； 范围=0；行会所有成员； 范围>0；在自己范围之内的行会成员
4: 同一地图所有人物(包含自己)； 范围=0；同一地图所有人物； 范围>0；在自己范围之内的人物
5: 对友(不包含自己)； 范围=0；所有对友； 范围>0；在自己范围之内的队友
6: 行会所有成员(不包含自己)； 范围=0；行会所有成员； 范围>0；在自己范围之内的行会成员
7: 同一地图所有人物(不包含自己)； 范围=0；同一地图所有人物； 范围>0；在自己范围之内的人物
8: 国家模式，仅对自己的国家成员


发送文字信息

功能：
利用NPC发送信息。

格式：
 SENDMSG 信息类型代码 %s信息内容%d 字体颜色(0-255) 背景颜色(0-255)

信息类型代码：（信息后面不加自定义颜色为默认颜色）
1、发送普通红色广播信息。
2、发送普通红色广播信息，并显示NPC名称。
3、发送普通红色广播信息，并人物NPC名称。
4、在NPC头顶，显示普通说话信息。
5、发送红色信息给人物
6、发送绿色信息给人物
7、发送蓝色信息给人物
8、和普通说话信息一样，角色头顶显示

%s 代表人物名称
%d 代表NPC名称

命令格式：
[@test]
#IF
#ACT
SENDMSG 0 %s信息内容%d 249 47
SENDMSG 1 %s信息内容%d 249 47
SENDMSG 2 %s信息内容%d 249 47
SENDMSG 3 %s信息内容%d 249 47
SENDMSG 4 %s信息内容%d
SENDMSG 5 %s信息内容%d 249 47
SENDMSG 6 %s信息内容%d 249 47
SENDMSG 7 %s信息内容%d 249 47
SENDMSG 8 信息内容
==================================================


返回OK框中的物品

格式: RECLAIMITEM

;返回OK框中的物品到包裹

例：
[@main]
#ACT
RECLAIMITEM


分割字符串[!]

功能：
分割字符串.

格式: TextSplit 分割符 源字符串 保存变量(只指定第一个，后面的递增) 返回分割数量

示列：

[@mail]
#ACT
TextSplit | aaa|bbb|ccc|ddddd|eeeeee s1 N$数量
SENDMSG 6 <$STR(s1)>,<$STR(s2)>,<$STR(s3)>,<$STR(s4)>,<$STR(s5)> ,分成了<$str(N$数量)>个变量


复活命令

说明: 给予角色有限时间的复活功能(此命令不受复活间隔控制，可以按照设置参数无限复活，按需使用)

格式：
命令: Setreborn 参数一 参数二
参数一 复活次数
参数二 命令持续有效时间

[@测试脚本]
#act
Setreborn 10 300
SendMsg 6 npc设置复活10次，有效时间5分钟

------------------------------------------------------qf触发

[@NpcRevival]
#act
SendMsg 6 命令剩余复活次数：<$NpcRebornCount>，已使用复活次数<$TriggerNpcRebornCount>


复活人物

格式: REALIVE

[@main]
#ACT
REALIVE


复制文件

格式: CopyFile 源文件 目标文件 是否覆盖目标(强制创建并覆盖目标文件 1:目标文件已存在不覆盖)

[@main]
#ACT
CopyFile ..\QuestDiary\列表.txt D:\列表.txt 0
#SAY
文件复制成功


改变宝宝名字颜色

功能: 改变人物宝宝名字颜色.
格式: ChangeSlaveNameColor 宝宝名字 颜色(0-255)


改变人物状态

格式: MAKEPOSION 类型(0-5,0和1是绿毒和红毒 5是麻痹 其他无效) 时间(秒) 威力 是否算防御目标的对应属性(1/0) 是否千分比计算威力(1/0)

例：
[@main]
#ACT
MAKEPOSION 5 10 10
#SAY
你被麻痹了

[@中红毒]
#ACT
MAKEPOSION 1 10 50 1
SENDMSG 6 防御减少50点

[@中绿毒]
#ACT
MAKEPOSION 0 10 50 1
SENDMSG 6 中毒了，每次伤害值50点

[@中红毒1]
#ACT
MAKEPOSION 1 10 50 1 1
SENDMSG 6 防御减少5%or千分之五十

[@中绿毒1]
#ACT
MAKEPOSION 0 10 10 1 1
SENDMSG 6 中毒了，每次伤害值1%or千分之十

是否算防御目标的对应属性 意思 就是是否无视麻痹防御 、防御全毒属性


高等级杀怪经验不变

格式:HighLevelKillMonFixExp 时间 是否保存（1保存，空或0不保存）

[@main]
#ACT
HighLevelKillMonFixExp 720 1


隔位野蛮冲撞

格式：SetSpaceMotaebo 时间(-1:关;0:在线一直有效;>0:秒)
提示：使用此命令需关闭M2野蛮冲撞技能参数界面中隔位野蛮选项

[@隔位野蛮]
#act
SetSpaceMotaebo 3
sendmsg 7 隔位野蛮开启3秒钟


个人定时器

功能：
个人定时器。

格式：
 SETONTIMER 定时器索引(0-255) 定时间隔（单位为秒）执行次数（留空为无限制执行，需使用停止定时器方可关闭，填写3为执行3次后自动关闭定时器）
SETOFFTIMER 定时器索引(0-255) //停止定时器

;==========================================
设置定时器
[@Test]
#IF
#ACT
SetOnTimer 0 20

QManage.txt:
[@OnTimer0]
#ACT
SendMsg 5 你目前位于%m的(%x：%y)
;==========================================

;==========================================
停止定时器
[@Test]
#IF
#ACT
SetOffTimer 0
;==========================================


给人物指定爆率文件命令

说明: 给人物指定爆率文件命令

载入爆率配置：
LoadMonItems 怪物名 配置文件名 @区段（不要[]，可以为空）

LoadMonItems 白野猪 QuestDiary\爆率系统\基础爆率.txt @药水

LoadMonItems 白野猪 MonItems\稻草人.txt

恢复默认爆率配置：
ResetMonItems 怪物名

恢得所有默认爆率配置：
ResetAllMonItems


更改人物颜色

功能：
更改人物颜色。

格式：
CHANGENAMECOLOR 颜色代码(0-255)

;==========================================
;设置人物的名称颜色
[@changeexp0]
#IF
#ACT
CHANGENAMECOLOR 2
#SAY
你的颜色已改变。
;==========================================


更改头发类型

功能：
更改头发类型

格式：
;============================
[@ChangeHair]
#if
#act
HAIRSTYLE 0
#say
你的头发已更改
;============================


更换性别

功能：
更换性别。

格式：
 CHANGEGENDER 性別(男 0 女 1)

;==========================================
[@toman]
#IF
#ACT
CHANGEGENDER 0
#SAY
呵呵，你已经变成一位猛男了。\ \

[@towoman]
#IF
#ACT
CHANGEGENDER 1
#SAY
呵呵，你已经变成一位淑女了。\ \


挂机命令[!]

功能: 挂机命令

格式:ISDUPMODE (0或空时检测所有对象，1只检测人物)

范例地址：挂机范例脚本


关闭NPC大对话框

格式: CLOSEMERCHANTBIGDLG

[@main]
#ACT
CLOSEMERCHANTBIGDLG

注意：上面的命令如果不能完美关闭自定义NPC大对话框，请使用下面的命令

<关闭对话框/@EXIT> 或者 制作自定义关闭按钮图片：<Img:287:0:0:0/@EXIT>


关闭自定义NPC对话框

CloseBigDialogBox

注意：上面的命令如果不能完美关闭自定义NPC大对话框，请使用下面的命令

<关闭对话框/@EXIT> 或者 制作自定义关闭按钮图片：<Img:287:0:0:0/@EXIT>


过滤全服提示信息

功能：
过滤全服提示信息
格式：FILTERGLOBALMSG 过滤类型 是否过滤(0不过滤，1过滤)

;过滤掉落提示信息（最后参数为1或者0,0或者空关闭过滤）
FILTERGLOBALMSG 1 1

;过滤SendCenterMsg全局信息（信息模式1）（最后参数为1或者0,0或者空关闭过滤）
FILTERGLOBALMSG 2 1

;过滤SENDMSG全局信息（信息代码0123）（最后参数为1或者0,0或者空关闭过滤）
FILTERGLOBALMSG 3 1

;过滤SENDMOVEMSG信息（最后参数为1或者0,0或者空关闭过滤）
FILTERGLOBALMSG 4 1

列： （信息代码0123）为以下格式公告 只过滤全局（所有人发送相同信息，SendCenterMsg也是一样只过滤模式 1的全局消息）
SENDMSG 0 信息内容
SENDMSG 1 信息内容
SENDMSG 2 信息内容
SENDMSG 3 信息内容

[@main]
#ACT
FILTERGLOBALMSG 1 1
SENDMSG 6 开启过滤全服掉落提示信息。

[@main]
#ACT
FILTERGLOBALMSG 1 0
SENDMSG 6 关闭过滤全服掉落提示信息。

[@main]
#ACT
FILTERGLOBALMSG 2 1
SENDMSG 6 开启过滤SendCenterMsg全局信息。

[@main]
#ACT
FILTERGLOBALMSG 2 0
SENDMSG 6 关闭过滤SendCenterMsg全局信息。

[@main]
#ACT
FILTERGLOBALMSG 3 1
SENDMSG 6 开启过滤全服SENDMSG0和SENDMSG1和SENDMSG2和SENDMSG3信息。

[@main]
#ACT
FILTERGLOBALMSG 3 0
SENDMSG 6 关闭过滤全服SENDMSG0和SENDMSG1和SENDMSG2和SENDMSG3信息。

[@main]
#ACT
FILTERGLOBALMSG 4 1
SENDMSG 6 开启过滤SENDMOVEMSG信息。

[@main]
#ACT
FILTERGLOBALMSG 4 0
SENDMSG 6 关闭过滤SENDMOVEMSG信息。


行会地图传送

GUILDMAPMOVE 地图号 X Y 最低等级
只有行会掌门，才可以使用

[@guildmapmove]
#if
#act
GUILDMAPMOVE 3 330 330 0


行会地图随机传送

GUILDMOVE 地图号 最低等级
只有行会掌门，才可以使用

[@guildmove]
#if
#act
GUILDMOVE 3 0


行会建设相关

修改行会建筑度:
格式： GUILDBUILDPOINT 控制符（+-）数字

修改行会人气度:
格式： GUILDAURAEPOINT控制符（+-）数字

修改行会安定度:
格式： GUILDSTABILITYPOINT控制符（+-）数字

修改行会繁荣度:
格式：GUILDFLOURISHPOINT控制符（+-）数字

检测行会建筑度：
格式： CHECKGUILDBUILDPOINT 控制符（<>=）数字

检测行会行会人气度:
格式： CHECKGUILDAURAEPOINT 控制符（<>=）数字

检测行会安定度:
格式： CHECKGUILDSTABILITYPOINT 控制符（<>=）数字

检测行会繁荣度：
格式: CHECKGUILDFLOURISHPOINT 控制符（<>=）数字

变量：
<$GUILDBUILDPOINT> 行会建筑度
<$GUILDAURAEPOINT> 行会人气度
<$GUILDSTABILITYPOINT> 行会安定度
<$GUILDFLOURISHPOINT> 行会繁荣度


回收指定位置装备

功能：
回收指定位置装备

命令：
TakePosW 物品位置

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 灵玉
18 时装衣服
19 时装武器
20 时装项链
21 时装头盔
22 时装左手镯
23 时装右手镯
24 时装左戒指
25 时装右戒指
26 时装勋章
27 时装腰带
28 时装靴子
29 时装宝石
30-35 首饰盒
40-51 生肖盒

例子：
[@测试]
#if
#act
TakePosW 1
TakePosW 30
TakePosW 40
sendmsg 5 武器，首饰1，生肖1已被回收


获取背包中某物品的数量[!]

功能：
获取背包中某物品的数量.

格式: GetBagItemCount 物品名称 保存变量 排除OK框中的物品(0或空:计算OK框的物品，1：不算OK框中的物品) 是否判断满持久(0:或空不判断； 1：判断）

示列：

[@mail]
#ACT
GetBagItemCount 屠龙 N1
SENDMSG 6 你的背包中共有<$STR(N1)>把屠龙


获取地图中某怪物的坐标[!]

功能：
获取地图中某怪物的坐标.

格式: CheckMapMonInfo 地图名称 怪物名称 X坐标变量 Y坐标变量 允许获取改名怪物(1获取，0或空为不获取)

示列：

[@mail]
#IF
CheckMapMonInfo 3 白野猪 n1 n2
#ACT
SENDMSG 6 盟重有个白野猪在<$STR(N1)>:<$STR(N2)>


获取对面人物的名字

说明: 获取对面人物的名字
格式: GetOppositeHumName 变量

#IF
#ACT
GetOppositeHumName S0
SendMsg 5 你对面的人物是: <$STR(S0)>


获取怪物原始各项参数

说明: 获取怪物原始各项参数

格式：通过怪物名字取数据库字段值 GetDBMonsterFieldValue 怪物名称 字段名 变量

GetDBMonsterFieldValue 魔龙教主 HP <$STR(N1)>


获取技能快捷键、设置技能快捷键

获取技能快捷键：GetSkillKey 技能名称 变量

变量的结果为数字，对应于下:
;49~56: F1~F8
;69~76: Ctrl+F1 ~ Ctrl + F8
;97~122: A-Z

[@获取烈火快捷键]
#if
#act
GetSkillKey 烈火剑法 N1
sendmsg 6 你的烈火剑法设置快捷键为<$STR(N1)>

------------------------------------------------------------------------------

设置技能快捷键：SetSkillKey 技能名称 快捷键值

[@设置烈火快捷键]
#if
#act
SetSkillKey 烈火剑法 76
sendmsg 6 你的烈火剑法设置快捷键为Ctrl+F8


获取技能信息命令

-----------------------------------获取技能信息命令---------------------------

功能说明：获取技能信息命令

获取技能信息：
GetMagicInfo 技能名称 值类型 变量
值类型：
0：技能等级
1：强化等级
2：技能点数

示范：

[@KTZ]
GetMagicInfo 开天斩 0 N1
GetMagicInfo 开天斩 1 N2
GetMagicInfo 开天斩 2 N3
SENDMSG 6 技能等级：<$str(N1)>，强化等级：<$str(N2)>，技能点：<$str(N3)>


获取某地图怪物数量 [!]

功能：
获取某地图怪物数量 .

格式: GetMapMonCount 地图名 是否排除宝宝(0：不排除，1：排除) 保存变量

示列：

[@mail]
#ACT
GetMapMonCount 3 0 N1
SENDMSG 6 地图3一共有<$STR(N1)>个怪物

如：<$STR(N1)>无法获取地图号N开头的地图，那么可以将变量更换为：<$const(n1)>


获取某地图人物数量 [!]

功能：
获取某地图人物数量 .

格式: GetMapHumanCount 地图名 不算假人(0：算假人，1：不算假人) 保存变量

示列：

[@mail]
#ACT
GetMapHumanCount 3 1 N1
SENDMSG 6 地图3一共有<$STR(N1)>个真实玩家

如：<$STR(N1)>无法获取地图号N开头的地图，那么可以将常量更换为：<$const(n1)>


获取人物全身星星数量[!]

功能：
获取人物全身星星数量.

格式:GetUpgradeCount 位置 变量

说明：位置支持OK框，装备，首饰，神佑，all或*表示取得身上所有装备星星的数量

示列：

[@mail]
#ACT
GetUpgradeCount 1 n1
SENDMSG 6 武器一共有<$STR(N1)>个星星

------------------------------------------------------------------

全身星星数量变量人物：<$UpgradeCount> 英雄：<$H.UpgradeCount>


获取文本字符

GetRandomText 文件路径 变量


获取物品原始各项数据库字段值参数

说明：获取物品原始各项数据库字段值参数

格式：通过物品名字取数据库字段值 GetDBItemFieldValue 物品名称 字段名 变量
格式：通过 IDX 字段取数据库字段值 GetDBIdxItemFieldValue idx 字段名 变量

---------------------------------------------------------------------------------------------
示范脚本：

[@循环]
#ACT
GetDBItemFieldValue 屠龙 idx <$STR(N1)>
GetDBItemFieldValue 屠龙 stdmode <$STR(N2)>
sendmsg 6 idx ：<$STR(N1)> ,stdmode:<$STR(N2)>

===========================================================================================================================
详细参考示范脚本：

;以下所有内容大家都可以自己选择任何设置方式和应用，不一定非是商铺，可以很多方式也可以很多应用
;只拿【商铺来购买金币物品】进行举例，如有不足还请见谅，毕竟脚本这个东西需要脑子去无数次的想！
;本脚本由群友提供有问题可以私密，QQ：815915131 大叔
;切记！！将下列脚本内容放入到MirServer\Mir200\Envir\Market_Def\QFunction-0.txt中去！
;——————————————————————————————商城购物触发字段
[@BuyShopItem]
#if
;——————————————————————————————检测当前购入的物品是否在你设置允许批量购买的路径名单中
CHECKTEXTLIST ..\QuestDiary\商城批量购物\金币物品.txt <$STR(S0)>
#act
;——————————————————————————————清理之前购买的物品名和价格（保完全，可以不用）
MOV S$商城当前购入物品名
MOV N$商城当前购入物品单 0
;——————————————————————————————将当前价格写入变量
MOV S$商城当前购入物品名 <$STR(S0)>
MOV N$商城当前购入物品单价 <$STR(M0)>
;——————————————————————————————如果你当前购入的物品是你允许批量购买的物品时，则提取IDX
GetDBItemFieldValue <$STR(S$商城当前购入物品名)> idx N$商铺购买物品代码
;——————————————————————————————转向下段脚本
goto @在线_商铺批量购买
break

;————————————————————————————————————————————————————————金币类批量购买
[@在线_商铺批量购买]
#act
;——————————————————————————————设置自定义对话框
OPENMERCHANTBIGDLG 176 19 1 0 10 70 1 190 8 1
;——————————————————————————————将单价乘以数量后写入总价格
MUL N$批量商铺购买物品总金额 <$STR(N$商城当前购入物品单价)> <$STR(N$批量商铺购买物品数量)>
#say
;——————————————————————————————触发对话，并且调用之前已经提取号的IDX变量
<ItemShow:<$STR(N$商铺购买物品代码)>:0:16:53:1> \
  \
  \
            名称：<$STR(S$商城当前购入物品名)>\
            单价：<$STR(N$商城当前购入物品单价)>金币\
            说明：@关闭批量\
  \
  \
  \
;——————————————————————————————修改批量购买商铺物品的数量，输入后会自动计算！
              <$STR(N$批量商铺购买物品数量)>个<(修改数量)/@@InPutInteger300>\
  \
              <$STR(N$批量商铺购买物品总金额)>金币\
  \
     <批量购入/@批量购买>　　 <放弃购入/@放弃购入>

;——————————————————————————————修改批量物品数量后触发的字段
[@InPutInteger300]
#if
EQUAL N300 0
#act
;——————————————————————————————将单价乘以数量后写入总价格
MUL N$批量商铺购买物品总金额 <$STR(N$商城当前购入物品单价)> <$STR(N$批量商铺购买物品数量)>
;——————————————————————————————设置自定义对话框
OPENMERCHANTBIGDLG 176 19 1 0 10 70 1 190 8 1
#say
;——————————————————————————————触发对话，并且调用之前已经提取号的IDX变量
<ItemShow:<$STR(N$商铺购买物品代码)>:0:16:53:1> \
  \
  \
            名称：<$STR(S$商城当前购入物品名)>\
            单价：<$STR(N$商城当前购入物品单价)>金币\
            说明：@关闭批量\
  \
  \
  \
;——————————————————————————————修改批量购买商铺物品的数量，输入后会自动计算！
              <$STR(N$批量商铺购买物品数量)>个<(修改数量)/@@InPutInteger300>\
  \
              <$STR(N$批量商铺购买物品总金额)>金币\
  \
    <批量购入/@批量购买>　　<放弃购入/@放弃购入>

;——————————————————————————————所有条件满足开始执行批量购买
[@批量购买]
#IF
;——————————————————————————————检测人物当前是否有足够的金币来购买，当然你也可以换成任何其他货币如元宝之类的
checkgold <$STR(N$批量商铺购买物品总金额)>
#ACT
take 金币 <$STR(N$批量商铺购买物品总金额)>
;——————————————————————————————给予人物购买的物品名+数量
give <$STR(S$商城当前购入物品名)> <$STR(N$批量商铺购买物品数量)>
#ELSEACT
;——————————————————————————————不满足输入条件时候触发字段
MessageBox 缺少“<$STR(N$批量商铺购买物品总金额)>”个金币无法购买！

[@放弃购入]
#act
;——————————————————————————————结束批量购入对话和其他对话，因为之前已经调用了自定义，
;——————————————————————————————为避免直接点击其他NPC出错我们则用引擎说明书中的关闭命令来关闭，
;——————————————————————————————最后指向正常的脚本结束语
CloseBigDialogBox
CLOSEMERCHANTBIGDLG
;——————————————————————————————指向普通脚本结束语
close


技能转换 技能替换[!]

功能：
技能转换.

格式: ConvertSkill 原技能 目标技能

示列：

[@mail]
#ACT
ConvertSkill 野蛮冲撞 烈火剑法
SENDMSG 6 替换成功

英雄操作命令：
H.CONVERTSKILL 英雄野蛮冲撞 英雄烈火剑法


加入会员人物及时间

加入会员人物及时间： ADDUSERDATE 会员.txt

相关命令：
CHECKUSERDATE 会员.txt < 30 p0 p1
检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1

删除会员人物及时间： DELUSERDATE 会员.txt


假人自动练功[!]

功能: 假人自动练功

格式:AutoUseMagic 技能名字 间隔秒。(必须是学过的技能，在非挂机状态，没有攻击目标的情况下才能正常练功)

[@main]
#ACT
AutoUseMagic 雷电术 10

停止自动练功

[@main]
#ACT
StopAutoUseMagic


检测伴侣是否在线和同一地图

格式:

CheckDearOnline 人物名称 (不填表示检查自己的配偶在不在线，填则表示检查指定人的配偶在不在线）
CheckDearOnMap 地图号(self或不填，自己所在的地图，否则为指定地图） 人物名称(不填表示检查自己的配偶在某个地图，否则检查指定人的配偶是否在某个地图）

[@main]
#ACT
CheckDearOnline
#SAY
你的配偶当前在线

[@main]
#ACT
CheckDearOnline 翎风世界
#SAY
翎风世界的配偶当前在线

[@main]
#ACT
CheckDearOnMap
#SAY
你的配偶和你在同一地图

[@main]
#ACT
CheckDearOnMap 3 翎风世界
#SAY
翎风世界的配偶当前在土城

[@main]
#ACT
CheckDearOnMap 0
#SAY
你的配偶在比奇


检测当前玩家登陆的分辨率

功能：
检测当前玩家登陆的分辨率

例子：

[@Test]
#IF
CheckClientHeight = 600
#ACT
#say
你的游戏窗口高600

#if
CheckClientWidth = 1024
#ACT
#say
你的游戏窗口宽 1024

#if
CheckClientHeight > 800
#ACT
#say
你的游戏窗口高大于800

你的窗口是：<$ClientHeight>*<$ClientWidth>


检测对面的有没有徒弟

功能：
 POSEHAVEPRENTICE
命令格式：
 POSEHAVEPRENTICE

==========================
#if
POSEHAVEPRENTICE
#say
对面有徒弟
 #elsesay
对面没有徒弟
==========================


检测对面是否为自己的徒弟

功能：
检测对面是否为自己的徒弟

格式：
 CHECKPOSEISPRENTICE
;==========================================
#if
CHECKPOSEISPRENTICE
#say
对面的是你徒弟哦！
#elsesay
对面的不是你徒弟!
;==========================================


检测身上指定装备名字 获取looks保存到变量

功能：
检测身上指定装备名字 获取looks保存到变量

格式: CheckItemwLooks 装备名称 变量名(变量名可以不填)
有指定装备返回真，否则返回假

[@main]
#IF
CheckItemwLooks 传送戒指 N0
#ACT
SENDMSG 0 测试成功<$Str(n0)>


检测师傅（或徒弟）是否在XXX地图

功能：
 检测师傅（或徒弟）是否在XXX地图，支持SELF（是否同一地图) 徒弟序号(为空表示大徒弟)

命令格式：
 CHECKMASTERONMAP 地图号

==========================
#if
CHECKMASTERONMAP 3
#say
你的师傅（或徒弟）在盟重
==========================


检测师傅（或徒弟）是否在线

功能：
 用来检查人物的师傅或者徒弟是否在线上

命令格式：
 CHECKMASTERONLINE 徒弟序号(为空表示大徒弟)

==========================
#if
CHECKMASTERONLINE
#say
你的师傅（或徒弟）在线
#elsesay
你的师傅（或徒弟）不在线
==========================


检测文件中是否包含字符串

功能：
检测文件中是否包含字符串。

格式：
CheckContainsTextList 文件名 字符串

;==========================================
检查字符串是否包涵在另外一个字符串中
[@Test]
#if
CheckContainsTextList ..\QuestDiary\理想\理想爆率\10元地图.txt <$MAP>
#ACT
MESSAGEBOX 包含
#elsesay
不包含

注： 新增的CheckCacheContainsTextList 同CheckContainsTextList用法一致，区别就是CheckCacheContainsTextList从缓存检测。会更快。
启动后不动态发生变化又要求速度的，可以用缓存检测（引擎启动后不会去手动修改）

CheckContainsTextList 支持绝对路径（地址直接写绝对路径即可）

;==========================================


检测英雄怒气值

功能：
检测英雄怒气值

格式：
CheckAngryValue 操作符(>,<,=) 值 值类型(0:点数；1:百分比)

[@测试]
#IF
CheckAngryValue > 80 1
#act
sendmsg 6 你的英雄怒气值>80%

英雄怒气值变量：<$H.AngryValue>


检测装备元素属性

功能：
检测装备元素属性

格式：
 CHECKNEWITEMVALUE 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 检测符(<,>,=) 值(1-100)

(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加目标暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%
......

检测命令不包含天生元素属性（即数据库字段设置的属性）

[@main]
#IF
CHECKNEWITEMVALUE 0 0 > 10
#SAY
衣服的暴击元素大于10%


检测自己是否是师傅

功能：
 用来检测自己是否是师傅

命令格式：
 CHECKISMASTER

==========================
#if
CHECKISMASTER
#say
你是师傅
#elsesay
你不是师傅
==========================


检测自己是否是徒弟

功能：
 用来检测自己是否是徒弟

命令格式：
 CHECKISPRENTICE

==========================
#if
CHECKISPRENTICE
#say
你是徒弟
#elsesay
你不是徒弟
==========================


检查对面的人物是不是自己的师傅

功能：
 检查对面的人物是不是自己的师傅
命令格式：
 CHECKPOSEISMASTER

==========================
#if
CHECKPOSEISMASTER
#say
他是你师傅
 #elsesay
他不是你师傅
==========================


检查自己是不是别人的徒弟

功能：
 检查自己是不是别人的徒弟
命令格式：
 POSEHAVEMASTER

==========================
#if
POSEHAVEMASTER
#say
你是别人的徒弟
 #elsesay
你不是别人的徒弟
==========================


减少合击怒气恢复间隔

功能：
减少合击怒气恢复间隔

;减少怒气增加间隔 减少值 命令有效时间(单位：秒; 0为一直有效)

DecAddAngryValueTime 100 0

[@测试]
#IF
#ACT
DecAddAngryValueTime 100 0
SENDMSG 7 怒气恢复间隔减少100毫秒，有效时间：持续有效
BREAK

[@测试]
#IF
#ACT
DecAddAngryValueTime 500 200
SENDMSG 7 怒气恢复间隔减少500毫秒，有效时间：200秒
BREAK


减少技能冷却时间

功能说明: 减少技能冷却时间

设置技能冷却时间减少:
SetSkillDecCD 技能名称 操作符(+/-/=) 时间（秒)

获取减多少技能冷却时间：
GetSkillDecCD 技能名称 变量名

获取当前的技能冷却时间：
GetSkillCD 技能名称 变量名

技能CD清零(一般用不上，直接清除技能CD)：
ClearSkillCD 技能名称

#act
SetSkillDecCD 烈火剑法 = 2
; 烈火剑法缩短3秒的CD时间
SetSkillDecCD 烈火剑法 + 1
GetSkillDecCD 烈火剑法 N1
GetSkillCD 烈火剑法 N2
SENDMSG 6 烈火剑法缩短CD时间<$Str(N1)>秒，当前冷确时间为<$Str(N2)>秒

**************************
英雄技能使用命令加H. 如H.SetSkillDecCD

**************************
附：连击技能减少CD间隔使用方式：

减少连击技能间隔
SetSkillDecCD [连击技能] = 3
GetSkillDecCD [连击技能] N1
GetSkillCD [连击技能] N2
sendmsg 6 减少连击技能攻击间隔<$STR(N1)>秒，当前连击间隔<$STR(N2)>秒

**************************
技能冷却时间减少只支持以下有CD的技能：
分身术
乾坤大挪移
护体神盾
倚天辟地
十步一杀
旋风斩
彻地钉
烈火
狮子吼
擒龙手
逐日剑法
龙影剑法
雷霆剑法
开天斩
野蛮冲撞
冰咆哮
灭天火
流星火雨
冰霜雪雨
冰霜群雨
五雷轰
召唤骷髅
召唤神兽
新诅咒术
噬血术
召唤月灵
召唤圣兽
裂神符
死亡之眼
幽冥火符
施毒术
群体施毒术
无极真气
禁锢术
心灵召唤
断空斩
血魄一击

以及所有自定义技能

对他人使用需变量传递


将背包物品放入仓库

功能: 将背包物品放入仓库

格式:

BagItemToStorage 物品名称 仓库类型(0或空:普通仓；1:无限仓) 变量(保存实际存放数量)
BagItemToStorageIdx 数据库物品Idx 仓库类型(0或空:普通仓；1:无限仓) 变量(保存实际存放数量)
BagItemToStoragemakeIndex 数据库物品唯一序列号 仓库类型(0或空:普通仓；1:无限仓) 变量(保存实际存放数量)

示范：

[@仓库]
#ACT
BagItemToStorage 屠龙 1 N1
SendMsg 6 背包的屠龙有<$STR(N1)>保存到普通仓库中


将人物行会名加入列表

功能：
将人物行会名加入列表

格式：
==========================
[@addguildList]
#if
#act
ADDGUILDLIST guildlist.txt
==========================


角色变身怪物、人物变身

格式：changeAppr appr 时间(单位：秒)

[@变脸]
#act
changeAppr 161 10
sendmsg 6 你变成了鹿，时间10秒

[@变脸1]
#act
;自定义怪物Appr在数据库Appr的基础上加100000
changeAppr 100220 60
sendmsg 6 你变成Appr=220的定自定义怪物，有效时间1分钟


角色打怪爆出物品自动拾取，角色打怪爆出物品范围捡起[!]

功能：角色打怪爆出物品自动拾取，角色打怪爆出物品范围捡起

命令：

启用人物杀怪爆出的物品范围内自动拾取功能， 默认按查看----列表信息1捡取列表和优先捡取列表进行捡物，如需按照内挂配置进行捡物，需要开选项开启或命令开启
人物捡物同步内挂配置/英雄捡物同步内挂配置；位置：查看——》列表信息2——》内挂捡取
英雄捡物同步内挂配置；位置：选项——》宠物设置——》参数设置

格式：OpenAutoPickItem 类型(1:自身; 2:宝宝; 3:自己+宝宝) 有效时间 捡物范围 是否一次全捡 捡人物丢弃物品 捡人物爆出物品 物品掉地上多长时间才能捡 是否进入主人背包（参数仅H.有效）

说明：OpenAutoPickItem 类型(1:自己; 2:宝宝; 3:自己+宝宝) 有效时间(0在线一直有效,单位：秒) 范围(0:走上去捡；>0:范围捡 ) 是否秒捡(0或空则1个个的捡范围内可捡物品， 1则秒捡范围内所有可捡物品 ) 捡人物丢弃物品(0/1) 捡人物爆出物品(0/1) 物品掉地上多长时间才能捡(单位:毫秒) 是否进入主人背包（参数仅H.有效）

关闭自动捡物：CloseAutoPickItem

英雄命令：H.OpenAutoPickItem和 H.CloseAutoPickItem

注意：范围内秒捡请慎用捡起触发鉴定脚本，拾取鉴定脚本写的不够优秀（各种GOTO各种CALL等，甚至还有死循环脚本）可能会引起游戏卡顿或更严重的后果，另秒捡的话范围请设置建议3，最大建议不超过20.超过视觉范围无意义，范围越大一下捡的物品越多，同时鉴定脚本触发也越厉害

;-------------------------------Npc示范脚本：----------------------------

<杀怪物品自动拾取/@杀怪物品自动拾取> <关闭物品自动拾取/@关闭物品自动拾取> \ \

[@杀怪物品自动拾取]
#if
#ACT
;设置角色自动捡起自己打怪和自己宝宝打怪爆出以角色自身坐标为中心3格内内挂设置可捡物品，时间在线一直有效，挨个捡、不捡丢弃、不捡他人爆出，爆出物品后5秒开始捡
OpenAutoPickItem 3 0 3 0 0 0 5000
break

[@关闭物品自动拾取]
#if
#ACT
CloseAutoPickItem
break

本命令默认禁止捡起ThrowItem放置在地上的物品，英雄或宠物则需要勾选只允许捡怪物爆出物品才不会捡ThrowItem命令放置在地面的物品

;-------------------------------其他说明：----------------------------

地图参数：
NoAutoRangePickItem 禁止范围拾取 （地图内开启自动拾取命令功能后，打怪爆出物品不能自动拾取）

列表信息1可自定义设置哪些物品在使用范围拾取命令后，不再自动范围拾取！！！（意思就列表中物品正常掉落到地上，不允许范围拾取）

类型(1:自己; 2:宝宝; 3:自己+宝宝) 意思是以谁的范围位置自动拾取，1就自己所在范围，2为宝宝所在范围，3为自己和宝宝所在范围
不建议使用宝宝捡物品，推荐类型值为1，因为宝宝数量多（几百人的情况下），可能出现哄抢物品引起非法内存而导致报错


脚本控制人物等级

功能：
调整人物等级。

格式：
 CHANGELEVEL 控制符(=,+,-) 等级数(1-500)

;==========================================
;设置人物等级
[@changelevel0]
#IF
#ACT
CHANGELEVEL = 80
#SAY
你的等级已经为80级了。
;==========================================

;==========================================
;增加人物等级
[@changelevel1]
#IF
#ACT
CHANGELEVEL + 1
#SAY
你的等级已经升了1级。
;==========================================

;==========================================
;降人物等级
[@changelevel2]
#IF
#ACT
CHANGELEVEL - 1
#SAY
你的等级已经降了1级。
;==========================================


脚本命令给物品镶嵌宝石

脚本命令给物品镶嵌宝石（无需宝石直接镶嵌）

脚本命令给物品镶嵌宝石（无需宝石直接镶嵌）

// ++++++++++++++++++++++++++++++++++ 检测装备对应的孔位置是否有宝石;孔位置 (1-8)
CheckItemFluteIndexHasStone 装备位置 孔位置

// ################################################## 直接给装备加一个宝石（不需要包裹中有宝石）
ItemAddStone 装备位置 宝石名 孔位置(0或空表示自动空孔位，1-8：指定位置)

// 删除装备指定孔位的宝石孔位置 (1-8)
ItemDelStone 装备位置 孔位置

--------------------------2019-02-01新增取下镶嵌宝石命令-----------------
取下镶嵌宝石命令：
ItemoffStone 装备位置 孔位置（1-8）


脚本命令释放技能

脚本命令释放技能

releasemagic 参数1 参数2 参数3 参数4 参数5 参数6

参数1 释放技能id (能支持自定义技能)

参数2 技能是否是强化技能 0=普通技能 1=强化技能

参数3 技能等级

参数4 技能目标 1=攻击目标 2=自身

参数5 是否计算冷却时间 0或空为计算。1为不计算

参数6 值=0或空会不支持伤害触发 值=1支持伤害触发

在攻击/伤害相关触发中使用 RelaseseMagic/ReleaseMagicEx，参数6最好置0（即不触发脚本），以避免可能产生的脚本死循环,且不要写在@AttackDamage/@StruckDamage等中.......
在不触发的前提下，持续伤害技能如火墙不推荐使用，因即使设置不触发在火墙内移动也会触发
参数6为以下触发：
[@MagicStruck]
[@MagicAttack]
[@Struck]
[@Attack]

[@attack]
#if
#act
releasemagic 26 0 3 1
SENDMSG 6 你的物理攻击触发了一次3级烈火剑法

[@magicattack]
#if
equal <$CURRRUSEMAGICID> 11
#act
releasemagic 33 1 9 1
SENDMSG 6 你的雷电术触发特效攻击，对怪物释放了一次强化九重冰咆哮

#if
equal <$CURRRUSEMAGICID> 11
#act
releasemagic 2 0 3 2
SENDMSG 6 你的雷电术攻击为自己释放了一次3级治疗术

英雄命令：H.releasemagic

分身命令：FS.releasemagic

注：本命令施展技能带动作，如需无动作请使用releasemagicEx


脚本命令释放技能(无动作施展)

脚本命令释放技能(无动作施展)

releasemagicEX 参数1 参数2 参数3 参数4 参数5 参数6

参数1 释放技能id (能支持自定义技能)

参数2 技能是否是强化技能 0=普通技能 1=强化技能

参数3 技能等级

参数4 技能目标 1=攻击目标 2=自身

参数5 是否计算冷却时间 0或空为计算。1为不计算

参数6 值=0或空不会支持伤害触发 值=1支持伤害触发

在攻击/伤害相关触发中使用 RelaseseMagic/ReleaseMagicEx，参数6最好置0（即不触发脚本），以避免可能产生的脚本死循环,且不要写在@AttackDamage/@StruckDamage等中.......
在不触发的前提下，持续伤害技能如火墙不推荐使用，因即使设置不触发在火墙内移动也会触发
参数6为以下触发：
[@MagicStruck]
[@MagicAttack]
[@Struck]
[@Attack]

[@attack]
#if
#act
releasemagicEx 33 1 9 1
SENDMSG 6 你的物理攻击触发了一次3级烈火剑法

[@magicattack]
#if
equal <$CURRRUSEMAGICID> 11
#act
releasemagicEx 33 1 9 1
SENDMSG 6 你的雷电术触发特效攻击，对怪物释放了一次强化九重冰咆哮

#if
equal <$CURRRUSEMAGICID> 11
#act
releasemagicEx 2 0 3 2
SENDMSG 6 你的雷电术攻击为自己释放了一次3级治疗术

[@attack]
#if
#act
releasemagicEx 206 0 3 1 1
;参数5为1时候触发技能无视该技能CD
SENDMSG 6 你的雷电术触发特效攻击，对怪物释放了一次强化九重冰咆哮

英雄命令：H.releasemagicEX

分身命令：FS.releasemagicEx

注：本命令不支持战士技能，如需要绑定自身动作的技能请使用releasemagic


脚本刷怪

格式：
    MONGENEX 地图名称 坐标X 坐标Y 怪物名称 范围 数量 名字颜色(0-255、 为空为默认颜色) 内功怪物(0,1) 国家ID 是否可攻击同国家的玩家(0,1) 不同国家怪物是否可PK(0,1) 怪物能否被同国家的人攻击(0,1) 体型大小（空或100为默认大小）

    注意：请不要跨界留空（如不要颜色只需要内功怪物时名字颜色参数必须有，如果只要名字颜色后面不要可在颜色值后留空） 名字颜色支持变量
示例：
[@main]
#IF
#ACT
MONGENEX D717 100 100 白野猪 100 50

简单的刷怪命令：
MonGen 怪物名 X Y 国家ID 怪物能否攻击同国家的人(0,1) 同国家的怪物能否相互攻击(0,1) 怪物能否被同国家的人来攻击(0,1)

GM刷怪命令：
@mob 怪物名 数量 等级 国家ID 怪物是否可以攻击同国家的玩家(0不可；1可以) 不同国家怪物是否可PK(0不PK；1PK) 固定颜色(空为默认，0-255：固定颜色)

服务端刷怪文件格式：
MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家ID 怪物能否攻击同国家的人(0,1) 不同国家的怪物能否相互攻击(0,1) 怪物能否被同国家的人来攻击(0,1)

注： 0 = 不可， 1 =可以


脚本调整人物PK点

功能：
调整人物PK点数。

格式：
 CHANGEPKPOINT 控制符(=,+,-) PK点数

;==========================================
;将人物的PK点数设置为指定点数，不能为负数
[@changepkpoint0]
#IF
#ACT
CHANGEPKPOINT = 0
#SAY
你的PK点数已经清除。
;==========================================

;==========================================
;将人物的PK点数加100点数，不能为负数
[@changepkpoint1]
#IF
#ACT
CHANGEPKPOINT + 100
#SAY
你的PK点数已经增加100点。

;==========================================

;==========================================
;将人物的PK点数减100点数，不能为负数，如果人物点数小于100则指定为0
[@changepkpoint2]
#IF
#ACT
CHANGEPKPOINT - 100
#SAY
你的PK点数已经减少100点。
;==========================================


脚本调整升级经验

功能：
调整人物经验点数。

格式：
 CHANGEEXP 控制符(=,+,-) PK点数

;==========================================
;将人物的经验点数设置为指定点数，不能为负数
[@changeexp0]
#IF
#ACT
CHANGEEXP = 20000
#SAY
你当前的经验点数为 20000。
;==========================================

;==========================================
;将人物的经验点数加1000点数，不能为负数
[@changeexp1]
#IF
#ACT
CHANGEEXP + 1000
#SAY
你的经验点数已经增加1000点。

;==========================================
;第三个参数等于1时英雄也增加经验、0为不分配，参数四：1为可存放聚灵珠，0和留空则不可以. -----------------------------------------给英雄分配经验(分配比例在引擎英雄设置控制)，英雄如不在线全部为人物所得
[@ChangeExp3]
#IF
#ACT
ChangeExp + 1000 1 1
;命令 加1000经验 允许英雄分配 允许聚灵珠获取
#SAY
获得1000点经验值。

;==========================================
;将人物的经验点数减1000点数，不能为负数，如果人物点数小于1000则指定为0
[@changeexp2]
#IF
#ACT
CHANGEEXP - 1000
#SAY
你的经验点数已经减少1000点。
;==========================================


解除英雄强制和平模式限制

功能：
解除英雄强制和平模式限制

;当引擎设置英雄强制和平模式时候，可以用此命令进行解除

CancelHeroForcePeaceMode 命令有效时间(单位：秒; 0为一直有效)

[@测试]
#IF
#ACT
CancelHeroForcePeaceMode 0
SENDMSG 7 你的英雄已经解除和平模式限制
BREAK

[@测试]
#IF
#ACT
CancelHeroForcePeaceMode 600
SENDMSG 7 你的英雄已经解除和平模式限制，有效时间：600秒
BREAK


禁止登录列表

此列表主要用于封闭一些在游戏中捣乱的人物，禁止这些人物进入游戏，封闭有登录IP、登录帐号、人物名称三种方法，临时、永久封闭二种模式。GM管理员根据实际情况灵活应用。

临时模式，主要用于临时封闭，在服务器端重启后就不起作用了。
永久模式，主要用于永久封闭，这些记录会保存在服务器端里，服务器端重启后会重新读取这些记录。

禁止登录IP：
 将指定登录IP加入禁止列表后，所有以此IP登录的人物进入游戏时会出现红字提示，并踢除下线，已经在线的人物不受影响，但下线再上就被禁止了。
命令格式：
加入列表：@DenyIPLogon IP地址 是否永久禁止(0、1)
删除列表：@DelDenyIPLogon IP地址
显示列表：@ShowDenyIPLogon

0代表临时禁止，1代表永久禁止，此命令必须有GM权限；

禁止登录帐号：
 将指定登录帐号加入禁止列表后，用此帐号登录的人物进入游戏时会出现红字提示，并踢除下线，已经在线的人物不受影响，但下线再上就被禁止了。
命令格式：
加入列表：@DelDenyAccountLogon 登录帐号 是否永久禁止(0、1)
删除列表：@DelDenyAccountLogon 登录帐号
显示列表：@ShowDenyAccountLogon

0代表临时禁止，1代表永久禁止，此命令必须有GM权限；

禁止登录人物：
 将指定人物名称加入禁止列表后，登录此人物进入游戏时会出现红字提示，并踢除下线，已经在线的人物不受影响，但下线再上就被禁止了。
命令格式：
加入列表：@DenyCharNameLogon 人物名称 是否永久禁止(0、1)
删除列表：@DelDenyCharNameLogon 人物名称
显示列表：@ShowDenyCharNameLogon

0代表临时禁止，1代表永久禁止，此命令必须有GM权限；

增加IP所在地禁止登录列表D:\MirServer\Mir200\Envir\DenyIPLocalList.txt


开启第四个连击技能的命令[!]

功能：开启第四个连击技能的命令
格式：无
说明：
例：
[@main]
#if
CHECKOPENLASTSKILL
#say
第四个连击技能已经开启
#elseact
OPENLASTSKILL

[@main]
#if
H.CHECKOPENLASTSKILL
#say
您的英雄第四个连击技能已经开启
#elseact
H.OPENLASTSKILL


扩展MessageBox

MessageBox 信息 @确定 @取消

[@main]
#if
#act
MessageBox 是否确认要删除 @确定 @取消

[@确定]
点击的确定

[@取消]
点击的取消


扩展MOVR使用方法

功能：
扩展MOVR使用方法。

格式：
 MOVR 变量 数值1 数值2

;==========================================
MOVR G10 100 ;随机生成100以内的随机数.
MOVR G10 10 100 ;随机生成10-100之间随机数
MOVR G10 100 5000 ;随机生成100-5000之间随机数
MOVR G10 1000 9999 ;随机生成1000-9999之间随机数
;==========================================


练习技能

功能：
脚本增加技能。

格式：
 ADDSKILL 技能名称

;==========================================
;增加技能
[@addskill]
#IF
#ACT
ADDSKILL 雷电术
#SAY
你已经练习雷电术了。
;==========================================

相关命令：
删除技能：DELSKILL
检查技能：CHECKSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL

英雄练习技能：H.ADDSKILL
删除英雄技能：H.DELSKILL
删除英雄非本职业所有技能：H.DELNOJOBSKILL
删除所有技能：H.CLEARSKILL


秒杀保护

功能：
秒杀保护

格式：
 ProtectHP 检测血量 保留血量 有效时间 是否为百分比

[@防秒杀百分比]
#act
ProtectHP 90 10 360 1
SENDMSG 6 该脚本的意思是，你的血量在大于等于90%的情况下，如果有人可以一刀秒杀你，你不会被秒杀，而是把你的血量降低到10%，并且触发QF字段[@ProtectHP]，有效期360秒

[@防秒杀]
#act
ProtectHP 100 10 360 0
SENDMSG 6 该脚本的意思是，你的血量在大于等于100的情况下，如果有人可以一刀秒杀你，你不会被秒杀，而是把你的血量降低到10，并且触发QF字段[@ProtectHP]，有效期360秒

------------------
;QF触发：

[@ProtectHP]
#ACT
防秒杀保护成功

[@HeroProtectHP]
#ACT
英雄防秒杀保护成功

英雄操作命令：H.ProtectHP
。
;==========================================


千里传音[!]

功能：
使用传音命令无需佩戴传音道具.

格式：在没有佩戴传音道具前提下，使用命令进行千里传音

示列：

;===================获取聊天框所有文字=========================
[@UserCmd22]
#IF
CHECKGAMEGOLD > 0
#ACT
MOV S1 <$PARAMS>
GAMEGOLD - 1
SENDMSG 0 <$USERNAME>:<$STR(S1)> 255 253 0
#ELSEACT
SENDMSG 7 使用千里传音需要支付1元宝

;=======================以下为原始，不能使用空格，如需空格支持请看最后面一条============================================
[@UserCmd2]
#IF
CHECKGAMEGOLD > 0
#ACT
MOV S1 <$PARAM(1)>
GAMEGOLD - 1
SENDMSG 0 <$USERNAME>:<$STR(S1)> 255 253 0
#ELSEACT
SENDMSG 7 使用千里传音需要支付1元宝

[@UserCmd3]
#IF
CHECKGAMEGOLD > 0
#ACT
MOV S1 <$PARAM(1)>
MOV S2 <$PARAM(2)>
MOV S3 <$PARAM(3)>
MOV S4 <$PARAM(4)>
MOV S5 <$PARAM(5)>
MOV S6 <$PARAM(6)>
GAMEGOLD - 2
SENDTOPCHATBOARDMSG 0 149 235 30 <$STR(S1)><$STR(S2)><$STR(S3)><$STR(S4)><$STR(S5)><$STR(S6)>
#ELSEACT
SENDMSG 7 使用传音筒需要支付2元宝


强行捡起他人打怪爆出未到冷却时间的物品[!]

强行捡起他人打怪爆出未到冷却时间的物品，捡起地面他人打怪爆出(一定时间范围内不能捡起)的物品

功能：强行捡起地面他人打怪爆出(一定时间范围内不能捡起)的物品

命令：

一般用于自定义技能触发执行脚本，执行脚本后捡起自己脚下物品

命令：ForcePickItem

;-------------------------------Npc示范脚本：----------------------------

[@MagSelfFuncX]
#if
#ACT
ForcePickItem
SENDMSG 6 物品已捡起
break


清除SendCenterMsg DelayGoto

[@main]
#act
CLEARDELAYGOTO
sendmsg 6 DELAYGOTO延迟时清除

[@main]
#act
CLEARDELAYGOTO 1
sendmsg 6 SendCenterMsg倒计时清除


清除地图物品

功能：
 清理地图上指定名字的物品.

格式：
 CLEARITEMMAP 地图 X Y 范围 物品名称 (清除地图物品，不带物品名称则清除所有)

说明：
 物品名字等于*时表示指定范围内的所有物品.

;清除盟重安全区内的回城卷
[@main]
#IF
#ACT
CLEARITEMMAP 3 330 330 10 回城卷
#SAY
盟重安全区内的回城卷都被清除了。

清除盟重安全区内所有物品
[@main]
#IF
#ACT
CLEARITEMMAP 3 330 330 10
#SAY
盟重安全区内的所有物品都被清除了。

ClearItemMap支持清理地图所有物品(参数2(X)=0或空；参数3(Y)=0或空；参数4(范围) = 0或空)

;清掉盟重所有物品
ClearItemMap 3


清除地图中的怪物

功能：
用于清除指定地图里的怪物，人物的宝宝不在此范围以内，禁止清除怪物列表中的怪物不会被清除。
此功能一般用于动态刷怪方式，在有人的地图出现怪物，没人时地图上的怪物全部清除，以大大节约机器资源。

命令格式：
CLEARMAPMON 地图号

例子：

#ACT
CLEARMAPMON D717
#say
<返回/@main>


清除结婚信息

;============================
[@delMarry]
#if
DELMARRY
#say
你的结婚信息已清除
;============================


清除列表内容

脚本功能:
清除列表内容

命令格式:
CLEARNAMELIST namelist.txt

;==========================================
;清除列表
[@Clearnamelist]
#IF
#ACT
CLEARNAMELIST namelist.txt
#SAY
列表已被清除
;==========================================

支持绝对路径欠了个清空文本内容的
ClearNameList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）

缓存操作:
指令ClearCacheNameList 命令用法等同clearnamelist,区别就是内存中操作


清除人物的仓库密码

功能：
清除人物的仓库密码

格式：
 CLEARPASSWORD

;==========================================
;设置人物的名称颜色
[@clearpassword]
#IF
#ACT
CLEARPASSWORD
#SAY
你的仓库密码已清除。
;==========================================


清除人物转生

功能：
清除人物转生数据(即人物转生后恢复到未转生状态)

格式：
;==========================================
[@ClearRenewLevel]
#IF
#ACT
RestRenewLevel
;==========================================


清除延时移动

功能:
清除延时移动

格式:
BREAKTIMERECALL

============================

[@Test]
#IF
#ACT
BREAKTIMERECALL
#Say
延时移动已清除

===========================


清除英雄转生

功能：
清除英雄转生数据(即英雄转生后恢复到未转生状态)

格式：
;==========================================
[@ClearRenewLevel]
#IF
#ACT
H.RestRenewLevel
;==========================================


清掉地图某范围的怪物[!]

功能：
清掉地图某范围的怪物.

格式: KillMapMon 地图名 坐标X 坐标Y 范围 怪物名(*表示不判断名称) 是否爆物品(0：不爆，1：爆) 是否清尸体(0或空:不清; 1:清)

示列：

[@mail]
#ACT
KillMapMon 3 333 333 10 * 0
SENDMSG 6 地图3，坐标333,333范围10以内怪物被成功清理，不爆物品


清空P变量

命令: clearvarp

示范：

[@P]
#act
ClearVarp
SENDMSG 6 你的P变量全部清空重置为0！！！！

说明：比如自定义按钮用P变量关闭对话框无法清空，可以使用此命令触发清空


清空变量[!]

功能：
清空变量.

格式: ClearVar 变量名 数量

示列：

[@mail]
#ACT
ClearVar S0 5
SENDMSG 6 S0-S4全部清空


取得随机字符串(2020新)

功能: 从文件中随机获取一行字符串
格式: GetCacheRandomText 文件路径 变量(S0--S99) 指定行(1-10000)
说明: 没有指定行时随机取某一行的字符串.
      变量可以是S0--S99或者A0--A499

例如:随机取一行字符串到S10中.
[@Main]
#IF
#ACT
GetCacheRandomText ..\QuestDiary\测试.txt S10
SendMsg 5 取出的字符串是:<$STR(S10)>

例如:取特定行的字符串.
[@Main]
#IF
#ACT
GetCacheRandomText ..\QuestDiary\测试.txt S10 5
SendMsg 5 取出的字符串是:<$STR(S10)>

GetCacheRandomText 为缓存模式 比 GetRandomText 更为高效!

注： 新增的GetCacheRandomText同GetRandomText 用法一致，区别就是GetCacheRandomText从缓存检测。会更快。
启动后不动态发生变化又要求速度的，可以用缓存检测（引擎启动后不会去手动修改）


取对面角色人物名

功能：
取对面角色人物名到变量

格式：
GETPOSENAME 变量名

功能：
================================
[@AddAccountList]
#IF#act
GETPOSENAME a1
#SAY
对面的人物名：<$STR(a1)>
================================


取下镶嵌宝石命令

取下镶嵌宝石命令

ItemoffStone 装备位置 孔位置（1-8）


取指定排行榜指定排名的玩家名字和检测人物在指定排行榜中的名次

功能：
取指定排行榜指定排名的玩家名字和 检测人物在指定排行榜中的名次。

★★★★★★★★★ 使用以下npc命令，请勾选：选项——》功能设置——》其他控制——》其他控制一——》从DBServer刷新排名数据

根据名次取玩家名
GetRankNameByNo (排行榜 1-等级榜 2-战士榜 3-法师榜 4-道士榜) 名次 玩家名变量

取指定玩家的名次
GetRankNoByName (排行榜 1-等级榜 2-战士榜 3-法师榜 4-道士榜) 玩家名 名次变量

#ACT
GetRankNameByNo 1 1 S1
SENDMSG 6 等级榜排行第一的是：<$str(S1)>
GetRankNoByName 1 <$UserName> N1
SENDMSG 6 我在等级榜中的排名是：<$str(N1)>

检测人物在指定排行榜中的名次。 CheckSelfRankNo ><= 榜单(1-等级榜\2-战士榜\3-法师榜\4-道士榜) 名次

#if
CheckSelfRankNo < 1 4
#act
SENDMSG 6 我的排名在前3
#elseact
SENDMSG 6 我的排名不在前3

;--------------------------------------2020-10-28新增以下--------------------------------------

根据排名获取等级:
GetRankLevelByNo (排行榜 1-等级榜 2-战士榜 3-法师榜 4-道士榜) 名次 玩家等级变量

#act
GetRankNameByNo 1 5 S1
GetRankLevelByNo 1 5 N1
sendmsg 6 个人榜第5名的人是：<$STR(S1)>，等级为<$STR(N1)>

根据玩家名称获取排名中的等级:
GetRankLevelByName (排行榜 1-等级榜 2-战士榜 3-法师榜 4-道士榜) 玩家名称 玩家等级变量

#act
GetRankNoByName 1 dddd N1
GetRankLevelByName 1 dddd N2
sendmsg 6 dddd在个人榜中的排名为：<$STR(N1)>，等级为<$STR(N2)>


取字符串长度[!]

功能：
取字符串长度.

格式: TextLength 字符串 保存变量

示列：

[@mail]
#ACT
TextLength 这是一个测试文字aaabbbccc N1
SENDMSG 6 <$STR(N1)>
;--输出25，一个汉字占2个字符


人物/英雄临时数据命令

格式：SetTempDBMode 开/关(0：关；非0:开）
注意：开启临时数据模式后数据不在保存到数据库，关闭临时模式或重新退出/小退进入游戏人物将读取开启临时模式前的数，临时数据模式期间该角色数据都不会保存到数据库
临时数据模式，不允许使用：修改人物或英雄名，禁止无限仓，拍卖行，个人商店操作(M2数据库)。另避免临时数据人物和正常数据人物在一张地图，防止临时数据角色丢弃物品被正常数据人物拾取

关闭临时数据模式后，数据会恢复到上一次保存的状态，且能正常保存

[@开启]
#ACT
SetTempDBMode 1
SENDMSG 4 开启临时数据模式

[@关闭]
#act
SetTempDBMode 0
SENDMSG 4 关闭临时数据模式,数据恢复到开启临时数据前

;关闭临时数据同时保存数据，一般用于个人闯关，闯关成功数据正常保存..闯关失败则可以去掉最后一个参数1清除所有奖励，恢复到闯关前的数据
[@关闭1]
#act
SetTempDBMode 0 1
SENDMSG 4 关闭临时数据模式,数据正常保存


人物和英雄穿戴装备前触发

功能：
人物穿戴装备前触发/英雄穿戴装备前触发

命令：
人物中止穿装备：StopTakeOn
英雄中止穿装备：H.StopTakeOn

QF触发：
人物穿戴装备前触发：[@BeginTakeOn]
英雄穿戴装备前触发：[@HeroBeginTakeOn]

[@BeginTakeOn]
#act
SENDMSG 7 Begin穿装备：位置:<$CurItemPos>，物品:<$CurItemName>(<$G_CurItemName>)，ID:<$CurItemMakeIndex>
StopTakeOn
break

[@HeroBeginTakeOn]
#act
SENDMSG 7 英雄Begin穿装备：位置:<$H.CurItemPos>，物品:<$H.CurItemName>(<$H.G_CurItemName>)，ID:<$H.CurItemMakeIndex>
H.StopTakeOn
break

装备栏穿戴和脱下触发顺序：
[@BeginTakeOff]
[@BeginTakeOn]
[@TakeOffXXX]
[@TakeOffEx]
[@TakeOnXXX]
[@TakeOnEx]


人物隐身属性

功能：
人物（英雄）隐身属性
HideModeEx 时间 是否半透明(0:否;1:是)
H.HideModeEx 时间 是否半透明(0:否;1:是)

隐身命令（如同隐身戒指）

HideModeEx 时间 是否半透明(0:否;1:是)

#act
HideModeEx 5 1
sendmsg 7 你已经拥有隐身属性了


杀死宝宝

功能：
将自己的宝宝全部杀死。

格式：KillSlave 是否清尸体（0或空:不清; 1:清）宝宝名称(名字为空或*,清所有宝宝)

;==========================================
[@killslave]
#IF
#ACT
KILLSLAVE
#say
你的宝宝清理干净了。
;==========================================


杀死人物

功能：
杀死人物.

格式：
 Kill 类型(1为不显示凶手信息、2为不掉物品.不显示凶手信息、3为显示凶手信息为NPC、4为不掉物品.显示凶手信息为NPC) 清理尸体(0:不清理；1:清理；清尸对人物/英雄无效)

;==========================================
;杀死人物
KILL 0 人物死亡,不显示凶手信息
KILL 1 人物死亡不掉物品,不显示凶手信息
KILL 2 人物死亡,显示凶手信息为NPC
KILL 3 人物死亡不掉物品,显示凶手信息为NPC
;==========================================
[@KILL]
#IF
#ACT
KILL 2

[@KILL]
#ACT
M.Kill 1 1
sendmsg 6 目标被杀死并清尸

;==========================================


杀死人物的宝宝

说明:把自己的宝宝杀死.
格式:KillCallMob 名字 数量

#IF
#ACT
KILLCALLMOB 神兽
#SAY
你的神兽已经死亡.

#IF
#ACT
KILLCALLMOB 白野猪 2


删除非本职业的所有技能

功能：
清除人物非本职业的所有技能。

格式：
 DELNOJOBSKILL

;==========================================
;清除非本职业的所有技能
[@clearskill]
#IF
#ACT
DELNOJOBSKILL
#SAY
你的非法技能已经清除了。
;==========================================

相关命令：
练习技能：ADDSKILL
检查技能：CHECKSKILL
删除技能：DELSKILL
删除所有技能： CLEARSKILL

英雄练习技能：H.ADDSKILL
删除英雄技能：H.DELSKILL
删除英雄非本职业所有技能：H.DELNOJOBSKILL
删除所有技能：H.CLEARSKILL


删除行会成员

功能：
删除行会成员。

格式：
 DelGuildMember 行会名称 人物名称

（删除掌门无效）
;==========================================
[@Test]
#if
#act
DelGuildMember 测试行会 <$USERNAME>
#say
你已经从[测试行会]中脱离出来
;==========================================


删除会员人物及时间

删除会员人物及时间： DELUSERDATE 会员.txt

相关命令：
CHECKUSERDATE 会员.txt < 30 p0 p1
检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1
加入会员人物及时间： ADDUSERDATE 会员.txt


删除列表行会名

功能：
删除列表行会名

格式：
==========================
[@delguildList]
#if
#act
DELGUILDLIST guildlist.txt
==========================


删除人物IP在列表中

功能：
删除人物IP在列表中

功能：
================================
[@DelIPList]
#IF
#Act
DELIPLIST IPList.txt
================================


删除人物名在列表中

功能：
删除人物名在列表中

格式：
================================
[@DelNameList]
#IF
#Act
DELNAMELIST NameList.txt
================================

缓存操作命令：DelCacheNameList
用法和DelNameList一致,区别就是内存中操作


删除人物帐号在列表中

功能：
删除人物帐号在列表中

功能：
================================
[@DelAccountList]
#IF
#Act
DELACCOUNTLIST AccountList.txt
================================


删除所有技能

功能：
清除人物的所有技能。

格式：
 CLEARSKILL

;==========================================
;清除所有技能
[@clearskill]
#IF
#ACT
CLEARSKILL
#SAY
你的所有技能已经清除了。
;==========================================

相关命令：
练习技能：ADDSKILL
检查技能：CHECKSKILL
删除技能：DELSKILL
删除非本职业所有技能：DELNOJOBSKILL

英雄练习技能：H.ADDSKILL
删除英雄技能：H.DELSKILL
删除英雄非本职业所有技能：H.DELNOJOBSKILL
删除所有技能：H.CLEARSKILL


删除文本指定行

格式: DelTextListLine 文件名 行号(0开始) 是否绝对路径(0:否; 1:是)

例：
[@Test1]
#IF
#ACT
DelTextListLine d:\d.txt 0 1
#SAY
文本第一行被删除


删除一个NPC

格式: DELNPC NPC名字 地图代码

#IF
#ACT
DelNpc 测试

DELNPC 扩展参数3支持删除指定地图的NPC
格式：
命令 NPC名字 NPC所在地图代码(留空保持原有规则：删除所有地图该名字NPC)
如：Delnpc 传送员 3
意思为地图代码3的NPC名字为传送员的！


删除指定技能

功能：
脚本删除指定技能。

格式：
 DELSKILL 技能名称

;==========================================
;删除技能
[@delskill]
#IF
#ACT
DELSKILL 雷电术
#SAY
你的雷电术已删除了。
;==========================================

相关命令：
练习技能：ADDSKILL
检查技能：CHECKSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：CLEARSKILL

英雄练习技能：H.ADDSKILL
删除英雄技能：H.DELSKILL
删除英雄非本职业所有技能：H.DELNOJOBSKILL
删除所有技能：H.CLEARSKILL


设置被怪物攻击时伤害吸收

功能：
设置被怪物攻击时伤害吸收(宝宝/宠物除外)

格式：
 StruckDamageAbsorb 怪物名(*表示所有怪) 吸收几率(1~100) 伤害吸收比例(1~100) 有效时间（秒）

[@伤害吸收]
#if
#act
StruckDamageAbsorb 白野猪 50 80 30
sendmsg 5 50%几率吸收白野猪80%的伤害，有效时间30秒

英雄操作命令：H.StruckDamageAbsorb
。
;==========================================


设置攻击力倍数[!]

功能：
设置攻击力倍数

格式：
POWERRATE 攻击倍率 有效时间(0为永久) 是否保存(1为保存/0或留空不保存) 是否提示(0或者留空提示/1为不提示) 类型(0所有对象/1攻击人物(人物/英雄/宝宝)倍率/2攻击怪物倍率)
倍率 为杀攻击力倍数，倍数除以100为真正的倍率(200 为 2 倍经验，150 为1.5倍) 支持变量操作

;==========================================
[@POWERRATE]
#IF
#ACT
POWERRATE 1000 600
#SAY
您当前攻击力倍数为 10倍，有效时间 600秒。

[@POWERRATE]
#IF
#ACT
POWERRATE 1000 0 1
#SAY
您当前攻击力倍数为 10倍，有效时间 永久。下线保存。

[@POWERRATE]
#IF
#ACT
POWERRATE 1000 600 1
#SAY
您当前攻击力倍数为 10倍，有效时间 600秒，下线保存剩余时间。

已有变量修改
<$PowerRate>人物攻击人物伤害力倍数
<$PowerRateTime>人物攻击人物伤害力时长

新增加变量
<$AttackMonPowerRate>攻击怪物伤害力倍数
<$AttackMonPowerRateTime>攻击怪物伤害力时长

<$H.PowerRate>英雄攻击人物伤害力倍数
<$H.PowerRateTime>英雄攻击人物伤害力时长

<$H.AttackMonPowerRate>英雄攻击怪物伤害力倍数
<$H.AttackMonPowerRateTime>英雄攻击怪物伤害力时长

;==========================================


设置技能伤害防御[!]

功能：
设置技能伤害防御.

设置技能伤害/防御

格式: SetSkillPower 技能ID +/-/= 人物伤害增加%（-32768 .. 32767） 人物伤害增加值（-32768 .. 32767） 怪物伤害增加%（-32768 .. 32767） 怪物伤害增加值（-32768 .. 32767） 防御增加%（-32768 .. 32767） 防御增加值（-32768 .. 32767） 时间(秒; 0-65535;0一直有效) 是否保存数据库(0:不存；1：存）

示范脚本：

#act
SetSkillPower 66 = 100 0 100 0 0 0 0
SENDMSG 6 你的开天斩技能对人物伤害增加为原来的2倍(增加100%)，对怪物伤害为原来的2倍(增加100%)

获取技能伤害/防御

GetSkillPower 技能ID 人物伤害增加%(变量) 人物伤害增加值(变量) 怪物伤害增加%(变量) 怪物伤害增加值(变量) 防御增加%(变量) 防御增加值(变量) 时间(变量) 是否保存数据库(变量)

计算方式为：M2-列表信息2-技能威力设置中 全局设置+命令私人设置 =效果(不想用M2全局的话可以将全局全部设置为0)


设置离线挂机

功能：
设置离线挂机。

格式：
 SETOFFLINEPLAY ON/OFF

;==========================================
例：
#IF
#ACT
SETOFFLINEPLAY ON
#say
你已经开启了安全区下线自动挂机
;==========================================


设置人物当前模式

功能：
设置人物当前模式。（1管理模式、2无敌模式、3隐身模式）

格式：
CHANGEMODE 模式类型 开关（1为开，0为关）

;==========================================
[@test]
#IF
#ACT
CHANGEMODE 1 1
CHANGEMODE 2 1
CHANGEMODE 3 1
;==========================================


设置人物当前权限

功能：
设置人物当前权限（0-10）

格式：(提升到超级GM)

;==========================================
[@test]
#IF
#ACT
CHANGEPERMISSION 10
;==========================================


设置杀怪经验倍数

功能：
设置杀怪经验倍数.(支持内功经验，经络经验倍数)

格式：
 KILLMONEXPRATE 倍率 有效时间 是否保存剩余时间(1为保存，0或留空为不保存) 是否提示信息（0或者留空为给予时候提示，1为给予时候不提示）
倍率 为杀怪经验倍数，倍数除以100为真正的倍率(200 为 2 倍经验，150 为1.5倍)

;==========================================
[@KILLMONEXPRATE]
#IF
#ACT
KILLMONEXPRATE 1000 600
#SAY
您当前杀怪经验倍数为 10倍，有效时间 600秒。

[@KILLMONEXPRATE]
#IF
#ACT
KILLMONEXPRATE 1000 0 1
#SAY
您当前杀怪经验倍数为 10倍，有效时间永久，下线保存剩余时间。

[@KILLMONEXPRATE]
#IF
#ACT
KILLMONEXPRATE 1000 600 1
#SAY
您当前杀怪经验倍数为 10倍，有效时间600秒，下线保存剩余时间。

;==========================================


设置修改宝宝属性

功能：
设置宝宝属性
ChangeSlaveAbility 参数1 参数值 宝宝名（为空表示所有宝宝）
参数1表示值：
0: HP； 1: MaxHP； 2:MP； 3:MaxMP； 4:AC1； 5:AC2； 6:MAC1； 7:MAC2； 8:DC1； 9:DC2； 10:MC1； 11:MC2； 12:SC1； 13:SC2 14:攻击速度 15:移动速度 30:属性有效时间（秒，空或0表示不检测时间）

// 重算宝宝属性，ChangeSlaveAbility后不会重算宝宝属性，必须调用本命令
RecalcSlaveAbility 宝宝名（为空表示所有宝宝）
;------------------------------------------------

例子：

[@Test]
#IF
#ACT
ChangeSlaveAbility 14 300
ChangeSlaveAbility 15 300
ChangeSlaveAbility 30 30
RecalcSlaveAbility
sendmsg 6 您的所有宝宝攻击速度和移动速间隔调整为300ms，有效时间30秒！
break

本命令为调整设置间隔，如需灵活修改间隔可以使用ChangeSlaveAbilityEX


设置装备发光特效

格式: SETITEMEFFECT 位置(-1时是升级框中的装备, 0-51时是穿在身上的装备， boxitem0-boxitem7为自定义OK框) 特效编号(0-50000,0为清除特效) 特效位置

特效编号需要在列表信息2-特效列表中编辑好的（支持特效编号中所有类型特效，不局限性于发光特效）

特效位置0-2 ，可以同时给物品同时设置3个特效编号进行显示，参数3为空或0为默认

[@main]
#ACT
SETITEMEFFECT 0 1

注：设置英雄装备特效命令为：H.SETITEMEFFECT

;----------------------------------------------------------------------

例子脚本：

[@main]
#ACT
SETITEMEFFECT 6 1
SendMsg 6 左手镯附加了特效编号1，位置0

#ACT
SETITEMEFFECT 6 0
SendMsg 6 左手镯关闭了位置0特效编号

;-----------------上面为默认。下面为扩展需求

#ACT
SETITEMEFFECT 6 1 1
SendMsg 6 左手镯附加了特效编号1，位置1

#ACT
SETITEMEFFECT 6 0 1
SendMsg 6 左手镯关闭了位置1的特效

;-----------------
#ACT
SETITEMEFFECT 6 5 2
SendMsg 6 左手镯附加了特效编号5，位置2

#ACT
SETITEMEFFECT 6 0 2
SendMsg 6 左手镯关闭了位置2的特效

==================================================

装备位置：
-1 升级框
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 灵玉
18 时装衣服
19 时装武器
20 时装项链
21 时装头盔
22 时装左手镯
23 时装右手镯
24 时装左戒指
25 时装右戒指
26 时装勋章
27 时装腰带
28 时装靴子
29 时装宝石
30-35 首饰盒
40-51 生肖盒
boxitem0-boxitem7 自定义OK框


使用外置默认浏览器打开网站

说明: 使用外置默认浏览器打开网站

功能: 浏览器打开网站.
格式: OpenUrl 网站

#IF
#ACT
OpenUrl http://www.lfm2.com


收回OK框中的物品

格式: TAKEDLGITEM

例：
[@main]
#ACT
TAKEDLGITEM


收回玩家英雄脚本命令

功能：
收回玩家英雄

#IF
#ACT
HeroLoginOut
#SAY
你英雄被收回.


数学表达式运算命令

功能：
数学表达式运算命令
FORMULATION 公式 结果保存变量

范例:

FORMULATION <$STR(N$切割倍率)>/(<$STR(N$人物切割值)>+<$STR(N10)>)*100+<$STR(N$人物切割值)> N$切割值

;下面的结果为0，被除数为0，脚本执行错误

#act
Formulation 1/(3-3)*5+6 N1
sendmsg 6 <$STR(N1)>

;注意：表达式被除数不能为0

;-----------------------------------------------------------------------------

2024-07-01 增加：ForMulAtion 命令内进行随机数值运算

说明
ForMulAtion Random(1,20) N$获取数据显示
取随机数值1到20之间取随机数

例子：
#IF
#ACT
ForMulAtion Random(1,20) N$获取数据显示
Sendmsg 6 <$Str(N$获取数据显示)>,显示数据为1-20之间的随机数值

例子：
#IF
#ACT
ForMulAtion Random(1,20)^2 N$获取数据显示
Sendmsg 6 <$Str(N$获取数据显示)>,显示数据为1-20之间的随机数值的平方


刷新当前装备属性到客户端

绑定给予的装备进行命令操作:

;======================================================
格式：updateitem 位置

绑定脚本给的物品进行命令操作，只绑定最后一个给的物品，比如GIVE 屠龙 10 ，一次给10把屠龙，只对最后一把生效！

#IF
#ACT
give 屠龙 1
;给屠龙1把
LINKGIVEITEM
;绑定屠龙下面的操作只对绑定的装备生效
ChangeItemNameColor -1 253
;调整武器颜色
updateitem -1
;刷新到客户端
clearLinkItem
;解除绑定，不然刷新包裹物品不刷新 break

注：位置 -1是普通OK框，其他装备位置阅读说明书！

注意：clearLinkItem 因为绑定必须给物品一个位置，目前以下2个命令强行绑定到OK框，请加上解除绑定命令，不然不能及时刷新背包物品属性，需要小退生效，加上后及时生效！！！
主要是解决绑定到-1后，alt+R刷新包裹和捡起触发改名不刷新的问题，，身上或自定义OK框或者OK框只要有装备位置的不需要增加clearLinkItem，因为背包是没位置的所以需要增加！！！
特别注意：如果不解绑的情况下，会出现修改过属性的物品丢失，本命令绑定和解绑必须配套使用，只要绑定了，脚本执行不管成功还是失败，只要用了绑定就都必须解绑，切记！！！


所有行会同时攻城

功能:所有行会在当晚同时攻城

AddAttackSabukAll 城堡号(0)

#IF
#SAY
所有行会将于今晚同时攻城!
#ACT
AddAttackSabukAll 0


特修装备

功能：
特修装备,在物品规则列表中限制物品的不会被修理

格式：
 REPAIRALL 兼容其它引擎的特殊修理命令

ACTREPAIRALL 操作命令的修理
CHECKREPAIRALLGOLD <$STR(N99)> 统计需要修理装备数据库设置价格*特修价格 、 变量为价格变量

;特修装备

[@Test]
#IF
checkgold 2000
#ACT
take 金币 2000
RepairAll
#SAY
你的装备修好了.
#ELSESAY
你是不是没有钱啊.

#IF
CHECKREPAIRALLGOLD <$STR(N99)>
#ACT
take 金币 <$STR(N99)>
ACTREPAIRALL
#SAY
你的装备修好了.
#ELSESAY
你是不是没有钱啊.修理需要<$STR(N99)>金币


踢除服务器挂机人物

功能：
踢除服务器所有挂机人物。

格式：
 KICKOFFLINE //踢除服务器所有挂机人物

;==========================================
例：
#IF
#ACT
KICKOFFLINE
#Say
挂机人员全体下线
;==========================================


踢除服务器所有人物

功能：
踢除服务器所有人物。

格式：
 KICKALLPLAY //踢除服务器所有在线人物

;==========================================
例：
#IF
#ACT
KICKALLPLAY
#Say
全体下线
;==========================================


踢人物下线

功能：
踢人物下线.小退

格式：
 KICK

;==========================================
[@KICK]
#IF
#ACT
SENDMSG 5 %s，非法登录游戏
 KICK
;==========================================

[@KICK]
#IF
#ACT
DelayCall 5000 @Kicks
SENDMSG 5 %s，非法登录游戏，5秒会将被小退游戏！

[@KICKS]
#IF
#ACT
KICK 1

;注：命令：KICK 后面参数为0或空时为踢下线，为1时候将人物小退！


替换行会掌门,改变行会的掌门人

改变行会掌门人,替换行会掌门人

格式：SetGuildMaster 1/2(1是正会长，2是副会长）如果已经是行会会长，则调用无效

[@测试]
#IF
#ACT
SetGuildMaster 1
#SAY
你现在是行会一把手了.


替换字符命令[!]

功能：
替换字符命令.

示列：
格式：
TextReplace 字符串内容 待替换的内容 新的内容 保存变量 分大小写(0或空：不分； 1：分) 只替换一次(0或空：全部替换；1：只替换一次）

#ACT
TextReplace AAABBBAAA AAA 字母 S1 0 0
SendMsg 6 <$STR(S1)>


添加行会成员

功能：
添加行会成员。

格式：
 AddGuildMember 行会名称 人物名称

;==========================================
[@Test]
#if
#act
AddGuildMember 测试行会 <$USERNAME>
#say
你已经成功加入[测试行会]行会中
;==========================================


调用安全区特效命令

格式: RectMapEffect 地图 左上角X 左上角Y 宽度 高度 光圈类型 显示时间（单位：秒；0表示永久）

[@main]
#ACT
RectMapEffect 3 317 346 10 5 4 0

以上命令按需使用，一般用于活动泡点范围显示！！！！


调整宝宝等级

功能: 直接调整人物宝宝的等级
格式: ChangeSlaveLevel 名字(*为所有宝宝) 操作符(+ = -) 等级(1-7) 参数4（0：调整单个宝宝；1：调整所有宝宝）

例子: 把虎卫的等级调整到7级.
#IF
#ACT
ChangeSlaveLevel 虎卫 = 7

====================以下是调整人物在线所有宝宝，比如有5个虎卫全部调整到指定等级====================
#IF
#ACT
ChangeSlaveLevel 虎卫 = 7 1

#IF
#ACT
ChangeSlaveLevel * = 7
sendmsg 6 所有宝宝调整到7级


调整暴击威力

格式: SetBlastHitRate 威力(百分比) 有效时间(秒，0表示一直有效)

[@main]
#ACT
;持续5秒1.2倍的暴击威力 SetBlastHitRate 120 5


调整暴击威力倍数命令

功能：
设置暴击威力 威力(百分比) 有效时间(秒，0表示一直有效)
;持续5秒1.2倍的暴击威力

SetBlastHitRate 120 5

。
;==========================================


调整背包负重

命令: AddMaxWeight 符号(+/-/=) 值

变量：
取扩展背包重量 <$AddMaxBW>

[@脚本]
#act
AddMaxWeight + 100
SendMsg 6 扩展背包最大重量：<$AddMaxBW>


调整行会可以容纳最多成员

格式: CHANGEGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示调整自己所在的行会) 调整符(+,-,=) 数量
[@main]
#IF
CHANGEGUILDMEMBERMAXLIMITCOUNT = 100
#SAY
你的行会可以容纳100个成员


调整行会人数上限[!]

功能: 调整当前行会的人数上限.
说明: 只能由行会老大使用.每个行会会自动读取!Setup.txt中的行会人数限制,之后可以用此命令重
      新调整行会人数限制,也就是说调整后不受!Setup.txt中行会人数限制参数的限制.

格式: AddGuildMemberCount 操作符(+ - = ) 数量(0--1000)

#IF
CheckItem 金条 1
#ACT
Take 金条 1
AddGuildMemberCount + 5
#ELSESAY
你没有金条或者你不是行会老大.


调整合击怒气值

功能：
调整合击怒气值

SetAngryValue 操作符(+/-/=) 值 是否为百分比值(0:点数；1：百分比)

[@测试]
#IF
#ACT
SetAngryValue + 5 0
SendMsg 6 你的英雄怒气增加了5个点

**本命令对可对人物 或英雄使用，如果是对人物使用，自动调整人物英雄的值,本命令不用特别指定 H.

[@测试]
#IF
#ACT
SetAngryValue + 5 1
SendMsg 6 你的英雄怒气增加了5%

**本命令对可对人物 或英雄使用，如果是对人物使用，自动调整人物英雄的值


调整技能等级(扩展)

功能：
脚本调整技能等级。

格式：
 SKILLLEVEL 魔法名称 调整符(+,-,=) 等级 是否调整强化技能(0或为空时为技能等级,1为强化技能等级)

英雄操作命令：
 H.SKILLLEVEL 魔法名称 调整符(+,-,=) 等级 是否调整强化技能(0或为空时为技能等级,1为强化技能等级)

;==========================================
[@skilllevel0]
#IF
#ACT
SKILLLEVEL 雷电术 = 3
#SAY
你的雷电术等级已经为3级。
;==========================================

;==========================================
;
[@skilllevel1]
#IF
#ACT
SKILLLEVEL 雷电术 + 1
#SAY
你的雷电术等级已经升了1级。
;==========================================

;==========================================
;
[@skilllevel2]
#IF
#ACT
SKILLLEVEL 雷电术 - 1
#SAY
你的雷电术等级已经降了1级。
;==========================================

[@skilllevel3]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重

强化技能升级，技能栏"升级"鼠标移上去提示的配置文件：客户端目录\data\SkillUpgradeDesc.Dat(以下为示例：)

;技能类型(普通技能/内功技能),技能名,需要强化等级,强化描述(描述使用,换行 参考9重)
普通技能,攻杀剑术,1,111111111111
普通技能,攻杀剑术,2,222222222222
普通技能,攻杀剑术,3,333333333333333
普通技能,攻杀剑术,4,44444444444444444
普通技能,攻杀剑术,5,5555555555555555555555
普通技能,攻杀剑术,6,6666666666666666666666
普通技能,攻杀剑术,7,77777777777777777
普通技能,攻杀剑术,8,8888888888888888888
普通技能,攻杀剑术,9,升到9级要好多毛线的,你确定要升级????????


调整技能点数

功能：
脚本调整技能点数。

格式：
 CHANGETRANPOINT 控制符(+,-,=) 点数

英雄相关格式：
 H.CHANGETRANPOINT 控制符(+,-,=) 点数

;==========================================
[@CHANGETRANPOINT1]
#IF
#ACT
CHANGETRANPOINT 雷电术 = 100
;==========================================

;==========================================
;
[@CHANGETRANPOINT2]
#IF
#ACT
CHANGETRANPOINT 雷电术 + 200

;==========================================

;==========================================
;
[@CHANGETRANPOINT3]
#IF
#ACT
CHANGETRANPOINT 雷电术 - 10

;==========================================

检测技能点数命令: CheckTranPoint 技能名称 比较符(> = <) 值

[@CHANGETRANPOINT31]
#IF
CHANGETRANPOINT 雷电术 > 10
#ACT
SENDMSG 6 雷电术技能点数大于10
#elseact
SENDMSG 6 雷电术技能点数小于10


调整金刚石数量

功能：
调整金刚石和灵符数量。

格式：
 GAMEDIAMOND 控制符(=,+,-) 点数(0 到 2147483647)
GAMEGIRD 控制符(=,+,-) 点数(0 到 2147483647)

;==========================================
;将人物的金刚石设置为指定点数，不能为负数
#IF
#ACT
GAMEDIAMOND = 0
#SAY
你的金刚石数量为0
;==========================================

;==========================================
;将人物的灵符设置为指定点数，不能为负数

#IF
#ACT
GAMEGIRD = 0
#SAY
你的灵符数量为0

;==========================================


调整流星火雨伤害次数

格式： SetSkill58AttackCount 伤害次数(1-5)
格式： H.SetSkill58AttackCount 伤害次数(1-5)
注意：人物/英雄根据设置的次数和M2选项中的是否勾选“两次伤害”，选项和次数之间取最大次数

[@人物3次]
#ACT
SetSkill58AttackCount 3
SENDMSG 6 技能流星火雨伤害调整为3次了

[@英雄5次]
#act
H.SetSkill58AttackCount 5
SENDMSG 6 英雄技能流星火雨伤害调整为5次了


调整人物的荣誉值[!]

#IF
CheckLevelEx > 50
#ACT
ChangeNationCredit + 100

—————————————————————两个命令自己测试

格式: GAMEGLORY (+,-,=) 值

[@main]
#ACT
GAMEGLORY + 5
#SAY
荣誉值+5


调整人物会员等级

功能：
调整人物会员等级。

格式：
 SETMEMBERLEVEL 控制符(=,+,-) 等级数(1-65535)

;==========================================
;设置人物会员等级
[@changememberlevel0]
#IF
#ACT
SETMEMBERLEVEL = 5
#SAY
你的会员等级为5。
;==========================================

;==========================================
;增加人物会员等级
[@changememberlevel1]
#IF
#ACT
SETMEMBERLEVEL + 1
#SAY
你的会员等级已经改变。
;==========================================

;==========================================
;减少人物会员等级
[@changememberlevel2]
#IF
#ACT
SETMEMBERLEVEL - 1
#SAY
你的会员等级已经改变。
;==========================================


调整人物会员类型

功能：
调整人物会员类型。

格式：
 SETMEMBERTYPE 控制符(=,+,-) 类型数(1-65535)

;==========================================
;设置人物会员类型
[@changemembertype0]
#IF
#ACT
SETMEMBERTYPE = 5
#SAY
你的会员类型为5。
;==========================================

;==========================================
;增加人物会员类型
[@changemembertype1]
#IF
#ACT
SETMEMBERTYPE + 1
#SAY
你的会员类型已经改变。
;==========================================

;==========================================
;减少人物会员类型
[@changemembertype2]
#IF
#ACT
SETMEMBERTYPE - 1
#SAY
你的会员类型已经改变。
;==========================================


调整人物金币数量

 功能：调整人物金币数量
命令：GOLDCOUNT 控制符(=,+,-) 金币值 (0-2100000000)

格式：

   [@TEST]
#IF
#ACT
GOLDCOUNT = 10000
#SAY
你的金币调整为1万。\ \


调整人物属性

功能： 调整人物属性

格式: ChangeHumAbility 属性(1-29) 操作符(+ = -) 效果 时间秒(1-65535) 参数5(值是否为百分比;0:固定值；1:百分比)
说明: 属性1-29分别对应值
1、防御下限
2、防御上限
3、魔御下限
4、魔御上限
5、攻击下限
6、攻击上限
7、魔法下限
8、魔法上限
9、道术下限
10、道术上限
11、MaxHP
12、MaxMP
13、内功攻击伤害减
14、HP恢复
15、MP恢复
16、毒恢复
17、毒躲避
18、魔法躲避
19、准确
20、敏捷
21、幸运
22、内功伤害增加
23、内力值
24、刺术下限
25、刺术上限
26、箭术下限
27、箭术上限
28、武力下限
29、武力上限

注意:整后的属性效果只在人物在线时有效.? 不带时间为在线一直有效

例子：

[@Test]
#IF
#ACT
ChangeHumAbility 2 + 10 60
#SAY
你的防御上限增加10点.60秒后恢复

[@Test]
#IF
#ACT
ChangeHumAbility 2 + 50 60 1
#SAY
你的防御上限增加50%.60秒后恢复

;==================================================================================================================

使用 = 可以不用清零，如果使用+ 或 - 修改属性前需清零，否则存在执行一次叠加一次的情况出现

[@ChangeHumAbility]
#IF
#ACT
ChangeHumAbility 2 = 100 5 1
;等于符号操作 可以不清零，每次执行都是最后最新执行参数为准
#SAY
你的防御上限增加100%.5秒后恢复

[@ChangeHumAbility]
#IF
#ACT
ChangeHumAbility 2 = 0
ChangeHumAbility 2 + 50 5 1
;使用 + 或者 - ，如果允许叠加属性就不要清零，需要每次以最后执行为准就在前面加个清零命令，防止叠加（一直现有属性上叠加）
#SAY
你的防御上限增加50%.5秒后恢复

提示：调整英雄属性命令为： H.ChangeHumAbility

注：ChangeHumAbility支持多级脚本

注：支持调整人物原始属性，减少属性为累计属性，如：人物100点攻击，命令减少200点，那么人物攻击变成0，更换装备提升攻击，必须让人物自身攻击大于200才可以突破0（因为已经存储人物攻击减少200点），恢复原始属性 ChangeHumAbility = 0 即可

也就是当减少属性大于角色当前属性，角色需要将差值的坑填满才可以有属性

;涉及人物或英雄的属性修改建议使用LockUpdateAbil和UpdateAbil对执行脚本进行锁定操作并解锁刷新来显著提高脚本性能，详细请说明书搜索LockUpdateAbil和UpdateAbil查阅说明文档


调整人物游戏点数

功能：
调整人物游戏点。

格式：
 GAMEPOINT 控制符(=,+,-) 点数(1-100)< /FONT>

;==========================================
;设置人物游戏点
[@GAMEPOINT0]
#IF
#ACT
GAMEPOINT = 8
#SAY
你的游戏点已经为8了。
;==========================================

;==========================================
;增加人物游戏点
[@GAMEPOINT1]
#IF
#ACT
GAMEPOINT + 1
#SAY
你的游戏点已经加了1点。
;==========================================

;==========================================
;降人物游戏点
[@GAMEPOINT2]
#IF
#ACT
GAMEPOINT - 1
#SAY
你的游戏点已经降了1点。
;==========================================


调整声望点

功能：
调整人物声望点。

格式：
CREDITPOINT 控制符(=,+,-) 点数(1-100)< /FONT>

;==========================================
;设置人物声望点
[@CREDITPOINT0]
#IF
#ACT
CREDITPOINT = 8
#SAY
你的声望点已经为8了。
;==========================================

;==========================================
;增加人物声望点
[@CREDITPOINT1]
#IF
#ACT
CREDITPOINT + 1
#SAY
你的声望点已经加了1点。
;==========================================

;==========================================
;降人物声望点
[@CREDITPOINT2]
#IF
#ACT
CREDITPOINT - 1
#SAY
你的声望点已经降了1点。
;==========================================


调整属性点

功能：
调整人物属性点。

格式：
BONUSPOINT 控制符(=,+) 点数(0-1000)< /FONT>

;==========================================
;设置属性点
[@BONUSPOINT0]
#IF
#ACT
BONUSPOINT = 0
#SAY
你的属性点点已全部清0了。
;==========================================

;==========================================
;增加属性点
[@BONUSPOINT1]
#IF
#ACT
BONUSPOINT + 1
#SAY
你的属性点已经加了1点。
;==========================================

相关命令：
复位属性点数：RESTBONUSPOINT
检查属性点数：CHECKBONUSPOINT


调整物品名字颜色

功能:调整人物身上物品装备名字颜色(英雄M2)
格式:ChangeItemNameColor 位置(0-13) 颜色(0-255)
说明:颜色=0时恢复默认颜色.

[@main]
#IF
#ACT
ChangeItemNameColor 1 253
#SAY
你装备名字的颜色变成紫色了.

调整英雄物品名字颜色

命令：H.ChangeItemNameColor


调整物品新增属性

格式: SetNewItemValue 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-25) 操作符(+,-,=) 值(1-100)

属性(0-10)
(0)暴击几率增加 1~1000%
(1)增加攻击伤害 1~1000%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加杀人暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%
(11)增加杀怪暴率 1~100%
(12)增加防爆几率(该件装备死亡防止爆出几率) 1~100%
(13)增加防止麻痹 1~100%
(14)增加防止护身 1~100%
(15)增加防止复活 1~100%
(16)增加防止全毒 1~100%
(17)增加防止诱惑 1~100%
(18)增加防止火墙 1~100%
(19)增加防止冰冻 1~100%
(20)增加防止蛛网 1~100%
(21)致命一击几率 1~100%
(22)致命一击伤害增加 1~100%
(23)致命一击防御 1~100%
(24)暴击抗性(对方暴击几率 - 暴击抗性 = 对方暴击打出几率) 1~1000% ..........本抗性对应元素属性0 暴击几率增加
(25)攻击伤害抗性(对方攻击伤害倍数 - 攻击伤害抗性 = 对方攻击伤害增加的倍数) 1~1000% ..........本抗性对应元素属性1 增加攻击伤害
几率大于100%则按照100%计算，如暴击几率300%，目标暴击抗性270%，那么攻击这个目标的暴击几率只有30% ，，目标抗性为10% ，就是300-10=290 ，也为100%
(26)杀怪经验倍率 1~100000% [算法相加：自身倍数(自身倍率含特殊物品倍数*经验倍数命令 ） + 元素倍率]

点击OK键后触发字段[@UpgradeDlgItem]

[@UpgradeDlgItem]
#SAY
OK框中物品的名称:<$DLGITEM.NAME>\
OK框中物品的StdMode:<$DLGITEM.STDMODE>\
OK框中物品的持久:<$DLGITEM.DURA>\
OK框中物品的最大持久:<$DLGITEM.DURAMAX>\
<升级/@升级>\

[@升级]
#ACT
SetNewItemValue -1 0 + 10
RECLAIMITEM

调整英雄物品新增属性

格式: H.SetNewItemValue 位置(-1时是OK框中的装备, 0-12时是穿在身上的装备) 属性(0-10) 操作符(+,-,=) 值(1-100)

===============================================================================================================

目标爆率（人物个怪物）算法（不描述 给大家做个详细说明吧）

1/30 井中月
1/50 血饮
1/30 无极棍
1/60 裁决之杖

以上上面为例：
目标爆率加50%如下

1/15 井中月
1/25 血饮
1/15 无极棍
1/30 裁决之杖

80%计算如下
1/6 井中月
1/10 血饮
1/6 无极棍
1/12 裁决之杖

100%计算如下（所有物品必爆）

1/0 井中月
1/0 血饮
1/0 无极棍
1/0 裁决之杖

===============================================================================================================

防爆几率指的是当自己被杀死（无论是人物还是怪物）后防止自己掉落身上、背包、神佑、首饰盒装备几率

======================================================================================

几个元素整体变量：
元素性质 几率

防麻： <$UnParalysisRate>
防护身： <$UnMagicShieldRate>
防复活： <$UnRevivalRate>
防毒： <$UnPosionRate>
防诱惑： <$UnTammingRate>
防火墙： <$UnFireCrossRate>
防冰冻： <$UnFrozenRate>
防蛛网： <$UnCobwebWindingRate>

其他元素相关变量：
<$ELEMENT>，<$ELEMENT1> - <$ELEMENT25>


调整物品新增属性

格式: SetNewItemValueEx 位置( 0-12时是穿在身上的装备) 属性(0-25) 操作符(+,-,=) 值(1-100) 值(1-65535) 时间 秒

属性(0-10)
(0)暴击几率增加 1~1000%
(1)增加攻击伤害 1~1000%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加杀人暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%
(11)增加杀怪暴率 1~100%
(12)增加防爆几率(该件装备死亡防止爆出几率) 1~100%
(13)增加防止麻痹 1~100%
(14)增加防止护身 1~100%
(15)增加防止复活 1~100%
(16)增加防止全毒 1~100%
(17)增加防止诱惑 1~100%
(18)增加防止火墙 1~100%
(19)增加防止冰冻 1~100%
(20)增加防止蛛网 1~100%
(21)致命一击几率 1~100%
(22)致命一击伤害增加 1~100%
(23)致命一击防御 1~100%
(24)暴击抗性(对方暴击几率 - 暴击抗性 = 对方暴击打出几率) 1~1000% ..........本抗性对应元素属性0 暴击几率增加
(25)攻击伤害抗性(对方攻击伤害倍数 - 攻击伤害抗性 = 对方攻击伤害增加的倍数) 1~1000% ..........本抗性对应元素属性1 增加攻击伤害
几率大于100%则按照100%计算，如暴击几率300%，目标暴击抗性270%，那么攻击这个目标的暴击几率只有30% ，，目标抗性为10% ，就是300-10=290 ，也为100%
(26)杀怪经验倍率 1~100000% [算法相加：自身倍数(自身倍率含特殊物品倍数*经验倍数命令 ） + 元素倍率]

[@升级]
#ACT
SetNewItemValueEx 0 0 + 10 10
; 衣服暴击属性增加10% 有效时间10秒
；此命令增加的属性为临时隐藏属性,不会在装备上或者属性栏显示属性

======================================================================================

几个元素整体变量：
元素性质 几率

防麻： <$UnParalysisRate>
防护身： <$UnMagicShieldRate>
防复活： <$UnRevivalRate>
防毒： <$UnPosionRate>
防诱惑： <$UnTammingRate>
防火墙： <$UnFireCrossRate>
防冰冻： <$UnFrozenRate>
防蛛网： <$UnCobwebWindingRate>

其他元素相关变量：
<$ELEMENT>，<$ELEMENT1> - <$ELEMENT25>


调整修改下次攻击伤害比例

格式: SetNextDamage 参数1

参数1 下次伤害百分比 不能为0和负数
低于100 伤害低于正常值

;例1
#act
SetNextDamage 300
#say
下次攻击 伤害提高到300%

;例2

[@Attack]
#act
<$CURRRTARGETNAME>.SetNextDamage 50
#say
目标角色的下次攻击伤害 为其正常伤害的50%

魔法触发请使用@MagicAttack，不要使用@MagSelfFunc

[@MagSelfFunc33] 可以理解为这个是释放魔法的时候触发。

@MagicAttack这个可以理解为攻击完成后触发。


调整英雄职业[!]

格式: ChangeHeroJob 职业(0,1,2)

#IF
CheckHeroOnline
#ACT
ChangeHeroJob 2
#SAY
你英雄现在的职业是道士.


调整游戏速度

格式: ChangeSpeed 速度类型 速度值 有效时间(秒，该参数为空时表示不限制时间，小退失效)
速度类型 1为 移动速度 2为攻击速度 3为魔法速度
速度值(-100 - 100之间，速度值间隔在M2-客户端控制-内挂控制-速度控制内设置速度间隔)

[@main]
#ACT
CHANGESPEED 1 5
#SAY
移动速度增加5,小退后失效！

[@加速]
#ACT
ChangeSpeed 2 10 10
SendMsg 5 攻击速度+10！时长10秒！

[@减速]
#ACT
ChangeSpeed 2 -10 10
SendMsg 5 攻击速度-10！时长10秒！

[@魔速]
#ACT
ChangeSpeed 3 10 10
SendMsg 5 魔法速度+10！时长10秒！

[@攻速总和]
#if
#act
changespeed 2 10 100
SENDMSG 6 您当前攻击速度(含装备加速)是：<$AttackSpeed>

英雄速度调整命令H.CHANGESPEED
分身速度调整命令FS.CHANGESPEED


调整装备升级次数[!]

功能: 调整装备升级次数或星星数量.

格式: ChangeItemUpgradeCount 位置(0~37,-1时为OK框物品) (+,-,=) 次数(0~255)

#IF
CheckItem 金条 1
#ACT
Take 金条 1
ChangeItemUpgradeCount 0 + 10
SendMsg 5 盔甲升级次数增加10次
#ELSESAY
你没有金条

位置如下：

-1 升级框
0--29：装备栏
30-36：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框


通过脚本建立一个NPC 动态创建NPC

通过脚本命令建立一个NPC,服务器重启后消失.

格式: CreateNPC NPC名字 地图 坐标X(-1时随机坐标) 坐标Y(-1时随机坐标) 外观 脚本文件 脚本文件是否要加上地图名称(例如.设置为0时脚本文件必须带“-3”如:“传送员-3.txt” 设置为1时脚本文件不需要带“-3”如:“传送员.txt”这样的好处就是，你可以在任意地图地图创建NPC，只要一个脚本“传送员.txt”而不需要“传送员-0.txt、传送员-3.txt”等等好多NPC脚本)
注意: 脚本文件必须在Market_Def目录中.

例如:首先在Market_Def中建立一个叫测试-3.txt的脚本文件.
#IF
#ACT
CreateNPC 测试 3 330 330 8 测试-3 0
#SAY
通过脚本建立了一个NPC.

#IF
#ACT
CreateNPC 测试NPC 3 -1 -1 8 测试NPC 1
#SAY
通过脚本建立了一个NPC 随机坐标

*脚本刷可巡逻的Npc,请在NPC代码后面加中挂号和坐标(具体参阅引擎-选项-自定义NPC界面下发说明)

#if
#act
CreateNPC 新的NPC 0 297 624 10026[301,634] 新的NPC 1


退出行会前触发

功能: 退出行会(门派)前触发

触发QF字段:
@ExitGuildBefore

终止退出行会命令:
StopExitGuild

;行会成员退出行会前触发 并终止退出操作，掌门人操作不受限制，也不会触发（主要规避行会PK时门派成员恶意退出行会）

;QFunction-0.txt 触发如下

[@ExitGuildBefore]
#ACT
StopExitGuild
SENDMSG 7 【提示】禁止退出行会
break

;掌门人将成员踢出行会前触发，并终止退出操作脚本

;QFunction-0.txt 触发如下

[@DelGuildMemBefore]
#ACT
StopExitGuild
sendmsg 6 不允许管理员删除行会成员<$CurUserName>


文本字符交替命令

功能：
文本字符交替/文本字符替换，可以将文本进行排名，交替换位置，一般用于捐献榜、拍行榜脚本

说明：
交换行数1和行数2中的内容（大于0：指定行；小于0：取倒数第几行）

格式：
ExchangeLineText 文件名(有盘符是绝对路径) 行数1 变量1 行数2 变量2
CacheExchangeLineText 文件名(有盘符是绝对路径) 行数1 变量1 行数2 变量2

[@测试]
#IF
#ACT
ExchangeLineText d:\a.txt 1 S1 -1 S2
SendMsg 6 已经将d:\a.txt中的第1行和最后1行进行交换，交行后：第1行的值为<$STR(S1)>,最后一行的值为<$STR(S2)>

;高频脚本请使用缓存命令CacheExchangeLineText 更高效


物品标记，装备标记，物品标识，装备标识、

功能：
物品标记数据在设置/修改后会随物品存盘，合区也会保留

格式：
 物品标记数据在设置/修改后会随物品存盘，合区也会保留

设置物品标记数据（根据需要选择合适的数据类型）：
设置1字节数字标记：SetItemAddByte 装备位置 序号(0-19) 值
设置4字节数字标记：SetItemAddInt 装备位置 序号(0-9) 值
设置文本标记：SetItemAddText 装备位置 序号(0-1) 文本(最多20个英文字符)

读取物品标记数据：
读取1字节数字标记：SetItemAddByte 装备位置 序号(0-19) 变量
读取4字节数字标记：SetItemAddInt 装备位置 序号(0-9) 变量
读取文本标记：SetItemAddText 装备位置 序号(0-1) 变量

[@设置标记]
#if
#act
SetItemAddByte 0 0 10
SetItemAddInt 0 0 100
SetItemAddText 0 0 我自己加的文字
sendmsg 5 衣服自定标记设置完成

[@读取标记]
#if
#act
GetItemAddByte 0 0 n0
GetItemAddInt 0 0 n1
GetItemAddText 0 0 s1
sendmsg 5 衣服自定义标记读取：单字节值(0)=<$STR(n0)>，4字节值(0)=<$STR(n1)>，文本值(0)=<$STR(s1)>

;==========================================


显示倒计时信息提示

功能:

显示倒计时信息提示

格式:

SENDDELAYMSG 信息内容 时间(秒) 字体颜色 换地图是否删除 跳转字段 X坐标

[@测试]
#if
#act
SENDDELAYMSG 你的礼物在%s后到达 300 255 0 @给礼物

------------------------------------------
300秒倒计时结束后会执会当前脚本文件里的@给礼物段


新游戏点[!]

检测命令 CHECKGAMEGOLDEX 检测符(<,>,=) 值
操作命令 GAMEGOLDEX 操作符(+,-,=) 值
显示变量 <$GAMEGOLDEX>


修改宝宝属性

功能：
修改宝宝属性
ChangeSlaveAbilityEx 参数1 参数值 值类型(0:点;1:百分比) 宝宝名（空表示所有宝宝）
参数1表示值：
0: HP； 1: MaxHP； 2:MP； 3:MaxMP； 4:AC1； 5:AC2； 6:MAC1； 7:MAC2； 8:DC1； 9:DC2； 10:MC1； 11:MC2； 12:SC1； 13:SC2 14:攻击速度 15:移动速度 30:属性有效时间（秒，空或0表示不检测时间）

// 重算宝宝属性，ChangeSlaveAbilityEX后不会重算宝宝属性，必须调用本命令
RecalcSlaveAbility 宝宝名（为空表示所有宝宝）
;------------------------------------------------

例子：

[@Test]
#IF
#ACT
ChangeSlaveAbilityEX 14 -10 1
ChangeSlaveAbilityEX 15 -10 1
ChangeSlaveAbilityEX 30 30
RecalcSlaveAbility
sendmsg 6 您的所有宝宝攻击速度和移动速度加快了10%，有效时间30秒！
break

;------------------------------------------------

例子：

[@Test]
#IF
#ACT
ChangeSlaveAbilityEX 14 -100
ChangeSlaveAbilityEX 15 -100
ChangeSlaveAbilityEX 30 30
RecalcSlaveAbility
sendmsg 6 您的所有宝宝攻击速度和移动速度间隔减少100ms，有效时间30秒！
break

值： -10为宝宝原始属性参数减少10 ，+10则是原始参数加10（变慢） ，0 为恢复原始速度，符号中间无空格！！！！！

格式如下：
ChangeSlaveAbilityEX 14 -10 1
ChangeSlaveAbilityEX 14 +10 1
ChangeSlaveAbilityEX 14 0 1

ChangeSlaveAbilityEX 14 -50
ChangeSlaveAbilityEX 14 +50
ChangeSlaveAbilityEX 14 0


修改宝宝外观

功能：
修改宝宝外观
ChangeSlaveAppr 脸型 宝宝名（为空或*，表示所有宝宝，指定名字为指定宝宝） 脸型有效时间（分钟，空或0 表示不检测时间）

例子：

[@Test]
#IF
#ACT
;//修改宝宝脸型
ChangeSlaveAppr 72 神兽 60
sendmsg 6 您的神兽外观已经修改为虎卫外观！有效时间60分钟！
break


修改地图内怪物属性,修改怪物属性(在原属性的基本上进行加减操作）

修改地图内怪物属性 (在原属性的基本上进行加减操作）

格式:格式: ChangeMonAbility 地图名(self：当前所在地图) 怪物名(*：所有怪物) 参数类型 操作符(+/-/=) 参数值 值类型(0:点;1:百分比) 坐标X 坐标Y 范围 (当坐标及范围均为空时，表示为整个地图，非必要请不要整个地图修改属性，因为消耗性能)

功能说明: 刷新地图内怪物属性

格式: RecalcMonAbility 地图名(self:当前所在地图) 怪物名(*:所有怪物) X坐标 Y坐标 范围 (当坐标及范围均为空的时候，表示为整个地图，非必要请不要整个地图修改属性，因为消耗性能)

*PS:当参数中坐标和范围全部为空时则修改整个地图怪物，仅范围为空或等于0时为修改坐标上的怪物，大于0则是坐标为中心半径范围内的怪物

设置修改后怪物属性有效时间
ChangeMonAbility 地图名(self：当前所在地图) 怪物名(*：所有怪物) 参数类型 操作符(+/=) 参数值（秒，空或0表示不检测时间）
参数1表示值：
0: HP； 1: MaxHP； 2:MP； 3:MaxMP； 4:AC1； 5:AC2； 6:MAC1； 7:MAC2； 8:DC1； 9:DC2； 10:MC1； 11:MC2； 12:SC1； 13:SC2 14:攻击速度 15:移动间隔 30:属性有效时间（秒，空或0表示不检测时间）

*****************; 特别提醒 ： 非必要请不要整个地图修改属性，因为消耗性能，推荐使用范围。建议使用原子钟测试，超过1000微秒基本属于高消耗*******************

示范脚本：

[@Test]
#IF
#ACT
;减白野猪50%的MaxHP
ChangeMonAbility 3 白野猪 1 = -50 1 325 323 10
;减白野猪10点的防御下限
ChangeMonAbility 3 白野猪 4 = -10 0 325 323 10
;减白野猪10点的防御上限
ChangeMonAbility 3 白野猪 5 = -10 0 325 323 10
;加白野猪50点的攻击下限
ChangeMonAbility 3 白野猪 8 = 50 0 325 323 10
;加白野猪50点的攻击上限
ChangeMonAbility 3 白野猪 9 = 50 0 325 323 10
;设置有效时间
ChangeMonAbility 3 白野猪 30 + 20
;重算怪物属性
RecalcMonAbility 3 白野猪 325 323 10
sendmsg 6 土城坐标325 323范围10格内的白野猪属性已经刷新 有效时间20秒！
break

[@Test1]
#IF
#ACT
;减白野猪50%的MaxHP
ChangeMonAbility 3 白野猪 1 = -50 1 325 323 10
;减白野猪10点的防御下限
ChangeMonAbility 3 白野猪 4 = -10 0 325 323 10
;减白野猪10点的防御上限
ChangeMonAbility 3 白野猪 5 = -10 0 325 323 10
;加白野猪50点的攻击下限
ChangeMonAbility 3 白野猪 8 = 50 0 325 323 10
;加白野猪50点的攻击上限
ChangeMonAbility 3 白野猪 9 = 50 0 325 323 10
;重算怪物属性
RecalcMonAbility 3 白野猪 325 323 10
sendmsg 6 土城坐标325 323范围10格内的白野猪属性已经刷新！
break


修改物品的附加属性值

功能： 修改物品的附加属性值

格式: CHANGEITEMADDVALUE 装备位置(-1时是升级OK框中的装备, boxitem0 -boxitem7是自定义OK框，0-51时是穿在身上的装备) 属性位置(0-18) (符号 + - =) 值
修改英雄物品的附加属性值命令：H.CHANGEITEMADDVALUE 装备位置(-1时是OK框中的装备, 0-51时是穿在身上的装备) 属性位置(0-18) (符号 + - =) 值

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求（无效）
6 佩带级别（无效）
7-13 无效果
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求（无效）
7 佩带级别（无效）
8 reserved
9-13 暂不知道
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求（无效）
7 佩带级别（无效）
8-13 无效果
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求（无效）
7 佩带级别（无效）
8-13 无效果
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

功能：读取物品的附加属性值
格式：GetItemAddValue 装备位置(-1时是升级OK框中的装备, boxitem0 -boxitem7是自定义OK框，0-51时是穿在身上的装备) 属性位置(0-18) 变量名

例子：

[@Test]
 #IF
CheckItemAddValue 0 0 > 1
#ACT
GETITEMADDVALUE 0 0 <$STR(M10)>
#SAY
你的盔甲附加了<$STR(M10)>点防御属性.

英雄获取物品的附加属性值H.GETITEMADDVALUE


修改装备内观和外观命令

外观格式: SetItemShape 位置 操作符(+，-，=) 数值 ;只能改武器和衣服

内观格式:SetItemLooks 位置 操作符(+，-，=) 数值

命令一个分别修改装备的Shape，另外个是修改Looks，注意的是，只是改变视觉效果，不是改变实际！！！！！


循环脚本运行次数设置

说明：循环脚本运行次数设置

格式：Loopgoto @脚本 脚本运行次数（为空或0时，运行1次）

示范脚本：
[@循环]
#ACT
mov N1 0
mov N2 1
Loopgoto @运算 100
sendmsg 6 1加到100的结果为：<$STR(N1)>

[@运算]
#ACT
Inc <$STR(N1)> <$STR(N2)>
Inc N2 1

增加NPC命令：endloop中止loopgoto

[@随机取数]
#act
mov p1 0
loopgoto @取数 100
sendmsg 6 循环<$str(p1)>次，才取到>=50的数：<$str(p10)>

[@取数]
#act
inc p1 1
;此例仅做说明，实际只用取一次，取50以内的取机数+49即可
movr p10 100

#if
large p10 49
#act
endloop


延时移动

功能:
延时移动

格式:
TIMERECALL 时间(分钟)

============================

[@Test]
#IF
#ACT
timerecall 60
map G012
give 回城卷 1
SENDMSG 0 [%s]使用了元宝练级卷.进入快速升级地图,1小时后会将您传回土城!

<$RecallRemainingTime> 显示延时TIMERECALL还剩多少秒。

===========================


验证码功能说明

验证码功能，用法类似GOTO，验证成功后需下级脚本才有执行权限(验证码支持中文、字母、数字自行在M2-列表信息1设置验证内容)
例:
[@main]
#IF
CanVerifyCode
#ACT
VerifyCode @回收验证完成

[@回收验证完成]
#IF
CheckVerifyCode
#ACT
#say
验证通过!


移动到回城点

功能：
 移动到回城点

使用方法：

[@main]
#if
#act
GoHome
#say
你已经回城了

[@main]
#if
#act
GoHome 5
;回城点范围5内随机
#say
你已经回城了


英雄宝宝攻击触发

-----------------------------------英雄宝宝攻击触发---和人物宝宝攻击触发用法一致，只是触发命令不同---------------------------

@HeroSlaveMagicStruck
@HeroSlaveStruck
@HeroSlaveMagicAttack
@HeroSlaveAttack

增加变量<$H.CurSlaveName> 英雄当前宝宝名 。 仅用于 [@HeroSlaveMagicAttack] 及 [@HeroSlaveAttack]中

增加英雄的宝宝死亡触发 @OnHeroSlaveDie

增加英雄的分身死亡触发 @OnHeroCloneDie

增加变量<H.DIESLAVENAME> 英雄当前死亡宝宝名（不去数字)

[@HeroSlaveMagicStruck]
#act
sendmsg 5 英雄宝宝被魔法攻击

[@HeroSlaveStruck]
#act
sendmsg 5 英雄宝宝被物理攻击

[@HeroSlaveMagicAttack]
#act
sendmsg 5 英雄的宝宝 <$H.CurSlaveName> 正在用魔法攻击目标

[@HeroSlaveAttack]
#act
sendmsg 5 英雄的宝宝 <$H.CurSlaveName> 正在砍目标


英雄相关命令支持与示范，英雄捡起触发

-----------------------------------英雄捡起触发---------------------------

1.增加英雄相关操作命令 支持-1位置
H.LINKPICKUPITEM
H.ChangeItemName
H.UpdateItem
H.ClearLinkItem
H.LINKGIVEITEM
H.ChangeItemNameColor
H.ChangeItemName

示范：

[@H.PickUpItemEx]
#if
#act
H.LINKPICKUPITEM
H.ChangeItemName -1 捡到的<$PICKDROPITEMNAME>
H.UpdateItem -1
H.ClearLinkItem
SENDMSG 0 玩家<$USERNAME>的英雄在<$MapTitle>坐标<$X>：<$Y>捡到<$PICKDROPITEMNAME>
break

#IF
#ACT
H.give 屠龙 1
;给屠龙1把
H.LINKGIVEITEM
;绑定屠龙下面的操作只对绑定的装备生效
H.ChangeItemNameColor -1 253
H.ChangeItemName -1 屠龙改名
;调整武器颜色
H.updateitem -1
;刷新到客户端
H.clearLinkItem

注：如果命令不知道干啥的，可以去掉命令前的H. 然后搜索人物命令查看介绍即可！！！！

特别注意：如果不解绑的情况下，会出现修改过属性的物品丢失，本命令绑定和解绑必须配套使用，只要绑定了，脚本执行不管成功还是失败，只要执行了绑定都必须执行解绑，切记！！！


永久调整人物属性值

功能： 调整人物属性

格式: ChangeHumAbilityEX 属性(1-29) 操作符(+ = -) 效果(1-65535)
说明: 属性1-29分别对应值
1、防御下限
2、防御上限
3、魔御下限
4、魔御上限
5、攻击下限
6、攻击上限
7、魔法下限
8、魔法上限
9、道术下限
10、道术上限
11、MaxHP
12、MaxMP
13、内功攻击伤害减
14、HP恢复
15、MP恢复
16、毒恢复
17、毒躲避
18、魔法躲避
19、准确
20、敏捷
21、幸运
22、内功伤害增加
23、内力值
24、刺术下限
25、刺术上限
26、箭术下限
27、箭术上限
28、武力下限
29、武力上限

注意: 此命令是永久增加属性值

例子：

[@Test]
#IF
#ACT
ChangeHumAbilityEX 2 + 10
#SAY
你的防御上限增加10点

提示：调整英雄属性命令为： H.ChangeHumAbilityex

注：支持调整人物原始属性，减少属性为累计属性，如：人物100点攻击，命令减少200点，那么人物攻击变成0，更换装备提升攻击，必须让人物自身攻击大于200才可以突破0（因为已经存储人物攻击减少200点），恢复原始属性 ChangeHumAbilityEX = 0 即可

也就是当减少属性大于角色当前属性，角色需要将差值的坑填满才可以有属性 (慎重使用)

;涉及人物或英雄的属性修改建议使用LockUpdateAbil和UpdateAbil对执行脚本进行锁定操作并解锁刷新来显著提高脚本性能，详细请说明书搜索LockUpdateAbil和UpdateAbil查阅说明文档


永久增加人物属性点(按属性分配点分配)

功能：
永久增加人物属性分配点（增加的为属性点，如属性点分配设置加1点攻击需要17点，那么此脚本增加20点可以增加1点攻击剩余3点.并非直接增加20点攻击点数）。

格式：
 USEBONUSPOINT 属性位置（1-9） 控制符（+,-,=） 点数

;==========================================
[@Main]
#ACT
USEBONUSPOINT 1 + 20
SENDMSG 7 攻击力增加20点.

[@Main]
#ACT
USEBONUSPOINT 2 + 20
SENDMSG 7 魔法力增加20点.

[@Main]
#ACT
USEBONUSPOINT 3 + 20
SENDMSG 7 道术力增加20点.

[@Main]
#ACT
USEBONUSPOINT 4 + 20
SENDMSG 7 防御力增加20点.

[@Main]
#ACT
USEBONUSPOINT 5 + 20
SENDMSG 7 魔防力增加20点.

[@Main]
#ACT
USEBONUSPOINT 6 + 20
SENDMSG 7 生命值上限增加20点

[@Main]
#ACT
USEBONUSPOINT 7 + 20
SENDMSG 7 魔法值上限增加20点.

[@Main]
#ACT
USEBONUSPOINT 8 + 20
SENDMSG 7 准确增加20点.

[@Main]
#ACT
USEBONUSPOINT 9 + 20
SENDMSG 7 躲避增加20点.
;==========================================


游戏币(元宝)控制

功能：
调整人物游戏币及根据时间自动增减游戏币（可用来做会员时间用）。

格式：
GAMEGOLD 控制符(=,+,-) （1-100）

;==========================================
;设置人物游戏币
[@GAMEGOLD0]
#IF
#ACT
GAMEGOLD = 8
#SAY
你的游戏点已经为8了。
;==========================================

;==========================================
;增加人物游戏币
[@GAMEGOLD1]
#IF
#ACT
GAMEGOLD + 1
#SAY
你的游戏点已经加了1点。
;==========================================

;==========================================
;降人物游戏币
[@GAMEPOINT2]
#IF
#ACT
GAMEGOLD - 1
#SAY
你的游戏币已经降了1点。
;==========================================

功能：
设置是否自动增加游戏币。

格式：
AUTOADDGAMEGOLD 控制符(START,STOP)

;==========================================
;设置自动增加游戏币
[@AutoAddGAMEGOLD]
#IF
#ACT
PARAM1 1
PARAM2 10
AUTOADDGAMEGOLD START
#SAY
现进入自动增加游戏币模式，每10秒增加一个

;==========================================

;==========================================
;停止自动增加游戏点
[@AutoAddGAMEGOLD]
#IF
#ACT
AUTOADDGAMEGOLD STOP
#SAY
现退出自动增加游戏币模式

;==========================================

功能：
设置是否自动减少游戏币。

格式：
 AUTOADDGAMEGOLD 控制符(START,STOP)

;==========================================
;设置自动增加游戏币
[@AutoAddGAMEGOLD]
#IF
#ACT
PARAM1 1
PARAM2 10
AUTOSUBGAMEGOLD START
#SAY
现进入自动增加游戏币模式，每10秒增加一个
;==========================================

;==========================================
;停止自动增加游戏点
[@AutoAddGAMEGOLD]
#IF
#ACT
AUTOSUBGAMEGOLD STOP
#SAY
现退出自动减少游戏币模式

;==========================================


游戏窗口标题公告

 功能说明：窗口标题公告

格式：SendClientTitleMsg 显示内容

;例子
[@main]
#ACT
SendClientTitleMsg 显示内容
;SendClientTitleMsg 你的会员到期时间是<$STR(S1)>【剩余天数=<$STR(N1)>】


在登陆器里浏览网页

功能：
浏览网页

格式：
WebBrowser 地址

;==========================================
[@WebBrowsertest]
#IF
#ACT
WebBrowser http://www.lfm2.com
;==========================================


在地图上播放魔法效果[!]

格式: MAPEFFECT 地图名称 X Y WIL文件序号 开始图片数 播放图片张数 播放次数(-1为无限次数) 播放速度(毫秒) 播放效果(0普通 1特效) (该参数值范围0~5，0表示没有亮度，在关闭禁止免蜡时有效) ID 播放顺序(0或空：对象底层；1：对象上层 2：所有对象上层)

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

图层播放顺序说明：
0或空 在当前坐标对象的底层播放 (类似火墙)
1 在当前坐标对象的前面 (类似playeffect 效果, 置于对象会在顶层播放,置于坐标Y+1的对象时,会被其遮挡)
2 在全部图层的上方 (不会被其他目标遮挡，类似雷电术)

[@main]
#ACT
MAPEFFECT 3 333 333 0 0 10 1 300 1 0

关闭指定特效（参数同 MapEffect一样，参数一样的删除）：

DelMapEffect 3 333 333 0 0 10 1 300 1 0

---------------------------2017-06-29扩展---------------------------

MAPEFFECT，DelMAPEFFECT 扩展第11个参数，ID，为空，保留以前的逻辑

0 - n，指定id（为空表示-1）个特效id可以重复，删除时，指定id的全删

; 2个特效同一个id，都为1
MAPEFFECT 3 333 333 1 500 10 -1 300 1 0 1
MAPEFFECT 0 111 111 1 500 10 -1 300 1 0 1

; 最后参数id = 1，直接按id删除，会删会上面2个特效
DelMAPEFFECT 0 0 0 0 0 0 0 0 0 0 1


在地图上放物品[!]

格式: THROWITEM 地图名称 X坐标 Y坐标 范围 物品名称 数量|时间(此时间不受M2上的爆物品可捡时间控制) 捡取条件（0、1、2、3） 叠加物品是否叠加（0或空：叠加；1非叠加）

[@main]
#IF
Random 100
#ACT
ThrowItem 3 330 330 10 回城卷 5|60

捡取条件说明：

0 或者空 任何人都不可以捡，必须等到时间才可以
1 所有人都可以立即拾取。
2 自己与队伍可立即拾取，其他人不可拾取，需等到时间
3 自己可以立即拾取。其他人需要等到时间才可以


在屏幕上播放魔法效果

格式: SCREENEFFECT 屏幕坐标X 屏幕坐标Y WIL文件序号 开始图片数 播放图片张数 播放次数 播放速度(毫秒) 播放效果(0=普通，1=魔法效果) 模式(0=自己，1=所有人) 播放位置（0或空，在对话框下层播放，1：在对话框上层播放）

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

[@main]
#ACT
SCREENEFFECT 0 0 0 0 10 1 300 0

=====================================================================================
停止魔法效果（停止哪个特效通过参数来判断，参数一致的特效将被停止）

格式: StopScreenEffect 屏幕坐标X 屏幕坐标Y WIL文件序号 开始图片数 播放图片张数 播放次数(-1和0为不限次数) 播放速度(毫秒) 播放效果(0=普通，1=魔法效果) 模式(0=自己，1=所有人) 播放位置（0或空，在对话框下层播放，1：在对话框上层播放）

WIL文件序号是在M2里编辑好的，详见M2-查看-列表信息二-WIL资源

[@main]
#ACT
StopScreenEffect 0 0 0 0 10 1 300 0

=====================================================================================
清空魔法效果（停止所有SCREENEFFECT命令播放的特效）

[@main]
#ACT
ClearScreenEffect 模式（0：自己；1：屏幕上所有人）


在文件的固定行替换写入内容[!]

功能：
在文件的固定行替换写入内容.

格式: WriteLine 文件名 行号(0开始) 内容 是否绝对路径(0或空:不是，1:是)

说明：说明：文件不存在写入失败，行号从0开始，替换写入，当行不存在时，插入到最后一行

示列：

[@mail]
#ACT
WRITELINE d:\aaaa.txt 1 写入一段文字 1
SENDMSG 6 第2行内容被修改


在文件的指定行插入一行内容[!]

功能：
在文件的指定行插入一行内容.

格式: InsertLine 文件名 行号(0开始) 内容 是否绝对路径(0或空:不是，1:是)

说明：文件不存在写入失败，行号从0开始

示列：

[@mail]
#ACT
InsertLine d:\aaaa.txt 1 插入一行文字 1
SENDMSG 6 第2行插入了新的内容


在线命令弹出菜单功能

功能：
 玩家在线输入指定命令弹出菜单脚本功能

格式：
命令为command.ini内（命令名称随便定义）：MemberFunc=我是会员
输入@我是会员 命令后将运行登录脚本(Qmanage.txt)内[@Member]段内容脚本
具体脚本内容自己写。


在线泡经验

功能：
在线泡经验（直接得到经验）

格式：例：（等级30级以上，地图3安全区内每1秒种得到10个经验点）
==================================================
#IF
CheckLevelex > 30
#ACT
setautogetexp 1 10 1 3 1 1 1000 100

命令 ：setautogetexp
参数一：间隔时间
参数二：获得经验值
参数三：是否安全区（0为任何地方）
参数四：地图号（*为任何地图）
参数五：是否允许英雄分配经验（0为禁止）
参数六：是否允许将经验存放聚灵珠（1为允许，留空或0为不允许）
参数七：泡点有效时间（秒；为0或空表示泡点一直有效）
参数八：100为限制泡点等级（参数8等级限制(0为不限制 填写100 则表示小于100级才会获得经验 到100级了就不加经验了 命令自动结束)

==================================================


在线修改宝宝名字[!]

功能：
在线修改宝宝名字.

格式：ChangeBmz 新名字 原有名字 （如果原有名字为空，则把所有宝宝的名字都改成新名字）

示列：

[@ChangeBmz]
#IF
#ACT
ChangeBmz 超级神兽
SendMsg 5 你所有宝宝名字修改为超级神兽！

[@ChangeBmz1]
#IF
CHECKSLAVENAME 神兽
#ACT
ChangeBmz 超级神兽 神兽
SendMsg 5 你的神兽宝宝名字成功修改为超级神兽！
#ELSEACT
SENDMSG 5 提示:你的宝宝名字不叫神兽


暂停刷怪,停止刷怪

说明: 暂停游戏刷怪

检测是否暂停刷怪：
CheckStopM2MakeMon

暂停M2Server刷怪
StopM2MakeMon 参数1(0:不暂停；1:暂停)

[@test]
#if
CheckStopM2MakeMon
#act
StopM2MakeMon 0
sendmsg 6 现在已经恢复M2刷怪
#elseact
StopM2MakeMon 1
sendmsg 6 现在已经暂停M2刷怪


增加附加伤害效果

格式: RangeHarm 参数1 参数2 参数3 参数4 参数5 参数6....参数12

说明：
RangeHarm 参数1 参数2 参数3 参数4 参数5 参数6.....参数12
参数1 X坐标
参数2 Y坐标
参数3 范围
参数4 伤害值
参数5 附加效果 0=无，1=击退，2=冻结，3=麻痹，4=吸血，5=吸蓝,6真实伤害,7石化, 8冰冻,9蛛网效果,10红毒, 11绿毒,12定身,13瘫痪,14防禁锢,15最大hp百分比真实伤害,16当前hp百分比真实伤害
参数6 附加属性值 分别对应参数5= 1;击退距离 、2;冻结时间 、3;麻痹时间、4;吸血值、5;吸蓝值、6;真实伤害值（真实伤害无视防御不无视护身）、7;石化时间、8;冰冻时间、9;蛛网时间、10;红毒时间、
11;绿毒时间、12;定身时间、13;瘫痪时间、14;防禁锢时间、15;MAXHP百分比伤害值、16;HP百分比真实伤害值
参数7 是否检查防冻结/麻痹/石化/冰冻/蛛网/红毒/绿毒属性（0: 直接设置状态; 1：检查后设置状态)
参数8 目标(0或空:所有目标; 1:仅人物; 2:仅怪物)
参数9 WIL序号
参数10 开始图片
参数11 播放张数
参数12 播放速度
参数13 是否透明绘制(0或空，1)
参数14 是否物理属性攻击(0或空，1 物理属性则目标以防御来抵御伤害，0或者空目标则以魔御来抵御伤害)

例
RangeHarm 333 333 8 100 1 5 0 0
当前地图 坐标 333 333 范围8之内所有可以攻击的目标都受到100点伤害 并且被击退5格
所有参数都支持变量 伤害和普通伤害一样 需要考虑目标的防御

扩展了一个 RangeHarmEx 支持伤害触发

RangeHarmEx
参数1 X坐标
参数2 Y坐标
参数3 范围
参数4 伤害值
参数5 附加效果 0=无；1=击退，2=冻结，3=麻痹，4=吸血，5=吸蓝, 6真实伤害, 7.石化 8.冰冻 9.蛛网效果 10.红毒 11.绿毒, 12.定身 13.瘫痪 14.防禁锢,15最大hp百分比真实伤害,16当前hp百分比真实伤害
参数6 附加属性值 分别对应参数5= 1;击退距离 、2;冻结时间 、3;麻痹时间、4;吸血值、5;吸蓝值、6;真实伤害值（真实伤害无视防御不无视护身）、7;石化时间、8;冰冻时间、9;蛛网时间、10;红毒时间、
11;绿毒时间、12;定身时间、13;瘫痪时间、14;防禁锢时间、15;MAXHP百分比伤害值、16;HP百分比真实伤害值
参数7 是否检查防冻结/麻痹/石化/冰冻/蛛网/红毒/绿毒属性（0: 直接设置状态; 1：检查后设置状态)
参数8 目标(0或空:所有目标; 1:仅人物; 2:仅怪物)
参数9 触发选项(0:所有目标触发； 1:只触发一次）
参数10 触发几率(仅对所有目标触发有效，值越小几率越高)
参数11 WIL序号
参数12 开始图片
参数13 播放张数
参数14 播放速度
参数15 是否透明绘制(0或空，1)
参数16 是否物理属性攻击(0或空，1 物理属性则目标以防御来抵御伤害，0或者空目标则以魔御来抵御伤害)

注：RangeHarm和RangeHarmEx按需使用

英雄命令：
H.RangeHarm 参数1 参数2 参数3 参数4 参数5 参数6....参数12
H.RangeHarmEx 参数1 参数2 参数3 参数4 参数5 参数6....参数12

分身命令：
FS.RangeHarm 参数1 参数2 参数3 参数4 参数5 参数6....参数12
FS.RangeHarmEx 参数1 参数2 参数3 参数4 参数5 参数6....参数12

[@Attack]
#IF
#ACT
RangeHarm <$X> <$Y> 12 100 15 10 0 0 0 0 0 0 0 0
SENDMSG 6 当前屏幕内所有目标造成100点伤害附加10%的伤害


增加会员时间[!]

功能：
增加会员时间 文件名称 天 时 分

例子：

[@Test]
#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 <$STR(S1)> <$STR(N1)> <$STR(N2)> <$STR(N3)>
#ACT
ADDNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 30 0 0
SENDMSG 5 <$USERNAME>会员充值成功，增加30天0小时0分会员时间！
SENDMSG 6 你的会员到期时间是<$STR(S1)>【剩余天数=<$STR(N1)>】【剩余小时=<$STR(N2)>】【剩余分钟=<$STR(N3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253


增加人物IP在列表中

功能：
增加人物IP在列表中

功能：
================================
[@AddIPList]
#IF
#Act
ADDIPLIST IPList.txt
================================


增加人物名在列表中

功能：
增加人物名在列表中

格式：
================================
[@AddNameList]
#IF
#Act
ADDNAMELIST NameList.txt
================================

缓存操作命令：AddCacheNameList
用法和AddNameList一致,区别就是内存中操作


增加人物帐号在列表中

功能：
增加人物帐号在列表中

功能：
================================
[@AddAccountList]
#IF
#Act
ADDACCOUNTLIST AccountList.txt
================================


增加隐藏元素属性

格式: AddHumNewValue 属性(0-20) 操作符(+,-,=) 值(1-100) 时间(1-21亿秒，时间留空则为在线一直有效)

AddHumNewValue 属性(0-20) 操作符(+,-,=) 值(1-100)
属性(0-20)

(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加杀人暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%
(11)增加杀怪暴率 1~100%
(12)不支持!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
(13)增加防止麻痹 1~100%
(14)增加防止护身 1~100%
(15)增加防止复活 1~100%
(16)增加防止全毒 1~100%
(17)增加防止诱惑 1~100%
(18)增加防止火墙 1~100%
(19)增加防止冰冻 1~100%
(20)增加防止蛛网 1~100%
(21)致命一击几率 1~100%
(22)致命一击伤害增加 1~100%
(23)致命一击防御 1~100%
(24)暴击抗性(对方暴击几率 - 暴击抗性 = 对方暴击打出几率) 1~1000% ..........本抗性对应元素属性0 暴击几率增加
(25)攻击伤害抗性(对方攻击伤害倍数 - 攻击伤害抗性 = 对方攻击伤害增加的倍数) 1~1000% ..........本抗性对应元素属性1 增加攻击伤害
几率大于100%则按照100%计算，如暴击几率300%，目标暴击抗性270%，那么攻击这个目标的暴击几率只有30% ，，目标抗性为10% ，就是300-10=290 ，也为100%
(26)杀怪经验倍率 1~100000% [算法相加：自身倍数(自身倍率含特殊物品倍数*经验倍数命令 ） + 元素倍率]

说明：此命令只调整本命令对应的元素属性值，而不会改变装备自带的属性值

如：AddHumNewValue 0 = 10 100
将人物的暴击几率调整为10，假如人身上的装备暴击几率原来为5，则最终人物身上的暴击几率为 10 + 5

直接：此属性仅自己在状态栏元素综合属性中查看，无需装备，别人是无法看到的 ,按需使用


战斗力计算

-----------------------------------战斗力计算---------------------------

功能说明：位于引擎---选项--战斗力计算设置 用于计算战斗力总值

示范：

[@战斗力]
#if
#act
Inc N0 10
SENDMSG 6 你的战斗力为<$CombatPower>

[@英雄战斗力]
#if
#act
Inc N0 10
SENDMSG 6 你英雄的战斗力为<$H.CombatPower>


掌门人踢出行会成员前触发

功能: 掌门人踢出行会成员前触发

触发QF字段:
@DelGuildMemBefore

终止退出行会命令:
StopExitGuild

;行会成员退出行会前触发 并终止退出操作，掌门人操作不受限制，也不会触发（主要规避行会PK时门派成员恶意退出行会）

;QFunction-0.txt 触发如下

[@ExitGuildBefore]
#ACT
StopExitGuild
SENDMSG 7 【提示】禁止退出行会
break

;掌门人将成员踢出行会前触发，并终止退出操作脚本

;QFunction-0.txt 触发如下

[@DelGuildMemBefore]
#ACT
StopExitGuild
sendmsg 6 不允许管理员删除行会成员<$CurUserName>


召唤指定怪物为宝宝

功能：
脚本召唤宝宝。

格式：
RECALLMOB 怪物名称 宝宝等级(最高为 7) 叛变时间(分钟) 颜色类型(0:固定颜色,1:自动变色) 颜色值(0-255;0不改变颜色) 所属技能 召唤数量
攻击力受自动变色颜色不同而不同
固定颜色攻击力受指定颜色不同而不同

注：如设固定颜色，自动变色参数必须设置为0

;==========================================
;召唤最多5个七宝宝，30分钟后叛变,七彩变色
[@recallmob]
#IF
CHECKSLAVECOUNT < 5
#ACT
RECALLMOB 神兽 7 30 1
#SAY
好好看着自己的宝宝，不要乱咬人。
#ELSESAY
你已经有5个或以上的宝宝，现在不可以再召宝宝。
;==========================================

所属技能取值如下
1：骷髅
2：神兽
3：圣兽
4：月灵
5：诱惑之光
其他值和留空则表示不算到技能中


致命一击触发，暴击触发

说明：
    致命一击打出触发，暴击打出触发

命令：

[@BlastAttack]
#ACT
SENDMSG 6 物理攻击触发暴击

[@BlastMagicAttack]
#ACT
SENDMSG 6 魔法攻击触发暴击

[@FatalAttack]
#ACT
SENDMSG 6 物理攻击触发致命一击

[@FatalMagicAttack]
#ACT
SENDMSG 6 魔法攻击触发致命一击

[@HeroBlastAttack]
#ACT
SENDMSG 6 英雄物理攻击触发暴击

[@HeroBlastMagicAttack]
#ACT
SENDMSG 6 英雄魔法攻击触发暴击

[@HeroFatalAttack]
#ACT
SENDMSG 6 英雄物理攻击触发致命一击

[@HeroFatalMagicAttack]
#ACT
SENDMSG 6 英雄魔法攻击触发致命一击


重新分配人物附加属性点
功能：
将人物附加的属性点复位到未分配状态；
格式：
#if
#act
RESTBONUSPOINT
#say
你的属性点已经重新分配；

相关命令：
检查属性点数：CHECKBONUSPOINT
调整属性点数：BONUSPOINT


转换职业

功能：
转换职业。

格式：
 CHANGEJOB 职业名称(Warrior,Wizard,Taoist)

;==========================================
;转职业为武士
[@changejob0]
#IF
#ACT
CHANGEJOB Warrior
#SAY
你的职业已经变成武士了。
;==========================================

;==========================================
;转职业为法师
[@changejob1]
#IF
#ACT
CHANGEJOB Wizard
#SAY
你的职业已经变成法师了。
;==========================================

;==========================================
;转职业为道士
[@changejob2]
#IF
#ACT
CHANGEJOB Taoist
#SAY
你的职业已经变成道士了。
;==========================================


装备名称自定义系统

功能：
装备名称自定义系统

格式：
例脚本：

(@@useitemname)
[@main]
请选择要改名的装备：(将要改名的装备戴身上)\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
◇◇◇『<盔　甲/@@useitemname0>』◇◇◇『<武　器/@@useitemname1>』◇◇◇\
◇◇◇『<项　链/@@useitemname3>』◇◇◇『<头　盔/@@useitemname4>』◇◇◇\
◇◇◇『<左手镯/@@useitemname5>』◇◇◇『<右手镯/@@useitemname6>』◇◇◇\
◇◇◇『<左戒指/@@useitemname8>』◇◇◇『<右戒指/@@useitemname7>』◇◇◇\
◇◇◇『<勋 章/@@useitemname2>』\
┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈┈\
〖<返回/@main>〗 〖<关闭/@exit>〗
[@@useitemname0]
#ACT
goto @ChangeName
[@@useitemname1]
#ACT
goto @ChangeName
[@@useitemname2]
#ACT
goto @ChangeName
[@@useitemname3]
#ACT
goto @ChangeName
[@@useitemname4]
#ACT
goto @ChangeName
[@@useitemname5]
#ACT
goto @ChangeName
[@@useitemname6]
#ACT
goto @ChangeName
[@@useitemname7]
#ACT
goto @ChangeName
[@@useitemname8]
#ACT
goto @ChangeName
[@@useitemname9]
#ACT
goto @ChangeName
[@@useitemname10]
#ACT
goto @ChangeName
[@@useitemname11]
#ACT
goto @ChangeName
[@@useitemname12]
#ACT
goto @ChangeName
[@ChangeName]
#if
checkgamegold > 0
#act
gamegold - 1
SETSCRIPTFLAG 1 1
sendmsg 7 改名成功！！！
Close
#elseact
sendmsg 7 没钱跑来做什么？

如果启用了特殊字符过滤功能请修改为以下脚本：

[@ChangeName]
#if
checkgamegold > 0
#act
SETSCRIPTFLAG 1 1
Close
#elseact
sendmsg 7 没钱跑来做什么？

[@UseItemName_Fail]
#if
#act
sendmsg 7 装备改名失败！名称中包含系统禁用字符！！
break

[@UseItemName_OK]
#if
#act
gamegold - 1
sendmsg 7 装备改名成功！！！
break

;@UseItemName_OK 为改名成功触发，@UseItemName_Fail为改名失败触发


装备属性升级

装备升级

装备升级功能可以指定升级物品及属性，按指定机率得到结果。
需要升级的装备物品必须放在身上。

命令格式

UPGRADEITEMEX 物品位置(0-12) 属性位置(0-17) 成功机率(0-100) 点数机率(0-255) 是否破碎(0,1) 是否显示文字信息(0,1)

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 灵玉
18 时装衣服
19 时装武器
20 时装项链
21 时装头盔
22 时装左手镯
23 时装右手镯
24 时装左戒指
25 时装右戒指
26 时装勋章
27 时装腰带
28 时装靴子
29 时装宝石
30-35 首饰盒
40-51 生肖盒

属性位置:
不同类型的物品属性位置不一样，以后补充这些资料，自行可以进行测试得到。

成功机率:
升级成功机率，数字越大机率越小。

点数机率:
升级成功后得到的点数，数值在 0 -255之间。

是否破碎:
升级失败后装备是否破碎，数值为0或1，1为失败后破碎。

属性位置详解

重要注意事项，请在使用本功能前务必详细阅读，否则将有可能带来严重后果
当所需要升级的项链、手镯、戒指、在DB数据库中因 StdMode值的不同，而升级
出来得到的结果也不同，所以使用者请按照以下属性变化列表进行详细设置！
其中涉及的体力恢复、魔法恢复、毒物躲避、中毒恢复、如升级成功“1”点属性，则表示为 10%

项链属性：
当StdMode值为19时：属性位置“0”升级出来表现为“魔法躲避”、属性位置“1”升级出来属性表现为“幸运”
当StdMode值为20时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当StdMode值为21时：属性位置“0”升级出来表现为“体力恢复”、属性位置“1”升级出来属性表现为“魔法恢复”

手镯属性：
当StdMode值为24时：属性位置“0”升级出来表现为“准确”、属性位置“1”升级出来属性表现为“敏捷”
当StdMode值为26时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”

戒指属性：
当StdMode值为22时：属性位置“0”升级出来表现为“防御上限”、属性位置“1”升级出来属性表现为“魔御上限”
当StdMode值为23时：属性位置“0”升级出来表现为“毒物躲避”、属性位置“1”升级出来属性表现为“中毒恢复”

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久
15 刺术
16 箭术
17 武力

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久
15 刺术
16 箭术
17 武力

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久
15 刺术
16 箭术
17 武力

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久
15 刺术
16 箭术
17 武力

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久
15 刺术
16 箭术
17 武力

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久
15 刺术
16 箭术
17 武力

英雄装备升级

H.UPGRADEITEMEX 物品位置(0-12) 属性位置(0-17) 成功机率(0-100) 点数机率(0-255) 是否破碎(0,1) 是否显示文字信息(0,1)


装备投保功能

DB字段: InsuranceCurrency 保金类型 0元宝 1金币 2泡点 3金刚石 4灵符
DB字段:InsuranceGold 投保金额 设置大于0时 登陆器才会显示该装备是否已经投保

设置投保次数：
SETINSURANCECOUNTXX 位置 操作符(+，-，=) 数值

获取投保次数
GETINSURANCECOUNTXX 位置 变量

英雄设置投保次数：
H.SETINSURANCECOUNTXX 位置 操作符(+，-，=) 数值

英雄获取投保次数
H.GETINSURANCECOUNTXX 位置 变量

QF脚本触发投保装备掉落触发:
@DropInsuranceItem
@HeroDropInsuranceItem

相关常量：
OK框的常量 保金类型:<$BOXITEM[X].INSURANCECURRENCY> 投保次数：<$BOXITEM[X].INSURANCECOUNT> 投保金额：<$BOXITEM[X].INSURANCEGOLD>

变量：
投保物品名：$DROPINSURANCEITEMNAME
剩余投保数：$DROPINSURANCEITEMCOUNT
投保货币类型：$DROPINSURANCEITEMCURRENCY （StdItem.db)
单件投保单价： $DROPINSURANCEITEMGOLD （StdItem.db)


自定义OK框[!]

*******注意：如果您的QF内也使用了自定义OK框，那么NPC和QF内的OK框编号不要出现相同编号***************

<ITEMBOX:N:F:M:X:Y:W:H:S:T>\
N=编号(0~31)
F=OK框的背景的WIL序号，-1时不绘制背景
M=OK框的背景的图片序号
X Y = 微调坐标
W=宽度
H=高度
S=允许放入的物品类型。DB库的StdMode值，如果有多个使用“,”隔开，如果为“*”时，允许所有物品
T=未放入装备时，鼠标移动显示信息

<$BOXITEM[X].NAME> 当前自定义OK框中的物品名称
<$BOXITEM[X].NAME_G> 当前自定义OK框中的物品改名名称
<$BOXITEM[X].DURA> 当前自定义OK框中的物品持久
<$BOXITEM[X].DURAMAX> 当前自定义OK框中的物品最大持久
<$BOXITEM[X].MAKEINDEX> 当前自定义OK框中的物品序列号
<$BOXITEM[X].STDMODE> 当前自定义OK框中的物品StdMode字段值
<$BOXITEM[X].SHAPE> 当前自定义OK框中的物品Shape字段值
<$BOXITEM[X].LOOKS> 当前自定义OK框中的物品Looks字段值
<$BOXITEM[X].COLOR> 当前自定义OK框中的物品Color字段值
<$BOXITEM[X].UPGRADECOUNT> 当前自定义OK框中的物品星星数
<$BOXITEM[X].HP> 当前自定义OK框中的物品HP字段值
<$BOXITEM[X].MP> 当前自定义OK框中的物品MP字段值
<$BOXITEM[X].LAC> 当前自定义OK框中的物品的防御下限
<$BOXITEM[X].HAC> 当前自定义OK框中的物品的防御上限
<$BOXITEM[X].LMAC> 当前自定义OK框中的物品的魔防下限
<$BOXITEM[X].HMAC> 当前自定义OK框中的物品的魔防上限
<$BOXITEM[X].LDC> 当前自定义OK框中的物品的攻击下限
<$BOXITEM[X].HDC> 当前自定义OK框中的物品的攻击上限
<$BOXITEM[X].LMC> 当前自定义OK框中的物品的魔法下限
<$BOXITEM[X].HMC> 当前自定义OK框中的物品的魔法上限
<$BOXITEM[X].LSC> 当前自定义OK框中的物品的道术下限
<$BOXITEM[X].HSC> 当前自定义OK框中的物品的道术上限

.............. <$BOXITEM[X].Expand20> 支持数据库所有字段.............

PS:当基础属性字段为上述字段时为当前属性，数据库字段为数据库属性
<$BOXITEM[0].hdc> ;当前属性最高攻击
<$BOXITEM[0].dc2> ;数据库属性最高攻击
<$BOXITEM[0].XXX> ;数据库自定义字段XXX的数值(仅支持数字)

OK框触发编号X范围=0~31
;-------------------------------------------------------------------------------

[@main]
请放入需要升级的装备\
<ITEMBOX:0:2:117:20:10:76:76:10,11:254#只允许放入衣服^251#www.lfm2.com>\ \ \
<ITEMBOX:1:2:117:96:10:76:76:*:254#所有物品都允许放入^251#www.lfm2.com>\

UNALLOWITEMINTOBOX
禁止放入命令，在OK框里放入物品时触发使用

ReturnBoxItem (0~31)
OK框物品返回到包裹

CheckBoxItemCount OK框编号(0~31) 物品数量(该参数只有是叠加物品时才会有效)
检测OK框中是否有物品

DelBoxItem(0~31) 数量(数量只对叠加物品有效)
删除操作框物品

自定义OK框放入物品后在当前NPC脚本中触发，X值为0~31
[@ItemIntoBoxX]
#ACT
;禁止放入命令，可以检测是否可以升级的物品，可以使用此命令禁止放入
UNALLOWITEMINTOBOX

例:
[@main]
请放入需要升级的装备\
<ITEMBOX:0:2:117:20:10:76:76>\ \ \ \ \ \

<开始升级/@开始升级>\

[@开始升级]
#IF
;检测名称不等于空时OK框中有物品,也可以检测其他参数
NOT Equal <$BOXITEM[0].NAME>
#ACT
;关联到OK框物品 才可以使用脚本命令修改自定义OK框中的物品
SetUpgradeItem 0

;修改该OK框物品的名称颜色 boxitem0表示是OK框
CHANGEITEMNAMECOLOR boxitem0 253

;修改OK框物品星星数量 boxitem0表示是OK框
CHANGEITEMUPGRADECOUNT boxitem0 + 1

;修改OK框装备名称 boxitem0表示是自定义OK框第一个位置
ChangeItemName boxitem0 <$BOXITEM[0].NAME>+1

;修改OK框装备暴击+1 boxitem0表示是OK框第一个框
SetNewItemValue boxitem0 0 + 1

;刷新到客户端 (注意：刷新必须写对位置)
UpdateItem boxitem0

;物品返回到包裹
ReturnBoxItem 0
SENDMSG 6 装备升级成功
#ELSEACT
SENDMSG 6 请放入需要升级的装备

;自定义OK框新增命令:GiveBoxItem 0~31 数量(数量只对叠加物品有效) 将背包中指定物品放入指定OK框

#IF
checkitem 怒斩 1
#ACT
GiveBoxItem 0 怒斩
SendMsg 5 恭喜：OK框0成功放入怒斩！
----------------------------------------------------------------------------------------------

功能：通过唯一ID将物品放入OK框
命令：GIVEBOXITEMEX OK框编号 唯一ID

============================================================================================
GiveOnItem 装备位置 物品名称 数量默认写1(数量大于1时只对OK框叠加物品有效) 参数4 参数5 参数6 参数7 参数8 参数9

物品位置：
-1升级框
0--29：装备栏和时装栏
30-35：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框

参数4-参数9 参考 GIVE的扩展

----------------------------------------------------------------------------------------------

检测包裹中物品的数量(排除已经放入自定义OK框的物品)
CHECKBAGITEMCOUNTEX 物品名称 数量

增加触发：
将OK框的物品放回到包裹后，触发[@ItemOutBoxX],X值为0~31

*******注意：如果您的QF内也使用了自定义OK框，那么NPC和QF内的OK框编号不要出现相同编号***************


自定义UI中自定义按钮使用,预留按钮

自定义UI部分界面增加自定义按钮（预留按钮），自定义UI中开启后QF使用以下脚本来检测按钮编号 和使用

QF:

[@CustomButtonClick]
#act
SENDMSG 7 按钮点击编号为<$CustomButtonID>

#IF
equal <$CustomButtonID> 50
#ACT
SENDMSG 7 你触发了50编号的按钮
break

脚本命令：
ShowCustomButton 编号 显示/隐藏(0:隐藏， 1:显示）

预留编号:
主界面 （0-9）
背包 （20-24）
系统商铺 （40-42）
老行会 （30-32）
新行会 （50-52）
装备 （60-62）
时装 （70-71）
状态 （80-82）
属性 （90-92）
称号 （100-102）
技能 （110-112）
出战 （120-129）
神佑 （130-132）
首饰盒 （140-142）
内功状态 （300-302）
内功技能 （310-312）
内功经络 （3320-322）
内功连击 （330-332）
内挂界面 （340-342）
英雄头像 (400-402) 3个预留按钮
英雄背包 (410-414) 5个预留按钮
英雄装备 (420-422) 3个预留按钮
英雄时装 (430-432) 3个预留按钮
英雄状态 (440-442) 3个预留按钮
英雄属性 (450-452) 3个预留按钮
英雄称号 (460-462) 3个预留按钮
英雄技能 (470-472) 3个预留按钮
英雄神佑 (480-482) 3个预留按钮
英雄首饰盒 (490-492) 3个预留按钮
英雄内功状态 (500-502) 3个预留按钮
英雄内功技能 (510-512) 3个预留按钮
英雄内功经络 (520-522) 3个预留按钮
英雄内功连击 (530-532) 3个预留按钮
他人装备 (800-802)
他人时装 (810-812)
他人称号 (820-822)
他人神佑 (830-832)
他人首饰 (840-842)
宠物界面 (850-858)

点击他人装备按钮脚本：
[@CustomButtonClick]>
#IF>
equal <$CustomButtonID> 800
#ACT>
SENDMSG 7 你触发了他人装备栏自定义按钮1
SENDMSG 7 他人名称<$USERSTATENAME>
break>


自定义变量按变量值大小排序[!]

SortVarToList
功能：
自定义变量按变量值大小排序，并把排序后变量值对应的人物名存放到指定列表文件中(制作排行榜用)

格式：
SortVarToList 自定义变量名 自定义变量文件路径 排序后列表的保存路径 降序还是升序(0,1) 保存格式(0,1)为0时只保存人物名,为1时:人物名 变量值. 自定义变量文件是否绝对路径(0,1) 保存文件是否绝对路径(0,1)

例子：

[@test2]
#if
#act
SortVarToList LJSQZS .\QuestDiary\数据文件\Test.txt ..\QuestDiary\数据文件\排序的文件.txt 0 1
break


自定义变量功能

功能：
 自定义变量功能，不再受固定几个变量限制

使用方法：
三个步骤：
1、首先要声明变量
2、读取变量
3、保存变量
该变量支持增加、减少、脚本查看、检查大小等功能，该功能的开发突破了变量使用受限制，利用该变量可制作出超强功能脚本。
脚本样例：
=========================================
<声明变量/@newvarInteger> \
<查看变量/@viewvarInteger>\
<读取变量/@loadvarInteger> \
<保存变量/@savevarInteger> \
<增加变量/@calcvarinc> <检查变量是否大于5/@checklarage5>\
<减少变量/@calcvardec> <检查变量是否小于5/@checksmall5>\
<检查变量是否等于5/@checkequal5>
[@calcvarinc]
#IF
#ACT
CALCVAR HUMAN QQQQ + 5
goto @varcontrol
[@calcvardec]
#IF
#ACT
CALCVAR HUMAN QQQQ - 5
goto @varcontrol
[@checkequal5]
#IF
CHECKVAR HUMAN QQQQ = 5
#ACT
sendmsg 7 等于5
goto @varcontrol
#ELSEACT
sendmsg 7 不等于5
goto @varcontrol
[@checklarage5]
#IF
CHECKVAR HUMAN QQQQ > 5
#ACT
sendmsg 7 大于5
goto @varcontrol
#ELSEACT
sendmsg 7 小于5
goto @varcontrol
[@checksmall5]
#IF
CHECKVAR HUMAN QQQQ < 5
#ACT
sendmsg 7 小于5
goto @varcontrol
#ELSEACT
sendmsg 7 大于5
goto @varcontrol

[@decInteger]
#ACT
DEC QQQQ 1
sendmsg 7 <$HUMAN(QQQQ)>
goto @varcontrol
[@addInteger]
#ACT
INC QQQQ 1
sendmsg 7 <$HUMAN(QQQQ)>
goto @varcontrol
[@loadvarInteger]
#IF
#ACT
LOADVAR HUMAN QQQQ VarSave.txt
sendmsg 7 OK
GOTO @varcontrol

[@savevarInteger]
#IF
#ACT
SAVEVAR HUMAN QQQQ VarSave.txt
sendmsg 7 OK
GOTO @varcontrol
[@viewvarInteger]
#ACT
sendmsg 7 <$HUMAN(QQQQ)>
GOTO @varcontrol

[@newvarInteger]
#IF
#ACT
VAR Integer HUMAN QQQQ
sendmsg 7 OK
GOTO @varcontrol
[@viewvarString]
<$HUMAN(QQQS)>

------------- 行会变量

[@2]
#act
var integer guild 变量测试
calcvar guild 变量测试 = 100
dec <$guild(变量测试)> 10
savevar guild 变量测试 ..\QuestDiary\行会变量.txt


自动穿取装备

功能：
自动穿取装备。

格式：
 穿装备 TakeOnItem 装备名称 位置(0-12)
脱装备 TakeOffItem 位置(0-12)

;==========================================
物品位置:
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 灵玉
18 时装衣服
19 时装武器
20 时装项链
21 时装头盔
22 时装左手镯
23 时装右手镯
24 时装左戒指
25 时装右戒指
26 时装勋章
27 时装腰带
28 时装靴子
29 时装宝石
30-35 首饰盒
40-51 生肖盒
;==========================================

;==========================================
;穿装备
[@TakeOnItem]
#IF
#ACT
TakeOnItem 天魔神甲 0
#SAY
已经帮你穿上衣服了。
;==========================================

;==========================================
;脱装备
[@TakeOffItem]
#IF
#ACT
TakeOffItem 0
#SAY
已经帮你把衣服脱下来了。
;==========================================


自动穿装备和取装备

自动穿装备和取装备.新人出生就无需手动穿装备了.

例子:

;自动穿装备
AutoTakeOnItem 装备名称 位置(0-12)

;自动脱装备
AutoTakeOffItem 装备名称 位置(0-12)如不能正常脱请删除装备名字，只需位置即可

物品位置:
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 护身符
10 腰带
11 鞋子
12 宝石


自动行走

功能：
自动行走 AUTOGOTOXY 地图名称 X坐标 Y坐标

例子：

[@Test]
#IF
#ACT
AUTOGOTOXY 3 330 330


自动替换装备

背包物品自动穿戴命令:

;======================================================

开启命令 OpenAutoUsePickItem 、 H.OpenAutoUsePickItem
关闭命令 CloseAutoUsePickItem 、 H.CloseAutoUsePickItem

格式：
开启命令 OpenAutoUsePickItem 参数1 参数2 参数3 参数4
参数1 ：为0或空时静默替换。参数为1时则提示替换
参数2 ： 有效时间 1-65535分钟 0或空不限制时间
参数3： 替换对话框倒计时时间（如果填0，建议直接用静默的方式）
参数4： 0或空自动替换，1为不替换，到时间直接关闭提示窗口

例子：

[@人物自动替换装备]
#IF
#ACT
OpenAutoUsePickItem 1 60 5
sendmsg 6 人物开启了提示替换，有效时间60分钟,5秒自动替换

[@英雄自动替换装备]
#IF
#ACT
H.OpenAutoUsePickItem 0
sendmsg 6 英雄开启静默替换，当背包出现比佩戴属性更好的装备则静默自动替换

[@关闭人物自动换装]
#ACT
CloseAutoUsePickItem
sendmsg 6 关闭了人物自动换装

[@关闭英雄自动换装]
#ACT
H.CloseAutoUsePickItem
sendmsg 6 关闭了英雄自动换装

在背包物品比身上佩戴物品属性更高时候自动替换装备，对比条件：引擎-选项-客户端控制-装备信息 页面中“背包对比选项功能”设置对比条件！


字符串分隔命令

字符串切割命令:

;======================================================

命令 分割符号 分割内容 保存变量 (自动填写数字编号)

[@aaa]
#IF
#ACT
; 分隔字符串后，按顺序往S11及以后放
ExtractStringEx | aaa|bbb|ccc|ddd|000 S11
SendMsg 6 <$STR(S11)>,<$STR(S12)>,<$STR(S13)>,<$STR(S14)>,<$STR(S15)>

; 分隔字符串后，依次放自定义变量1，2，3，4及以后放
ExtractStringEx | aaa|bbb|ccc|ddd|000 S$拆分
SendMsg 4 <$STR(S$拆分1)>,<$STR(S$拆分2)>,<$STR(S$拆分3)>,<$STR(S$拆分4)>,<$STR(S$拆分5)>

;======================================================

特别说明：当参数是变量的不支持嵌套

这样不支持，如下：
GetDBItemFieldValue <$STR(S$奖励内容<$str(p1)>)> idx N$签到奖励<$str(p1)>

正确应该这样：
mov s1 N$签到奖励<$str(p1)>
GetDBItemFieldValue <$STR(S$奖励内容<$str(p1)>)> idx s1
得到的idx还是存到s1中，而不是N$签到奖励1中

正确可以参考以下示范：

#if
#act
MOV S$奖励内容 麻痹戒指,圣战戒指,裁决之杖,屠龙
ExtractStringEx , <$STR(S$奖励内容)> S$奖励内容
MOV P1 1
WHILE P1 < 3
mov s1 N$签到奖励<$str(p1)>
GetDBItemFieldValue <$STR(S$奖励内容<$str(p1)>)> idx s1
sendmsg 6 嵌套的变量获取<$STR(S$奖励内容<$str(p1)>)>IDX<$STR(s1)>
INC P1 1
ENDWHILE


字符串分隔命令

;======================================================
;下列为读取一套装备数据配合GetRandomText使用

#IF
gender man
checkjob warrior
#ACT
GetRandomText ..\QuestDiary\装备列表.txt S0 0
EXTRACTSTRING : <$STR(S0)> s1 s2 s3 s4 s5 s6 s7 s8
GIVE <$STR(S1)> 1
GIVE <$STR(S2)> 1
GIVE <$STR(S3)> 1
GIVE <$STR(S4)> 1
GIVE <$STR(S5)> 1
GIVE <$STR(S6)> 1
GIVE <$STR(S7)> 1
GIVE <$STR(S8)> 1
TakeOn <$STR(S1)> 0
TakeOn <$STR(S2)> 1
TakeOn <$STR(S3)> 3
TakeOn <$STR(S4)> 4
TakeOn <$STR(S5)> 5
TakeOn <$STR(S6)> 6
TakeOn <$STR(S7)> 7
TakeOn <$STR(S8)> 8
BREAK
;======================================================
;装备列表.txt 内容

;战神盔甲(男):裁决之杖:绿色项链:黑铁头盔:骑士手镯:骑士手镯:力量戒指:力量戒指
;战神盔甲(女):裁决之杖:绿色项链:黑铁头盔:骑士手镯:骑士手镯:力量戒指:力量戒指
;魔法长袍(男):血饮:恶魔铃铛:道士头盔:龙之手镯:龙之手镯:紫碧螺:紫碧螺
;魔法长袍(女):血饮:恶魔铃铛:道士头盔:龙之手镯:龙之手镯:紫碧螺:紫碧螺
;灵魂战衣(男):无极棍:灵魂项链:道士头盔:三眼手镯:三眼手镯:泰坦戒指:泰坦戒指
;灵魂战衣(女):无极棍:灵魂项链:道士头盔:三眼手镯:三眼手镯:泰坦戒指:泰坦戒指

;======================================================
;写变量可配合inc实现写入数据
#act
inc S0 <$DRESS>
inc S0 :
inc S0 <$WEAPON>
inc S0 :
inc S0 <$HELMET>
;.........后面的自己写
;======================================================

注：是字符串为空的时候才出现报错 引擎报错要延时两秒 应该是卡了一下，处理方式：就是字串空的时候 m2会报错 功能正常 字串空时中止执行就OK了

;======================================================

扩展支持自定义变量并支持自动填写数字编号

[@aaa]
#IF
#ACT
; 分隔字符串后，按顺序往S11及以后放
ExtractStringEx | aaa|bbb|ccc|ddd|000 S11
SendMsg 6 <$STR(S11)>,<$STR(S12)>,<$STR(S13)>,<$STR(S14)>,<$STR(S15)>

; 分隔字符串后，依次放自定义变量1，2，3，4及以后放
ExtractStringEx | aaa|bbb|ccc|ddd|000 S$拆分
SendMsg 4 <$STR(S$拆分1)>,<$STR(S$拆分2)>,<$STR(S$拆分3)>,<$STR(S$拆分4)>,<$STR(S$拆分5)>


字符检测命令GetStringPosEX

功能：
字符检测命令GetStringPosEX。

格式：
GetStringPosEX A B C D E F
参数A：文件路径
参数B：检测字符(支持变量、支持大小写字母、支持数字)
参数C：N1返回检测的字符所在的行数(N变量不是固定，可以更换其它数字型变量)
参数D：S1返回检测的字符所在的行数(S变量不是固定，可以更换其它字符型变量)
参数E：是否绝对路径(0:相对路径 1:绝对路径)两种模式
参数F：匹配模式(0或空:包含匹配; 1:完全匹配)

命令作用：检测参数B字符，是否在指定文本中包含。
命令作用：如果包含则返回字符所在文本中的行数到参数C变量，本行所有内容返回到参数D变量。

例如：
#IF
GetStringPosEX ..\QuestDiary\测试.txt 管理员1号 N1 S1 0
#ACT
SendMsg 5 字符在文本中的行数:<$STR(N0)>，本行所有内容是:<$STR(S1)>。
#ELSEACT
SendMsg 5 字符不在测试.txt文本中。

测试.txt
---------------------------------------
管理员1号|奖励100元宝|奖励1000金刚石
管理员2号|奖励200元宝|奖励2000金刚石
管理员3号|奖励300元宝|奖励3000金刚石

示范2：
[@GetStringPosEx]
;GetStringPosEX 文件路径 包含字符串 行数变量 文本变量 是否绝对路径
#if
GetStringPosEX ..\QuestDiary\111.txt aabb N1 S1 0
#act
sendmsg 6 字符在文本中的行数:<$STR(N1)>，本行所有内容是:<$STR(S1)>。

;==========================================

带缓存的字符检测命令：
CacheGetStringPosEx；命令格式同上


宝宝立即叛变

功能: 指定宝宝立即叛变的脚本命令
格式: GetCallMob 宝宝名字

#act
GETCALLMOB 神兽
#say
你的神兽已经叛变

;==================2020-09-28更新扩展如下===============================

GetCallMob命令扩展(默认命令只叛变一个宝宝)
功能: 指定宝宝立即叛变的脚本命令
格式: GetCallMob 宝宝名字

扩展为
GetCallMob 宝宝名字 数量 (0为所有相同名字宝宝都叛变 1为只叛变一个.2为叛变2个 其它类堆) 分身是否保留(0:不保留收回分身/1:保留分身叛变)
GetCallMob 无参数形式 所有的宝宝立即叛变(分身收回)

#IF
CheckSlaveCount > 0 <$UserName> 1
#ACT
GetCallMob <$USERNAME> 1 1
sendmsg 6 分身叛变啦
#elseact
SENDMSG 5 你没有分身

宝宝叛变默认情况下会收回分身，如果需要叛变分身需要用人物名字 <$USERNAME>


不允许宝石升级

功能: 当前宝石升级装备失败
格式: SetUpgradeFail
说明: 此命令只能在QFunction中的@ItemUpgrade下执行.

[@ItemUpgrade]
#IF
CheckGold 5000
#ACT
Take 金币 5000
#ELSESAY
升级装备需要5000金币.
#ELSEACT
SetUpgradeFail
Break


查看动态地图链接点

说明: 查看使用AddMapRoute设置的动态链接点.
格式: GetMapRouteInfo 链接标示 查看方式(0-1) 坐标X 坐标Y

例子: 查看地图链接点
[@ViewRoute]
#IF
#ACT
;查看链接坐标,参数2等于0查看连接地图,等于1查看待连接地图.
GetMapRouteInfo 1 0 A0 G0 G1
GetMapRouteInfo 1 1 A1 G2 G3
SendMsg 5 [地图<$STR(A0)>坐标:<$STR(G0)>:<$STR(G1)>]->[地图<$STR(A1)>坐标:<$STR(G2)>:<$STR(G3)>]


拆解物品

功能: 可简单实现物品拆解,升级,回收等功能.
格式: OpenItemBoxEx 标号(1-1000) 是否回收(0,1) 提示信息
说明: 标号代表要执行的脚本编号,提示信息是登录器显示的简单提示.
      放入的物品名字保存在人物的S0变量中.
      放入的物品的持久放在人物的N0变量中.
注意: 脚本文件头必须加入@ReclaimItem
      N0中保存的持久1000=游戏中1点持久,20000=20点持久.

相关检测脚本命令:EQUAL  CheckTextList
例如:实现装备拆解功能.

(@ReclaimItem )
[@main]
是否要把圣战戒指拆解为3个力量戒指.\
是否要把天尊戒指拆解为3个泰坦戒指.\
是否要把法神戒指拆解为3个紫碧螺戒指.\
<开始拆解/@拆解_戒指>

[@拆解_戒指]
#IF
#ACT
OpenItemBoxEx 1 1 拆解戒指类物品

Q-Function.txt中脚本:
[@GetBoxItem1]
#IF
EQUAL S0 圣战戒指
#ACT
Give 力量戒指 3
Break

#IF
EQUAL S0 天尊戒指
#ACT
Give 泰坦戒指 3
Break

#IF
EQUAL S0 法神戒指
#ACT
Give 紫碧螺 3
#ELSEACT
ReclaimItem
#ELSESAY
请放入<圣战戒指> <天尊戒指> <法神戒指>


穿人模式

功能: 改变当前人物的穿人,穿怪模式.
格式: THROUGHHUM 模式 时间(秒)
模式: [-1=恢复/0=穿人穿怪/1=穿怪/2=穿人]

#IF
#ACT
ThroughHum 1 60
SendMsg 5 60秒之内可随意穿怪.


创建目录

功能: 创建新目录.
格式: ForceDirectories 目录

#IF
#ACT
ForceDirectories \QuestDiary\新目录\


打开网站地址

功能: 游戏中打开网站.
格式: OpenWebSite 网站

#IF
#ACT
OpenWebSite http://www.lfm2.com


打开游戏商铺

功能: 打开游戏中商铺窗口.
命令: OPENGAMESHOP
列:
#IF
#ACT
OPENGAMESHOP
Break


地图随机物品

使用方法: Envri\UserData\MapItems.txt
使用说明: 添加的物品可自动出现在指定地图的指定范围内.

添加格式: 物品名称 出现地图 坐标X:坐标Y 几率:范围:时间:数量
几率说明: 物品几率大于100时设置多少就是多少分之一的出现率,例如1000就是1/1000的可能.100以内设置每减一几率降低一点.例如80就是80%的可能,50就是50%的可能.

例如: 在盟重省330:330范围10以内每过2分钟有50%的可能出现5个传送戒指
传送戒指 3 330:330 50:10:2:5


动态修改地图名字

功能: 动态修改地图显示名字.
格式: ChangeMapDesc 新名字 是否保存(0,1)
说明: 直接修改MapInfo.txt中对应地图的显示名字.

例子: 修改盟重省的名字,并且保存.
#IF
#ACT
ChangeMapDesc 新盟重 1


读取文本内容到变量[!]

功能: 读取文本文件中的内容到变量中.

格式:GetListString 文件路径 行号(行号从0开始) 变量1 变量2 是否绝对路径(0,1)
说明: 变量2可以不需要,当读取变量2时文本单行的内容必须是以下格式:
人物1:10
人物2:20

例子:
[@main]
#IF
#ACT
GetListString ..\QuestDiary\测试.txt 5 A10 N10


改变人物的模式

改变人物当前模式(无敌,隐身,生命,魔法,攻击力,道术力,魔法力,攻击速度,禁止攻击)

格式: ChangeModeEx 模式(1-10)  时间(1-65535)  附加值(1-21E)
说明: 1=无敌 2=隐身 3=HP  4=MP  5=攻击力 6=魔法力 7=道术力 8=攻击速度 9=禁止攻击 10=锁定 11=护身 12=防麻痹 13=破复活 14=传送
       第三个参数无敌,隐身,禁止攻击时没有使用.

模式为11时，第三个参数为护身掉蓝比例(参数3设置100 表示遭遇攻击护身吸收所有伤害，设置50则只吸收一半)
模式为12时，第三个参数为防御麻痹几率(参数3设置100 表示100%防御麻痹，设置50则为50%防御麻痹)
模式为13时，第三个参数为破复活几率(参数3设置100 表示100%破复活，设置50则为50%几率破复活)

#IF
#ACT
ChangeModeEx 1 60
#SAY
给你1分钟的无敌时间,好好利用哦!

#IF
#ACT
ChangeModeEx 5 60 20
#SAY
60秒之内攻击力增加20点.

提示：改变英雄当前模式命令为：H.ChangeModeEx

注：ChangeModeEx支持多级脚本


改变物品的持久

功能: 修改指定位置装备的当前持久和最大持久.
格式: ChangeItemDura 装备位置(0-12) 操作符(+,-,=) 持久(0-65000) 是否修改最大持久 (0或空为当前持久。1为修改最大持久)

#IF
#ACT
ChangeItemDura 0 - 1000
#SAY
你的物品当前持久降低1点.

#IF
#ACT
ChangeItemDura 0 + 1000 1
#SAY
你的物品最大持久增加1点.


改变衣服翅膀效果

改变人物衣服翅膀效果
说明:客户端需要有HumEffect.wil

#IF
#ACT
ChangeDressEffect 3

关闭此命令增加的特效方式如下：

#IF
#ACT
ChangeDressEffect 0

ChangeDressEffect 特效编号 绘制方式(留空或0:特效绘制；1:普通绘制)

翅膀算法和扩展的算法一致


改变用户模式

功能：
增加脚本命令ChangeModeEx
改变人物当前模式(无敌,隐身,生命,魔法,攻击力,魔法力,道术力,攻击速度,禁止攻击)

格式: ChangeModeEx 模式(1-10) 时间(1-65535) 附加值(1-21e)
说明: 1=无敌 2=隐身 3=HP 4=MP 5=攻击力 6=魔法力 7=道术力 8=攻击速度 9=禁止攻击 10=锁定 11=护身 12=防麻痹 13=破复活 14=传送
第三个参数无敌,隐身,禁止攻击时没有使用.
模式为11时，第三个参数为护身掉蓝比例(参数3设置100 表示遭遇攻击护身吸收所有伤害，设置50则只吸收一半)
模式为12时，第三个参数为防御麻痹几率(参数3设置100 表示100%防御麻痹，设置50则为50%防御麻痹)
模式为13时，第三个参数为破复活几率(参数3设置100 表示100%破复活，设置50则为50%几率破复活)

例子：

[@Test]
#IF
#ACT
ChangeModeEx 1 60
#SAY
给你1分钟的无敌时间,好好利用哦!

#IF
#ACT
ChangeModeEx 5 60 20
#SAY
60秒之内攻击力增加20点.

提示：改变英雄当前模式命令为：H.ChangeModeEx

修改ChangeModeEx 命令支持用时间来解除

比如锁定 人物被锁定60秒，如果再次使用锁定10秒的脚本则按最后次附加的时间为准，那么就是10秒锁定倒计时，如果设置1则表示1秒后解除，设置0就是立即解除状态！！！！

如：
changemodeex 10 10 ;锁定玩家10秒
如果想用下面这个命令来解除锁定
changemodeex 10 0
无效，而且M2会提示错误，参数2不允许为0

注：ChangeModeEx支持多级脚本


改变指定行会的掌门人

改变行会掌门人

[@changeguildmaster]
#IF
#ACT
ChangeGuildMaster 华山派
#SAY
贡献,你现在是华山派掌门人了.


给予带绑定状态装备[!]

功能：
给予带绑定状态装备。主要方便设置不能配带的装备绑定状态

格式：

格式:GiveStateItem 装备位置(-1~13,-1时为OK框中物品)
GiveStateItem 物品名称 项目1 项目2 项目3 项目4 项目5 项目6(0为正常,1为绑定)

;项目1--禁止扔，项目2--禁止交易，项目3--禁止存，项目4--禁止修，项目5--禁止出售,项目6--禁止爆出的装备 项目7--丢弃消失

[@给一个绑定的装备]
#ACT
GiveStateItem 木剑 1 0 0 0 0 0
SENDMSG 6 给你一个绑定木剑并且禁止扔


给字符串增加空格

功能： 给字符串在前面或者后面增加指定个数的空格.

格式: SetStringBlank 变量(S,A) 长度(1-100) 格式(0, 1)?
说明: 可支持人物S变量或者全局A变量,格式0=前面,1=后面
注意: 第二个参数长度是指增加空格后整个字符串的长度,例如字符串MirYQ引擎长度是9,
如果第二个参数设置1 那么实际增加6个空格.
注意: 英文字母和数字占用1个字节(长度),汉字占用2个字节(长度).

例子：

[@Test]
#IF
#ACT
MOV S10 MirYQ引擎
SetStringBlank <$STR(S10)> 15 0
SendMsg 5 <$STR(S10)>

MOV S10 MirYQ引擎
SetStringBlank <$STR(S10)> 15 1
SendMsg 5 <$STR(S10)>


关闭大对话框模式

功能: 关闭大对话框模式. (专用登录器)
格式: CloseBigDialogBox

#IF
#ACT
CloseBigDialogBox


获取玩家名字

功能:
取得玩家名字.

格式:
GetUserName 0-99之间的数字,或者范围是0-99之间的数值型变量.
如下将玩家名字放入S10中

#IF
#ACT
GetUserName 10


建立新行会

增加一个新的行会.可以指定某人成为该行会掌门(必须在线)

说明: 第二个参数等于Self时掌门是自己.否则是在线玩家.

[@AddGuild]
#IF
#ACT
AddGuild 华山派 Self


建立一个文本文件

在指定位置建立一个文本文件.

注意:文件保存在 \Envir目录中.

#IF
#ACT
CreateFile ..\QuestDiary\NewFile.txt
#SAY
在Envir\QuestDiary目录中建立了一个文件.


禁言、恢复发言

恢复人物发言.（脚本中 Shutup 和 ReleaseShutup 为引擎GM解除禁言命令，请修改为您引擎设置的命令）

[@禁言]
#IF
#ACT
Gmexecute Shutup Self 888888
SendMsg 5 您被禁言了.
break

[@解除禁言]
#IF
#ACT
Gmexecute ReleaseShutup Self
SendMsg 5 您可以正常聊天了.


排序人物自定义变量[!]

功能: 排序人物自定义变量.
格式: SortHumVarToListEx 变量名 变量路径 排序模式(0,1) 保存路径 保存模式(0,1) 变量文件是否绝对路径(0,1) 保存文件是否绝对路径(0,1)
说明: 排序模式 0=升序,1=降序

升序排序人物变量QQQQ:
[@main]
#IF
#ACT
SortHumVarToListEx QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试A.txt 0

升序排序人物变量QQQQ,不保存人物变量:
[@main]
#IF
#ACT
SortHumVarToListEx QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试A.txt 1


排序在线人物自定义变量[!]

功能: 排序在线人物自定义变量.
格式: SortHumVarToList 变量类型(HUMAN,GUILD,GLOBAL) 变量名 保存路径 排序模式(0,1) 名字路径
说明: 排序模式 0=升序,1=降序
      名字路径在排序后只保存人物名字不保存人物变量.
注意: 此脚本命令只排序在线人物的变量

升序排序人物变量QQQQ:
[@main]
#IF
#ACT
SortHumVarToList HUMAN QQQQ ..\QuestDiary\测试.txt 0

升序排序人物变量QQQQ,单独保存人物名字:
[@main]
#IF
#ACT
SortHumVarToList HUMAN QQQQ ..\QuestDiary\测试.txt 0 ..\QuestDiary\测试1.txt


屏幕中间显示公告

功能: 在专用登录器屏幕的中间显示公告.
格式: SendCenterMsg 前景色 背景色 消息文字 模式 显示时间 倒计时标签 是否替换模式（0或空为不替换，不等于0为替换模式) X坐标
模式: 0=发送给自己 1=发送所有人物 2=发送行会 3=发送国家 4=发送当前地图.
说明: 设置倒计时标签时可执行自定义脚本功能.

例子:
[@main]
#IF
#ACT
SendCenterMsg 180 251 这是一个居中显示的公告. 0

例子:显示30秒.
[@main]
#IF
#ACT
SendCenterMsg 180 251 这是一个居中显示的公告. 0 30

;以下功能需要2009-01之后的M2支持.
执行倒计时标签(注意:文字提示中必须包含%d):
[@main]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d发放新手奖励. 0 30 @GiveNewHumanItem

QFunction中:
[@GiveNewHumanItem]
#IF
#ACT
Give 金条 1
Give 裁决之杖 1
Give 圣战戒指 2
Give 圣战手镯 2
Give 圣战头盔 1
Give 圣战项链 1
Give 天魔神甲 1

例子:替换模式
替换模式只在有倒计时标签时有效.

;以下例子说明如何使倒计时从新开始.
[@main]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d离开本地图. 0 600 @ExitMap 1

;执行替换模式使时间从新开始
[@main1]
#IF
#ACT
SendCenterMsg 180 251 还剩余%d离开本地图. 5 600 @ExitMap 1

SendCenterMsg 180 251 这是一个居中显示的{<$USERNAME>|250:0}公告. 0
SendCenterMsg 180 251 图片数字测试看看效果


强制攻击模式

功能: 强制人物的攻击模式
格式: SetHumAttackMode 攻击模式(0-7) 时间(秒) 地图号(*为任何地图)
说明: 0=全体模式 1=和平模式

例子: 强制人物和平模式
#IF
CheckPkPoint 2
#ACT
SetHumAttackMode 1 3600
sendmsg 6 强制和平攻击模式3600秒！

#IF
CheckPkPoint 2
#ACT
SetHumAttackMode 1 3600 3
sendmsg 6 你在土城被强制和平攻击模式3600秒！

#IF
CheckPkPoint 2
#ACT
SetHumAttackMode 1 3600 *
sendmsg 6 你在所有地图被强制和平攻击模式3600秒！


清除宝石升级属性

功能: 清除使用宝石升级的装备属性.
格式: ClearStoneUpgrade 位置(0-14)
注意: 此命令不区分极品和普通装备,清除时所有属性都将消失.

例子:
[@main]
#IF
#ACT
ClearStoneUpgrade 0


取得随机字符串

功能: 从文件中随机获取一行字符串
格式: GetRandomText 文件路径 变量(S0--S99) 指定行(1-10000)
说明: 没有指定行时随机取某一行的字符串.
      变量可以是S0--S99或者A0--A499

例如:随机取一行字符串到S10中.
[@Main]
#IF
#ACT
GetRandomText ..\QuestDiary\测试.txt S10
SendMsg 5 取出的字符串是:<$STR(S10)>

例如:取特定行的字符串.
[@Main]
#IF
#ACT
GetRandomText ..\QuestDiary\测试.txt S10 5
SendMsg 5 取出的字符串是:<$STR(S10)>


取下人物身上装备

把人物身上装备放入背包中.

格式: TakeEx (0-51)

#IF
#ACT
TakeEx 1


取装备名字

取指定位置的装备名字
格式: GetUserItemName 位置(0-12) S变量(0-99) 参数3是否只取DB中的名称(0:若改名以改名为准； 1：只取DB中的名称）
说明: S变量是人物私有变量(0-99) 参数3是否只取DB中的名称(0:若改名以改名为准； 1：只取DB中的名称）

例子: 把武器的名字放如S10变量中

#IF
#ACT
GetUserItemName 1 10
SendMsg 5 武器的名字: <$STR(S10)>


取字符串在列表中的位置

功能: 取字符串在列表中的下标.
格式: GetStringPos 路径 字符串 是否绝对路径(0,1)
说明: 返回值放在人物的N0变量中,如果值=9999999说明没有找到.
其他: 返回值可以通过EQUAL做条件检测

[@main]
#IF
#ACT
GetStringPos .\QuestDiary\测试.txt 管理员
SendMsg 5 字符串在列表中的位置:<$STR(N0)>


人物聊天文字变色

功能: 改变人物公聊时的文字信息颜色.
格式: ChangeHearMsgColor 时间(分钟) 颜色(0-255)

;人物说话信息蓝色显示
[@main]
#IF
#ACT
ChangeHearMsgColor 10 180


杀死地图中的怪物

功能: 随机杀死地图中的怪物.
格式: RandomKillMon 地图 怪物名字 数量(1-255) 掉落物品(0,1)
说明: 地图=Self时表示当前地图.

例子:
[@main]
#IF
#ACT
RandomKillMon Self 稻草人 5

注：设置空或者0为杀死怪物掉落物品，，设置1为不爆！


杀死人物的宝宝

说明:把自己的宝宝杀死.
格式:KillCallMob 名字 数量 是否清尸体（0或空:不清; 1:清）

#IF
#ACT
KILLCALLMOB 神兽
#SAY
你的神兽已经死亡.

#IF
#ACT
KILLCALLMOB 白野猪 2


删除地图动态链接点

功能: 删除使用AddMapRoute设置的地图链接点.
格式: DelMapRoute 动态链接标示(1-65535)

例子: 删除链接表示等于1的链接点.
#IF
#ACT
DelMapRoute 1


设置人物伤害吸收

说明:设置人物可吸收收到的攻击伤害.

格式: SetSuckDamage 操作符(+ - =) 总吸收值(1-2000000000) 吸收比例(1-1000) 成功率(1-100)
      吸收比例 1=0.1% 500=50% 1000=100%

例子: 设置总共吸收1000点伤害,每次吸收20%伤害,成功率95%
#IF
CheckGold 10000
#ACT
SetSuckDamage + 1000 200 95
Take 金币 10000

特别说明:当人物设置伤害吸收后,收到攻击后会按照一定比例减少受到的伤害.
例如:当前拥有5000点伤害吸收,每次吸收20%,成功率100%.当前攻击受到100点伤害,那么本次攻击实际受到的伤害是80点.当前伤害吸收剩余4980点,此状态直到伤害吸收等于0时恢复,下线不保存.

总吸收值设置为 -1时 无限数值(必须用等于号，不可以加减)

[@77]
#ACT
SetSuckDamage = -1 800 100

伤害吸收值变量：<$SUCKDAMAGE>


设置人物商铺购买价格比例

功能: 设置人物商铺购买物品的价格比例.
格式: SetShopItemPriceRate 比例(1-100)
注意: 人物下线后状态消失.
其他: 列表信息中可设置单个物品是否允许打折购买.

例如:大于100级人物商铺购买物品的价格比例是90%,人物上线时在登录脚本设置价格比例即可.

[@Login]
#IF
CheckLevelEx > 99
#ACT
SetShopItemPriceRate 90


设置英雄伤害吸收

说明:设置英雄可吸收收到的攻击伤害.

格式: SetHeroSuckDamage 操作符(+ - =) 总吸收直(1-2000000) 吸收比例(1-1000) 成功率(1-100)
      吸收比例 1=0.1% 500=50% 1000=100%

例子: 设置总共吸收1000点伤害,每次吸收20%伤害,成功率95%
#IF
CheckGold 10000

#ACT
SetHeroSuckDamage + 1000 200 95
Take 金币 10000

总吸收值设置为 -1时 无限数值(必须用等于号，不可以加减)

[@77]
#ACT
H.SetSuckDamage = -1 800 100

特别说明:查看SetSuckDamage


设置装备绑定状态[!]

功能：设置装备绑定状态。
格式：SetItemState 装备位置(-1~13,-1时为OK框中物品) 项目(0-5) 属性(0为正常,1为绑定)
项目: 0 禁止扔 1 禁止交易 2 禁止存 3 禁止修 4 禁止出售 5 禁止爆出 6 丢弃消失 7 禁止取下

 [@检测绑定]
#IF
CheckItemState 0 0
#ACT
SENDMSG 6 该装备已经设置过禁止扔
#ELSEACT
SENDMSG 6 没有绑定禁止扔掉

[@设置禁止扔]
#IF
CheckItemState 0 0
#ACT
SENDMSG 6 该装备已经设置过禁止扔
#ELSEACT
SetItemState 0 0 1
SENDMSG 6 该装备禁止扔

[@禁止取下]
#IF
CheckItemState 1 7
#ACT
SENDMSG 6 该装备已经设置过取下
#ELSEACT
SetItemState 1 7 1
SENDMSG 6 该装备禁止取下


设置装备发光

功能: 设置装备发光
说明: 衣服,武器和头盔不支持次功能.
适用: 英雄M2
格式: SetItemsLight 位置(0-12) 值(1=发光效果1 2=发光效果2 0=不发光).
其他: 选择效果点击 M2\选项\功能设置\内挂控制

发光效果1:
#IF
#ACT
SetItemsLight 3 1

发光效果2:
#IF
#ACT
SetItemsLight 3 2

取消发光:
#IF
#ACT
SetItemsLight 3 0

1.首饰放光的效果1-14
2.扩展文件为首饰发光专用：headgearEffect.wzl headgearEffect2.wzl 读取为每20张图片为一组 分别读取代码为100-199 200-299
headgearEffect3.wzl 读取代码300-399 headgearEffect4.wzl 读取代码400-499 headgearEffect5.wzl 读取代码500-599 headgearEffect6.wzl 读取代码 600-699


收回人物的英雄

功能: 收回人物的英雄.
格式: TakeHero

[@main]
#IF
CheckHeroOnline
#ACT
TakeHero

======================== 两种命令大家自己测试哪个可用===================================

功能: 收回人物的英雄.
格式: HeroLoginOut

[@main]
#IF
CheckHeroOnline
#ACT
HeroLoginOut


随机验证码

命令：setrandomno 参数(0或空:全数字;1:数字+小写字母;2:数字+大写字母;3:数字+小写字母+大写字母）

随机输入验证码

[@Main]
#If
CheckLevelEx > 0
#Act
SetRandomNo
#Say
<输入验证码/@@CheckNo>:<$RANDOMNO>

[@@CheckNo]
#If
CheckRandomNo
#SAY
输入正确.
#ELSESAY
输入不正确.


特修身上装备

在物品规则列表中限制物品的不会被修理

#IF
CHECKREPAIRALLGOLD <$STR(N99)>
#ACT
take 金币 <$STR(N99)>
RepairAll
#SAY
你的装备修好了.
#ELSESAY
你是不是没有钱啊.修理需要<$STR(N99)>金币


调整英雄的PK值[!]

增加英雄PK值

#IF
CheckHeroOnline
#ACT
ChangeHeroPkPoint + 100
#SAY
你英雄的PK值增加100点.

减少英雄PK值

#IF
CheckHeroOnline
#ACT
ChangeHeroPkPoint - 100
#SAY
你英雄的PK值减少100点.

调整英雄PK值

#IF
CheckHeroOnline
#ACT
ChangeHeroPkPoint = 100
#SAY
你英雄的PK值等于0点.

;英雄PK值脚本变量查看：英雄当前PK值：<$HEROPKPOINT>


调整英雄的忠诚度

格式: ChangeHeroLoyal 操作符(+ - =) 数值(0 -- 10000)
注意: 第二个参数+1那么英雄增加0.01点忠诚+100那么英雄增加1点忠诚

例子: 增加英雄1点忠诚
#IF
CHECKHEROONLINE
#ACT
ChangeHeroLoyal + 100
SendMsg 5 您的英雄忠诚度增加[1]

功能: 检测英雄当前的忠诚度
格式: CheckHeroLoyal 操作符(< = >) 数值(0 -- 100)

例子:
#IF
CHECKHEROONLINE
CheckHeroLoyal > 50
#ACT
SendMsg 5 您的英雄忠诚度大于50%.


调整英雄等级[!]

调整人物英雄等级.

ChangeHeroLevel 操作符(+ - =) 级别(1-65535)

#IF
CheckHeroOnline
#ACT
ChangeHeroLevel = 50
#SAY
你的英雄50级了.


调整英雄职业

格式: ChangeHeroJob 职业(0,1,2)

#IF
CheckHeroOnline
#ACT
ChangeHeroJob 2
#SAY
你英雄现在的职业是道士.


物品合成系统

M2: 查看->列表信息->其他设置->合成系统

.

使用说明: 以合成逆火麻痹戒为例:
首先在物品列表中找到逆火麻痹戒,然后点击下面的添加按钮将逆火麻痹戒添加到物品列表中.
接着在左边的物品列表中点击逆火麻痹戒,右边的所需物品列表中的添加按钮处于激活状态后就可以添加合成逆火麻痹戒需要的
材料和装备了.(目前除了StdItems.DB中的物品外还可以直接支持 金币 元宝 声望 能量点) 图中合成逆火麻痹戒需要寒铁5块
声望10点 麻痹戒指1个.添加完成之后点保存按钮即可.

特别说明: 成功几率=100时合成物品必定成功,99=99%90=90%1=1%的成功率.如果需要更低的成功率那么设置大于100即可,这时设置多少就是多少分之一的成功率例如1000=1/1000的成功率.当合成物品有成功率时,失败消失=1时 如果物品合成失败那么
此物品将会消失,失败消失=0时物品不会消失(另外物品合成成功之后所有所需物品都会消失).

脚本说明: CheckFoundryItem 检测背包中合成物品的材料是否足够 GiveFoundryItem 回收合成材料同时将合成后的物品放入背包.
合成失败后自动执行@FoundryFail段的脚本.合成失败后自动执行@FoundryOK段的脚本

合成逆火麻痹戒脚本如下:
[@Main]
<合成逆火麻痹/@逆火>\

[@逆火]
#IF
CheckFoundryItem 逆火麻痹戒
#ACT
GiveFoundryItem 逆火麻痹戒
#ELSEACT
SendMsg 5 缺少合成物品<%Item>
[@FoundryFail]
#ACT
SendMsg 5 合成 <%Item> 失败!

合成多个物品的脚本可以参考如下脚本(以@FoundryItem_开头后面跟要合成的物品, %FoundryItem是M2自动转换后的合成物品名称):
[@Main]
<合成逆火麻痹/@FoundryItem_逆火麻痹戒>   <查看所需物品/@ShowItem_逆火麻痹戒>\
<合成九转天龙/@FoundryItem_九转天龙戒>   <查看所需物品/@ShowItem_九转天神戒>\
<合成天神守护/@FoundryItem_天神守护戒>   <查看所需物品/@ShowItem_天神守护戒>\

[@FoundryItem_]
#IF
CheckFoundryItem %FoundryItem
#ACT
GiveFoundryItem %FoundryItem
#ELSEACT
;SendMsg 5 缺少合成物品<%Item>
ShowFoundryItem %FoundryItem
[@FoundryFail]
#ACT
SendMsg 5 合成 <%Item> 失败!

[@FoundryOK]
#ACT
SendMsg 5 合成 <%Item> 成功!

[@ShowItem_]
<$ShowItem>


写入指定文本文件

功能: 把字符串写入到指定的文本文件中,可以指定写入行.
格式: AddTextListEx 路径 字符串 行(0-65535) 是否绝对路径

#IF
#ACT
AddTextListEx ..\TestList.txt <$USERNAME> 0


新的装备改名

功能: 新的装备改名
格式: ChangeItemName 位置(0-51) 名字

#IF
#ACT
ChangeItemName 1 新名字

英雄如下：
#IF
#ACT
H.ChangeItemName 1 新名字

##################2019-03扩展#################################

物品名称支持60字符，字符包含名称中各种符号，2个符号为一个汉字！！！！

Changeitemname 1 屠龙[强化+<ImgNum:1:10:1:0:0:0>]
Changeitemname 1 屠龙<img:74:79:0:0>

注意设置装备名字颜色如果使用了PlayImg 参数8(指定鼠标指向后提示信息的高度):参数9(指定鼠标指向后提示信息宽度) ，不用PlayImg的话可以无视！！

Changeitemname 1 {我|70}是彩色的{极品|249}<PlayImg:1:520:10:100:0:0:0:20:20>


延时执行脚本

延时执行指定的脚本.

DelayCall S Label (S单位毫秒, Label是需要跳转的脚本段)

#IF
#ACT
DelayCall 5000 @Kick

[@Kick]
#IF
#ACT
Kick


移动怪物到新坐标

功能: 移动指定坐标的怪物到新的位置.
格式: MoveMonToPos 怪物 地图 老坐标X 老坐标Y 新坐标X 新坐标Y

例子:
#IF
CheckRangeMonCountEx K004 魔王弓箭手 51 43 5 > 0
#ACT
MoveMonToPos 魔王弓箭手 K004 51 43 48 47


移动某地图全部人物到另外一个地图

把某个地图中的玩家全部移动到另外一个地图.

#IF
#ACT
MoveMapPlay 0 3 333 333
#SAY
地图0中的人物已经全部移动到地图3中.


英雄登录器荣誉

英雄登录器专用荣誉
格式: ChangeHumCreditEx 操作符(+ - =) 数值(1-65535)

#IF
#ACT
ChangeHumCreditEx + 10


英雄增加以及删除技能

英雄增加技能

#IF
#ACT
H.ADDSKILL 英雄治愈术 3
SENDMSG 4 恭喜<$USERNAME>您的英雄学习了英雄治愈术三级
break

-----------------------------------------------------------------------------------

英雄删除指定技能

#IF
#ACT
H.DELSKILL 英雄治愈术
SENDMSG 4 恭喜<$USERNAME>您的英雄英雄治愈术技能已经被删除
break

-----------------------------------------------------------------------------------

清除英雄所有技能
注意:如果清除后英雄技能依然显示存在,那么请更新最新登录器.

#IF
#ACT
ClearHeroAllSkill


增加限次使用物品的次数.
说明: 只对刚刚使用过的类型(StdItem=31 Source=1)或者(StdItem=2 Shape=1,3,5,9)的物品有效.

[@StdModeFunc10]
#IF
CheckLevelEx < 100
#ACT
ChangeLevel + 1
Break
#ELSESAY
小于100级才可以使用.
#ELSEACT
AddFunItemDura   ;持久增加1

[@StdModeFunc11]
#IF
CheckLevelEx < 100
#ACT
ChangeLevel + 1
Break
#ELSESAY
小于100级才可以使用.
#ELSEACT
AddFunItemDura 100 ;持久增加100


召唤自己的分身

格式:RecallSelf 分身有效时间 数量 继承人物属性百分比 分身颜色(0-255;0不改变颜色) 改变分身衣服外观(0或空为不改变) 改变分身武器外观(0或空为不改变) X坐标 Y坐标

#IF
#ACT
RecallSelf 60 3 150 251 1 1
sendmsg 6 召唤3只金黄色分身帮助自己作战1分钟.继承人物全部属性150%，外观为木剑布衣


自定义颜色文字发送

功能说明: 发送自定义颜色的文字信息.

格式: GuildNoticeMsg 255 233 发送自定义颜色的文字信息. Self

参数一是前景颜色,参数二是背景颜色,参数三是要发送的文字信息,参数四等于'Self'时只发送给自己, 等于'Group'时发送给组队, 等于'Guild'时发送给行会成员, 等于'National'时发送给自己国家的人(使用于国战), 等于'Map'时发送到当前地图中的人物.如果省略参数四表示全服发送.

支持的参数: %s(玩家名字) %d(NPC名字) %m(地图名字) %x%y(坐标)
  <$KILLER>杀死人物的名字
<$KILLMONNAME>人物杀死怪物的名字
<$H.KILLMONNAME>英雄杀死怪物的名字


自动穿戴装备

   功能:自动穿背包中的装备

  装备位置:
  衣服        = 0;
  武器        = 1;
  蜡烛        = 2;
  项链        = 3;
  头盔        = 4;
  左手镯      = 5;
  右手镯      = 6;
  左戒指      = 7;
  右戒指      = 8;
  护符        = 9;
  腰带        = 10;
  鞋子        = 11;
  宝石        = 12;

  #IF
  CheckLevelEx > 1
  #ACT
  Give 怒斩 1
  AutoTakeOnItem 怒斩 1


自动寻路

功能: 自动移动到指定坐标,专用登录器.
格式: GotoNow X Y

例子: 在盟重时自动移动到330 330
#IF
IsOnMap 3
#ACT
GotoNow 330 330


检测被自己杀死宝宝的名字

检测被自己杀死的宝宝的名字.
注意:此命令只检测直属宝宝,例如道士英雄召唤的神兽不属于直属宝宝.

#IF
CheckKillSlaveName 白野猪
#SAY
你把对方的宝宝<白野猪>杀死了.


检测本月的天数

功能: 检测是否是本月的第几天.
格式: DAYOFMONTH 天数(1-31) 天数(1-31)
说明: 第二个参数可省略.

例子: 检测是否本月的前7天
[@main]
#IF
DAYOFMONTH 1 10
#SAY
本月10号之前.

例子: 检测是否是本月的第一天
[@main]
#IF
DAYOFMONTH 1
#SAY
今天是1号,新的一个月又开始了.


检测当前宝石升级装备的名字

功能: 检测当前通过宝石升级装备的名字
格式: CheckUpgradeItemName 位置(0-1) 名字
说明: 位置0=升级装备的名字 1=左边一格宝石的名字
注意: 此命令只能在QFunction中的@ItemUpgarde下执行.

[@ItemUpgrade]
#IF
CheckGold 5000
CheckUpgradeItemName 0 裁决之杖
#ACT
Take 金币 5000
#ELSESAY
只能升级裁决之杖,或者你没有5000金币.
#ELSEACT
SetUpgradeFail
Break


检测服务器最高属性人物命令

功能：
检测服务器最高属性人物命令。

格式：
 ISHIGH 项目

;==========================================
例：
#IF
ISHIGH L
#ACT
SENDMSG 0 本区最高等级玩家『%s』进入了『<$SERVERNAME>』游戏中！当前等级数<$LEVEL>！
#IF
ISHIGH P
#ACT
SENDMSG 0 本区最大恶棍玩家『%s』进入了『<$SERVERNAME>』游戏中！当前邪恶值<$PKPOINT>！
#IF
ISHIGH D
#ACT
SENDMSG 0 本区最高攻击玩家『%s』进入了『<$SERVERNAME>』游戏中！当前攻击力<$DC>-<$MAXDC>！
#IF
ISHIGH M
#ACT
SENDMSG 0 本区最高魔法玩家『%s』进入了『<$SERVERNAME>』游戏中！当前魔法力<$MC>-<$MAXMC>！
#IF
ISHIGH S
#ACT
SENDMSG 0 本区最高道术玩家『%s』进入了『<$SERVERNAME>』游戏中！当前道术力<$SC>-<$MAXSC>！
;==========================================


检测人物的攻击模式

说明: 检测人物的攻击模式
格式: CheckAttackMode 模式(0-7)

#IF
CheckAttackMode 0
#SAY
全体攻击模式

#IF
CheckAttackMode 1
#SAY
和平攻击模式


检测人物的伤害吸收

说明: 检测人物的伤害

格式: CheckSuckDamage 操作符(> = <) 数量(1-2000000000)

#IF
CheckSuckDamage > 1000
#SAY
SendMsg 5 你当前拥有的伤害吸收大于1000点.


检测人物是否挂机

功能:检测人物是否是离线挂机
格式:CheckOffline


检测物品持久

功能:检测人物身上物品持久.
格式:CheckItemDura 位置(0-12) 操作法(> = <) 持久(1-65000) 模式(0,1)
说明:默认模式=0表示检测物品持久下限,模式=1时检测物品持久上限.

例子:检测物品持久下限
[@Main]
#IF
CheckItemDura 1 > 30000 0
#SAY
武器持久下限大于30.

例子:检测物品持久上限
[@Main]
#IF
CheckItemDura 1 > 30000 1
#SAY
武器持久上限大于30.


检测物品纯度

功能: 检测背包中物品的纯度(持久,品质).
格式: CheckMine 物品名称 数量(1-45) > = < 纯度(1-65)

例子: 检测背包中是否有5个纯度20的黑铁矿石,并且回收.
[@main]
#IF
CheckMine 黑铁矿石 5 = 20
#ACT
TakeMine 黑铁矿石 5 = 20
#SAY
背包中有5个纯度20的黑铁矿石.
#ELSESAY
没有.


检测新属性

功能: 检测当前装备是否附加了新属性. 专用登录器.
格式: CheckNewItemValue 位置(0-18) 属性(0-5) 操作符(<,=,>) 值(1-100)
说明: 属性 0=致命一击 1=攻击伤害增加 2=物理伤害减少 3=魔法伤害减少 4=攻击伤害反弹 5=人物体质增加
位置说明：-1 升级框， 0-18装备位置(新增位置：boxitem0 - boxitem7 对应8个框)

例子:

#IF
CheckNewItemValue 1 0 > 5
#SAY
你的武器附加了5%的致命一击属性.

#IF
CheckNewItemValue 1 1 > 5
#SAY
你的武器附加了5%的攻击伤害增加属性.

#IF
CheckNewItemValue 0 5 > 5
#SAY
你的衣服附加了5点人物体质属性.

检测命令不包含天生元素属性（即数据库字段设置的属性）


检测英雄的PK值

#IF
CheckHeroPkPoint > 100
#SAY
英雄的PK值大于100点.


检测英雄的伤害吸收

说明: 检测英雄的伤害

格式: CheckHeroSuckDamage 操作符(> = <) 数量(1-2000000000)

#IF
CheckHeroSuckDamage > 1000
#SAY
SendMsg 5 你的英雄当前拥有的伤害吸收大于1000点.


检测英雄的忠诚度

功能: 检测英雄当前的忠诚度
格式: CheckHeroLoyal 操作符(< = >) 数值(0 -- 100)

例子:
#IF
CheckHeroOnline
CheckHeroLoyal > 50
#ACT
SendMsg 5 您的英雄忠诚度大于50%.

忠诚度变量：<$H.LOYALPOINT>


检测英雄登录器荣誉
格式: CheckHumCreditEx 操作符(> = <) 数值(1-65535)

#IF
CheckHumCreditEx < 10
#ACT
ChangeHumCreditEx = 10


检测英雄职业.

CheckHeroJob 职业(WARRIOR,WIZARD,TAOIST)

#IF
CheckHeroOnline
CheckHeroJob TAOIST
#SAY
你英雄的职业是道士
#ELSESAY
你的英雄没有在线.

----------------------------------------------------------------------------------------

检测英雄职业.

CheckHeroJob 职业(0,1,2)

#IF
CheckHeroOnline
CheckHeroJob 2
#SAY
你英雄的职业是道士
#ELSESAY
你的英雄没有在线.

----------------------------------------------------------------------------------------

另外支持H.CheckJob 职业(WARRIOR,WIZARD,TAOIST) //检测英雄职业


检测月份

功能: 检测现在是几月
格式: MONTHOFYEAR 月份(1-12) 月份(1-12)
说明: 第二个参数可省略.

例子: 检测是否7月--8月
[@main]
#IF
MONTHOFYEAR 7 8
#SAY
暑假期间大家玩的开心点.

例子: 检测是否1月
[@main]
#IF
MONTHOFYEAR 1
#SAY
新的一年开始了.


检测装备的附加属性总和[!]

功能: 检测装备的附加属性总和(武器的诅咒不在计算范围之内).
格式: 格式: CheckItemAddValueEx 位置(0-51 -1升级框 ，boxitem0 -boxitem7自定义OK框) 操作符(> = <) 附加值(0-65000) 新属性(0,1)
说明: 第四个参数只在英雄M2下有效,1时计算附加的致命一击等属性.

例子:
#IF
CheckItemAddValueEx 1 > 5 1
#SAY
武器的附加属性大于5点.


检测装备名字颜色

功能: 检测装备名字的颜色(英雄M2).
格式: CheckItemNameColor 位置(0-13) 颜色(0-255)

例子: 检测武器颜色是否是紫色.
[@main]
#IF
CheckItemNameColor 1 253
#SAY
武器名字紫色显示.

检测英雄装备名字的颜色命令：H.CheckItemNameColor


检测字符串长度命令

功能：

检测字符串长度命令

格式：

CheckStringlength 字符串 操作符(<,>,=) 位数

说明：一个汉字位数为2, "》"也为2个字符

[@test]
#IF
CheckStringlength lfm2 > 3
#SAY
lfm2大于3个字符
#ELSESAY
lfm2小于3个字符


检查宝宝数量

功能：
    可以检查玩家所带宠物的数量。

格式：
CHECKSLAVECOUNT  控制符  <.=.>  数量< FONT>

;==========================================
;检查宝宝数量是否为指定数量
[@checkslavecount0]
#IF
#ACT
  CHECKSLAVECOUNT = 5
#SAY
你的宝宝数量为5个。
#ELSESAY
你的宝宝数量不为5个。
;==========================================

;==========================================
;检查宝宝数量是否为大于数量
[@checkslavecount1]
#IF
#ACT
  CHECKSLAVECOUNT > 5
#SAY
你的宝宝数量超过5个。
#ELSESAY
你的宝宝数量不超过5个。
;==========================================

;==========================================
;检查宝宝数量是否为小于数量
[@checkslavecount2]
#IF
#ACT
  CHECKSLAVECOUNT < 5
#SAY
你的宝宝数量小于5个。
#ELSESAY
你的宝宝数量不小于5个。
;==========================================

;******************************2018-05-12进行扩展**************************************************

.可以检查玩家所带宝宝的数量扩展。
格式：
CHECKSLAVECOUNT 控制符 <.=.> 数量

扩展,可以检查相同名字宝宝的数量(不带宝宝名字则为检查所有宝宝)
CHECKSLAVECOUNT 控制符 <.=.> 数量 宝宝名字 是否检查名称数字(0:不检查名称数字[骷髅1,骷髅2都按包骷髅算], 1:算数字)


检查宝宝最高等级

脚本功能:
检查宝宝的等级。

命令格式:
CHECKSLAVELEVEL 控制符(=,>,<)  等级数(7)< /FONT>

;==========================================
;检查宝宝的等级是否等于指定级别
[@checklevel0]
#IF
  CHECKSLAVELEVEL = 5
#SAY
宝宝的等级等于5级。
#ELSESAY
宝宝的等级不等于5级。
;==========================================

;==========================================
;检查宝宝的等级是否大于指定级别
[@checklevel1]
#IF
  CHECKSLAVELEVEL > 5
#SAY
宝宝的等级大于5级。
#ELSESAY
宝宝的等级不大于5级。
;==========================================

;==========================================
;检查宝宝的等级是否小于指定级别
[@checkposelevel2]
#IF
  CHECKSLAVELEVEL < 5
#SAY
宝宝的等级小于5级。
#ELSESAY
宝宝的等级不小于5级。
;==========================================


检查地图中的人物是否属于同一个行会

检查当前地图中的人物是否属于同一行会

格式: MapHumIsSameGuild 是否忽略没有加人行会的人物(0-1)

#IF
MapHumIsSameGuild 1
#SAY
当前地图中的人物属于同一个行会,不包涵没有加入行会的人物.


检查人物被踢次数.

#IF
CheckNumOfKick 3
#SAY
你已经被踢下线至少3次了.


检查人物杀死怪物的名字

功能:检查人物杀死怪物的名字
格式:CheckKillMonName 名字 是否清除(0,1)
说明:是否清除参数可以不需要默认0,为了避免杀死某个怪物可重复执行脚本是设置1.

[@main]
#IF
CheckKillMonName 白野猪
#SAY
你把白野猪干掉了!

;检测后立即清除人物内置变量.

[@main]
#IF
CheckKillMonName 白野猪 1
#SAY
你把白野猪干掉了!


检查人物是否学习了某项魔法

#IF
CheckMagicName 烈火剑法
#SAY
你已经学会了烈火剑法.


检查人物是否在指定范围内

功能: 检测人物是否在指定范围之内
格式: CheckHumInRange 地图 坐标X 坐标Y 范围(0 -- 500)
说明: 地图=Self时表示当前地图.

例子: 检测人物是否在盟重安全区.
#IF
CheckHumInRange 3 330 330 5
#SAY
你在盟重安全区发呆呢..


检查人物所在地图是否允许使用记忆,夫妻,师徒传送

#IF
CheckRecall 人物名字
#SAY
当前地图不允许被传送.


检查是被人物还是怪物杀死的

检查是被怪物还是人物杀死的.

#IF
KillByHum
#ACT
SendMsg 5 玩家 <$HumKiller> 在%m 把你干死了!
#ELSEACT
SendMsg 5 怪物 <$MONKILLER> 在%m 把你干死了!

变量：<$KILLER> 可显示人物、怪物、等其他一切杀死自己的对象名称，使用此变量为综合变量！！！可用于人物名字变量和怪物名字变量、如：

检查是被怪物还是人物杀死的.

#IF
KillByHum
#ACT
SendMsg 5 玩家 <$KILLER> 在%m 把你干死了!
#ELSEACT
SendMsg 5 怪物 <$KILLER> 在%m 把你干死了!

特别说明：
KillByHum 检测人物杀死为显示人物，宝宝杀死则为怪物（非人物）
CheckKillByHum 检测为凶手为人物包含人物的任意下属 （含宝宝，英雄和英雄宝宝均检测为人物）
$KILLER 变量显示配合CheckKillByHum 检测，凶手名字全部为人物名字（无论是宝宝，英雄和英雄宝宝均显示人物名字）

[@PlayDie]
#IF
CheckKillByHum
#ACT
SendMsg 5 玩家 <$KILLER> 在%m 把你干死了!
#ELSEACT
SendMsg 5 怪物 <$KILLER> 在%m 把你干死了!


检查是否有英雄

检查人物是否有英雄

#IF
CheckHaveHero
#SAY
你已经有英雄了.
#ELSESAY
你还没有英雄.


检查一个范围内怪物数

功能：
    可以检查一个坐标范围内怪物数量。

格式：
CheckRangeMonCount 地图号 X坐标 Y坐标 范围 控制符(=,>,<) 数量

;==========================================
[@Main]
#IF
  CheckRangeMonCount 3 330 330 10 < 100
#SAY
地图3的X330Y330十的范围内怪物少于100只
#ELSESAY
地图3的X330Y330十的范围内怪物多于100只
;==========================================


检查英雄等级

检查英雄当前等级.

格式: CheckHerolevel 操作符(> = <) 级别(1-65535)

#IF
CheckHerolevel = 50
#SAY
你的英雄已经50级了


检查正在穿身上装备的名字名字.

格式: CheckTakeonItem 物品名字

#ACT
CheckTakeonItem 布衣(男)
#SAY
你正在穿布衣(男)

============================================================================

检查正在穿身上装备的名字名.

格式: CheckTakeOffItem 物品名字

#ACT
CheckTakeOffItem 布衣(男)
#SAY
你的布衣是不是该扔掉了?


检查正在攻击中的怪物名字

说明: 检查正在被自己攻击的怪物的名字.
注意: 地图参数中加入 HITMON(@XXX)

Q-Function0.txt中

[@XXX]
#IF
CHECKHITMONNAME 白野猪
#SAY
你正在攻击白野猪


检查正在取下身上装备的名字.

格式: CheckTakeOffItem 物品名字

#ACT
CheckTakeOffItem 布衣(男)
#SAY
你的布衣是不是该扔掉了?

============================================================================

检查正在穿身上装备的名字名字.

格式: CheckTakeonItem 物品名字

#ACT
CheckTakeonItem 布衣(男)
#SAY
你正在穿布衣(男)

============================================================================


检查指定范围内人物数量

功能: 检测指定范围内人物数量
格式: 格式: CheckRangeHumCount 地图 坐标X 坐标Y 范围 操作符(>= <) 数量
说明: 地图=Self时表示当前地图 坐标=0时表示当前坐标

例子: 检测盟重省安全区的人物数量
#IF
CheckRangeHumCount 3 330 330 10 > 100
#SAY
盟重土城当前人数超过100.


检查指定人物背包空格数量

检测指定人物背包空格数量

#IF
CheckHumBag <$STR(S1)> > 5
#SAY
<$STR(S1)>的背包有5个以上的空格.


检查装备升级次数

功能: 用来检测通过宝石升级装备的次数.
格式: CheckItemupgradeCount 方式(0,1) 位置(0-12) 操作符(> = <) 次数(0-255)
说明: 方式=0时检测正在升级的装备,方式=1时检测人物身上的装备.

例子: 检测武器是否已经升级10次.
#IF
CheckItemUpgradeCount 1 1 > 10
#SAY
你的武器已经升级了10次以上.


检查自己和宝宝之间的距离[!]

功能: 检测自己和宝宝之间的距离
格式: CheckSlaveInRange 名字 距离
说明: 此命令的主要作用是配合128类型的宝宝使用(可模仿押镖任务).

#IF
CheckSlaveInRange 月灵 5
#SAY
你的月灵在身边
#ELSESAY
你的月灵宝宝跑哪里去了?


摆摊触发脚本

说明:允许摆摊的地图需要在MapInfo.txt中增加地图参数MyShop

打开摆摊窗口之前首先执行Q-Function中的@StartMyShop脚本段.
脚本命令ForbidMyShop用于中断摆摊.

例子:以下脚本放在Q-Function中.
[@StartMyShop]
#IF
CheckLevelEx < 40
IsOnMap 3
#SAY
40级之后才可以在盟重使用摆摊功能.
#ACT
ForbidMyShop


购买商铺物品时触发

功能说明: 人物通过商铺购买物品成功时触发(英雄M2).
使用方法: Q-Function.txt中@BuyShopItem脚本段,
          购买的物品名字放在人物的S0变量中,物品价格放在M0中.

[@BuyShopItem]
#IF
#ACT
SendMsg 5 %s通过商铺购买了<$STR(S0)>,价格是:<$STR(M0)>

---------------------------------------

2020-0510扩展商铺购买物品触发：

S0: 物品名称
S1: 货币名称
M0: 总价
M1: 货币类型
M2: 商品数量
M3: 批量购买数量

[@BuyShopItem]
#act
SendMsg 5 购买了商铺物品<$str(S0)>，商品总价<$str(M0)>货币名称<$str(S1)>（货币类型<$str(M1)>)，商铺物品数量<$str(M2)>，批量购买数量<$str(M3)>


技能触发脚本功能

说明: 默认技能触发脚本功能没有开启,在功能设置\其他控制中开启之后才有效.

增加魔法触发功能.自身技能触发. Q-Function.txt中[@MagSelfFuncX]段,其中X表示要触发的魔法ID
增加魔法触发功能.对目标人物使用时自身触发. Q-Function.txt中[@MagTagFuncX] 段,其中X表示要触发的魔法ID
增加魔法触发功能.目标人物技能触发. Q-Function.txt中[@MagTagFuncExX] 段,其中X表示要触发的魔法ID
增加魔法触发功能.目标怪物技能触发. Q-Function.txt中[@MagMonFuncX] 段,其中X表示要触发的魔法ID

例子:使用治愈术时触发脚本

[@MagSelfFunc2]
#ACT
SendMsg 5 自己加血
[@MagTagFunc2]
#ACT
SendMsg 5 给别人加血
[@MagMonFunc2]
#ACT
SendMsg 5 给怪物加血.


宝石升级系统[!]

说明:1.打开人物背包点右下脚的升级按钮进行升级.也可使用OpenUpgradeDialog命令打开界面.
       2.在M2\查看\列表信息二\物品规则，可设置禁止宝石升级的装备
       3.放好物品点升级时先执行Q-Function中的@ItemUpgrade脚本段.

例如:升级装备需要5000金币,此脚本放入Q-Function.txt中.

[@ItemUpgrade]
#IF
CheckGold 5000
#ACT
Take 金币 5000
#ELSESAY
升级装备需要5000金币.
#ELSEACT
SetUpgradeFail
Break

----------------------设置数据库字段加星的方法----------------------------------------------------------------------------------------

升级宝石StdMode=55,56,57,58,59

宝石类型1:

StdMode=55(升级指定类型的装备)
Shape=(指定升级哪种类型的装备,此处添写和要升级类型的StdMode一样的值即可,例如武器设定为5)
AniCount=(指定可以升级加几以下的装备,例如:设定为10,那么该宝石可以升级次数小于10次的装备)
DuraMax=(指定宝石升级装备的成功机率,例如:设定为20既为20%成功机率)
Need=(升级失败后可执行的操作,如果该值等于1-100时,则失败后把装备副加属性全部清零.如果该等于101-200时,则失败后装备消失.等于201-300时,升级失败后装备当前属性不变.)
NeedLevel=(指定宝石升级范围,等于0时不限制,例如:该宝石只允许升级+5到+10之间的装备,那么Need=5*65535+10,计算规则=低限*65535+上限)
Ac,Ac2,Mac,Mac2,Dc,Dc2,Mc,Mc2,Sc,SC2=(指定该宝石升级成功后给装备加的属性，设定方法跟设置装备属性一样，不同的装备设置也不一样)

宝石类型2:
StdMode=57(升级符合类型的装备)
Source=(等于1)
Shape=(等于0升级符合类型的装备：10，11{衣服}，66, 67{时装衣服}，12{盾牌}，15{头盔}.
16{斗笠},22{戒指},26{手镯},62{鞋子},64{腰带},30{照明物},28{马牌}，65{军豉}.
(指定填写升级AC2,MAC2字段类型装备,必须是Source=(等于1)类型范围中的StdMode值)
区别:其他设置方法参照宝石类型1
注意:此类宝石只增加防御和魔御.
AC2,MAC2=(升级装备,必须是可增加防御和魔御的装备才可以升级)

宝石类型3:
StdMode=57(升级符合类型的装备)
Source=(等于2)
Shape=(等于0升级符合类型的装备：
5，6{武器}，68, 69{时装武器}，19{项链}，20{项链},21{项链},23{戒指},24{手镯}.
(指定填写升级DC2,MC2,SC2字段类型装备,必须是Source=(等于2)类型范围中的StdMode值)
区别:其他设置方法参照宝石类型1
注意:此类宝石只增加攻击,魔法,道术.
DC2,MC2,SC2=(升级装备,必须是可增加攻击,魔法,道术属性的装备才可以升级)

宝石类型4:
StdMode=58(随成升级装备属性)
Shape=(0表示所有类型,指定类型时填写待升级装备的StdMode值)
AniCount=(升级点数)
区别:其他设置参照宝石类型1,此类宝石升级时随机增加装备属性,例如:AniCount等于5时,那么随机增加装备5点属性.
注意:升级失败后如果Need小于100那么随机清除某项或者多项附加属性.

宝石类型5:
StdMode=59(增加升级成功率)
Shape=(0表示所有类型,指定类型时填写待升级装备的StdMode值)
DuraMax=(提高成功机率,例如:设定5即为提高5%的机率)

以下是最新更新后的部分新特性:
1.55,57,58这三种类型宝石失败后默认不会降低装备升级次数.如果升级失败时需要降低装备等级那
  么设置物品的Reserved字段,0时不降,大于0时设置几就降几点.

2.58类型的升级宝石的Reserved有其他用途,所以对58类型宝石重新做了调整,
  Weight=1时随机升级所以属性,
Weight=2时只随机升级攻击,魔法,道术.
Weight=3时只随机升级防御和魔御.

宝石类型6:
StdMode=56(升级指定类型的装备)
NeedLevel=(1-100)
区别:和第一种【宝石类型1（55）】宝石失败后要么消失,要么清除属性,要么没有变化,而这种宝石升级失败时则给装备减去此类宝石相同的属性,并且装备降一级.

点击宝石升级触发QFunction中的@ItemUpgrade
在@ItemUpgrade中支持
宝石升级框中物品的名称 :<$StoneUpgrade.NAME>\
宝石升级框中物品的StdMode :<$StoneUpgrade.STDMODE>\
宝石升级框中物品的持久 :<$StoneUpgrade.DURA>\
宝石升级框中物品的最大持久 :<$StoneUpgrade.DURAMAX>\
宝石升级框中物品的升级次数 :<$StoneUpgrade.UpgCount>

脚本实例：
在QF中加入

[@ItemUpgrade]
#IF
#SAY
宝石升级框中物品的名称 :<$StoneUpgrade.NAME>\
宝石升级框中物品的StdMode :<$StoneUpgrade.STDMODE>\
宝石升级框中物品的持久 :<$StoneUpgrade.DURA>\
宝石升级框中物品的最大持久 :<$StoneUpgrade.DURAMAX>\
宝石升级框中物品的升级次数 :<$StoneUpgrade.UpgCount>


毒素武器[!]

使用方法:\Envir\UserData\PoisonWeapon.txt

格式: 武器名称 成功几率 减HP值 基本时间 扩展时间
成功率100以下时设置多少就是多少的成功率例如:80就是80%的成功率50就是50%的成功率
扩展时间是一个随即值,假如设置为10那么它的值就是1-10之间的值. 持续时间=基本时间+扩展时间所产生的随机值
例如:木剑 90 10 10 5


or检测命令

增加#or 脚本处理

比如:

#or
CHECKLEVEL 85
checkgamegold > 49999
#ACT
SendMsg 5 检测通过

两个条件只有一个符合.即可往下继续执行


行会成员人数

功能: 检测行会成员人数

格式:
CheckGuildMemberCount 控制符  <.=.>  数量

#IF
CheckGuildMemberCount  > 100
#SAY
行会成员大于100人.


获取NPC坐标

功能：
检测地图中的NPC并得到坐标

命令：
FindNpcPoint 地图名 NPC名称 X坐标变量 Y坐标变量

说明：
如果同一地图拥有相同名称的NPC，只会获取第一个找到的NPC，支持自定义NPC获取

[@测试]
#if
FindNpcPoint 3 盟重老兵 N1 N2
#act
SendMsg 6 盟重省中npc盟重老兵的坐标为<$STR(N1)>,<$STR(N2)>


获取当前镖车名称和坐标

功能说明: 获取当前镖车名称和坐标

说明：获取当前镖车名称和坐标（仅限押镖期间）

--------------------------------------------------------

示例脚本：

[@MAIN]
#IF
CHECKLEVELEX > 0
#SAY
镖车名称：<$EscortName>
镖车位置：<$EscortMapName> <$EscortX> ：<$EscortY>


获取地图怪物坐标

功能：
检测地图中的最近的怪物并得到坐标

命令：
FindMonPoint 地图名 怪物名称 X坐标变量 Y坐标变量

说明：
如果同一地图拥有相同名称的怪物，只会检测地图中的最近的怪物并得到坐标

[@测试]
#if
FindMonPoint 3 采集怪 N1 N2
#act
SendMsg 6 最近的盟重采集怪坐标为<$STR(N1)>,<$STR(N2)>


获取行会人数脚本命令

功能: 获取行会人数脚本命令

格式:
GETGUILDMEMBERCOUNT  参数1  参数2  参数3

参数1:行会名称
参数2:保存变量 行会不存在返回0
参数3:0或空为行会总人数，1为行会当前在线成员人数

例:
[@main]
#act
GETGUILDMEMBERCOUNT <$guildname> N$人数
sendmsg 6 你的行会人数:<$str(N$人数)>


获取自定义怪物攻击类型

功能说明: 获取自定义怪物攻击类型

说明：被自定义怪物攻击时，获取自定义怪物攻击类型

--------------------------------------------------------

示例脚本：

通常使用被攻击触发获取，由于翎风引擎的人物 分身 宝宝触发是分开触发，所以需要独立设置，下面仅为人物触发

;QFunction-0.txt

;人物被物理攻击触发
[@Struck]
#IF
CHECKCURRTARGETRACE = 156
#ACT
#CALL [\自定义怪物BUFF.txt] @_@MONBUFF

;人物被魔法攻击触发
[@MagicStruck]
#IF
CHECKCURRTARGETRACE = 156
#ACT
#CALL [\自定义怪物BUFF.txt] @_@MONBUFF

;分身被物理攻击触发
[@CloneStruck]
#IF
CHECKCURRTARGETRACE = 156
#ACT
#CALL [\自定义怪物BUFF.txt] @_@MONBUFF分身

;分身被魔法攻击触发
[@CloneMagicStruck]
#IF
CHECKCURRTARGETRACE = 156
#ACT
#CALL [\自定义怪物BUFF.txt] @_@MONBUFF分身

;宝宝被物理攻击触发
[@SlaveStruck]
#IF
CHECKCURRTARGETRACE = 156
#ACT
#CALL [\自定义怪物BUFF.txt] @_@MONBUFF宝宝

;宝宝被魔法攻击触发
[@SlaveMagicStruck]
#IF
CHECKCURRTARGETRACE = 156
#ACT
#CALL [\自定义怪物BUFF.txt] @_@MONBUFF宝宝

示范脚本为人物被自定义怪物触发 ，分身或宝宝自己添加
多级命令，分身：FS. 宝宝BB.

[@_@MONBUFF]
{

#IF
EQUAL <$CURRRTARGETFULLNAME> MON120
EQUAL <$CURRRUSEMAGICID> 0
#ACT
SENDMSG 6 MON120对你施展了普通攻击
BREAK

#IF
EQUAL <$CURRRTARGETFULLNAME> MON120
EQUAL <$CURRRUSEMAGICID> 1
#ACT
SENDMSG 7 MON120对你施展了攻击1
BREAK

#IF
EQUAL <$CURRRTARGETFULLNAME> MON120
EQUAL <$CURRRUSEMAGICID> 2
#ACT
SENDMSG 7 MON120对你施展了攻击2
BREAK

#IF
EQUAL <$CURRRTARGETFULLNAME> MON120
EQUAL <$CURRRUSEMAGICID> 3
#ACT
SENDMSG 7 MON120对你施展了攻击3
BREAK

#IF
EQUAL <$CURRRTARGETFULLNAME> MON120
EQUAL <$CURRRUSEMAGICID> 4
#ACT
SENDMSG 7 MON120对你施展了攻击4
BREAK

#IF
EQUAL <$CURRRTARGETFULLNAME> MON120
EQUAL <$CURRRUSEMAGICID> 5
#ACT
SENDMSG 7 MON120对你施展了攻击5
BREAK

#IF
EQUAL <$CURRRTARGETFULLNAME> MON120
EQUAL <$CURRRUSEMAGICID> 6
#ACT
SENDMSG 7 MON120对你施展了攻击6
#if
random 5
#act
ChangeState 3 5
;多级脚本应用，分身：FS.ChangeState 宝宝：BB.ChangeState
SENDMSG 7 MON120对你施展了攻击6中了蜘蛛网 5秒内禁止跑动
BREAK
}


检测包裹中满经验聚灵珠数量

功能说明: 给予一个满经验聚灵珠、检测包裹中满经验聚灵珠数量

说明：给予一个满经验聚灵珠、检测包裹中满经验聚灵珠数量

--------------------------------------------------------

给予一个满经验聚灵珠命令
命令格式：GIVE 物品名 数量 参数3 参数4 参数5 参数6 参数7 参数8 参数9

参数3-8对应物品位置的0-5极品属性（其他位置无效）。参考下面的极品属性

参数9: 物品持久值(0或空保持当前，视物品而定; -1:给满持久)；*******注意：参数9仅对非叠加物品有效

例如
#ACT
give 聚灵珠 1 0 0 0 0 0 0 -1
sendmg 6 给了你一个满经验的聚灵珠

give 祝福罐 1 0 0 0 0 0 0 -1
sendmg 6 给了你一个满的祝福罐

-------------------------------------------------------

检测包裹中满经验聚灵珠数量命令
获取背包中某物品的数量命令：GetBagItemCount 物品名称 保存变量 排除OK框中的物品(0或空:计算OK框的物品，1：不算OK框中的物品) 是否判断满持久

参数3： 是否判断满持久(0:不判断； 1：判断）*******注意：参数3仅对非叠加物品有效

格式: GetBagItemCount 物品名称 保存变量 排除OK框中的物品(0或空:计算OK框的物品，1：不算OK框中的物品) 是否判断满持久(0:或空不判断； 1：判断）

示列：

[@main]
#ACT
GetBagItemCount 聚灵珠 N1 0 1
SENDMSG 6 你的背包中共有<$STR(N1)>个满经验的聚灵珠
-------------------------------------------------------

使用TAKE命令收回满经验的聚灵珠
格式：take 物品 数量 是否检测装备改名（0或空：不检测，1：检测） 物品名匹配方式(0或空：完整匹配，1：部分匹配） 是否回收自定义OK框物品(0或空:回收; 1:不回收) 检测持久（0或空：不检测 ，-1检测为满持久，-2未满持久）

[@main]
#ACT
GetBagItemCount 聚灵珠 N1 0 1
SENDMSG 6 你的背包中共有<$STR(N1)>个满经验的聚灵珠

#If
Large N1 0
#Act
take 聚灵珠 1 0 0 0 -1
ChangeExp + 100000
SendMsg 7 你的经验点数已经增加100000点。


检测背包是否包含文件中的物品

功能：
检测背包是否包含文件中的物品

命令：
CheckBagItems 文件名 物品名变量 数量变量
CacheCheckBagItems 文件名 物品名变量 数量变量

说明：
检测背包是否包含文件中的物品,按文件中的物品顺序检测，检测到后返回
高频率检测脚本请使用CacheCheckBagItems 缓存命令，效果更高

[@测试]
#IF
CheckBagItems d:\a.txt S1 N1
#ACT
SendMsg 6 检测到背包中有d:\a.txt的物品，物品名为<$STR(S1)>，数量为<$STR(N1)>
#ELSEACT
SendMsg 6 未检测到背包中有d:\a.txt的物品

[@测试1]
#IF
CheckBagItems ..\QuestDiary\回收系统\赤月装备.txt S1 N1
#ACT
SendMsg 6 检测到背包中有赤月装备物品，物品名为<$STR(S1)>，数量为<$STR(N1)>
#ELSEACT
SendMsg 6 未检测到背包中有赤月装备物品


检测背包是否有指定物品[!]

功能: 检测背包是否有指定物品

格式:checkitem 名字 数量 参数3（空或0，名称完全匹配。 不等于0部分匹配）参数4(是否检测改名的装备0：否; 1: 是）

#IF
CheckItem 麻痹 1 1
#ACT
SendMsg 5 你背包有包含麻痹文字的装备

#IF
CheckItem 麻痹戒指 1
#ACT
SendMsg 5 你背包有麻痹戒指

==================================================

格式:checkitems 参数1名字 参数2数量 参数3检测身上相同（包含检查装备，首饰，神佑）装备总量

#IF
checkitems 传送戒指 2
#ACT
SENDMSG 5 你身上有2个传送戒指....


检测当前目标类型

格式: CHECKCURRTARGETRACE 控制符(=,>,<) 数据库Race值

该命令只有在死亡触发和攻击触发中使用

[@MagicStruck]
#IF
CHECKCURRTARGETRACE = 0
#SAY
当前是人物
BREAK

#IF
CHECKCURRTARGETRACE = 1
#SAY
当前是英雄
BREAK

#IF
CHECKCURRTARGETRACE = 150
#SAY
当前是人形怪
BREAK

#IF
CHECKCURRTARGETRACE = 151
#SAY
当前是分身


检测地图范围怪物数量

格式: CHECKRANGEMONCOUNTEX 地图代码 怪物名 X坐标 Y坐标 范围 控制符(=,>,<) 数量 宝宝是否计算在内
[@main]
#IF
CHECKRANGEMONCOUNTEX 3 半兽人 333 333 10 > 100
#SAY
大于100个半兽人

[@main]
#IF
CheckRangeMonCountEx <$MAP> 半兽人 51 43 0 > 0 1
#SAY
大于100个半兽人

最后扩展一个参数：0：不算宝宝；1：算宝宝


检测地图相同怪物数

格式: CheckMapSameMonCount 地图名称 怪物名称 控制符(<,>,=) 数量 是否忽略怪物名称后面的数字(留空或0=检测数字,1=不检测数字)

[@Main]
#IF
CheckMapSameMonCount 3 稻草人 > 10
#SAY
土城的稻草人大于10个

[@Main]
#IF
CheckMapSameMonCount 3 圣兽A > 2
#SAY
土城的圣兽A大于2个
比如圣兽a 圣兽A1 圣兽A2各刷一只，后面不检测数字 那么土城圣兽大于2 ，检测的话就只有一个真正的圣兽了,留空和0 全是检测数字 ，1才是不检测


检测地图坐标是否可以到达

功能：
检测地图坐标是否可以到达

格式：
CHECKMAPMOVE 地图名 X坐标 Y坐标

==============================================
[@测试]
#IF
CHECKMAPMOVE 3 333 333
#SAY
盟重省333 333能够到达
#ELSESAY
该坐标不能到达
============================================


检测对象状态

功能说明: 检测对象状态

说明：CheckStateValue 状态值

--------------------------------------------------------

示例脚本：

[@MAIN]
#IF
CheckStateValue 1
#SAY
你中红毒了

可检测对象状态：CheckStateValue 状态值（如下:)
0: 绿毒
1: 红毒
2: 麻痹
3: 冰冻
4: 永恒冰冻
5: 蛛网
6: 禁锢
7: 定身
8: 瘫痪
9: 0防御
10: 0魔御
11: 隐身
12: 连击技锁定时
13: 魔法盾
14: 武力盾
15: 道士盾
;检测盾请使用代码13（14.15无效）.无论盾的类型，只要检测是否开盾就使用13检测
16: 神圣战甲术
17: 幽灵盾

、


检测行会可以容纳多少成员

格式: CHECKGUILDMEMBERMAXLIMITCOUNT 行会名称(SELF表示检测自己所在的行会) 检测符(<,>,=) 数量
[@main]
#IF
CHECKGUILDMEMBERMAXLIMITCOUNT > 100
#SAY
你的行会可以容纳成员数大于100个


检测会员剩余时间

格式: 检测会员剩余时间 文件名称 过期是否删除(0不删除 1删除) 变量1(到期时间 字符变量) 变量2(剩余天数 数字变量) 变量3(剩余小时 数字变量) 变量4(剩余分钟 数字变量)

例子:?

#IF
CHECKNAMEDATETIMELIST ..\QuestDiary\会员名单.txt 1 <$STR(S1)> <$STR(N1)> <$STR(N2)><$STR(N3)>
#ACT
SENDMSG 6 你的会员到期时间是<$STR(S1)>【剩余天数=<$STR(N1)>】【剩余小时=<$STR(N2)>】【剩余分钟=<$STR(N3)>】 255 253
#ELSEACT
SENDMSG 6 你不是会员或已过期，请及时充值！ 255 253

删除会员还是使用原来的老命令DELNAMEDATELIST

;----------------------------------------------------------------

以下命令支持绝对路径

ClearNameList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）
AddNameDateList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）
DelNameDateList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）


检测技能修炼点数

功能：
检测技能修炼点数。

格式：
 CHECKTRANPOINT 技能名称 控制符(=,>,<) 点数

;==========================================
[@Main]
#IF
CHECKTRANPOINT 刺杀剑术 > 9
#SAY
刺杀剑术的技能修炼点大于10
#ELSESAY
刺杀剑术的技能修炼点小于10
;==========================================

;==========================================
[@Main]
#IF
H.CHECKTRANPOINT 刺杀剑术 > 9
#SAY
您的英雄刺杀剑术技能修炼点大于10
#ELSESAY
您的英雄刺杀剑术技能修炼点小于10
;==========================================


检测魔法盾是否启用

功能: 检测魔法盾、武力盾、道力盾是否开启状态

格式:
CheckShieldStateOpen   参数1(0:武力盾;1:魔法盾;2:道力盾)

;检测防御盾是否开启 CheckShieldStateOpen 参数1(0:武力盾;1:魔法盾;2:道力盾)

[@测试]
#IF
CheckShieldStateOpen 0
#ACT
sendmsg 5 武力盾防御已开启

#IF
CheckShieldStateOpen 1
#ACT
sendmsg 5 魔法盾防御已开启

#IF
CheckShieldStateOpen 2
#ACT
sendmsg 5 道力盾防御已开启


检测骑马状态

功能: 检测是否骑马状态

格式:
CheckOnHorse

#IF
CheckOnHorse
#SAY
你正在骑马中....


检测人物PK值

功能：
检测人物PK值。

格式：
 CHECKPKPOINTEX 控制符(=,>,<) 数量

;==========================================
[@Main]
#IF
CHECKPKPOINTEX > 100
#SAY
PK值大于 100
#ELSESAY
PK值小于 100
;==========================================


检测人物宝宝名字[!]

功能：

检测人物宝宝名字

格式：

;==========================================
[@main]
#IF
CHECKSLAVENAME 翎风引擎
#ACT
SENDMSG 5 提示:你的宝宝叫翎风引擎
#ELSEACT
SENDMSG 5 提示:你的宝宝不叫翎风引擎
;==========================================


检测人物荣誉

格式: CHECKGAMEGLORY (<,>,=) 值

[@Main]
#IF
CHECKGAMEGLORY = 100
#SAY
荣誉等于100


检测人物是否佩带指定物品

功能:
检测当前人物是否佩带指定物品

格式:
CHECKITEMW 物品名 数量 是否装备名部分匹配（空或0，完全匹配。 不等于0部分匹配）

============================

[@TEST]
#IF
CHECKITEMW 力量戒指 1
#elsesay
你身上没有力量戒指\ \
#elseact
sendmsg 5 身上有力量戒指
break

[@TEST]
#IF
CHECKITEMW 力量 1 1
#elsesay
你身上没有穿戴包含力量的装备\ \
#elseact
sendmsg 5 身上有包含力量的装备
break

============================

[@TEST1]
#IF
COMPARETEXT <$DRESS> 布衣(男)
#elsesay
你身上没有布衣(男)\ \
#elseact
break

注：检测当前英雄是否佩带指定物品命令：H.CHECKITEMW


检测人物新增属性

格式: CHECKNEWITEMVALUE 位置(-1时是OK框中的装备, 0-18时是穿在身上的装备,boxitem0 - boxitem7 对应8个自定义OK框) 属性(0-10) 检测符(>,<,=) 值(1-100)

(0)暴击几率增加 1~100%
(1)增加攻击伤害 1~100%
(2)物理伤害减少 1~100%
(3)魔法伤害减少 1~100%
(4)忽视目标防御 1~100%
(5)所有伤害反弹 1~100%
(6)增加杀人暴率 1~100%
(7)人物体力增加 1~100%
(8)人物魔力增加 1~100%
(9)怒气恢复增加 1~100%
(10)合击攻击增加 1~100%
(11)增加杀怪暴率 1~100%
(12)增加防爆几率 1~100%
(13)增加防止麻痹 1~100%
(14)增加防止护身 1~100%
(15)增加防止复活 1~100%
(16)增加防止全毒 1~100%
(17)增加防止诱惑 1~100%
(18)增加防止火墙 1~100%
(19)增加防止冰冻 1~100%
(20)增加防止蛛网 1~100%
(21)致命一击几率 1~100%
(22)致命一击伤害增加 1~100%
(23)致命一击防御增加 1~100%
(24)暴击抗性(对方暴击几率 - 暴击抗性 = 对方暴击打出几率)1~1000%
(25)攻击伤害抗性(对方攻击伤害倍数 - 攻击伤害抗性 = 对方攻击伤害增加的倍数) 1~1000% ..........本抗性对应元素属性1 增加攻击伤害
几率大于100%则按照100%计算，如暴击几率300%，目标暴击抗性270%，那么攻击这个目标的暴击几率只有30% ，，目标抗性为10% ，就是300-10=290 ，也为100%
(26)杀怪经验倍率 1~100000% [算法相加：自身倍数(自身倍率含特殊物品倍数*经验倍数命令 ） + 元素倍率]

[@main]
#IF
CHECKNEWITEMVALUE 0 0 > 10
#ACT
GETNEWITEMVALUE 0 0 <$STR(M10)>
#SAY
你的盔甲附加了<$STR(M10)>点暴击属性！
暴击几率大于10%

说明：
CheckNewItemValue -1 0 > 10 检查升级框装备暴击几率增加 > 10
CheckNewItemValue 0 0 > 10 检查衣服暴击几率增加 > 10
CheckNewItemValue boxitem0 0 > 10 检查OK框0暴击几率增加 > 10

英雄检测命令：H.CheckNewItemValue
英雄调整命令：H.SetNewItemValue

检测命令和获取命令不包含天生元素属性（即数据库字段设置的属性）

===============================================================================================================

目标爆率（人物个怪物）算法（不描述 给大家做个详细说明吧）

1/30 井中月
1/50 血饮
1/30 无极棍
1/60 裁决之杖

以上上面为例：
目标爆率加50%如下

1/15 井中月
1/25 血饮
1/15 无极棍
1/30 裁决之杖

80%计算如下
1/6 井中月
1/10 血饮
1/6 无极棍
1/12 裁决之杖

100%计算如下（所有物品必爆）

1/0 井中月
1/0 血饮
1/0 无极棍
1/0 裁决之杖

===============================================================================================================

防爆几率指的是当自己被杀死（无论是人物还是怪物）后防止自己掉落身上、背包、神佑、首饰盒装备几率


检测人物幸运值

功能：
检测人物幸运值。

格式：
 CheckLuckPoint 控制符(=,>,<) 数量

;==========================================
[@Main]
#IF
CheckLuckPoint > 1
#SAY
幸运值大于 1
#ELSESAY
幸运值小于 1
;==========================================

#############如果上面命令不行可尝试下面的#############################

格式：
 CheckLuckPointy 控制符(=,>,<) 数量

;==========================================
[@Main]
#IF
CheckLuckPointy > 1
#SAY
幸运值大于 1
#ELSESAY
幸运值小于 1
;==========================================


检测人物在线时长[!]

功能：
可以检查人物在线时间长度。

格式：
ONLINELONGMIN (> < =) 支持变量操作
;==========================================
#if
ONLINELONGMIN > 10
#say
在线时间大于 10分钟
;==========================================


检测杀人者是人物还是怪物

功能：
人物是被怪物杀死还是玩家杀死 死亡触发

格式：

;==========================================
[@PlayDie]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你被英雄【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
CHECKCURRTARGETRACE = 151
#ACT
SENDMSG 6 你被分身【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#OR
;检测是否被NPC命令杀死，如KILL杀死，10和15分别人普通NPC和常规NPC，一般情况用不上本项检测
CHECKCURRTARGETRACE = 10
CHECKCURRTARGETRACE = 15
#ACT
SENDMSG 6 被NPC命令杀死了
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

;======================下面变量获取角色和怪物完整名字==========================

增加变量以显示完整名（不去数字）：<$CURRRTARGETFULLNAME>

上面演示脚本中变量不获取角色以及怪物名字后面的数字：<$CURRRTARGETNAME>

提供2种变量大家自己按需使用！

其它相关检测命令说明：
KillByHum 检测人物杀死为显示人物，宝宝杀死则为怪物（非人物）
CheckKillByHum 检测为凶手为人物包含人物的任意下属 （含宝宝，英雄和英雄宝宝均检测为人物）
$KILLER 变量显示配合CheckKillByHum 检测，凶手名字全部为人物名字（无论是宝宝，英雄和英雄宝宝均显示人物名字）

[@PlayDie]
#IF
CheckKillByHum
#ACT
SendMsg 5 玩家 <$KILLER> 在%m 把你干死了!
#ELSEACT
SendMsg 5 怪物 <$KILLER> 在%m 把你干死了!


检测是不是在摆摊

格式: CHECKSHOPSTALLSTATUS

[@main]
#IF
CHECKSHOPSTALLSTATUS
#SAY
正在摆摊
#ELSE
没有摆摊


检测是否进入攻城的范围

格式: CHECKCASTLEWARAREA 城堡名称

[@Main]
#IF
CHECKCASTLEWARAREA 沙巴克
#SAY
你已经进入进入攻城的范围


检测是否正在攻城

格式: CHECKUNDERWAR 城堡名称

[@Main]
#IF
CHECKUNDERWAR 沙巴克
#SAY
沙巴克正在攻击战


检测玩家是否在线

功能：
检查玩家是否在线。

格式：
 CheckOnline 人物名字

;==========================================

[@Test]
#IF
CheckOnline 人物名字
#Say
在线
#elsesay
不在线
;==========================================


检测物品的附加属性值

功能： 获取物品的附加属性值

格式: 格式: CHECKITEMADDVALUE 装备位置(-1时是升级OK框中的装备, boxitem0 -boxitem7为自定义OK框，0-51时是穿在身上的装备) 属性位置(0-18) (符号 < > =) 值 保存变量

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久
15 所需等级（不支持混合等级需求，如指定职业及指定等级组合）
16 刺术
17 箭术
18 武力

例子:?
#IF
CheckItemAddValue 0 0 > 1
#ACT
GETITEMADDVALUE 0 0 <$STR(M10)>
;H.GETITEMADDVALUE 0 0 <$STR(M10)>
#SAY
你的盔甲附加了<$STR(M10)>点防御属性.


检测在安全区

INSAFEZONE


检测指定范围内的人物数量

CheckRangeHumCount 地图名称 X Y 范围 (<,>,=) 数量


检测装备星星数量

功能: 检测装备星星数量

格式:
 检测人物星星数量
CheckUpgradeCount 物品位置 (<,>,=) 星星数量

检测英雄星星数量
H.CheckUpgradeCount 物品位置 (<,>,=) 星星数量

位置介绍：

物品位置:
-1 升级框中星星数量
-2 全身星星数量
boxitem0-boxitem7 自定义OK框
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 灵玉
18 时装衣服
19 时装武器
20 时装项链
21 时装头盔
22 时装左手镯
23 时装右手镯
24 时装左戒指
25 时装右戒指
26 时装勋章
27 时装腰带
28 时装靴子
29 时装宝石
30-35 首饰盒
40-51 生肖盒

示例：

#IF
CheckUpgradeCount 5 > 1
#SAY
武器星星数量大于1.


检测组队人数[!]

功能：
可以检查人物组队人数。

格式：
CHECKGROUPMEMBERCOUNT (<,>,=) 数量
;==========================================
#if
CHECKGROUPMEMBERCOUNT > 10
#say
组队人数大于10个人
;==========================================


检查宝宝数量

功能：
可以检查玩家所带宠物的数量。

格式：
CHECKSLAVECOUNT 控制符 <.=.> 数量

CHECKBBCOUNT 控制符 <.=.> 数量 ；也是检查宝宝的命令自己试试把

;==========================================
;检查宝宝数量是否为指定数量
[@checkslavecount0]
#IF
#ACT
CHECKSLAVECOUNT = 5
#SAY
你的宝宝数量为5个。
#ELSESAY
你的宝宝数量不为5个。
;==========================================

;==========================================
;检查宝宝数量是否为大于数量
[@checkslavecount1]
#IF
#ACT
CHECKSLAVECOUNT > 5
#SAY
你的宝宝数量超过5个。
#ELSESAY
你的宝宝数量不超过5个。
;==========================================

;==========================================
;检查宝宝数量是否为小于数量
[@checkslavecount2]
#IF
#ACT
CHECKSLAVECOUNT < 5
#SAY
你的宝宝数量小于5个。
#ELSESAY
你的宝宝数量不小于5个。
;==========================================

;******************************2018-05-12进行扩展**************************************************

.可以检查玩家所带宝宝的数量扩展。
格式：
CHECKSLAVECOUNT 控制符 <.=.> 数量

扩展,可以检查相同名字宝宝的数量(不带宝宝名字则为检查所有宝宝)
CHECKSLAVECOUNT 控制符 <.=.> 数量 宝宝名字 是否检查名称数字(0:不检查名称数字[骷髅1,骷髅2都按包骷髅算], 1:算数字)


检查宝宝最高等级

脚本功能:
检查宝宝的等级。

命令格式:
CHECKSLAVELEVEL 控制符(=,>,<) 等级数(7)

;==========================================
;检查宝宝的等级是否等于指定级别
[@checklevel0]
#IF
CHECKSLAVELEVEL = 5
#SAY
宝宝的等级等于5级。
#ELSESAY
宝宝的等级不等于5级。
;==========================================

;==========================================
;检查宝宝的等级是否大于指定级别
[@checklevel1]
#IF
CHECKSLAVELEVEL > 5
#SAY
宝宝的等级大于5级。
#ELSESAY
宝宝的等级不大于5级。
;==========================================

;==========================================
;检查宝宝的等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKSLAVELEVEL < 5
#SAY
宝宝的等级小于5级。
#ELSESAY
宝宝的等级不小于5级。
;==========================================


检查城堡占领天数

功能：
 检查沙巴克占领天数

格式：
================================
#if
CASTLECHANGEDAY > 7
#say
你已经占领沙城7天以上.
================================

<$CASTLEGETDAYS> 沙巴克占领天数,此变量需要在沙巴克NPC中使用，比如沙皇宫管理人员


检查城堡战争天数

功能：
可以检查上次攻城到现在的天数。

格式：
 CASTLEWARAY 控制符(<=>) 天数
;==========================================
[@Main]
#IF
CASTLEWARAY > 3
#SAY
上次攻城到现在超过三天
#ELSESAY
上次攻城到现在未够三天
;==========================================


检查城门状态

功能：
可以检查沙城门状态。

格式：
;==========================================
#if
CHECKCASTLEDOOR 损坏
#say
城门损坏

#if
CHECKCASTLEDOOR 开启
#say
城门开启

#if
CHECKCASTLEDOOR 关闭
#say
城门关闭
;==========================================


检查当前所在地图的名字

功能：
检查当前所在地图的名字

格式：CHECKMAPNAME 地图名称
;==========================================
#if

CHECKMAPNAME 3

#say

你当前在地图3上\ \

<退出/@exit>

#elsesay

你当前不在地图3上\ \

<退出/@exit>

;==========================================


检查登录帐号与IP是否匹配

功能：
可以检查登录帐号与IP是否匹配。

格式：
CHECKACCOUNTIPLIST AccountIPList.txt

;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKACCOUNTIPLIST AccountIPList.txt
#SAY
您的登录帐号与指定IP匹配。
#ELSESAY
您的登录帐号与指定IP不匹配。
;==========================================

列表文件格式:
此文件们于目录：Mir200\Envir\

AccountIPList.txt

;==========================================
;登录帐号 IP
lintest 192.168.1.123
lintest1 192.168.1.124
;==========================================


检查地图怪物数量

功能：
可以检查一个地图内的怪物数量。

格式：
CheckMonMap 地图号 数量 是否检测宝宝（参数0或者留空宝宝算在里面 、1则宝宝不算到里面）

;==========================================
[@Main]
#IF
CheckMonMap 3 30
#SAY
地图3的内怪物多于100只
#ELSESAY
地图3的怪物少于100只
;==========================================


检查地图怪物数量

功能：
可以检查一个地图内的怪物数量。

格式：
CheckMapMonCount 地图号 检测符号 数量 是否检测宝宝（参数0或者留空宝宝算在里面 、1则宝宝不算到里面）

;==========================================
[@Main]
#IF
CheckMapMonCount 3 = 30
#SAY
地图3的内怪物等于30只
#ELSESAY
地图3的怪物不等于30只
;==========================================

格式：
CheckMapMonCount 地图号 检测符号<、 =、 > 数量 是否检测宝宝（参数0或者留空宝宝算在里面 、1则宝宝不算到里面）

;==========================================
[@Main]
#IF
CheckMapMonCount 3 > 30
#SAY
地图3的内怪物大于30只
#ELSESAY
地图3的怪物小于30只
;==========================================


检查对面人物的等级

功能：
 可以检查对面人物的等级（不要求面对面）。

格式：
CHECKPOSELEVEL 控制符(=,>,<) 等级数(1 - 65535)

;==========================================
;检查对面人物的等级是否等于指定级别
[@checkposelevel0]
#IF
CHECKPOSELEVEL = 50
#SAY
您对面人物的等级等于50级。
#ELSESAY
您对面人物的等级不等于50级。
;==========================================

;==========================================
;检查对面人物的等级是否大于指定级别
[@checkposelevel1]
#IF
CHECKPOSELEVEL > 50
#SAY
您对面人物的等级大于50级。
#ELSESAY
您对面人物的等级不大于50级。
;==========================================

;==========================================
;检查对面人物的等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKPOSELEVEL < 50
#SAY
您对面人物的等级小于50级。
#ELSESAY
您对面人物的等级不小于50级。
;==========================================


检查对面人物的性别

功能：
 可以检查对面人物的性别（不要求面对面）。

格式：
CHECKPOSEGENDER 性别(MAN,男,WOMAN,女)

;==========================================
;检查对面人物是否为男的
[@checkposegender0]
#IF
CHECKPOSEGENDER MAN
#SAY
你对面的人物是男的。
#ELSESAY
你对面的人物不是男的。
;==========================================

;检查对面人物是否为女的
[@checkposegender1]
#IF
CHECKPOSEGENDER WOMAN
#SAY
你对面的人物是女的。
#ELSESAY
你对面的人物不是女的。
;==========================================


检查对面人物站的位置

功能：
 可以检查对面人物站的位置性别（要求面对面）。

格式：
CHECKPOSEDIR 控制符(1,2)

;==========================================
;检查对面人物是否面对面
[@checkposedir0]
#IF
CHECKPOSEDIR
#SAY
你二个站的位置正确。
#ELSESAY
你二个站的位置不正确。
;==========================================

;==========================================
;检查对面人物是否面对面，而且要求二个人相同性别
[@checkposelevel0]
#IF
CHECKPOSEDIR 1
#SAY
你二个站的位置及性别一样。
#ELSESAY
你二个站的位置不正确或性别不一样。
;==========================================

;==========================================
;检查对面人物是否面对面，而且要求二个人不同性别
[@checkposelevel0]
#IF
CHECKPOSEDIR 2
#SAY
你二个站的位置及性别不一样。
#ELSESAY
你二个站的位置不正确或性别一样。
;==========================================


检查行会名称

功能：
 检查行会名称

格式：
================================
#if
CHECKOFGUILD 行会名称
#say
行会正确
================================


检查行会是否在列表中

功能：
检查行会是否在列表中

格式：
================================
[@checkGuild]
#IF
CHECKGUILDLIST GuildList.txt
#SAY
列表中有行会。
#ELSESAY
列表中没有行会。
================================


检查会员时间

相关命令：
CHECKUSERDATE 会员.txt < 30 p0 p1
检查命令 会员名单 控制符 天数 使用天数 剩余天数（可用<$STR(p1)>在脚本中显示)
注：如果要检查忽略人物名字就在p1 后面加个参数 1

加入会员人物及时间： ADDUSERDATE 会员.txt
删除会员人物及时间： DELUSERDATE 会员.txt


检查金刚石数量

功能：
 检查金刚石数量。

格式：
 CHECKGAMEDIAMOND 控制符(<、>、 =) 点数

GAMEDIAMOND (+,-,=) 值
<$GAMEDIAMOND>

;==========================================
#IF
CHECKGAMEDIAMOND> 50
#SAY
你的金刚石超过50点
#ELSESAY
你的金刚石少于50点
;==========================================

功能：
 检查灵符数量。

格式：
 CHECKGAMEGIRD 控制符(<、>、 =) 点数

GAMEGIRD (+,-,=) 值
<$GAMEGIRD>

;==========================================
#IF
CHECKGAMEGIRD > 50
#SAY
你的灵符超过50点
#ELSESAY
你的灵符少于50点
;==========================================

功能：
 检查荣誉数量。

格式：
 CHECKGAMEGLORY 控制符(<、>、 =) 点数

GAMEGLORY (+,-,=) 值
<$GAMEGLORY>

;==========================================
#IF
CHECKGAMEGLORY > 50
#SAY
你的荣誉超过50点
#ELSESAY
你的荣誉少于50点
;==========================================


检查人物HP值

功能：
用来检查人物HP值的上限及下限值

命令格式：
 CHECKHP 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限

======================
#if
CHECKHP > 30 > 40
#say
你的HP值大于30-40
======================


检查人物MP值

功能：
 用来检查人物MP值的上限及下限值

命令格式：
 CHECKMP 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限

==========================
#if
CHECKMP > 30 > 40
#say
你的MP值大于30-40
==========================


检查人物背包空格数

功能：
检查人物背包空格数

命令：
 CheckBagSize 数量

=======================
[@checkbagsize]
#if
CHECKBAGSIZE 5
#say
身上有5个空格
#elsesay
身上的空格不够。
=======================


检查人物当前经验值

功能：
 检查玩家当前经验值。

格式：
CHECKEXP 控制符(=,>,<) 经验值(1 - 4000000000)< /FONT>

;==========================================
;检查人物的经验值是否等于指定值
[@checkexp2]
#IF
CHECKEXP = 5000
#SAY
您的经验值等于5000。
#ELSESAY
您的经验值不等于5000。
;==========================================

;==========================================
;检查人物的经验值是否大于指定值
[@checkexp2]
#IF
CHECKEXP > 5000
#SAY
您的经验值大于5000级。
#ELSESAY
您的经验值不大于5000。
;==========================================

;==========================================
;检查人物的经验值是否小于指定值
[@checkexp2]
#IF
CHECKEXP < 5000
#SAY
您的经验值小于5000级。
#ELSESAY
您的经验值不小于5000。
;==========================================


检查人物道术

功能：
 用来检查人物道术的上限及下限值

命令格式：
 CHECKSC 控制符(<、>、 =) 攻击下限 控制符(<、>、 = ) 攻击上限

================
#if
CHECKSC > 30 > 40
#say
你的道术大于30-40
================


检查人物的会员等级

功能：
 可以检查人物的会员等级。

格式：
CHECKMEMBERLEVEL 类型(1-65535) 控制符(=,>,<) 等级数(1 - 65535)

;==========================================
;检查人物的会员等级是否为指定等级
[@checkmemberlevel0]
#IF
CHECKMEMBERLEVEL 2 = 5
#SAY
您的会员等级为5。
#ELSESAY
您的会员等级不为5。
;==========================================

;==========================================
;检查人物的会员等级是否大于指定等级
[@checkmemberlevel1]
#IF
CHECKMEMBERLEVEL 2 > 5
#SAY
您的会员等级大于5。
#ELSESAY
您的会员等级不大于5。
;==========================================

;==========================================
;检查人物的会员等级是否小于指定等级
[@checkmemberlevel1]
#IF
CHECKMEMBERLEVEL 2 < 5
#SAY
您的会员等级小于5。
#ELSESAY
您的会员等级不小于5。
;==========================================


检查人物的会员类型

功能：
可以检查人物的会员类型。

格式：
CHECKMEMBERTYPE 控制符(=,>,<) 类型数(1 - 65535)

;==========================================
;检查人物的会员类型是否为指定类型
[@checkmember0]
#IF
CHECKMEMBERTYPE = 5
#SAY
您的会员类型为5。
#ELSESAY
您的会员类型不为5。
;==========================================

;==========================================
;检查人物的会员类型是否大于指定类型
[@checkmember1]
#IF
CHECKMEMBERTYPE > 5
#SAY
您的会员类型大于5。
#ELSESAY
您的会员类型不大于5。
;==========================================

;==========================================
;检查人物的会员类型是否小于指定类型
[@checkmember1]
#IF
CHECKMEMBERTYPE < 5
#SAY
您的会员类型小于5。
#ELSESAY
您的会员类型不小于5。
;==========================================


检查人物的游戏点数

功能：
 用于配合泡点功能，检查当前人物身上有多少点数。

格式：
 CHECKGAMEPOINT 控制符(<、>、 =) 点数

;==========================================
#IF
CHECKGAMEPOINT > 50
#SAY
你的游戏点超过50点
#ELSESAY
你的游戏点少于50点
;==========================================

功能：
 检查当前人物身上有多少游戏币。

格式：
 CHECKGAMEGOLD 控制符(<、>、 =) 点数

;==========================================
#IF
CHECKGAMEGOLD > 50
#SAY
你的游戏币超过50点
#ELSESAY
你的游戏币少于50点
;==========================================


检查人物的转生等级

功能：
 检查人物的转生等级

命令格式:
 CHECKRENEWLEVEL 控制符(=,>,<) 转生等级数(1 - 255)

检测英雄等级命令：H.checkrenewlevel

;==========================================
;检查人物的转生等级是否等于指定级别
[@checklevel0]
#IF
CHECKRENEWLEVEL = 5
#SAY
您的转生等级等于5级。
#ELSESAY
您的转生等级不等于5级。
;==========================================

;==========================================
;检查人物的转生等级是否大于指定级别
[@checklevel1]
#IF
CHECKRENEWLEVEL > 5
#SAY
您的转生等级大于5级。
#ELSESAY
您的转生等级不大于5级。
;==========================================

;==========================================
;检查人物的转生等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKRENEWLEVEL < 5
#SAY
您的转生等级小于5级。
#ELSESAY
您的转生等级不小于5级。
;==========================================


检查人物登录IP

功能：
检查人物登录IP.

格式：
 CHECKIPLIST 会员.txt

;==========================================
;按IP检查
[@checkiplist0]
#IF
CHECKIPLIST IP会员.txt
#SAY
你是会员
#ELSESAY
你不是会员
;==========================================


检查人物登录帐号

功能：
检查人物登录帐号.

格式：
 CHECKACCOUNTLIST 帐号.txt

;==========================================
;按登录帐号检查
[@checkaccountlist0]
#IF
CHECKACCOUNTLIST 帐号.txt
#SAY
你是会员
#ELSESAY
你不是会员
;==========================================


检查人物等级（改进）

功能：
可以更为方便地检查玩家等级。

格式：
CHECKLEVELEX 控制符(=,>,<) 等级数(1 - 65535)

;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKLEVELEX = 50
#SAY
您的等级等于50级。
#ELSESAY
您的等级不等于50级。
;==========================================

;==========================================
;检查人物的等级是否大于指定级别
[@checklevel1]
#IF
CHECKLEVELEX > 50
#SAY
您的等级大于50级。
#ELSESAY
您的等级不大于50级。
;==========================================

;==========================================
;检查人物的等级是否小于指定级别
[@checkposelevel2]
#IF
CHECKLEVELEX < 50
#SAY
您的等级小于50级。
#ELSESAY
您的等级不小于50级。
;==========================================


检查人物附加属性点数

功能：
检查人物附加属性点数

格式：
CHECKBONUSPOINT 控制符(=,>,<) 点数

相关命令：
复位属性点数：RESTBONUSPOINT
调整属性点数：BONUSPOINT


检查人物攻击力

功能：
用来检查人物攻击力的上限及下限值

命令格式：
 CHECKDC 控制符(<、>、 =) 攻击下限 控制符(<、>、 =) 攻击上限

====================
#IF
CHECKDC > 30 > 40
#say
你的攻击力大于30-40
====================


检查人物技能(扩展)

检查人物技能

功能：
检查人物技能

格式：
CHECKSKILL 技能名称 检测符(>,<,=) 等级 是否检测强化技能(0或为空时为技能等级,1为强化技能等级)

例：
[@main]
#IF
CHECKSKILL 冰咆哮 = 0 1
#ACT
SKILLLEVEL 冰咆哮 = 1 1
SENDMSG 6 冰咆哮已修炼到强化一重

相关命令：
练习技能：ADDSKILL
删除技能：DELSKILL
删除非本职业所有技能：DELNOJOBSKILL
删除所有技能：

英雄练习技能：H.ADDSKILL
删除英雄技能：H.DELSKILL
删除英雄非本职业所有技能：H.DELNOJOBSKILL
删除所有技能：H.CLEARSKILL

强化技能升级，技能栏"升级"鼠标移上去提示的配置文件：客户端目录\data\SkillUpgradeDesc.Dat(以下为示例：)

;技能类型(普通技能/内功技能),技能名,需要强化等级,强化描述(描述使用,换行 参考9重)
普通技能,攻杀剑术,1,111111111111
普通技能,攻杀剑术,2,222222222222
普通技能,攻杀剑术,3,333333333333333
普通技能,攻杀剑术,4,44444444444444444
普通技能,攻杀剑术,5,5555555555555555555555
普通技能,攻杀剑术,6,6666666666666666666666
普通技能,攻杀剑术,7,77777777777777777
普通技能,攻杀剑术,8,8888888888888888888
普通技能,攻杀剑术,9,升到9级要好多毛线的,你确定要升级????????


检查人物名称是否与IP匹配

功能：
可以检查登录帐号与IP是否匹配。

格式：
CHECKNAMEIPLIST NameIPList.txt

;==========================================
;检查人物的等级是否等于指定级别
[@checklevel0]
#IF
CHECKNAMEIPLIST NameIPList.txt
#SAY
您的登录帐号与指定IP匹配。
#ELSESAY
您的登录帐号与指定IP不匹配。
;==========================================

列表文件格式:
此文件们于目录：Mir200\Envir\

NameIPList.txt

;==========================================
;人物名称 IP
GM001 192.168.1.123
GM002 192.168.1.124
;==========================================


检查人物魔法力

功能：
用来检查人物魔法力的上限及下限值

命令格式：
 CHECKMC 控制符(<、>、 =) 攻击下限 控制符(<、>、 =) 攻击上限

======================
#if
CHECKMC > 30 > 40
#say
你的魔法力大于30-40
======================


检查人物身上指定位置是否戴物品

功能：
检查人物身上指定位置是否戴物品

命令：
 CHECKUSEITEM 物品位置(0-18)

物品位置:
0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 灵玉
18 时装衣服
19 时装武器
20 时装项链
21 时装头盔
22 时装左手镯
23 时装右手镯
24 时装左戒指
25 时装右戒指
26 时装勋章
27 时装腰带
28 时装靴子
29 时装宝石
30-35 首饰盒
40-51 生肖盒

[@checkUseItem]
#if
CHECKUSEITEM 0
#say
你身上穿了衣服。
#elsesay
你还没穿衣服呢。


检查人物身上装备类型

功能：
用来检查人物身上戴物品类型，因为不同类型物品的附加属性值位置不一样，在升级装备物品性时用来控制指定属性值。
命令格式：
 CHECKITEMTYPE 物品位置 物品类型

物品位置：
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石

物品类型：
5 武器
6 武器
10 衣服
11 衣服
15 头盔
19 项链
20 项链
21 项链
22 戒指
23 戒指
24 手镯
25 护身符
26 手镯
28 马牌
30 照明物
52 鞋子
53 宝石
54 腰带

位置支持： boxitem0——boxitem7： 自定义OK框
0 ———————25: 装备位置
30———————35: 首饰盒
40———————51： 神佑
-1： 升级框


检查人物声望点

功能：
检查人物声望点

命令格式:
CHECKCREDITPOINT 控制符(=,>,<) 声望点数(1 - 255)< /FONT>

;==========================================
;检查声望点是否等于指定点数
[@CHECKCREDITPOINT0]
#IF
CHECKCREDITPOINT = 50
#SAY
您声望点等于50级。
#ELSESAY
您声望点不等于50级。
;==========================================

;==========================================
;检查声望点是否大于指定点数
[@CHECKCREDITPOINT1]
#IF
CHECKCREDITPOINT > 50
#SAY
您声望点大于50级。
#ELSESAY
您声望点不大于50级。
;==========================================

;==========================================
;检查声望点是否小于指定点数
[@CHECKCREDITPOINT2]
#IF
CHECKCREDITPOINT < 50
#SAY
您声望点小于50级。
#ELSESAY
您声望点不小于50级。
;==========================================


检查人物是否付费

#if
CHECKPAYMENT 2
#say


检查人物是否加入行会

功能：
可以检查玩家是否加入行会。

格式：
============================
#IF
HAVEGUILD
#SAY
你已经加入了行会！
#ELSESAY
你没加入行会！
============================


检查人物是否为管理员

功能：
检查人物是否为管理员

格式：
;==========================================
;检查人物是否为系统管理员
[@IsSysOp]
#IF
ISADMIN
#SAY
你是系统管理员。
#ELSESAY
你不是系统管理员。
;==========================================


检查人物是否为行会掌门人

功能：
可以检查玩家是否为行会老大。

格式：
============================
#IF
ISGUILDMASTER
#SAY
你是行会老大！
#ELSESAY
你不是行会老大！
============================


检查人物是否为沙城成员

功能：
可以检查玩家是否为沙城成员。

格式：
============================
#IF
ISCASTLEGUILD
#SAY
你是沙城成员！
#ELSESAY
你不是沙城成员！
============================


检查人物是否为沙城城主

功能：
可以检查玩家是否为沙城老大。

格式：
============================
#IF
ISCASTLEMASTER
#SAY
你是沙城老大！
#ELSESAY
你不是沙城老大！
============================


检查人物是否为新人

功能：
可以检查玩家是否为新人（即刚注册进入游戏的人，退出后再进就不是新人了）。

格式：
============================
#IF
ISNEWHUMAN
#SAY
你是新人！
#ELSESAY
你不是新人！
============================


检查人物是否在攻城区域[!]

功能: 检查人物是否在攻城区域
格式: CheckInWarArea

#IF
CheckInWarArea
#SAY
在攻城区域.


检查人物在列表中的位置

功能：
检查人物在列表中的位置。

格式：
 CHECKNAMELISTPOSITION List.txt (> < = ) 10 P0

;==========================================
;
[@checkpostion0]
#IF
CHECKNAMELISTPOSITION AccountIPList.txt < 10 P0
#SAY
您在前10名，当前排名为<$STR(P0)>。
#ELSESAY
您不在前10名，当前排名为<$STR(P0)>。。
;==========================================


检查是否为组长

功能：
检查人物是否为编组的组长
格式：
ISGROUPMASTER
[@checkgroup]

#if
ISGROUPMASTER
#say
你是组长
#elsesay
你不是组长

相关命令：
编组地图传送：GROUPMAPMOVE
编组地图随机传送：GROUPMOVE


检查是否在某地图

ISONMAP 地图名称


检查一个地图内人数

功能：
可以检查一个地图内的人物数量。

格式：
CheckMapHumanCount 地图号 ('<' '>' '=')数量

;==========================================
[@Main]
#if
CheckMapHumanCount 3 < 100
#say
地图3内人数小于100人
#elsesay
地图3内人数多于100人

;==========================================


检查字符串是否在指定文件中[!]

[@旧格式_不区分大小写]
#IF
CHECKTEXTLIST ..\QuestDiary\充值系统\10元卡号.txt <$STR(S2)>
#SAY
<$STR(S2)>在列表中
#ELSESAY
<$STR(S2)>不在列表中

[@新格式_区分大小写]
#IF
CHECKTEXTLIST ..\QuestDiary\充值系统\10元卡号.txt <$STR(S2)> <$STR(S3)>
#SAY
卡号密码正确
#ELSESAY
卡号密码错误

S2和S3的值在“10元卡号.txt”文本中以空格分开

=================================================================

增加缓存操作指令CheckCacheTextList 使用方法等同checktextlist 区别就是内存中操作

=================================================================

--------------------------------------------2019-01-31更新扩展参数5----------------------------------------------------------------------------------------
CheckTextList 文件名 检测字符串1 检测字符串2(可为空) 是否绝对路径(为空表示相对路径) 是否区分大小写（0或空：不区分； 1：区分）
注：当字符串2可用'' 或 ""表示空
----------------------------------------------------------------------------------------------------------------------------------

示范脚本：
[@main]
<检测D001是否在列表中/@检测D001是在列表中1>\
<检测A001是否在列表中/@检测A001是在列表中1>\
<检测T001是否在列表中/@检测T001是在列表中1>\
<检测字符变量值D001是否在列表中/@检测字符变量值D001是否在列表1>\
<检测字符变量值T001是否在列表中/@检测字符变量值T001是否在列表1>\
<检测字符变量值Da11是否在列表中/@检测字符变量值Da11是否在列表1>\
<检测人物名字变量是否在列表中/@检测人物名字是否在列表1> <$USERNAME> 请把你的人物名字放进列表中再测试 \
<检测服务器名字变量是否在列表中/@检测服务器名字是否在列表1> <$SERVERNAME> 请把你的服务器名字放进列表中再测试 \

[@检测服务器名字是否在列表1]
#IF
CHECKTEXTLIST ..\QuestDiary\列表.txt <$SERVERNAME>
;此处CHECKTEXTLIST无法识别 <$USERNAME> <$BOXITEM[X].NAME> <$STR(S$人物名称)>这些类型变量 现在只支持读取<$STR(XX)>这类变量
#ACT
#SAY
<$SERVERNAME>在列表中
#ELSESAY
<$SERVERNAME>不在列表中

[@检测人物名字是否在列表1]
#IF
CHECKTEXTLIST ..\QuestDiary\列表.txt <$USERNAME>
;此处CHECKTEXTLIST无法识别 <$USERNAME> <$BOXITEM[X].NAME> <$STR(S$人物名称)>的这些类型变量
#ACT
#SAY
<$USERNAME>在列表中
#ELSESAY
<$USERNAME>不在列表中

[@检测字符变量值Da11是否在列表1]
#IF
#ACT
MOV S1 Da11

#IF
CHECKTEXTLIST ..\QuestDiary\列表.txt <$STR(S1)>
#ACT
#SAY
<$STR(S1)>在列表中
#ELSESAY
<$STR(S1)>不在列表中

[@检测字符变量值T001是否在列表1]
#IF
#ACT
MOV S1 T001

#IF
CHECKTEXTLIST ..\QuestDiary\列表.txt <$STR(S1)>
;此处CHECKTEXTLIST无法识别 S1的变量值
#ACT
#SAY
<$STR(S1)>在列表中
#ELSESAY
<$STR(S1)>不在列表中 此处有问题

[@检测字符变量值D001是否在列表1]
#IF
#ACT
MOV S1 D001
#IF

CHECKTEXTLIST ..\QuestDiary\列表.txt <$STR(S1)>
;此处CHECKTEXTLIST无法识别出 S1的变量值 估计是把S1的变量值当成了变量
#ACT
#SAY
<$STR(S1)>在列表中
#ELSESAY
<$STR(S1)>不在列表中 此处有问题

[@检测T001是在列表中1]
#IF
CHECKTEXTLIST ..\QuestDiary\列表.txt T001
#ACT
#SAY
T001在列表中
#ELSESAY
T001不在列表中

[@检测A001是在列表中1]
#IF
#ACT
MOV S1 A001
;检测条件第一个字母为变量字母的需规避

#IF
CHECKTEXTLIST ..\QuestDiary\列表.txt A001
;比如这里S1直接写A001就无法解析的，<$STR(S1)>也无法解析，必须S1，开头字母需规避变量字母
#SAY
A001在列表中
#ELSESAY
A001不在列表中

[@检测D001是在列表中1]
#IF
CHECKTEXTLIST ..\QuestDiary\列表.txt D001
#ACT
#SAY
D001在列表中
#ELSESAY
D001不在列表中

------------------------------------------------
..\QuestDiary\列表.txt

列表.TXT里面的内容

D001
TAa1
Da11
D002
C001
A001
G001
GG001
T001
11111
暗杀来袭1区


脚本检测命令取反NOT[!]
格式:NOT 命令 > 50 //检测人物物品算不大于50

例子:

[@main]
#IF
NOT CHECKGAMEGOLD > 50 //检测人物元宝算不大于50
#ACT
SENDMSG 5 你身上没有50元宝

[@main_1]
#IF
NOT CHECKLEVELEX > 80 //检测人物等级不大于80级
#ACT
SENDMSG 5 你的等级不足80级

[@main_2]
#IF
NOT EQUAL P0 5 //检测变量P0是否不等于5
#ACT
SENDMSG 5 <$STR(P0)>变量不等于5

[@main_3]
#IF
NOT H.CHECKLEVELEX > 80 //检测英雄等级不大于80级
#ACT
SENDMSG 5 你的英雄等级不足80级


脚本性能原子钟，检测脚本运行时间

脚本性能检测，用于检测脚本运行时间:

;======================================================

计时功能：PrintUseTime 参数1(1/2) 参数2(数字变量) 参数3(文本变量)
参数1如下：
1：表示计时开始（参数2和参数3为空）
2：表示计算结束，参数2（必填参数）得到耗时时间（微秒）；参数3（可选）会根据耗时时间自动填充对应的单位

示例：

[@测试1]
#if
#act
PrintUseTime 1
[@测试2]
#if
#act
PrintUseTime 2 N0 S0
Sendmsg 6 提示:脚本执行耗时<$STR(N0)>微秒，自动单位为<$STR(S0)>

[@测试3]
#if
#act
PrintUseTime 1
MOV N0 0
MOV N1 1
WHILE N1 < 10000
INC N0 N1
INC N1 1
ENDWHILE
PrintUseTime 2 N2 S2
Sendmsg 6 提示:脚本执行耗时<$STR(N2)>微秒，自动单位为<$STR(S2)>

用于检测自己脚本执行时间，一般用于脚本优化


扩展check支持批量检测个人标识

扩展check支持批量检测

check支持批量检测

多个非连续的标识可以用逗号隔开，连续可用 - 串联
格式：check [1,2,4-6,8] 1

#if
check [1,2,4-6,8] 1
#act
SENDMSG 6 1,2,4,5,6,8全为1

SET支持批量设置个人标识

格式：
SET [1,2,4-6,8] 1
SET [1,2,4-6,<$STR(N$变量)>] 1

个人标识取反 set [n] -1

; 新增方式 set [n] -1

[@main1]
个人标识9的值为：<$flag(9)> \
<修改flag_9/@修改flag9>\
<flag取反_9/@取反flag9>

[@取反flag9]
#act
set [9] -1
goto @main1

[@修改flag9]
#IF
check [9] 0
#act
set [9] 1
goto @main1
#elseact
set [9] 0
goto @main1

特别注意：个人标识从1开始，0是无效的！！！


判断对面对象的类型

功能说明: 判断对面对象的类型

说明：CheckPoseActor 参数1(0:人物;1:英雄;2:分身;3:怪物(含宝宝/宠物))

--------------------------------------------------------

示例脚本：

[@MAIN]
#IF
CheckPoseActor 0
#SAY
你对面是人物


战斗状态禁止退出

功能：战斗状态禁止退出：

位置：选项 - 参数设置 - 战斗禁止退出

图示：

.

根据需求自行调整参数选项进行设置

;===================================================

检测人物是否处于战斗状态

命令： CheckBattleStatus

示范脚本

[@战斗状态]
#IF
CheckBattleStatus
#act
SENDMSG 6 处于战斗状态
#ELSEACT
SENDMSG 6 非战斗状态


字符串比较处理

功能：
字符串比较处理。

格式：
CheckContainsText 字符 字符串检查 //检查字符串是否包涵在另外一个字符串中.
CompareText 字符 字符 // 比较两个字符串是否一样

;==========================================
检查字符串是否包涵在另外一个字符串中
[@Test]
#IF
CheckContainsText www.lfm2.com lfm2.com
#Say
包涵
#elsesay
不包涵
;==========================================

;==========================================
比较两个字符串是否一样
[@Test]
#IF
CompareText www.lfm2.com www.lfm2.com
#Say
一样
#elsesay
不一样
;==========================================


检测坐标范围
用于地图事件触发CheckInMapRange

如：

[@OnTimer12]
#IF
CheckInMapRange 3 354 337 0
;检测是否在地图3 坐标354 337 为中心，范围0
#elseact
SetOffTimer 12
break
#IF
CheckInMapRange 3 354 337 0
#ACT
CHANGEEXP + 200000
break


ClientMerchantDlgSelect接收到非法请求？,防刷封包,防刷跳转

特殊字段应用，NPC脚本使用@_@

特殊字段@_@只允许使用在不需要客户端登录器点击的NPC字段，可有效避免封包刷脚本！只要不涉及靠登录器点击的均可使用@_@

<测试特殊字段/@_@特殊字段> ;------->登录器是无法点击执行的 ，这种需要点击的不要使用！！！！！

----------------------------------------------------------

[@特殊字段]
#ACT
goto @_@特殊字段

[@_@特殊字段] ;--------------------> 封包是无法刷@_@字段的脚本的
#ACT
SENDMSG 6 ok

特殊字段[@_@XXXX] 只可以CALL 、GOTO 、DelayCall 、SendCenterMsg 、 DelayGoto、SENDDELAYMSG ，和任何不需要点击的脚本！！！！

如果不理解可以在QQ群内交流使用！！！


自定义装备框[!]
本功能在未注册状态下，在线人数低于2人可开启所有装备框，超过2人则只可开启2个框（已经开启的框不受影响可正常使用）

增加NPC检测命令：

1. 检测自定义装备框是否开启

命令格式：CheckCustomItemOpen 装备框位置(0-49)

2. 物品位置修改(CheckUseItem, GetItemFieldValue 所有和物品位置有关的，部分命令不支持OK框和升级框，具体看文档)

物品位置代码 | 物品位置说明 (所有装备位置参考如下）
-1 | 升级框
boxitem0-boxitem7 | OK框
0 | 盔甲
1 | 武器
2 | 照明物（蜡烛，此物品属性升级无效）
3 | 项链
4 | 头盔
5 | 左手镯
6 | 右手镯
7 | 左戒指
8 | 右戒指
9 | 护身符
10 | 腰带
11 | 鞋子
12 | 宝石
13 | 斗笠
14 | 军鼓
15 | 马牌
16 | 盾牌
17 | 灵玉
18 | 时装衣服
19 | 时装武器
20 | 时装项链
21 | 时装头盔
22 | 时装左手镯
23 | 时装右手镯
24 | 时装左戒指
25 | 时装右戒指
26 | 时装勋章
27 | 时装腰带
28 | 时装靴子
29 | 时装宝石
30-35 | 首饰盒
40-51 | 生肖盒
70-75 | 时装生肖盒
80-91 | 时装生肖盒
200-249 | 自定义装备框

增加NPC执行命令：

1. 开启自定义装备框

命令格式：OpenCustomItem 装备框位置(0-49) 支持物品StdMode(,分隔，最多10个)

2. 关闭自定义装备框

命令格式：CloseCustomItem 装备框位置(0-49) 是否删除对应的按钮(0:不删;1:删除)
命令说明：如果装备框中有物品，则物品会返回到背包，如果背包装不上，则丢地上

3. 显示自定义装备框按钮到界面

命令格式: ShowCustomItem 装备框位置(0-49) 界面位置 图片wzl 图片序号 坐标X 坐标Y 是否使用内观图片(0:不用,1:使用) 提示文字

英雄操作命令请在命令前面加H.
界面位置代码 | 界面位置说明
0 | 主界面-不能移动
1 | 主界面-可以移动
2 | 人物装备栏
3 | 人物背包栏
4 | 英雄装备栏
5 | 英雄背包栏
6 | 聊天框左侧龙界面
7 | 聊天框右侧等级界面
8 | 商铺界面
9 | 时装界面
10 | 英雄时装
11 | 技能栏
12 | 英雄技能栏
13 | 称号栏
14 | 英雄称号栏
15 | 状态栏
16 | 英雄状态栏
17 | 属性栏
18 | 英雄属性栏
19 | 人物出战栏
20 | 行会界面
21 | 详细属性位置
22 | 宠物界面
24 | 人物首饰
25 | 英雄首饰
26 | 人物神佑
27 | 英雄神佑
28 | 查看他人装备
29 | 查看他人时装
30 | 查看他人称号
31 | 查看他人首饰盒
32 | 查看他人神佑袋
33 | M大地图
34 | 英雄出战栏
35 | 查看他人出战栏
36 | 人物时装首饰
37 | 英雄时装首饰
38 | 他人时装首饰
39 | 人物时装神佑
40 | 英雄时装神佑
41 | 他人时装神佑

注意：以上为自定义装备框可放入的地方，但是也不要滥用，建议人物和英雄装备栏相关位置不要混用.

说明：英雄出战栏和他人出战栏，在界面中默认是隐藏状态，可以在自定义UI中开启

界面位置相关命令：AddButton, AddArrButton, AddNumberButton, AddDlg, AddDlgEx

自定义装备框放入物品说明：

物品数据库CustomItem字段值100-149和200-249分别对应自定义装备框位置0-49

StdItems表增加了一个字段：CustomItem，值如下

值 | 说明
0 | 原装备框
1 | 所的自定义装备框 （不支持双击或右键穿戴，仅限手动穿戴）
2 | 原装备+所有自定义装备（双击或右键穿戴到默认装备位置，自定义位置需手动）
100-149 | 仅指定自定义装备框（双击或右键穿戴到对应的自定义位置）
200-249 | 原装备框+指定自定义装备框（双击或右键优先穿戴到自定义的装备位置，如果自定义框未开启或StdMode不对，则穿到默认位置）

增加NPC变量：

取自定义装备框物品数据库名称：<$CustomItem0> ------- <$CustomItem49>
取自定义装备框物品改名后名称：<$G_CustomItem0> ------- <$G_CustomItem49>

[@Main]
你的装备框0放入的物品是【<$CustomItem0>】\\
<开自定义装备框/@开自定义装备框>  <显示自定义装备框/@显示自定义装备框>   <关闭自定义装备框/@关闭自定义装备框>\\
<CustomItem:0:1:1549:1:2:提示文字>

[@开自定义装备框]
#IF
not CheckCustomItemOpen 0
#ACT
;开启自定义装备框0;stdmode=5,6最多支持10个
OpenCustomItem 0 5,6
SendMsg 6 已成功开启自定义装备框0

[@显示自定义装备框]
#IF
not CheckCustomItemOpen 0
#ACT
;显示装备框0到人物装备栏，Newopui.pak
ShowCustomItem 0 2 1 1635 240 30 0 提示文字
SendMsg 6 显示自定义装备框0到人物装备栏中了
#ELSEACT
;显示装备框0到人物装备栏，Newopui.pak
ShowCustomItem 0 2 1 1549 240 30 0 提示文字
SendMsg 6 显示自定义装备框0到人物装备栏中了

[@关闭自定义装备框]
#IF
; 检测装备框1是否放了物品
CheckUseItem 200
#ACT
SendMsg 6 你的自定义装备框0上面放了物品，物品将会自动返回到背包

#IF
#ACT
CloseCustomItem 0 1
SendMsg 6 已经关闭了自定义装备框0，并且自动删除对应的按扭

;将素材文件改为-1，这样下次再开的时候，默认也不会有按钮
ShowCustomItem 0 -1

取自定义装备框物品数据库名称：<$CustomItem0> ------- <$CustomItem49>
取自定义装备框物品改名后名称：<$G_CustomItem0> ------- <$G_CustomItem49>

[@Main]
你的装备框0放入的物品是【<$CustomItem0>】\\
<开自定义装备框/@开自定义装备框>  <显示自定义装备框/@显示自定义装备框>   <关闭自定义装备框/@关闭自定义装备框>\\
<CustomItem:0:1:1549:1:2:提示文字>

[@开自定义装备框]
#IF
not CheckCustomItemOpen 0
#ACT
;开启自定义装备框0;stdmode=5,6最多支持10个
OpenCustomItem 0 5,6
SendMsg 6 已成功开启自定义装备框0

[@显示自定义装备框]
#IF
not CheckCustomItemOpen 0
#ACT
;显示装备框0到人物装备栏，Newopui.pak
ShowCustomItem 0 2 1 1635 240 30 0 提示文字
SendMsg 6 显示自定义装备框0到人物装备栏中了
#ELSEACT
;显示装备框0到人物装备栏，Newopui.pak
ShowCustomItem 0 2 1 1549 240 30 0 提示文字
SendMsg 6 显示自定义装备框0到人物装备栏中了

[@关闭自定义装备框]
#IF
; 检测装备框1是否放了物品
CheckUseItem 200
#ACT
SendMsg 6 你的自定义装备框0上面放了物品，物品将会自动返回到背包

#IF
#ACT
CloseCustomItem 0 1
SendMsg 6 已经关闭了自定义装备框0，并且自动删除对应的按扭

;将素材文件改为-1，这样下次再开的时候，默认也不会有按钮
ShowCustomItem 0 -1

增加QF触发：

未开启的自定义装备框点击：@ClosedCustomItemClickEx， @ClosedCustomItemClick0 ------- @ClosedCustomItemClick49
未开启的英雄自定义装备框点击：@HeroClosedCustomItemClickEx， @HeroClosedCustomItemClick0 ------- @HeroClosedCustomItemClick49

增加NPC脚本标签：
<CustomItem:I:F:D:X:Y:S:H>
<HeroCustomItem:I:F:D:X:Y:S:H>

格式：<CustomItem:I:F:D:X:Y:S:H>
参数说明：
I = 自定义装备框编号(0-49)
F = wil文件编号
D = 图片编号
X,Y = 微调坐标
S = 是否内观显示(内观显示读取StdItem.wzl，否则读取Items.wzl)
H = 提示信息
注意：本标签不支持触发

[@main]
#IF
CheckCustomItemOpen 0
#SAY
下面一个人物的自定义装备框0\\
<CustomItem:0:1:1549:1:2:0:提示文字>
#ELSESAY
你的自定义OK框还未开启\\
[@main]
#IF
CheckCustomItemOpen 0
#SAY
下面一个人物的自定义装备框0\\
<CustomItem:0:1:1549:1:2:0:提示文字>
#ELSESAY
你的自定义OK框还未开启\\


时间戳

功能说明: 时间戳、获取时间、世界UTC时间到北京时间

格式：世界UTC时间到北京时间 格式：UnixToStr UTC时间 保存变量 格式(0:日期用-分隔; 1:日期用/分隔)

--------------------------------------------------------

世界时间变量：<$UTCNow>

时间戳转换月日年时分秒
世界UTC时间到北京时间（北京时间需在世界时间上减去8小时）
格式： UnixToStr UTC时间 保存变量 格式(0:日期用-分隔; 1:日期用/分隔)

例子 [@main]
#IF
#ACT
Mov N1 <$UTCNow>
Mov N2 <$STR(N1)>
inc N2 28800\
UnixToStr <$STR(N1)> S1 0
#SAY
UTC(<$STR(N1)>)转为北京时间是:<$STR(S1)>\
UTC8为<$STR(N2)>\
--------------------------------------------------------


首饰盒

首饰盒详情：

NPC命令（以下命令均支持英雄操作H.）：

  • 功能命令：激活首饰盒

    命令格式：activationcasket 是否时装首饰0/1(0:普通首饰;1:时装首饰)
    功能说明：激活首饰盒后，首饰盒图标显示出来且为灰色，点击灰色图标可以触发QF中的以下脚本

    1. [@OpenSndacasket] ----- 人物普通首饰盒图标点击
    2. [@OpenFashionSndacasket] ----- 人物时装首饰盒图标点击
    3. [@HeroOpenSndacasket] ----- 英雄普通首饰盒图标点击
    4. [@HeroOpenFashionSndacasket] ----- 英雄时装首饰盒图标点击

  • 功能命令：反激活/删除首饰盒图标

    命令格式：CloseSndacasket 是否时装首饰0/1(0:普通首饰;1:时装首饰)
    功能说明：必须激活的情况下才能使用，执行后，首饰盒图标隐藏不见

  • 功能命令：开启/关闭首饰盒图标

    命令格式：SetSndacasket 开关(0:关;1:开) 是否时装首饰0/1(0:普通首饰;1:时装首饰)
    功能说明：开启：将首饰盒的图标由灰色变为彩色可用状态，关闭：将首饰盒的图标由彩色变为灰色不可用状态

DB设置

  • 头盔：stdmode段为15
  • 项链：stdmode段为19、20、21
  • 手镯：stdmode段为24、26
  • 戒指：stdmode段为22、23

放入条件

物品允许装备的位置（只限于可以装备的物品）数据库字段：Overlap

Overlap值 | 位置
0 | 只允许穿身上
1 | 只允许穿身上 【基础位置】
2 | 只允许首饰盒【基础位置】
4 | 只允许神佑【基础位置】
8 | 只允许时装首饰盒【基础位置】
16 | 只允许时装神佑【基础位置】
25 | 1+8+16；身上+时装首饰盒+时装神佑

其他位置在此不逐个列举，比如，希望一个物品能放置在以下位置，只需要将基础位置相加：
身上+首饰盒+时装首饰盒 = 1 + 2 + 8 = 11

首饰盒放入位置设置： Expand1: 1-6 对应6个位置； 0或7，所有位置可放

装备位置

  • 普通首饰：30 --- 35
  • 时装首饰：70 --- 75

变量

  • 人物变量（普通首饰盒）：<$JEWELRYITEM1> --- <$JEWELRYITEM6>
  • 英雄变量（普通首饰盒）：<$H.JEWELRYITEM1> --- <$H.JEWELRYITEM6>
  • 人物变量（时装首饰盒）：<$FASHION_JEWELRYITEM1> --- <$FASHION_JEWELRYITEM6>
  • 英雄变量（时装首饰盒）：<$H.FASHION_JEWELRYITEM1> --- <$H.FASHION_JEWELRYITEM6>

备注

M2上--功能设置--其他控制--其他控制三，可设置首饰盒中的首饰是否计算装备属性(选择后需小退生效)。
盛大的首饰盒是只可以放特殊戒指（只计算特殊属性），本引擎做了进一步的扩展，根据版本的
性质，请GM自行调整。

脚本示例

[@main]
玩家普通首饰盒:  <激活/@激活首饰盒>  <锁定/@锁定首饰盒>  <打开/@打开首饰盒>  <关闭/@关闭首饰盒>  \
英雄普通首饰盒:  <激活/@激活首饰盒2>  <锁定/@锁定首饰盒2>  <打开/@打开首饰盒2>  <关闭/@关闭首饰盒2> \
玩家时装首饰盒:  <激活/@激活时装首饰盒>  <锁定/@锁定时装首饰盒>  <打开/@打开时装首饰盒>  <关闭/@关闭时装首饰盒>  \
英雄时装首饰盒:  <激活/@激活时装首饰盒2>  <锁定/@锁定时装首饰盒2>  <打开/@打开时装首饰盒2>  <关闭/@关闭时装首饰盒2> \

[@激活首饰盒]
#IF
#ACT
activationcasket
;--激活首饰盒
MessageBox 恭喜你成功激活首饰盒功能,可点击装备栏首饰盒来开启此功能。
break

[@锁定首饰盒]
#IF
#ACT
closeSndacasket
;--首饰盒功能锁定
MessageBox 首饰盒功能已被锁定,激动可再次使用。
break

[@打开首饰盒]
;--开启触发
#IF
#ACT
MessageBox 【首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品】\\
开启【首饰盒】需要金币10000，你是否确定开启？ @确定开启首饰盒 @取消
break

[@确定开启首饰盒]
#IF
checkgold  10000
#ACT
SetSndacasket 1
;--开启首饰盒
take 金币 10000
MessageBox 恭喜你开启成功。
break
#ELSEACT
MessageBox 金币不够1万，首饰盒无法开启。
break

[@关闭首饰盒]
#IF
#ACT
SetSndacasket 0
MessageBox 关闭首饰盒成功。

[@激活首饰盒2]
#IF
#ACT
H.activationcasket
;--激活首饰盒
MessageBox 恭喜你成功激活首饰盒功能,可点击装备栏首饰盒来开启此功能。
break

[@锁定首饰盒2]
#IF
#ACT
H.closeSndacasket
;--首饰盒功能锁定
MessageBox 首饰盒功能已被锁定,激动可再次使用。
break

[@打开首饰盒2]
;--开启触发
#IF
#ACT
MessageBox 【首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品】\\
开启【首饰盒】需要金币10000，你是否确定开启？ @确定开启首饰盒2 @取消
break

[@确定开启首饰盒2]
#IF
checkgold  10000
#ACT
H.SetSndacasket 1
;--开启首饰盒
take 金币 10000
MessageBox 恭喜你开启成功。
break
#ELSEACT
MessageBox 金币不够1万，首饰盒无法开启。
break

[@关闭首饰盒2]
#IF
#ACT
H.SetSndacasket 0
MessageBox 关闭首饰盒成功。

[@激活时装首饰盒]
#IF
#ACT
activationcasket 1
;--激活首饰盒
MessageBox 恭喜你成功激活时装首饰盒功能,可点击装备栏首饰盒来开启此功能。
break

[@锁定时装首饰盒]
#IF
#ACT
closeSndacasket 1
;--首饰盒功能锁定
MessageBox 时装首饰盒功能已被锁定,激动可再次使用。
break

[@打开时装首饰盒]
;--开启触发
#IF
#ACT
MessageBox 【首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品】\\
开启【首饰盒】需要金币10000，你是否确定开启？ @确定开启时装首饰盒 @取消
break

[@确定开启时装首饰盒]
#IF
checkgold  10000
#ACT
SetSndacasket 1 1
;--开启首饰盒
take 金币 10000
MessageBox 恭喜你开启成功。
break
#ELSEACT
MessageBox 金币不够1万，首饰盒无法开启。
break

[@关闭时装首饰盒]
#IF
#ACT
SetSndacasket 0 1
MessageBox 关闭时装首饰盒成功。

[@激活时装首饰盒2]
#IF
#ACT
H.activationcasket 1
;--激活首饰盒
MessageBox 恭喜你成功激活时装首饰盒功能,可点击装备栏首饰盒来开启此功能。
break

[@锁定时装首饰盒2]
#IF
#ACT
H.closeSndacasket 1
;--首饰盒功能锁定
MessageBox 时装首饰盒功能已被锁定,激动可再次使用。
break

[@打开时装首饰盒2]
;--开启触发
#IF
#ACT
MessageBox 【首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品】\\
开启【首饰盒】需要金币10000，你是否确定开启？ @确定开启时装首饰盒2 @取消
break

[@确定开启时装首饰盒2]
#IF
checkgold  10000
#ACT
H.SetSndacasket 1  1
;--开启首饰盒
take 金币 10000
MessageBox 恭喜你开启成功。
break
#ELSEACT
MessageBox 金币不够1万，首饰盒无法开启。
break

[@关闭时装首饰盒2]
#IF
#ACT
H.SetSndacasket 0 1
MessageBox 关闭首饰盒成功。
[@main]
玩家普通首饰盒:  <激活/@激活首饰盒>  <锁定/@锁定首饰盒>  <打开/@打开首饰盒>  <关闭/@关闭首饰盒>  \
英雄普通首饰盒:  <激活/@激活首饰盒2>  <锁定/@锁定首饰盒2>  <打开/@打开首饰盒2>  <关闭/@关闭首饰盒2> \
玩家时装首饰盒:  <激活/@激活时装首饰盒>  <锁定/@锁定时装首饰盒>  <打开/@打开时装首饰盒>  <关闭/@关闭时装首饰盒>  \
英雄时装首饰盒:  <激活/@激活时装首饰盒2>  <锁定/@锁定时装首饰盒2>  <打开/@打开时装首饰盒2>  <关闭/@关闭时装首饰盒2> \

[@激活首饰盒]
#IF
#ACT
activationcasket
;--激活首饰盒
MessageBox 恭喜你成功激活首饰盒功能,可点击装备栏首饰盒来开启此功能。
break

[@锁定首饰盒]
#IF
#ACT
closeSndacasket
;--首饰盒功能锁定
MessageBox 首饰盒功能已被锁定,激动可再次使用。
break

[@打开首饰盒]
;--开启触发
#IF
#ACT
MessageBox 【首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品】\\
开启【首饰盒】需要金币10000，你是否确定开启？ @确定开启首饰盒 @取消
break

[@确定开启首饰盒]
#IF
checkgold  10000
#ACT
SetSndacasket 1
;--开启首饰盒
take 金币 10000
MessageBox 恭喜你开启成功。
break
#ELSEACT
MessageBox 金币不够1万，首饰盒无法开启。
break

[@关闭首饰盒]
#IF
#ACT
SetSndacasket 0
MessageBox 关闭首饰盒成功。

[@激活首饰盒2]
#IF
#ACT
H.activationcasket
;--激活首饰盒
MessageBox 恭喜你成功激活首饰盒功能,可点击装备栏首饰盒来开启此功能。
break

[@锁定首饰盒2]
#IF
#ACT
H.closeSndacasket
;--首饰盒功能锁定
MessageBox 首饰盒功能已被锁定,激动可再次使用。
break

[@打开首饰盒2]
;--开启触发
#IF
#ACT
MessageBox 【首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品】\\
开启【首饰盒】需要金币10000，你是否确定开启？ @确定开启首饰盒2 @取消
break

[@确定开启首饰盒2]
#IF
checkgold  10000
#ACT
H.SetSndacasket 1
;--开启首饰盒
take 金币 10000
MessageBox 恭喜你开启成功。
break
#ELSEACT
MessageBox 金币不够1万，首饰盒无法开启。
break

[@关闭首饰盒2]
#IF
#ACT
H.SetSndacasket 0
MessageBox 关闭首饰盒成功。

[@激活时装首饰盒]
#IF
#ACT
activationcasket 1
;--激活首饰盒
MessageBox 恭喜你成功激活时装首饰盒功能,可点击装备栏首饰盒来开启此功能。
break

[@锁定时装首饰盒]
#IF
#ACT
closeSndacasket 1
;--首饰盒功能锁定
MessageBox 时装首饰盒功能已被锁定,激动可再次使用。
break

[@打开时装首饰盒]
;--开启触发
#IF
#ACT
MessageBox 【首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品】\\
开启【首饰盒】需要金币10000，你是否确定开启？ @确定开启时装首饰盒 @取消
break

[@确定开启时装首饰盒]
#IF
checkgold  10000
#ACT
SetSndacasket 1 1
;--开启首饰盒
take 金币 10000
MessageBox 恭喜你开启成功。
break
#ELSEACT
MessageBox 金币不够1万，首饰盒无法开启。
break

[@关闭时装首饰盒]
#IF
#ACT
SetSndacasket 0 1
MessageBox 关闭时装首饰盒成功。

[@激活时装首饰盒2]
#IF
#ACT
H.activationcasket 1
;--激活首饰盒
MessageBox 恭喜你成功激活时装首饰盒功能,可点击装备栏首饰盒来开启此功能。
break

[@锁定时装首饰盒2]
#IF
#ACT
H.closeSndacasket 1
;--首饰盒功能锁定
MessageBox 时装首饰盒功能已被锁定,激动可再次使用。
break

[@打开时装首饰盒2]
;--开启触发
#IF
#ACT
MessageBox 【首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品】\\
开启【首饰盒】需要金币10000，你是否确定开启？ @确定开启时装首饰盒2 @取消
break

[@确定开启时装首饰盒2]
#IF
checkgold  10000
#ACT
H.SetSndacasket 1  1
;--开启首饰盒
take 金币 10000
MessageBox 恭喜你开启成功。
break
#ELSEACT
MessageBox 金币不够1万，首饰盒无法开启。
break

[@关闭时装首饰盒2]
#IF
#ACT
H.SetSndacasket 0 1
MessageBox 关闭首饰盒成功。

QF触发

[@openSndacasket]
#IF
#ACT
break
#SAY
首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品\\
<开启首饰盒/@确定开启首饰盒> \
<取消/@exit>\

[@确定开启首饰盒]
#IF
#ACT
SetSndacasket 1
MessageBox 恭喜你主体首饰盒成功开启。
break

;英雄触发
[@HeroOpenSndacasket]
#IF
#ACT
break
#SAY
首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品\\
<开启英雄首饰盒/@确定开启英雄首饰盒> \
<取消/@exit>\

[@确定开启英雄首饰盒]
#IF
#ACT
h.SetSndacasket 1
MessageBox 恭喜你英雄首饰盒成功开启。
break

[@openFashionSndacasket]
#IF
#ACT
break
#SAY
时装首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品\\
<开启首饰盒/@确定开启时装首饰盒> \
<取消/@exit>\

[@确定开启时装首饰盒]
#IF
#ACT
SetSndacasket 1 1
MessageBox 恭喜你主体首饰盒成功开启。
break

;英雄触发
[@HeroOpenFashionSndacasket]
#IF
#ACT
break
#SAY
时装首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品\\
<开启英雄首饰盒/@确定开启英雄时装首饰盒> \
<取消/@exit>\

[@确定开启英雄时装首饰盒]
#IF
#ACT
h.SetSndacasket 1  1
MessageBox 恭喜你英雄首饰盒成功开启。
break

[@openSndacasket]
#IF
#ACT
break
#SAY
首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品\\
<开启首饰盒/@确定开启首饰盒> \
<取消/@exit>\

[@确定开启首饰盒]
#IF
#ACT
SetSndacasket 1
MessageBox 恭喜你主体首饰盒成功开启。
break

;英雄触发
[@HeroOpenSndacasket]
#IF
#ACT
break
#SAY
首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品\\
<开启英雄首饰盒/@确定开启英雄首饰盒> \
<取消/@exit>\

[@确定开启英雄首饰盒]
#IF
#ACT
h.SetSndacasket 1
MessageBox 恭喜你英雄首饰盒成功开启。
break

[@openFashionSndacasket]
#IF
#ACT
break
#SAY
时装首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品\\
<开启首饰盒/@确定开启时装首饰盒> \
<取消/@exit>\

[@确定开启时装首饰盒]
#IF
#ACT
SetSndacasket 1 1
MessageBox 恭喜你主体首饰盒成功开启。
break

;英雄触发
[@HeroOpenFashionSndacasket]
#IF
#ACT
break
#SAY
时装首饰盒内可放置带有麻痹、护身、复活等特殊属性的饰品\\
<开启英雄首饰盒/@确定开启英雄时装首饰盒> \
<取消/@exit>\

[@确定开启英雄时装首饰盒]
#IF
#ACT
h.SetSndacasket 1  1
MessageBox 恭喜你英雄首饰盒成功开启。
break


DEFINE说明

功能说明: DEFINE

说明： DEFINE文件中ini内容注释符号为\\ 和 // 和 ;

--------------------------------------------------------

示例脚本：

;Mir200\Envir\Defines\全局常量配置.ini(以下内容为全局常量配置.ini文本中内容)
;================================================================================================================
;===============================================【全局常量配置】=================================================
;================================================================================================================
;声明命令 常量 常量内容 ;备注(;和//均可以在本文件中作为注释符号//和;后的内容不在被读取)

#Define $全局常量 80 ;这里是备注，用于备注这条变量用处，记性好的可以不用，记性不好时间久怕忘记的可以用
#Define $常量测试 180 //这里是备注，用于备注这条变量用处记性好的可以不用，记性不好时间久怕忘记的可以用

;NPC内容(NPC脚本顶部需要加入该NPC调用的INI文件，下面是示范脚本)

#INCLUDE 全局常量配置.ini
[@MAIN]
#IF
CHECKLEVELEX > 0
#SAY
\ \ \
<> ($全局常量) \ \
<> ($常量测试) \
#ACT
BREAK


货币实时刷新常量

功能说明: 货币实时刷新常量，用于对话框实时显示货币动态

说明：实时显示最新货币值动态

--------------------------------------------------------

比普通的变量多一个$符号，用于实时刷新显示货币数量

[@Main]
元宝：<$$GameGold>\
游戏点：<$$GamePoint>\
金币：<$$GoldCount>\
金刚石：<$$GameDiamond>\
灵符：<$$GameGird> <TEXT:$$GameGird{FCOLOR=250}>\
声望：<$$CreditPoint>\
荣誉：<$$GameGlory>\

按需使用，一般用于NPC对话框实时显示最新货币数量

--------------------------------------------------------

★★★★注意：
<$GameGold>是服务器变量，加上<>
$$GAMEGOLD是实时变量（也就是客户端变量），不加<>
具体自己测试，当变量值显示存在时表示不需要加<>，显示不出来就是需要加<>

示范脚本：

[@Main]
<ImgNum:9:$$GAMEGOLD:-3:0:0|提示信息<$GAMEGOLD>+$$GAMEGOLD/@测试> \\
<ProgressBar:0:50:1:620:630:6:100:4:1:100:$$GAMEGOLD:190:0:249:0:0:%p／%m:NewopUI.pak中<$GAMEGOLD>+$$GAMEGOLD/@Label>
<ItemShow:21:$$GAMEGOLD:0:0:1:0:0/@Label>\

--------------------------------------------------------


DEC对字符型变量操作命令[!]

DEC对字符型变量操作命令。
MOV命令做了一些改进。

[@Main]
#ACT
MOV S1 lfm2引擎M2
MOV S2 lfm2引擎M2
DEC S1 lfm2引擎 ;删除S1中的“lfm2引擎”字符串
DEC S2 1 3 ;删除S2中的第1至第6个字符串 这个要注意，一个汉字是2个字节长度，不要删除半个汉字的情况，否则会乱码。

结果 S1=M2
S2=引擎


MagicShieldItemList

功能：
护身属性扩展。

;装备名称(必须是可以护身的装备才有效) 掉蓝比例(设置数值除以100) 伤害吸收(设置数值除以100)
护身戒指 50

;比如设置50.那么受到100伤害的话!!!就是扣50%的蓝.50%的红
;比如设置75.那么受到100伤害的话!!!就是扣75%的蓝.25%的红
;比如设置100.那么受到100伤害的话!!!就是扣100%的蓝.
;比如设置150.那么受到100伤害的话!!!就是扣150%的蓝.
;比如设置200.那么受到100点攻击的话!!!就是扣200的蓝.

掉蓝比例备注： 用户如果佩戴多个，按装备位置顺序，最后一个装备的设置才有效

伤害吸收备注：

护身戒指 40 20

;比如设置40.那么受到100伤害的话!!!就是扣40%的蓝.40%的红

;当受到100的攻击伤害时，吸收20，即还有100 - (100 * 20%) = 80的伤害，掉蓝80 * 40% = 32，掉血 80 - 32 = 48

配置文件位于：X:\MirServer\Mir200\Envir\MagicShieldItemList.txt


MapQuest.txt说明

MapQuest.txt

原格式：

地图 变量 判断 怪物名 条件 文件名

A1 [999] 0 赤月恶魔 * 赤月恶魔
A2 [999] 0 赤月恶魔 * 赤月恶魔
A3 [999] 0 赤月恶魔 * 赤月恶魔
A4 [999] 0 赤月恶魔 * 赤月恶魔
A5 [999] 0 赤月恶魔 * 赤月恶魔

建议改进后，* 星号代表 所有地图触发， 则一行就能搞定！！

地图 变量 判断 怪物名 条件 文件名

* [999] 0 赤月恶魔 * 赤月恶魔

【地图代码不建议用*，如果不是所有地图都有，建议单个地图写，效率更高】


NPC对话框点击复制文字

示范脚本：

<复制地址/@@CopyToClipboard1(点击后将会复制这段文字到剪粘版中)>

[@CopyToClipboard1]
#IF
#ACT
Messagebox 复制文字到剪粘版中成功


NPC对话框内默认输入框

INPUTTEXT:输入框ID:X:Y:宽度:高度:背景色:边框色:文字颜色:最小长度:最大长度:数据无效时提示对话框内容:提示文字:提示文字颜色

输入框ID: 1-40
背景色：-1为透明，0-255
边框色：-1为无边框， 0-255
最小长度，最大长度，为0表示不判断

INPUTNUM:输入框ID:X:Y:宽度:高度:背景色:边框色:文字颜色:最小值:最大值:数据无效时提示对话框内容:提示文字:提示文字颜色
输入框ID: 1-40
背景色：-1为透明，0-255
边框色：-1为无边框， 0-255
最小值，最大值：同时为0表示不限，否则最小值必须 <= 最大值

以上2个命令：“数据无效时提示对话框内容”为空时，客户端不检查数据有效性。

示范：

[@main]
姓名：<INPUTTEXT:1:0:0:80:15:0:249:255:4:10:姓名必须在4-10位长:输入姓名:160> \
年龄：<INPUTNUM:2:0:2:80:15:0:249:255:1:100:年龄必须输入1-100之间的数字:输入年龄:160> \
性别：<INPUTNUM:3:0:4:80:15:0:249:255:0:1:性别必须输入0或1:男(0)-女(1):160> \
<Img:130:1:0:4:*|249#将所有输入框的内容全提交/@全部提交>
<text:只提交姓名年龄:10:6:1,2/@提交部分>

[@提交部分]
#act
;;;;;;★★★★★★★★★★★★★★★★★★★★★★★★★★这里别忘了对输入的数据有效性判断。。。
SendMsg 5 输入的姓名为 <$NPCINPUT(1)>
SendMsg 5 输入的年龄为 <$NPCINPUT(2)>
SendMsg 5 输入的性别为 <$NPCINPUT(3)>

[@全部提交]
#act
;;;;;;★★★★★★★★★★★★★★★★★★★★★★★★★★这里别忘了对输入的数据有效性判断。。。
SendMsg 5 输入的姓名为 <$NPCINPUT(1)>
SendMsg 5 输入的年龄为 <$NPCINPUT(2)>
SendMsg 5 输入的性别为 <$NPCINPUT(3)>

;---------------------------------------------------------------------------------------------

注： 如果留空要通过检测不想提示的请用空格。

姓名：<INPUTTEXT:1:0:0:80:15:0:249:255:0:0: : :160>\

;---------------------------------------------------------------------------------------------

INPUTTEXT
INPUTNUM 有非法字符，全是触发 @inputboxFilter

[@InputBoxFilter]
#ACT
SendMsg 5 输入了非法字符


按比例恢复的太阳水类药品[!]

功能：
按比例恢复的太阳水类药品.

格式: 按比例恢复的太阳水类药品，按MaxHP/MaxMP的比例恢复

说明：

StdMode = 0
Shape = 101 {特殊药，类似于太阳水}
AC1：HP恢复比例; AC2：在AC1的基础上增加一个随机范围
MAC1: MP恢复比例；MAC2：在MAC1基础上增加一个随机范围

如：
AC1 = 15； AC2 = 10；那么恢复血量为: 15% - (15+10)%，即 15%---25%的随机。
AC1 = 15; AC2 = 0；那么恢复的血量为 15%

DB:
1414 强效太阳水(比例) 0 101 2 0 0 0 312 0 30 10 40 10 0 0 0 0 0 0 0 0 2500 5 255 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0


本地登陆器集成列表[!]

功能：
本地登陆器列表.

格式：将放在配置器--补丁文件夹\Config--LocalGameList_GeeM2.txt

示列：

本地列表与远程列表格式一致(功能等全部相同)...
将放在配置器--补丁文件夹\Config--LocalGameList_GeeM2.txt
当登陆器获取不到远程列表时候则读取本地集成列表


查看人物私聊信息

此功能可以实时侦听指定人物的私聊信息，将指定人物发送及接收的私聊信息发送到自己。

命令格式：
@ViewWhisper 人物名称

重复输入取消侦听私听信息。


程序变量说明[!]

P0-P999 (私人变量，数字型) 关闭对话框重置为0。
D0-D999 (私人变量，数字型) 下线不保存.摇筛子变量.
M0-M999 (私人变量，数字型) 下线不保存.切换地图清空.
N0-N999 (私人变量，数字型) 下线不保存.小退归0.
S0-S999 (私人变量，字符型) 下线不保存.小退归0.
I0-I999 (全局变量，数字型) 不可保存，服务器重启自动重置为0。
G0-G999 (全局变量，数字型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
A0-A999 (全局变量，字符型) 可保存。（存放在Mir200/GlobalVal.ini文件里面）
U0-U499 (私人变量，数字型) 可保存。（存放在人物数据库Mir.db里面、值最大范围正负21亿）
T0-T499 (私人变量，字符型) 可保存。（存放在人物数据库Mir.db里面、字符长度256<1个字母为1字符、1汉字为2字符>）
J0-J499 (私人变量，数字型) 可保存,每晚自动12点重置,合区或关停服务器请错开00:00点即可。（存放在人物数据库Mir.db里面、值最大范围正负21亿）
Z0-J499 (私人变量，字符型) 可保存,每晚自动12点重置,合区或关停服务器请错开00:00点即可。（存放在人物数据库Mir.db里面、自定义清理时间位于参数设置 - 时间控制,和J变量共清理时间）

提示：仅G、N$、U、N变量数字支持9223372036854775807，其他数字变量支持21亿

提示：2023-07-22扩展U500-U599 T500-T599变量，如果你用不上跨服，或者说跨服用不上参数1为2的话，那么U500-U599 T500-T599可以在你服务端正常脚本中随意使用，如果用上了跨服的参数1为2的话变量将会从母区传回子区保存，所以写版本时需注意...

注意：N998和N999变量为鼠标的在游戏中地图上的 坐标数字，请不要再服务端中使用这两个变量（因为这2个变量值一直的变动）

注意： 自定义变量不要以P、D、M、N、S、I、G、A开头

(扩展说明见本页下方)

【变量属性】

P(0-999)

『属性说明』：该变量只对当前对话NPC内有效果。如果中途点其他NPC或者对话产生close、关闭时所有P变量均归0。该变量取值范围：（0-？）根据M2最大值不同
『用法』：该变量没有NPC间传递性作为临时变量多重复使用效果十分好。而且因为脚本命令有对该变量进行加/减/赋值/随机取值等运算，他和goto的配合可以使脚本中出现仿for循环的效果。并且因为他不传递的性质其
随机取值也能与RANDOM媲美。

D(0-999)

『属性说明』：该变量在人物不下线时对全局NPC通用传递。该变量取值范围：同P变量
『用法』：既有像[0-？]变量一样的人物属性私有变量的效果又有像P变量一样的运算功能！唯一不足就是下线 后该变量会被清空。可是如果配合上[000]变量或者namelist变量的记录性。实在是功能强大的个人隐私属性！

G(0-999)

『属性说明』：该变量不属于人物属性范围，对于全服务器内该变量唯一并且全局NPC通用传递。该变量取值范围：同P变量
『用法』：这个变量是唯一的一个不属于任何人物而属于服务器的变量，该变量通过任何人的运算均产生效果。而且不保存在任何人的属性中。（存放在Mir200/GlobalVal.ini文件里面）

A(0-999)

『属性说明』：该变量不属于人物属性范围，对于全服务器内该变量唯一并且全局NPC通用传递。该变量取值范围：同D变量
『用法』：这个变量是唯一的一个不属于任何人物而属于服务器的变量，该变量通过任何人的运算均产生效果。而且不保存在任何人的属性中。（存放在Mir200/GlobalVal.ini文件里面）

@@InPutString 用法 @InPutInteger 类似,

如果需要在一个脚本中使用该命令，则需要在脚本的第一行输入(@@InPutInteger @@InPutString)这段内容。以下脚本用于测试输入功能，大家可从脚本中仔细研究一下脚本的实现原理。

举例说明：

22要和后面的变量一样<$STR(S22)>

[@InPutString22]
#IF
CHECKTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是检测你输入的卡号和50000.txt这里面的某行卡号是否相同
#ACT
DELTEXTLIST ..\QuestDiary\元宝充值\50000.txt <$STR(S22)>
;这个命令是将你输入的那行卡号在50000.txt这个文档里删除掉
GAMEGOLD + 50000
SENDMSG 7 充值成功：增加[50000元宝]，你当前帐户里元宝数为：<$GAMEGOLD>
SENDMOVEMSG 0 251 249 350 1 [『<$USERNAME>』使用在线充值卡--充值成功：增加[50000元宝]，感谢您的支持希望您玩的开心:-)]
GOTO @充值元宝
#ELSEACT
SENDMSG 7 您输入的卡号不正确或已被他人使用，请重新输入！
GOTO @充值元宝

@InPutInteger

★★★★★★★有禁止符号时执行当前npc的脚本@InputStringFilter, @InputIntegerFilter
禁止符号在M2-列表信息一设置
---------------------------------------------------------------------------------------------------------------------------------------------

扩展字符变量S和数字变量N

功能：扩展字符变量S和数字变量N
格式：无
说明：扩展字符变量S和数字变量N，除了支持0~499以外，可以在S$变量或N$变量后面增加任意字符
例：
[@test]
#ACT
MOV S$我的人物名称 <$USERNAME>
SENDMSG 0 <$STR(S$我的人物名称)> 255 253
[@test1]
#ACT
MOV N$我的杀怪总数 100
INC <$STR(N$我的当前杀怪数)> 1
SENDMSG 6 【杀怪总数=<$STR(N$我的杀怪总数)>】【当前杀怪数=<$STR(N$我的当前杀怪数)>】 255 253

---------------------------------------@@InPutString 与 @InPutInteger区别------------------------------------------------------------------------------------------------------

;区别就是@@InPutString为字符，@InPutInteger为数字，数字对应私人变量为N，字符则为S
;示范：

[@Main]
请输入数字1 <输入/@@InPutInteger1>\
请输入数字2 <输入/@@InPutInteger2>\
请输入数字3 <输入/@333>\
...............................\
请输入字符1 <输入/@@InPutString1>\
请输入字符2 <输入/@@InPutString2>\
...............................\

[@InPutInteger1]
#SAY
你输入的数字1是 <$STR(N1)>\

[@InPutInteger2]
#IF
LARGE N2 0
SMALL N2 1000001
#ACT MessageBox 你输入的数字2是 <$STR(N2)>\
#ELSEACT
MessageBox 请正确输入数量（1-100W）。
break

[@333]
#ACT
MessageBox 请输入数量（1-100W）。 @@InPutInteger3(请输入元宝数量（1-1000000）。)

[@InPutInteger3]
#IF
LARGE N3 0
SMALL N3 1000001
#ELSEACT
MessageBox 请正确输入元宝数量（1-100W）。
break

#IF
CHECKGAMEGOLD < <$STR(N3)>
#ACT
MessageBox 你身上没有足够的元宝。
#ELSEACT
GAMEGOLD - <$STR(N3)>
MessageBox 成功将 <$STR(N3)>元宝扣除。
break

;===============================

[@InPutString1]
#SAY
你输入的字符1是<$STR(S1)>\

[@InPutString2]
#IF
EQUAL S2 aaa
#ACT
MessageBox 正确
#ELSEACT
MessageBox 错误
break

有禁止符号时执行当前npc的脚本@InputStringFilter, @InputIntegerFilter
禁止符号在M2-列表信息一设置

[@InputStringFilter]
; 如果用户输入的字符在消息过滤列表中就会调转到这个字段
#SAY
输入的字符非法

[@InputIntegerFilter]
; 如果用户输入的数字在消息过滤列表中就会调转到这个字段
#SAY
输入的字符非法


传奇脚本命令详解[!]

===========================================================

传奇脚本命令详解
====================********************************========================

[@段] ;段用英文或数字表示

goto @段 ;跳转到指定段，开始执行相当于B中的goto语句

#say 语句 ;语句设定为字符，不用加任何定界符

#act 执行命令 ;符合3.0规定的任何系统已定义命令

give 物品 数量 ;给多少东西,除了物器数据库中有的物品，还有金币，

take 物品 数量 是否检测装备改名（0或空：不检测，1：检测） 物品名匹配方式(0或空：完整匹配，1：部分匹配） 是否回收自定义OK框物品(0或空:回收; 1:不回收) 检测持久(0或空:不检测; -1:满持久;-2:未满持久).

map 地图名 ;移动到这个地图的随机坐标，地图名为地图的数字人码

mapmove 地图名 坐标A 坐标B 范围 ;同上，只是指定了坐标（范围留空或者0则为定点传送）

monclear 地图名 ;清除这个地图上刷的怪物

MonGen 怪物名称 数量 时间 ;刷怪物，与刷怪角本用法相同

TimeRecall 数值 ;数值为分钟，定义进入某地的时间限制。

BreakTimeRecall ;中断上面那个语句设定的时间

hairstyle 数值 ;改变头发类型

haircolor 红值 绿值 蓝值 ;值域为0 ~ 255 设定头发颜色

close ; 关闭对话框

======================****************************========================
---------------------- 程 序 中 的 变 量 与 常 量 ------------------------
======================****************************========================

变量 ;变量用字母表示，在程序中可以赋任何数据 名称只限于P0-P9,D0-D9
SMALL (变量) (数值) ;测试变量是不是小于指定数值

LARGE (变量) (数值) ;测试变量是不是大于指定数值

EQUAL (变量) (数值) ;测试变量是不是等于指定数值

mov 变量赋值 ;变量赋值 MOV N0 1

inc 变量相加 ;让变量自动加指定数值到变量，相当于程序中的x=x+n

DEC 变量相减 DEC N0 1

MUL 变量想乘 MUL N0 2 或者 MUL N0 100 2 (不支持字符串变量)

DIV 整除变量 DIV N0 2 或者 DIV N0 100 2 (不支持字符串变量)

sum 变量A 变量B ;变量求和不要与int混淆,需要下面的组合语名才能实现

MOV 变量X 0 ;变量X，初值。

sum 变量A 变量B ;X=A+B

sum 变量C ;X=X+C 最后在程序中得到的是X值，实际X=A+B+C

;如果只写中间一句是无意义的，只能导致错误

movr 变量 数值 ;定义随机变量，变量值为 “0 到 数值”

random 数值 ;当数值=随机数时则为1否则为0

<$STR(变量)> ;显示变量时用，可以将变量值显示在游戏里，用在 #say后面。

=========================*******************************========================
------------------------- 程 序 中 的 逻 辑 判 断 语 句 ------------------------
=========================*******************************========================

[n] ;n为任何正整数，是逻辑变量，有0值和1值，初始0值

#IF
条件--执行
#elsesay 或者 #elseact
否定--执行 ;相当于程序中的条件判断

SET [n] 1 ;设置逻辑变量为真

--------------------关于reset命令的详解------------------------------------

reset [XXX] 7 意思是将从XXX开始的7个变量回复到原始值0

比如：reset [100] 7 就是把100 101 102 103 104 105 106这7个变量赋值为0。

它等同与：set [100] 0

set [101] 0

set [102] 0

set [103] 0

set [104] 0

set [105] 0

set [106] 0

--------------------------------------------------------

set check reset 标示增加变量支持
如：
mov <$STR(P0)> 90
set [<$STR(P0)>] 1

#IF
check [90] 1
#act
sendmsg 6 你自己的变量值90为1
---------------2019-02-01扩展支持批量检测---------
4扩展 check 支持批量操作 ，检测多个非连续标识用 , 隔开 、连续的标识可使用 - 串联！！！

格式：check [1,2,4-6,8] 1

#if
check [1,2,4-6,8] 1
#act
SENDMSG 6 1,2,4,5,6,8全为1

--------------------------------------------------------

Check [n] 1 ;测试逻辑变量是否为真，可以测试是否已经完成了任务

small 变量 数值 ;如果“变量 < 数值”则为1否则为0

large 变量 数值 ;如果“变量 > 数值”则为1否则为0

equal 变量 数值 ;如果“变量 = 数据”则为1否则为0

checkjob Warr(Wizard、Taos) ;测试职业 成功为1否则为0

checkgold 数值 ;拥有金币数>=数值为1否则为0

checklevel 数值 ;人物等级>=数值为1否则为0

checkitem 物品 数值 ;测试拥用物品的数量

genderman ;测试性别为男，如果为男则为1否则为0

CHECKBAGSIZE ;检测背包空格数量，CHECKBAGSIZE 数量

checkpkpoint 数值 ;数值为PK值，PK值数>值时为1否则为0

CheckLuckPoint 数值 ;同上，只是测的是幸运值(检测符号：> < =)

checkmonmap 地图名 数值 ;同上，只是测的是怪物数量

checkduraeva 物品名 数值 ;同上，只是测试有品质的物品的品质

checkhum 地图名 数值 ;同上，测试这个地图的人数

checkitemw 物品 检测身上所带的物品

takew 物品 直接从身上回收物品(支持位置0-51)

checkmagicname 技能名称 检测已经修炼的技能

脚本大全 [喜欢脚本的来]
传奇商用NPC开头解释(部分,补足请补足)
%100 代表买东西是原价格还是双倍价格
+40 买肉
+1 卖肉
+43 武器有关(修)
+15 头盔
+10 买衣服
+11 修衣服
+26 修手镯类
+0 买各种药水
+42 卖各种药水
+30 蜡烛等.
+25 特殊水
+3 买卷轴,书类
+4 卖书类
+19 项链
+20 项链
+21 项链
+22 买戒指
+23 卖戒指
+24 买手镯
+26 卖手镯
+5 修炼武器或买武器
+6 修炼武器或卖武器
================================

checkjob (Warr, Wizard, Taos) ;测试职业
checkgold (金币数) ;测试金币
checklevel (等级) ;测试等级
checkitem (物品名) (数量) ;测试物品及数量
give gold (金币数) ;给钱
give (物品名) (数量) ;给物及数量
take gold (金币数) ;拿走钱
take (物品名) (数量) ;拿走物及数量
checkpkpoint (pk值) ;测试PK值
checkduraeva (物品名) (数值) ;一般测试矿物等物品的品质
checkhum (地图名) (数值) ;测试这个地图的人数
checkmonmap (地图名) (数值) ;测试这个地图的怪物数
map (地图名) ;移动到这个地图
mapmove (地图名) (坐标A) (坐标B) ;移动到这个地图指定坐标
monclear 地图清除
close 关闭对话框
TimeRecall (设定时间值) ;分钟,一般指进入地图时间限制
BreakTimeRecall ;中断设定时间
ExchangeMap (地图名) ;与指定地图里的人交换位置
daytime sunset ;一天时间
checkbaggage ;测试背包满没
small (变量) (数值) ;测试变量是不是小于指定数值
large (变量) (数值) ;测试变量是不是大于指定数值
equal (变量) (数值) ;测试变量是不是等于指定数值
mov (变量) (数值) ;让变量等于指定数值
sum (变量A) (变量B) ;A+B 注意,如果还要家第3个数直接换行写sum (变量C)
注:关于SUM的详解
首先有MOV (变量X) 0 ;(变量X)清0
sum (变量A) (变量B) ;X=A+B
sum (变量C) ;X=X+C
movr (变量) (数值) ;随机把指定数值以下的数(正数)给变量
inc (变量) (数值) ;让变量自动加指定数值到变量
;----------------------------------------------------------------------------------
playdice (骰子数) @xxx ;玩骰子,跳转到标签[@xxx]
; 整一个骰子来摇； 变量D0是第一个骰子最后的点数，D1是第2个骰子，顺序往后
; 如果没有给初始值（初值为0），则骰子最后没有点数即看不到
#act
; 1个骰子摇
mov D0 3
playdice 1 @XXX
; 3个骰子摇
mov D0 1
mov D1 3
mov D2 5
playdice 3 @XXX
;----------------------------------------------------------------------------------
random (随机数) ;一般用在#IF语句中作为触发#IF机率,有时随机数=并列#IF语句数用 于随机多项选择,例如: #IF RANDOM 3 #SAY() #ELSEACT
Check [条件数] 1 ;测试[条件数]触发与否 1(触发)
SET [条件数] 1 ;设置[条件数]触发
Monclear 地图 清理这个地图！
Param1 地图 地图名
Param2 横坐标 坐标
Param3 纵坐标 坐标
MonGen 怪物名称 数量 时间
TimeRecall 时间 时间限制

二。脚本变量：
<$USERNAME> 当前用户名
<$GUILDWARFEE> 行会战金币数
<$LORD> 沙巴克行会头名
<$OWNERGUILD> 沙巴克行会名
<$UPGRADEWEAPONFEE> 升级武器价格
<$USERWEAPON> 放在对话框里的武器名字
<$STR(变量)> 把变量转换为字符型 random (随机数) ;一般用在#IF语句中作为触发#IF机率,有时随机数=并列
#IF语句数用 于随机多项选择,例如: #IF RANDOM 3 #SAY() #ELSEACT


登录二级密码功能

二级密码功能

LoginSrv 启用二级密码

路径：mirserver\LoginSrv\Logsrv.ini
查找：
EnabledL2Password=0

修改为：
EnabledL2Password=20161105

然后重启LoginSrv.exe，打开基本设置即可看到二级密码相关设置！

本功能20170419开始已经无需设置参数，默认开启！


登录器标识变量

[+]登录器推广标识变量

登录器版本号变量：<$ClientBuildVer> ;这个变量基本没什么用，属内核编译版本变量

登录器推广标识:<$GamePromotionFlag> ；由登录器配置器上面自定义配置


仿Herom2第三方骑马参数：变量：<$HORSE> 装备位置：15

数据库字段：（其他字段自己随便填写或者参考仿官方填写）
stdmode ------- 28 马牌
Horse --------- 20-28（马的外观进行29-49为扩展.读取L-Horse1.wil）
source -------- 当 stdmode=28 并且Horse=[20-28]时，为马上的人物外观(0，1）
Expend3 ------- 当 stdmode=28 并且Horse=[20-28]时，为马上的人物在马上的发型(0，1）
Expend2 ------- 0 代表（马上的人物衣服外观）在马牌上控制
Expend2 ------- 1 代表（马上的人物衣服外观）在衣服上Horse字段控制
Expend4 = 1-6为horse2（图标编号：1920-3839）中马的6组特效，0为不使用特效

==========================================================================================

文件说明：

第三方骑马人物衣服素材，文件名：L-HumHorse.wil 读取为0-49；L-HumHorse1.wil为50-99；L-HumHorse2.wil 读取为100-149；.......L-HumHorse6.wil 读取为300-349；
第三方骑马坐骑马的素材，文件名：L-Horse.wil 读取为20-28；L-Horse1.wil 读取为29-49；L-Horse2.wil 读取为50-99
第三方骑马马上发型素材，文件名：L-HairHorse.wil 读取为0-14，15种发型

如不懂扩展说明请先看一次上面所描述的数据库字段，然后再看扩展说明！

2014-06-06 （支持韩服马上的人物外观扩展）
是否用马牌的horse还是用衣服的horse用 expand2来控制
当马牌 Expend2 字段设置为[1] ，马上的人物衣服外观由stdmode=10、11(人物衣服DB)中的Horse字段控制。
（注：马牌source字段的马上的人物外观不再控制；当没穿衣服时显示L-HumHorse里第一个裸体外观）

==========================================================================================

DB详情：（注意：overlap字段控制由于冲突已经修改到Expend3字段控制，以下DB为老DB，导入后将overlap 字段中数值修改到Expend3内即可）

1186,官方红马,28,114,1,0,1,0,3475,20000,0,0,0,0,0,0,0,0,0,0,1,0,3049,5,245,1,0,0,0,1,0,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1188,赤红马,28,0,1,33,1,0,288,2000,0,0,0,0,0,0,0,0,0,0,1,0,3049,5,245,1,0,0,0,3,0,0,3,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1227,主宰者马牌,28,0,1,0,0,0,3475,20000,0,0,10,10,10,10,10,10,10,10,0,5,3049,5,251,,,0,,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1228,主宰者双人马牌,28,0,1,0,1,0,3475,20000,0,0,10,10,10,10,10,10,10,10,0,5,3049,5,251,,,0,,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1229,主宰者灵笛,28,0,1,0,0,0,288,2000,0,0,10,10,10,10,10,1,10,10,0,5,3049,5,251,1,,,,2,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,5
1230,主宰者双人灵笛,28,0,1,0,1,0,4293,5000,10,10,0,0,0,0,0,0,0,0,0,0,50000,50,251,1,0,0,0,2,,,,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1231,黑鬃马,28,0,1,0,1,0,1223,50000,10,10,10,10,4,9,2,7,3,8,0,45,200000,5,251,,,,,4,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1232,枣红马,28,0,1,0,1,0,1223,50000,6,10,6,8,7,14,9,11,11,12,0,50,200000,5,251,,,,,21,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1233,赤兔马,28,0,1,0,1,0,1223,50000,7,11,6,9,8,15,10,12,12,13,0,55,200000,5,251,,,,,22,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1234,汗血马,28,0,1,0,1,0,1223,50000,8,12,7,11,9,16,11,13,13,14,0,60,200000,5,251,,,,,23,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1235,白龙马,28,0,1,0,1,0,1224,50000,9,14,8,13,10,18,12,15,14,16,0,65,200000,5,251,,,,,24,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1236,迎亲马,28,0,1,0,1,0,1224,50000,12,17,11,16,12,20,14,17,16,18,0,70,200000,5,251,,,,,25,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1237,黄金马,28,0,1,0,1,0,1060,50000,15,20,16,20,14,22,16,19,18,20,0,75,200000,5,251,,,,,26,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1238,卓越战马,28,0,1,0,1,0,2419,50000,20,25,21,25,16,24,18,21,20,22,0,80,200000,5,251,,,,,27,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1239,御龙灵兽,28,0,1,0,1,0,2419,50000,20,25,21,25,16,24,18,21,20,22,0,80,200000,5,251,,,,,28,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
备注：属性请自行调整；(454-462为HEROM2骑马)
==========================================================================================

2、QF段触发：

@UPHORSE：上马触发
[@UPHORSE]
#if
#act
Sendmsg 7 您的坐骑成功被召唤！
break

-----------------

@DOWNHORSE：下马触发

[@DOWNHORSE]
#if
#act
Sendmsg 7 您的坐骑成功被收回！
break

-----------------

2、上下马脚本命令：

[@UpOrDownHorse]
#if
#act
UpOrDownHorse
Sendmsg 7 OK！
break

==========================================================================================

骑马时候声音（程序包内第三方补丁文件内查看）
#######################################2019-03 扩展支持第三方马特效#######################################

Expand4: 扩展马特效
Horse = 3 - 5时，特效支持 0- 6（0:表示无特效），特效文件读取 Data\horse2.wil (1920-3839)，320张一组
Horse = 20 - 28时，特效支持 0- 9（0:表示无特效），特效文件读取 Data\L-HorseEffect.wil ，600张一组
Horse = 29 - 49时，特效支持 0-21（0:表示无特效），特效文件读取 Data\L-HorseEffect1.wil ，600张一组
Horse = 50 - 99时，特效支持 0-50（0:表示无特效），特效文件读取 Data\L-HorseEffect2.wil ，600张一组

==========================================================================================

第三方介绍：(上马和下马命令在引擎游戏命令处查看)

上马方法：
1） 上马必须将马牌装备在相应装备位当中；
2） 装备好之后，在F12当中设置快捷键（若未设置按照默认快捷键ctrl+g）；
3） 使用快捷键召唤坐骑；

下马方法：
1. 主动下马：
1） 大退下马
2） 小退下马
3） 使用快捷键下马
2. 被动下马：
1） 死亡下马
2） 马牌放入包裹当中：下马

坐骑状态下，可进行的动作：
1） 走：每步1格。鼠标左键进行操作；
2） 跑：每步3格。鼠标右键进行操作；
3） 可进行吃药；
4）可进行自动开盾；
5） 可面对面交易、丢弃物品；
6） 可点击NPC。
7）可以释放烟花。

坐骑状态下，不可进行的动作：
1） 无法攻击其他目标；
2） 不可接水；
3） 不可拾取
4） 不可挖宝；
5） 不可挑战；
6） 骑乘状态下，不可进行有起手动作的动作。。


掉落身上装备命令

人物：
HumanDropUseItem 装备位置
英雄：
H.HumanDropUseItem 装备位置

[@main]
#IF
#act
HumanDropUseItem 1
SendMsg 6 您佩戴的武器掉落了


掉落提示增加支持物品属性信息查看

默认：
DropItemHint=物品[%Item]从[%Name]身上掉落在地图%Map(%X,%Y)处

如果需要掉落显示物品属性请到String.ini文件内将DropItemHint项修改如下即可：

DropItemHint=物品[%ShowItem]从[%Name]身上掉落在地图%Map(%X,%Y)处

注：（20180512修改如下）
%ShowItem 显示当前掉落物品名字

%ShowDBItem 显示数据库名字 就算改名了也显示数据库的

2020824修改:
人物掉落提示/怪物掉落提示：HumDropItemHint，DropItemHint，增加数据库名变量%DBItem (原默认的%Item修改为支持掉落触发改名后的名字显示)


动态创建镜像地图

动态创建一个镜像地图

ADDMIRRORMAP
格式：AddMirrorMap 参数1 参数2 参数3 参数4 参数5 参数6
功能：动态创建一个镜像地图

参数1：原地图编号，在地图配置文件中存在的地图！
参数2：新地图编号，临时使用的地图编号，就和镜像地图功能一样！
参数3：新地图名，这里指客户端显示的名字
参数4：该地图存在的有效时长(秒)，时间到后，此地图将自动回收，并且将地图上的人传送至E参数设置的地图
参数5：人物退出时返回的地图编号
参数6：小地图编号
参数7：变量名，创建成功会将变量写1，否则写0
参数8：为0：剩3分钟显示剩余时间，1：一直显示剩余时间
参数9：人物退出时返回的地图位置（空或0,0：表示随机位置； 200,300：退出镜像地图返回到200,300的坐标）注意：如果坐标不可达，命令会提示错误

;--------------------------------------------------------------------------------------------------
删除镜像地图
DelMirrorMap 镜像地图编号
;--------------------------------------------------------------------------------------------------
获取镜像地图时间

GetMirrorMapTime 地图名 总时间变量 剩余时间变量(可选参数）

#act
GetMirrorMapTime 镜像地图2 N1 N2
sendmsg 6 地图的总有效时间为<$STR(N1)>，剩余时间为<$STR(N2)>

;--------------------------------------------------------------------------------------------------
重新设置镜像地图时间
SetMirrorMapTime 镜像地图编号 值 是否重新计算时间 （ 1为重新计算时间 留空则为重新设置的时间减少已使用时间）
;--------------------------------------------------------------------------------------------------
检查是否为镜像地图
CheckMirrorMap 地图编号

;--------------------------------------------------------------------------------------------------

特别注意：部分用户ADDMIRRORMAP命令报错 （可创建地图，就是命令会报错）。。。。。原因是：【第7个参数应该是变量名，而非值】

示例脚本1 ：AddMirrorMap EM006 <$USERNAME>BOOS地图 冰封决土豪空间 600 2 0 N8 1 410,550
示例脚本2 ：AddMirrorMap <$const(n3)> <$USERNAME>BOOS地图 冰封决土豪空间 600 2 0 N8 1 410,550

注意：$CONST( 是后面加的，为了表示常量 ，这样运用可以避免一些变量开头字母为系统变量字符如：A N S D P ，使用了$CONST则可防止二次解析

或者其他脚本地方需要避免变量字母可参考下方示范脚本
CHECKTEXTLIST ..\QuestDiary\测试.txt <$STR(S$什么)>
改成
CHECKTEXTLIST ..\QuestDiary\测试.txt S$什么
也可以避免当变量内容开头字母为系统变量字母二次解析


官方马牌参数： 变量：<$HORSE>装备位置：15
==========================================================================================

1、DB段详情参数：

stdmod -------- 28 马牌
source -------- 1：支持双人骑，0：不支持双人骑， 仅当stdmod=28并且Horse=[1,2]时有效
Expend3 ------- 0：不显示翅膀特效；1：显示翅膀特效 只对官方主宰者灵虎有效(stdmod=28; Horse=2)
Horse --------- 1：主宰者战马， 2：主宰者灵虎 （3-5为Horse2.wzl单人马匹，320张一个性别，640张一组，自动区分男女，如设置3读取Horse2.wzl文件的0-639张图片）
Expend2 = 0代表（马上的人物衣服外观）在马牌上控制
Expend2 = 1代表（马上的人物衣服外观）在衣服上Horse字段控制
Expend4 = 1-6为horse2（图标编号：1920-3839）中马的6组特效，0为不使用特效

DB详情：（overlap字段控制由于冲突已经修改到Expend3字段控制，原数据需手动手动数据库，以下DB无需修改）

198;主宰者马牌;28;0;1;0;0;0;3475;20000;0;0;10;10;10;10;10;10;10;10;0;5;3049;5;251;;;0;;1;0;0;0;;;;;;;;;;;;;;;;;;;;;;
199;主宰者双人马牌;28;0;1;0;1;0;3475;20000;0;0;10;10;10;10;10;10;10;10;0;5;3049;5;251;;;0;;1;0;0;0;;;;;;;;;;;;;;;;;;;;;;
200;主宰者灵笛;28;0;1;0;0;0;288;2000;0;0;10;10;10;10;10;1;10;10;0;5;3049;5;251;0;;;;2;0;0;0;1;;;;;;;;;;;;;;;;;;;;;6
201;主宰者双人灵笛;28;0;1;0;1;0;4293;5000;10;10;0;0;0;0;0;0;0;0;0;0;50000;50;251;0;0;0;0;2;;;;1;;;;;;;;;;;;;;;;;;;;;6
202;Horse2第一个;28;0;1;0;0;0;3475;20000;0;0;10;10;10;10;10;10;10;10;0;5;3049;5;251;;;0;;3;0;0;0;;;;;;;;;;;;;;;;;;;;;;
203;Horse2第二个;28;0;1;0;0;0;3475;20000;0;0;10;10;10;10;10;10;10;10;0;5;3049;5;251;;;0;;4;0;0;0;;;;;;;;;;;;;;;;;;;;;;
204;Horse2第三个;28;0;1;0;0;0;3475;20000;0;0;10;10;10;10;10;10;10;10;0;5;3049;5;251;;;0;;5;0;0;0;;;;;;;;;;;;;;;;;;;;;;

=====================================================================================================================================
1186,官方红马,28,114,1,0,1,0,3475,20000,0,0,0,0,0,0,0,0,0,0,1,0,3049,5,245,1,0,0,0,1,0,0,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1188,赤红马,28,0,1,33,1,0,288,2000,0,0,0,0,0,0,0,0,0,0,1,0,3049,5,245,1,0,0,0,3,0,0,3,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1227,主宰者马牌,28,0,1,0,0,0,3475,20000,0,0,10,10,10,10,10,10,10,10,0,5,3049,5,251,,,0,,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1228,主宰者双人马牌,28,0,1,0,1,0,3475,20000,0,0,10,10,10,10,10,10,10,10,0,5,3049,5,251,,,0,,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
1229,主宰者灵笛,28,0,1,0,0,0,288,2000,0,0,10,10,10,10,10,1,10,10,0,5,3049,5,251,1,,,,2,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,5
1230,主宰者双人灵笛,28,0,1,0,1,0,4293,5000,10,10,0,0,0,0,0,0,0,0,0,0,50000,50,251,1,0,0,0,2,,,,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

备注：属性请自行调整；(454-462为HEROM2骑马)
==========================================================================================

2、QF段触发：

@UPHORSE：上马触发

[@UPHORSE]
#if
#act
Sendmsg 7 您的坐骑成功被召唤！
break

-------------------------------------------------------
@DOWNHORSE：下马触发

[@DOWNHORSE]
#if
#act
Sendmsg 7 您的坐骑成功被收回！
break
-----------------

2、上下马脚本命令：

[@UpOrDownHorse]
#if
#act
UpOrDownHorse
Sendmsg 7 OK！
break

==========================================================================================

骑马时候声音（程序包内第三方补丁文件内查看）
==========================================================================================

3、相关操作

邀请方式：

鼠标移至身边3格内的不在坐骑状态下的玩家，点击以下快捷键，即可进行邀请。
邀请命令：CTRL+L（固定键）
下马命令：CTRL+G（邀请人和被邀请人共用）

双人坐骑状态：

1. 基础设定：
走路（鼠标左键）：1格；
跑步（鼠标右键）：3格。
双人坐骑状态下无法攻击、不可接水、不可拾取、不可挖宝，不可进行有起手动作的动作。如：不可逗宠物，不可释放除烟花、璀璨烟花、传情烟花和周年庆礼炮之外的其它烟花等。（包含邀请人和被邀请人）
2. 邀请人坐骑状态：
邀请人坐骑状态遵循单人坐骑状态所有条件（除不可组队）。
3. 被邀请人坐骑状态：
1） 被邀请人可进行状态：吃药、小退、大退、下马、聊天五种操作；
2） 其他操作由邀请人进行决定。
4. 伤害计算：双人坐骑为1格，双人共用格子。被攻击的伤害全部施放在邀请人身上，被邀请人为保护状态。
5. 状态展示：所有双人坐骑状态，遵循邀请人坐骑状态。如，心法状态判断邀请人是否开启心法，中毒判断邀请人是否中毒等。
6. 被邀请人界面：在双人坐骑状态下，被邀请人界面出现下马按钮，为一个马按钮状，点击可直接下马，同时有悬浮提示：点击按钮可直接下马。
7. 双人骑外显：双人坐骑时，邀请人显示坐骑后方，被邀请人显示坐骑前方。
8.角色名显示：
在双人坐骑状态下，不显示其他称号，只显示名字。邀请人名字显示在后部，被邀请人名字显示在前部。
9. 血条显示：
在双人坐骑状态下，只显示邀请人血条和内功条，被邀请人血条不显示。
10.禁止相关：
双人坐骑状态下，点击传送相关按钮和使用传送石进行传送，将无反应。双人骑状态，邀请人和被邀请人无法进行组队。

下马设置：

1. 被邀请人单独下马：
被邀请人快捷键下马：CTRL+G，或点击操作界面下马按钮。
小退单独下马
大退单独下马
被邀请人死亡下马
2. 共同下马：
邀请人快捷键下马：CTRL+G
邀请人小退
邀请人大退
邀请人死亡
===========================================================================================================================================

单人骑马介绍：

上马方法：
    1） 上马必须将马牌装备在相应装备位当中；
    2） 装备好之后，在F12当中设置快捷键（若未设置按照默认快捷键ctrl+g）；
    3） 使用快捷键召唤坐骑；

下马方法：(上马和下马命令在引擎游戏命令处查看)
    1. 主动下马：
        1） 大退下马
        2） 小退下马
        3） 使用快捷键下马
    2. 被动下马：
        1） 死亡下马
        2） 马牌放入包裹当中：下马

坐骑状态下，可进行的动作：
    1） 走：每步1格。鼠标左键进行操作；
    2） 跑：每步3格。鼠标右键进行操作；
    3） 可进行吃药；
    4）可进行自动开盾；
    5） 可面对面交易、丢弃物品；
    6） 可点击NPC。
    7）可以释放烟花。

坐骑状态下，不可进行的动作：
    1） 无法攻击其他目标；
    2） 不可接水；
    3） 不可拾取
    4） 不可挖宝；
    5） 不可挑战；
    6） 骑乘状态下，不可进行有起手动作的动作。。

===========================================================================================================================================


国战系统脚本实例

 [@main]
测试1：<加入一个国家/@加入国家>
测试2：<检查是否第一个国家的人/@检查是否加入国家>
通用：<国家信息/@国家信息>\
<国家人数/@国家人数> \

测试3：<成为国王/@成为国王> 测试4：<检查是否第一个国家国王/@检查是否国王> 测试5：<检查是否国王/@检查是否国王2> \
测试7：<叛国/@叛国> 测试8：<更改国家为中国/@修改中国字>\
测试8：<国家资金/@国家资金>
测试6：<修改国家名字/@@InPutString60> <国家资金检测/@国家资金2>
-----------------------------------------\
新序列：\
<国家一刷兵过/@shanglu> <国家二刷兵过/@shanglu1> <国家消息/@国家消息>

[@国家消息]
#IF
#ACT
SuperMoveMsg 8 这是一个居中显示的公告. 3

[@shanglu]
#if
#act
MISSION 3 320;320,320 320;330,320
PARAM1 333
PARAM2 333
PARAM3 1
PARAM4 1
PARAM5 1
PARAM6 0
PARAM7 1
PARAM8 1
PARAM9 0
MOBPLACE 黑野猪
sendmsg 6 刷新成功。
break

[@shanglu1]
#if
#act
MISSION 3 320;320,320 320;330,320
PARAM1 333
PARAM2 333
PARAM3 1
PARAM4 1
PARAM5 2
PARAM6 0
PARAM7 1
PARAM8 2
PARAM9 1
MOBPLACE 红野猪
sendmsg 6 刷新成功。
break

[@加入国家]
#IF
CheckNation 0
#ACT
JoinNation 2
#SAY
你加入了一个国家.
#ELSESAY
你已经加入了国家.

[@检查是否加入国家]
#IF
CheckNation 1
#SAY
你是编号1国家的人
#ELSESAY
你不是编号1国家的人.

[@国家信息]
当前你加入了编号为<$NATION>的<$NATIONNAME> 该国共有：<$NATIONPEOPLE>人\

[@检查是否国王]
#IF
IsNationKing 1
#SAY
你是编号1国家的国王
#ELSESAY
你不是编号1国家的国王

[@检查是否国王2]
#IF
IsNationKing
#SAY
你是国王
#ELSESAY
你不是国王

[@叛国]
#IF
#ACT
ExitNation
#SAY
叛国成功.
#ELSESAY
叛国失败

[@国家资金2]
#IF
#ACT
SetNationValue 0 0 > 1
#SAY
成功.
#ELSESAY
失败

[@国家资金]
国家信息展示：\
金币:<$NationGold> 建筑能力:<$NationBuilding> 军事能力:<$NationArm> 经济能力:<$NationEconomy> 政治能力:<$NationPolitics> 国家贡献:<$NationContribution> 地图数:<$NationMaps>\
临时调整面板 \
对编号<0-6/@@InPutString61>中的<$STR(N$临时类型)>进行<$STR(S$加减操纵)> <加减操作/@@InPutString62> <数量为/@@InPutString63> <$STR(N$临时数量)>处理。 <开始/@条件开始>

[@InPutString61]
#IF
#ACT
mov <$STR(N$临时类型)> <$STR(S61)>
goto @国家资金
[@InPutString62]
#IF
#ACT
mov <$STR(S$加减操纵)> <$STR(S62)>
goto @国家资金

[@InPutString63]
#IF
#ACT
mov <$STR(N$临时数量)> <$STR(S63)>
goto @国家资金

[@条件开始]
#IF
#ACT
SetNationValue 0 <$STR(N$临时类型)> <$STR(S$加减操纵)> <$STR(N$临时数量)>
MESSAGEBOX ！！！！！
goto @国家资金

[@国家人数]
#IF
CheckNationHumCount > 100
#SAY
当前国家大于1人.
#ELSESAY
目前你的国家还没有这么强大

[@InPutString60]
#IF
CheckNationNameExists <$STR(S60)>
#ACT
#SAY
修改失败 国家已存在
#ELSEACT
SetNationName 1 <$STR(S60)>
#ELSESAY
修改完成

[@修改中国字]
#IF
#ACT
SetNationName 1 华夏帝国
#SAY
修改成功
#ELSESAY
修改失败

[@成为国王]
#IF
#ACT
SetNationKing 1
#SAY
你现在是国家1的国王了


国战系统命令汇总

国战系统

国战系统 常量如下、后附常量脚本：
国家系统检测是否加入国家、国家编号等变量，如果是0，就表示没有加入国家 非0表示加入了国家
-----------------------------------------------------------------
M2总控相关：
选项-参数设置-环境设置-是否监听国家说话
选项-参数设置-坐标范围-国家模式控制
选项-参数设置-文字颜色-国家说话颜色
选项-游戏命令-普通命令-国家相关命令
选项-参数设置-状态控制-国家人物名字颜色设置
-----------------------------------------------------------------
国家聊天命令：
!#要说的话发布国家信息
-----------------------------------------------------------------
Envir\Nations\Nations.ini中的NationalNames1 -- NationalNames255是国家的名字,只有定义了国家名字之后加入国家才有效!
Nations.ini默认信息如下：
[Names]
NationalNames1=沧月国
NationalNames2=凌风国
NationalNames3=炎天国
NationalNames4=
NationalNames5=
NationalNames6=
NationalNames7=
NationalNames8=
NationalNames9=
NationalNames10=
NationalNames11=
NationalNames12=
NationalNames13=
NationalNames14=
NationalNames15=
NationalNames16=
NationalNames17=
NationalNames18=
NationalNames19=
NationalNames20=
NationalNames21=
NationalNames22=
NationalNames23=
NationalNames24=
NationalNames25=
NationalNames26=
NationalNames27=
NationalNames28=
NationalNames29=
NationalNames30=
NationalNames31=
NationalNames32=
NationalNames33=
NationalNames34=
NationalNames35=
NationalNames36=
NationalNames37=
NationalNames38=
NationalNames39=
NationalNames40=
NationalNames41=
NationalNames42=
NationalNames43=
NationalNames44=
NationalNames45=
NationalNames46=
NationalNames47=
NationalNames48=
NationalNames49=
NationalNames50=
NationalNames51=
NationalNames52=
NationalNames53=
NationalNames54=
NationalNames55=
NationalNames56=
NationalNames57=
NationalNames58=
NationalNames59=
NationalNames60=
NationalNames61=
NationalNames62=
NationalNames63=
NationalNames64=
NationalNames65=
NationalNames66=
NationalNames67=
NationalNames68=
NationalNames69=
NationalNames70=
NationalNames71=
NationalNames72=
NationalNames73=
NationalNames74=
NationalNames75=
NationalNames76=
NationalNames77=
NationalNames78=
NationalNames79=
NationalNames80=
NationalNames81=
NationalNames82=
NationalNames83=
NationalNames84=
NationalNames85=
NationalNames86=
NationalNames87=
NationalNames88=
NationalNames89=
NationalNames90=
NationalNames91=
NationalNames92=
NationalNames93=
NationalNames94=
NationalNames95=
NationalNames96=
NationalNames97=
NationalNames98=
NationalNames99=
NationalNames100=
;....自己添加
;....最多255个

-----------------------------------------------------------------
国家基础变量：
国家编号：<$NATION>
国家名称：<$NATIONNAME>
国家人数：<$NATIONPEOPLE>
国家金币：<$NationGold>
建筑能力：<$NationBuilding>
军事能力：<$NationArm>
经济能力：<$NationEconomy>
政治能力：<$NationPolitics>
国家贡献：<$NationContribution>
地图数：<$NationMaps>
---------------------------------------------------------------
指定编号国家信息（编号用X表示（1-100））
国家名称：<$NationNameX>
国家人数：<$NationPeopleX>
国家金币：<$NationGoldX>
建筑能力：<$NationBuildingX>
军事能力：<$NationArmX>
经济能力：<$NationEconomyX>
政治能力：<$NationPoliticsX>
国家贡献：<$NationContributionX>
地图数：<$NationMapsX>
---------------------------------------------------------------
地图参数相关：
地图参数强制锁定攻击模式： NOSWITCHATTACKMODE 增加锁定攻击模式1-8（0或无括号表示不锁定），如下
NOSWITCHATTACKMODE(1)
地图参数：SHOWNATIONCOLOR 含此参数的地图会强制显示国家颜色（游戏参数——》状态控制——》国家名字颜色识别）
-----------------------------------------------------------------

国家相关命令：

检测是否加入国家（最多支持255个国家）：
CheckNation 国家编号

加入国家（最多支持255个国家）：
JoinNation 国家编号

检查是否国王：
IsNationKing 国家编号 （为空表示所有国家）

退出国家：
ExitNation

检查国家人数:
CheckNationHumCount > 人数

成为国王：
SetNationKing 国家编号

修改国家名称：
SetNationName 国家编号 国家名字

检测国家名字是否被使用
CheckNationNameExists 国家名称

设置国家相应的变量值
SetNationValue 国家编号(0表示人物所在的国家，1-100指定国家） 编号(0-6) 操作符(+,-,=) 值
参数2的编号如下：
0:金币
1:建筑能力
2:军事能力
3:经济能力
4:政治能力
5:国家贡献
6:地图数

-----------------------------------------------------------------
国家脚本刷怪设定：
此命令支持怪物巡逻坐标攻击，设置多个指定坐标后，怪物会沿途巡逻(按照设定坐标行走到最后一个坐标停止)
格式:
MISSION 地图 x1;x2;x3...xn y1;y2;y3...yn (x和y的数量要一致）
PARAM1 刷新怪物座标X
PARAM2 刷新怪物座标Y
PARAM3 数量
PARAM4 范围
PARAM5 国家编号
PARAM6 是否攻击本国玩家(0,1)
PARAM7 不同国家怪物是否PK(0,1)
PARAM8 怪物名字颜色
PARAM9 是否允许本国玩家攻击(0,1)
MobPlace 怪物名称
;;;;;;;;;;;;;;;;;;;;刷怪命令扩展最后一个参数，为空表示可攻击所有可攻击的对象，指定名字表示只攻击指定名称的可攻击对象
MOBPLACE 怪物名称 目标名称

示范：
[@国家刷怪]
#act
MISSION 3 319;319 320;340
PARAM1 333
PARAM2 333
PARAM3 10
PARAM4 0
PARAM5 1
PARAM6 0
PARAM7 1
PARAM8 242
PARAM9 0
MOBPLACE 国家士兵
-----------------------------------------------------------------
MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家编号 同国家名玩家是否可攻击(0,1)
说明：最后一个参数为0时表示同国家玩家不能攻击该怪物，为1时在非国家攻击模式下可以攻击该怪物
-----------------------------------------------------------------
国家支持的信息：
格式: SendCenterMsg 前景色 背景色 消息文字 模式 显示时间 倒计时标签 是否替换模式（0或空为不替换，不等于0为替换模式)
模式: 0=发送给自己 1=发送所有人物 2=发送行会 3=发送国家 4=发送当前地图.
-----------------------------------------------------------------

以下命令和刷怪文件内关于 填写国家名字的修改为国家编号 更新引擎务必修改！！！！！
MobPlace
MonGen
MonGenEx
刷怪文件
管理员命令：Mob

-----------------------------------------------------------------

国王名称变量：
<$NATIONKING>
<$NATIONKINGX>


获取当前NPC名称

获取当前NPC名字命令

[@main]
#IF
#act
GetNpcName S1
SendMsg 6 当前NPC名称<$STR(S1)>


获取装备镶嵌宝石数量

命令：
获取装备宝石数量
GetItemStoneCount 装备位置 宝石名称(不分名称可用 * 或 all） 变量

获取身上所有装备宝石数量
GetStoneCount 宝石名称(不分名称可用 * 或 all） 变量

示范：
GetItemStoneCount 1 * N10
SENDMSG 6 你的【<$WEAPON>】上面共有宝石：<$STR(N10)>

GetItemStoneCount 1 攻击青宝石(初级) N10
SENDMSG 6 你的【<$WEAPON>】上面共有【攻击青宝石(初级)】：<$STR(N10)>

GetStoneCount * N10
SENDMSG 6 你的身上所有宝石共有宝石：<$STR(N10)>

GetStoneCount 攻击青宝石(初级) N10
SENDMSG 6 你的身上【攻击青宝石(初级)】共有宝石：<$STR(N10)>


将需要继承的补丁文件放入补丁文件夹内相应的目录内.

如：
WZL wil补丁放入配置器目录的补丁文件夹的DATA目录内 如果是PAK就放入 Resources/data目录内.生成登陆器将自动压缩到登陆器内.。PAK地图的话建议MAP文件也放入Resources/MAP内.

其他文件集成可以参阅配置器的特殊集成！！！
注：物品备注、内挂捡起、套装备注需集成到登陆器内请将引擎上发送到客户端关闭.否则将以引擎为准.
集成读取规则：生成后读取本地-->远程更新-->引擎 (引擎未开启发送：-->本地与远程对比MD5,如不一致将从远程重新下载列表.远程如未添加列表更新则以本地集成为主....--->凡是开了引擎发送均以引擎为主)


脚本变量大全[!]

脚本变量

人物信息

变量名称 | 说明
<$USERNAME> | 人物名称
<$GUILDNAME> | 行会名称
<$RANKNAME> | 行会职位名称
<$LEVEL> | 等级
<$HP> | 生命值
<$AC> | 防御力
<$MAXAC> | 最高防御力
<$MAC> | 魔法防御力
<$MAXMAC> | 最高魔法防御力
<$DC> | 物理攻击力
<$MAXDC> | 最高物理攻击力
<$MC> | 魔法力
<$MAXMC> | 最高魔法力
<$SC> | 道术
<$MAXSC> | 最高道术
<$ASC> | 刺术
<$MaxASC> | 最高刺术
<$ARC> | 箭术
<$MaxARC> | 最高箭术
<$MPC> | 武力
<$MaxMPC> | 最高武力
<$H.ASC> | 英雄刺术
<$H.MaxASC> | 英雄最高刺术
<$H.ARC> | 英雄箭术
<$H.MaxARC> | 英雄最高箭术
<$H.MPC> | 英雄武力
<$H.MaxMPC> | 英雄最高武力
<$EXP> | 当前经验值
<$H.EXP> | 英雄当前经验值
<$MAXEXP> | 升级经验值
<$PKPOINT> | PK点数
<$H.PKPOINT> | 英雄PK点数
<$CREDITPOINT> | 声望点数
<$GOLDCOUNT> | 金币数量
<$CombatPower> | 人物战斗力
<$H.CombatPower> | 英雄战斗力
<$GAMEGOLD> | 游戏币数
<$GAMEPOINT> | 游戏点数
<$AddMaxBW> | 背包最大负重
<$HW> | 腕力
<$MAXHW> | 最高腕力
<$BW> | 背包重量
<$MAXBW> | 最高背包重量
<$WW> | 负重力
<$LUCK> | 幸运
<$H.LUCK> | 英雄幸运
<$POISONRECOVER> | 中毒恢复
<$HEALTHRECOVER> | 体力恢复
<$SPELLRECOVER> | 魔法恢复
<$ANTIPOISON> | 毒躲避
<$ANTIMAGIC> | 魔法躲避
<$MAXWW> | 最高负重
<$HUNGER> | 饥饿程度
<$LOGINTIME> | 登录时间
<$LOGINLONG> | 登录时长
<$DRESS> | 衣服
<$WEAPON> | 武器
<$RIGHTHAND> | 蜡烛
<$HELMET> | 头盔
<$NECKLACE> | 项链
<$RING_R> | 左戒指
<$RING_L> | 右戒指
<$ARMRING_R> | 左手镯
<$ARMRING_L> | 右手镯
<$BUJUK> | 护身符
<$BELT> | 腰带
<$BOOTS> | 鞋子
<$CHARM> | 宝石
<$HORSE> | 马牌
<$UserShopName> | 个人商店名称
<$HAT> | 斗笠
<$SHIELD> | 盾牌
<$DEARNAME> | 配偶的名字
<$G_DRESS> | 改名变量
<$H.G_DRESS> | 改名变量英雄
<$CASTLEGETDAYS> | 沙巴克占领天数,此变量需要沙巴克NPC中使用，比如沙皇宫管理人员
<$CASTLENAME> | 沙巴克名称
<$REQUESTCASTLEWARDAY> | 申请攻城需要的道具
<$OWNERGUILD> | 沙巴克管理行会名称
<$REQUESTBUILDGUILDITEM> | 创建行会需要的道具
<$LORD> | 沙巴克管理员名称
<$GUILDWARFEE> | 申请行会战争费用
<$BUILDGUILDFEE> | 创建行会费用
<$CASTLEWARDATE> | 获取攻城时间
<$LISTOFWAR> | 获取攻城列表
<$CASTLEWARLASTDATE> | 上次攻城时间
<$CASTLEGETDAYS> | 守城天数
<$GAMEDIAMOND> | 金刚石
<$GAMEGIRD> | 灵符
<$CURRRUSEMAGICID> | 人物当前攻击技能ID
<$H.CURRRUSEMAGICID> | 英雄当前攻击技能ID
<$MAP> | 人物当前地图代码
<$H.MAP> | 英雄当前地图代码
<$RELEVEL> | 显示人物转生等级
<$H.RELEVEL> | 显示英雄转生等级
<$STATSERVERTIME> | 显示M2启动时间
<$RUNDATETIME> | 开区间隔时间
<$KILLER> | 杀人者变量
<$HeroKiller> | 杀英雄者变量
<$CURRRTARGETNAME> | 被杀者变量
<$RANDOMNO> | 随机值变量
<$X> | 人物X坐标
<$H.X> | 英雄X坐标
<$Y> | 人物Y坐标
<$H.Y> | 英雄Y坐标
<$STR(N998)> <$STR(N999)> | 鼠标在游戏地图中的坐标，脚本请勿使用这2个变量
<$MouseX> <$MouseY> | 鼠标在游戏窗口中的坐标
<$H.ATTACKMONSTER_HP> | 英雄当前击中目标剩余HP
<$H.ATTACKMONSTER_MAXHP> | 英雄当前击中目标最大HP
<$H.ATTACKMONSTER_XEX> | 英雄当前攻击(主目标)目标X坐标
<$H.ATTACKMONSTER_YEX> | 英雄当前攻击(主目标)目标Y坐标
<$H.ATTACKMONSTER_X> | 英雄当前攻击目标X坐标
<$H.ATTACKMONSTER_Y> | 英雄当前攻击目标Y坐标
<$H.ATTACKMONSTER_HPEX> | 英雄当前锁定攻击(主目标)目标剩余HP
<$H.ATTACKMONSTER_MAXHPEX> | 英雄当前锁定攻击(主目标)目标最大HP
<$H.ATTACKMONSTER_NAME> | 英雄当前击中目标的名称
<$H.ATTACKMONSTER_NAMEEX> | 当前英雄锁定攻击(主目标)目标的名称
<$USERALLNAME> | 人物完整名称
<$GAMEGLORY> | 人物荣誉值
<$RevivalTime> | 复活剩余时间
<$SlaveCount> | 人物宝宝数量
<$HumCloneCount> | 人物分身数量
<$MapTitle> | 取地图名称
<$H.GetExp> | 英雄当前获得经验变量
<$H.LOYALPOINT> | 英雄忠诚度变量
<$GetExp> | 人物当前获得经验变量
<$USERID> | 人物登录帐号
<$H.KILLMONNAME> | 英雄杀死的怪物名称
<$KILLMONNAME> | 人物杀死的怪物名称
<$KILLMONX> <$KILLMONY> | 人物杀死怪物的坐标
<$RecallRemainingTime> | 显示延时TIMERECALL还剩多少秒
<$HIT> | 准确
<$SPD> | 敏捷
<$MACHINEID> | 玩家机器码
<$HITSPD> | 攻速（装备加速）
<$AttackSpeed> | 攻速（含脚本加速）
<$FASHIONDRESS> | 时装衣服
<$FASHIONWEAPON> | 时装武器
<$H.FASHIONDRESS> | 英雄时装衣服
<$H.FASHIONWEAPON> | 英雄时装武器
<$FASHIONNECKLACE> | 时装项链
<$FASHIONHELMET> | 时装头盔
<$FASHIONARMRINGL> | 时装左手镯
<$FASHIONARMRINGR> | 时装右手镯
<$FASHIONRINGL> | 时装左戒指
<$FASHIONRINGR> | 时装右戒指
<$FASHIONRIGHTHAND> | 时装照明物
<$FASHIONBELT> | 时装腰带
<$FASHIONBOOTS> | 时装鞋子
<$FASHIONCHARM> | 时装宝石
<$JADE> | 灵玉
<$H.GENDER> | 英雄性别
<$H.JOB> | 英雄职业
<$H.LEVEL> | 英雄级别
<$HERONAME> | 英雄名字
<$HMapTitle> | 英雄地图名字
<$HMAP> | 英雄地图编号
<$H.X> | 英雄前坐标X
<$H.Y> | 英雄前坐标Y
<$H.AngryValue> | 英雄怒气值
<$LIUSERCOUNT> | 离线人数()
<$YEAR> | 当前年份
<$MONTH> | 当前月份
<$DAY> | 当前日期
<$HOUR> | 当前小时
<$MINUTE> | 当前分钟
<$SECOND> | 当前秒
<$TEAM0>..<$TEAMX> | 用于显示组队成员,<$TEAM0>代表队长,成员从<$TEAM1>开始
<$STNAME> | 师徒名称变量
<$DRUM> | 军鼓变量
<$FBMAPNAME> | 人物当前副本地图名称
<$FBMAP> | 人物当前副本地图代码
<$SUCKDAMAGE> | 人物伤害吸收剩下值
<$ATTACKMONSTER_MAXHP> | 当前攻击目标总血量
<$ATTACKMONSTER_HP> | 当前攻击目标剩余血量
<$ATTACKMONSTER_MAXHPEX> | 当前攻击(主目标)目标总血量
<$ATTACKMONSTER_HPEX> | 当前攻击(主目标)目标剩余血量
<$ATTACKMONSTER_NAME> | 当前击中目标的名称
<$ATTACKMONSTER_NAMEEX> | 当前锁定攻击(主目标)目标的名称
<$ATTACKMONSTER_X> | 当前攻击目标X坐标
<$ATTACKMONSTER_Y> | 当前攻击目标Y坐标
<$ATTACKMONSTER_XEX> | 当前攻击(主目标)目标X坐标
<$ATTACKMONSTER_YEX> | 当前攻击(主目标)目标Y坐标
<$SlaveX> | 宝宝自身X坐标（当有多个宝宝时，随便选一个）
<$SlaveY> | 宝宝自身Y坐标（当有多个宝宝时，随便选一个）
<$SlaveTargetX> | 宝宝当前攻击目标X坐标（优先锁定目标，多宝宝随机抽取）
<$SlaveTargetY> | 宝宝当前攻击目标Y坐标（优先锁定目标，多宝宝随机抽取）
<$Pet.X > | 宠物自身X坐标
<$Pet.Y > | 宠物自身Y坐标
<$Pet.HP > | 宠物当前剩余HP
<$Pet.MaxHP > | 宠物最大HP
<$Pet.MP > | 宠物当前剩余MP
<$Pet.MaxMP > | 宠物最大MP
<$Pet.CurTargetName > | 宠物攻击目标名称（不包含数字）
<$Pet.CurTargetFullName > | 宠物攻击目标名称（包含数字）
<$Pet.CurTargetX > | 宠物当前攻击目标X坐标
<$Pet.CurTargetY > | 宠物当前攻击目标Y坐标
<$Pet.CurTargetHP > | 宠物当前击中目标剩余HP
<$Pet.CurTargetMaxHP > | 宠物当前击中目标最大HP
<$Pet.DamageValue > | 宠物攻击目标掉血量
<$Pet.KillMonName > | 宠物杀死的怪物名称
<$POWERRATE > | 人物攻击人物伤害力倍数
<$AttackMonPowerRate > | 人物攻击怪物伤害力倍数
<$POWERRATETIME> | 人物攻击人物伤害倍数剩余时间
<$AttackMonPowerRateTime> | 人物攻击怪物伤害倍数剩余时间
<$H.PowerRate> | 英雄攻击人物伤害力倍数
<$H.PowerRateTime> | 英雄攻击人物伤害倍数剩余时间
<$H.AttackMonPowerRate> | 英雄攻击怪物伤害力倍数
<$H.AttackMonPowerRateTime> | 英雄攻击怪物伤害倍数剩余时间
<$GROUPMEMBERCOUNT> | 当前组队人数
<$PKPOWER> | 人物对攻击目标的伤害输出值
<$H.PKPOWER> | 英雄对攻击目标的伤害输出值
<$StruckHP> | 自己被攻击减少的HP输出值
<$H.StruckHP> | 自己英雄被攻击减少的HP输出值
<$KILLMONBURSTRATE> | 人物杀怪暴率倍数（脚本命令调整）
<$KILLMONBURSTRATETIME> | 人物杀怪暴率倍数时间（脚本命令调整）
<$DUMMYCOUNT> | 在线的假人数
<$ONUSERCOUNT> | 真人在线数
<$UpgradeCount> | 人物全身星星数量
<$H.UpgradeCount> | 英雄全身星星数量
<$ClientBuildVer> | 登录器内核版本号
<$GamePromotionFlag> | 登录器推广标识
<$CurTargetMasterName> | 当前攻击目标的主人名(英雄、宝宝)
<$H.CurTargetMasterName> | 英雄当前攻击目标的主人名(英雄、宝宝)
<$GameDirectory> | 服务端目录变量
<$M2Directory> | M2所在目录变量
<$MAXHP> | HP上限
<$MAXMP> | MP上限
<$REVIVALTIME> | 复活间隔变量
<$KILLMONEXPRATE> | 杀怪经验倍数
<$KILLMONEXPRATETIME> | 杀怪经验倍数时长
<$GAMEGOLDEX> | 新游戏点数

天地结晶变量

变量名称 | 说明
<$GETCRYSTALEXP> | 天地结晶可提取的经验
<$GETCRYSTALNGEXP> | 天地结晶可提取的内功经验
<$CRYSTALEXP> | 天地结晶当前的经验
<$CRYSTALNGEXP> | 天地结晶当前的内功经验
<$CRYSTALLEVEL> | 天地结晶等级

人物内力变量

变量名称 | 说明
<$NH> | 内力
<$MAXNH> | 内力上限
<$NGEXP> | 内功经验
<$NGMAXEXP> | 内功升级经验
<$NGLEVEL> | 内功等级

英雄内力变量

变量名称 | 说明
<$H.NH> | 英雄内力
<$H.MAXNH> | 英雄内力上限
<$H.NGEXP> | 英雄内功经验
<$H.NGMAXEXP> | 英雄内功升级经验
<$H.NGLEVEL> | 英雄内功等级

连击变量

变量名称 | 说明
<$NGLEVEL> | 内功等级
<$HEROPULSEXP> | 英雄经络经验
<$NGAddPower> | 内功伤害增加
<$NGDecPower> | 内功伤害减少
<$H.NGAddPower> | 英雄内功伤害增加
<$H.NGDecPowe> | 英雄内功伤害减少
<$GETNGEXP> | 当前得到的内功经验
<$HEROGETNGEXP> | 英雄当前得到的内功经验
<$GODBLESSITEM1> ---- <$GODBLESSITEM12> | 人物生肖盒
<$H.GODBLESSITEM1> ---- <$H.GODBLESSITEM12> | 英雄生肖盒
<$JEWELRYITEM1> ---- <$JEWELRYITEM6> | 人物首饰盒
<$H.JEWELRYITEM1> ---- <$H.JEWELRYITEM6> | 英雄首饰盒

服务器信息

变量名称 | 说 明
<$Date> | 当前日期 格式:2021-01-11
<$Time> | 当前时间 格式:10:00:00
<$SERVERNAME> | 服务器名字
<$SERVERIP> | 服务器IP地址
<$WEBSITE> | 游戏网址
<$BBSSITE> | 论坛网址
<$CLIENTDOWNLOAD> | 客户端程序下载地址
<$QQ> | 联系QQ号
<$PHONE> | 联系电话号码
<$BANKACCOUNT0> | 银行帐号信息
<$BANKACCOUNT1> | 银行帐号信息
<$BANKACCOUNT2> | 银行帐号信息
<$BANKACCOUNT3> | 银行帐号信息
<$BANKACCOUNT4> | 银行帐号信息
<$BANKACCOUNT5> | 银行帐号信息
<$BANKACCOUNT6> | 银行帐号信息
<$BANKACCOUNT7> | 银行帐号信息
<$BANKACCOUNT8> | 银行帐号信息
<$BANKACCOUNT9> | 银行帐号信息
<$GAMEGOLDNAME> | 游戏币名称
<$USERCOUNT> | 在线人数
<$GUILDMASTER1> | 行会老大1
<$GUILDMASTER2> | 行会老大2
<$guildmembercount> | 行会成员数量
<$DATETIME> | 当前日期时间
<$GAMEGOLDNAME> | 游戏币名称
<$HIGHLEVELINFO> | 最高等人物信息
<$HIGHPKINFO> | 最高PK点数人物信息
<$HIGHDCINFO> | 最高攻击力人物信息
<$HIGHMCINFO> | 最高魔法力人物信息
<$HIGHSCINFO> | 最高道术人物信息


扩展GIVE命令

此功能可以实现脚本给物品时候增加特定属性。

命令格式：
GIVE 物品名 数量 参数0 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8 参数9 参数10 参数11 参数12

参数3-8对应物品位置的0-5极品属性（其他位置无效）。参考下面的极品属性

参数9: 物品持久值(0或空保持当前，视物品而定; -1:给满持久)；*******注意：参数9仅对非叠加物品有效
参数10：刺术
参数11：箭术
参数12：武力

例如
#ACT
give 聚灵珠 1 0 0 0 0 0 0 -1
sendmsg 6 给了你一个满经验的聚灵珠

give 祝福罐 1 0 0 0 0 0 0 -1
sendmsg 6 给了你一个满的祝福罐

;-------------------------------------------------------------------------------------

扩展新GiveOnItem命令

命令格式：给予玩家一个新的物品直接到指定位置不经过背包

GiveOnItem 装备位置 物品名称 数量默认写1(数量大于1时只对OK框叠加物品有效) 参数4 参数5 参数6 参数7 参数8 参数9 参数10 参数11 参数12

装备位置：
-1升级框
0--29：装备栏和时装栏
30-35：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框

参数4-参数9 参考 下面的极品属性

参数10：刺术
参数11：箭术
参数12：武力

[@测试]
#act
GIVE 屠龙 1 0 0 0 0 0 0 0 10 11 12
GIVE 重盔甲(女) 1 0 0 0 0 0 0 0 10 11 12
GIVE 金项链 1 0 0 0 0 0 0 0 10 11 12
Sendmsg 6 上面的几个物品，极品属性为：刺术:10；箭术:11；武力:12

位置及值参考物品的极品属性

盔甲
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5-13 无效果
14 持久

武器
0 DC2
1 MC2
2 SC2
3 幸运
4 诅咒
5 准确
6 攻击速度
7 强度
8-9 暂不知道
10 需开封
11-13 暂不知道
14 持久

头盔
0 防御
1 魔御
2 攻击
3 魔法
4 道术
5 佩带需求
6 佩带级别
7-13 无效果
14 持久

项链
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8 reserved
9-13 暂不知道
14 持久

手镯
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久

戒指
0 AC2
1 MAC2
2 DC2
3 MC2
4 SC2
6 佩带需求
7 佩带级别
8-13 无效果
14 持久


魔血石、气血石、幻魔石说明[!]

魔血石、气血石、幻魔石相关说明。
讲解一些参数的使用和用途。

1. 气血石当前持久%
气血石剩余持久 如：5000/300000 ,增加HP设置1 以为就是每次恢复5000的百分之一 ，即每次恢复50点，剩余持久越大每次恢复越多

按照吃药进行恢复，比如50点HP，表示吃了一颗可以加50点HP的金创药，恢复一次相当于吃一个药品

PS：魔血石 幻魔石同样理解

2.气血石总持久%
 气血石剩余持久 如：5000/300000 ,增加HP设置1 以为就是每次恢复300000的百分之一 ，即每次恢复3000点

按照吃药进行恢复，比如3000点HP，表示吃了一颗可以加3000点HP的金创药，恢复一次相当于吃一个药品

PS：魔血石 幻魔石同样理解

3. 点
气血石增加HP设置100 ，表示开启后每次恢复100点HP

PS：魔血石 幻魔石同样理解

4.单次恢复气血石总持久万分比
气血石剩余持久 如：5000/300000 ,增加HP设置100 以为就是每次恢复300000的百分之一 ，即每次恢复3000点

按照万年雪霜那样一次性进行恢复，比如3000点HP，表示吃了一颗可以加3000点HP疗伤药

100/1000 ，增加HP设置100就表示百分之一，设置1000表示千分之一，设置10000表示万分之一

PS：魔血石 幻魔石同样理解


内力恢复药物

说明: 内力恢复药物

内力恢复药物:StdMode = 0; Shape = 102

MAC1：是否为百分比方式（最大内力的百分比； 0：恢复点数； 1：百分比恢复）

恢复内力: 下限 AC1, 上限随机AC2; 如 AC1 = 30; AC2 = 10，则表示 30-40

1425 内力恢复药 0 102 2 0 0 0 312 0 30 10 0 0 0 0 0 0 0 0 0 0 2500 5 255 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
1426 内力恢复药(百分比) 0 102 2 0 0 0 312 0 30 10 1 0 0 0 0 0 0 0 0 0 2500 5 255 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0


设置显示名称格式

一、显示名称设置方法

1、相关配置

配置文件：String.ini

以下为相关配置内容：

CastleGuildName=%guildname[%castlename(%rankname)]
NoCastleGuildName=%guildname(%rankname)
WarrReNewName=%chrname\*<圣>*
WizardReNewName=%chrname\*<神>*
TaosReNewName=%chrname\*<尊>*
ManDearName=%s的老公
WoManDearName=%s的老婆
MasterName=%s的师父
NoMasterName=%s的徒弟
HumanShowName=%chrname\%guildname\%dearname\%mastername

CastleGuildName 沙城成员显示行会格式
NoCastleGuildName 普通已加入行会人员显示行会格式

%guildname 行会名称
%castlename 城堡名称
%rankname 职位名称

WarrReNewName 武士转生后名称显示
WizardReNewName 法师转生后名称显示
TaosReNewName 道士转生后名称显示

%chrname 人物名称

ManDearName 结婚后男的显示名称
WoManDearName 结婚后女的显示名称

MasterName 师父显示名称
NoMasterName 徒弟显示名称

HumanShowName 显示完整名称格式

游戏中显示出来的名称是根据以上格式组合出来的，大家可以根据自己的要求，自行调行组合及格式。


神秘人地图设置

[+] 增加地图参数：SECRET(31|固定名字|2|21) //浑水摸鱼模式

01 禁止说话
02 禁止名字变色
04 禁止看对方装备
08 统一名字 //第2参数就是指定显示的名字
16 统一装备外观 //第3参数指衣服外观，第4参数指武器外观
32 是否百分比显血 //是否人物、影响HP以百分比显示
64 隐藏称号显示
128 隐藏顶戴花翎
注意：隐藏顶戴和称号自己可见自己属正常！！！！
如果要多个功能起作用，相加对应的数字即可，
例如：禁止名字变色(02) + 禁止看对方装备(04) + 统一装备外观(16)，等于：22，既是第1参数=22

SECRET(31|固定名字|2|21)

特别解说: 第一参数 31 为控制总参数

总参数分为

01 禁止说话
02 禁止名字变色
04 禁止看对方装备
08 统一名字 //第2参数就是指定显示的名字
16 统一装备外观 //第3参数指衣服外观，第4参数指武器外观
32 是否百分比显血 //是否人物、英雄、人形怪HP以百分比显示
64 隐藏称号显示
128 隐藏顶戴花翎

假如第一参数为01时 SECRET(1|固定名字|2|21) 那么后面的 |固定名字|2|21 的几个参数也必须写上但是不生效

举列: 我要设置盟重身 所有玩家名字为 神秘人 禁止说话 禁止查看对方装备

那么第一参数就是 01+08+04=13 第2参数写 神秘人 第3参数和第4参数由于未用到可以随便写不起效

[盟重省 3] SECRET(13|神秘人|2|21)

举列2: 我要设置盟重身 所有玩家名字为 神秘人 禁止说话 禁止名字变色 禁止查看对方装备 统一装备外观为倚天衣=物品库的倚天衣SHAPE=35 统一武器外观为倚天武器=物品库的SHAPE=68

那么第一参数就是 1+2+4+8+16=31 第2参数写 神秘人 第3参数写35 第4参数写68

[盟重省 3] SECRET(31|神秘人|35|68)

举列2: 我要设置盟重身 所有玩家名字为 神秘人 禁止说话 禁止名字变色 禁止查看对方装备 统一装备外观为倚天衣=物品库的倚天衣SHAPE=35 统一武器外观为倚天武器=物品库的SHAPE=68 .比例显血

那么第一参数就是 1+2+4+8+16+32=63 第2参数写 神秘人 第3参数写35 第4参数写68

[盟重省 3] SECRET(63|神秘人|35|68)

**************************************************以下为脚本命令使用**************************************************

如觉得地图参数设置不够灵活，可使用脚本命令实现：

设置摸鱼模式：

SetSecretMode 地图名(所有地图*) 控制参数 统一显示名字 统一显示衣服 统一显示武器

控制参数：可随意组合（各值相加即可）；0为取消摸鱼模式

01 禁止说话

02 禁止名字变色

04 禁止看对方装备

08 统一名字 //第2参数就是指定显示的名字

16 统一装备外观 //第3参数指衣服外观，第4参数指武器外观

32 是否百分比显血 //是否人物、影响HP以百分比显示

64 隐藏称号显示

128 隐藏顶戴花翎

脚本示范：

[@MY]

#IF

#ACT

SetSecretMode 3 31 摸鱼 9 34
break


盛大称号系统介绍

功能：
盛大称号系统介绍

功能：称号物品.

数据库配置
称号物品的stdmode必须为70 - 74，不同的值有不同的含义，如下
┏━━━━━┳━━━━━━━┳━━━━━━━┳━━━━━━━┳━━━━━━━┓
┃ StdMode ┃ AC1 ┃ AC2 ┃ MAC ┃ MAC2 ┃
┣━━━━━╋━━━━━━━╋━━━━━━━╋━━━━━━━╋━━━━━━━┫
┃ 70 ┃ ┃ 魔法躲避 ┃ 诅咒 ┃ 幸运 ┃
┣━━━━━╋━━━━━━━╋━━━━━━━╋━━━━━━━╋━━━━━━━┫
┃ 71 ┃ ┃ 准确 ┃ ┃ 敏捷 ┃
┣━━━━━╋━━━━━━━╋━━━━━━━╋━━━━━━━╋━━━━━━━┫
┃ 72 ┃ 攻击速度+ ┃ 体力恢复 ┃ 攻击速度- ┃ 魔法恢复 ┃
┣━━━━━╋━━━━━━━╋━━━━━━━╋━━━━━━━╋━━━━━━━┫
┃ 73 ┃ 防御下线 ┃ 防御上线 ┃ 魔御下线 ┃ 魔御上线 ┃
┣━━━━━╋━━━━━━━╋━━━━━━━╋━━━━━━━╋━━━━━━━┫
┃ 74 ┃ 攻击速度 ┃ 毒物躲避 ┃ ┃ 中毒恢复 ┃
┗━━━━━┻━━━━━━━┻━━━━━━━┻━━━━━━━┻━━━━━━━┛

Name： 称号名称
Anicount： 当值大于0时，无需设置为当前称号，称号的属会就可叠加到人物
Reserved： 控制称号在客户端的显示方式（0：名字+图标，1：只显示图标，2：不显示）
Looks： 称号图片的开始位置（5个为一级）
Color： 颜色 0~255

注意：如果称号物品要限时使用，请参照限时物品,称号数量支持100个
================================================================================================

称号加元素属性：
    人物格式: SetNewFengHaoValue 称号名 属性(0-10) 操作符(+,-,=) 属性值(1-100)
    英雄格式: H.SetNewFengHaoValue 称号名 属性(0-10) 操作符(+,-,=) 属性值(1-100)

    属性类型(0-10)
    (0)暴击几率增加 1~100%
    (1)增加攻击伤害 1~100%
    (2)物理伤害减少 1~100%
    (3)魔法伤害减少 1~100%
    (4)忽视目标防御 1~100%
    (5)所有伤害反弹 1~100%
    (6)增加目标暴率 1~100%
    (7)人物体力增加 1~100%
    (8)人物魔力增加 1~100%
    (9)怒气恢复增加 1~100%
    (10)合击攻击增加 1~100%
    (11)怪物暴率增加 1~100%
    (12)防暴几率增加 1~100%
    (13)防止麻痹增加 1~100%
    (14)防止护身增加 1~100%
    (15)防止复活增加 1~100%
    (16)防止全毒增加 1~100%
    (17)防止诱惑增加 1~100%
    (18)防止火墙增加 1~100%
    (19)防止冰冻增加 1~100%
    (20)防止蛛网增加 1~100%
    (21)致命一击几率 1~100%
    (22)致命一击伤害增加 1~100%
    (23)致命一击防御 1~100%
    (24)暴击抗性(对方暴击几率 - 暴击抗性 = 对方暴击打出几率) 1~1000% ..........本抗性对应元素属性0 暴击几率增加
    (25)攻击伤害抗性(对方攻击伤害倍数 - 攻击伤害抗性 = 对方攻击伤害增加的倍数) 1~1000% ..........本抗性对应元素属性1 增加攻击伤害
    几率大于100%则按照100%计算，如暴击几率300%，目标暴击抗性270%，那么攻击这个目标的暴击几率只有30% ，，目标抗性为10% ，就是300-10=290 ，也为100%
    (26)杀怪经验倍率 1~100000% [算法相加：自身倍数(自身倍率含特殊物品倍数*经验倍数命令 ） + 元素倍率]

检测称号的元素属性
    人物格式: CheckNewFengHaoValue 称号名 属性(0-10) 操作符(>, <, =) 属性值(1-100)
    英雄格式: H.CheckNewFengHaoValue 称号名 属性(0-10) 操作符(>, <, =) 属性值(1-100)

    属性类型(0-10)
    (0)暴击几率增加 1~100%
    (1)增加攻击伤害 1~100%
    (2)物理伤害减少 1~100%
    (3)魔法伤害减少 1~100%
    (4)忽视目标防御 1~100%
    (5)所有伤害反弹 1~100%
    (6)增加目标暴率 1~100%
    (7)人物体力增加 1~100%
    (8)人物魔力增加 1~100%
    (9)怒气恢复增加 1~100%
    (10)合击攻击增加 1~100%
    (11)怪物暴率增加 1~100%
    (12)防暴几率增加 1~100%
    (13)防止麻痹增加 1~100%
    (14)防止护身增加 1~100%
    (15)防止复活增加 1~100%
    (16)防止全毒增加 1~100%
    (17)防止诱惑增加 1~100%
    (18)防止火墙增加 1~100%
    (19)防止冰冻增加 1~100%
    (20)防止蛛网增加 1~100%
    (21)致命一击几率 1~100%
    (22)致命一击伤害增加 1~100%
    (23)致命一击防御 1~100%
    (24)暴击抗性(对方暴击几率 - 暴击抗性 = 对方暴击打出几率) 1~1000% ..........本抗性对应元素属性0 暴击几率增加
    (25)攻击伤害抗性(对方攻击伤害倍数 - 攻击伤害抗性 = 对方攻击伤害增加的倍数) 1~1000% ..........本抗性对应元素属性1 增加攻击伤害
    (26)杀怪经验倍率 1~100000% [算法相加：自身倍数(自身倍率含特殊物品倍数*经验倍数命令 ） + 元素倍率]

================================================================================================

称号相关触发：QFunction
---------------玩家称号从激活变为非激活（设置为当前称号）---------------

[@ActiveTitle_XX]
---------------　英雄称号从激活变为非激活（设置为当前称号）　--------------

[@HeroActiveTitle_XX]
------------------------玩家称号从非激活变为激活（取消当前称号或更换别的称号为当前）-------------------------

[@UnactiveTitle_XX]
------------------------英雄称号从非激活变为激活（取消当前称号或更换别的称号为当前）------------------------

[@HeroUnactiveTitle_XX]

注： XX是数据库中的Shape
================================================================================================

检测称号是否激活：

人物：
CheckActiveFengHao 称号名称

英雄：
H.CheckActiveFengHao 称号名称

================================================================================================

人物头顶是否显示称号

修改数据库 Reserved 字段 显示方式（0：显示DB中的名字+图标，1：只显示图标不显示名字，2：不显示）

================================================================================================

使用脚本命令增加人物称号（英雄则在命令前增加H.）
NPC命令：
功能：给予玩家称号
格式：GiveFengHao 称号名（称号名后面空白为不激活，加1为激活）
（注：当有同样的称号时，则不能再增加此称号）

#IF
#act
GIVEFENGHAO 巅峰战神 ;（注：巅峰战神是数据库增加好的称号）
SENDMSG 6 您已获得巅峰战神的称号

#IF
#act
GIVEFENGHAO 巅峰战神 1
;（注：增加1为激活当前使用的称号）
SENDMSG 6 您已获得巅峰战神的称号

;━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
功能：回收玩家称号
格式：RECYCFENGHAO 称号名 （ALL 删除所有称号）

#act
RECYCFENGHAO 巅峰战神
（注：巅峰战神是数据库增加好的称号）
SENDMSG 6 您的称号已消失
#act
RECYCFENGHAO ALL
（注：删除所有称号）
SENDMSG 6 您的所有称号称号已消失

;━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
功能：获取玩家当前拥有的所有称号名命令
格式：GetAllFengHao L$称号名
#IF
#act
GetAllFengHao L$称号名
SENDMSG 6 您目前拥有称号：<$str(L$称号名)>

;━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
功能：检查玩家是否有指定称号
格式：CHECKFENGHAO 称号名(也就是在物品数据库增加的那个称号物品名称)

#IF
CHECKFENGHAO 巅峰战神
;（注：巅峰战神是数据库增加好的称号）
#act
SENDMSG 6 您已经有巅峰战神的称号了

;━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
功能：检查玩家所有称号的数量
格式：CHECKFENGHAOCOUNT 操作符(<,>,=) 数量(0-255)

#IF
CHECKFENGHAOCOUNT < 8
#act
SENDMSG 6 您已经有了所有称号

;━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

套装触发，称号物品支持套装属性;
    注意：不管称号物品是否属于套装，封号属性（或套装属性）在以下情况下生效：
    Anicount = 0时，必须将称号设置为当前（激活）后生效
    Anicount = 1时，给予角色称号即生效

;━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
服务器设置：
    必须在服务器上指定称号素材读取的文件，客户端才能通过称号物品的Looks指定的位置显示称号图标，指定称号素材读取文件：
称号素材读取文件位于：引擎-选项-客户端控制-其他控制

;━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

客户端相关
    封号备注信息 resources\fenghao.dat (限连击界面显示，非连击界面只可以物品备注)；支持多种颜色，3位数字的颜色/内容 ,换行用\
    战神=255/服务器249/第一255/战士
;━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

1192;沙巴克城主;70;1;1;0;0;0;690;5000;0;0;0;0;0;2;0;1;0;1;101;3;500;50;255;1;0;0;;0;0;0;0
1193;道尊;71;2;1;0;0;0;695;5000;1;2;3;4;0;2;0;1;0;1;101;10;500;50;255;1;0;0;;0;0;0;0
1194;兵贵神速;70;3;1;0;0;0;700;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1195;法圣;70;4;1;0;0;0;705;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1196;战神;70;5;1;0;0;0;710;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1197;不动如山;70;6;1;0;0;0;715;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1198;主宰者知己;70;0;1;0;0;0;720;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1199;国色天香;70;0;1;0;0;0;725;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1200;巅峰战神;70;5;1;0;0;0;730;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1201;倾国倾城;70;6;1;0;0;0;735;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1202;称号9;70;0;1;0;0;0;1240;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1203;称号10;70;0;1;0;0;0;1245;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1204;称号11;70;0;1;0;0;0;1250;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1205;称号12;70;0;1;0;0;0;1255;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1206;称号13;70;0;1;0;0;0;1260;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1207;玛法之星;70;0;1;0;0;1;1265;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1208;称号15;70;0;1;0;0;0;1270;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1209;传奇之星;70;0;1;0;0;1;1275;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1210;威武之师;70;0;1;0;0;1;3010;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0
1211;雄霸天下;70;0;1;0;0;1;3015;5000;0;0;0;0;0;2;0;1;0;1;0;3;500;50;255;1;0;0;;0;0;0;0

官方称号素材位于UI1.WZL ，请在列表信息二的WIL资源中添加UI1.WZL，然后请在M2-客户端控制-其他控制里面设置文件名为：UI1.WZL，内挂瘾藏称号是控制角色头顶显示的！


数据库变量说明[!]

<$NAME>
<$STDMODE>
<$SHAPE>
<$WEIGHT>
<$ANICOUNT>
<$SOURCE>
<$RESERVED>
<$LOOKS>
<$DURAMAX>
<$AC>
<$AC2>
<$MAC>
<$MAC2>
<$DC>
<$DC2>
<$MC>
<$MC2>
<$SC>
<$SC2>
<$NEED>
<$NEEDLEVEL>
<$STOCK>
<$COLOR>
<$OVERLAP>
<$LIGHT>
<$HORSE>
<$ELEMENT>
<$EXPAND1>
<$EXPAND2>
<$EXPAND3>
<$UPGRADECOUNT>

用于获取物品数据库指定字段数值或文字变量


添加自动排列按钮，自定义按钮自动排列

-----------------------------------添加自动排列按钮，自定义按钮自动排列---------------------------

位于引擎---选项-》客户端设置-》按钮自动排列

说明：类似于ADDBUTTON，区别在于自动排列

格式：添加自动排列按钮 AddArrButton 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8 参数9

参数1为分组编号 （参数1为分组编号(1-7)）
参数2为按钮点击后的脚本触发序号，触发QF里面的[@ArrButtonClickX]X即为触发序号
参数3为WIL补丁序号，此序号在M2-查看-列表信息二-WIL资源 里面编辑
参数4为按钮默认图片
参数5为鼠标经过图片
参数6为按钮按下图片
参数7为按钮是否可以移动0=不能移动1=可以移动2=人物装备栏3=人物背包栏4=英雄装备栏5=英雄背包栏6=聊天框左侧龙界面7=聊天框右侧等级界面8=商铺界面9=时装界面,10=英雄时装，11=技能栏，12=英雄技能栏，13=称号栏，14=英雄称号栏，15=状态栏，16=英雄状态栏，17=属性栏，18=英雄属性栏，19=人物出战栏，20=行会界面,21=详细属性位置，22=宠物界面，24=人物首饰，25=英雄首饰，26=人物神佑，27=英雄神佑，28=查看他人装备，29=查看他人时装，30=查看他人称号，31=查看他人首饰盒，32=查看他人神佑袋，33=M大地图
参数8为按钮上面显示的文字标题,-1时为空标题(用于不显示标题)
参数9为鼠标移动到按钮显示的悬浮框备注信息

注意：不在一个位置的按钮不要放到一个分组中，不然坐标会计算错误（比如，一个在背包，一个在主界面，然后放到一个分组）

;以下按钮加到背包
AddArrButton 1 21 1 135 136 137 3 标题1 这是提示文字
AddArrButton 1 22 1 135 136 137 3 标题2 这是提示文字
AddArrButton 1 23 1 135 136 137 3 标题3 这是提示文字
AddArrButton 1 24 1 135 136 137 3 标题4 这是提示文字
AddArrButton 1 25 1 135 136 137 3 标题5 这是提示文字

QF触发
[@ArrButtonClick1]
#act
sendmsg 7 自动排列按钮点击1

删除自动排列按钮：DelArrButton 按钮编号


为什么提示禁止点击该NPC触发字段？

下面以一个死亡触发为例，不仅仅是死亡触发，引擎的所有触发都不允许玩家点击NPC触发，
例如：物品触发[@StdModeFunc]，套装触发[@GroupItemOn] [@GroupItemOff]，魔法触发[@MagTagFunc]，穿脱装备触发[@TakeOn] [@TakeOff]等等，就不一一举例了。

[@PlayDie]
<下一页/@下一页>

[@下一页]
<返回/@PlayDie>

;<返回/@PlayDie> 新引擎这里“@PlayDie”是引擎内部触发字段，禁止用户通过NPC点击来触发这个字段
;不仅仅“@PlayDie”不允许“@PlayDie1、 @PlayDie2、 @PlayDie死亡”等等都不允许，只有前面的字符和“@PlayDie”一样的后面不管增加什么字符都将不允许
;如果非要使用玩家点击NPC触发的，可以把上面的脚本改成如下,使用goto转一下

[@PlayDie]
<下一页/@下一页>

[@下一页]
<返回/@返回>

[@返回]
#ACT
goto @PlayDie

---------------------------------------------------------------------------------------------------

还有其他一些触发，也属于这类的，比如：

DelayCall 5000 @再次复活
SendCenterMsg 180 251 还剩余%d发放新手奖励. 0 30 @GiveNewHumanItem

“@再次复活”和“@GiveNewHumanItem”就会变成引擎内部触发，也是不允许用使用NPC点击来触发的
还有一些其他脚本命令带字段触发的，就不一一举例了。


物品绑定人物

功能：
物品绑定人物

绑定类型:
帐号，角色名，IP

命令格式:
@BindUseItem 人物名称 物品类型 绑定类型
例：@BindUseItem 人物名称 武器 帐号
此时将指定的人物及其身上的武器绑定在该人的帐号上
========================================================

物品类型:
衣服，武器，照明物，项链，头盔，左手镯，右手镯，左戒指，右戒指，物品
腰带，鞋子，宝石

BindUseItem
显示绑定物品到人物信息

ShowUseItemInfo
显示人物身上带装备信息


物品来源相关

功能：
物品来源相关资料

功能：物品来源.

物品来源获取和修改来源信息
GetItemFrom 装备位置 类型(0-4) 变量名
类型：
0：物品来源（0：未知；1：GM制造；2：NPC制造；3：商店购买；4：杀怪掉落；5：系统给予；6：挖矿获取；7：宝箱获取；8：宝箱获取；9：挖肉获取；10：捕捉获取）
1：地图
2：杀死怪物
3：经手人
4：时间
--------------------------

SetItemFrom 装备位置 类型(0-4) 值1 值2
0：物品来源（0：未知；1：GM制造；2：NPC制造；3：商店购买；4：杀怪掉落；5：系统给予；6：挖矿获取；7：宝箱获取；8：宝箱获取；9：挖肉获取；10：捕捉获取）
1：地图
2：杀死怪物
3：经手人
4：时间
当 类型 = 4时，值2填时间，其他类型时，留空
当 类型 = 4时，值1为日期（2016-08-31），值2填时间（22:54:10），其他类型时，留空

注：物品来源修改，如修改时间一直显示00:00:00 ，也就是无法修改时间， 请检查M2所在引擎系统时间格式 ，修改为 ：短日期： yyyy/m/d 长日期： yyyy'年'M'月'd'日' ，短时间：H:mm 长时间：H:MM:SS


物品位置[!]

物品位置:

;==========================================
0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠
15 马牌
16 盾牌
17 时装衣服
18 时装武器
;==========================================


新增GM命令[!]

新增部分游戏相关命令

注：以下命令在(M2目录中)Command.ini文件中均可自由更改命令名称.

传送相关命令
@recall | 将人物召唤到自己身边
@Regoto | 传送到对方身边
@Ting | 将对方随机传送
@SuperTing | 将指定范围内人物随机传送
@Mapmove | 将指定地图所有人物传送到指定地图
@Move | 移动到指定地图
@PositionMove | 移动到指定地图座标
人物控制相关命令
@GameMaster | 进入/退出管理员模式
@Observer | 进入/退出隐身模式
@Superman | 进入/退出无敌模式
@Level | 调整自己的等级
@Kick | 将指定的人物踢下线
@Kill | 将指定的人物杀死
@Realive | 将死亡的人物复活
@Setpermission | 设置人物的游戏权限，可将普通人物提升为GM
@Info | 显示人物详细信息
@MobLevel | 显示身边所有怪物或人物信息
@FreePK | 清除指定人物的PK点
@PKpoint | 显示指定人物的PK点
@IncPkPoint | 增加指定人物的PK点
@AdjustLevel | 调整他人级别
@AdjustExp | 调整他人经验
怪物控制相关命令
@Mob | 在身边放置一个指定的怪物
@RecallMob | 召唤一个怪物为宝宝
@Mission | 设置怪物集中点(用于开展怪物攻城)
@MobPlace | 放置怪物，怪物向集中点集中，大刀守卫不攻击怪物(用于开展怪物攻城)
聊天信息相关命令
@DisableSendMsg | 将指定人物加入禁言列表，人物发信息只能自己看到别人看不到
@EnableSendMsg | 将指定人物从禁言列表中删除
@DisableSendMsgList | 显示禁言列表中的人物名称
@ViewWhisper | 查看指定人物的私聊信息
@MobNpc | 制造一个NPC（可不用重启M2做增加NPC制作脚本）；
@DelNpc | 删除NPC
重新加载设置相关命令
@ReloadAdmin | 重新加载管理员列表
@ReloadNpc | 重新加载NPC脚本
@ReloadMonItems | 重新加载怪物爆物品列表
@ReloadLineNotice | 重新加载游戏公告
@ReloadManage | 重新加载登录脚本
@ReloadItemDB | 重新加载物品数据库
@ReloadMagicDB | 重新加载魔法数据库(暂时无效)
@ReloadMonsterDB | 重新加载怪物数据库
@ReloadRobotManage | 重新加载游戏登录文本
物品控制相关命令
@make | 制造指定的物品
@SuperMake | 调整给指定物品属性值
@BindUseItem | 物品绑定人物信息
@GiveMine 数量 纯度 | 给指定纯度的矿石.
仓库、登录密码相关命令
@CLEARPASSWORD | GM专用命令
人物分配点数控制相关命令
@BonusPoint | 增加人物属性点
@DelBonusPoint | 删除人物属性点(删除所有已分配及未分配的属性点)
@RestBonusPoint | 将人物属性点复位(已分配的复位到未分配的点数)
地图控制相关命令
@SetMapMode | 设置地图模式
@Map | 查看当前所在地图相关信息
游戏点、币相关命令
@GameGold | 调整人物游戏币数量
@GamePoint | 调整人物游戏点数量(泡点数量)
@CREDITPOINT | 调整人物声望点(1-255)
@DelGold | 减少人物金币
@AddGold | 增加人物金币
其他相关命令
@Showflag | 显示标识
@showopen | 显示打开
@showunit | 显示单位
@setflag | 设置标识
@setopen | 设置打开
@setunit | 设置单位
@Reconnection | 更换网关的命令
行会相关命令
@AddGuild | 添加一个行会
@DelGuild | 删除一个行会
@SabukWallGold | 更改沙城所属性行会
@ForcedWallconquest | 强行开始或结果攻城战
@SabukWallGold | 查看沙城金币数


修改内力值

说明: 修改内力值

NPC命令：修改内力值ChangeNGPoint 操作符(+/-/=) 值 百分比(%表示百分比；空或其他表示点数）

; 减100点内力
ChangeNGPoint - 100

; 增加总内力10%的内力值
ChangeNGPoint + 10 %


页游天关系统

说明: 仿页游天关系统

天关相关触发：

领奖成功：
@GuardinaLevelCanGetItemOK

攻击力：
@GuardinaLevelClick1

召唤守卫:
@GuardinaLevelClick2

NPC命令：

// 初始化守关信息 SetGuardianLevelInfo 关卡号 总波数 守护雕像名称 守护雕像坐标X 守护雕像坐标Y 刷怪坐标X 刷怪坐标Y 奖励物品1 奖励物品2 奖励物品3 奖励物品4

// 设置每波信息 SetGuardianLevelBatchInfo 第几波 怪物名:数量|怪物名:数量|怪物名:数量 本波奖励物品1数量 本波奖励物品2数量 本波奖励物品3数量 本波奖励物品4数量

// 开始闯关 StartGuardianLevel

; 在进入地图后执行以下触本
[@MoveEctype_OK]
#ACT
SetGuardianLevelInfo 1 5 天关雕像 44 27 52 27 黑铁矿石 鸡肉 护身符 强效金创药
SetGuardianLevelBatchInfo 1 白野猪:2|稻草人:4|僵尸1:5 0 0 1 1
SetGuardianLevelBatchInfo 2 白野猪:4|稻草人:6|僵尸1:5 0 0 1 1
SetGuardianLevelBatchInfo 3 白野猪:6|稻草人:8|僵尸1:8 1 1 0 0
SetGuardianLevelBatchInfo 4 白野猪:8|稻草人:10|僵尸1:10 1 1 1 1
SetGuardianLevelBatchInfo 5 白野猪:10|稻草人:10|尸王1:1 1 2 1 2
DELAYGOTO 3000 @开始闯关

[@开始闯关]
#IF
#ACT
StartGuardianLevel

示范：
[@main]
#IF
CheckMirrorMap <$USERID>
#ACT
CLEARITEMMAP <$USERID> 30 35 10
CLEARMAPMON <$USERID>
SetMirrorMapTime <$USERID> 100 1
#ELSEACT
ADDMIRRORMAP 0139 <$USERID> 魔境 100 <$const(3)> 9999 <$STR(N$镜像)> 1 338,341
#act
mapmove <$USERID> 30 35
SetGuardianLevelInfo 1 5 千年树妖 31 36 17 20 回城卷 随机传送卷 麻痹戒指 护身戒指
SetGuardianLevelBatchInfo 1 黑野猪:1 0 0 1 1
SetGuardianLevelBatchInfo 2 黑野猪:2 1 1 1 1
SetGuardianLevelBatchInfo 3 黑野猪:5 1 1 1 1
SetGuardianLevelBatchInfo 4 黑野猪:8 1 1 1 1
SetGuardianLevelBatchInfo 5 黑野猪:15 1 1 1 1

StartGuardianLevel 特别说明：宝宝请务必使用REAC= 155的自定义怪物


用户游戏命令详解

用户游戏相关命令

注：以下命令在(M2目录中)Command.ini文件中均可自由更改命令名称.

相关命令
@Date | 显示当前服务器上的日期时间
@禁止私聊 |
@禁止群聊 |
@禁止交易 |
@加入行会 |
@退出行会 |
@禁止行会聊天 |
@允许行会联盟 |
@联盟 |
@取消联盟 |
@允许天地合一 |
@天地合一 |
@仓库解锁 |
@仓库开锁 |
@设置仓库密码 |
@修改仓库密码 |
@Rest |
@传送 | 传送物品移动命令
@Dear | 夫妻查询位置
@Master | 师徒查询位置
@DearRecall | 夫妻传送
@MasterRecall | 师徒传送
@AllowDearRecall | 允许夫妻传送
@AllowMasterRecall | 允许师徒传送
@GuildRecall | 行会合一
@AllowGuildRecall | @允许天地合一
@AttackMode | 调整攻击模式
仓库、登录密码相关命令
@SetPassword | 设置仓库密码
@Chgpassword | 修改仓库密码
@UnLock | 打开密码锁
@UnLockStorage | 仓库解锁
@Lock | 仓库加锁


自定义安全区光柱类型

自定义安全区光环：

地图号：安全区所在地图
座标X：安全区所在地图座标X
座标Y：安全区所在地图座标Y
禁止说话：安全区内是否禁止说话(此功能未完成)
大小范围：安全区范围大小
光环类型：安全区边界显示类型(1-11编号均可使用，主流2或4或5，自行测试设置适合自己的安全区光圈)
PKZONE：安全区是否为PK比赛区域(此功能未完成)
PKFIRE：安全区PK区域边界显示类型(此功能未完成)

光环类型： 20-75 每组10张图片 （如果你的素材不足10张请补齐）
补丁名称：SafePointEffect.wzl
类型：20 读取补丁素材内的0-9图片
类型：21 读取补丁素材内的10-19图片

关于绘制：
编号： 20-55 透明绘制
编号： 56-75 普通绘制


GOTOLABEL触发[!]

GOTOLABEL 模式(0,1,2,3) 触发字段 范围(模式等于3时有效)

模式=0 小组成员触发
模式=1 行会成员触发
模式=2 当前地图的人物触发
模式=3 以自己坐标为中心指定范围人物触发

[@main]
#IF
#ACT
GOTOLABEL 0 @小组成员触发
GOTOLABEL 1 @行会成员触发
GOTOLABEL 2 @当前地图的人物触发
GOTOLABEL 3 @指定范围人物触发 12

下面为新增加：

模式=4 小组成员触发 (自己除外)
模式=5 行会成员触发 (自己除外)
模式=6 当前地图的人物触发 (自己除外)
模式=7 以自己坐标为中心指定范围人物触发 (自己除外)
模式=8 模式触发指定范围
模式=9 国家成员触发(自己除外)

2015-12-18更新0-7全部支持范围，不填写范围则保持以前模式

例

模式=0 小组成员触发 最后增加一个参数 为范围
GOTOLABEL 0 @触发字段 5 (最后的数字5表示 以自己坐标为中心指定范围人物触发)

模式=4 小组成员触发 (自己除外)
GOTOLABEL 4 @触发字段 5 (最后的数字5表示 以自己坐标为中心指定范围人物触发)

模式=9 国家成员触发(自己除外) 最后增加一个参数 为范围，范围小于1 则表示全地图触发给自己同国家角色
GOTOLABEL 9 @指定范围同一国家人物触发 5 (最后的数字5表示 以自己坐标为中心指定范围人物触发，范围小于1 则表示全地图触发给自己同国家角色)

br>

---------------------------------20200925增加模式8 ---------------------------------

模式=8脚本例子
模式=8 模式触发指定范围
GOTOLABEL 8 @触发字段 X Y 范围 是否包含自己(0包含/1不包含) 传递的变量(允许为空) 接受的变量(允许为空)

[@main]
#IF
#ACT
mov n1 <$X>
mov n2 <$Y>
mov S1 <$USERNAME>
GOTOLABEL 8 @触发字段 <$STR(N1)> <$STR(N2)> 5 1 S1 S2

[@触发字段]
#ACT
SENDMSG 6 传递的变量和接受的变量是同一个，对方名称<$STR(S2)>


摆摊物品购买前触发

功能：摆摊物品购买前触发 和 中止购买
-----------------------------------------------------------------

购买前触发 QF 字段： @BeginHeroM2BuyUserItem
中止购买命令：StopBuyUserItem

*简易示范脚本，具体自己发挥

[@BeginHeroM2BuyUserItem]
#IF
CHECKLEVELEX < 50
#ACT
StopBuyUserItem
sendmsg 5 你的等级小于50级，脚本中止你的购买
BREAK
#elseact
sendmsg 5 你购买<$CurUserName> 出售的摆摊物品<$CURITEMNAME> (<$G_CURITEMNAME> ),ID:<$CurItemMakeIndex> ，花费<$CurItemPrices> <$CurItemMoneyType> (货币类型值：<$CurItemMoneyTypeValue> )，叠加数量<$CurItemOverlapCount>
BREAK


武器被诅咒前触发

武器被诅咒前触发和终止诅咒命令

功能：武器被诅咒前触发使用命令中止诅咒
格式：人物触发：@BeginWeaponCurse ，英雄触发@HeroBeginWeaponCurse
说明：中止命令StopWeaponCurse

*例子

;人物武器被诅咒前QF触发脚本
[@BeginWeaponCurse]
#ACT
sendmsg 6 人物武器被诅咒，在此中止诅咒
StopWeaponCurse

;英雄武器被诅咒前QF触发脚本
[@HeroBeginWeaponCurse]
#ACT
sendmsg 6 英雄武器被诅咒，在此中止诅咒
StopWeaponCurse


人物身上物品掉落触发

-----------------------------------人物身上物品(不包含背包)掉落触发---------------------------

QF触发字段：[@HumDropItem]
功能说明：人物身上掉落触发（人物）-------列表信息二 物品规则 仅对勾选启用的物品生效

以下为QF触发示范：
[@HumDropItem]
#act
; 扩展参数3，是否只取DB中的名称(0:若改名以改名为准； 1：只取DB中的名称）
; 将名字放到S1中
GetUserItemName -1 1 1
;也可以用 Mov S1 <$PickDropItemName>
#if
CompareText S1 偃月
#act
ChangeItemNameColor -1 253

;---------------------------------------例子二
[@HumDropItem]
#ACT
SENDMSG 5 【<$CurUserName>】掉落物品【<$CurItemName>】，位置：<$maptitle> <$ScatterItemX>:<$ScatterItemY>

;---------------------------------------例子三
;//******************************** ;// 物品掉落触发（人物） ;//******************************** [@HumDropItem] #IF
#ACT
SENDMSG 0 【<$CurUserName>】掉落物品【<$CurItemName>】，位置：<$maptitle> <$ScatterItemX>:<$ScatterItemY>
ChangeItemNameColor -1 253

;英雄身上掉落物品触发[@HeroDropItem] -------列表信息二 物品规则 仅对勾选启用的物品生效

[@HeroDropItem]
#ACT
SENDMSG 0 【<$CurUserName>】掉落物品【<$CurItemName>】物品位置<$H.CurItemPos>物品序列号:<$CurItemMakeIndex>，位置：<$H.maptitle> <$H.ScatterItemX>:<$H.ScatterItemY>


个人商店购买物品前触发

功能：个人商店购买物品前触发
格式：购买前触发QF脚本
------------------------------------------------

*个人商店购买物品前触发 + 中止购买命令

购买前触发 QF 字段 @BeginBuyUserItem

;QF触发脚本(简易示范脚本，具体自己发挥！！！！)
[@BeginBuyUserItem]
#IF
ISONMAP 3
INSAFEZONE
#ELSEACT
StopBuyUserItem
Messagebox 购买失败\\只能在盟重安全区使用购买功能

;QF触发脚本2(简易示范脚本，具体自己发挥！！！！)
[@BeginBuyUserItem]
#IF
CHECKGAMEGOLD > 999
#ACT
sendmsg 5 你购买<$CurUserName> 出售的个人商店物品<$CURITEMNAME> (<$G_CURITEMNAME> ),ID:<$CurItemMakeIndex> ，花费<$CurItemPrices> <$CurItemMoneyType> (货币类型值：<$CurItemMoneyTypeValue> )，叠加数量<$CurItemOverlapCount>
#ELSEACT
Sendmsg 5 对不起，您的元宝不足。


系统商铺赠送物品前触发

商铺赠送物品前触发

功能：商铺赠送物品前触发
格式：商铺赠送物品前触发
说明：商铺赠送物品前触发

;QF触发

[@BeginGiveShopItem]
#ACT
StopShopItem
sendmsg 6 你已经拒绝了好友赠送的物品

*商铺赠送物品前触发...


物品进入背包触发

功能说明: 物品进入背包触发

说明：物品进入背包会触发QF内的 [@AddBag] 标签端

--------------------------------------------------------

物品进入背包QF触发

示例：

[@AddBag]
#if
#act
Sendmsg 6 提示:【<$CurItemName>】进到了你的背包！

示例2：

[@AddBag]
#IF
;检测条件脚本自己写
#ACT
LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚捡取的物品进行检测，或操作
;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253
;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1
;修改后的参数，刷新到客户端
UpdateItem -1
Sendmsg 6 提示:【<$CurItemName>】进到了你的背包，物品序列号:<$CurItemMakeIndex>
break

示例3：

[@AddBag]
#IF
;检测条件自己写
#ACT
;LINKPICKUPITEM
GetItemFieldValue -1 makeindex N1
GetItemFieldValue -1 idx N2
GetItemFieldValue -1 hdc N3
;UpdateItem -1
Sendmsg 6 提示:【<$CurItemName>】进到了你的背包，物品序列号:<$STR(N1)>，物品idx:<$STR(N2)>，物品DC2:<$STR(N3)>
break

★★★★★★★★★★★★不要在此触发中写任何关于回收物品的操作，不然可能导致M2异常 ★★★★★★★★★★★★★


仓库存取物品前触发

功能说明: 仓库存取物品前触发

说明：仓库存取物品前触发

--------------------------------------------------------

存入物品到仓库前QF触发

到普通仓：@BeginAddStorage
到无限仓：@BeginAddBigStorage

取回仓库物品触发
普通仓取回：@BeginDelStorage
无限仓取回：@BeginDelBigStorage

中止存取操作，命令
StopStorageItem

--------------------------------------------------------

示例：

[@BeginAddStorage]
#if
CHECKLEVELEX < 50
#act
StopStorageItem
SENDMSG 6 等级低于50级无法使用仓库

示例2：

[@BeginAddStorage]
#IF
#ACT
Sendmsg 6 提示:存放物品【<$CurItemName>】进到了你的普通仓库，物品序列号:<$CurItemMakeIndex>
break

[@BeginDelStorage]
#IF
#ACT
Sendmsg 6 提示:取回物品【<$CurItemName>】进到了你的背包，物品序列号:<$CurItemMakeIndex>
break


货币改变触发

功能说明: 货币改变触发

说明：货币改变触发

--------------------------------------------------------

;QF触发
元宝 触发 @GameGoldChange
游戏点 触发 @GamePointChange
金币 触发 @GoldChange
金刚石 触发 @GameDiamondChange
灵符 触发 @GameGirdChange
声望 触发 @CreditPointChange
荣誉 触发 @GamegLoryChange

当前身上货币常量：<$OldMoney>
改变后的货币常量：<$NewMoney>或直接用<$GoldCount>等变量

[@GoldChange]
#ACT
SENDMSG 6 当前金币发生了变更 ，原来为：<$OldMoney>，改变后为：<$NewMoney>(或者用<$GoldCount>)
BREAK

--------------------------------------------------------

提示：可能 仅限脚本命令操作时触发


查看他人装备触发、查看装备触发[!]

功能: 查看他人装备触发、查看装备属性触发

查看他人装备触发：@QueryUserState
查看他人英雄装备触发：@QueryUserHeroState

他人查看自己的装备触发：@UserQueryState
他人查看自己英雄的装备触发：@UserQueryHeroState

[@QueryUserState]
#ACT
SENDMSG 5 你查看了他人<$UserStateName>的装备

[@QueryUserHeroState]
#ACT
SENDMSG 5 你查看了英雄<$UserStateName>的装备

[@UserQueryState]
#ACT
SENDMSG 5 他人<$CurUserName>查看了你的装备

[@UserQueryHeroState]
#ACT
SENDMSG 5 他人<$CurUserName>查看了你的英雄装备

;---------------------------------------------------------------------

*中止查看他人或英雄装备”

命令：stopQueryUserState

[@QueryUserState]
#ACT
stopQueryUserState
SENDMSG 5 禁止查看他人<$UserStateName>的装备

[@QueryUserHeroState]
#ACT
stopQueryUserState
SENDMSG 5 禁止查看英雄<$UserStateName>的装备

[@QueryPlayMonsterState]
#ACT
stopQueryUserState
SENDMSG 5 禁止查看人形怪<$UserStateName>的装备

;---------------------------------------------------------------------

[@QueryUserState]
#ACT
MOV S1 <$UserStateName>
;SetCurrTarget 名称 (名称空的情况下表示清空当前对象;设置指定人物为当前对象，要求和执行脚本的玩家在同一地图且坐标在20格以内)
;使用SetCurrTarget设置当前对象
SetCurrTarget S1

#IF
CompareText <$C.USERNAME> S1
;检测设置的对象是否成功
#say
当前对象名称：\
【<$C.USERNAME> 】等级=【<$C.LEVEL> 】攻击=【<$C.DC> - <$C.MAXDC> 】PK值=【<$C.PKPOINT> 】\
#ELSESAY
对象获取失败。


传送戒指传送触发、坐标传送触发[!]

功能: 传送戒指传送触发、坐标传送触发

传送戒指传送前QF触发: @BeginTeleport

中止传送戒指传送命令：StopTeleport

QFunction-0.txt

[@BeginTeleport]
#act
StopTeleport
sendmsg 6 停止传送戒指传送


带上物品时触发[!]

功能: 带上物品时触发 位置0-12

[@TakeOn0] 0----12

[@TakeOn]
#IF
CheckLevelEx > 0
#SAY
穿上衣服真漂亮！!

提示：英雄触发为：@HeroTakeOnXX


;地图魔法触发功能需要手动编辑Envir\UserData\MapMagicEvent.txt
;范围指的是以该坐标为中心的范围内触发,永久可见指的魔法处于人物屏幕内即可看见.
;魔法类型: 1=地钉效果 2=雷电效果 3,4,5,6,7,8=雷电效果 9=龙头燃烧 10=岩桨效果 11=喷火效果
12=自己试 15=泉水 16=泉水 17=泉水 26,27,28,29,30=雪域五种传送门效果
;附加功能: 根据不同类型的魔法产生不同的效果.

;地图名称 X坐标 Y坐标 范围 魔法类型 魔法威力 永久可见 附加功能 智能攻击（0为固定坐标攻击。1为范围内坐标攻击）
3 330 330 1 1 50 0 0 0

附加功能:
1 =麻痹 2=绿毒 3=红毒 4=冰冻 5=蜘蛛网 (除毒外其他类型均固定时间为3秒，几率1/10)


地图事件触发

地图事件配置详解 必须在M2-选项-功能设置-基本设置-启用地图事件触发勾上才有效

Mir200\Envir\MapEvent.txt 配置

;触发标识
; 格式:
; 标识:值
;
; 标识:(-1 - 800) -1 代表不检查标识
; 值: (0 - 1)
;
;

;触发条件

; 格式:
; 代码:物品:组队;
; 代码:
; 0:无效
; 1:扔物品
; 2:捡物品
; 3:挖矿
; 4:走路(不支持物品条件)
; 5:跑步(不支持物品条件)
; 6:爆物品(仅支持人物死亡)
; 7:骑马走动
; 8:骑马跑动
; 9:挖矿(命中一次触发一次，无需挖到矿，也不是每次挥锄头就触发，而是命中一次才触发)
; 10:英雄死亡爆物品(仅支持英雄死亡)

; 物品:(物品名称 - *) * 代表不需要物品
; 组队:(0 - 1) 0为不需要组队，1为必须组队才触发(暂时不支持)

;触发机率
; 数字越大，机率越低
; 范围:(0 - 999999) 0 的机率为100%

;事件类型
; 格式
; 代码:内容

; 代码:(现在只支持脚本事件)
; 0:无效
; 1:调用脚本(调用QFunction-0.txt中的内容)
;注意事项
;
; 在相同地图座标，不支持相同触发标识及条件(触发条件中的物品名称除外)，如果有相同的设置，只有最后一个设置有效

;地图号 座标X 座标Y 范围 触发标识 触发条件 触发机率 事件类型
;和翎风不同的我们这里增加一个范围,如果范围的值是0 那么必须在这个坐标上才能触发，否则只要进入这个坐标的范围就会触发
;坐标为-1时不检测坐标

3 333 333 0 -1:1 1:回城卷:0 2 1:@MapEventDropItem
3 333 333 0 -1:1 2:回城卷:0 2 1:@MapEventPickUpItem
3 338 331 0 -1:1 3:*:0 2 1:@MapEventMine
3 330 330 0 -1:1 4:*:0 2 1:@MapEventWalk
3 331 335 0 -1:1 5:*:0 2 1:@MapEventRun
3 -1 -1 0 -1:0 6:*:0 0 1:@爆物品
3 -1 -1 0 -1:0 10:*:0 0 1:@英雄爆物品

QFunction脚本
[@爆物品]
#ACT
;这里的%s表示的爆出的物品名称 %x爆出的物品X坐标 %y爆出的物品Y坐标.
SENDMSG 0 【地图:%m】【物品:%s】【坐标(%x:%y】 255 253
;也可以这样
SENDMSG 0 【地图:%m】【物品:<$SCATTERITEMNAME>】【坐标(<$SCATTERITEMX>:<$SCATTERITEMY>】 255 253

QF脚本
[@英雄爆物品]
#act
SENDMSG 7 物品：<$H.SCATTERITEMNAME>，掉落在地图：<$H.maptitle><$H.SCATTERITEMX>,<$H.SCATTERITEMY>

检测坐标范围触发：

[@OnTimer12]
#IF
CheckInMapRange 3 354 337 0
;检测是否以地图3 坐标354,337为中心，范围0触发
#elseact
SetOffTimer 12
break
#IF
CheckInMapRange 3 354 337 0
#ACT
OPENPULSE 0 1
CHANGEEXP + 200000
break


定时触发[!]

定时触发 DelayCall 时间毫秒 触发字段


个人商店和人物摆摊

点击开始摆摊或停止摆摊将触发 QFunction-0 [@ShopStall]

M2 个人商店 摆摊信息字符控制0-30 设置为0 则不显示摆摊信息

[@ShopStall]
#IF
INSAFEZONE
;检测在安全区
#ELSEACT
MESSAGEBOX 需要在安全区才能摆摊
BREAK

#IF
CHECKSHOPSTALLSTATUS
;检测是不是在摆摊
#ACT
MESSAGEBOX 你是否确认要停止摆摊 @确定开始或停止摆摊
#ELSEACT
MESSAGEBOX 你是否确认要开始摆摊 @确定开始或停止摆摊

[@确定开始或停止摆摊]
#ACT
SHOPSTALL
;使用SHOPSTALL命令，如果正在摆摊就会停止摆摊，如果没有摆摊就会开始摆摊

;============================================================================================================

点击我的商店，如果还没有创建将触发[@QueryMyShopFail]

[@QueryMyShopFail]
#ACT
MESSAGEBOX 你还没有个人商店，是否创建你的个人商店？\\点击确定创建个人商店。 @创建个人商店 @取消

[@创建个人商店]
亲爱的玩家你好。这里可以申请开店。\
你可以把你的物品放到你的店铺里出售，\
游戏中的玩家可以查询到你要出售的物品。\
也可以把不用的物品放到店铺的仓库里。\
点击客户端中“店”就可以进入到你的店铺中,\
也可以查询其他用户的店铺和物品，\
可以很方便的把仓库物品和出售的物品相互转移。\
还可以进行摆摊操作。\

<我要开店(点击输入你喜欢的店铺名称)/@@InputString1>\

[@InputString1]
#IF
CHECKMYSHOP
#ACT
MESSAGEBOX 你已经有店铺了
BREAK

#IF
CHECKSHOPNAME <$STR(S1)>
#ACT
MESSAGEBOX <$STR(S1)>店铺名称已经存在，请重新选择一个
BREAK

#IF
#ACT
CREATEMYSHOP <$STR(S1)>

[@CreateMyShopOK]
#SAY
你的店铺创建成功

[@CreateMyShopFail]
#SAY
你的店铺创建失败

;============================================================================================================

列表信息1加入个人商店取名禁止字符

店铺名有过滤字符触发，触发字段在当前npc的脚本内：
@ShopNameFilter

示范：
[@ShopNameFilter]
#ACT
MESSAGEBOX 失败。店铺名称包含禁用字符


个人商店名称过滤触发

功能：
个人商店名称过滤触发

格式：

列表信息1加入个人商店取名禁止字符

店铺名有过滤字符触发，触发字段在当前npc的脚本内：
@ShopNameFilter

示范：
[@ShopNameFilter]
#ACT
MESSAGEBOX 失败。店铺名称包含禁用字符


个人商店物品上架触发、下架触发、停止个人商店物品上架、停止个人商店物品下架

功能说明：个人商店物品上架触发、下架触发、停止个人商店物品上架、停止个人商店物品下架

QF触发：
个人商店上架物品到出售：@BeginShopItemUp
个人商店从出售下架物品：@BeginShopItemDown

变量：个人商店名称：<$UserShopName>

NPC命令：停止个人商店物品上架/下架 StopShopItem

;例子

[@BeginShopItemUp]
#act
StopShopItem
SENDMSG 7 禁止上架物品到商铺<$UserShopName>，物品数据库名：<$CURITEMNAME>；物品名：<$G_CURITEMNAME>；ID：<$CurItemMakeIndex>；售价：<$CurItemPrices><$CurItemMoneyType>(货币类型值：<$CurItemMoneyTypeValue>)
;SENDMSG 0 <$USERNAME>上架物品到商铺{[<$CurItemName>]/<$CurItemMakeIndex>},点击可查看<$CURITEMNAME>物品属性

[@BeginShopItemDown]
#act
StopShopItem
SENDMSG 7 禁止商铺下架物品：<$UserShopName>，物品数据库名：<$CURITEMNAME>；物品名：<$G_CURITEMNAME>；ID：<$CurItemMakeIndex>；售价：<$CurItemPrices><$CurItemMoneyType>(货币类型值：<$CurItemMoneyTypeValue>)

;------------------------------------------------仿HERO摆摊物品上架前触发---------变量与个人商店的一致，只是触发标签不同-------------------------------

[@BeginHeroM2ItemUp]
#act
StopShopItem
SENDMSG 7 禁止上架物品到摊位，物品数据库名：<$CURITEMNAME>；物品名：<$G_CURITEMNAME>；ID：<$CurItemMakeIndex>；售价：<$CurItemPrices><$CurItemMoneyType>；货币类型值：<$CurItemMoneyTypeValue>)
SENDMSG 0 <$USERNAME>上架物品到摊位{[<$CurItemName>]/<$CurItemMakeIndex>},点击可查看<$CURITEMNAME>物品属性


攻击触发

QFunction-0

;所有触发只有攻击到怪物才会触发，有些魔法不会触发，如魔法盾
;======================魔法攻击触发==========================
[@MagicStruck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK
#IF
CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你被英雄【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK
#IF
CHECKCURRTARGETRACE = 151
#ACT
SENDMSG 6 你被分身【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK
#IF
CheckCurrTargetSlave
#ACT
SENDMSG 6 你被宝宝【<$CURRRTARGETNAME>】攻击了。。宝宝主人：【<$CurTargetMasterName>】 使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

[@MagicAttack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。<$ATTACKMONSTER_NAME>，锁定目标<$ATTACKMONSTER_NAMEEX>。<$ATTACKMONSTER_MAXHP> 使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

;======================物理攻击触发==========================
[@Struck]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK
#IF
CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你被英雄【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK
#IF
CHECKCURRTARGETRACE = 151
#ACT
SENDMSG 6 你被分身【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】攻击了。使用魔法ID=<$CURRRUSEMAGICID> 255 253
BREAK

[@Attack]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

#IF
#ACT
SENDMSG 6 你攻击了怪物【<$CURRRTARGETNAME>】。<$ATTACKMONSTER_NAME>，锁定目标<$ATTACKMONSTER_NAMEEX>。<$ATTACKMONSTER_MAXHP> 使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK

;======================下面变量获取怪物完整名字==========================

增加技能锁定目标名（有可能为空，比倚天辟地等 等无鼠标指向 、点击、魔法锁定的目标时）
<$ATTACKMONSTER_NAMEEX>

增加变量以显示完整名（不去数字）：$CURRRTARGETFULLNAME

上面演示脚本中变量不获取怪物名字后面的数字：$CURRRTARGETNAME

提供2种变量大家自己按需使用！


购买个人商店物品触发

功能说明：购买个人商店物品触发，个人商店物品卖出后提款成功触发，个人商店出售物品触发

;例子

;购买物品触发
[@BuyUserItem]
#act
sendmsg 6 你购买了<$CurUserName> 出售的个人商店物品<$CURITEMNAME> (<$G_CURITEMNAME> ),ID:<$CurItemMakeIndex> ，花费<$CurItemPrices> <$CurItemMoneyType> (货币类型值：<$CurItemMoneyTypeValue> )，叠加数量<$CurItemOverlapCount>

;出售物品成功后取款时触发
[@SellUserItemWithdrawals]
#act
sendmsg 6 <$CurUserName> 购买了你出售的物品<$CURITEMNAME> ,ID:<$CurItemMakeIndex> ，花费<$CurItemPrices><$CurItemMoneyType> (货币类型值：<$CurItemMoneyTypeValue> )，叠加数量<$CurItemOverlapCount>，提款成功

;-----------------------------------------------------------------------

增加个人商店物品售出触发（仅当售卖人在线时，人物不在线是不会触发滴）：@SelledUserItem
增加售出物品结算完成命令（当直接给售卖者增加货币后）：SetUserItemSettled，此命令无参数，仅用于@SelledUserItem中

特别注意：卖家在线时触发@SelledUserItem，触发如果涉及给予交易货币的话，必须在结尾处增加SetUserItemSettled，不然可以再次取款，只要执行了SetUserItemSettled则表示已经结清本次交易或理解为已经取款！！！

示例QF触发代码：

[@SelledUserItem]
#IF
EQUAL <$CurItemMoneyTypeValue> 0
#ACT
GameGold + <$CurItemPrices>

#IF
EQUAL <$CurItemMoneyTypeValue> 1
#ACT
GamePoint + <$CurItemPrices>

#IF
EQUAL <$CurItemMoneyTypeValue> 2
#ACT
GoldCount + <$CurItemPrices>

#IF
EQUAL <$CurItemMoneyTypeValue> 3
#ACT
GameDiamond + <$CurItemPrices>

#IF
EQUAL <$CurItemMoneyTypeValue> 4
#ACT
GameGird + <$CurItemPrices>

#IF
#ACT
sendmsg 6 <$CurUserName> 购买了你的个人商店物品<$CURITEMNAME> (<$G_CURITEMNAME> ),ID:<$CurItemMakeIndex> ，扣税后所得:<$CurItemPrices> <$CurItemMoneyType> (货币类型值：<$CurItemMoneyTypeValue> )，叠加数量<$CurItemOverlapCount>
;当完成上面收款后，必须执行下面的命令来完成结算，否则售卖者可以再次取款
SetUserItemSettled
sendmsg 7 本次交易已经完成结算


加入行会成员前触发,中止行会成员添加

QFunction-0

;加入行会成员前触发,中止行会成员添加

增加加入行会成员前触发QF.[@BeforeJoinGuild]（老行会:行会老大添加成员时触发，新行会：行会老大接受申请前触发）

增加中止行会成员添加：StopHumanJoinGuild，仅限于@BeforeJoinGuild中使用

增加Npc变量，当前加入行会的成员名称：<$JoinGuildHuman>,仅限于@BeforeJoinGuild中使用

[@BeforeJoinGuild]
#ACT
SendMsg 5 当前要加入行会的人是：<$JoinGuildHuman>
StopHumanJoinGuild


界面帮助按钮触发

功能： 界面帮助按钮触发

格式:

QFunction-0.txt
[@Help]
#SAY
Help


聚灵珠使用前触发

功能说明: 聚灵珠使用前触发、聚灵珠使用前中断命令

说明：聚灵珠使用前触发、聚灵珠使用前中断命令

--------------------------------------------------------

聚灵珠使用前触发QF命令

人物：@BeginUseExpSpiritBeads
宠物：@PetBeginUseExpSpiritBeads
英雄：@HeroBeginUseExpSpiritBeads

聚灵珠使用前中断命令**************************不管是人物还是英雄宠物，都用下面的中断，不用H. 或 Pet.
StopUseExpSpiritBeads

--------------------------------------------------------

示例：

[@BeginUseExpSpiritBeads]
#if
CHECKLEVELEX > 50
#act
StopUseExpSpiritBeads
SENDMSG 6 等级大于50级无法使用聚灵珠


连击完成触发，连击释放触发

功能：连击完成触发，连击释放触发

QFunction-0.txt

[@ContinueMagicFinished]
#ACT
SENDMSG 6 连击施展完成


切换地图触发[!]

功能：
切换地图触发

;QFunction-0.txt触发

[@EnterMap]
#IF
#ACT
SENDMSG 5 你已更换地图....

[@HeroEnterMap]
#IF
#ACT
SENDMSG 5 英雄更换地图了....


切换攻击模式触发

格式: @AttatckModeChange

说明:切换攻击模式触发（仅限Ctrl+H触发QF字段，不含脚本命令切换攻击模式）

[@AttatckModeChange]
#ACT
SENDMSG 7 切换攻击模式触发
break


取下身上物品时触发[!]

功能: 取下身上物品时触发,位置0-12

[@TakeOff0] 0----12

[@TakeOff]
#IF
CheckLevelEx > 0
#SAY
不穿衣服小心感冒!

提示：英雄触发为：@HeroTakeOffXX

取下装备触发支持关联

[@takeoff1]
#ACT
LinkPickupItem
ChangeItemName -1 新的名称
SENDMSG 0 镶嵌装备已改为“新的名称”
; 获取取下的装备数据库名称
GetItemFieldValue -1 name S3
; 获取取下的装备Idx
GetItemFieldValue -1 idx S1
; 获取取下的装备名称（含改名）
GetItemFieldValue -1 name_g S2
clearLinkItem
SendMsg 0 当前操作的装备Idx：<$Str(S1)>；改名名称：<$Str(S2)>，数据库名称：<$Str(S3)>


人物大退触发

[@PlayOffLine] 人物大退触发


人物当前获得经验触发

@KillMonGetExp 人物杀怪获得经验触发 QF

@HeroKillMonGetExp 英雄杀怪获得经验触发 QF

@GetExp

例如:
[@GetExp]
#if
#act
SENDMSG 5 ：人物本次获取经验为:<$GetExp>
break


人物和英雄属性发生变更时触发QF脚本[!]

功能：
人物和英雄属性发生变更时触发QF脚本.

说明：本命令触发属性计算的里面不要修改属性，否则无限死循环引起M2崩溃，可用于刷新战斗力

英雄属性发生改变时触发QF字段：

[@HeroRecalcAbilitys]
#ACT
sendmsg 6 英雄属性发生改变

--------------------------------

人物属性发生改变时触发QF字段：

[@RecalcAbilitys]
#ACT
sendmsg 6 角色属性发生改变


人物取下装备前触发、英雄取下装备前触发

功能说明：人物取下装备前触发、英雄取下装备前触发

QF触发：
人物取下装备前触发：@BeginTakeOff
英雄取下装备前触发：@HeroBeginTakeOff

请不要在@BeginTakeOff/@HeroBeginTakeOff做回收物品等操作

NPC命令：中止取下 StopTakeOff 仅用于上面2个触发

;例子

[@BeginTakeOff]
#if
CHECKMAPNAME 3
#ACT
;中止装备取下操作
StopTakeOff
SENDMSG 6 你身上的物品位置<$CurItemPos>，名称：<$CurItemName>，改名名称：(<$G_CurItemName>)，ID<$CurItemMakeIndex> 在当前地图禁止更换！

[@HeroBeginTakeOff]
#if
EQUAL <$H.CurItemName> 屠龙
#act
H.StopTakeOff
SENDMSG 7 禁止英雄脱装备：位置:<$H.CurItemPos>，物品:<$H.CurItemName>(<$H.G_CurItemName>)，ID:<$H.CurItemMakeIndex>


人物升级触发

脚本文件位于: X:\LFSERVER\Mir200\Envir\Market_Def\QFunction-0.txt

;此脚为功能脚本，用于实现各种与脚本有关的功能

;人物升级触发
[@PlayLevelUp]
#ACT
MessageBox 升级


人物死亡

功能：
人物是被怪物杀死还是玩家杀死

格式：

;==========================================
[@PlayDie]
#IF
CHECKCURRTARGETRACE = 0
#ACT
SENDMSG 6 你被人物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
CHECKCURRTARGETRACE = 1
#ACT
SENDMSG 6 你被英雄【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
CHECKCURRTARGETRACE = 151
#ACT
SENDMSG 6 你被分身【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

#IF
CheckCurrTargetSlave
#ACT
SENDMSG 6 你被宝宝【<$CURRRTARGETNAME>】杀死了,目标主人：【<$CurTargetMasterName>】 255 249
BREAK

#IF
#ACT
SENDMSG 6 你被怪物【<$CURRRTARGETNAME>】杀死了 255 249
BREAK

;======================下面变量获取角色和怪物完整名字==========================

增加变量以显示完整名（不去数字）：$CURRRTARGETFULLNAME

上面演示脚本中变量不获取角色以及怪物名字后面的数字：$CURRRTARGETNAME

提供2种变量大家自己按需使用！


人物死亡时触发.

#IF
KillByHum
#ACT
SendMsg 5 玩家 <$HumKiller> 在%m 把你干死了!
#ELSEACT
SendMsg 5 怪物 <$MONKILLER> 在%m 把你干死了!

====================================================================================================

变量：<$KILLER> 可显示人物、怪物、等其他一切杀死自己的对象名称，使用此变量为综合变量！！！可用于人物名字变量和怪物名字变量、如：

检查是被怪物还是人物杀死的.

#IF
KillByHum
#ACT
SendMsg 5 玩家 <$KILLER> 在%m 把你干死了!
#ELSEACT
SendMsg 5 怪物 <$KILLER> 在%m 把你干死了!

====================================================================================================

另外检测是否被人物杀死命令除KillByHum 也可使用 ：CheckKillByHum

特别说明：
KillByHum 检测人物杀死为显示人物，宝宝杀死则为怪物（非人物）
CheckKillByHum 检测为凶手为人物包含人物的任意下属 （含宝宝，英雄和英雄宝宝均检测为人物）
$KILLER 变量显示配合CheckKillByHum 检测，凶手名字全部为人物名字（无论是宝宝，英雄和英雄宝宝均显示人物名字）

[@PlayDie]
#IF
CheckKillByHum
#ACT
SendMsg 5 玩家 <$KILLER> 在%m 把你干死了!
#ELSEACT
SendMsg 5 怪物 <$KILLER> 在%m 把你干死了!


人物小退触发

[@PlayReconnection] 人物小退触发


杀死怪物时触发,杀怪触发

功能: 杀死怪物时触发
说明: 对应地图参数中需要加入ONKILLMON才可生效!
[@OnKillMob]
#IF
CheckKillMonName 白野猪
#SAY
你杀死一头白野猪!

;=============================================================

人物杀死怪物时触发(变量显示带怪物名称后面数字)

[@KillMon]
#ACT
SENDMSG 7 你杀死<$KILLMONNAME>
break

英雄杀死怪物时触发

[@HeroKillMon]
#ACT
SENDMSG 7 你英雄杀死<$H.KILLMONNAME>
break

------------------------------------------------------------------------

人物杀死怪物时触发(变量显示不包含怪物名称后面数字)

[@KillMon]
#ACT
SENDMSG 7 你杀死<$KILLMONNAMEex>
break

英雄杀死怪物时触发

[@HeroKillMon]
#ACT
SENDMSG 7 你英雄杀死<$H.KILLMONNAMEex>
break

注： 英雄杀死怪物触发需要在英雄设置打开选项，否则共享人物触发

勾选后，英雄独立触发（英雄触发含英雄的宝宝和英雄分身杀死怪物触发）


杀死人物宝宝时触发[!]

功能: 杀死人物宝宝时触发

[@KillSlave]
#IF
CheckKillSlaveName 月灵
#ACT
SendMsg 5 你把对方的月灵宝宝杀死了.


杀死人物触发

@KillPlay

;杀人触发
[@KillPlay]
#ACT
MessageBox 你杀人了


沙巴克行会触发[!]

功能：沙巴克行会触发

QF触发

@GetCastle 占领沙巴克

@LostCastle 沙巴克被别人占领


套装触发

@GroupItemOn

例如：

[@GroupItemOn0]
#IF
#ACT
SENDMSG 0 圣战套装隐藏属性被激发:攻击上限增加5点!

[@GroupItemOn1]
#IF
#ACT
SENDMSG 0 法神套装隐藏属性被激发:魔法上限增加5点!

[@GroupItemOn2]
#IF
#ACT
SENDMSG 0 天尊套装隐藏属性被激发:道术上限增加5点!

@GroupItemOff

例如：

[@GroupItemOff0]
#IF
#ACT
SENDMSG 0 圣战套装隐藏属性失效:攻击恢复正常!

[@GroupItemOff1]
#IF
#ACT
SENDMSG 0 法神套装隐藏属性失效:魔法恢复正常!

[@GroupItemOff2]
#IF
#ACT
SENDMSG 0 天尊套装隐藏属性失效:道术恢复正常!

套装生效触发[@GroupItemOnX],套装失效触发[@GroupItemOffX],英雄对应[@HeroGroupItemOnX],[@HeroGroupItemOffX] X表示套装序号

##########################################################以下为全局触发，任意套装生效就触发##########################################################

套装生效全局触发和检测命令

QF套装触发
@GroupItemOnEx @GroupItemOffEx
@HeroGroupItemOnEx @HeroGroupItemOffEx

套装检测命令：
CheckGroupItem 套装编号
用于检测指定编号套装有没生效

例子：
[@GroupItemOnEx]
#IF
CheckGroupItem 1
#ACT
SENDMSG 7 1号套装生效
#ELSEACT
SENDMSG 5 1号套装未生效

[@GroupItemOffEx]
#IF
CheckGroupItem 1
#ACT
SENDMSG 7 1号套装生效
#ELSEACT
SENDMSG 5 1号套装未生效


退出行会触发[!]

功能：退出行会时触发

被掌门人删除或者自己退出行会QF增加[被删除人]或者[退出人]触发

举例：QF触发 （被删除和自己退出触发一个命令）

掌门人删除 123 玩家,123玩家就触发QF [@exitGuild]

123自己退出行会 123玩家就触发QF [@exitGuild]

[@exitGuild]
#IF
#SAY
你已经从行会中退出!


外挂触发[!]

QFunction-0脚本里[@UsePlugin]字段

[@UsePlugin]
#ACT
ChangeModeEx 10 10
SENDMSG 6 使用外挂，锁定10秒


物品触发脚本功能

功能：
双击物品可以自动触发指定脚本功能；

使用方法：
1、物品数据库设置1：STDMODE字段设置为：31
2、物品数据库设置2：AniCount字段设置为：X
X为指字数字触发脚本（1-999）
3、\Mir200\Envir\market_def\QFunction-0.txt下设置
[@StdModeFuncX]
#IF
#ACT
sendmsg 7 触发成功！！！
===================================
注：其中X为物品数据库设置2中的X


物品掉落触发

-----------------------------------物品掉落触发---------------------------

功能说明：物品掉落触发（怪物）-------列表信息二 物品规则

特别注意：脚本不要太复杂，因掉落属频繁调用脚本，如服务器同时掉落几百件物品同时触发属于大负荷运用，脚本尽量简单，复杂脚本建议使用捡取触发

QF触发（仅支持改色和改名，复杂的暂不考虑支持）

以下为QF触发示范：
[@M2DropItem]
#act
; 扩展参数3，是否只取DB中的名称(0:若改名以改名为准； 1：只取DB中的名称）
; 将名字放到S1中
GetUserItemName -1 1 1
;也可以用 Mov S1 <$PickDropItemName>
#if
CompareText S1 偃月
#act
ChangeItemNameColor -1 253

;---------------------------------------例子二
[@M2DropItem]
#ACT
SENDMSG 5 【<$CurUserName>】掉落物品【<$CurItemName>】，位置：<$maptitle> <$ScatterItemX>:<$ScatterItemY>


物品捡取和丢弃触发

@PickUpItemsX X是物品数据库中对应的IDX
@DropItemsX X是物品数据库中对应的IDX
@H.PickUpItemsX X是物品数据库中对应的IDX(英雄)
@H.DropItemsX X是物品数据库中对应的IDX(英雄)

QFunction-0.txt功能脚本增加以下内容

在列表信息二选择需要触发的物品后在功能脚本增加：

[@DropItems10]
#if
#act
SENDMSG 0 玩家<$USERNAME>在<$MapTitle>坐标<$X>：<$Y>扔掉了力量戒指
break

[@PickUpItems10]
#if
#act
SENDMSG 0 玩家<$USERNAME>在<$MapTitle>坐标<$X>：<$Y>捡到<$PICKDROPITEMNAME>
break

----------------------------------------------------------------------------

[@DropItems10]
#if
#act
; //这里支持查看物品属性
SENDMSG 0 玩家<$USERNAME>在<$MapTitle>坐标<$X>：<$Y>扔掉<$PICKDROPITEM>
break

<$PICKDROPITEMNAME>//捡到或者丢弃的物品名字
<$PICKDROPITEM>//捡到或者丢弃的物品名字，支持查看物品属性

注意：需要使用此触发需要在（选项——》列表信息2——》物品规则——》增加“触发ID”）选择触发物品！

以上脚本为捡起物品和扔物品触发.触发条件需要在列表信息二增加物品规则..


物品捡取和丢弃触发

QFunction-0.txt功能脚本增加以下内容

在列表信息二选择需要触发的物品后在功能脚本增加：

[@DropItem]
#if
#act
SENDMSG 0 玩家<$USERNAME>在<$MapTitle>坐标<$X>：<$Y>扔掉了<$PICKDROPITEMNAME>
break

[@PickUpItem]
#if
#act
SENDMSG 0 玩家<$USERNAME>在<$MapTitle>坐标<$X>：<$Y>捡到<$PICKDROPITEMNAME>
break

<$PICKDROPITEMNAME> 捡起和丢弃的物品名称

以上脚本为捡起物品和扔物品触发.触发条件需要在列表信息二增加物品规则..

;=================================================下面为新增=====================================

增加捡起物品QF触发命令@PickUpItemEX ，此触发不需要任何物品规则，捡起任何物品都触发

[@PickUpItemEX]
#if
#act
SENDMSG 0 玩家<$USERNAME>在<$MapTitle>坐标<$X>：<$Y>捡到<$PICKDROPITEMNAME>
break

英雄捡起触发：H.PickUpItemEX


限时装备到期(到时间)触发

QFunction-0

;限时装备到期(到时间)触发

[@HeroItemExpired]
#act
sendmsg 3 你的英雄到期的装备为 <$H.ExpiredItemName>

[@ItemExpired]
#act
sendmsg 3 你到期的装备为 <$ExpiredItemName>


英雄当前获得经验触发

@HeroGetExp

例如:
[@HeroGetExp]
#if
#act
SENDMSG 5 ：英雄本次获取经验为:<$H.GetExp>
break


英雄上线触发

英雄上线触发 @HeroLogin 注意这个触发是由主人执行的所以对英雄的操作请在前面加H

QManage.txt里的配置脚本

[@HeroLogin]
#if
H.CHECKNAMELIST ..\QuestDiary\数据文件\英雄名单.txt
#act
H.DELSKILL 破魂斩
H.DELSKILL 劈星斩
H.DELSKILL 雷霆一击
H.DELSKILL 噬魂沼泽
H.DELSKILL 末日审判
H.DELSKILL 火龙气焰
H.delnamelist ..\QuestDiary\数据文件\英雄名单.txt
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 恶魔长袍(男) 1
H.give 骨玉权杖 1
H.TakeOnitem 骨玉权杖 1
H.TakeOnitem 恶魔长袍(男) 0
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 恶魔长袍(女) 1
H.give 骨玉权杖 1
H.TakeOnitem 骨玉权杖 1
H.TakeOnitem 恶魔长袍(女) 0
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 战神盔甲(男) 1
H.give 裁决之杖 1
H.TakeOnitem 战神盔甲(男) 0
H.TakeOnitem 裁决之杖 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 战神盔甲(女) 1
H.give 裁决之杖 1
H.TakeOnitem 战神盔甲(女) 0
H.TakeOnitem 裁决之杖 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender man
#ACT
H.give 幽灵战衣(男) 1
H.give 龙纹剑 1
H.TakeOnitem 幽灵战衣(男) 0
H.TakeOnitem 龙纹剑 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break
#IF
H.ISNEWHUMAN
H.gender WOMAN
#ACT
H.give 幽灵战衣(女) 1
H.give 龙纹剑 1
H.TakeOnitem 幽灵战衣(女) 0
H.TakeOnitem 龙纹剑 1
H.give 超级金创药 4
H.give 超级魔法药 3
SENDMSG 4 恭喜<$USERNAME>您的英雄领取了装备
break


英雄升级触发

英雄升级触发 @HeroLevelUp 这个触发也是由主人执行的所以对英雄的操作请在前面加H

例如:

[@HeroLevelUp]
#IF
#ACT
H.give 金条 2
break


英雄死亡

功能：
英雄死亡触发

格式：

;==========================================
[@HeroDie]
#IF
#ACT
SENDMSG 6 你英雄死亡了 255 249
BREAK

;-----------------------------------------------------------------------------------------------

[@HeroDie]
#IF
H.CHECKCURRTARGETRACE = 0
#ACT
sendmsg 6 <$H.JOB>
<$HeroKiller> .GAMEGIRD + 10
<$HeroKiller> .SendNewLineMsg 1 255 0 10 540 3 1 你击杀了拥有{狂暴之力的<$H.CURRRTARGETNAME> |250:0:1}获得{【10灵符】|249:0:1}奖励！


英雄学习技能触发

功能说明：英雄学习技能QF触发

[@HeroLearnMagic]
#act
SENDMSG 6 英雄学习技能 <$H.LearnMagicID>


战斗状态触发

功能说明: 进入战斗状态触发、退出战斗状态触发

说明：战斗状态禁止退出、进入战斗状态触发、退出战斗状态触发

--------------------------------------------------------

示例脚本（仅在开启禁止战斗状态退出的地图生效）：

[@StartCombatMode]
#IF
#ACT
SENDMSG 6 进入战斗状态触发

[@EndCombatMode]
#IF
#ACT
SENDMSG 6 退出战斗状态触发


指定人物触发字段[!]

指定人物触发字段 HCALL 人物名称 触发字段


装备持久消失时触发

功能: 装备持久消失时触发,位置0-12

[@ItemDamage1]
#IF
#ACT
SendMsg 5 你的武器已经损坏.


装备升级触发[!]

执行脚本功能.升级成功时执行@UpgradeOKX,升级失败时执行@UpgradeFailX,
属性被清除时执行@UpgradeClearX,其中X代表装备位置,例如:衣服=0,武器=1


走路触发和跑步触发

功能：
走路触发和跑步触发

格式：

;==========================================
走路和跑步触发

QFunction-0

[@Run]
#SAT
你在跑步

[@Walk]
#SAT
你在走路


组队时触发

功能: 创建小组时触发.
说明: 队员的名字放在队长S0变量中.
[@GroupCreate]
#IF
#ACT
SendMsg 5 <$STR(S0)>加入了组队.
<$STR(S0)>.SendMsg 5 你加入了组队.

;在组队前触发,检测创建小组人员的等级
[@StartGroup]
#IF
CheckLevelEx < 25
#ACT
CreateGroupFail
SendMsg 5 25级之后才可以组队.

功能: 离开队伍时触发.
说明: 被删除的队员名字放在队长的S0变量中.
[@LeaveGroup]
#IF
#ACT
SendMsg 5 你退出了组队.

功能: 删除小组成员时触发.
说明: 被删除的队员名字放在队长的S0变量中.
[@GroupDelMember]
#IF
#ACT
<$STR(S0)>.SendMsg 5 你被队长踢出了组队!

功能: 添加小组成员时触发.
说明: 队员名字放在队长的S0变量中....
[@GroupAddMember]
#IF
#ACT
SendMsg 5 <$STR(S0)>加入了队伍.
<$STR(S0)>.SendMsg 5 你加入了队伍.

功能: 组队杀死怪物时触发.
[@GroupKillMon]
#IF
#ACT
SendMsg 5 组队杀怪.


47类右键准星物品说明

新增物品分类47，物品可叠加使用，类似宝石镶嵌~和31类的··结合产物，背包直接执行

StdMode=47 新增扩展物品 可叠加
Shape=50， 物品使用一次后消失 , 准星对准物品点击了 和宝石镶嵌那样视为使用
Shape=51， 物品可以一直使用，直到手动删除

右键使用后 鼠标变成准星模式

触发：
以上扩展2种类型的物品
人物触发 QF中的 [@StdmodeShowX] X=物品的Anicount
英雄触发 QF中的 [@HeroStdmodeShowX] X=物品的Anicount
-----------------------------------------------------------
增加NPC变量（变量名带G_可显示改名后的物品名，详见下方示范脚本）:
当前使用物品名：<$UseItemName>, <$H.UseItemName>
当前使用物品唯一ID：<$UseItemMakeIndex> <$H.UseItemMakeIndex>

+当前准星使用对象物品名： <$BagItemName> <$H.BagItemName>
+当前准星使用对象物品唯一ID：<$BagItemMakeIndex> <$H.BagItemMakeIndex>
;==========================================================

·脚本示范

[@StdModeShow1]
#if
#act
SendMsg 6 人物当前使用的物品名:<$UseItemName>，唯一ID:<$UseItemMakeIndex>
SendMsg 6 使用物品目标名字:<$BagItemName>,唯一ID:<$BagItemMakeIndex>
SendMsg 6 邪恶の力量到此一游
LinkBagItem <$BagItemMakeIndex>
;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1
UpdateItem -1
ClearLinkItem
break

[@HeroStdModeShow2]
#if
#act
SendMsg 6 英雄当前使用的物品名:<$H.UseItemName>，唯一ID:<$H.UseItemMakeIndex>
SendMsg 6 英雄物品目标名字:<$H.BagItemName>,唯一ID:<$H.BagItemMakeIndex>
H.LinkBagItem <$H.BagItemMakeIndex>
;修改物品星星数量
H.CHANGEITEMUPGRADECOUNT -1 + 1 H.UpdateItem -1
H.ClearLinkItem
 break

[@StdModeShow1]
#if
#act
;$G_UseItemName 和$G_BagItemName支持改名后的名称显示，不带G_则为数据库名字
SendMsg 6 人物当前使用的物品名:<$UseItemName> （<$G_UseItemName> ），唯一ID:<$UseItemMakeIndex>
SendMsg 6 使用物品目标名字:<$BagItemName> （<$G_BagItemName> ）,唯一ID:<$BagItemMakeIndex>
break


以下为NPC脚本讲解，常规高频率修改属性会非常消耗CPU资源，需要使用LockUpdateAbil和UpdateAbil对执行脚本进行锁定操作并解锁刷新来显著提高脚本性能
示范的脚本内容均增加了原子钟测试脚本性能和锁定与解锁，如果需要对比性能可以注释掉脚本中的LockUpdateAbil和UpdateAbil
如果你需要测试对比，发现脚本中的物品在你的服务端中没有，请自行修改物品名称进行测试
当然可以参考下面示范脚本内原子钟的运用对你的服务端脚本进行检验，高频脚本低于1毫秒为优，即时间越短越优秀！

[@main]
第一步(开启首饰盒,生肖盒) <开启/@开启>\
第二步(刷物品) <刷物品/@刷> \
第三步(增加属性命令) [耗时高] <加属性/@加> \
第四步(扣除属性命令) [耗时高] <扣属性/@扣> \
第五步(增加属性命令) [耗时高] <EX加属性/@加2> \
第六步(扣除属性命令) [耗时高] <EX扣属性/@扣2> \
第七步(检测套装) [耗时高] <检测/@检测> \ \
清理物品(清理物品) <清理/@删>\

[@加2]
#IF
#ACT
PrintUseTime 1
LockUpdateAbil
;执行脚本前请加上LockUpdateAbil进行锁定，可显著提高脚本性能，防止高频率使用时游戏卡的问题
ChangeHumAbilityEX 1 + 5
ChangeHumAbilityEX 2 + 5
ChangeHumAbilityEX 3 + 5
ChangeHumAbilityEX 4 + 5
ChangeHumAbilityEX 5 + 5
ChangeHumAbilityEX 6 + 5
ChangeHumAbilityEX 7 + 5
ChangeHumAbilityEX 8 + 5
ChangeHumAbilityEX 9 + 5
ChangeHumAbilityEX 10 + 5
ChangeHumAbilityEX 11 + 5
ChangeHumAbilityEX 12 + 5
UpdateAbil
;脚本执行完毕增加UpdateAbil命令进行解锁并刷新
PrintUseTime 2 N0 S0
Sendmsg 6 提示:脚本执行耗时<$STR(N0)>微秒，自动单位为<$STR(S0)>
break

[@扣2]
#IF
#ACT
PrintUseTime 1
LockUpdateAbil
ChangeHumAbilityEX 1 = 0
ChangeHumAbilityEX 2 = 0
ChangeHumAbilityEX 3 = 0
ChangeHumAbilityEX 4 = 0
ChangeHumAbilityEX 5 = 0
ChangeHumAbilityEX 6 = 0
ChangeHumAbilityEX 7 = 0
ChangeHumAbilityEX 8 = 0
ChangeHumAbilityEX 9 = 0
ChangeHumAbilityEX 10 = 0
ChangeHumAbilityEX 11 = 0
ChangeHumAbilityEX 12 = 0
UpdateAbil
PrintUseTime 2 N0 S0
Sendmsg 6 提示:脚本执行耗时<$STR(N0)>微秒，自动单位为<$STR(S0)>
break

[@加]
#IF
#ACT
PrintUseTime 1
LockUpdateAbil
ChangeHumAbility 1 + 5
ChangeHumAbility 2 + 5
ChangeHumAbility 3 + 5
ChangeHumAbility 4 + 5
ChangeHumAbility 5 + 5
ChangeHumAbility 6 + 5
ChangeHumAbility 7 + 5
ChangeHumAbility 8 + 5
ChangeHumAbility 9 + 5
ChangeHumAbility 10 + 5
ChangeHumAbility 11 + 5
ChangeHumAbility 12 + 5
UpdateAbil
PrintUseTime 2 N0 S0
Sendmsg 6 提示:脚本执行耗时<$STR(N0)>微秒，自动单位为<$STR(S0)>
break

[@扣]
#IF
#ACT
PrintUseTime 1
LockUpdateAbil
ChangeHumAbility 1 = 0
ChangeHumAbility 2 = 0
ChangeHumAbility 3 = 0
ChangeHumAbility 4 = 0
ChangeHumAbility 5 = 0
ChangeHumAbility 6 = 0
ChangeHumAbility 7 = 0
ChangeHumAbility 8 = 0
ChangeHumAbility 9 = 0
ChangeHumAbility 10 = 0
ChangeHumAbility 11 = 0
ChangeHumAbility 12 = 0
UpdateAbil
PrintUseTime 2 N0 S0
Sendmsg 6 提示:脚本执行耗时<$STR(N0)>微秒，自动单位为<$STR(S0)>
break

[@检测]
#IF
#ACT
PrintUseTime 1
#IF
CheckGroupItem 1
#ACT
#IF
#ACT
PrintUseTime 2 N0 S0
Sendmsg 6 提示:脚本执行耗时<$STR(N0)>微秒，自动单位为<$STR(S0)>
break

[@删]
#IF
#ACT
TakeBagItemEX 1-9999 200 0 0 0 0 N1 0
MOV N$循环开始 0
WHILE N$循环开始 < 52
TakePosW <$Str(N$循环开始)>
INC N$循环开始 1
ENDWHILE
break

[@开启]
#IF
#ACT
activationcasket
SetSndacasket 1
ShowGodBless 1
OpenGodBless all
break

[@刷]
#IF
#ACT
LockUpdateAbil
;因为一次性自动穿戴物品过多，属性刷新次数过多导致性能有所下降，这时可以在执行前锁定后执行脚本内容
GiveOnItem 00 布衣(男)
GiveOnItem 01 木剑
GiveOnItem 02 荣誉勋章11号
GiveOnItem 03 黑檀项链
GiveOnItem 04 魔法头盔
GiveOnItem 05 皮制手套
GiveOnItem 06 皮制手套
GiveOnItem 07 玻璃戒指
GiveOnItem 08 玻璃戒指
GiveOnItem 09 符
GiveOnItem 10 腰带
GiveOnItem 11 靴子
GiveOnItem 12 宝石
GiveOnItem 13 斗笠
GiveOnItem 14 军鼓
GiveOnItem 15 马牌
; GiveOnItem 16
GiveOnItem 17 灵玉
GiveOnItem 18 时装衣
GiveOnItem 19 时装武
GiveOnItem 20 时装项
GiveOnItem 21 时装头
GiveOnItem 22 时装手
GiveOnItem 23 时装手
GiveOnItem 24 时装戒
GiveOnItem 25 时装戒
GiveOnItem 26 时装勋
GiveOnItem 27 时装腰
GiveOnItem 28 时装靴
GiveOnItem 29 时装宝石
GiveOnItem 30 首饰盒1
GiveOnItem 31 首饰盒2
GiveOnItem 32 首饰盒3
GiveOnItem 33 首饰盒4
GiveOnItem 34 首饰盒5
GiveOnItem 35 首饰盒6
GiveOnItem 40 生肖1
GiveOnItem 41 生肖2
GiveOnItem 42 生肖3
GiveOnItem 43 生肖4
GiveOnItem 44 生肖5
GiveOnItem 45 生肖6
GiveOnItem 46 生肖7
GiveOnItem 47 生肖8
GiveOnItem 48 生肖9
GiveOnItem 49 生肖10
GiveOnItem 50 生肖11
GiveOnItem 51 生肖12
UpdateAbil
;执行完成后解锁并刷新，这样原本刷新几十次（每佩戴一件物品刷新一次）仅需一次刷新即可，不但提高脚本性能效率且减少发往客户端的流量（刷新一次发一次）
PrintUseTime 2 N0 S0
Sendmsg 6 提示:脚本执行耗时<$STR(N0)>微秒，自动单位为<$STR(S0)>
break

;以上属性修改及原子钟例子.游戏卡都是脚本问题导致，在线人数低于1000人就卡请排查服务端耗时大于2毫秒的高频率执行的脚本，低于1500人卡就排查所有大于2毫秒的脚本，排查后如自己无法解决(或换更高效的方式实现该功能)请提供重现服务端（将你无法优化的脚本放入该服务端内并可以直接测试）到论坛


NPC界面调用怪物外观

功能：NPC界面调用怪物外观
格式：无
说明：无

Npc对框增加怪物显示元素

格式：Monster:RaceImg:Appr:F:Dir:X:Y

F:显示方式；0：显示怪物站立第一张图; 1：显示怪物站立动作， 10:怪物走路第一张图; 11:怪物走路动作
Dir: 怪物方向（0-7）
X: X坐标偏移
Y: Y坐标偏移

;--------------------------------------------------------------------------------------------

;显示鸡
<Monster:11:160:1:1:10:60>

*例子2

[@main]
#if
#act
GetDBMonsterFieldValue 暗之双头血魔 appr <$STR(N$怪物APPR)>
GetDBMonsterFieldValue 暗之双头血魔 raceImg <$STR(N$怪物RaceImg)>
#say
<MONSTER:<$STR(N$怪物RaceImg)>:<$STR(N$怪物APPR)>:1:4:50:100>


掉血的地图参数

功能：掉血的地图参数
说明：地图设置掉血并且支持自定义特效
参数：掉血数值,百分比掉血,掉血范围 | 每波数量,每波间隔(秒) | WIL文件序号,开始图片数,播放图片张数,播放速度(毫秒),播放效果(0普通 1特效)

参数：掉血数值,百分比掉血,掉血范围 | 每波数量,每波间隔(秒) | WIL文件序号,开始图片数,播放图片张数,播放速度(毫秒),播放效果(0普通 1特效)
参数说明：
百分比掉血 0掉血数值为固定点数 1掉血数值视为百分比
掉血范围 0仅当前坐标掉血 >0影响范围
每波数量 每波在n个坐标上播放并造成掉血

;------------------------------------------------------------

例子:

[盟重省 3] CustomEffect(10,0,1|10,2|0,1190,7,60,0)

;------------------------------------------------------------

例子说明:

10,0,1 受影响的坐标范围(1)内的对象(怪物除外 因为地图参数伤害是不攻击怪物的，类似于顶部2个地图参数，无非这个是自定义) 固定掉血10点
10,2 每波随机取10个坐标掉血并播放特效，2秒一波
0,1190,7,60,0 NewopUI.pak（资源序号：0）从1190号图开始播放7张，播放间隔60ms，普通播放


巡逻怪物

功能：巡逻怪物
说明：支持怪物巡逻坐标攻击，设置多个指定坐标后，怪物会沿途巡逻(按照设定坐标行走到最后一个坐标停止)
格式：MISSIONEX 地图 x1:y1;x2:y2;x3:y3;x4:y4;xn:yn 是否循环(0:不循环;1循环);

说明:

NPC命令：MISSIONEX 地图 x1:y1;x2:y2;x3:y3;x4:y4;xn:yn 是否循环(0:不循环;1循环);
MISSIONEX 3 315:348;325:348;325:356;315:356 1
循环时，当走到xn:yn，又重新走x1:y1
不循环 走到Xn:Yn结束巡逻

例子:

[@test]
#if
#act
MISSIONEX 3 315:348;325:348;325:356;315:356 1
PARAM1 315
PARAM2 348
PARAM3 1
PARAM4 1
PARAM5 1
PARAM6 0
PARAM7 1
PARAM8 1
PARAM9 0
MOBPLACE 黑野猪
sendmsg 6 刷新成功。
break


设置货币关联

功能：设置货币关联
说明：引擎选项---自定义货币。同一分组中的货币，扣除顺序从0开始，即0优先扣除
说明：注意：对绑定货币进行操作的指令，如果没有绑定（自定义货币中没有配置分组，同一分组的为绑定），则操作指定货币名称自身

命令:

调整货币数量(含预留货币): ChangeMoney 货币名称 操作符(=/+/-) 值

检测货币对应分组中的所有货币总额是否>=检测值：CheckBindMoney 货币名称 检测值

获取绑定的货币总数量：
GetBindMoney 货币名称 变量

减少绑定的货币数量：
DecBindMoney 货币名称 数量

增加变量：
预留货币5数量：<$Money5> ....................................... 预留货币34数量：<$Money34>

==================================================

示例代码如下：

#ACT
ChangeMoney 预留货币34 = 150
ChangeMoney 游戏点 = 250
ChangeMoney 金币 = 350
ChangeMoney 金刚石 = 450
ChangeMoney 灵符 = 550
ChangeMoney 预留货币5 = 650
ChangeMoney 元宝 = 750
GetBindMoney 元宝 N1
sendmsg 5 元宝所对应的分组中，货币总额为<$STR(N1)>
DecBindMoney 元宝 300
GetBindMoney 元宝 N1
sendmsg 5 元宝所对应的分组中，货币总额为<$STR(N1)>


实名认证（身份认证二元素）

实名认证（身份认证二要素）

功能：身份证实名认证

*本实名认证系统适用于阿里云市场身份二要素认证（正式使用前，请先在云市场购买测试确定该商家的身份认证二要素是否可正常使用）...

1.图文说明

将调用地址复制填写到服务器上，对比名称是否和服务器匹配，如不一致将名称对应填写到服务器上

--------------------------------------------------------

复制该商家的Appcode 填写到复制器上

--------------------------------------------------------

进入到调试页面获取变量信息

--------------------------------------------------------

点击调试页面的“发起请求”

--------------------------------------------------------

请求完成后点击“成功响应”获取变量信息，并将变量和对应成功码填写到服务器

--------------------------------------------------------

填写后的效果图（完成配置）：

--------------------------------------------------------

*部分商家变量只有1个，如下图...

--------------------------------------------------------

*部分商家自身就存在目录名字那么填写变量需要填写目录名称+变量名（成功响应中变量如果还存在上级目录则为：目录名+下级目录+变量）如下图...

*因云市场提供身份认证二要素的商家过多，而且部分商家调用变量填写方式不同 ，所以正式使用前请先测试该商家的认证API是否可正常使用再进行购买套餐包...

*以上是三种常见API调用实例，不同商家API变量填写请自己测试，理论上以上三种变量填写方式的总有一种适用（最直接方式就是参阅商家提供的api文档填写）...


跨区跨服功能设置

跨区跨服功能

功能：可跨区和跨服务器进行游戏
格式：M2-选项-跨服设置 中配置中央服务器(母区)和专区服务器(子区)
说明：大概意思就是多个相同版本 可以进入指定区***不是相同版本会出现数据显示错误*****

================================================================

专区(子服)跨到中央服务器命令:
M2SpanRegion 0 3 330 330
参数1为0不保留人物数据，意思就是不回传数据，小退后所有数据回到命令执行的那一刻
参数1为1可以接收人物数据，意思就是跨服服务器小退或者大退回到正常区会进行保存
参数1为2 人物数据全部不保存，和参数为0时候一样，区别就是会保存U T变量（仅U500-U599 T500-T599）
参数2地图代码
参数3地图X坐标
参数4地图Y坐标

================================================================

将母区角色遣返回原服务器(除小退或大退之外可使用此命令强制遣返回原区)，按需使用****一般情况下用不上此命令...

中央服务器母区服务器执行命令格式如下：
M2ReturnRegion 0 3 330 330
参数1为0不保留人物数据
参数1为1传回人物数据
参数1为2 人物数据全部不保存，和参数为0时候一样，区别就是会保存U T变量（仅U500-U599 T500-T599）
参数2地图代码
参数3地图X坐标
参数4地图Y坐标
参数5 坐标范围 随机传送到范围内

================================================================

相关命令：
1.检测角色是否为跨区角色
2.获取专区分区服务器名称
3.获取专区分区服务器ID

#IF
IsSpanRegionHumam
;母区有离线挂机请在挂机脚本前进行检测，防止专区角色离线挂机
#ACT
SendMsg 你是跨服玩家，原服玩家名:<$OldUserName>，服务器名:<$OldServerName>，服务器ID:<$OldServerID>

================================================================

*如果你用不上跨服，或者说跨服用不上参数1为2的话，那么U500-U599 T500-T599可以在你服务端正常脚本中随意使用，如果用上了跨服的参数1为2的话变量将会从母区传回子区保存，所以写版本时需注意...

需要注意的是跨服改名长度不要超过32个字符。默认为专区+角色名字，所以子区的服务器名称不要超过16个汉字，不然显示不全

*跨服的服务器禁止使用动态IP（因动态IP填写是127.0.0.1），禁止使用离线挂机（如必须有，那么离线挂机前检测是跨区角色不让挂）...

*子区正常关闭，正在跨服的角色自动掉线并返回数据（命令参数设置有数据保存的话），服务器宕机、引擎无响应、引擎结束进程的情况下，正在跨服角色不会掉线，这点请注意...


CSV表格读取

功能说明: CSV表格读取

说明：CSV表格读取

--------------------------------------------------------

CSV相关命令

;将文件设置为缓存，某一文件执行此命令后，所有的操作都是缓存操作（不使用缓存命令读取的文件可以实时操作）
;如果不经常更改的情况下建议放在QM的[@Startup]启动触发执行缓存命令，可加快脚本运行速度与效率
;修改文件后可使用CSVOpenCache重新加载文件命令更新缓存内容

加载csv表格内容到内存中
CSVOpenCache 文件路径

;-------------------------------------------
获取CSV文件的最大行数和最大列数
CSVGetCellInfo 文件路径 最大行数保存变量 最大列数保存变量

读取单元格的内容
CSVGetCellText 文件路径 行数 列数 保存变量

查找内容出在第几行
CSVFindTextRow 文件路径 字符串 开始行~结束行 列数(从第几列查找) 0/1(0:开始出现的行；1:最后出现的行) 保存变量

--------------------------------------------------------------

下面示范脚本的Test.csv内容

; 备注符号，读取时会忽略此行
; 转生等级,当前属性,下级属性,需求材料
0,当前攻击1.05倍,1.10倍,转生晶石,1
1,当前攻击1.10倍,1.15倍,转生晶石,2
2,当前攻击1.15倍,1.20倍,转生晶石,3
3,当前攻击1.20倍,1.25倍,转生晶石,4
4,当前攻击1.25倍,1.30倍,转生晶石,5
5,当前攻击1.30倍,1.35倍,转生晶石,6

-------------------------------------------------------------

;示范脚本

[@测试]

#act
;CSVOpenCache ..\QuestDiary\Test.csv
CSVGetCellInfo ..\QuestDiary\Test.csv N$总行数 N$总列数
Mov N$行数 0
While N$行数 < N$总行数
CSVGetCellText ..\QuestDiary\Test.csv <$STR(N$行数)> 0 S0
CSVGetCellText ..\QuestDiary\Test.csv <$STR(N$行数)> 1 S1
CSVGetCellText ..\QuestDiary\Test.csv <$STR(N$行数)> 2 S2
Sendmsg 6 [<$STR(N$行数)>,0]<$STR(S0)>;[<$STR(N$行数)>,1]<$STR(S1)>;[<$STR(N$行数)>,2]<$STR(S2)>;
Inc N$行数 1
EndWhile
CSVFindTextRow ..\QuestDiary\Test.csv 1.25倍 0~10 2 0 N0
Sendmsg 6 "1.25倍"在<$STR(N0)>行,第2列中

;--------------------------------------------------------

;表格内容作为常量进行获取，仅对CSVOpenCache的可用...
;读取时会已常量形式存放在内存中(如果不经常更改的情况下建议放在QM的[@Startup]启动触发执行)
;修改CSV文件后可使用CSVOpenCache重新加载文件命令更新缓存内容
;通过以下去读相关内存中的表格常量值

[@测试]
#act
CSVOpenCache ..\QuestDiary\Test.csv
SendMsg 7 TEST表格内第一行第二列值为：<$TEST(1,2)>
Mov S1 <$TEST(1,2)>
SendMsg 5 1行2列的值为：<$STR(S1)> <$TEST(1,2)>


DB控制不显示人物发型,悬浮框装备背景图片

DB控制不显示人物内观和外观发型 和 悬浮框装备背景图片

DB数据库字段：expand5

expand5: 装备悬浮名字背景图片序号 * 10；如：要装备显示Newopui.pak中 100的图片，应该填 1000
衣服： expand5 = 0表示衣服内观和外观带头发。 =1则表示内外观不带发型

衣服的就是，图片编号 * 10 + （0/1)，图片编号1000，就要设置 1000 * 10 = 10000 + 0/1(是否衣服带头发）

图片0就是不显示图片，显示图片只能从>=1

如：设置图片编号Newopui.pak 1801 的图片则填写18010 ，如果是衣服不需要显示发型设置18011

悬浮框不显示物品名称选项（选项-客户端设置-装备信息，，选项expend5值 > 9 才生效 ）可用于指定图片替代装备名字

****************注：此背景图，不可同装备改名Changeitemname设置背景图一起使用 ，否则会叠加显示******************************


NPC彩色字体设置[!]

功能：NPC彩色字体设置
格式：无
说明：无
例：

变量字符颜色{<$USERNAME>/FCOLOR=254}\
变量字符自动变色{<$USERNAME>/AUTOCOLOR=254,251,168,191,250,70,245,249,253}\

<字体颜色/FCOLOR=69>\
<自动变色/AUTOCOLOR=254,251,168,191,250,70,245,249,253>\

<可以触发字段颜色{FCOLOR=250}/@跳转1>\
<可以触发自动变色{AUTOCOLOR=254,251,168,191,250,70,245,249,253}/@跳转2>\


Npc对话框动态进度条功能[!]

功能：
Npc对话框动态进度条功能

<测试2/@测试2>
  \<ProgressBar:0:0:1:620:630:6:100:4:1:100:200:190:0:249:0:0:%p／%m:NewopUI.pak中/@Label>
  \<ProgressBar:0:0:24:770:771:1:100:0:0:100:200:170:3:255:0:0:%r%:ui_n.pak中/@Label>

[@aaa]
;<ProgressBar:X:Y:F:B:P:C:T:X2:Y2:N:X:V:D:L:X3:Y3:显示文字:备注信息>
X, Y: 微调坐标
F: WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
B: 进度条背景为文件中的第几个图片
P: 进度条进度部分为文件中的第几个图片
C: 进度条进度部分播放张数
T: 进度条进度部分播放间隔
X2: 进度条进度部分X坐标偏移
Y2: 进度条进度部分Y坐标偏移
N: 进度条最小值
X: 进度条最大值
V: 进度条当前值
D: 进度条方向(0:左向右, 1:右向左, 2:上向下, 3:下向上)
L: 进度条文字颜色(0-255)
X3: 进度条文字偏移X
Y3: 进度条文字偏移Y
显示文字：%p当前值, %m最大值, %r百分比

进度部分解释
如必备补丁的620 621图片，一个是背景，一个是进度部分，2个图片大小不一样，背景大些，进度部分小些，进度部分要偏移


NPC对话框提示文字命令，NPC界面上向上滚动提示信息

功能说明：NPC界面上向上滚动提示信息

格式：SENDMOVEHINTMSG 文字信息 文字颜色 背景颜色 X坐标 Y坐标 停留时间(秒；0或空默认3秒)

文字换行：\

[@5555]
#IF
checkgold 2500000
#ACT
#ELSEACT
SENDMOVEHINTMSG 金币不足\金币不足 249 0 10 60

[@55555]
#IF
checkgold 2500000
#ACT
#ELSEACT
;停留5秒消失
SENDMOVEHINTMSG 金币不足\金币不足 249 0 10 60 5


NPC自动变色[!]

;脚本名称 地图名称 X坐标 Y坐标 NPC名称 标志 形象 是否属于沙 是否移动 移动间隔 是否允许变色 变色速度（秒）
;--------------------------------------------------------------------------------------------


宝箱获取物品触发、宝箱触发

 功能说明：宝箱获取物品触发
列表信息2---物品规则-- 宝箱触发 对指定物品开启触发提示，一旦获取该物品将QF触发！

;例子

[@GetBoxsItem]
#act
sendmsg 6 你获取到宝箱物品<$CURITEMNAME>,ID:<$CurItemMakeIndex>


宝箱自定义UI相关说明

 功能说明：宝箱自定义UI动态图相关说明
列表信息2---- 宝箱

宝箱自定义UI动态图相关说明：;

1、普通宝箱，由动画1来配置(20张为一组，连续4组）
2、黄金宝箱，由动画2来配置
3、开宝箱动画和发光帧数相等，且发光效果在开箱动画之后（开箱动画+发光动画不能超过20张）


爆率透视

功能说明：怪物爆率透视

格式：PreviewMonDropItem 最多可显示透视物品数量(0或空:所有)

;提示

脚本命令执行可透视鼠标指向的怪物爆率
允许透视怪物在列表信息1中添加
禁止透视物品在列表信息二物品规则添加
列表信息1 爆率刷新时间解释：
参数为0时 透视怪提前获取爆率，只要怪物不被杀死爆率永远不刷新
参数大于0时 透视怪提前获取爆率，怪物被自己透视后，等达到设置时间后怪物恢复到初始状态,也就可以再次透视获取新的爆率,（怪需满血状态）
参数等于0时 怪物被自己透视后，只要怪物不被杀死其他人不可透死此怪（因考虑内存使用不允许多人同时透视一个怪，因为爆率每个人都不一样，多人可透视需要消耗大量内存进行缓存）
参数大于0时 怪物被自己透视后，等达到设置时间后爆率刷新，任何人可透视此怪，被一个人透视后其他人则不可透视（因考虑内存使用不允许多人同时透视一个怪，因为爆率每个人都不一样，多人可透视需要消耗大量内存进行缓存）

在透视后的物品为什么不爆？

1.变量爆率，透视之前变量符合爆率要求，杀死怪物时变量却不符合要求所以不爆
2.爆率规则限制，当可以爆出物品只剩下1件，同时透视多个怪物都可以爆出这个物品，那么谁先打死怪物物品归谁，其他自然不爆出

[@脚本]
#if
#ACT
;不限制透视物品数量
M.PreviewMonDropItem
break

;---------------------------------------------------------------------

[@MagSelfFunc1016]
#if
;检测透视的这个技能等级等于0/1级
CHECKSKILL 透视技能 < 2
M.CheckLevelEx < 55
#ACT
;只允许透视1个物品
M.PreviewMonDropItem 1
break

#if
;检测透视的这个技能等级等于2级
CHECKSKILL 透视技能 = 2
M.CheckLevelEx < 85
#ACT
;允许透视10个物品
M.PreviewMonDropItem 10
break

#if
;检测透视的这个技能等级等于3级
CHECKSKILL 透视技能 = 3
M.CheckLevelEx < 105
#ACT
;不限制透视物品数量
M.PreviewMonDropItem
break

;---------------------------------------------------------------------

刷新透视爆率命令
PreviewMonDropItemRefresh 最多显示数量 刷新条件（0：仅刷新有间隔的透视怪；1：无条件刷新）

刷新一次表示重置一次爆率，相当于正常流程刷新一次杀死一次怪物
用法与透视命令一样，区别就是刷新透视命令使用一次，爆率就刷新一次,而透视则是根据列表信息1中允许透视怪物设置的刷新间隔进行刷新


背包扩展、包裹扩展

-----------------------------------背包扩展、包裹扩展---------------------------

功能说明：扩展角色背包

扩展背包页数：
ExtBagPageCount 操作符(=+-) 页数

扩展背包开启格数
;每一页背包最多可加40格
ExtBagOpenItemCount 操作符(=+-) 格数

变量：
获取背包扩展页数：<$ExtBagPageCount>
获取扩展背包已开启格数：<$ExtBagOpenItemCount>
获取扩展背包未开启格数：<$ExtBagCloseItemCount>

触发:
双击背包中未开启的格子（有个锁图标的），触发QF中的[@ClosedBagItemClick]

[@ClosedBagItemClick]
#if
Large <$ExtBagCloseItemCount> 0
#act
mov n1 <$ExtBagOpenItemCount>
ExtBagOpenItemCount + 1
SENDMSG 7 你的扩展背包已从<$STR(n1)>格扩展到<$ExtBagOpenItemCount>格


采集类型怪物设置

功能:采集类怪物

采集类怪物Race=30，自定义采集类怪物Race=159{不带攻击的采集怪}，160{带攻击的采集怪}
采集怪数据库的level字段用来控制采集时的活动范围（0：移动/魔法/攻击等会中断；大于0位允许采集期间活动范围，如设置3：在离采集怪3格范围内可以自由移动，在采集命令设置中断情况下 超出3格中断采集，设置0为立即中断）
多级脚本：采集怪 CO.
取当前采集怪名称：<$CollectTargetName>

鼠标点击怪物，角色跑近怪物身边，站立不动不攻击，只触发[@CollectMonX]
玩家采集将会触发QF的[@CollectMonX]其中X代表怪物数据库的MP值

数据库：
采集怪 30 11 160 20 0 0 10 100 99 0 0 1 1 0 0 10 3 1400 1 0 3000 0 0 111 1 0
采集类怪物静止移动，不受任何类型攻击，宝宝英雄也不会去攻击这个怪物
如果自定义怪物做的采集，可以让设置采集怪攻击（比如范围内魔法攻击），加大采集压力，但是怪物自身不受任何攻击！

参考QF脚本：
[@CollectMon99]
#IF
CO.CHECKHPPER > 0
#ACT
Sendmsg 5 正在采集【<$CollectTargetName>】。
SHOWPROGRESSBARDLG 5 @怪物采集成功 采集中%d%... 1 @怪物采集中断

[@怪物采集成功]
#IF
CO.CHECKHPPER > 0
#ACT
SENDMSG 6 〖提示〗采集成功【<$CollectTargetName>】
CO.KILL
GOTOLABEL 7 @强制中断采集 3
#ELSEACT
MESSAGEBOX 别人已经捷足先登了

[@怪物采集中断]
#ACT
Sendmsg 5 采集中断
[@强制中断采集]
#IF
CO.CHECKHPPER = 0
#ACT
Sendmsg 5 强制中断
StopCollect
BREAK

################################暂 未 完 善###################################################

采集怪增加采集次数 ---秒采集可用，按需使用
注意：每次触发@CollectMonX时减计数，而非采集成功减计数。

数据库Exp字段（0：不计数；大于0：采集完指定次数后怪物死亡）
剩余采集次数：<$CollectMonRemainCount>

[@CollectMon99]
#IF
M.CHECKHPPER > 0
#ACT
Sendmsg 5 正在采集【<$CollectTargetName>】，剩余次数<$CollectMonRemainCount>。
SHOWPROGRESSBARDLG 5 @怪物采集成功 采集中%d%... 1 @怪物采集中断
[@怪物采集成功]
#IF
M.CHECKHPPER > 0
#ACT
SENDMSG 6 〖提示〗采集成功【<$CollectTargetName>】
GOTOLABEL 7 @强制中断采集 3
#ELSEACT
MESSAGEBOX 别人已经捷足先登了


嘲讽命令,吸怪

格式: DoTaunt 参数1 参数2 参数3 参数4 参数5 参数5

说明:DoTaunt 范围 怪物最低等级 是否瞬移过来(0=走动 1=瞬移) 是否检测怪物已经有攻击目标(0不检测 1不吸引已经有了攻击目标的怪物) （是否将怪嘲讽到鼠标坐标;0:人物坐标；1:鼠标坐标） 分散范围

#ACT
DoTaunt 5 100
SENDMSG 6 范围5格内等级低于101级的的怪物对你攻击。
Break

*************注意，参数5将怪嘲讽到鼠标坐标仅在@BeginMagic触发中有效。
例子

[@BeginMagic]
#IF
EQUAL <$MagicID> 1017
#ACT
DoTaunt 30 0 1 0 1


宠物说明

宠物功能开启及设置:M2－》选项－》宠物设置

1.数据库说明

StdItems:

【★★★★默认宠物蛋必加，名字不要变★★★★★】

100,宠物蛋,91,0,,,,,3710,,,,,,,,,,,,,,,,255,0,0,0,,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
101,白野猪,92,0,,,,,3710,,,,,,,,,,,,,,,,255,0,0,0,,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
103,宠物技能,93,0,1,17,1000,1,1964,0,22,95,0,0,0,0,0,0,0,0,0,0,0,0,251,,,,,0,0,0,0,0,1,2,3,4,5,6,7,8,9,0,0,0,0,0,0,0,0,0,0,0,0,0
102,捕捉网,94,3,1,16,3,0,1195,10000,2,5,0,0,0,0,0,0,0,0,0,0,0,0,251,,,,,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

宠物技能物品（Stdmode：93），字段加成主人属性：
AC： 准确
AC2： 敏捷
MAC： 幸运
MAC2： 攻击速度
DC： 中毒恢复
DC2： 毒物躲避
MC： 魔法恢复
MC2： 魔法躲避
SC： 体力恢复
SC2：
DuraMax：负重(穿戴)
Overlap：负重（背包）
Element，Element1....Element23：元素属性

自定义宠物蛋（Stdmode=92）名字为数据库已有怪物名称 字段为宠物初始属性

AC： 防御下限
AC2： 防御上限
MAC： 魔御下限
MAC2： 魔御上限
DC： 攻击下限
DC2： 攻击上限
MC： 魔法下限
MC2： 魔法上限
SC： 道术下限
SC2： 道术上限
Level： 初始等级

Magic:
90,宠物捕捉,2,70,5,50,60,2,20,20,0,18,50,21,100,24,200,26,400,28,800,30,1600,33,3200,36,6400,39,12800,42,25600,46,51200,50,102400,55,204800,60,409600,66,819200,60,,3,,技能

---------------------------------------------------------------------------------------------------------------------------------------------------------------------

2.QFunction触发说明

·宠物召唤触发
[@GamePetRecall]
#ACT
SendMsg 5 召唤宠物<$GamePetName>

·收回宠物 / 宠物死亡触发
[@GamePetRetake]
#ACT
SendMsg 5 收回宠物 <$GamePetName>

·宠物升级触发 宠物等级变量<$GamePetLevel> 宠物数量变量<$GamePetCount>
[@GamePetLevelUp]
#ACT
SendMsg 5 你的宠物 <$GamePetName>升级了，当前等级<$GamePetLevel>

·双击宠物技能物品触发 QF中的 [@GamePetTrainingMagic]
·NPC命令：中断宠物技能学习 BreakGamePetTrainingMagic
·NPC变量 - 宠物技能名：<$GamePetMagicName>
[@GamePetTrainingMagic]
#act
sendmsg 7 <$GamePetName>准备学习技能（技能编号 :<$GamePetMagicID>；技能名 :<$GamePetMagicName>)，技能位置<$GamePetMagicIndex>
BreakGamePetTrainingMagic
sendmsg 6 已经中断了宠物技能学习

·宠物列表选择触发 QF中的 [@GamePetSelect] *新增（打开宠物界面也会触发,返回变量为上次选择)
·NPC变量（仅用于@GamePetSelect）：宠物列表中选择索引 <$SelectGamePetIndex>； 宠物列表选择名：<$SelectGamePetName>
[@GamePetSelect]
#act
sendmsg 7 选择宠物列表中的第<$SelectGamePetIndex>个宠物<$SelectGamePetName>

·宠物学习技能触发：
[@GamePetAddMagic]
当前学习技能编号：<$GamePetMagicID>
当前学习技能位置：<$GamePetMagicIndex>

[@GamePetAddMagic]
#act
sendmsg 7 <$GamePetName>学习了技能（技能编号 :<$GamePetMagicID>)，技能位置<$GamePetMagicIndex>

·宠物捡物触发人物的QF拾取触发

@PickUpItem
@PickUpItems
@PickUpItemEx

·增加宠物返回到背包后触发：
[@PetToEgg]
#IF
#ACT
LinkBagItem <$BagItemMakeIndex>
SetCustomItemAbil -1 0 0 250
SetCustomItemAbil -1 0 1 50
SetCustomItemAbil -1 0 2 0
SetCustomItemValue -1 0 = 1500
UpdateItem -1
Sendmsg 7 返回一个蛋"<$BagItemName>"并修改资质为1500

·增加双击宠物蛋放入到列表中触发
[@EggToPet]
#IF
#ACT
LinkBagItem <$BagItemMakeIndex>
GetCustomItemValue -1 0 N1 N2
Sendmsg 7 当前宠物蛋"<$BagItecmName>"的资质为<$STR(N1)>

3.宠物操作命令说明

·直接从宠物列表中删除宠物(序号0开始)：GamePetToBag 宠物序号

#if
#act
DeleteGamePet 0

·将宠物变成蛋放回到背包：GamePetToBag 宠物序号

#if
#act
GamePetToBag 0

·检测宠物技能
#if
CheckGamePetSkillMagic 宠物技能3
#act
DelGamePetMagic 宠物技能3

·给予宠物蛋

GiveGamePet 怪物名 N变量(存储蛋的MakeIndex，可选变量 可不填,)

;给一个修改属性的蛋蛋，如果就数据库的蛋无需变量直接给予！

[@测试给宠物]
#IF
#ACT
GiveGamePet 白野猪 N1
LinkBagItem <$STR(N1)>
SetCustomItemAbil -1 0 0 250
SetCustomItemAbil -1 0 1 50
SetCustomItemAbil -1 0 2 0
SetCustomItemValue -1 0 = 1500
UpdateItem -1
Sendmsg 7 返回一个蛋并修改资质为1500

·清除当前召唤的宠物技能
ClearGamePetMagic 敏捷技能

·给予宠物经验
GamePetChangeExp 操作符(+，-，=) 值

·设置宠物攻击力倍数
 SetGamePetAttackHumPowerRate 攻击人物威力倍率(0不攻击人物,当前值除以100为实际倍数)

·调整宠物攻击人物威力(数值)
 SetGamePetAttackHumPowerRateEx 操作符(+/-/=) 值

·获取宠物攻击人物威力(数值)
 GetGamePetAttackHumPowerRate 变量

·检测宠物是否召唤
CheckCallGamePet

·检测宠物等级
CheckGamePetLevel 操作符(>/=/<) 等级

·调整宠物等级
ChangeGamePetLevel 操作符(+/-/=) 数值

·召唤宠物：
RecallGamePet 宠物名(当为空时，表示召唤最后一次召唤的宝宝）

·调整宠物蛋属性
ChangeGamePetEggAbil 物品位置(-1或boxitem0-boxitem7) 属性类型(参考下面) 操作符(+-=) 值
属性类型：
1: 等级
2: HP
3: MP
4: EXP

·获取宠物蛋属性：
》GetGamePetEggAbil 物品位置(-1或boxitem0-boxitem7) 属性类型 变量名
属性类型：
1: 等级
2: HP
3: MP
4: EXP
5: MaxHP
6: MaxMP
7: MaxEXP
8: 防御下限
9: 防御上限
10: 魔防下限
11: 魔防上限
12: 攻击下限
13: 攻击上限
14: 魔法下限
15: 魔法上限
16: 道术下限
17: 道术上限
》获取：GetItemFieldValue 物品位置 属性名称 变量名

;Uelement0……uelement23为元素属性，其中元素属性3-10为技能1-8

GetItemFieldValue -1 uelement3 N$技能1
GetItemFieldValue -1 uelement4 N$技能2
GetItemFieldValue -1 uelement5 N$技能3
GetItemFieldValue -1 uelement6 N$技能4
GetItemFieldValue -1 uelement7 N$技能5
GetItemFieldValue -1 uelement8 N$技能6
GetItemFieldValue -1 uelement9 N$技能7
GetItemFieldValue -1 uelement10 N$技能8

返回值为技能在数据库中的 Idx 值+1 例如:你技能一IDX为100 则获取的返回值为101

》设置：SetItemFieldValue 物品位置 属性名称 变量名

属性支持dura, duramax, upgradecount, Value0……Value13, uelement0……uelement23
说明： Value0……Value13为极品属性；uelement0……uelement23为元素属性

SetItemFieldValue -1 uelement3 N$技能1
SetItemFieldValue -1 uelement4 N$技能2
SetItemFieldValue -1 uelement5 N$技能3
SetItemFieldValue -1 uelement6 N$技能4
SetItemFieldValue -1 uelement7 N$技能5
SetItemFieldValue -1 uelement8 N$技能6
SetItemFieldValue -1 uelement9 N$技能7
SetItemFieldValue -1 uelement10 N$技能8

设置值为技能在数据库中的 Idx 值+1 例如:你技能一IDX为100 则获取的返回值为101

·打开宠物界面命令
OpenGamePetDlg

·打开宠物背包（坐标X、Y均为0时，表示不设置坐标)
OpenGamePetBag 坐标X 坐标Y

·npc命令收回宠物
#if
#act
RetakeGamePet
SENDMSG 6 你的宠物已经收回

；------------------------------------------------------------------------

#if
CheckCallGamePet
#act
SENDMSG 6 你的宠物等级是：<$GamePetLevel>
ChangeGamePetLevel + 10
SENDMSG 6 调整后的宠物等级是：<$GamePetLevel>
#elseact
RecallGamePet
OpenGamePetBag 10 10

；------------------------------------------------------------------------

·设置当前召唤的宠物是否可捡物
SetGamePetEnablePick 参数值
参数值：
0：由宠物设置中的“允许宠物捡取物品”选项决定
1：允许捡物
2：禁止捡物

；------------------------------------------------------------------------

·修改当前召唤的宠物属性值：【修改的属性不保存，当收回宠物再重新召唤时，属性值还原】
ChangeGamePetAbility 属性类型 值
0: HP
1: MaxHP
2: MP
3: MaxMP
4: AC1
5: AC2
6: MAC1
7: MAC2
8: DC1
9: DC2
10: MC1
11: MC2
12: SC1
13: SC2
14: 攻击速度
15: 移动速度
30: 属性有效时间（秒，空或0表示不检测时间）

·获取当前召唤宠物的属性修改值(ChangeGamePetAbility 命令增加的属性，可以理解为附加属性)
GetGamePetAbility 属性类型 变量

·获取当前召唤宠物的属性
GetGamePetAbilityEx 属性类型 变量

·重新计算宠物属性(重算属性是修改属性后重算修改的属性,可多次修改后一次计算)：
RecalcGamePetAbility

#if
CheckCallGamePet
#act
GetGamePetAbility 1 N1
Inc N1 100
ChangeGamePetAbility 1 N1
RecalcGamePetAbility
SendMsg 6 修改宠物MaxHP增加值为：<$str(N1)>

；------------------------------------------------------------------------

·获取当前召唤宠物技能数量：
GetGamePetMagicCount 变量名
；------------------------------------------------------------------------

·获取当前召唤宠物技能位置对应技能信息
GetGamePetMagicInfo 技能位置 技能ID变量 技能名变量

[@获取宠物技能信息]
#if
CheckCallGamePet
#act
GetGamePetMagicCount N1
SendMsg 6 你当前宠物一个学习了<$Str(N1)>个技能
GetGamePetMagicInfo 0 N1 S1
SendMsg 6 你当前宠物技能0信息为（技能编号：<$Str(N1)>，技能名称：<$Str(S1)>）
#elseact
SendMsg 6 你还没有召唤宠物
；------------------------------------------------------------------------

·设置当前召唤宠物某个技能位置技能
GiveGamePetMagic 技能位置 技能名称

[@宠物技能位置2学技能]
#if
CheckCallGamePet
#act
;感觉这个没有AddGamePetMagic好用，如果技能位有技能，会被覆盖
GiveGamePetMagic 1 宠物技能1
#elseact
SendMsg 6 你还没有召唤宠物
；------------------------------------------------------------------------

·直接给一个宠物到宠物列表
GiveGamePetEx 宠物名称

[@直接给个宠物]
#act
GiveGamePetEx 红野猪
#if
not CheckCallGamePet
#act
RecallGamePet 红野猪
；------------------------------------------------------------------------

·修改当前召唤的宠物外观/脸型
ChangeGamePetAppr 新的脸型(Appr) 有效时间(分钟)

[@修改宠物脸型]
#if
CheckCallGamePet
#act
ChangeGamePetAppr 10 1
sendmsg 6 你的宠物已经变成了食人花造型，有效时间1分钟

·宠物界面预留按钮9个 850-858
搜索帮助文档“预留按钮”，预留编号增加：
宠物界面 （850-858）
；------------------------------------------------------------------------

·收回指定宠物
#if
equal 白野猪 <$GamePetName>
#act
RetakeGamePet

·自定义修改宠物名字（不保存，重新召唤恢复）
ChangeGamePetName 新名称

#if
CheckCallGamePet
#act
ChangeGamePetName 大花
SENDMSG 6 你的宠物名字更改为【大花】

；------------------------------------------------------------------------

·获取宠物列表中宠物数量 GetGamePetListCount 变量名
·获取当前召唤的宠物在列表中的顺序 GetRecalGamePetIndex 变量名

#act
GetGamePetListCount N0
GetRecalGamePetIndex N1
SendMsg 6 你的宠物列表共有宠物：<$str(N0)>个；当前召唤的宠物序号是：<$str(N1)>

·设置宠物不攻击
GamePetSetAttackOption 类型 值(0/1/2) 有效时间(0为在线有效)
类型:
0: 允许宠物攻击 ;当值=0时，宠物是否攻击随全局参数；当值=1时，允许宠物攻击；当值=2时，禁止宠物攻击
1: 怪物不攻击宠物 ;当值=0时，随全局参数；当值=1时，开启此功能
2: 宠物不受任何攻击 ;当值=0时，随全局参数；当值=1时，开启此功能

#####################################################下方为2021-10-08增加############################################

宠物设置——》参数设置——》增加选项"杀怪触发[@GamePetKillMon]"

增加宠物（攻击-魔法）触发
@GamePetAttack
@GamePetMagicAttack

增加宠物（被攻击-被魔法）触发
@GamePetStruck
@GamePetMagicStruck

增加宠物（攻击-被攻击掉血前）触发、修改当前伤害血量
@GamePetAttackDamage
@GamePetStruckDamage

宠物自身坐标
<$Pet.X>
<$Pet.Y>

宠物血量
<$Pet.HP>
<$Pet.MaxHP>

宠物蓝：
<$Pet.MP>
<$Pet.MaxMP>

宠物攻击目标名称：
<$Pet.CurTargetName>; 不带数字
<$Pet.CurTargetFullName>

宠物当前攻击目标坐标
<$Pet.CurTargetX>
<$Pet.CurTargetY>

宠物当前击中目标HP
<$Pet.CurTargetHP>
<$Pet.CurTargetMaxHP>

宠物攻击目标掉血量
<$Pet.DamageValue>

宠物杀死的怪物名称
<$Pet.KillMonName>

;变量:当前伤害掉血量（仅用于以下触发）：<$Pet.DamageValue>
[@GamePetAttackDamage]
#ACT
SENDMSG 6 宠物攻击目标，掉血量为<$Pet.DamageValue>，攻击加成10点血量
Pet.ChangeDamageValue 0 + 10

[@GamePetStruckDamage]
#ACT
SENDMSG 6 宠物被攻击，掉血量为<$Pet.DamageValue>，抵御掉血量的50%
Pet.ChangeDamageValue 1 - 50

；------------------------------------------------------------------------

注：常规普通的宠物捡物在引擎-列表信息1-设置允许捡取和优选捡起 （普通捡物品列表与常规英雄捡物同步（M2- 列表信息1设置允许捡起物品）,特殊需求用户可同步玩家内挂设置进行捡物品）

--------------------------------------------------


穿戴和脱装备统一触发

功能说明：穿戴和脱装备统一触发

人物通用穿戴装备触发@TakeOnEx，卸下装备触发：@TakeOffEx
英雄通用穿戴装备触发@HeroTakeOnEx，卸下装备触发：@HeroTakeOffEx

增加变量（人物）：
当前操作装备位置: <$CurItemPos>
当前操作装备数据库名: <$CurItemName>
当前操作装备改名后名称: <$G_CurItemName>
当前操作装备唯一ID: <$CurItemMakeIndex>

增加变量（英雄）：
当前操作装备位置: <$H.CurItemPos>
当前操作装备数据库名: <$H.CurItemName>
当前操作装备改名后名称: <$H.G_CurItemName>
当前操作装备唯一ID: <$H.CurItemMakeIndex>

[@TakeOnEx]
#ACT
SENDMSG 6 人物穿装备，位置<$CurItemPos>，物品<$CurItemName>(<$G_CurItemName>)，ID<$CurItemMakeIndex>

[@TakeOffEx]
#ACT
SENDMSG 6 人物脱装备，位置<$CurItemPos>，物品<$CurItemName>(<$G_CurItemName>)，ID<$CurItemMakeIndex>

[@HeroTakeOnEx]
#ACT
SENDMSG 6 英雄穿装备，位置<$H.CurItemPos>，物品<$H.CurItemName>(<$H.G_CurItemName>)，ID<$H.CurItemMakeIndex>

[@HeroTakeOffEx]
#ACT
SENDMSG 6 英雄脱装备，位置<$H.CurItemPos>，物品<$H.CurItemName>(<$H.G_CurItemName>)，ID<$H.CurItemMakeIndex>

------------------------------------------


从文本里随机获取一组不相同的字符

功能说明：从文本里随机获取一组不相同的字符

GetMultiRandomText 文件路径 获取数量 保存变量(不输入括号的变量，非自定义变量，如:S1) 保存实际获取数量的变量 是否是绝对路径（最后加个参数 1为绝对路径，，0或者留空为默认的相对路径)

示范：

[@Main]
#IF
#ACT
GetMultiRandomText ..\QuestDiary\测试.txt 10 S1 N1
SENDMSG 6 在“测试.txt”文件里，随机获取10个不相同的字符，保存在变量S1~S10里面，实际获取到字符数量为:<$STR(N1)>
SENDMSG 6 S1=<$STR(S1)>
SENDMSG 6 S2=<$STR(S2)>
SENDMSG 6 S3=<$STR(S3)>
SENDMSG 6 S4=<$STR(S4)>
SENDMSG 6 S5=<$STR(S5)>
SENDMSG 6 S6=<$STR(S6)>
SENDMSG 6 S7=<$STR(S7)>
SENDMSG 6 S8=<$STR(S8)>
SENDMSG 6 S9=<$STR(S9)>
SENDMSG 6 S10=<$STR(S10)>

;如果文本中只有9行字符,S10则为空,实际获取字符数量为:9

------------------------------------------


打开客户端界面功能

-----------------------------------打开客户端界面功能---------------------------

说明：打开客户端相关界面

格式：OpenClientDlg 界面编号 是否设置坐标(0：不设置; 1:设置）坐标X 坐标Y

界面编号 ：
1:系统商铺; 2:个人商店; 3:任务 4: 日志 5: 小地图; 6:交易 7:行会 8:组队 9:关系 10:帮助 11:排行榜 12:挑战 13:私聊信息 14:属性点分配 15:内挂 16:M地图 17:背包

示范：

#act
OpenClientDlg 1 1 100 10


登录点安全区[!]

功能：登录点安全区
格式：无
说明：配置文件StartPoint.txt
例：

文件格式：

;地图号 | 座标X | 座标Y | 禁止说话 | 大小范围 | 光环类型 | PKZONE | PKFIRE
0 | 289 | 618 | 0 | 10 | 4 | 0 | 0
0 | 650 | 631 | 0 | 10 | 4 | 0 | 0
0 | 334 | 266 | 0 | 10 | 4 | 0 | 0
2 | 503 | 483 | 0 | 10 | 4 | 0 | 0
3 | 330 | 330 | 0 | 10 | 4 | 0 | 0

地图号：安全区所在地图
座标X：安全区所在地图座标X
座标Y：安全区所在地图座标Y
禁止说话：安全区内是否禁止说话(此功能未完成)
大小范围：安全区范围大小(此功能未完成)
光环类型：安全区边界显示类型(1-11编号均可使用，主流2或4或5，自行测试设置适合自己的安全区光圈)
PKZONE：安全区是否为PK比赛区域(此功能未完成)
PKFIRE：安全区PK区域边界显示类型(此功能未完成)


地图参数限制人物在地图的时间（TimeMap）

功能: 使用地图参数限制角色在地图内时间

格式:TimeMap(3|5|1|@计时地图返回)

参数一到时间返回的地图代码
参数二 倒计时时间分钟计算
参数三 是否显示当前地图剩余倒计时
参数四 退出地图触发QF字段

（MapInfo.txt)

[G001 质询屋] SAFE DAY QUIZ NOMANNOMON TimeMap(3|5|1)

OR

[G001 质询屋] SAFE DAY QUIZ NOMANNOMON TimeMap(3|5|1|@计时地图返回)

QFunction-0.txt
[@计时地图返回]
#IF
#ACT
Sendmsg 5 返回地图。
;从地图出来时候触发，无论在线到时间出来还是小退后自动出地图，只要出地图就触发


地图参数详解[!]

功能：地图参数详解
格式：无
说明：无
例：

地图参数标志 | 说明
CHECKQUEST | 进入本地图执行任务脚本 格式：CHECKQUEST(Q001) 说明： Q001 代表脚本名。
NEEDSET_ON | 进入本地图需要人物指定标志为打开状态格式：NEEDSET_ON(001) 说明：001 代表人物标志
NEEDSET_OFF | 进入本地图需要人物指定标志为关闭状态格式：NEEDSET_OFF(001) 说明：001 代表人物标志
MUSIC | 进入入本地图播放音乐 格式：MUSIC(..\Wav\bg.mp3) 或者 MUSIC(.\Wav\sellect-loop2.wav)代表客户端Wav文件下的sellect-loop2.wav文件
EXPRATE | 进入本地图后杀怪经验倍数 格式：EXPRATE(100) 说明：100代表经验倍数，除以100后为实际倍数。
PKWINLEVEL | 进入本地图后可以PK升级 格式：PKWINLEVEL(1) 说明：1代表升多少级；
PKWINEXP | 进入本地图后可以PK得经验 格式：PKWINEXP(1000) 说明：1000代表得多少经验；
PKLOSTLEVEL | 进入本地图后可以PK死亡掉等级 格式：PKLOSTLEVEL(1) 说明：1代表掉多少等级；
PKLOSTEXP | 进入本地图后可以PK死亡掉经验 格式：PKLOSTEXPP(1000) 说明：1000代表掉多少经验；
DECHP | 进入本地图后自动减HP 格式：DECHP(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；
INCHP | 进入本地图后自动加HP 格式：INCHP(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次加多少点；
DECGAMEGOLD | 进入本地图后自动减游戏币 格式：DECGAMEGOLD(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；
INCGAMEGOLD | 进入本地图后自动加游戏币 格式：INCGAMEGOLD(1/10) 说明 1/10 1代表加的间隔(秒)，10代表一次加多少点；
INCGAMEPOINT | 进入本地图后自动加游戏点 格式：INCGAMEPOINT(1/10) 说明 1/10 1代表加的间隔(秒)，10代表一次加多少点；(用于游戏泡点功能)
DECGAMEPOINT | 进入本地图后自动减游戏点 格式：DECGAMEPOINT(1/10) 说明 1/10 1代表减的间隔(秒)，10代表一次减多少点；(用于游戏泡点功能)
BattlingDisExit | 战斗状态禁止退出
RUNMON | 允许穿怪
RUNHUMAN | 允许穿人
NORUNMON | 禁止穿怪
NORUNHUMAN | 禁止穿人
NEEDHOLE | 进入需要洞
NORECALL | 禁止记忆召唤
NOGUILDRECALL | 禁止行会召唤
NODEARRECALL | 禁止夫妻召唤
NOMasterRECALL | 禁止师徒传送
NORANDOMMOVE | 禁止随机传送;瞬息移动
NODRUG | 禁止使用任何药品
MINE | 可以挖矿
NoAutoDropItemToBag | 禁止OpenAutoDropItemToBag命令物品自动入包
NoAutoRangePickItem | 禁止OpenAutoPickItem命令范围拾取
NOPOSITIONMOVE | 禁止定座标移动、传送戒指、坐标传送
NORECONNECT | 进游戏时退出本地图 格式:NORECONNECT(3) 说明：3 代表地图号盟重
QUIZ | 禁止喊话
ALLOWUSEMYSHOP | 允许摆摊(个人商店允许购买物品的地图加此参数,使用仿herom2指定地图摆摊也需此参数)
FIGHT2 | 杀人不犯法.但是会爆装备.适合用来做一些战争PK的地图
FIGHT3(是否掉装备) | 行会战地图进入该地图名字颜色会变色，杀人不加PK。格式:FIGHT3(0) 死亡不掉装备 格式:FIGHT3(1) 死亡掉装备
NOTALLOWUSEITEMS | 禁止使用物品 说明：NOALLOWUSEITEMS(回城卷|强效金创药)
NOTALLOWUSEMAGIC | 禁止使用技能 说明：NOTALLOWUSEMAGIC(火墙|彻地钉)
NODROPITEM | 禁止死亡爆装备、物品(怪除外)
NOHEROPROTECT | 禁止英雄守护
THUNDER | 例:THUNDER(10) 此地图有闪电效果,击中减hp为10
LAVA | 例:LAVA(10) 此地图地上冒岩浆,击中减HP为10
CustomEffect | 例:CustomEffect(参数)设置地图伤害和特效等
FIGHT4 | 挑战地图
Safe | 此地图为安全地图，不可PK类似安全区
FIGHT | 此参数地图不犯法，不爆装备
FLAME | FLAME(45:82:50|43:84:50)参数说明:x坐标：y坐标：伤害 可以为多坐标以|分隔
NOHORSE | 当前地图禁止骑马
NoAutoOnline | 当前地图禁止挂机
NoCallPet | 禁止召唤宠物，已召唤宠物将自动收回
MISSION | 不允许使用任何物品和技能，并且宝宝在该地图会自动消失，不能攻击
NOMANNOMON | 智能刷怪，当地图无人时清理怪物，有人时重新刷怪，此功能需在M2怪物设置开启
NOCALLHERO | 禁止召唤英雄，已召唤英雄将自动消失
DisableCallHero | 禁止召唤英雄，已召唤英雄不受影响
NIGHT | 该参数与M2禁止免蜡无关联，凡是地图参数包含NIGHT那么该地图就开启天气效果（不受禁止免蜡控制）
NEEDLEVELTIME | 没到指定等级时不让进入，发送string.ini里的NeedLevelToXYErrorMsg提示可以自行修改
DECEXPRATETIME(值) | 每秒减双倍经验时间,如值小于1时，则默认为1
NGEXPRATE(数值) | 内功经验倍数(100代表经验倍数，除以100后为实际倍数)
PULSEXPRATE(数值) | 经络经验倍数(100代表经验倍数，除以100后为实际倍数)
DARK | 黑暗效果 如果同时存在 DAY以DAY参数效果为准
DAY | 白天效果 如果同时存在DARK以DAY参数效果为准
SAYLEVEL(等级) | 可限制当前地图人物说话等级.
DELDROPITEM | 人物(英雄)死亡后掉落的身上物品立即消失(不掉落在地图中).
REVIVAL(X/N) | 当前地图人物可复活的次数,X表示复活次数(X设置0为禁止复活),N表示人物在当前地图已经复活次数的自动清零间隔(最小30秒).具体表示:设定多少秒内允许复活次数,达到指定时间后重新计数.
NODROPUSEITEMS | 当前地图人物死亡不掉落身上的物品
NOSAFEPOSITIONMOVE | 禁止在当前地图安全区中使用传送戒指
NOALLOWUSEITEMS | 不允许使用物品NOALLOWUSEITEMS(回城卷,随机传送卷)
NOSWITCHATTACKMODE | 地图中禁止切换攻击模式
NOHEROPROTECT | 禁止英雄守护
KILLMON | 杀死怪物时触发,对应地图参数中需要加入ONKILLMON才可生效!
NOTSTONE | 当前地图魔血石、气血石、幻魔石无效!
DIETIME(10) | 当前地图人物死亡多长时间后自动掉线,DIETIME(时间秒),加入此项后,M2上的时间设置对当前地图无效!
NOCHALLENGE | 当前地图禁止挑战
NOTHROWITEM | 禁止丢物品(连金币都不可以)!
SLAVENOTATTACKHUMAN | 宝宝不攻击人物
SLAVENOTATTACKHERO | 宝宝不攻击英雄
FB(40,祖玛副本,0,1) | FB(40,祖玛副本,0,1)创建40个祖玛副本地图 第3个参数：0:限制队友必须有三职业; 1:不限制职业，队友都可进; 2:只允许自己进入; 3:允许行会进入 第4个参数：副本创建1分钟后(未收回时)，允许延时进入副本时间(分)系统默认时间为1分钟.此参数为在1分钟时间基础上延长多少分,第5个参数默认留空，表示当角色退出副本地图后删除副本时间，留空默认10秒
NoDeal | 禁止交易
NoShop | 禁止使用商铺
DROPITEMADDUSERBAG(破魂|降魔) | 怪物死亡掉落物品直接进入玩家背包,多件物品使用 | 隔开
NOSWITCHATTACKMODE(1) | 锁定攻击模式1-8（0或无括号表示不锁定）
SHOWNATIONCOLOR(1) | 强制显示国家颜色（游戏参数——》状态控制 中设置名字颜色）SHOWNATIONCOLOR(1)不含怪物,去掉(1)则包含怪物


点击小地图自动寻路[!]

增加点击小地图自动寻路功能(可以在M2关闭或开启该功能，使用小地图按键或M键打开)

寻路QF触发
[@FindPathBegin] 开始
[@FindPathStop] 中断
[@FindPathEnd] 到达


叠加功能[!]

功能：多个物品放到一格
格式：无
说明：物品重叠功能不能使用在拥有持久、属性、品质、纯度等物品上。StdMode等于 0, 2, 3, 40, 41, 42,46
例：

物品重叠功能，StdItem.DB 中OverLap=1或2或3 表示可以重叠 0不叠加
OverLap=1 重量=重叠数量*单物品重量/10
OverLap=2 重量=重叠数量*单物品重量
OverLap=3 重量=无论叠加多少物品，重量为单物品重量

收回物品 take 1 数字自己看着办喽

检测多少个 查看持久即可

DuraMax字段表示可以叠加的数量 必须大于1.例如：DuraMax=100表示可以叠加100个


顶戴花翎功能[!]

功能：顶戴花翎功能
格式：SetIcon 位置(0-9) WIL文件序号 图片序号(0-65535) X(为空时默认X=0) Y(为空时默认Y=0) 播放张数(为空时默认张数=1) 播放效果(0普通 1特效) 播放顺序(0或空：在角色前面；非0：在角色后面) 播放速度(为空默认为300) 是否仅自己可见(0或空: 所有人可见; 1:仅自己可见)
说明：无
例：

MerChant.txt中的NPC
盟重土城/流浪汉 3 346 334 流浪汉 0 3 0

流浪汉的顶戴花翎会读取 Envir\NpcIcons\盟重土城\流浪汉-3.txt

Envir\NpcIcons\盟重土城\流浪汉-3.txt 格式如下:
;WIL文件序号 图片序号(0-65535) 播放张数 X Y 播放效果(0普通 1特效) 播放顺序(0或空：在角色前面；非0：在NPC后面) 播放速度(为空默认为300)
;最多不超过十行
3 1 5 0 -30 0 0 300

怪物的顶戴花翎如下:
白野猪的顶戴花翎会读取 Envir\MonIcons\白野猪.txt

Envir\MonIcons\白野猪.txt 格式如下和NPC的顶戴花翎格式是一样的:
;WIL文件序号 图片序号(0-65535) 播放张数 X Y 播放效果(0普通 1特效) 播放顺序(0或空：在角色前面；非0：在角色后面) 播放速度(为空默认为300)
;最多不超过十行
3 1 5 0 -30 0 0 300

备注：Npc_Def文件夹内的管理NPC 直接放置在NpcIcons文件夹根目录即可

#####################################################################################
人物顶戴：

[@main]
#ACT
SETICON 0 3 1 30 -30 0 0 0 300
SETICON 1 3 2 -30 -30
SETICON 2 3 3 -60 -30 3
SETICON 3 3 7

注：扩展的播放顺序和播放速度方便大家给人物做一些特效。。。以上为基本列子，大家自行按照格式添加需要的特效！

;如果要清除，WIL文件序号设置为-1即可
[@main]
SETICON 0 -1
SETICON 1 -1
SETICON 2 -1

英雄顶戴：H.SETICON


斗笠功能设置[!]

斗笠相关数据

功能：斗笠相关数据
格式：无
说明：NODROPUSEITEMS禁止在当前地图安全区中使用传送戒指、NOSAFEPOSITIONMOVE当前地图人物死亡不掉落身上的物品
例：

StdMode = 16
Anicount 0-人物和英雄可佩戴 1-人物佩戴 2-英雄佩戴
Shape 0~9 共10种斗笠,值为-1的时候不显示斗笠外观，直接显示发型
需要显示神秘人在引擎-功能设置-其他设置选择（GM权限无效）.
面巾： Shape 值为1000时面巾可与头盔一起显示,设置0则只显示面巾

神秘人显示可以在M2中设置-功能设置-其他设置

436;斗笠1;16;0;1;4;0;0;1188;6000;0;1;0;0;0;0;0;0;0;0;0;44;5000;5;255;0;
437;斗笠2;16;1;1;4;0;0;1587;6000;0;0;0;1;0;0;0;0;0;0;0;44;5000;5;255;0;
438;斗笠3;16;2;1;4;0;0;2080;6000;0;0;0;0;0;1;0;0;0;0;0;44;5000;5;255;0;
439;斗笠4;16;3;1;4;0;0;2081;6000;0;0;0;0;0;0;0;1;0;0;0;44;5000;5;255;0;
440;斗笠5;16;4;1;4;0;0;2422;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;
441;斗笠6;16;5;1;4;0;0;2522;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;
442;斗笠7;16;6;1;4;0;0;2768;6000;0;0;0;0;0;0;0;0;0;1;0;44;5000;5;255;0;
443;斗笠8;16;7;1;4;0;0;3356;6000;0;1;0;0;0;1;0;0;0;0;0;44;10000;5;255;0;
444;斗笠9;16;8;1;4;0;0;3356;6000;0;1;0;0;0;1;0;0;0;0;0;44;10000;5;255;0;
445;斗笠10;16;9;1;4;0;0;3356;6000;0;1;0;0;0;1;0;0;0;0;0;44;10000;5;255;0;
446;面巾;16;1000;1;4;0;0;2517;6000;0;1;0;0;0;1;0;0;0;0;0;44;10000;5;255;0;

扩展斗笠：stdmode = 16
Shape（8 - 19):Hair3.wzl
Shape（20 - 29): Hair4.wzl
Shape（30 - 39): Hair5.wzl
Shape（40 - 49): Hair6.wzl
Shape（50 - 99): Hair7.wzl
Shape（100 - 149): Hair8.wzl
Shape（150 - 155): Hair9.wzl

物品位置:

0 盔甲
1 武器
2 照明物
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 右戒指
9 护身符
10 腰带
11 鞋子
12 宝石
13 斗笠


对捡取的物品进行关联

对捡取的物品进行关联 LINKPICKUPITEM

刷新关联物品UpdateItem

[@PickUpItems10]
#IF
#ACT
LINKPICKUPITEM
;关联后就可以使用其他脚本命令对刚刚捡取的物品进行检测，或操作
;修改该物品的名称颜色
CHANGEITEMNAMECOLOR -1 253
;修改物品星星数量
CHANGEITEMUPGRADECOUNT -1 + 1
;修改后的参数，刷新到客户端
UpdateItem -1
break

位置：
-1升级框
0--29：装备栏和时装栏
30-35：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框

说明：linkpickupitem和linkgiveitem都是绑定对象到升级框，调整属性后刷新-1位置即可！


多级脚本使用[!]

功能：多级脚本使用
格式：无
说明：本功能的实现突破执行脚本的唯一性，使脚本的使用更加灵活多变，使用方法为 任意人物名称.任意脚本命令。以下所使用的翎风网络名称等全部支持变量操作

H. 表示是英雄

O. 表示是主人

M. 表示是怪物(当前攻击目标)

P. 表示是对面的角色

L. 表示是当前攻击自己角色

英雄多级：HM. HL. 和M. L.一样，区别是英雄使用HM. HL.

PET. 表示宠物（单个宠物时可用）

BB. 表示宝宝 (当存在多个宝宝时，随机取一个宝宝执行，注意，BB.仅支持执行命令，不支持检测命令)

CO. 采集类怪物

例：

例如：
#if
翎风网络.Check [100] 1
check [100] 1
#act
翎风网络的变量值100为1
你自己的变量值100也为1

下面列举几种常用的使用方法，以下方法同样可以用在#ACT命令中

例如
#if
翎风网络.CheckLevel 51
CheckLevel 51
#act
翎风网络.GameGold + 10
GameGold + 10
#say
翎风网络的等级在50级以上，给予10元宝奖励
你的等级也在50级以上，给予10元宝奖励

上面脚本，如果翎风网络不在线，M2会提示出错，但脚本会继续执行并跳过该句做为无效检测处理
当做为无效检测处理后，只要翎风引擎等级和自己的等级在50级以上，既执行#say和#act段，
并且，翎风网络.GameGold + 10 该句也无法执行，被跳过，继续执行下面的
所以在使用多级的时候请注意脚本的使用

#if
H.CheckLevelEx > 1
#say
你的英雄大于1级

#if
P.CheckLevelEx > 1
#say
你的对面的角色大于1级

;怪物操作，一般用在攻击触发里
#if
#act
M.HumanHP + 100


分身攻击触发

 分身攻击触发：

@CloneStruck：人物分身被物理攻击
@CloneMagicStruck：人物分身被魔法攻击
@CloneAttack：人物分身物理攻击别人
@CloneMagicAttack：人物分身魔法攻击别人

@HeroCloneStruck：英雄分身被物理攻击
@HeroCloneMagicStruck：英雄分身被魔法攻击
@HeroCloneAttack：英雄分身物理攻击别人
@HeroCloneMagicAttack：英雄分身魔法攻击别人

QFunction-0

;所有触发只有攻击到目标才会触发，有些魔法不会触发，如魔法盾

分身相关触发：

@GamePetKillClone ;//分身杀死怪物触发 ------对应@GamePetKillMon
@OnKillCloneMob (对应@OnKillCloneMob)
@OnCloneDie ;//人物分身死亡触发
@OnHeroCloneDie ;//英雄分身死亡触发


改变怪物脸型、改变怪物外观、改变怪物appr、修改怪物脸型、修改怪物外观、修改怪物appr

格式: ChangeMapMonAppr 地图名 X坐标 Y坐标 范围(为3时表示3*3) 怪物名(*不判断) Appr 有效时间(分钟)
备注：当X,Y,范围均为0时，表示地图所有范围；此命令仅对怪物操作，要对宝宝或分身操作，可使用ChangeSlaveAppr

示范：

#if
#act
ChangeMapMonAppr 3 0 0 0 羊 161 1
sendmsg 5 你已经将盟重地图中的所有羊显示成鹿外观，有效时间1分钟

------------------------------------------


改变用户模式 改变人物模式 石化或冰冻 中毒效果 蛛网效果,人物状态，禁锢，吸血,ChangeState

NPC命令增加石化或冰冻 中毒效果 蛛网效果 禁锢 吸血

说明：ChangeState 参数1 参数2 参数3 参数4 参数5 参数6 参数7 参数8

命令格式：ChangeState 效果 时间

格式：
参数1 效果
参数2 时间
参数3 几率、伤害值（不同效果用途不同）
参数4 间隔、百分比（不同效果用途不同）
参数5 WIL序号
参数6 开始图片
参数7 播放张数
参数8 播放速度
参数9 是否透明绘制(0或空或1)
参数10 聊天框是否提示（如麻痹、冰冻、蛛网）

[@Test]
#IF
#ACT
ChangeState 3 30
#SAY
你被蜘蛛网罩了，30秒内无法跑步.

[@Test1]
#IF
#ACT
H.ChangeState 3 30
#SAY
你的英雄被蜘蛛网罩了，30秒内无法跑步.

效果代码：1.石化 2.冰冻 3.蛛网效果 4.红毒 5.绿毒 6.定身 7.瘫痪 8.禁锢别人 9.防禁锢 10.吸血 11.吸蓝 12.禁锢自己 13.间隔掉血（类似绿毒) 14.禁止使用技能

//8 禁锢(释放一个类似困魔咒的光圈，敌对人物或怪物只能在这个圈子里移动，无法走出圈子外面，所有传送失效，不能小退)
//9 防禁锢
//10 吸血
//11 吸蓝

例子：

#ACT
ChangeState 8 10 3
SENDMSG 6 你周围的目标被禁锢10秒，禁锢期间可移动范围3X3

CHANGESTATE 9 10
SENDMSG 6 10秒内可以防禁锢

CHANGESTATE 10 10 100 50
SENDMSG 6 10秒内攻击目标，可以吸血，吸血机率100(数字越大机率越高 100表示每次都会吸血)，吸血百分比50%(比如攻击伤害值是10000，50%的吸血比例，可以吸血5000)

CHANGESTATE 11 10 100 50
SENDMSG 6 10秒内攻击目标，可以吸蓝，吸蓝机率100(数字越大机率越高 100表示每次都会吸蓝)，吸蓝百分比50%(比如攻击伤害值是10000，50%的吸蓝比例，可以吸蓝5000)

ChangeState 12 10 3
SENDMSG 6 你被禁锢10秒，禁锢期间可移动范围3X3

ChangeState 12 0 3
SENDMSG 6 禁锢范围3以内的禁锢被解除。
注意：如果范围设置20则解除禁止自己范围在20以内的所有禁锢，请不要设置太大，比如你游戏最大禁锢范围6，那么你解除最大7，不要设置50或更大，越大需要检索的地图范围越大越占资源
另外解除自己禁锢同样可解除代码8别人禁锢自己，当自己被别人使用代码8禁锢，也可使用代码12来解除

-------------------------------------2021-11-09扩展示范及说明--------------------------------------------------------------------

代码13和中绿毒效果一样，间隔多少时间掉一次血
例子：
#ACT
ChangeState 13 60 10 5
;ChangeState 13 60 10 5 0 1660 6 200 ;带特效
SENDMSG 6 你流血了,间隔5秒损失10点生命值.持续60秒

代码14 禁止使用技能（快捷键的技能不让使用）
#ACT
ChangeState 14 30
SENDMSG 6 你被禁封了,30秒内无法使用任何技能.

-------------------------------------2019-05-21扩展--------------------------------------------------------------------

扩展增加参数5、6、7、8用于执行目标播放特效，留空则不启用：
参数5 WIL序号
参数6 开始图片
参数7 播放张数
参数8 播放速度
参数9 是否透明绘制(0或空或1)
参数10 聊天框是否提示（如麻痹、冰冻、蛛网）

示例：
CHANGESTATE 11 10 100 50 0 1660 6 200

SENDMSG 6 10秒内攻击目标，可以吸蓝，吸蓝机率100(数字越大机率越高 100表示每次都会吸蓝)，吸蓝百分比50%(比如攻击伤害值是10000，50%的吸蓝比例，可以吸蓝5000)
---------------------------------------------------------------------------------------------------------

#########################以下为2016-11-08扩展#########################
当效果为1-5时，参数3表示是否检查对应的防止属性（0：不检查；1：检查）
当效果为8时，参数3表示范围
当效果为10-11时，参数3表示吸血、吸蓝成功几率（%）， 参数4表示吸血吸蓝比例（%）
例子：

#ACT
CHANGESTATE 1 10 1
SENDMSG 6 麻痹时间有效时间10秒，注意：佩戴防御麻痹的人物有几率躲过麻痹！

#ACT
CHANGESTATE 5 10 1
SENDMSG 6 绿毒时间10秒，注意：佩戴有防毒属性的装备按照几率躲避毒物！

#ACT
CHANGESTATE 2 10 0
SENDMSG 6 冰冻时间10秒，无视佩戴有防冰冻属性角色！

##################################################

状态说明

6、定身 无法跑动、走动，可以攻击、施法
7、瘫痪 无法攻击、施法、跑动、走动，被攻击立即解除瘫痪状态

注意：以上所有状态支持通过重置时间为0来解除状态，比如：

changestate 1 10 ;麻痹10秒
changestate 1 0 ;解除麻痹

备注：此命令支持多级脚本！


根据物品数据库idx直接得到物品

说明: 根据物品数据库idx直接得到物品

格式: giveidx idx编号 数量

#ACT
giveidx 10 1
SENDMSG 6 恭喜你获得IDX序号为10的物品。
Break


购买摆摊物品后触发、摆摊触发

功能说明：摆摊物品购买后触发

;例子

[@HeroM2BuyUserItem]
#act
sendmsg 6 你购买了<$CurUserName>出售de摆摊物品<$CURITEMNAME>(<$G_CURITEMNAME>),ID:<$CurItemMakeIndex>交易金额: <$CurItemPrices>,货币类型（文字）:<$CurItemMoneyType>,货币类型值:<$CurItemMoneyTypeValue>

<$CurItemMoneyTypeValue> 货币类型值（0:元宝 1:游戏点 2:金币 3:金刚石 4:灵符）


怪物爆率支持变量

传统：
1/100 金币 100

支持变量：

<$STR(I1)> /<$STR(I5)> 金币 100


怪物大血条

 设置指定怪物大血条显示，注意怪物只有被自己攻击才会显示，血条也是自己可见，超过3秒没有被攻击将自动关闭，血条为固定在屏幕指定坐标！！！

说明：
D:\Mirserver\Mir200\Envir\MonHPProgress.txt 设置怪物血条

00749~00759 10张图片用于显示数量，749为x，750-769为0-9 十张数字图片
00760~00769 10张怪物自定义大血条背景 ， 设置参数为0-9
00770~00779 10张怪物自定义大血条的血条 ，设置参数为0-9
00780~00879 100张怪物自定义大血血条的怪物肖像，设置参数为0-99

示范：

;怪物名称 背景编号 背景偏移X 背景偏移Y 图像编号 图像偏移X 图像偏移Y 血条编号 血条偏移X 血条偏移Y 显示等级(-1~255) 等级偏移X 等级偏移Y 怪物显名(-1~255) 名字偏移X 名字偏移Y 显示血值(-1~255) 血值偏移X 血值偏移Y 显示血量百分比(-1~255) 百分比偏移X 百分比偏移Y 显示怪物归属(-1~255) 归属偏移X 归属偏移Y 水平对齐(0:左;1:中;2:右) 血管数量 血管数量偏移X 血管数量偏移Y
(洪荒)远古骑士·[世界BOSS] 0 350 50 4 50 18 0 98 49 243 115 28 253 165 28 -1 150 51 254 200 51 -1 150 51 0 10 280 45

文本内参数设置-1表示关闭，比如肖像设置-1 就是不显示肖像！设置0-255为启用，也代表文字颜色！

注意启用血管数量后，在NewopUI.Pak文件中编号749-759为显示血管数量图片有X和0-9图片组成，另外770-779必须10张血管，如果无素材可以将默认素材重复导入填满这10张图

血管数量：当怪物HP为1000点血，设置20条血管则每条血管50点HP，血管会循环读取编号770-779！！！！当前HP为当前血管的HP，百分比为总HP，按需是否需要显示！

如不需使用血管数量请留空则为传统血条（单血管 显示总HP）

参数提示：水平对齐(0:左;1:中;2:右)。要看对齐效果，X偏移为0


怪物名称颜色自定义功能[!]

增加怪物名称颜色自定义功能

MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家名字 是否攻击同国家的玩家 不同国家名称的怪物PK 能否被同国家的人物攻击 @脚本触发
说明：最后一个参数为0时表示同国家玩家不能攻击该怪物，为其他数值时在非国家攻击模式下可以攻击该怪物
内功怪物参数为0时不会获得内容经验，为其他数值时则为壳获得内容经验的怪物
集中刷新坐标机率（0--100)；数字越小，怪物集中几率越高

3 380 290 羊 60 10 7 100 249 0 0 0 0 0 @刷怪触发

QFunction-0.txt

[@刷怪触发]
#ACT
SENDMSG 0 羊出现在土城


怪物伤害封顶[!]

增加怪物伤害封顶，封顶数值等于怪物BD中的MP数值，若DB中怪物MP值=0则不计算伤害封顶


怪物属性扩展[!]

增加怪物属性扩展：Envir\MonSpAbilList.txt(如不知道格式可删除此文档让引擎自动生成一个MonSpAbilList.txt)

格式：怪物名 忽视防御(0~100) 增加伤害(0~255) 伤害反弹(0~100) 物伤减少(0~100) 魔伤减少(0~100) 麻痹-几率-时间(0~1 0~10 0~10) 防麻痹(0~100) 防全毒(0~100) 防火墙(0~100) 防诱惑(0~100) 破复活(0~100) 破护身(0~100) 冰冻-几率-时间(0~1 0~10 0~10) 防冰冻(0~100) 蛛网-几率-时间(0~1 0~10 0~10) 防蛛网(0~100) 暴击抗性(0~1000) 攻击伤害抗性(0~1000)

白野猪 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 100 100

;白野猪 暴击抗性100% 攻击伤害抗性100%

暴击抗性(人物暴击几率 - 暴击抗性 = 人物暴击打出几率) 1~1000%

攻击伤害抗性(攻击伤害增加 - 攻击伤害抗性 = 人物攻击伤害打出) 1~1000%

特别说明：自定义怪物有无视防御选项，启用了自定义怪物的无视防御则本规则第一条不生效，不启用则生效会计算本规则中忽视防御几率！

*2025-07-01将以下参数从原必防修改为几率性防御

// 防麻痹
// 防毒
// 防火墙
// 防诱惑
// 防复活
// 防护身
// 防冰冻
// 防蛛网
这几个字段调整为0-100，0表示不防御，100%表示必防 （原来参数：0不防御，1必防御，现在修改为几率性防御，需要必防请将原来设置的1改为100）


怪物说话配置[!]

功能：怪物说话配置
格式：无
说明：配置文件位置Mir200\Envir\MonSayMsg.txt
例：

;状态(0为杀人，1为被攻击，2为死亡，3为刚刷出来) 刚刷出来发的文字为广播文字全服务器都可以看到。
;机率(数字越大，说话机率越小)
;颜色(0为红色，1为绿色，2为蓝色，3为白色) 白色文字，显示在怪物头顶上所有旁边的人都可以看到，其它颜色则显示在人物聊到框中只有对应的人物可以看到。

;状态 机率 颜色 怪物名称 文字内容

1 30 0 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 1 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 2 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 3 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 4 鹿 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 稻草人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 森林雪人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 半兽人 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 30 0 半兽战士 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 0 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 0 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 1 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 2 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 3 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
1 50 4 白野猪0 %s不要打我，%d我没东西爆的！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标

2 30 1 鹿 %s不要打我，%d我挂了！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 0 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 1 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 2 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 3 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标
0 50 4 白野猪0 %s哈哈，死了吧%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标

3 1 4 白野猪0 %s老猪来也%d！！！！ 支持%m 地图名称 %x=X坐标 %yY坐标


怪物探索设置说明[!]

人形怪物设置说明

1、在Envir目录下增加MonUseItems目录，放置怪的配置文件，见MonUseItems目录

2、Monster.DB范例：
战士;150;19;0;198;0;100;5000;0;10;10;0;0;0;0;88;45;450;1;0;450;5000;
法师;150;19;0;198;0;100;5000;0;10;10;0;0;0;0;88;45;750;1;0;750;5000;
道士;150;19;0;198;0;100;5000;0;10;10;0;0;0;0;88;45;750;1;0;750;5000;

3、此类怪物支持暴背包物品(MonItems目录下建立暴物品列表)，同时支持暴身上物品(MonUseItems目录，见MonUseItems目录)

4、挖取列表文本，该文本放在MonUseItems目录下，命名规则为 怪物名称-Item.txt
挖取列表文本的设置方法，跟设置普通怪物的爆率一样 ,如需怪死后爆物品,直接加爆率文件

可以挖身上装备,也可以挖取列表中的物品,也可以爆物品,也可以掉装备

怪死后,按CTRL+右键,可以查看怪的装备

5.如怪挖取列表物品被挖取完后,可以触发脚本给物品,实现无限挖取(进入脚本段,一样会收费)

触发脚本段QFunction-0.txt文件
[@ButchCloneItem]
#if
random 5
#act
CreditPoint + 3
sendmsg 7 恭喜：你获得了：声望值:3
break
#if
random 4
#act
GIVE 铁剑 1
sendmsg 7 恭喜：你获得了：铁剑:1
break
#if
random 4
#act
GAMEDIAMOND + 30
sendmsg 7 恭喜：你获得了：金刚石:30

---------------------------------------------------------------
卧龙战将.txt
;=============================人形宝宝配制文件(以M2怪物设置中为准！)=======================
[Info]
;是不是掉装备，1=掉，0=不掉
DropUseItem=0
;掉装备几率
DropUseItemRate=15

;职业
Job=0
;性别
Gender=0
;头发
Hair=5

;守护状态，1=守护，0=不守护
ProtectStatus=1

;使用魔法
UseSkill=

;是否允许挖取身上装备1=是，0=否
ButchUseItem=1

;人形怪挖是否进入触发，1=进，0=不进
ButchCloneItem=1

;挖取身上装备机率0为百分百，数字越大，机率越小
;请注意，就算这里设置为0也不一定就百分百成功，因为系统还要随机取人型怪身上装备位置，所以如果取到的位置没有装备也会失败
ButchRate=10

;挖取身上装备收费模式(0金币，1元宝，2金刚石，3灵符)
ButchChargeClass=3

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=雷霆战甲(男)
;武器
UseItems1=天之屠龙
;照明物
UseItems2=荣誉勋章53号
;项链
UseItems3=强化雷霆项链
;头盔
UseItems4=圣龙盔
;左手镯
UseItems5=强化雷霆护腕
;右手镯
UseItems6=强化雷霆护腕
;左戒指
UseItems7=强化雷霆战戒
;右戒指
UseItems8=强化雷霆战戒
;物品
UseItems9=
;腰带
UseItems10=强化雷霆腰带
;鞋子
UseItems11=强化雷霆战靴
;宝石
UseItems12=
;斗笠
UseItems13=

卧龙战将-Item.txt
1/1 祝福油
1/2 强效魔法药
1/2 强效魔法药
1/2 强效魔法药
1/2 强效魔法药
1/2 强效魔法药
1/2 强效魔法药
1/2 强效金创药
1/2 强效金创药
1/2 强效金创药
1/2 强效金创药
1/2 强效金创药

如果觉得人形怪气血石恢复间隔慢 或移动之类的比设置参数慢，因人形怪比普通的怪物更占用资源，在M2上将运行间隔调小即可解决上面的问题


韩国地图,韩国传奇2

韩国地图（传奇2）支持说明

服务器端：
地图放在 map\

客户端：

MAP文件放入客户端MAP文件夹内，其余DATA目录（smTiles.wzl,Tiles.wzl,Objects.wzl）中的素材全部放入自定义客户端文件夹中的Hmapdata内

如果要使用韩国2地图必须使用可以打开韩国传奇2原始客户端的编辑器导出素材，然后wzl编辑器创建同名WZL文件并导入素材即可(wzl编辑器可直接打开的可不转换)！

注：如果地图MAP文件名字冲突，又要共存，处理方式：比如土城3.MAP ，又想使用韩国2的3.MAP，那么将韩国2的3.MAP改任意名字，如：H_3.MAP。然后将 H_3.MAP分别复制到服务端和客户端的MAP文件夹内，其余素材按照以上说明操作即可！


韩国地图,韩国传奇3

韩国地图（传奇3）支持说明

服务器端：
地图放在 map\

客户端：
地图放在map\
地图资源放在：Resources\Mir3MapData (仅支持pak格式，必须使用默认密码，创建PAK时密码留空即可）


火龙神殿[!]

NPC相关命令：
功能：关闭客户端'!'图标显示
格式：CLOSEMSGWINDOWS

格式：MESSAGEBOX 消息内容 QF触发段 QF触发段
例： MESSAGEBOX 使用10元宝，便可在当前地图内原位\置复活？ @确认 @取消
说明：在客户端显示一个提示框，点确定时，触发QFunction-0.txt的 @确认 代码
点取消时，触发QFunction-0.txt的 @取消 代码

物品ID
774;火龙凭证;41;0;1;0;0;0;269;0;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;;0;

MonGen.txt
;地图名：火龙殿
D2083 82 44 火龙教主 0 1 30
D2083 65 48 恶魔蝙蝠 10 10 30
D2083 81 62 恶魔蝙蝠 10 10 30
D2083 66 62 恶魔蝙蝠 10 10 30
D2083 51 75 恶魔蝙蝠 10 10 30

火龙守护兽设置说明
Mir200\Envir\FireDragonGuard.txt (手动创建FireDragonGuard.txt 或开启引擎自动生成)设置方法

;名称 地图 x y dir(0-1) 攻击坐标x 攻击坐标Y(可以为多个以|分隔)
;----------------------------------
火龙守护兽 D2083 51,67 1 77,50|74,50|83,50|80,53|86,53|74,41|71,41|71,44|71,47
火龙守护兽 D2083 48,70 1 81,44|81,47|78,44|75,44|84,47|78,41|75,41|81,50|84,50
火龙守护兽 D2083 45,73 1 81,44|84,47|78,41|85,50|75,41|76,51|79,54|73,48
火龙守护兽 D2083 61,78 0 79,48|79,51|76,48|78,53|75,50|76,45|82,51|81,44|84,47|78,41
火龙守护兽 D2083 58,81 0 79,48|82,51|85,54|76,45|71,40|82,48|79,45|76,42|85,51|73,42
火龙守护兽 D2083 55,84 0 80,48|77,48|80,45|77,51|74,51|74,54|71,54|71,57

注：火龙守护兽不用MonGen.txt刷，如果用其它方式刷出来，无攻击效果及发亮效果(怪物血量以及一些其他配置请自行修改)

灵魂收割者;81;19;240;100;1;1000;20000;20000;0;12;12;280;300;0;0;17;15;900;1;0;2000;
蓝影刀客;81;19;241;100;1;1000;20000;20000;0;12;12;280;300;0;0;17;15;900;1;0;2000;
恶魔蝙蝠;146;19;80;999;0;1000;2000;400;0;1000;1000;40;45;0;0;17;15;900;1;0;2000
火龙教主;144;83;800;200;1;0;10000;12000;0;70;100;120;170;0;0;25;30;0;1;0;1500
火龙守护兽;145;95;802;999;1;1000;0;18000;0;30;30;40;45;0;0;17;15;900;1;0;2000


获取地图人数命令

 功能说明：获取地图人数

格式：GetMapHumCount 地图编号 是否包含假人(0不包含假人/1包含假人) 返回变量

;例子
[@main]
#ACT
GetMapHumCount 3 1 N1
Sendmsg 7 当前土城有<$STR(N1)>人

如：<$STR(N1)>无法获取地图号N开头的地图，那么可以将常量更换为：<$const(n1)>


获取地图上分身数量

功能说明：获取地图上分身数量

GetMapHumCloneCount 地图名 X坐标 Y坐标 范围(为3时表示3*3) 变量
备注：当X,Y,范围均为0时，表示地图所有范围

示范：

#if
#act
GetMapHumCloneCount 3 0 0 0 N1
sendmsg 5 你已经将盟重地图中共有分身<$STR(N1)>个

如：<$STR(N1)>无法获取地图号N开头的地图，那么可以将常量更换为：<$const(n1)> ------------------------------------------


获取对象的属性、获取属性

 功能说明：获取对象的全体属性、获取怪物属性 （目标M.GetObjectAbilityEx）

格式：GetObjectAbilityEx 属性类型 变量

属性类型如下：
0: HP
1: MaxHP
2: MP
3: MaxMP
4: AC1
5: AC2
6: MAC1
7: MAC2
8: DC1
9: DC2
10: MC1
11: MC2
12: SC1
13: SC2
14: 攻击速度
15: 移动速度

#ACT
FS.GetObjectAbilityEx 0 N1
SendMsg 6 分身的血量为<$STR(N1)>

FS.M.GetObjectAbilityEx 0 N2
SendMsg 6 分身攻击目标的血量为<$STR(N2)>

M.GetObjectAbilityEx 0 N2
SendMsg 6 攻击目标的血量为<$STR(N2)>

对人物需变量传递：

#IF
CHECKCURRTARGETRACE = 0
#ACT
M.GetObjectAbilityEx 0 N1
GetHumVar <$CURRRTARGETNAME> <$STR(N1)> N1
SendMsg 6 目标人物的血量为<$STR(N1)>
SENDMSG 6 你攻击了人物【<$CURRRTARGETNAME>】。使用魔法ID=<$CURRRUSEMAGICID> 255 249
BREAK


获取角色背包信息

功能: 获取角色背包信息

获取角色背包信息 格式:GetBagInfo 参数1 参数2(保存变量) 参数3(stdmode值)

参数1：信息类型可取如下值：
ItemCount: 物品数量(每个背包物品都算一个数量，不管是否为叠加物品)
ItemMakeIndex:所有背包物品的MakeIndex；参数2即保存变量必须为元素类型
ItemIdx:所有背包物品的数据库idx；参数2即保存变量必须为元素类型
ItemName:所有背包物品的名称；参数2即保存变量必须为元素类型
参数3(stdmode值)：留空为获取背包所有物品数量，填写5只获取stdmode值为5的武器数量，可以 5|6|10|11 只取背包武器衣服

获取背包物品的字段值 格式:GetBagItemFieldValue 参数1 参数2 字段名称 保存变量

参数1: 可取如下值
0: 根据背包物品序号取物品（即取背包第几个物品），参数2就是序号（从0开始）
1: 根据背包物品的MakeIndex取物品，参数2就是MakeIndex
将对应的物品字段保存到变量中

--------------------------------------------------------

示例脚本：

;取背包物品数量保存到变量
#act
GetBagInfo ItemCount N100
SendMsg 6 背包物品数量为<$STR(N100)>

Mov N1 0
GetBagInfo ItemCount N100
WHILE N1 < <$STR(N100)>
Mov S1
Mov S2
; 第一个参数: (0根据顺序号/1根据MakeIndex)；参数2：表示取第几个；参数3：字段名称；参数4：
GetBagItemFieldValue 0 <$STR(N1)> name S1
GetBagItemFieldValue 0 <$STR(N1)> upgradecount S2
Sendmsg 6 提示：第<$STR(N1)>件,物品名称=<$STR(S1)>,星星数=<$STR(S2)>
INC N1 1
ENDWHILE

;取背包所有物品的MakeIndex保存到元素变量中
GetBagInfo ItemMakeIndex L$背包物品
SendMsg 6 背包物品MakeIndex:<$STR(L$背包物品)>

;根据MakeIndex取得对应背包物品的字段值并保存到变量中
GetBagItemFieldValue 1 <$STR(L$背包物品[0])> name S1
Sendmsg 6 提示：第0件,物品名称=<$STR(S1)>;MakeIndex=<$STR(L$背包物品[0])>

;取背包所有物品的数据库Idx保存到元素变量中
GetBagInfo ItemIdx L$背包物品
SendMsg 6 背包物品数据库Idx:<$STR(L$背包物品)>

;取背包所有物品名称保存到元素变量中
GetBagInfo ItemName L$背包物品
SendMsg 6 背包物品名称:<$STR(L$背包物品)>

示例脚本2：

<获取背包物品的字段值/@获取背包物品的字段值(0)> <获取背包物品的字段值index获取/@获取背包物品的字段值(1)> \

[@获取背包物品的字段值]
#IF
equal <$scriptparam1> 0
#act
GetBagItemFieldValue 0 9 NAME S$name

#IF
equal <$scriptparam1> 1
#act
GetBagItemFieldValue 1 227490 NAME S$name

#IF
#ACT
sendmsg 7 .方法<$scriptparam1>.<$STR(S$name)>


获取物品属性值

-----------------------------------获取物品属性值---------------------------

获取物品属性值

1.获取物品属性值
GetItemFieldValue 物品位置 属性名称 变量名

物品位置：支持装备位置、首饰、神佑、升级框、OK框
属性名称支持：
makeindex
dura
duramax
upgradecount
name
name_g
stdmode
shape
looks
color
hp
mp
lac
hac
lmac
hmac
ldc
hdc
lmc
hmc
lsc
hsc
idx
need
needlevel
price
element
element1
element2
element3
element4
element5
element6
element7
element8
element9
element10
element11
element12
element13
element14
element15
element16
element17
element18
element19
element20
element21
element22
element23
element24
element25
element26
expand1
expand2
expand3
expand4
expand5
InsuranceCurrency
InsuranceGold
InsuranceCount

[@元素]
#IF
#ACT
GetItemFieldValue 1 element21 N1
SendMsg 6 21的值为：<$STR(N1)>

;以上获取命令仅获取数据库原生字段值（支持自定义字段），不包含命令或附加值

--------------------------------------------------------------

以下为附加属性（非数据库字段的值）

极品属性（防御 魔法防御 攻击 魔法 道术 ....）
Value0
Value1
Value2
Value3
Value4
Value5
Value6
Value7
Value8
Value9
Value10
Value11
Value12
Value13

元素属性(非数据库）
uelement0
uelement1
uelement2
uelement3
uelement4
uelement5
uelement6
uelement7
uelement8
uelement9
uelement10
uelement11
uelement12
uelement13
uelement14
uelement15
uelement16
uelement17
uelement18
uelement19
uelement20
uelement21
uelement22
uelement23
uelement24
uelement25
uelement26


获取一组不相同的随机数

功能说明：获取一组不相同的随机数

GetMultiRandomNumber 最小值 最大值 数量(最多200) 变量(不输入括号的变量，非自定义变量，如:N1) 保存实际获取数量的变量

示范：

[@Main]
#IF
#ACT
GetMultiRandomNumber 100 1000 10 N1 M1
SENDMSG 6 获取10个不一样的随机数，范围在100到1000之间，保存在N1~N10变量里，实际获取到随机数的数量为:<$STR(M1)>
SENDMSG 6 N1=<$STR(N1)>
SENDMSG 6 N2=<$STR(N2)>
SENDMSG 6 N3=<$STR(N3)>
SENDMSG 6 N4=<$STR(N4)>
SENDMSG 6 N5=<$STR(N5)>
SENDMSG 6 N6=<$STR(N6)>
SENDMSG 6 N7=<$STR(N7)>
SENDMSG 6 N8=<$STR(N8)>
SENDMSG 6 N9=<$STR(N9)>
SENDMSG 6 N10=<$STR(N10)>

------------------------------------------


机器码使用说明[!]

<$MACHINEID> 机器码，和登录的角色无关，只要是该机器登录的角色，这个机器码就一样。

配合以下命令可以限制角色登录游戏

CheckTextList 文件位置 字符串
AddTextList 文件位置 字符串
DelTextList 文件位置 字符串


假人配置[!]

功能：假人配置
格式：无
说明：假人是和人物一样的，所有人物的命令假人都可以使用，比如可以使用加入行会的命令，把假人加入某个行会
例：

;====================================华丽的分割线====================================

增加假人登录脚本命令DUMMYLOGON。会自动登录“D:\MirServer\Mir200\Envir\DummyNameList.txt”中的假人

格式:DUMMYLOGON 地图 X Y 数量

;====================================华丽的分割线====================================

假人主体设置当前的锁定攻击目标
SetTarget 名称 人物或英雄或怪物(1:英雄，2:人物 3:怪物) 名称是否过滤数字匹配(仅适用于怪物时；0:不过滤;1：过滤数字匹配)

英雄设置当前的锁定攻击目标
假人H.SetTarget 名称 人物或英雄或怪物(1:英雄，2:人物 3:怪物) 名称是否过滤数字匹配(仅适用于怪物时；0:不过滤;1：过滤数字匹配)

;QManage.txt

;====================================人物登录触发====================================
[@Login]
#IF
;检测是否是假人
ISDUMMY
#ACT
;设置假人配置文件。 如果不设置假人配置文件，默认读取 D:\MirServer\Mir200\Envir\DummyConfig\假人名称.txt
;格式 SETDUMMYCONFIGFILENAME 文件路径
SETDUMMYCONFIGFILENAME ..\QuestDiary\智能陪练\一级女法陪练.txt

;读取假人配置文件，将配置文件中的参数读取到假人，这句必须要的。
LOADDUMMYCONFIGFILE

;更改攻击模式
;攻击模式(英雄无效)
;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击
;6-红名攻击(不主动攻击，受攻击后反击)
ChangeAttatckMode 0
;--------------------------下面是英雄相关的，如果假人不召唤英雄，下面的脚本就不需要了--------------------------

;从假人列表或假人英雄列表中获取一个没有登录过的名称
;人物的 D:\MirServer\Mir200\Envir\DummyNameList.txt
;英雄的 D:\MirServer\Mir200\Envir\DummyHeroNameList.txt
;格式 GETDUMMYNAME 保存变量 列表类型(0=人物列表 1=英雄列表) 获取类型(0=顺序获取 1=随机获取)
GETDUMMYNAME <$STR(S1)> 1 1

;把获取到的英雄名称给假人，假人就可以召唤英雄了，这句必须要的，否则召唤不了英雄
;格式 SETDUMMYHERONAME 英雄名称
SETDUMMYHERONAME <$STR(S1)>

;召唤英雄
RECALLHERO
;-------------------------------------------------------------------------------------

;假人开始自动打怪，这句必须的，否则假人就站着不会动。如果就在安全区挂着，可以不要。
;对应使用的命令 DUMMYSTOP 停止自动打怪
DUMMYSTART

;====================================英雄登录触发====================================
[@HeroLogin]
#IF
;检测是否是假人英雄
H.ISDUMMY
#ACT
;设置假人配置文件。 如果不设置假人配置文件，默认读取 D:\MirServer\Mir200\Envir\DummyConfig\假人名称.txt
;格式 SETDUMMYCONFIGFILENAME 文件路径
H.SETDUMMYCONFIGFILENAME ..\QuestDiary\智能陪练\一级女法陪练.txt

;读取假人配置文件，将配置文件中的参数读取到假人英雄，这句必须要的。
H.LOADDUMMYCONFIGFILE

;====================================假人配置文件====================================
[Info]

;反击延时
CounterattackDelay = 1000

;自动捡物，1=捡，0=不捡
AutoPickUpItem=1

;攻击模式(英雄无效)
;0-全体攻击(主动攻击) 1-和平攻击(不PK) 2-夫妻攻击 3-师徒攻击 4-编组攻击 5-行会攻击
;6-红名攻击(不主动攻击，受攻击后反击)
AttatckMode=0

;说话机率(英雄无效)
SayRate=10;

;装备极品机率
ItemAddValueRate = 10;

;装备元素机率
ItemNewAddValueRate= 10;

;掉身上装备，1=掉，0=不掉
DropUseItem=0

;掉身上装备机率
DropUseItemRate=15

;掉包裹物品，1=掉，0=不掉
DropBagItem=1

;;假人走位几率（为0表示不走位攻击）
RunAttackRate = 6

;职业
Job=2

;性别
Gender=1

;头发
Hair=1

;等级
Level=60

;使用毒符物品(道士有效)
;1：身上或包裹中都不需要符或毒，就可以直接使用魔法
;2：需要身上佩戴符或毒，才可以使用魔法
;3：首先使用身上佩戴符或毒，如果身上没有佩戴，就使用包裹中的符或毒。
NeedMagicItem=1

;使用魔法
UseSkill=灵魂火符,施毒术,召唤月灵,召唤神兽,治愈术,神圣战甲术,幽灵盾

;包裹物品
BagItems=护身符,黄色药粉(大量),灰色药粉(大量)

[灵魂火符]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[施毒术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[召唤月灵]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[召唤神兽]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[治愈术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[神圣战甲术]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[幽灵盾]
;魔法等级
Level=3
;强化魔法等级
NewLevel=0

[UseItems]
;衣服
UseItems0=天师长袍
;武器
UseItems1=逍遥扇
;照明物
UseItems2=
;项链
UseItems3=天尊项链
;头盔
UseItems4=天尊头盔
;左手镯
UseItems5=天尊手镯
;右手镯
UseItems6=天尊手镯
;左戒指
UseItems7=天尊戒指
;右戒指
UseItems8=天尊戒指
;物品
UseItems9=护身符
;腰带
UseItems10=
;鞋子
UseItems11=
;宝石
UseItems12=

;攻击时的说话信息(英雄无效)
[Say]
0=没钱买装备玩什么游戏
1=装备差就不要出来混
2=垃圾装备也出来丢人现眼
3=刚花了500买的装备

;QFunction-0.txt
;使用假人开始挂机命令DummyStart触发[@DummyStart]
[@DummyStart]

;使用假人停止挂机命令DummyStop或者假人在挂机过程中移动失败，触发[@DummyStop]
[@DummyStop]

;人物的 D:\MirServer\Mir200\Envir\DummyNameList.txt
;英雄的 D:\MirServer\Mir200\Envir\DummyHeroNameList.txt
需要把这2个文件里的名称，复制到D:\MirServer\DBServer\DenyChrName.txt这样玩家就不可以注册假人的角色名

;============================================================================
功能：检查服务器假人数
格式：CHECKDUMMYCOUNT 检测符(>,<,=) 人数

;============================================================================
检查地图假人数量：

CheckMapDummyCount 地图 ('>' '<' '=') 数量

;============================================================================
增加关键字<$const(); 地图名为n3，执行下面脚本跳转不正确：

#act
VAR string global 假人_盟重省地图编号

;★★★★★★★★★★★注意下面一行，n3是一个常量，而非变量，用 <$const(n3)> 来表示常量
calcvar global 假人_盟重省地图编号 = <$const(n3)>
SendMsg 0 <$global(假人_盟重省地图编号)>
map <$global(假人_盟重省地图编号)>

;============================================================================


捡起丢弃物品ID序列号

-----------------------------------获取捡起丢弃物品ID序列号---------------------------

获取捡起丢弃物品ID序列号

变量：<$PickDropItemMakeIndex>

[@PickUpItemEx]
#act
SENDMSG 0 物品ID:<$PickDropItemMakeIndex>


检测使用的物品来源于哪个背包

 功能说明：检测使用的物品来源于哪个背包（仅限双击使用能触发QF的物品，比如31类）

变量：<$UseItemFrom>，值为0对应人物背包，1:英雄背包; 2：宠物背包

-----------------------------------------------------------------------------

[@StdModeFunc10]
#if
equal <$UseItemFrom> 0
#act
humanhp + 100
sendmsg 6 你使用【<$UseItemFrom>】增加了100血
break
#if
equal <$UseItemFrom> 1
#act
H.humanhp + 100
sendmsg 6 你使用【<$UseItemFrom>】英雄增加了100血
break
#if
equal <$UseItemFrom> 2
#act
PET.humanhp + 100
sendmsg 6 你使用【<$UseItemFrom>】宠物增加了100血
break


角色打怪爆出物品直接入包，角色打怪爆出物品直接入包[!]

功能：角色打怪爆出物品直接入包，角色打怪爆出物品直接入包

命令：

启用人物杀怪入包,默认按查看----列表信息1捡取列表和优先捡取列表进行捡物，如需按照内挂配置进行捡物，需要开选项开启或命令开启
人物捡物同步内挂配置/英雄捡物同步内挂配置；位置：查看——》列表信息2——》内挂捡取
英雄捡物同步内挂配置；位置：选项——》宠物设置——》参数设置

命令：
OpenAutoDropItemToBag 对象(1:自己; 2:宝宝; 3:自己+宝宝) 时间(秒，0或者空 表示在线有效)， 是否直接进入主人背包（0或空进入英雄背包，1进入主人背包， 该参数 仅H.有效）

CloseAutoDropItemToBag 关闭怪物爆物品自动放入背包

英雄命令：H.OpenAutoDropItemToBag H.CloseAutoDropItemToBag

入包物品因考虑到多数服喜欢使用拾取触发鉴定，特别是一些不懂脚本不经过大脑的搬砖档，搬的脚本效率低下而且还存在死循环，出于全局考虑所以暂不支持拾取触发(仅支持掉落触发和掉落提示)，目的就是避免一些傻X脚本写的不好，同时有触发脚本频率过高，造成游戏卡甚至引擎崩溃,如需触发请用 杀怪爆出的物品角色可范围内拾取命令

;-------------------------------Npc示范脚本：----------------------------

<杀怪物品自动入包/@杀怪物品自动入包> <关闭物品自动入包/@关闭物品自动入包> \ \

[@杀怪物品自动入包]
#if
#ACT
OpenAutoDropItemToBag 3

[@关闭物品自动入包]
#if
#ACT
CloseAutoDropItemToBag

;-------------------------------其他说明：----------------------------

地图参数：
NoAutoDropItemToBag 禁止物品自动入包 （地图内开启自动入包功能后，打怪爆出物品依然掉落在地上）

列表信息1可自定义设置哪些物品在使用自动入包命令后，不进入背包！！！（意思就列表中物品正常掉落到地上，不允许自动入包）

对象(1:自己; 2:宝宝; 3:自己+宝宝) :意思是谁杀死的怪物爆出物品自动入包，1为自己，2为宝宝，3为自己和宝宝


角色交易系统,账号交易买卖，角色出售[!]

角色出售、角色交易系统

功能：角色交易功能说明

查看详细信息脚本：
查看角色属性栏最下面的“其他”读取的是SellPlayerInfo.txt文本，手动创建后复制下面的脚本即可！
SellPlayerInfo.txt 是显示出售角色信息中的“其他”中的内容，置于 Mir200\Envir\ 目录下。
和npc写法相同，不要任何标签和[@main]，不支持触发<触发/@不支持>，主要用于显示一些角色信息无法显示的各种变量属性

下方为 SellPlayerInfo.txt 文本内容示范：

用户名:<$UserName>\
等级:<$Level>\
转生等级:<$ReLevel>\

;******************************************分界线******************************************

功能操作命令：

检测自己是否在出售中：
CheckIsSellPlayer

检测自己是否为角色出售委托人
CheckIsSellPlayDelegator

打开角色出售对话框：
OpenAddSellPlayerDlg

获取委托自己出售的角色数量
GetSellPlayerCount

取消某个委托自己出售的角色
DelSellPlayer 角色名

打开取消角色出售对话框
OpenDelSellPlayerDlg

打开角色出售商店
OpenSellPlayerShopDlg

中止添加角色出售 （仅用于 QFunction-[@PlayerSelling]或[@BeforePlayerSelling]中使用）
BreakAddSellPlayer

;-------------------------------Npc示范脚本：----------------------------

<我要出售角色/@我要出售角色> <取消角色出售委托/@取消角色出售委托> \ \
<我要购买角色/@我要购买角色>

[@我要出售角色]
#if
CheckIsSellPlayer
#act
SendMsg 6 您已经在出售中
break

#if
CheckIsSellPlayDelegator
#act
SendMsg 6 您是别人的委托人，不能出售，如果要出售请先取消委托
break

#if
#act
;打出角色出售对话框，在此前可以加出售条件判断
; 此前加的条件可能会被构造的非法封包绕过，建议在QFunction-[@PlayerSelling]或[@BeforePlayerSelling]触发中检测
OpenAddSellPlayerDlg

[@取消角色出售委托]
#if
#act
GetSellPlayerCount n0
;获取正在委托自己出手的信息到变量中，N0修改为服务端没用到其他N变量

#if
Equal n0 0
;判断上面的变量是否为0，如上面N0修改了，本项N0同步修改
#act
SendMsg 6 没有委托您出售的角色
break
#elseact
OpenDelSellPlayerDlg

[@我要购买角色]
#if
#act
OpenSellPlayerShopDlg

;-------------------------------触发：QFunction ----------------------------

QFunction触发字段说明：
1、添加出售角色委托人同意之后触发：@PlayerSelling
2、添加出售在询问委托人确认前触发：@BeforePlayerSelling
3、角色出售成功触发：@PlayerSold

4、购买角色成功触发：@PlayerBuyIn

;-------------------------------QFunction触发示例----------------------------

[@PlayerSold]
#act
;交易成功后将售出的角色强行离婚
unmarry requestunmarry force
break

[@BeforePlayerSelling]
#if
#act
SendMsg 6 委托人：<$SellPlayDelegater>
SendMsg 6 出售货币：<$SellPlayMoneyType>
;(1:元宝；2:游戏点；3:金币；4:金刚石；5:灵符)
SendMsg 6 出售价格：<$SellPlayMoneyValue>

#if
not checklevel 300
#act
BreakAddSellPlayer
SendMsg 6 您的等级不够，不能出售
break

说明：
@PlayerSelling出售前最后一个触发，可用于检测一些特殊项，至于检测什么自己决定
@BeforePlayerSelling 为向委托人发送请求前触发，比如检查等级，出售价格等，如果在 @PlayerSelling 中触发，感觉不太友好，因为折腾半天到最后一步提示条件不足，不够优雅，简单检测可以用在@BeforePlayerSelling 中进行

委托人是他人或自己另外个角色都会进行触发，因为触发为出售人的QF触发，一般用于检测

;-------------------------------购买角色成功QFunction触发示例----------------------------

变量（仅@PlayerBuyIn中可用）：

购买的角色名：<$PlayerBuyUser>
角色出售委托人：<$PlayerBuyUserDelegater>
角色出售价格：<$PlayerBuyPrices>
角色出售货币类型文本：<$PlayerBuyMoneyType>
角色出售货币类型值：<$PlayerBuyMoneyTypeValue>；0:元宝; 1:游戏点; 2:金币；3:金钢石; 4:灵符

[@PlayerBuyIn]
#ACT
SendMsg 6 购买角色“<$PlayerBuyUser>”（委托人：<$PlayerBuyUserDelegater>）成功触发；价格：<$PlayerBuyPrices><$PlayerBuyMoneyType>(货币类型值：<$PlayerBuyMoneyTypeValue>)

以上为简单脚本，各种检测 需GM自己完善，已经成功后触发需要解除什么关系的 需GM自己加

如需下架指定出售角色命令请查阅GM命令

角色交易系统可和修改指定账号的注册信息命令配合使用

;******************************************分界线******************************************

购买角色前触发：@BeginBuyUser
中止人物购买角色：StopBuyUser，仅用于@BeginBuyUser中

[@BeginBuyUser]
#ACT
StopBuyUser
#SAY
购买的角色名：<$PlayerBuyUser>\
角色出售委托人：<$PlayerBuyUserDelegater>\
角色出售价格：<$PlayerBuyPrices>\
角色出售货币类型文本：<$PlayerBuyMoneyType>\
角色出售货币类型值：<$PlayerBuyMoneyTypeValue>；0:元宝; 1:游戏点; 2:金币；3:金钢石; 4:灵符

;******************************************分界线******************************************

角色出售 默认为本账号下另外个角色进行委托，如果不想账号下另外个角色，可以委托指定在线玩家帮忙代售，交易成功后货币直接进入委托人角色上！

角色出售 出售给指定玩家，意思是出售的角色在角色购买栏只有指定的这个玩家才看得到，其他玩家无法看到~~~~

为防止PK期间被人恶意输入委托人弹出对话框，角色交易采用委托在线其他玩家代售，则需要代售玩家使用命令@角色交易（此命令在M2上玩家命令中可自行修改） 打开和关闭是否允许接受委托，上线默认禁止

角色交易UI默认使用13周年UI，可在自定义UI中选择替换UI读取路径为你服的UI界面

********************出售角色默认都是离线挂机状态，M2剔除离线挂机无法剔除这些出售中的角色。因为不是离线挂机状态无法查看角色属性，仓库，背包之类 ，可脚本给予无敌模式、观察模式或必须在或者不允许PK地图进行交易（M2-功能设置-脱机登录 勾选上“ 怪物不攻击脱机人物”）********************


脚本命令将数字转换为图片显示

功能：
脚本命令将数字转换为图片显示.

格式：

脚本命令将数字转换为图片显示：

打开命令：
AddNumberButton 参数1 参数2 .... 参数8
参数1：数字点击后的脚本触发序号，触发QF里面的[@NumberButtonClickX]X即为触发序号
参数2：数字类型 (0 -- 9)
参数3：数值
参数4：数字间隔
参数5：X
参数6：Y
参数7：为按钮是否可以移动0=不能移动1=可以移动2=人物装备栏3=人物背包栏4=英雄装备栏5=英雄背包栏6=聊天框左侧龙界面7=聊天框右侧等级界面8=商铺界面9=时装界面,10=英雄时装，11=技能栏，12=英雄技能栏，13=称号栏，14=英雄称号栏，15=状态栏，16=英雄状态栏，17=属性栏，18=英雄属性栏，19=人物出战栏，20=行会界面,21=详细属性,22=宠物界面，23=宠物背包，24=人物首饰，25=英雄首饰，26=人物神佑，27=英雄神佑，28=查看他人装备，29=查看他人时装，30=查看他人称号，31=查看他人首饰盒，32=查看他人神佑袋，33=M大地图
参数8：鼠标移过时提示信息

关闭命令：
DelNumberButton 序号

列子：
AddNumberButton 1 9 1234 -3 0 0 2 这是一个提示信息
AddNumberButton 1 9 1234 -3 0 0 2 添加到装备栏数字的提示信息

图片位置：NewopUI.pak 1230开始---1329结束 (一共10组)


脚本中使用图标功能[!]

功能：脚本中使用图标功能[!]
格式：无
说明：无
例：

格式: <Img:N:F:X:Y:D/@Label>
N表示显示文件中的第几个图片,F表示WIL文件序号,X是横向坐标,Y是纵向坐标.
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
X和Y这两个坐标可以使图片显示的坐标更加精准.
D=输入框的ID列表，用','分隔开，所有用*表示 (本参数为20170407更新扩展，但如果图片要用于提交输入的内容，就必须要填)
@Label是点击图片时需要触发的脚本标签.

===================================================================================================

新增加 格式: <ImgEx:F:U:H:D:X:Y:P/@Label>
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
U=默认显示的图片序号
H=鼠标放上去时显示的图片序号
D=鼠标点下去时显示的图片序号
X和Y这两个坐标可以使图片显示的坐标更加精准.
P=输入框的ID列表，用','分隔开，所有用*表示 (本参数为20170407更新扩展。可以不填写，但如果图片要用于提交输入的内容，就必须要填)
@Label是点击图片时需要触发的脚本标签.

===================================================================================================

增加脚本中播放图片功能.

格式: <PlayImg:F:N:C:T:X:Y:M:备注文字内容:P/@Label>.
F表示WIL文件序号,N表示播放开始图片,C表示播放张数,T表示播放速度(毫秒),X是横向坐标,Y是纵向坐标.
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
X和Y这两个坐标可以使图片显示的坐标更加精准.
M：绘制模式（0:原始绘制; 1:透明绘制; 2:底层原始绘制;3:底层透明绘制)
P=输入框的ID列表，用','分隔开，所有用*表示 (本参数为20170407更新扩展。可以不填写，但如果图片要用于提交输入的内容，就必须要填)
@Label是点击图片时需要触发的脚本标签.
例： <PlayImg:5:510:3:100:10:10:M:249#翎风引擎官方网站：^250#www.lfm2.com/@播放图片>.

===================================================================================================

增加脚本中播放图片功能(支持播放次数).

格式: <PlayImgEx:F:N:C:T:H:X:Y:M:备注文字内容:P/@Label>.
F表示WIL文件序号,N表示播放开始图片,C表示播放张数,T表示播放速度(毫秒),
H:表示播放次数
X是横向坐标,Y是纵向坐标.
F=WIL文件序号(详见引擎：查看-列表信息(二)-WIL资源)
X和Y这两个坐标可以使图片显示的坐标更加精准.
M：绘制模式（0:原始绘制; 1:透明绘制; 2:底层原始绘制;3:底层透明绘制)
P=输入框的ID列表，用','分隔开，所有用*表示 (本参数为20170407更新扩展。可以不填写，但如果图片要用于提交输入的内容，就必须要填)
@Label是点击图片时需要触发的脚本标签.
例：<PlayImgEx:1:520:10:150:5:280:-50:0:250#翎风引擎官方网站：^250#www.lfm2.com/@播放图片>.

20170407扩展的参数主要用于：：<$NPCINPUT(1)>----- <$NPCINPUT(40)>

===================================================================================================

;显示图标
[@main]
显示图标<Img:10>
;设置坐标显示更加精确
[@main]
显示图标<Img:1185:1:1:-10>

;可执行脚本的图片
[@main]
显示图标<Img:1185:1:1:-10/@Hint>
[@Hint]
测试通过
;通过空格控制图片显示的位置.
;注意前面的空格,以及和X Y坐标的区别.
[@main]
<Img:1185:1:1:-10>显示图标

[@main]
播放图片<PlayImg:1:610:19:100/@播放图片>\
播放图片<PlayImg:1:130:7:300:-100:-100>\


禁止物品掉落、停止物品掉落、禁止爆出物品、爆出物品检测，脚本回收爆出物品

 功能说明：禁止物品掉落、停止物品掉落、禁止爆出物品、爆出物品检测,爆物品检测

操作命令：StopDropItem

增加NPC变量：
当前物品名<$CURITEMNAME>

爆率文件触发：
#CHILD 1/1 RANDOM [N1<1000,1,@触发检测]
(
1/1 天尊头盔
1/1 火球术
1/1 治愈术
1/1 基本剑术
)

QF 以检测天尊头盔是否爆出为例：
[@触发检测]
#if
;检测掉落物品是否有天尊头盔
equal <$CURITEMNAME> 天尊头盔
;有天尊头盔则继续执行，没有就中断执行
#act
#elseact
break
#if
LARGE U99 1999
;续检测U99充值记录大于2000元，则允许此物品掉落
#act
;U99 大于2000则中断执行，物品正常掉落，否则进入下一步执行命令
break
#elseact
;U3小于2000，禁止掉落天尊头盔
StopDropItem
SENDMSG 6 禁止物品"<$CURITEMNAME>"掉落
break


经络连击[!]

连击技能设置:
M2\选项\功能设置\技能魔法\通用技能\连击技能

魔法DB:
81;倚天辟地;0;55;5;10;10;5;6;6;99;15;5;15;10;15;15;60;;

300;万剑归宗;1;105;15;15;40;20;5;10;2;95;5;95;10;95;15;60;连击;
301;三焰咒;8;106;8;8;20;15;5;10;2;52;5;52;10;52;15;60;连击;
302;虎啸诀;8;107;5;20;45;10;5;15;2;15;5;15;10;15;15;60;连击;
303;八卦掌;1;108;5;20;45;10;5;15;2;33;5;33;10;33;15;60;连击;
305;冰天雪地;2;110;15;15;40;20;5;10;1;95;5;95;10;95;15;60;连击;
306;凤舞祭;1;111;5;20;45;5;5;10;1;33;5;33;10;33;15;60;连击;
307;双龙破;1;112;5;20;45;5;5;10;1;15;5;15;10;15;15;60;连击;
308;惊雷爆;1;113;5;20;45;5;10;10;1;52;5;52;10;52;15;60;连击;
310;追心刺;0;115;5;10;25;5;0;0;0;33;5;33;10;33;15;60;连击;
311;三绝杀;0;116;5;25;50;5;0;0;0;15;5;15;10;15;15;60;连击;
312;横扫千军;0;117;5;20;40;5;0;0;0;95;5;95;10;95;15;60;连击;
313;断岳斩;0;118;5;25;50;5;0;0;0;52;5;52;10;52;15;60;连击;

部分物品DB:
1434;倚天剑;5;530;80;241;-5;0;1880;50000;0;0;0;0;0;50;0;0;0;0;0;60;35000;5;0;10;0;251;0;;
1435;倚天战甲(男);10;75;80;242;0;0;1900;60000;20;25;17;20;10;10;0;0;0;0;0;40;80000;5;0;0;0;0;0;;
1441;倚天战甲(女);11;75;80;242;0;0;1900;60000;20;25;17;20;10;10;0;0;0;0;0;40;80000;5;0;0;0;0;0;;

金针物品:
17分类 Shape-表示等级(与符的等级对应) DuraMax(持久)--可叠加上限值
Anicount--合成成功率

1443;金针碎片;17;0;1;8;0;200;1730;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1444;金针;17;1;1;8;0;200;1731;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1445;一级金针;17;2;1;14;0;200;1732;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1446;二级金针;17;3;1;20;0;200;1733;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1447;三级金针;17;4;1;20;0;200;1734;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1448;四级金针;17;5;1;20;0;200;1735;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1449;五级金针;17;6;1;20;0;200;1736;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;

幸运符物品:
18分类,分配外观-表示等级(与针的等级对应) DuraMax(持久)--可叠加上限值
Anicount--合成成功率

1450;幸运符;18;1;1;20;0;200;1720;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1451;一级幸运符;18;2;1;20;0;200;1721;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1452;二级幸运符;18;3;1;20;0;200;1722;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1453;三级幸运符;18;4;1;20;0;200;1723;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1454;四级幸运符;18;5;1;20;0;200;1724;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;
1455;舒经活络丸;41;0;1;20;0;0;1751;1;0;0;0;0;0;0;0;0;0;0;5;0;4545;5;0;0;0;0;0;;

脚本命令:
功能: 检查英雄是否开通经脉系统
格式: CHECKHEROOPENOPULSE

功能：开通英雄经脉
格式：H.OPENPULSE

功能: 检查当前英雄经络修炼点是否大于等于升级所需的经验
格式: CHECKPULSEEXP 经络(0..3) 等级(0..4)
备注: 必须由英雄执行,格式: Hero.CheckPulseExp

功能: 把当前英雄的经络修炼点减去指定经络等级升级所需的经验
格式: DECPULSEEXP 经络(0..3) 等级(0..4)
备注: 必须由英雄执行,格式: Hero.DecPulseExp

功能: 调整英雄的经络经验值
格式: CHANGEHEROPULSEEXP 操作法(+ - =) Exp(0-200000000)
备注: 必须由英雄执行,格式: Hero.ChangeHeroPulseExp

功能: 清除人物的经络等级.
格式: ClearAllPulse

功能: 永久增加人物属性点.
格式: ChangeHumAbilityEX 属性位置(1-13) 控制符(+ - =) 点数
说明: 属性1-13分别对应人物 :防御下限 防御上限 魔御下限 魔御上限 攻击下限 攻击上限 魔法下限 魔法上限 道术下限 道术上限 MaxHP MaxMP 内功攻击伤害减

功能: 检查物品数量以及持久值
格式: CHECKITMECOUNTDURA 物品名称 数量 操作符(< = >) 持久(MaxDura--物品的持久上限)

功能: 收回指定名称物品(按数量,持久)
格式: TAKEITMECOUNTDURA 物品名称 数量 操作符(> = >) 持久(MaxDura--物品的持久上限)

功能：检查是否跨穴点击
格式：CHECKHUMANPULSE 经络(0..3) 穴位(1..5)

功能: 检查打通穴位所需内功等级
格式: CHECKOPENPULSELEVEL 经络(0..3) 穴位(1..5)

功能: 打通指定脉穴
格式: OPENPULSE 经络(0..3) 穴位(1..5)

功能：改变络经等级
格式：CHANGEPULSELEVEL 经络(0..3) 控制符(+,-,=) 等级(1..5)

功能：检查各经络等级
格式：CHECKPULSELEVEL 经络(0..3) 控制符(>,<,=) 等级(1..5)

地图参数:
进入本地图后杀怪英雄经络经验倍数 格式: PULSEEXPRATE(100) 说明:100代表经验倍数,除以100后为实际倍数
进入本地图后杀怪内功经验倍数 格式: NGEXPRATE(100) 说明: 100代表经验倍数,除以100后为实际倍数
MonGen.txt中设置内功怪物+经络经验怪物:
内功怪物(1,2,3) 1=内功怪物 2=经络怪物 3=内功+经络

地图  坐标X  坐标Y   名字    范围  数量  间隔  集中坐标  名字颜色  内功怪物(1,2,3)
D2004   49    44    红野猪   100   10    5      50       0           2
D2004   49    44    黑野猪   100   10    5      50       0           2

连击脚本参考: 点击下载
特别注意:使用USEBONUSPOINT增加人物属性不要出现防御和魔御下限高于上限的情况,否则会出现秒杀的情况.

人物内功参考: 点击查看
装备：need 18-21增加内功恢复速度

奇经会触发 QBatter-0.txt

@Pulse4-X

[@Pulse4-1]
#IF
#ACT
OPENPULSE 4 1

脚本自己写 具体干嘛自己看着搞·


可视仓库

可视仓库操作说明

说明：
OpenStorageView 1 打开无限仓库（可视）
OpenStorageView 0 打开普通仓库（可视）
支持坐标调整打开窗口的位置，格式为：OpenStorageView 0/1 坐标x 坐标 y

示例(打开默认仓库)：
[@main]
#IF
#ACT
OpenStorageView 0

下面为扩展的默认仓库数量。默认仓库由之前的44个存储数量提升至49个，页数扩展增加3页，合计4页。

非可视仓库NPC脚本：
<保管/@storage> 物品\
<保管2/@storage2> 物品\
<保管3/@storage3> 物品\
<保管4/@storage4> 物品\

<找回/@getback> 物品\
<找回2/@getback2> 物品\
<找回3/@getback3> 物品\
<找回4/@getback4> 物品\

QF触发：
[@OpenStoratge2]
[@OpenStoratge3]
[@OpenStoratge4]

触发脚本示范：

[@OpenStoratge2]
#if
; 检查2号仓库是否开启
not CheckStorageOpen 2
#act
; 开启仓库 仓库号(2,3,4) 是否开启(0,1)
OpenStoratge 2 1
SendMsg 5 开启仓库2

;========================================下方为无限仓库=========================

注：无限仓库需要在M2-功能设置- 个人商店 内打开无限仓库功能和设置无限仓库存取数量
无限仓库保存在UserData\Storage目录内

示例(打开无限仓库)：
[@main]
#IF
#ACT
OpenStorageView 1


可视化商店(交易市场)

;----------------------------------------------

打开交易的市场 @trading

说明：交易市场（可视化商店）和普通NPC一样使用，需要在NPC头加 （@trading），然后增加物品折扣，和可出售的物品分类号！

如果需要增加默认出售，请在NPC文本下面增加你需要出售的物品！

NPC内容列：

( @trading @buy )
%100
+20
+19
+21

<M2交易交易市场/@trading>

[goods]
灯笼项链 10 10
白色虎齿项链 10 10
白金项链 10 10
传统项链 10 10
魔鬼项链 10 10
凤凰明珠 10 10
琥珀项链 10 10
蓝翡翠项链 10 10
放大镜 10 10
竹笛 10 10


扩展NPC脚本点击触发带参数,NPC标签带参数

扩展NPC脚本点击触发带参数

-----------------------------------扩展NPC脚本点击触发带参数------------------------------

/////////////////////////////////////////////////////////// <$SCRIPTPARAM>新增触发带参数

<@测试1/@测试(1,2,3)> <@测试2/@测试(2,3,4)>

[@测试]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 1,2,3
CHECKSCRIPTPARAM 2,3,4
#ACT
SENDMSG 6 <$SCRIPTPARAM1>,<$SCRIPTPARAM2>,<$SCRIPTPARAM3>
break
#ELSEACT
SENDMSG 6 非法的参数
break

[@main]
你想买点什么呢?\\
<麻痹戒指/@购物(20,麻痹戒指)> <重生戒指/@购物(20,重生戒指)>\
<护体戒指/@购物(20,护体戒指)> <魔道麻痹/@购物(20,魔道麻痹戒)>\
[@购物]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 20,麻痹戒指
CHECKSCRIPTPARAM 20,护体戒指
CHECKSCRIPTPARAM 20,重生戒指
CHECKSCRIPTPARAM 20,魔道麻痹戒
#ELSEACT
;-----------------------------------------------防止用抓包工具刷数据并且跳过了检测
SENDMSG 6 非法的参数
break

#IF
CHECKGAMEGOLD <$SCRIPTPARAM1>
#ACT
GAMEGOLD - <$SCRIPTPARAM1>
GIVE <$SCRIPTPARAM2> 1
#ELSESAY
对不起!你的元宝不够!

####################################################2019-08-28进行补充说明，防止个别人运用错误！！！！！下面为解说！！！！#########################################

[@main]
亲爱的<$USERNAME>\
你想买点什么呢?\\
<麻痹戒指/@购物(20,麻痹戒指)> <重生戒指/@购物(20,重生戒指)>\
<护体戒指/@购物(20,护体戒指)> <魔道麻痹/@购物(20,魔道麻痹戒)>\

[@购物]
#OR
;检查参数是否是这几组，防止有可能被人刷数据
CHECKSCRIPTPARAM 20,麻痹戒指
CHECKSCRIPTPARAM 20,护体戒指
CHECKSCRIPTPARAM 20,重生戒指
CHECKSCRIPTPARAM 20,魔道麻痹戒
#ELSEACT
;-----------------------------------------------防止用抓包工具刷数据并且跳过了检测
SENDMSG 6 非法的参数
break

#IF
CHECKGAMEGOLD <$SCRIPTPARAM1>
#ACT
GAMEGOLD - <$SCRIPTPARAM1>
GIVE <$SCRIPTPARAM2> 1
#ELSESAY
对不起!你的元宝不够!

------------------------------------**************************************但是一些GM会写成这样，然后来提交BUG*******************************-------------------------
**************************************************************************** 下面的写法会出问题:

<@测试1/@测试(封号1,100,封号1+)>

[@测试]
#ACT
;下面的脚本可能会触发跳转 @UnactiveTitle_XX @ActiveTitle_XX，而为了保证安全发生跳转到新的标签时会清掉参数值
;建议可能触发跳转之前，用变量先存起来
GameGold - <$SCRIPTPARAM2>
RecycFenghao <$SCRIPTPARAM1>
GiveFenghao <$SCRIPTPARAM3> 1
MessageBox <$SCRIPTPARAM1>,<$SCRIPTPARAM2>,<$SCRIPTPARAM3>

总结：
参数仅在一个对话框标签生效，更换或跳转到其它标签后参数清空
比如:[@测试]标签的参数仅限在该条脚本内生效，脚本运行中途出现任何跳转其他标签均清空，GOTO @xxxx 脚本执行中途出现其他任何标签参数均清空


扩展字符变量S和数字变量N[!]

功能：扩展字符变量S和数字变量N
格式：无
说明：扩展字符变量S和数字变量N，除了支持0~999以外，可以在S$变量或N$变量后面增加任意字符
例：

[@test]
#ACT
MOV S$我的人物名称 <$USERNAME>
SENDMSG 0 <$STR(S$我的人物名称)> 255 253

[@test1]
#ACT
MOV N$我的杀怪总数 100
INC <$STR(N$我的当前杀怪数)> 1
SENDMSG 6 【杀怪总数=<$STR(N$我的杀怪总数)>】【当前杀怪数=<$STR(N$我的当前杀怪数)>】 255 253


聊天框脚本功能

功能: 聊天框脚本功能

;暂支持固顶公告和SENDMSG

[@Main]
#ACT
SENDTOPCHATBOARDMSG 0 149 235 30 %s:聊天框固顶信息{<点击打开脚本/@test>|254:253}

[@Main]
#ACT
SENDMSG 5 {<点击打开脚本/@test>|254:253}点击测试
;SENDMSG 支持 0 1 2 3 5 6 7

=====================

触发NPC脚本位置：

Mir200\Envir\Market_Def\QChatbox-0.txt

[@test]
触发NPC脚本


魔王岭相关

说明: 魔王岭相关

--------------------------------

怪物数据库race字段设置，然后使用召唤宝宝命令布置弓箭手位置
108魔王岭怪，109魔王岭弓箭手。

杀一个怪，触发@KillMissionMob

------------------------

自定义怪物：
154{魔王岭怪物}
155{魔王岭宝宝}
156{普通怪物}
157{不主动攻击，类似鸡羊鹿}:

----------扩展-----------

CheckRangeMonCountEx <$MAP> 魔王岭弓箭手 51 43 0 > 0 1

最后扩展一个参数：0：不算宝宝；1：算宝宝

-------------新增------------------

ReCallMobEx2 魔王岭弓箭手 51 43 8 1 1
加新npc命令：
召唤宝宝（魔王岭）
ReCallMobEx2 宝宝名称 坐标X 坐标Y 视角范围 隐藏主人名（0：不隐藏；1：隐藏） 宝宝不升级（0：宝宝升级，1：宝宝不升级）

魔王岭脚本参考: 点击下载


内功系统[!]

MonGen.txt 格式：地图 坐标X 坐标Y 怪物名字 范围 数量 间隔 集中刷新坐标机率 名字颜色(0~255) 内功怪物(0,1) 国家名字 同国家名玩家是否可攻击(0,1)
说明：最后一个参数为0时表示同国家玩家不能攻击该怪物，为1时在非国家攻击模式下可以攻击该怪物

物品DB：
(金牛装备：需等级 同时可内力恢复速度)
DB设置：
Need=18(表示穿戴需等级，装备可提高内力恢复速度) NeedLevel=50(等级条件) Stock=3(提高内力恢复速度)
Need=19(表示穿戴需攻击力，装备可提高内力恢复速度%) NeedLevel=50(攻击力条件) Stock=3(提高内力恢复速度%)
Need=20(表示穿戴需魔法，装备可提高内力恢复速度%) NeedLevel=50(魔法条件) Stock=3(提高内力恢复速度%)
Need=21(表示穿戴需道术，装备可提高内力恢复速度%) NeedLevel=50(道术条件) Stock=3(提高内力恢复速度%)
Need=22(表示穿戴需等级，装备可提高内力恢复速度+点) NeedLevel=50(等级条件) Stock=3(每次可提高内力值)
Need=23(表示穿戴需攻击力，装备可提高内力恢复速度+点) NeedLevel=50(攻击力条件) Stock=3(每次可提高内力值)
Need=24(表示穿戴需魔法，装备可提高内力恢复速度+点) NeedLevel=50(魔法条件) Stock=3(每次可提高内力值)
Need=25(表示穿戴需道术，装备可提高内力恢复速度+点) NeedLevel=50(道术条件) Stock=3(每次可提高内力值)

脚本命令：
功能:学习内功
格式:READSKILLNG

说明:
1.判断玩家是学过内功,学过则进入@ReadNGFail,英雄则进入@ReadNGHeroFail
2.学习成功进入@ReadNGOK,英雄则进入@ReadNGHeroOK
3.主号学习过后,英雄才能学习

功能:调整内力经验点数。
格式:CHANGENGEXP 控制符(=,+,-) 经验点数

功能:检查是否学过内功
格式:CHECKREADSKILLNG

功能:检查内功等级
格式:CHECKNGLEVEL 操作符 (<,>,=) 等级数(1-255)

功能:调整内功等级
格式:CHANGENGLEVEL 控制符(=,+,-) 等级数(1-255)


内挂挂机设置

内挂自动挂机使用说明：
使用快捷键CTRL+ALT+X或点击挂机按钮会触发QF里的[@StartAutoOnline]
点停止挂机按钮时；触发QF里的[@StopAutoOnline]

命令:
;开始挂机命令
StartAutoPlayGame

;停止挂机命令
StopAutoPlayGame

;点开始挂机触发
[@StartAutoOnline]
#IF
CHECKMAPNAME 0
#ACT
SENDMSG 6 当前地图禁止挂机
#ELSEACT
StartAutoPlayGame
SENDMSG 6 开始挂机，使用快捷键“CTRL+ALT+X”停止挂机

;—————————————————————————————————————————脚本命令停止挂机—————————

;点停止挂机触发
[@StopAutoOnline]
#IF
#ACT
StopAutoPlayGame
SENDMSG 6 命令停止挂机，使用快捷键“CTRL+ALT+X”开始挂机

注：内挂物品设置“特殊”的物品，打怪完成后优先捡，捡完才会捡未设置“特殊”的可拾取物品！背包满或负重满停止捡物品

内挂挂机为优先打怪，周围无怪打才会去捡物品


拍卖行

;----------------------------------------------
允许拍卖物品请在M2列表信息2内的物品规则处添加！

打开拍卖行命令：OpenAuctionView

;----------------------------------------------
例：
[@main]
#act
OpenAuctionView

;----------------------------------------------
相关QF触发：

以下2个触发只有成功时人物才线才触发：
;拍卖卖出成功
@AuctionSellItem

;拍卖买入成功
@AuctionBuyItem

;拍卖行竞价出价前触发
正常出价：@BeginAuctionItemBid
一口价出价：@BeginAuctionItemBidBuy

;例子
[@BeginAuctionItemBid]
#IF
#ACT
StopAuctionItemBid
SENDMSG 6 中止出价

;-----------------

;拍卖行物品取回前触发（流拍物品取回 和 拍卖成功物品取回）
@BeginRetrievedAuctionItem

;拍卖行中止取回物品命令
StopRetrievedAuctionItem

;例子
[@BeginRetrievedAuctionItem]
#IF
CheckInWarArea
#ACT
StopRetrievedAuctionItem
SENDMSG 6 攻城区域禁止取回物品

;----------------------------------------------
相关命令
;拍卖行中止取回物品命令
StopRetrievedAuctionItem

;拍卖行中止出价命令
StopAuctionItemBid

;----------------------------------------------

相关变量：
以下变量只支持 [@AuctionSellItem] , [@AuctionBuyItem] 中

拍卖物品名称(数据库)：<$AuctionItemName>
拍卖物品名称（当前）：<$G_AuctionItemName>
底价： <$AuctionItemStartPrice>
一口价：<$AuctionItemSellPrice>
成交价：<$AuctionItemFinaPrice>
物品拍卖人:<$AuctionItemHumanName>
物品买入人/最后出价人:<$AuctionItemBidHumanName>
<$AuctionItemFinaPrice>：在@AuctionSellItem/@AuctionBuyItem为成交价。在 @AuctionInvalidItem 为最新出价
<$AuctionItemMoneyType>： 货币类型
<$AuctionItemMoneyTypeValue>：货币类型--整数（0:元宝 1:游戏点 2:金币 3:金刚石 4:灵符)判断货币类型
<$AuctionItemInvalidPrice>: 失效出价，仅@AuctionInvalidItem中使用
<$AuctionItemSelled>：物品是否被卖出，一般用于@AuctionInvalidItem中

当成交价 = 一口价时，表示一口价成交

QF示范脚本

; 拍卖行出价被冲
[@AuctionInvalidItem]
#IF
; 物品被别人秒了
EQUAL <$AuctionItemSelled> 1
#ACT
sendmsg 7 很遗憾，你出价<$AuctionItemInvalidPrice>的竞拍物品【<$AuctionItemName>；底价：<$AuctionItemStartPrice><$AuctionItemMoneyType>；一口价：<$AuctionItemSellPrice>】被人用秒拍
#ELSEACT
sendmsg 7 你出价<$AuctionItemInvalidPrice>的竞拍物品【<$AuctionItemName>；底价：<$AuctionItemStartPrice><$AuctionItemMoneyType>；一口价：<$AuctionItemSellPrice>】被人出了更高的价格：<$AuctionItemFinaPrice>，赶快去加价吧

;拍卖人的物品被卖出
[@AuctionSellItem]
#ACT
sendmsg 7 你拍卖的物品【<$AuctionItemName>；底价：<$AuctionItemStartPrice><$AuctionItemMoneyType>；一口价：<$AuctionItemSellPrice>】被人用<$AuctionItemFinaPrice>的价格买走

;竞拍人买到物品
[@AuctionBuyItem]
#ACT
sendmsg 7 恭喜。你参与竞拍的物品【<$AuctionItemName>；底价：<$AuctionItemStartPrice><$AuctionItemMoneyType>；一口价：<$AuctionItemSellPrice>】竞拍成功。成交价：<$AuctionItemFinaPrice>


佩戴装备触发指定技能[!]

功能：佩戴装备触发技能设置参数
格式：无
说明：佩戴装备触发技能，类似火焰戒指和治愈戒指，不同的是当人物已经学习了技能则不触发增加，拿下装备也不会删除自身学习的技能，只删除触发增加的
详细说明：

自定义佩戴装备获得指定技能（类似火焰戒指）：
衣服，武器，照明物，时装衣服，时装武器：
AniCount = 210

其他类型（首饰，不支持马牌）设置：
Shape = 210

Expand3：装备对应的 MagicID
Expand4：技能等级，是否为强化等级

Expand4计算方式：
等级 * 10 + 是否为强化等级(0：普通等级；非0：强化等级）；如: 91 强化9重

佩戴时候如果已经学习了对应技能则不增加，，拿下时只删除触发增加的，原来学习的不删除！

#################################2019-09-28新增相关操作命令###############################################

功能说明：修改触发技能物品的Expand3,Expand4 （仅 数据库字段 ： AniCount = 210 和Shape = 210 有效）
SetSkillItemValue 装备位置(-1时是升级OK框中的装备, boxitem0 -boxitem7是自定义OK框，0-12时是穿在身上的装备) Expand3值 Expand4值

读取触发技能物品的Expand3,Expand4
GetSkillItemValue 装备位置 变量1 变量2

#IF
#act
SetSkillItemValue 40 1 30
SENDMSG 6 子鼠神佑触发技能学习火球术3级

GetSkillItemValue 40 N1 N2
SENDMSG 6 读取技能ID:<$STR(N1)>，等级:<$STR(N2)>

注：触发技能的物品必须符合以下字段才有效

衣服，武器，照明物，时装衣服，时装武器：
AniCount = 210

其他类型（首饰，不支持马牌）设置：
Shape = 210


强制怪物爆出物品、怪物掉落/爆出物品

 功能说明：强制怪物爆出物品、怪物掉落/爆出物品

格式：MonDropItems 怪物名称 物品名称 物品数量 是否掉落物品以最近攻击目标为中心(为0或空时物品以人物为中心,1时掉落物品以最近攻击目标为中心)

格式：MonDropItemsEx 怪物名称 物品名称 物品数量 是否掉落物品以最近攻击目标为中心(为0或空时物品以人物为中心,1时掉落物品以最近攻击目标为中心)

-----------------------------------------------------------------------------
增加怪物掉落/爆出物品：

MonDropItems 怪物名 物品名 物品数量 是否掉落物品以最近攻击目标为中心(为0或空时物品以人物为中心,1时掉落物品以最近攻击目标为中心)

杀死怪物触发：

[@KillMon]
#ACT
SENDMSG 6 <$USERNAME>杀了怪物<$ATTACKMONSTER_NAME>
MonDropItems <$KillMonName> 屠龙 2
SENDMSG 6 <$KILLMONNAME>再次爆出5个裁决

NPC命令执行：

[@测试]
#ACT
MonDropItems 随便搞个怪 屠龙 2 1
SENDMSG 6 没怪也掉物品

-----------------------------------------------------------------------------

MonDropItemsEx 掉落物品支持掉落提示和怪物掉落触发

-----------------------------------------------------------------------------

爆出来的物品来源根据怪物来写,该命令不受怪物爆出物品控制限制,但会记录到爆出数量!

注：本命令爆出的物品支持怪物掉落触发[@M2DropItem] , 物品必须在列表信息2的物品规则启用掉落触发才可以触发哦


人物攻击和被攻击掉血前触发、修改当前伤害血量

 功能说明：人物攻击和被攻击掉血前触发、修改当前伤害血量

格式：ChangeDamageValue 类型(0=值,1=百分比) 操作符(+,-,=) 值

注意：当前伤害血量仅用于以下触发

增加伤害前触发：
人物攻击目标掉血前：@AttackDamage
英雄攻击目标掉血前：@HeroAttackDamage
人物被攻击掉血前：@StruckDamage
英雄被攻击掉血前：@HeroStruckDamage

增加NPC变量，当前伤害掉血量（仅用于以下触发）：<$DamageValue> <$H.DamageValue>

[@AttackDamage]
#ACT
SENDMSG 6 人物攻击目标，掉血量为<$DamageValue>，攻击加成10点血量
ChangeDamageValue 0 + 10

[@HeroAttackDamage]
#ACT
SENDMSG 6 英雄攻击目标，掉血量为<$H.DamageValue>，攻击加成10点血量
H.ChangeDamageValue 0 + 10

[@StruckDamage]
#ACT
SENDMSG 6 人物被攻击，掉血量为<$DamageValue>，抵御掉血量的50%
ChangeDamageValue 1 - 50

[@HeroStruckDamage]
#ACT
SENDMSG 6 英雄被攻击，掉血量为<$H.DamageValue>，抵御掉血量的50%
H.ChangeDamageValue 1 - 50


人物释放技能前自身触发

功能说明：当人物使用技能前，自身触发

;触发字段
[@BeginMagic]
;变量
<$MagicID>
<$MagicName>
<$MagicTarget>
<$MagicTargetRace>
;操作命令
中断技能使用命令:StopMagic

范例:
[@BeginMagic]
#IF
EQUAL <$MagicName> 野蛮冲撞
EQUAL <$MagicTargetRace> 0
<$MagicTarget>.CheckFenghao 不动如山
#ACT
StopMagic
Sendmsg 7 目标拥有称号不动如山,无法对其释放野蛮冲撞.

------------------------------------------

英雄使用技能前，自身触发：
@H.BeginMagic

变量：
<$H.MagicID>
<$H.MagicName>
<$H.MagicTarget>
<$H.MagicTargetRace>

[@BeginMagic]
#IF
#ACT
;N998 N999 是获取鼠标游戏地图坐标的变量，请不要再服务端中使用这2个变量
;<$MouseX> <$MouseY>是获取鼠标游戏窗口坐标变量
SENDMSG 5 鼠标窗口坐标为变量为：<$MouseX> <$MouseY>
SENDMSG 5 鼠标游戏地图坐标为变量为：<$STR(N998)> <$STR(N999)>

;操作命令
中断技能使用命令:H.StopMagic支持

范例:
[@H.BeginMagic]
#if
equal <$H.MagicName> 英雄雷电术
#act
H.StopMagic
#elseact
sendmsg 6 英雄技能（ID：<$H.MagicID>；技能：<$H.MagicName>；目标：<$H.MagicTarget>；目标类型：<$H.MagicTargetRace>）


人物在线改名系统

-----------------------------------人物在线改名------------------------------
[@Main]
<我要改名/@@InputString2(请输入新的名称：)>\

[@InputString2]
#IF
Equal S2
#ACT
SENDMSG 6 请输入一个正确的名称
Break

#OR
CheckStringlength S2 > 14
CheckStringlength S2 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break

#IF
#ACT
CHANGEHUMNAME S2

-------------------------以下是同步修改文本命令使用相关解释----------------------------------------------------

ChangeHumNameFile 文件名 是否绝对路径(1:绝对路径; 0或空：相对路径) 前缀 后缀

ChangeHumNameFile ..\QuestDiary\会员名单.txt

特别注意：如果是修改自定义变量中的的角色名字 请注意填写是否绝对路径参数!(凡是调用最后的参数，那么前面参数必须完整，如果只需要前面的后面则可以留空)

ChangeHumNameFile ..\QuestDiary\玩家数据\杀人数.txt 0 [ ]

修改如下格式文件（abcd是角色名）：
[abcd]
杀人数=1

-------------------以下是QF脚本----------------------------------------------------------

QFunction-0.txt脚本相关触发

[@ChangeingHumName]
正在修改请稍后。。。\ \
<关闭/@exit>\

[@ChangeHumNameOK]
#ACT
;这个命令是用来修改，你的变量保存文件和人物名称列表文件里面的人物名称的，如果没有这些可以不使用这个命令
;这个命令也只能放在这个地方，放其他地方无效
CHANGEHUMNAMEFILE ..\QuestDiary\变量文件\HQCQASave.txt 0 [ ]
CHANGEHUMNAMEFILE ..\QuestDiary\会员名称.txt
#SAY
你的名字修改成功，旧名称：<$USERNAME> 新名称：<$USERNEWNAME>\ \
<关闭/@exit>\

[@NameLengthFail]
名字长度不允许超过30个字符！\ \
<关闭/@exit>\

[@HumNameFilter]
该名字存在非法字符！\ \
<关闭/@exit>\

[@HumNameExists]
该名字已经被其他玩家占用，请选择其他名字\ \
<关闭/@exit>\

[@ChangeHumNameFail]
改名失败！\ \
<关闭/@exit>\


人物注册资料变量显示

<$USERID> 当前ID
<$PASSWORD> 账号的密码
<$USERNAME> 当前角色名
<$BIRTHDAY> 注册账号时用户输入的生日
<$ACCOUNTUSERNAME> 注册账号填写的姓名
<$QUIZ1> 注册账号时用户输入的问题1
<$ANSWER1> 注册账号时用户输入的答案1
<$QUIZ2> 注册账号时用户输入的问题2
<$ANSWER2> 注册账号时用户输入的答案2
<$PHONE> 注册账号时用户输入的电话
<$MOBILEPHONE> 注册账号时用户输入的手机
<$EMAIL> 注册账号时用户输入的邮箱


人型怪物设置方法[!]

功能：人型怪物设置方法
格式：无
说明：无
例：

1、在Envir目录下增加MonUseItems目录，放置怪的配置文件，见MonUseItems目录

2、Monster.DB范例：
战士;150;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;450;1;0;450;5000;
法师;150;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;
道士;150;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;

3、此类怪物支持暴背包物品(MonItems目录下建立暴物品列表)，同时支持暴身上物品(MonUseItems目录，见MonUseItems目录)

4、1221新增挖取列表文本，该文本放在MonUseItems目录下，命令规则为 怪物名称-Item.txt
挖取列表文本的设置方法，跟设置普通怪物的爆率一样

注意：如果觉得怪物速度太慢！可以自己调节怪物的攻击速度。走动速度。防御等等！！！！增加新怪，RACE=60

示例：

Monster.DB范例：
战士;150;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;450;1;0;450;5000;
法师;150;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;
道士;150;19;0;198;0;100;5000;0;1000;1000;0;0;0;0;88;45;750;1;0;750;5000;

MonUseItems文件夹下：

道士.TXT
道士-Item.TXT //挖取列表文本

设置内容如下：

[Info]
;是不是掉装备，1=掉，0=不掉
DropUseItem=1

;掉装备几率
DropUseItemRate=100

;职业
Job=2
;性别
Gender=0
;头发
Hair=5
;使用魔法
UseSkill=神圣战甲术,幽灵盾,灵魂火符,施毒术,群体施毒术,无极真气,

;被挖取时可以挖到身上装备的几率，否则挖取挖取列表当中的物品，数字越大，机率越小(无论是否成功，都将会收取费用)
ButchUserItemRate=2

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率0为百分百，数字越大，机率越小(无论是否成功，都将会收取费用)
;请注意，就算这里设置为0也不一定就百分百成功，因为系统还要随机取人型怪身上装备位置，所以如果取到的位置没有装备也会失败
ButchRate=10

;挖取身上装备收费模式(0金币，1元宝，2金刚石，3灵符)
ButchChargeClass=3

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=光芒道袍(男)
;武器
UseItems1=玄天
;照明物
UseItems2=
;项链
UseItems3=光芒项链
;头盔
UseItems4=天龙盔
;左手镯
UseItems5=光芒护腕
;右手镯
UseItems6=光芒护腕
;左戒指
UseItems7=光芒道戒
;右戒指
UseItems8=光芒道戒
;物品
UseItems9=护身符(大)
;腰带
UseItems10=光芒腰带
;鞋子
UseItems11=光芒道靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠

=============================================================

法师.txt
法师-Item.TXT //挖取列表文本

设置如下：

[Info]
;是不是掉装备，1=掉，0=不掉
DropUseItem=1

;掉装备几率
DropUseItemRate=100

;职业
Job=1
;性别
Gender=1
;头发
Hair=1
;使用魔法
UseSkill=雷电术,冰咆哮,抗拒火环,火墙,地狱雷光,圣言术,魔法盾,灭天火,火龙气焰,

;被挖取时可以挖到身上装备的几率，否则挖取挖取列表当中的物品，数字越大，机率越小(无论是否成功，都将会收取费用)
ButchUserItemRate=2

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率0为百分百，数字越大，机率越小(无论是否成功，都将会收取费用)
;请注意，就算这里设置为0也不一定就百分百成功，因为系统还要随机取人型怪身上装备位置，所以如果取到的位置没有装备也会失败
ButchRate=10

;挖取身上装备收费模式(0金币，1元宝，2金刚石，3灵符)
ButchChargeClass=3

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=魔法长袍(女)
;武器
UseItems1=镇天
;照明物
UseItems2=
;项链
UseItems3=烈焰项链
;头盔
UseItems4=魔龙盔
;左手镯
UseItems5=烈焰护腕
;右手镯
UseItems6=烈焰护腕
;左戒指
UseItems7=烈焰魔戒
;右戒指
UseItems8=烈焰魔戒
;物品
UseItems9=
;腰带
UseItems10=烈焰腰带
;鞋子
UseItems11=烈焰魔靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠

======================================================================

战士.txt
战士-Item.TXT //挖取列表文本

设置如下：

[Info]
;是不是掉装备，1=掉，0=不掉
DropUseItem=1

;掉装备几率
DropUseItemRate=100

;职业
Job=0
;性别
Gender=0
;头发
Hair=5
;使用魔法
UseSkill=烈火剑法,半月弯刀,刺杀剑术,狮子吼,彻地钉,擒龙手,

;被挖取时可以挖到身上装备的几率，否则挖取挖取列表当中的物品，数字越大，机率越小(无论是否成功，都将会收取费用)
ButchUserItemRate=2

;是否允许挖取身上装备 1=是，0=否
ButchUseItem=1

;挖取身上装备机率0为百分百，数字越大，机率越小(无论是否成功，都将会收取费用)
;请注意，就算这里设置为0也不一定就百分百成功，因为系统还要随机取人型怪身上装备位置，所以如果取到的位置没有装备也会失败
ButchRate=10

;挖取身上装备收费模式(0金币，1元宝，2金刚石，3灵符)
ButchChargeClass=3

;挖取身上装备每次收费点数
ButchChargeCount=1

[UseItems]
;衣服
UseItems0=雷霆战甲(男)
;武器
UseItems1=开天
;照明物
UseItems2=
;项链
UseItems3=雷霆项链
;头盔
UseItems4=圣龙盔
;左手镯
UseItems5=雷霆护腕
;右手镯
UseItems6=雷霆护腕
;左戒指
UseItems7=雷霆战戒
;右戒指
UseItems8=雷霆战戒
;物品
UseItems9=
;腰带
UseItems10=雷霆腰带
;鞋子
UseItems11=雷霆战靴
;宝石
UseItems12=气血石(大)
;斗笠
UseItems13=斗笠


容器

Npc对话框元素增加编号及容器编号:
图层：Layout:X:Y:宽度:高度:边框颜色 （边框颜色:不填此字段或小于0时，不显示边框，0-255为指定边框颜色，边框颜色用于排版中辅助，当排款完成后即可取消）
多行文字：MText:X:Y:颜色:第一行文字|第二行文字|第三行文字
换行：NewLine: (主要用于容器中：<NewLine:#L01~>容器#L01中强行换行，因为\符不支持容器）

所有的元素支持编号及上层容器编号（编号段可为空，上层容器编号可为空，本元素编号也可以为空）：元素:#上层容器编号~#本元素编号:原始格式
注意：★★★★★★★★容器编号必须加#★★★★★★★★，容器支持 Layout、Img、ImgEx、PlayImg、PlayImgEx、itemshow容器中可放所有Npc支持的元素

如：
[@图片容器]
#IF
#ACT
; ui_n.wzl
mov N$资源编号 24
#SAY

-------------#L1中包含#L2；#L2中包含一个Looks-------------------
;元素编号为#L1；一级容器；上层容器为空，即Npc对话框
<Img:~#L1:1241:<$STR(N$资源编号)>:0:0>

;元素编号为#L2；二级容器；上层容器为#L1
<Img:#L1~#L2:1294:<$STR(N$资源编号)>:40:20>

;元素不进行编号；上级容器为#L2
<Looks:#L2~:100:10:0>

[@分列显示]
<&Layout:~#L01:10:20:195:140>
<text:#L01~:第1行1列内容/@main>
<text:#L01~: >

<text:#L01~:第1行2列内容/@main>
<text:#L01~: >

<NewLine:#L01~>
<text:#L01~:第2行1列内容/@main>
<text:#L01~: >

<text:#L01~:第2行2列内容/@main>
<text:#L01~: >

<&Layout:~#L02:205:20:195:140>
<MText:#L02~:0:0:70:第一行文字~~~~~~~|
第二行文字~~~~~~~~~~~~~~|
第三行文字~~~~~~~~~~~~~~！
>

;===============================================================
ListView支持（ListView容器请不要嵌套使用）
ListView:X:Y:宽度:高度:子控件间隔
ListView作为容器，下面的第一层子控件只支持Layout、Img、ImgEx、PlayImg、PlayImgEx、itemshow

ListView格式如下：
ListView:X:Y:宽度:高度:子控件间隔:跳到第几个容器(0开始算):方向(0竖向;1为横向):预留3:预留4:预留5:滚动所在文件:滚动条背景:向上箭头默认:向上箭头移入:向上箭头按下:滑块默认:滑块移入:滑块按下:向下箭头默认:向上箭头移入:向下箭头按下
;示范22编号为ui_Common.wzl
<&ListView:~#L1:0:100:750:280:1:0:0:0:0:0:22:85:9:10:11:6:7:8:12:13:14>

[@ListView]
#IF
#ACT
; NewopUI.Pak
mov N$资源编号 1
#SAY
<ListView:~#L1:0:0:250:150:1>
<Img:#L1~#L10:1800:<$STR(N$资源编号)>:0:0>
<&PlayImg:#L10~:<$STR(N$资源编号)>:1521:8:100:-20:-20>
<&PlayImg:#L10~:<$STR(N$资源编号)>:1560:15:100:30:5>
<&text:#L10~:这是一段测试文字:60:10/@main>

<Img:#L1~#L11:1801:<$STR(N$资源编号)>:0:0>
<Img:#L1~#L12:1802:<$STR(N$资源编号)>:0:0>
<Img:#L1~#L13:1803:<$STR(N$资源编号)>:0:0>
<Img:#L1~#L14:1804:<$STR(N$资源编号)>:0:0>
<Img:#L1~#L15:1805:<$STR(N$资源编号)>:0:0>
<Img:#L1~#L16:1805:<$STR(N$资源编号)>:0:0>
<Img:#L1~#L17:1805:<$STR(N$资源编号)>:0:0>
<Img:#L1~#L18:1805:<$STR(N$资源编号)>:0:0>

;======================================================

竖向例子：
[@main]
#IF
#ACT
MOV N$补丁编号 20 ;ui_n WIL编号
OPENMERCHANTBIGDLG <$str(N$补丁编号)> 122 1 4 0 0 1 588 24 1
GOTO @卡片合成页面展示

[@卡片合成页面展示]
#if
equal <$SCRIPTPARAM1>
#act
mov n$选择内容 0
#ELSEACT
MOV N$选择内容 <$SCRIPTPARAM1>

#if
#act
sendmsg 6 <$str(N$选择内容)>

#if
#say
<Layout:~#B1:20:60:600:26>
<Text:#B1:第0页:0:0/@卡片合成页面展示(0)><Text:#B1: >
<Text:#B1:第1页:0:0/@卡片合成页面展示(1)><Text:#B1: >
<Text:#B1:第2页:0:0/@卡片合成页面展示(2)><Text:#B1: >
<Text:#B1:第3页:0:0/@卡片合成页面展示(3)><Text:#B1: >
<Text:#B1:第4页:0:0/@卡片合成页面展示(4)><Text:#B1: >
<Text:#B1:第5页:0:0/@卡片合成页面展示(5)><Text:#B1: >

; <&ListView:~#L1:15:132:725:390:1>
<&ListView:~#L1:0:100:500:430:1:0:0:0:0:0:11:20:21:22:23:27:28:29:24:25:26>

#IF
EQUAL n$选择内容 0
#ACT
mov S$显示内容
Mov N$物品循环开始 1
Mov n$循环开始 0
While n$循环开始 < 10
INC S$显示内容 <Layout:#L1~#L1<$STR(n$循环开始)>:50:0:725:50>
GOTO @二次循环1
Inc n$循环开始 1
EndWhile
#SAY
<$str(S$显示内容)>

#IF
EQUAL n$选择内容 1
#ACT
mov S$显示内容
Mov N$物品循环开始 1
Mov n$循环开始 0
While n$循环开始 < 20
INC S$显示内容 <Layout:#L1~#L1<$STR(n$循环开始)>:50:0:725:30>
GOTO @二次循环2
Inc n$循环开始 1
EndWhile
#SAY
<$str(S$显示内容)>

#IF
EQUAL n$选择内容 2
#ACT
mov S$显示内容
Mov N$物品循环开始 1
Mov n$循环开始 0
While n$循环开始 < 20
INC S$显示内容 <Layout:#L1~#L1<$STR(n$循环开始)>:50:0:725:50>
GOTO @二次循环3
Inc n$循环开始 1
EndWhile
#SAY
<$str(S$显示内容)>

#IF
EQUAL n$选择内容 3
#ACT
mov S$显示内容
Mov N$物品循环开始 1
Mov n$循环开始 0
While n$循环开始 < 20
INC S$显示内容 <Layout:#L1~#L1<$STR(n$循环开始)>:50:0:725:50>
GOTO @二次循环4
Inc n$循环开始 1
EndWhile
#SAY
<$str(S$显示内容)>

#IF
EQUAL n$选择内容 4
#ACT
mov S$显示内容
Mov N$物品循环开始 1
Mov n$循环开始 0
While n$循环开始 < 20
INC S$显示内容 <Layout:#L1~#L1<$STR(n$循环开始)>:50:0:725:50>
GOTO @二次循环5
Inc n$循环开始 1
EndWhile
#SAY
<$str(S$显示内容)>

#IF
EQUAL n$选择内容 5
#ACT
mov S$显示内容
Mov N$物品循环开始 1
Mov n$循环开始 0
While n$循环开始 < 20
INC S$显示内容 <Layout:#L1~#L1<$STR(n$循环开始)>:50:0:725:50>
GOTO @二次循环6
Inc n$循环开始 1
EndWhile
#SAY
<$str(S$显示内容)>

#IF
EQUAL n$选择内容 6
#ACT
mov S$显示内容
Mov N$物品循环开始 1
Mov n$循环开始 0
While n$循环开始 < 20
INC S$显示内容 <Layout:#L1~#L1<$STR(n$循环开始)>:50:0:725:50>
GOTO @二次循环7
Inc n$循环开始 1
EndWhile
#SAY
<$str(S$显示内容)>

[@二次循环1]
#IF
#ACT
Mov n$循环开始1 0
While n$循环开始1 < 10
INC S$显示内容 <itemshow:#L1<$STR(n$循环开始)>~:<$str(N$物品循环开始)>:0:0:0:1>
inc N$物品循环开始 1
Inc n$循环开始1 1
EndWhile

[@二次循环2]
#IF
#ACT
INC S$显示内容 <text:#L1<$STR(n$循环开始)>~:行数：<$str(N$循环开始)>:0:0:0:1>
Mov n$循环开始1 0
While n$循环开始1 < 5
INC S$显示内容 <text:#L1<$STR(n$循环开始)>~:展示内容<$str(N$物品循环开始)>:0:0:0:1>
inc N$物品循环开始 1
Inc n$循环开始1 1
EndWhile

[@二次循环3]
#IF
#ACT
INC S$显示内容 <text:#L1<$STR(n$循环开始)>~:行数：<$str(N$循环开始)>:0:0:0:1>
Mov n$循环开始1 0
While n$循环开始1 < 5
INC S$显示内容 <Img:#L1<$STR(n$循环开始)>~:<$str(N$物品循环开始)>:9:0:0>
inc N$物品循环开始 1
Inc n$循环开始1 1
EndWhile

[@二次循环4]
#IF
#ACT
INC S$显示内容 <text:#L1<$STR(n$循环开始)>~:行数：<$str(N$循环开始)>:0:0:0:1>
Mov n$循环开始1 0
While n$循环开始1 < 5
INC S$显示内容 <ImgEX:#L1<$STR(n$循环开始)>~:9:1<$str(N$物品循环开始)>:1<$str(N$物品循环开始)>:1<$str(N$物品循环开始)>>
inc N$物品循环开始 1
Inc n$循环开始1 1
EndWhile

[@二次循环5]
#IF
#ACT
INC S$显示内容 <text:#L1<$STR(n$循环开始)>~:行数：<$str(N$循环开始)>:0:0:0:1>
Mov n$循环开始1 0
While n$循环开始1 < 5
INC S$显示内容 <PlayImg:#L1<$STR(n$循环开始)>~:9:<$str(N$物品循环开始)>:10:50:0:35>
inc N$物品循环开始 1
Inc n$循环开始1 1
EndWhile

[@二次循环6]
#IF
#ACT
INC S$显示内容 <text:#L1<$STR(n$循环开始)>~:行数：<$str(N$循环开始)>:0:0:0:1>
Mov n$循环开始1 0
While n$循环开始1 < 5
INC S$显示内容 <PlayImgEx:#L1<$STR(n$循环开始)>~:9:1<$str(N$物品循环开始)>:10:50:0:35>
inc N$物品循环开始 1
Inc n$循环开始1 1
EndWhile

;======================================================

横向例子：
[@main]
#IF
#ACT
;11为默认的NewopUI.Pak文件
MOV N$补丁编号 11
OPENMERCHANTBIGDLG <$str(N$补丁编号)> 108 1 4 0 0 1 621 0 1
GOTO @卡片合成页面展示

[@卡片合成页面展示]
;容器加载编号为#L1 注意前面有~符号
;22为ui_Common.wzl
<ListView:~#L1:1:65:596:236:5:0:1:0:0:0:22:76:82:83:84:86:87:88:79:80:81>
;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L10:0:0:60:236>
<&PlayImg:#L10~:20:1900:8:100:10:0:1>
<&itemshow:#L10~:101:0:10:60:1>
<&itemshow:#L10~:102:0:10:120:1>
<&itemshow:#L10~:103:0:10:180:1>
<&text:#L10~:33000:18:42/FCOLOR=222>
<&text:#L10~:32000:18:102/FCOLOR=222>
<&text:#L10~:27000:18:162/FCOLOR=222>
<&text:#L10~:34000:18:222/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L11:0:0:60:236>
<&itemshow:#L11~:102:0:10:0:1>
<&itemshow:#L11~:103:0:10:60:1>
<&itemshow:#L11~:104:0:10:120:1>
<&itemshow:#L11~:105:0:10:180:1>
<&text:#L11~:第2列:18:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L12:0:0:60:236>
<&itemshow:#L12~:106:0:10:0:1>
<&itemshow:#L12~:107:0:10:60:1>
<&itemshow:#L12~:108:0:10:120:1>
<&itemshow:#L12~:109:0:10:180:1>
<&text:#L12~:第3列:18:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L13:0:0:60:236>
<&itemshow:#L13~:110:0:10:0:1>
<&itemshow:#L13~:111:0:10:60:1>
<&itemshow:#L13~:112:0:10:120:1>
<&itemshow:#L13~:113:0:10:180:1>
<&text:#L13~:第4列:18:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L14:0:0:60:236>
<&itemshow:#L14~:114:0:10:0:1>
<&itemshow:#L14~:115:0:10:60:1>
<&itemshow:#L14~:116:0:10:120:1>
<&itemshow:#L14~:117:0:10:180:1>
<&text:#L14~:第5列:18:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L15:0:0:60:236>
<&itemshow:#L15~:118:0:10:0:1>
<&text:#L15~:第6列:18:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L16:0:0:60:236>
<&itemshow:#L16~:119:0:10:0:1>
<&itemshow:#L16~:120:0:10:60:1>
<&itemshow:#L16~:121:0:10:120:1>
<&itemshow:#L16~:122:0:10:180:1>
<&text:#L16~:第7列:18:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L17:0:0:60:236>
<&itemshow:#L17~:123:0:10:0:1>
<&itemshow:#L17~:124:0:10:60:1>
<&itemshow:#L17~:125:0:10:120:1>
<&itemshow:#L17~:126:0:10:180:1>
<&text:#L17~:第8列:18:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L18:0:0:60:236>
<&itemshow:#L18~:127:0:10:0:1>
<&itemshow:#L18~:128:0:10:60:1>
<&itemshow:#L18~:129:0:10:120:1>
<&itemshow:#L18~:130:0:10:180:1>
<&text:#L18~:第9列:18:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L19:0:0:60:236>
<&itemshow:#L19~:131:0:10:0:1>
<&itemshow:#L19~:132:0:10:60:1>
<&itemshow:#L19~:133:0:10:120:1>
<&itemshow:#L19~:134:0:10:180:1>
<&text:#L19~:第10列:16:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L20:0:0:60:236>
<&itemshow:#L20~:135:0:10:0:1>
<&itemshow:#L20~:136:0:10:60:1>
<&itemshow:#L20~:137:0:10:120:1>
<&itemshow:#L20~:138:0:10:180:1>
<&text:#L20~:第11列:16:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L21:0:0:60:236>
<&itemshow:#L21~:145:0:10:0:1>
<&itemshow:#L21~:146:0:10:60:1>
<&itemshow:#L21~:147:0:10:120:1>
<&itemshow:#L21~:148:0:10:180:1>
<&text:#L21~:第12列:16:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L22:0:0:60:236>
<&itemshow:#L22~:150:0:10:0:1>
<&itemshow:#L22~:151:0:10:60:1>
<&itemshow:#L22~:152:0:10:120:1>
<&itemshow:#L22~:153:0:10:180:1>
<&text:#L22~:第13列:16:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L23:0:0:60:236>
<&itemshow:#L23~:160:0:10:0:1>
<&itemshow:#L23~:161:0:10:60:1>
<&itemshow:#L23~:162:0:10:120:1>
<&itemshow:#L23~:163:0:10:180:1>
<&text:#L23~:第14列:16:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L24:0:0:60:236>
<&itemshow:#L24~:170:0:10:0:1>
<&itemshow:#L24~:171:0:10:60:1>
<&itemshow:#L24~:172:0:10:120:1>
<&itemshow:#L24~:173:0:10:180:1>
<&text:#L24~:第15列:16:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L25:0:0:60:236>
<&itemshow:#L25~:180:0:10:0:1>
<&itemshow:#L25~:181:0:10:60:1>
<&itemshow:#L25~:182:0:10:120:1>
<&itemshow:#L25~:183:0:10:180:1>
<&text:#L25~:第16列:16:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L26:0:0:60:236>
<&itemshow:#L26~:190:0:10:0:1>
<&itemshow:#L26~:191:0:10:60:1>
<&itemshow:#L26~:192:0:10:120:1>
<&itemshow:#L26~:193:0:10:180:1>
<&text:#L26~:第17列:16:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------
<&Layout:#L1~#L27:0:0:60:236>
<&itemshow:#L27~:200:0:10:0:1>
<&itemshow:#L27~:201:0:10:60:1>
<&itemshow:#L27~:202:0:10:120:1>
<&itemshow:#L27~:203:0:10:180:1>
<&text:#L27~:第19列:16:42/FCOLOR=222>

;-----------------------------------------------------------------------------------------

;======================================================

注意事项
ListView 参数0 以~符号为分界线 前面是子控件 后面是父控件
~#L1 这个参数为~开头#L1为#L1是 父控件
如果是#L1~#L2 #L1为上级控件 #L2是下级控件
参数0是新增项目
可以在其他NPC显示内容参数0可以附加

如
<text:#L1~#L2:内容>
<text:#L1~:内容>
<Img:#L1~#L3:图片:WIL序号>
<Img:#L1~:图片:WIL序号>
所有其他NPC显示内容参数0都可以附加
且可以附加~#L2为父控件

<text:#L2~:内容2>

ListView 参数
~#L1 控件ID
参数1 坐标X
参数2 坐标Y
参数3 容器宽度
参数4 容器高度
参数5 子控件间隔
参数6 跳到第几个容器(0开始计算)
参数7 滑动方向(0竖向，1横向)
参数8 预留3
参数9 预留4
参数10 预留5
参数11 滚动跳所在文件Wzl
参数12 滚动条背景序号
参数13 向上箭头默认图片序号
参数14 向上箭头鼠标经过图片序号
参数15 向上箭头鼠标按下图片序号
参数16 滚动条默认图片序号
参数17 滚动条鼠标经过图片序号
参数18 滚动条鼠标按下图片序号
参数19 向下箭头默认图片序号
参数20 向下箭头鼠标经过图片序号
参数21 向下箭头鼠标按下图片序号


伤害吸收装备设置

功能：伤害吸收装备设置
格式：无
说明：无

*请使用元素的"伤害吸收”


设置怪物爆率倍数[!]

功能：
设置杀怪爆率倍数

格式：
KILLMONBURSTRATE 倍率（实际倍率除以100）有效时间(时间为0或者为空时表示在线一直有效) 参数3 为0时下线不保存 为1时下线保存爆率倍数 ,参数4：0或者留空为给予时候提示，1为给予时候不提示（普遍用于登录触发防止提示二次）
倍率 为杀怪爆率倍数，倍数除以100为真正的倍率(200 为 2 倍爆率，150 为1.5倍) 支持变量操作

<$KILLMONBURSTRATE> 人物杀怪暴率倍数;
<$KILLMONBURSTRATETIME> 人物杀怪暴率倍数时间

;==========================================
[@KILLMONBURSTRATE]
#IF
#ACT
KILLMONBURSTRATE 200 600 1
#SAY
您当前杀怪爆率倍数 两倍 时长600秒 下线保存爆率倍数
;==========================================

200 为除以2
如
1/100 麻痹戒指
2倍后为：
1/50 麻痹戒指
因为涉及到元素也有爆率倍数，将脚本命令的爆率倍丢在最前面计算。如果有元素爆率那么再从脚本命令的1/50 再进行计算！

[@KILLMONBURSTRAT]
#IF
#ACT
KILLMONBURSTRATE 200 0 1
#SAY
您当前怪物爆率倍数为 2倍，有效时间永久 就算服务器重启也有效 参数3为0时 小退倍数消失

注：因为涉及到元素也有爆率倍数，将脚本命令的爆率倍丢在最前面计算。

如最终爆率1/45计算方式：
物品掉落几率是 1/100，角色的元素爆率增加为 10%，命令爆率倍数为2，那么物品的掉落几率为 1/100 * 2 = 1/(50*90%) = 1/45


数字转换为图片显示标签

功能：
数字转换为图片显示标签.

格式：

NPC对话框将数字转换为图片显示：
<ImgNum: 数字类型(0-9): 数字值: 字符间隔: X:Y:D | 提示信息/@脚本触发>

数字值支持变量 NPC对话框 ，不支持负数！！！！

X=X坐标
Y=Y坐标
D=输入框的ID列表，用','分隔开，所有用*表示 （本参数为20170407扩展，不适用可以不填写，如果图片要用于提交输入的内容，就必须要填）
列子：

<ImgNum:9:1234:-3:0:0|提示信息/@测试>

=====================================================设置NPC文字坐标===================================

<text:文字内容:X:Y/@触发>
<Text:测试下这段文字的显示|提示信息:10:20/@测试>
<Text:<$STR(S87)>|提示信息:10:20{FCOLOR=250}/@测试>
<Text:测试下这段文字的显示|提示信息:10:20{FCOLOR=254}/@测试>
<Text:测试下这段文字的显示|提示信息:10:20{AUTOCOLOR=250,251,252,253,254}/@测试>

图片位置：NewopUI.pak 1230开始---1329结束


天气效果[!]

功能：天气效果
格式：无
说明：无
例：

地图参数 DARK 黑暗效果
地图参数 DAY 白天效果
如果同时存在以DAY参数效果为准

以下三个效果读取客户端的Effect_EX.Wil和Effect_SE.Wil如果客户端没有这2个文件，效果显示不了

增加天气效果脚本命令SETWEATHEREFFECT
格式:SETWEATHEREFFECT 地图号 天气效果(0=关闭天气效果 1=黄沙效果 2=花瓣效果 3=下雪效果 扩展为4-21) 有效时间(秒) 是否黑暗(0正常 1黑暗) wav\音乐文件.后缀(文件名长度不超过50)

示列1:脚本格式:SETWEATHEREFFECT 3 3 600 0 wav\刮风声音.wav
脚本解释： 土城 下雪效果 时间10分钟 屏幕不暗 读取客户端wav内的刮风声音.wav) --如声音文件不存在客户端不会播放声音

示列2:脚本格式:SETWEATHEREFFECT 3 3 600 (地图3 播放下雪效果 持续时间10分钟 ,后面参数如全不填写默认为不黑暗和不播放音乐 )

------------------------------------------以下为扩展------------------------------------------------------------------------------

天气效果扩展:Effect_Weather.wzl
扩展一个文件特效为Effect_Weather.wzl 每30张图片为一组天气特效,特效代码为 4-21 如制作的图片不足30张可重复导入为30张即可.

特效代码4为Effect_Weather.wzl图片编号0-29,5为30-59以此类推...使用方法同上,如客户端无此补丁则显示不了效果.

注:地图变暗可用于下雨效果..


天使翼翅膀

说明: 天使翼翅膀

天使翼 代码：29

天使翅膀，勋章外观绘制：Horse （1: 普通绘制，2:不分男女（只针对Shape>=1000），组合自己相加）
0:透明分男女，1：普通分男女，2：透明不分男女，3普通不分男女

1376 天使翅膀1 29 1000 1 0 0 0 4762 5000000 1 2 3 4 5 6 7 8 9 10 0 0 13 14 255 0 17 18 1300 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0


天下第一雕像相关说明

天下第一雕像相关变量
雕像更新人：<$NPCSETUSER> \
雕像更新人等级：<$NPCSETLEVEL> \

天下第一雕像命令
功能：塑造人物当前形象为雕像
命令： SetNpcImage 编号(编号-1：雕像破碎) 是否彩色（0或空为黑白，其他值为彩色) 是否原始大小（0为放大,1为原始大小）
SetNpcImage 40 1 1 示例：

[@造形]
#IF
#ACT
SetNpcImage 40
MESSAGEBOX 恭喜，雕像打造成功！

[@造形1]
#IF
#ACT
SetNpcImage 40 1
MESSAGEBOX 恭喜，雕像打造成功！

[@破碎]
#IF
#ACT
SetNpcImage -1
MESSAGEBOX 您的雕像已经破碎！

----------------------------------------设置雕像有效时间---------------------------------------------------------------------------------------
SetNpcImageTime 操作符（=，+，-） 时间（为空，小于或等于0为永久有效，大于0为指定分钟） ，附：塑造雕像时候不用此命令为无时间限制，因为符合了小于0或等于0或为空

注意此命令只可以在ARP为273的NPC使用！！！！

示列：

[@SetNpc]
#IF
#ACT
SetNpcImageTime + 600
SendMsg 5 雕像维护成功，时间增加10小时！
======================================天下第一男战士简单示例===========================================================================

MerChant.txt 添加：
天下第一/天下第一男战士 3 366 338 天下第一男战士 0 273 0 0 0 0 0 天下第一男战士.txt

注：最后的天下第一男战士.txt表示当前天下第一信息保存文本名称，前方的5个0(第6个参数为保存名，可任意数,请勿重名冲突)表示NPC原始就拥有的参数配置，将天下第一男战士.txt放在最后就行了，保存路径为：Envir\Npc_Data

[@天下第一男战士]
#IF
EQUAL A2 <$USERNAME>
#SAY
  请问你需要进行什么操作？\ \
你申请时的信息\
  申请人物名称：<$STR(A2)>\
  申请人物等级：<$STR(G7)>\
  申请人物攻击：<$STR(G8)>\
  保持纪录时间：<$STR(G11)>\
  上次维护时间：<$STR(G9)>\ \
<更换形像/@天下第一更换形像>\
<关闭/@exit>\
#ELSESAY
  想为自己树立一尊雕像吗？从此扬名天\
下！现在机会来了，赶快申请吧！\
  申请成功后，可以自由设定雕像的样子\
  --------------------------------\
  申请人物名称：<$STR(A2)>\
  申请人物等级：<$STR(G7)>\
  申请人物攻击：<$STR(G8)>\
  --------------------------------\ \
<我要申请天下第一战圣（男）/@天下第一我要申请>\ <关闭/@exit>\

[@天下第一我要申请]
#IF
equal A3 <$USERNAME>
#act
MESSAGEBOX 你已经是天下第一法神(男)了，不能再申请！！
Break

#IF
equal A4 <$USERNAME>
#act
MESSAGEBOX 你已经是天下第一道尊(男)了，不能再申请！！
Break

#IF
equal A14 <$USERNAME>
#act
MESSAGEBOX 你已经是天下第一战圣(女)了，不能再申请！！
Break

#IF
equal A15 <$USERNAME>
#act
MESSAGEBOX 你已经是天下第一法神(女)了，不能再申请！！
Break

#IF
equal A16 <$USERNAME>
#act
MESSAGEBOX 你已经是天下第一道尊(女)了，不能再申请！！
Break

#IF
CHECKJOB Warrior
GENDER MAN
#ACT
Goto @申请检测
#ELSEACT
MESSAGEBOX 失败，只有男战士才能申请！
Break

[@申请检测]
#IF
NOT LARGE G8 <$MAXDC>
#ACT
Goto @天下第一申请成功
Break

#IF
NOT LARGE G8 <$MAXDC>
CHECKLEVELEX > <$STR(G7)>
#ACT
Goto @天下第一申请成功
#ELSEACT
MESSAGEBOX 申请失败，你的攻击力还没有超过他！
Break

[@天下第一申请成功]
#IF
#SAY
  恭喜你，申请成功！你现在可以对雕像\
进行维护、管理，以及设定造形。\ \
需要重新申请。\ \
<关闭/@exit>\
#ACT
MOV A2 <$USERNAME>
MOV G7 <$LEVEL>
MOV G8 <$MAXDC>
SetNpcImage 40
SENDMSG 0 【公告】：[<$USERNAME>]成功申请了天下第一战圣(男)，申请时等级(<$STR(G7)>)，攻击力(<$STR(G8)>)。天下第一拥有上线1.2倍攻击特权！
POWERRATE 120 9999
Break

[@天下第一更换形像]
  雕像的形象是根据人物当前的信息实时\
显示的。雕像的衣服、武器和发型是根据\
你当前的装备情况来显示。\ \
  此外，你还可以自由把雕像设定为三种\
攻击姿势。请打造雕像吧：\ \
<攻击造形一/@攻击造形一>\
<攻击造形二/@攻击造形二>\
<攻击造形三/@攻击造形三>\
<站立造形/@站立造形>\
<走路造形/@走路造形>\
<跑步造形/@跑步造形>\
<关闭/@exit>\

[@攻击造形一]
#IF
EQUAL A2 <$USERNAME>
#ACT
SetNpcImage 240
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

[@攻击造形二]
#IF
EQUAL A2 <$USERNAME>
#ACT
SetNpcImage 436
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

[@攻击造形三]
#IF
EQUAL A2 <$USERNAME>
#ACT
SetNpcImage 514
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

[@站立造形]
#IF
EQUAL A2 <$USERNAME>
#ACT
SetNpcImage 40 1 1
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

[@走路造形]
#IF
EQUAL A2 <$USERNAME>
#ACT
SetNpcImage 107 1 0
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

[@跑步造形]
#IF
EQUAL A2 <$USERNAME>
#ACT
SetNpcImage 173
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

}

======================================英雄天下第一男战士简单示例===========================================================================

命令如果说明书没有独立的，那么一般均是人物命令加H. ，脚本变量没独立的话，一般也是人物变量加H.

[@main]
#IF
EQUAL A2 <$HERONAME>
#SAY
  请问你需要进行什么操作？\ \
你申请时的信息\
  申请人物名称：<$STR(A2)>\
  申请人物等级：<$STR(G7)>\
  申请人物攻击：<$STR(G8)>\
  保持纪录时间：<$STR(G11)>\
  上次维护时间：<$STR(G9)>\ \
<更换形像/@天下第一更换形像>\
<关闭/@exit>\
#ELSESAY
  想为自己树立一尊雕像吗？从此扬名天\
下！现在机会来了，赶快申请吧！\
  申请成功后，可以自由设定雕像的样子\
  --------------------------------\
  申请人物名称：<$STR(A2)>\
  申请人物等级：<$STR(G7)>\
  申请人物攻击：<$STR(G8)>\
  --------------------------------\ \
<我要申请天下第一战圣（男）/@天下第一我要申请>\ <关闭/@exit>\

[@天下第一我要申请]
#IF
equal A3 <$HERONAME>
#act
MESSAGEBOX 你已经是天下第一法神(男)了，不能再申请！！
Break

#IF
equal A4 <$HERONAME>
#act
MESSAGEBOX 你已经是天下第一道尊(男)了，不能再申请！！
Break

#IF
equal A14 <$HERONAME>
#act
MESSAGEBOX 你已经是天下第一战圣(女)了，不能再申请！！
Break

#IF
equal A15 <$HERONAME>
#act
MESSAGEBOX 你已经是天下第一法神(女)了，不能再申请！！
Break

#IF
equal A16 <$HERONAME>
#act
MESSAGEBOX 你已经是天下第一道尊(女)了，不能再申请！！
Break

#IF
CheckHeroOnline
CheckHeroJob Warrior
H.GENDER MAN
#ACT
Goto @申请检测
#ELSEACT
MESSAGEBOX 失败，只有男战士才能申请！
Break

[@申请检测]
#IF
NOT LARGE G8 <$H.MAXDC>
#ACT
Goto @天下第一申请成功
Break

#IF
NOT LARGE G8 <$H.MAXDC>
H.CHECKLEVELEX > <$STR(G7)>
#ACT
Goto @天下第一申请成功
#ELSEACT
MESSAGEBOX 申请失败，你的攻击力还没有超过他！
Break

[@天下第一申请成功]
#IF
#SAY
  恭喜你，申请成功！你现在可以对雕像\
进行维护、管理，以及设定造形。\ \
需要重新申请。\ \
<关闭/@exit>\
#ACT
MOV A2 <$HERONAME>
MOV G7 <$H.LEVEL>
MOV G8 <$H.MAXDC>
H.SetNpcImage 40
SENDMSG 0 【公告】：[<$HERONAME> ]成功申请了天下第一战圣(男)，申请时等级(<$STR(G7)>)，攻击力(<$STR(G8)>)。天下第一拥有上线1.2倍攻击特权！
H.POWERRATE 120 9999
Break

[@天下第一更换形像]
  雕像的形象是根据人物当前的信息实时\
显示的。雕像的衣服、武器和发型是根据\
你当前的装备情况来显示。\ \
  此外，你还可以自由把雕像设定为三种\
攻击姿势。请打造雕像吧：\ \
<攻击造形一/@攻击造形一>\
<攻击造形二/@攻击造形二>\
<攻击造形三/@攻击造形三>\
<站立造形/@站立造形>\
<走路造形/@走路造形>\
<跑步造形/@跑步造形>\
<关闭/@exit>\

[@攻击造形一]
#IF
EQUAL A2 <$HERONAME>
#ACT
H.SetNpcImage 240
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

[@攻击造形二]
#IF
EQUAL A2 <$HERONAME>
#ACT
H.SetNpcImage 436
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

[@攻击造形三]
#IF
EQUAL A2 <$HERONAME>
#ACT
H.SetNpcImage 514
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

[@站立造形]
#IF
EQUAL A2 <$HERONAME>
#ACT
H.SetNpcImage 40 1 1
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

[@走路造形]
#IF
EQUAL A2 <$HERONAME>
#ACT
H.SetNpcImage 107 1 0
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

[@跑步造形]
#IF
EQUAL A2 <$HERONAME>
#ACT
H.SetNpcImage 173
MESSAGEBOX 恭喜，雕像打造成功！
#elsesay
[失败]\ \
这座雕像不是您的哦！\
Break

}


添加对话框(可用于主界面任务引导)

功能：
添加对话框(可用于主界面任务引导).

格式: AddDlg 编号(1-50) 图片文件序号 图片编号 是否可移动(0:不能; 1:可以) 界面X:界面Y 文字偏移X:文字偏移Y 位置 内容

参数7 位置：为按钮是否可以移动0=不能移动1=可以移动2=人物装备栏3=人物背包栏4=英雄装备栏5=英雄背包栏6=聊天框左侧龙界面7=聊天框右侧等级界面8=商铺界面9=时装界面,10=英雄时装，11=技能栏，12=英雄技能栏，13=称号栏，14=英雄称号栏，15=状态栏，16=英雄状态栏，17=属性栏，18=英雄属性栏，19=人物出战栏，20=行会界面，21=详细属性位置, 22=宠物界面, 23=宠物背包，24=人物首饰，25=英雄首饰，26=人物神佑，27=英雄神佑 28=查看他人装备，29=查看他人时装，30=查看他人称号，31=查看他人首饰盒，32=查看他人神佑袋，33=M大地图

示列：

[@mail]
#ACT
AddDlg 1 1 440 1 10:20 30:40 0 >翎风引擎官方网站|253#翎风引擎官方网站：^254#www.lfm2.com>\<当前时间：/SCOLOR=251><$DATETIME>\<按钮点击/@1>\<关闭/@exit>

;-------------------------------------------------------------------------------------------

格式:AddDlgEx 编号 图片文件序号 图片编号 是否可移动(0:不能; 1:可以) 界面X:界面Y 文字偏移X:文字偏移Y 位置 文件名 是否绝对路径(0:否;1:是)
示例：
AddDlgEx 1 1 440 1 10:20 30:40 0 d:\d.txt 1

;-------------------------------------------------------------------------------------------

删除对话框：DelDlg

示例：
#IF
#ACT
DelDlg 1 1
说明：参数1为对话框编号(1-50) 参数2(0或空的时删除自己的，1时删除全服用户的)

;-------------------------------------------------------------------------------------------
注意：AddDlg不支持 ITEMBOX: INPUTNUM: INPUTTEXT:
并且点击触发只能是数字

;-------------------------------------------------------------------------------------------

触发：
QFunction-0.txt中的 [@DlgButtonClickN] (N代表数字)

;-------------------------------------------------------------------------------------------

d:\d.txt内容如下:
<翎风引擎官方网站|253#翎风引擎官方网站：^254#www.lfm2.com>\
<当前时间：/SCOLOR=251><$DATETIME>\
<按钮点击/@1>\
<关闭/@exit>

;-------------------------------------------------------------------------------------------

AddDlg AddDlgex对话框支持图片
<翎风引擎官方网站|253#翎风引擎官方网站：^254#www.lfm2.com>\
★<当前时间：/SCOLOR=251><$DATETIME>\
<按钮点击/@1>\\\\
<关闭/@exit>\
\
\
\
<Looks:1:0:0:1|提示/@2>
<dnitems:1:0:0:1|提示/@3>
<stateitem:30:0:0:0|提示/@4>
<newopui:520:0:0|提示/@4>
newopui: 图片序号:X:Y
<ItemShow:1:1:10:0:1/@2>\
<ItemShow:2:1:10:20:1/@2>

looks / dnitems / stateitem
参数1：物品的looks
参数2：X
参数3：Y
参数4：边框(0:无边框; >0: newopui.pak - 250; <0: newopui.pak - 251)


调整宝宝攻击人物的威力倍率

命令格式：
SetSlaveAttackHumPowerRate 宝宝名称 攻击人物威力倍率(0不攻击人物,当前值除以100为实际倍数)

功能说明：调整宝宝攻击人物的威力倍率

示范脚本：

[@main]
#if
CHECKSLAVENAME 神兽
#act
SetSlaveAttackHumPowerRate 神兽 0
sendmsg 6 神兽不攻击人物
#elseact
sendmsg 6 请先把神兽召唤出来

注意：伤害倍数只对人物，和假人、英雄（怪物之外）有效！！！

-------------------------------------以下为调整数值----------------

调整宝宝攻击人物威力值命令 及 获取命令

调整宝宝攻击人物威力（具体数值 比如加50点攻击 + 50）

SetSlaveAttackHumPowerRateEx 宝宝名 操作符(+/-/=) 值

示范脚本：
[@main]
#if
CHECKSLAVENAME 神兽
#act
SetSlaveAttackHumPowerRateEx 神兽 + 50
sendmsg 6 神兽增加50点攻击人物威力
#elseact
sendmsg 6 请先把神兽召唤出来

获取宝宝攻击人物威力
GetSlaveAttackHumPowerRate 宝宝名 变量

[@main]
#if
CHECKSLAVENAME 神兽
#act
GetSlaveAttackHumPowerRate 神兽 N1
sendmsg 6 神兽增加<$STR(N1)>点攻击人物威力
#elseact
sendmsg 6 请先把神兽召唤出来

注意：伤害倍数只对人物，和假人、英雄（怪物之外）有效！！！


调整分身攻击人物的威力倍率

功能说明：调整分身攻击人物的威力倍率

格式：SetSlaveAttackHumPowerRate 分身名称 攻击人物威力倍率(0不攻击人物,当前值除以100为实际倍数)

示范：

#if
CheckSlaveCount > 0 <$UserName> 1
#act
SetSlaveAttackHumPowerRate <$USERNAME> 0
sendmsg 6 分身不攻击人物
#elseact
SENDMSG 5 你没有分身

-----------------------------上面为百分比、以下为数值-------------

调整宝宝、分身攻击人物威力值命令 及获取 （点数值 非百分比）

调整宝宝攻击人物威力（具体数值 比如加50点攻击 + 50）
SetSlaveAttackHumPowerRateEx 宝宝名 操作符(+/-/=) 值

#if
CheckSlaveCount > 0 <$UserName> 1
#act
SetSlaveAttackHumPowerRate <$USERNAME> + 50
sendmsg 6 分身增加50点攻击人物威力
#elseact
SENDMSG 5 你没有分身

获取宝宝攻击人物威力
GetSlaveAttackHumPowerRate 宝宝名 变量

#if
CheckSlaveCount > 0 <$UserName> 1
#act
GetSlaveAttackHumPowerRate <$USERNAME> N1
sendmsg 6 分身增加<$STR(N1)>点攻击人物威力
#elseact
SENDMSG 5 你没有分身


调整人物、英雄、宝宝、怪物体型大小命令

功能: 调整人物、英雄、宝宝、怪物体型大小命令

体型大小为默认大小的百分比，取值(1-255)，100表示100%，即默认大小

修改人物/英雄大小
ChangeBodySize 体型大小 有效时间（秒，空或0 表示不检测时间）

修改宠物大小
ChangeGamePetBodySize 体型大小 有效时间（秒，空或0 表示不检测时间）

修改宝宝大小
ChangeSlaveBodySize 体型大小 宝宝名称(*表示所有) 　有效时间（秒，空或0 表示不检测时间）

修改地图怪物大小
ChangeMapMonBodySize 地图名 X坐标 Y坐标 范围(为3时表示3*3) 怪物名(*不判断) 体型大小(100表示原大小，150表示1.5倍。50表示0.5倍) 有效时间(秒 时间为空则不限制时间)
备注：当X,Y,范围均为0时，表示地图所有范围；此命令仅对怪物操作，不含宝宝／分身

对英雄和英雄宝宝操作请在命令前加H.


文本读取、写入支持绝对路径

功能: 文本读取、写入支持绝对路径<

扩展文本读取、写入等功能 （最后加个参数 1为绝对路径，，0或者留空为默认的相对路径

GetRandomText
AddTextListEx
CHECKTEXTLIST
GETRANDOMLINETEXT
CHECKTEXTLIST ..\QuestDiary\充值系统\10元卡号.txt <$STR(S2)>
默认的相对路径
--------

下面为绝对路径 后面加个参数1
E:\数据文件\充值系统\10元卡号.txt 1

;------------------------------------------

绝对路径支持清空文本内容：
ClearNameList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）
AddNameDateList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）
DelNameDateList 文件名 是否绝对路径（0或空：相对路径；1：绝对路径）

--------------------------------------------2019-01-31更新扩展参数5----------------------------------------------------------------------------------------
CheckTextList 文件名 检测字符串1 检测字符串2(可为空) 是否绝对路径(为空表示相对路径) 是否区分大小写（0或空：不区分； 1：区分）
注：当字符串2可用'' 或 ""表示空
----------------------------------------------------------------------------------------------------------------------------------

----------------------------------------------------------------------------------------------------------------------------------


无限仓库

 (@bigstorage @biggetback @getnextpage @getPreviouspage)
%100
[@main]
您好。我是仓库保管员。这里存放的物品不受限制。\
无论你有多少物品，我这里都可以存放进去。\
<存放物品/@bigstorage>\
<取回物品/@biggetback>\
<离开/@exit>

[@bigstorage]
需要保管什么东西?\ \
<返回/@main>

[@biggetback]
请看目录决定找什么东西.\ \
无限仓库每页刷新50件物品出来，查看所有物品点击下一页\ \
<上一页/@getPreviouspage> <下一页/@getnextpage> \
<返回/@main>

[@getPreviouspage]
#ACT
goto @biggetback

[@getnextpage]
#ACT
goto @biggetback

注：无限仓库可存数量位于M2-功能设置- 个人商店 中设置无限仓库可存放数量！

无限仓库保存在Mir200\M2Data\M2Data.DB内

说明：无限仓库默认可存放数量在M2-功能设置- 个人商店 中设置，如果需要进行额外扩展可以使用以下命令进行增加无限仓库可存放数量

增加无限仓库扩展命令
说明: 调整人物无限制仓库存放物品的数量.
格式: SetBigStorageCount 操作符(+ - =) 数量(0-65535)

检测无限仓库可存放数量脚本：
将无限仓库可存放数量写入变量然后进行检测！
#ACT
GetBigStorageCount N1
SendMsg 5 扩展无限仓库数据为<$STR(N1)>


武器声音、武器音效

自定义武器砍击的声音

数据库配置武器声音 物品数据库字段：Horse，当值为0时表示使用默认声音

武器Horse字段：砍出(空中)声音为低位，打在目标身上为高位 ,提供数据折分合并工具（引擎包/工具文件夹）

数据折分合并工具.exe 用法（专用工具计算数值 ，不自定义目标挨打声音 武器Horse延续以前直接填写,直接填写指定数字即可，需要定义挨打声音则需要工具计算）

当指定值时，读取指定序号的声音：

声音序号对应参考对照：Wav\sound.lst

（例： 乌木剑 Horse=54，则读取Wav\54.wav） 若要添加自己的声音，可以修改Wav\sound.lst空位置或往最后添加 --- 此条说明仅为低位声自定义，需高位声请使用工具计算Horse数值

1: wav\1.wav
2: wav\2.wav
3: wav\3.wav
4: wav\4.wav
5: wav\5.wav
6: wav\6.wav
7: wav\7.wav
8: wav\8.wav
9: wav\9.wav
10: wav\10.wav
11: wav\11.wav
12: wav\12.wav
13: wav\13.wav
14: wav\14.wav
15: wav\15.wav
16: wav\16.wav
17: wav\17.wav
18: wav\18.wav
19: wav\19.wav
20: wav\20.wav
21: wav\21.wav
22: wav\22.wav
23: wav\23.wav
24: wav\24.wav
25: wav\25.wav
26: wav\26.wav
27: wav\27.wav
28: wav\28.wav
29: wav\29.wav
30: wav\30.wav
31: wav\31.wav
32: wav\32.wav
48: wav\M42-2.wav
49: wav\game-over2.wav
50: wav\50.wav
51: wav\51.wav
52: wav\52.wav
53: wav\53.wav
54: wav\54.wav
55: wav\55.wav
56: wav\56.wav

列表左侧为声音序号，如需设置 49: wav\game-over2.wav 那么Horse设置49(低位)即可 ！！！自己新增的声音文件需要将文件放入wav文件夹。然后 记事本打开sound.lst添加，然后将sound.lst集成到登录器即可，声音文件可集成登录器也就可微端更新


物品合成系统[!]

功能：物品合成系统
格式：无
说明：M2: 查看->列表信息2->铸造物品
例：

.

使用说明: 以合成求婚戒指为例:
首先在物品列表中找到求婚戒指,然后点击下面的添加按钮将求婚戒指添加到物品列表中.
接着在左边的物品列表中点击求婚戒指,右边的所需物品列表中的添加按钮处于激活状态后就可以添加合成求婚戒指需要的
材料和装备了.(目前除了StdItems.DB中的物品外还可以直接支持 金币 元宝 声望 能量点) 图中合成求婚戒指需要铜矿5块
银矿金矿各一块.添加完成之后点保存按钮即可.

特别说明: 成功几率=100时合成物品必定成功,99=99%90=90%1=1%的成功率.如果需要更低的成功率那么设置大于100即可,这时设置多少就是多少分之一的成功率例如1000=1/1000的成功率.当合成物品有成功率时,失败消失=1时 如果物品合成失败那么
此物品将会消失,失败消失=0时物品不会消失(另外物品合成成功之后所有所需物品都会消失).

脚本说明: CheckFoundryItem 检测背包中合成物品的材料是否足够 GiveFoundryItem 回收合成材料同时将合成后的物品放入背包.
合成失败后自动执行@FoundryFail段的脚本.合成成功后自动执行@FoundryOK段的脚本

合成求婚戒指脚本如下:
[@Main]
<合成求婚戒指/@合成求婚戒指>\

[@合成求婚戒指]
#IF
CheckFoundryItem 求婚戒指
#ACT
GiveFoundryItem 求婚戒指
#ELSEACT
SendMsg 5 缺少合成物品<%Item>
[@FoundryFail]
#ACT
SendMsg 5 合成 <%Item> 失败!

合成多个物品的脚本可以参考如下脚本(以@FoundryItem_开头后面跟要合成的物品, %FoundryItem是M2自动转换后的合成物品名称):
[@Main]
<合成求婚戒指/@FoundryItem_求婚戒指>   <查看所需物品/@ShowItem_求婚戒指>\
<合成护身戒指/@FoundryItem_护身戒指>   <查看所需物品/@ShowItem_护身戒指\
<合成负载戒指/@FoundryItem_负载戒指>   <查看所需物品/@ShowItem_负载戒指\

[@FoundryItem_]
#IF
CheckFoundryItem %FoundryItem
#ACT
GiveFoundryItem %FoundryItem
#ELSEACT
;SendMsg 5 缺少合成物品<%Item>
ShowFoundryItem %FoundryItem
[@FoundryFail]
#ACT
SendMsg 5 合成 <%Item> 失败!

[@FoundryOK]
;物品合成成功触发
#ACT
SendMsg 5 合成 <%Item> 成功!
break

[@ShowItem_]
<$ShowItem>


物品和武器的扩展算法[!]

功能：物品和武器的扩展算法
格式：无
说明：对装备素材读取进行人性化扩展
例：

武器得外观扩展算法:

Weapon.wzl Shape 1~99
Weapon2.wzl Shape 100~149
Weapon3.wzl Shape 150~199
Weapon4.wzl Shape 200~249
Weapon5.wzl Shape 250~299
Weapon6.wzl Shape 300~349
Weapon7.wzl Shape 350~399
Weapon8.wzl Shape 400~449
Weapon9.wzl Shape 450~499
Weapon10.wzl Shape 500~549
Weapon11.wzl Shape 550-599
Weapon12.wzl Shape 600-649
Weapon13.wzl Shape 650-699
Weapon14.wzl Shape 700-749
Weapon15.wzl Shape 750-799
Weapon16.wzl Shape 800-849
Weapon17.wzl Shape 850-899
Weapon18.wzl Shape 900-949
Weapon19.wz Shape 950-999

==========================================
衣服得外观扩展算法:

Hum.wzl Shape 1~99
Hum2.wzl Shape 100~149
Hum3.wzl Shape 150~199
Hum4.wzl Shape 200~249
Hum5.wzl Shape 250~299
Hum6.wzl Shape 300~349
Hum7.wzl Shape 350~399
Hum8.wzl Shape 400~449
Hum9.wzl Shape 450~499
Hum10.wzl Shape 500~549
Hum11.wzl Shape 550~599
Hum12.wzl Shape 600~649
Hum13.wzl Shape 650~699
Hum14.wzl Shape 700~749
Hum15.wzl Shape 750~799
Hum16.wzl Shape 800~849
Hum17.wzl Shape 850~899
Hum18.wzl Shape 900~949
Hum19.wzl Shape 950~999

==========================================
装备内观 背包 地上显示扩展算法:

Items.wil DnItems.wil StateItem.wil 数据库Looks起始编号0~9999
增加Items1.wil DnItems1.wil StateItem1.wil 数据库Looks起始编号10000~19999
增加Items2.wil DnItems2.wil StateItem2.wil 数据库Looks起始编号20000~29999
增加Items3.wil DnItems3.wil StateItem3.wil 数据库Looks起始编号30000~39999
增加Items4.wil DnItems4.wil StateItem4.wil 数据库Looks起始编号40000~49999
增加Items5.wil DnItems5.wil StateItem5.wil 数据库Looks起始编号50000~59999
增加Items6.wil DnItems6.wil StateItem6.wil 数据库Looks起始编号60000~65534

==========================================
小地图扩展:

mmap.wil读取为1-9900
以下为扩展:
mmap10.wil 10001-15000
mmap11.wil 15001-20000
mmap12.wil 20001-24999

==========================================
NPC扩展:

Npc10.wil Npc代码从1000~1999
Npc11.wil Npc代码从2000~2999
Npc12.wil Npc代码从3000~3999

==========================================
自定义装备和武器读取扩展计算:

武器和衣服时可按照一件武器一个.wil文件的方式配置.
武器放在传奇目录的Resources\Graphics\Weapon\
衣服放在Resources\Graphics\Human\下.
物品数据库中单个武器和衣服的Shape值从1000开始算起.
单个武器和衣服素材的文件名必须和物品数据库中的Shape值一样,
例如:数据库中设置Shape=1000,那么单个武器或者素材的文件就是1000.wil,如果Shape=1001那么文件名就是1001.wil

==========================================
怪物扩展:

monXX.wil 360张图片为一只怪 无限扩展(最大appr数值 65535 ).每10个怪物一个文件 每个怪物360张图

MON100以后扩展怪物的数据库APPR值算法为 (MonXX-1)*10 ，比如MON100.WZL 算法位100-1= 99*10=990 ，MON105.WZL为：105-1= 104*10 = 1040 （每个文件支持10个怪物，每个怪物360张图，详细参考MON3.WZL的格式布局，特殊怪物请使用自定义怪物实现）

建议大家使用扩展怪物使用MON100.WZL开始，MON50-70不要使用！！！

==========================================
Graphics装备:
武器和衣服时可按照一件武器一个.wil文件的方式配置.
武器放在传奇目录的Resources\Graphics\Weapon\
衣服放在Resources\Graphics\Human\下.
物品数据库中单个武器和衣服的Shape值从1000开始算起.
单个武器和衣服素材的文件名必须和物品数据库中的Shape值一样,
例如:数据库中设置Shape=1000,那么单个武器或者素材的文件就是1000.wil,如果Shape=1001那么文件名就是1001.wil

==========================================
  • 新小地图算法

    • ==========================================
    扩展人物发型:
    扩展人物发型Hair10.wzl、Hair11.wzl脚本控制发型 ...计算方式为每600张图为一个发型.每个文件内可放10种发型.分别从50-59 60-69开始算
    扩展按顺序读取如发型值：50 读取Hair10.wzl文件：第1种发型（0-599张图片），发型值：69 读Hair11.wzl第10种发型

    50-59：10个发型，读取文件Hair10.wzl，每个发型600张图（第一个发型：0-599）； 连击读取cboHair10.wzl，每个发型2000张图（第一个发型：0-1999）
    60-69：10个发型，读取文件Hair11.wzl，每个发型600张图（第一个发型：0-599）； 连击读取cboHair11.wzl，每个发型2000张图（第一个发型：0-1999）

    ---------------------发型内观说明----------------------
    扩展发型内观固定为Hair10.wzl为男发型外观、Hair11为女发型外观 内观图片位于：NewopUI.Pak 400-419
    发型内观：400-409对应外观：50-59（男性发型） 发型内观：410-419对应外观:60-69（女性发型）【如不需要内观的图的话外观无需分男女...】

    ==========================================
    扩展首饰发光：
    1.首饰放光的效果需要在物品数据库中增加Light字段,效果是1-14
    2.扩展2个文件为首饰发光专用：headgearEffect.wzl headgearEffect2.wzl 读取为每20张图片为一组 分别读取代码为100-199 200-299
    headgearEffect3.wzl 读取代码300-399 headgearEffect4.wzl 读取代码400-499 headgearEffect5.wzl 读取代码500-599 headgearEffect6.wzl 读取代码 600-699

    --------------------------------------------------------------------------------------------

    扩展衣服翅膀特效：Anicount 字段
    HumEffect6.wzl 1100 - 1124
    HumEffect7.wzl 1125 - 1149
    HumEffect8.wzl 1150 - 1174
    HumEffect9.wzl 1175 - 1199
    HumEffect10.wzl 1200 - 1224
    HumEffect11.wzl 1225 - 1249
    HumEffect12.wzl 1250 - 1274
    HumEffect13.wzl 1275 - 1299
    ...................以此类推扩展至65535

    扩展武器特效:
    WeaponEffect6.wzl 1150-1174
    WeaponEffect7.wzl 1175-1199
    WeaponEffect8.wzl 1200-1224
    WeaponEffect9.wzl 1225-1249
    WeaponEffect10.wzl 1250-1274
    WeaponEffect11.wzl 1275-1299
    ...................以此类推扩展至65535


显示改名后的装备名字变量

功能：显示改名后的装备名字变量

<$G_DRESS> 衣服 改名名称
<$G_WEAPON> 武器 改名名称
<$G_RIGHTHAND> 蜡烛 改名名称
<$G_HELMET> 头盔 改名名称
<$G_NECKLACE> 项链 改名名称
<$G_RING_R> 右戒指 改名名称
<$G_RING_L> 左戒指 改名名称
<$G_ARMRING_R> 右手镯 改名名称
<$G_ARMRING_L> 左手镯 改名名称
<$G_BUJUK> 护身符 改名名称
<$G_BELT> 腰带 改名名称
<$G_BOOTS> 鞋子 改名名称
<$G_CHARM> 宝石 改名名称
<$G_HAT> 斗笠 改名名称
<$G_DRUM> 军鼓 改名名称
<$G_HORSE> 马牌 改名名称
<$G_SHIELD> 盾牌 改名名称
<$G_JADE> 灵玉 改名名称
<$G_FASHIONDRESS> 时装衣服 改名名称
<$G_FASHIONWEAPON> 时装武器 改名名称
<$G_FASHIONNECKLACE> 时装项链 改名名称
<$G_FASHIONHELMET> 时装头盔 改名名称
<$G_FASHIONARMRINGL> 时装左手镯 改名名称
<$G_FASHIONARMRINGR> 时装右手镯 改名名称
<$G_FASHIONRINGL> 时装左戒指 改名名称
<$G_FASHIONRINGR> 时装右戒指 改名名称
<$G_FASHIONRIGHTHAND> 时装照明物品 改名名称
<$G_FASHIONBELT> 时装腰带 改名名称
<$G_FASHIONBOOTS> 时装鞋子 改名名称
<$G_FASHIONCHARM> 时装宝石 改名名称

<$G_UseItemName> 47类物品人物当前使用物品名字
<$G_BagItemName> 47类物品使用物品目标名字


限制摆摊物品最低售价

限制摆摊物品最低售价

Mir200\Envir目录内
LowestSellingPrice.txt 限制摆摊和商店出售物品最低价格

;物品名称 最低元宝价格 最低金刚石价格 最低游戏点价格 最低金币点价格 最低灵符价格


镶嵌宝石设置说明

凹槽宝石设置
StdMode：46
Shape：3
Anicount：1、防御 2、魔御 3、攻击 4、魔法 5、道术 6、生命值 7、魔法值 8、准确 9、敏捷 10、幸运 11、攻击速度 12、魔法躲避 13、毒物躲避 14、中毒恢复 15、体力恢复 16、魔法恢复 17、负重(穿戴) 18、负重（背包）19、刺术 20、箭术 21、武力
Source：所加属性值
AC：1、暴击几率 2、攻击伤害 3、物伤减少 4、魔伤减少 5、忽视防御 6、伤害反弹 7、人物暴率 8、体力增加 9、魔力增加 10、怒气恢复 11、合击伤害 12、怪物暴率 13、防暴几率 14、防止麻痹 15、防止护身 16、防止复活 17、防止全毒 18、防止诱惑 19、防止火墙 20、防止冰冻 21、防止蛛网 22、为麻痹 23、为复活 24、为护身 25、为魔道麻痹 26、冰冻 27、蜘蛛网 28、致命一击 29、致命威力 30、致命防御 31、暴击抗性 32、攻击伤害抗性 33、杀怪经验倍数
AC2：所加元素属性值
Reserved：0为卸下宝石后宝石不消失、大于0则表示卸下宝石后宝石将消失

注：Anicount字段为12、13、14、15、16有效附加属性值设置1-10，分别对应10% - 100%

当宝石AC字段是15-27时候，数据库ac2为百分比机率 (1-100最大100.有二次几率的设置0也为100%，比如麻痹,冰冻,蜘蛛网)，比如1-100 为几率进入麻痹几率，比如M2麻痹几率5 时间5，宝石几率50% 意思就是有50%机会进入到麻痹几率··麻痹几率为控制是否麻痹生效~

=================================================================================================================

宝石卸下设置
功能：
可将装备凹槽中的宝石取下

格式：
    脚本头添加(@ArmRemoveStone)
    NPC对话按钮    <卸下宝石/@ArmRemoveStone>
    点击后调用卸下宝石对话框进行操作

示例：

(@ArmRemoveStone)
[@main]
  有什么我可以帮你的。\ \
<卸下宝石/@ArmRemoveStone>\
<关闭/@exit>\

数据库设置：

在物品数据库StdItems.DB里设置如下：
卸下宝石道具
Stdmode = 46
Shape = 9

=================================================================================================================

物品备注示例：
ItemDescList.txt--物品备注MIR200目录中查找，或者M2-列表信息二中查找
宝石=250/将需镶嵌装备放入背包后鼠标右键点击宝石\250/当宝石变成准星后移动到需镶嵌武器上点击左键即可
混元锤=250/鼠标右键点击锤子，移动锤子到卸下宝石窗口\250/对准需卸下宝石点击即可卸下宝石

=================================================================================================================

相关操作命令（可使用自定义OK框制作自己喜欢的镶嵌功能）
打孔命令：
SETFLUTECOUNT 位置 数量
位置如下：
-1 升级框
0--25：装备栏
30-35：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框

检测打孔数量命令：
CheckFluteCount 位置 （<、=、>）数量
位置如下：
-1 升级框
0--25：装备栏
30-35：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框

检测物品镶嵌宝石数量：
CheckItemStoneCount 装备位置 （<、=、>） 数量
位置如下：
-1 升级框
0--25：装备栏
30-35：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框

检测装备是否镶嵌指定宝石：
命令格式：
CheckItemHasStone 装备位置 宝石名称 数量

镶嵌宝石QF触发：
@BagUseStoneItemOK

卸下宝石QF触发：
@RemoveStoneItem

--------------------------------------------

检测人物全身镶嵌指定宝石数量：
格式： 命令 宝石名称 数量
CheckStoneCount 宝石名 ><= 数量

------------------------------------------------------------------------------------------------------

关闭装备打孔： CloseItemFlute 装备位置 关闭的打孔数量

注：关闭后原镶嵌的宝石和属性全部消失！

------------------------------------------------------------------------------------------------------
使用OK框镶嵌宝石：
命令：ItemFluteStone 装备在OK框中的位置(0-7) 宝石在OK框中的位置(0-7)
注意：boxitem0-boxitem7：OK框位置,此命令不需要填写boxitem，正确为：ItemFluteStone 0 1

---------------------------------------------------------------------------------------------------
相关QF触发：
镶嵌成功后触发：@BagUseStoneItemOK

*******************************************2019-10-09扩展触发支持关联********************************************************

示范脚本：

[@BagUseStoneItemOK]
#ACT
LinkPickupItem
ChangeItemName -1 新的名称
SENDMSG 0 镶嵌装备已改为“新的名称”
; 获取宝石名称
GetDBIdxItemFieldValue <$UseStoneItemIndex> name S1
SendMsg 0 使用的宝石Idx:<$UseStoneItemIndex>，宝石名称:<$Str(S1)>
; 获取装备Idx
GetItemFieldValue -1 idx S1
; 获取装备名称（含改名）
GetItemFieldValue -1 name_g S2
; 获取装备数据库名称
GetItemFieldValue -1 name S3
clearLinkItem
SendMsg 0 当前操作的装备Idx：<$Str(S1)>；名称：<$Str(S2)>，数据库名称：<$Str(S3)>

=================================================================================================================

示例脚本（集成调用）
[@MAIN]
<给装备打孔增加凹槽/@凹槽页面>\
<关闭/@exit>\

[@凹槽页面]
请先把想要改良的装备穿在身上，然后在下方选择对应的装备位置\进行操作：\\
<武器/@Flut1_1>

;以武器为例
(增加1个凹槽,100%成功率)\
(增加2个凹槽,100%成功率)\
(增加3个凹槽,100%成功率)\
(增加4个凹槽,100%成功率)\
(增加5个凹槽,100%成功率)\
(增加6个凹槽,100%成功率)\
(增加7个凹槽,100%成功率)\
(增加8个凹槽,100%成功率)\
<返回主菜单/@MAIN> <关闭/@exit>\

[@Flut1_1]
#IF
NOT CHECKUSEITEM 1
#SAY
  您身上的该位置(武器) 未检测到装备，\
请先穿戴好装备，再进行改良操作！\ \
<返回重新选取/@凹槽页面>\
<关闭/@exit>\
#ELSESAY
  本次选取“<$WEAPON>”进行操作，\\
<增加[1]个凹槽(成功率:100%)/@Flut1_1_1>\
<增加[2]个凹槽(成功率:100%)/@Flut1_1_2>\
<增加[3]个凹槽(成功率:100%)/@Flut1_1_3>\
<增加[4]个凹槽(成功率:100%)/@Flut1_1_4>\
<增加[5]个凹槽(成功率:100%)/@Flut1_1_5>\
<增加[6]个凹槽(成功率:100%)/@Flut1_1_6>\
<增加[7]个凹槽(成功率:100%)/@Flut1_1_7>\
<增加[8]个凹槽(成功率:100%)/@Flut1_1_8>\
<返回重新选取/@凹槽页面>\
<关闭/@exit>\

[@Flut1_1_1]
#IF
#ACT
SETFLUTECOUNT 1 1
;给予装备位置武器增加一个凹槽
#SAY
  恭喜，本次成功为装备增加了[1]个凹槽，\
赶紧查看一下吧。\ \
<返回主菜单/@MAIN>\
<关闭/@exit>\

[@Flut1_1_2]
#IF
#ACT
SETFLUTECOUNT 1 2
;给予装备位置武器增加两个凹槽
#SAY
  恭喜，本次成功为装备增加了[2]个凹槽，\
赶紧查看一下吧。\ \
<返回主菜单/@MAIN>\
<关闭/@exit>\
[@Flut1_1_3]
#IF
#ACT
SETFLUTECOUNT 1 3
#SAY
  恭喜，本次成功为装备增加了[3]个凹槽，\
赶紧查看一下吧。\ \
<返回主菜单/@MAIN>\
<关闭/@exit>\
[@Flut1_1_4]
#IF
#ACT
SETFLUTECOUNT 1 4
#SAY
  恭喜，本次成功为装备增加了[4]个凹槽，\
赶紧查看一下吧。\ \
<返回主菜单/@MAIN>\
<关闭/@exit>\
[@Flut1_1_5]
#IF
#ACT
SETFLUTECOUNT 1 5
#SAY
  恭喜，本次成功为装备增加了[5]个凹槽，\
赶紧查看一下吧。\ \
<返回主菜单/@MAIN>\
<关闭/@exit>\
[@Flut1_1_6]
#IF
#ACT
SETFLUTECOUNT 1 6
#SAY
  恭喜，本次成功为装备增加了[6]个凹槽，\
赶紧查看一下吧。\ \
<返回主菜单/@MAIN>\
<关闭/@exit>\
[@Flut1_1_7]
#IF
#ACT
SETFLUTECOUNT 1 7
#SAY
  恭喜，本次成功为装备增加了[7]个凹槽，\
赶紧查看一下吧。\ \
<返回主菜单/@MAIN>\
<关闭/@exit>\
[@Flut1_1_8]
#IF
#ACT
SETFLUTECOUNT 1 8
;给予装备位置武器增加8个凹槽
#SAY
  恭喜，本次成功为装备增加了[8]个凹槽，\
赶紧查看一下吧。\ \
<返回主菜单/@MAIN>\
<关闭/@exit>\

=================================================================================================================

参数详解：

[@Flut1_0]为衣服
[@Flut1_1]为武器
[@Flut1_3]为项链
依次类推，最后的数字是装备位置！

[@Flut1_1_1] 表示给武器打第一个孔
....中间省略说明...依次类推...
[@Flut1_1_8] 表示给武器打第八个孔

[@Flut1_0_1] 表示给衣服打第一个孔
....中间省略说明...依次类推...
[@Flut1_0_8] 表示给衣服打第八个孔

[@Flut1_3_1] 表示给项链打第一个孔
....中间省略说明...依次类推...
[@Flut1_3_8] 表示给项链打第八个孔

其他自己按照装备位置和孔数自己对应即可！（装备位置如下：）

0 盔甲
1 武器
2 照明物（蜡烛，此物品属性升级无效）
3 项链
4 头盔
5 右手镯
6 左手镯
7 右戒指
8 左戒指
9 无(放护身符位置)
10 腰带
11 鞋子
12 宝石
13 斗笠
14 军鼓
15 马牌
16 盾牌
17 灵玉
18 时装衣服
19 时装武器
20 时装项链
21 时装头盔
22 时装左手镯
23 时装右手镯
24 时装左戒指
25 时装右戒指
26 时装勋章
27 时装腰带
28 时装靴子
29 时装宝石
30-35 首饰盒
40-51 生肖盒

=================================================================================================================

获取装备宝石的属性

GetItemStoneInfo
功能说明：可以获取装备上面的每个宝石的数据

GetItemStoneInfo 装备位置 宝石位置（0-7） 属性类型(0-5) 变量
属性类型：
参数3为 0 时 获取 宝石Name看【0】介绍
参数3为 1 时 获取宝石类型（攻击魔法道术之类的）看【1】介绍
参数3为 2 时 获取宝石属性值 看【2】介绍
参数3为 3 时 获取宝石元素类型 看【3】介绍
参数3为 4 时 获取宝石元素属性值 看【4】介绍
参数3为 5 时 获取卸下宝石是否消失 看【5】介绍
参数3为 6 时 获取宝石叠加数量 (相同属性宝石可以叠加镶嵌)
【0】：Name
【1】: Anicount：1、防御 2、魔御 3、攻击 4、魔法 5、道术 6、生命值 7、魔法值 8、准确 9、敏捷 10、幸运 11、攻击速度 12、魔法躲避 13、毒物躲避 14、中毒恢复 15、体力恢复 16、魔法恢复 17、负重(穿戴) 18、负重（背包）
【2】: Source：所加属性值
【3】: AC：1、暴击几率 2、攻击伤害 3、物伤减少 4、魔伤减少 5、忽视防御 6、伤害反弹 7、人物暴率 8、体力增加 9、魔力增加 10、怒气恢复 11、合击伤害 12、怪物暴率 13、防暴几率 14、防止麻痹 15、防止护身 16、防止复活 17、防止全毒 18、防止诱惑 19、防止火墙 20、防止冰冻 21、防止蛛网 22、为麻痹 23、为复活 24、为护身 25、为魔道麻痹 26、冰冻 27、蜘蛛网 28、致命一击 29、致命威力 30、致命防御 31、暴击抗性 32、攻击伤害抗性
【4】: AC2：所加元素属性值
【5】: Reserved：0为卸下宝石后宝石不消失、大于0则表示卸下宝石后宝石将消失

示例：
[@main]
<获取武器装备宝石的属性/@获取武器装备宝石的属性>\

[@获取装备装备宝石的属性]
#IF
#ACT
GetItemStoneInfo 1 0 0 <$STR(S$宝石名称)>
GetItemStoneInfo 1 0 1 <$STR(S$宝石类型)>
GetItemStoneInfo 1 0 2 <$STR(S$宝石属性值)>
SENDMSG 6 你的武器的第一个宝石名称为【<$STR(S$宝石名称)>】
SENDMSG 6 你的武器的第一个宝石属性类型为【<$STR(S$宝石类型)>】
SENDMSG 6 你的武器的第一个宝石攻击属性为【<$STR(S$宝石属性值)>】

=================================================================================================================

命令功能说明：
对人物 英雄身上的装备进行镶嵌宝石
ItemFluteStoneEx 装备位置 宝石名
H.ItemFluteStoneEx 装备位置 宝石名
英雄使用H.ItemFluteStoneEx 请确保英雄包裹里有指定宝石

示例：
[@main]
<镶嵌身上武器装备/@镶嵌身上武器装备>\

[@镶嵌身上武器装备]
#if
#act
ItemFluteStoneEx 1 麻痹宝石5级
;注意英雄包裹里要有宝石才行
H.ItemFluteStoneEx 1 麻痹宝石5级

=================================================================================================================

附加说明：

装备打孔最多可打8个孔，每个宝石最多同时支持2个属性（常规属性+元素属性）

关于打孔成功率大家可以自己在脚本中增加几率控制

镶嵌其他相关控制：M2-物品装备-特殊属性-基本选项

===============================================以下为单独的功能操作命令（无需宝石直接命令镶嵌数据库中的宝石到装备上）=================================================================

脚本命令给物品镶嵌宝石（无需宝石直接镶嵌）

// ++++++++++++++++++++++++++++++++++ 检测装备对应的孔位置是否有宝石;孔位置 (1-8)
CheckItemFluteIndexHasStone 装备位置 孔位置

// ################################################## 直接给装备加一个宝石（不需要包裹中有宝石）
ItemAddStone 装备位置 宝石名 孔位置(0或空表示自动空孔位，1-8：指定位置)

// 删除装备指定孔位的宝石孔位置 (1-8)
ItemDelStone 装备位置 孔位置

// 2019-02-01增加取下镶嵌宝石命令：
ItemoffStone 装备位置 孔位置（1-8）


小地图边框

-----------------------------------小地图边框---------------------------

功能说明：M2-客户端设置--小地图选择页游模式，然后在自定义UI编辑仿页游小地图

必备补丁内：
雷达：
1650; // 怪物
1651; // NPC
1652; // 守卫
1653; // 其他玩家
1654; // 英雄
1655; // BOSS
1656; // 自己

小地图预留按钮点击触发：

@MinMapCustomButtonClickX， X是序号，为1-14


爆率设置方式一：(传统设置)
文件位置
【\Mir200\Envir\MonItems\】
内容格式
格式：几率 物品名称 (数量)数量针对金币
使用示例
1/1 万年雪霜
1/1 金币 10000
--------------------------------------------------------------------------------

爆率设置方式二：(新格式)
文件位置
【\Mir200\Envir\MonItems\】
内容格式
格式：#CHILD 几率 RANDOM //里面的爆率设置要使用()包围起来
使用说明
#CHILD 固定命令不能更改
几率 当符合几率条件时才会执行()里的爆率设置
RANDOM 固定值，当加入该条件后，怪物死亡后从()里随机抽取一件物品爆出，注意因为子爆率依旧有效，子爆率必须是1/1

使用示例
#CHILD 1/1 RANDOM
(
1/1 圣殿之刃
1/1 圣殿宝甲
)
新爆率设置的主要应用特色说明
在传统的爆率设置中，由于爆率随机性的缺点，对于爆出的物品无法精确控制。
例如：
1/4 天尊头盔
1/4 天尊项链
1/4 天尊手镯
1/4 天尊戒指
以上设置，在怪物爆出物品时无法控制每次只爆出一件，系统有可能爆出两件或四件，也有可能一件都不爆。

新方式一：
#CHILD 1/1 RANDOM
(
1/1 天尊头盔
1/1 天尊项链
1/1 天尊手镯
1/1 天尊戒指
)
使用这种方式后，可以确保每次只随机爆出其中的一件物品。
子爆率依旧有效，示例为，1/1的几率进入（）得爆率，然后按照（）中设置的几率再次运算，设置1/1就是随机掉落，如果其中有不是1/1的，当掉落物品为该物品时候则有几率不掉落。
------------------------------------------------------------------------

新方式二：
#CHILD 1/2
(
1/1 天尊头盔
1/1 天尊项链
1/1 天尊手镯
1/1 天尊戒指
)
使用这种方式后，子爆率有效,杀怪爆率倍数有效，二分之一几率进入然后按子爆率爆出物品。

新方式三：
#CHILD 1/1 BURSTRATE
(
1/10 天尊头盔
1/10 天尊项链
1/10 天尊手镯
1/10 天尊戒指
)
使用这种方式后，子爆率有效，增加BURSTRATE则子爆率杀怪爆率倍数无效。

新方式四：
#CHILD 1/1 BURSTRATE RANDOM
(
1/10 天尊头盔
1/10 天尊项链
1/10 天尊手镯
1/10 天尊戒指
)
使用这种方式后，为随机掉落最多1件物品，子爆率有效，增加BURSTRATE则子爆率杀怪爆率倍数无效。

*新手说明：CHILD设置几率进入到子爆率.....

*新手说明：加了RANDOM表示进入子爆率后随机选一件物品（最多爆出一件），如果该物品为1/1则必爆出，不是1/1则几率爆出.需要必出一件物品那么子爆率全部设置为1/1

*新手说明：加了BURSTRATE则表示角色杀怪爆率倍率无效，反之则有效，意思为当子爆率不是1/1时，如子爆率1/10 ，人物杀怪爆率10倍必爆出，加上BURSTRATE后则杀怪爆物品倍率无效 则为1/10几率爆出.....

====================================================================================================

注：两种新格式可同时使用，也可以单独使用，同时使用需要底部为双刮号（只需一种就不需要双刮号），下面示列：
1/1 二级金针
1/1 解读卷轴
1/1 超强魔法药
1/15 半月弯刀
1/60 地狱雷光
1/3000 困魔咒
1/10 野蛮冲撞
1/60 魔法盾
1/10 降妖除魔戒指
;当CHILD 指定RANDOM后，表示从下面随机取一个（中间的几率设置无效），子项的几率有效，需要必爆1件则子爆率必须全部是1/1

#CHILD 1/1 RANDOM
(
1/1 天尊头盔
1/1 天尊项链
;当CHILD不指定RANDOM后，根据几率爆下面的物品，子项爆率有效

#CHILD 1/2
(
1/100 火球术
1/1 治愈术
1/1 基本剑术
1/1 精神力战法
)
)

====================================以下是采用#call设置怪物爆率================================================================

》》》》》》》》》》》》》白野猪.txt

#CALL [\\爆率系统\基础爆率.txt] @药水

--------------------------------------------------------以上是怪物爆率文件中白野猪设置-----------------------------------------

》》》》》》》》》》》》》D:\MirServer\Mir200\Envir\QuestDiary\爆率系统\基础爆率.txt

[@药水]
{
#CHILD 1/1 RANDOM
(
1/1 超强金创药
1/1 超强魔法药
1/1 太阳水
)
}

--------------------------以上是CALL路径的基础爆率设置-----------------------------------------------------

**************************************************************2019-06月 再次扩展支持多变量检测，变量检测变量，QF触发*********************************************************************

操作符号：小于(<)，等于(=)，小于等于(<=)，大于等于(>=) ，不等于(<>)

;中括号内为条件判断，变量名在前，判断值在后，并以空格分隔；条件写在RANDOM的后面；若无 RANDOM则直接写条件
;变量支持D(0-999),M(0-999),N(0-999),U(0-254),J(0-254),I(0-999),G(0-999)这些数字型变量，不支持自定义变量
;判断依据是根据杀怪者变量来判断，如杀怪者为宝宝或者英雄通过参数来觉得是否继承人物变量，如不继承则表示无变量（私人），全局除外
;如果是宝宝/英雄打的，判断人物的变量。如果是2个怪物打的（好像不同国家的怪物可以打架），怪物没有变量，就不会掉（全局变量 I，G除外）
[N1=1000,继承主人变量] 或 [N1=U1,继承主人变量]
继承变量计算:
0: 不继承
1: 英雄继承
2: 宝宝继承
4: 宠物继承

3: (1+2)英雄+宝宝继承
5: (1+4)英雄+宠物继承
6: (2+4)宝宝+宠物继承
7: (1+2+4)英雄、宝宝、宠物继承

-----------------------------------------------------------------------------

支持2个变量直接检测操作，注意顺序，以下四组为常见顺序使用
#CHILD 1/1 RANDOM [N1<=1000;N2<D2;N3<200,1]

#CHILD 1/1 RANDOM [N1<=1000;N2<D2;N3<200,1,@触发脚本]

#CHILD 1/1 RANDOM [N1<=1000;N2<D2;N3<200|OR,1,@触发脚本]

#CHILD 1/1 RANDOM [N1<=1000;N2<D2;N3<200|OR,1]

-----------------------------------------------------------------------------

;;;;;;;;;;;;;;;;;;;;;;;;;;; OR方式检测多个变量，使用or需要用上 | 符号
#CHILD 1/1 RANDOM [N1<=1000;N2<100;N3<200|OR,1,@触发脚本]
(
1/1 天尊头盔
1/3 火球术
1/4 治愈术
1/5 基本剑术
)
-----------------------------------------------------------------------------

;;;;;;;;;;;;;;;;;;;;;;;;;;; AND方式检测多个变量 （常规传统使用，即变量全部满足）
#CHILD 1/1 RANDOM [N1<=1000;N2<100;N3<200,1]
(
1/1 天尊头盔
1/3 火球术
1/4 治愈术
1/5 基本剑术
)
-----------------------------------------------------------------------------

单个变量使用：
[N1=1000,1]

注意 , 为英文的标点符号

1/15 半月弯刀
#CHILD 1/1 RANDOM [N1<=1000,3]
;N1变量小于或等于1000时执行爆率，英雄和宝宝继承主人的私人变量
(
1/1 天尊头盔
1/3 火球术
1/4 治愈术
1/5 基本剑术

)
#CHILD 1/1 [N1<=100,0]
(
1/1 天尊项链
1/1 精神力战法
)
1/10 野蛮冲撞


新小地图计算方法[!]

功能：新小地图计算方法
格式：无
说明：无
例：

Data\minimap\301.mmap 小地图代码 9901
Data\minimap\302.mmap 小地图代码 9902
Data\minimap\303.mmap 小地图代码 9903
Data\minimap\304.mmap 小地图代码 9904
Data\minimap\306.mmap 小地图代码 9905
Data\minimap\308.mmap 小地图代码 9906
Data\minimap\309.mmap 小地图代码 9907
Data\minimap\310.mmap 小地图代码 9908
Data\minimap\311.mmap 小地图代码 9909
Data\minimap\312.mmap 小地图代码 9910
Data\minimap\313.mmap 小地图代码 9911
Data\minimap\314.mmap 小地图代码 9912
Data\minimap\315.mmap 小地图代码 9913
Data\minimap\316.mmap 小地图代码 9914
Data\minimap\317.mmap 小地图代码 9915
Data\minimap\318.mmap 小地图代码 9916
Data\minimap\319.mmap 小地图代码 9917
Data\minimap\320.mmap 小地图代码 9918
Data\minimap\321.mmap 小地图代码 9919
Data\minimap\322.mmap 小地图代码 9920
Data\minimap\323.mmap 小地图代码 9921
Data\minimap\324.mmap 小地图代码 9922
Data\minimap\325.mmap 小地图代码 9923
Data\minimap\326.mmap 小地图代码 9924
Data\minimap\327.mmap 小地图代码 9925
Data\minimap\328.mmap 小地图代码 9926
Data\minimap\329.mmap 小地图代码 9927
Data\minimap\330.mmap 小地图代码 9928
Data\minimap\331.mmap 小地图代码 9929
Data\minimap\402.mmap 小地图代码 9930
Data\minimap\3021.mmap 小地图代码 9931
Data\minimap\3022.mmap 小地图代码 9932
Data\minimap\3023.mmap 小地图代码 9933


修改宝宝身体颜色,修改分身身体颜色

说明: 修改宝宝身体颜色（含分身）

格式：SetSlaveBodyColor 宝宝名称(*表示所有) 颜色(0-255;0不改变颜色) 时间(秒,0表示一直有效) 颜色类型(0:固定颜色,1:转生颜色中配置的颜色自动变色)

示范：

#if
#act
SetSlaveBodyColor * 253 100 0
sendmsg 5 改成了粉红宝宝

------------------------------------------


修改地图怪物名称,修改地图怪物名字

说明: 修改地图怪物名称

格式：修改地图怪物名称：ChangeMapMonName 地图名 X坐标 Y坐标 范围(为3时表示3*3) 原怪物名(*不判断) 新怪物名
备注：当X,Y,范围均为0时，表示地图所有范围

示范：

#if
#act
ChangeMapMonName 3 0 0 0 羊 喜羊羊
sendmsg 5 你已经将盟重地图中的所有羊改名为喜羊羊了

示范2：

#if
#act
ChangeMapMonNameEx 3 0 0 0 稻草人 白野猪
sendmsg 5 你已经将盟重地图中的所有稻草人改名为白野猪了

区别

ChangeMapMonNameEx 修改名字后爆率依然读取源名字怪物爆率

ChangeMapMonName 修改名字后爆率读取修改名称后的怪物爆率

------------------------------------------


修改指定账号的注册信息

功能说明：修改指定账号的注册信息（需要指定账号，从密码开始内容均为修改内容）

格式：ChangeAccountInfo 账号 密码 用户名 生日 提问1 回答2 提问2 回答2 邮箱(可以空) 手机(可以空) 二级密码(可以空)

;例子
[@修改账号密码信息]
#ACT
;ChangeAccountInfo 账号 密码 用户名 生日 提问1 回答2 提问2 回答2 邮箱(可以空) 手机(可以空) 二级密码(可以空)
ChangeAccountInfo qqqq 1234 1234 2019/01/01 1 2 3 4 1234@qq.com 1234567890 passsword2

;触发脚本位于当前NPC

[@ChangeAccountInfo_Error_Account]
#if
#act
#say
账号长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Password]
#if
#act
#say
密码长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_PasswordSame]
#if
#act
#say
账号不能和密码相同！

[@ChangeAccountInfo_Error_PasswordSimple]
#if
#act
#say
不能使用简单的密码！

[@ChangeAccountInfo_Error_UserName]
#if
#act
#say
用户名长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_BirthDay]
#if
#act
#say
生日格式错误！

[@ChangeAccountInfo_Error_Quiz1]
#if
#act
#say
提问1长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Answer1]
#if
#act
#say
回答1长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Quiz2]
#if
#act
#say
提问2长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Answer2]
#if
#act
#say
回答2长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Mail]
#if
#act
#say
邮件地址长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_MobilePhone]
#if
#act
#say
手机号码长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_Quiz1Answer1Same]
#if
#act
#say
问题1与答案1不能相同！

[@ChangeAccountInfo_Error_Quiz2Answer2Same]
#if
#act
#say
问题2与答案2不能相同！

[@ChangeAccountInfoing]
#if
#act
#say
正在修改中，请稍后！

[@ChangeAccountInfoOK]
#if
#act
#say
账号信息修改成功！

[@ChangeAccountInfoError]
#if
#act
#say
账号信息修改失败！

[@ChangeAccountInfo_Error_NotExists]
#if
#act
#say
账号不存在！

[@ChangeAccountInfo_Error_L2Password]
#if
#act
#say
二级密码长度不正确或存在非法字符！

[@ChangeAccountInfo_Error_L2PasswordSameAccount]
#if
#act
#say
二级密码不能和帐号相同！

[@ChangeAccountInfo_Error_L2PasswordSamePassword]
#if
#act
#say
二级密码不能和密码相同！


悬浮框自定义进度条使用说明

 自定义装备进度条说明书

功能说明：可以给装备自定义进度条，支持2个进度条。
显示位置：显示在升级星星的下一行
资源位置：必备补丁NewopUI.PAK
进度条1：620 背景图片 621~629 为静态的进度条图 630~639 为动态的进度条图
进度条2：640 背景图片 641~649 为静态的进度条图 650~659 为动态的进度条图

自定义进度条的支持的装备位置如下：
-1 升级框
0--25：装备栏
30-35：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框

M2 其他设置 可以设置关闭提示没有佩戴装备的提示
@KillMonGetExp 人物杀怪获得经验触发 可以配合进度条使用
@HeroKillMonGetExp 英雄杀怪获得经验触发 可以配合进度条使用

检测进度条是否开启：CheckCustomItemProgressBar装备位置 进度条序号(0=进度条1；1=进度条2)
检测类型说明（参数3）：
0：进度条最大值
1：进度当前值
2：进度条当前百分比
3：进度条等级

[@检测武器的第一个进度条是否开启]
#IF
CHECKCUSTOMITEMPROGRESSBAR 1 0
#ACT
SENDMSG 6 武器的第一个进度条已经开启
#ELSEACT
SENDMSG 6 武器的第一个进度条没有开启

检测进度条值：CheckCustomItemProgressbarValue 装备位置 进度条序号(0,1) 检测值类型(0,1,2,3) 检测符(>,<,=) 检测值
检测值类型说明（参数3）：
0：进度条最大值
1：进度当前值
2：进度条当前百分比
3：进度条等级

[@检测武器的第一个进度条最大值]
#IF
CheckCustomItemProgressbarValue 1 0 0 > 99
#ACT
SENDMSG 6 武器的第一个进度条最大值大于99
#ELSEACT
SENDMSG 6 武器的第一个进度条最大值不大于99

[@检测武器的第一个进度条当前值]
#IF
CheckCustomItemProgressbarValue 1 0 1 > 99
#ACT
SENDMSG 6 武器的第一个进度条当前值大于99
#ELSEACT
SENDMSG 6 武器的第一个进度条当前值不大于99

[@检测武器的第一个进度条百分比]
#IF
CheckCustomItemProgressbarValue 1 0 2 > 99
#ACT
SENDMSG 6 武器的第一个进度条百分比为100%

[@检测武器的第一个进度条等级]
#IF
CheckCustomItemProgressbarValue 1 0 3 > 99
#ACT
SENDMSG 6 武器的第一个进度条等级大于99
#ELSEACT
SENDMSG 6 武器的第一个进度条等级不大于99

设置进度条值：SetCustomItemProgressbarValue 装备位置 进度条序号(0,1) 设置值类型(0,1,2,3) 设置符(+,-,=) 设置值
设置值类型说明（参数3）：
0：进度条最大值
1：进度当前值
2：进度条当前百分比
3：进度条等级

[@修改武器的第一个进度条的最大值]
#ACT
SetCustomItemProgressbarValue 1 0 0 = 100
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。这里最大值设置为100

[@修改武器的第一个进度条的当前进度值]
#ACT
SetCustomItemProgressbarValue 1 0 1 + 10
;当前进度值不能超过进度条最大值，一般先要修改进度条最大值，然后在修改当前进度值。

[@修改武器的第一个进度条的百分比]
#ACT
SetCustomItemProgressbarValue 1 0 2 + 10
;百分比最大建议 100% 。
[@修改武器的第一个进度条的等级]
#ACT
SetCustomItemProgressbarValue 1 0 3 + 10
;进度条的等级可以用 %i 显示在进度条名称后面，用于进度条的值满后提升进度条的等级。

获取自定义装备进度条属性值
GetCustomItemProgressbarValue 装备位置 进度条序号(0,1) 获取值类型(0,1,2,3) 变量
获取值类型说明（参数3）：
0：进度条最大值
1：进度当前值
2：进度条当前百分比
3：进度条等级

[@获取武器的第一个进度条的最大值]
#ACT
GetCustomItemProgressbarValue 1 0 0 <$STR(N1)>
SENDMSG 6 武器第一个进度条的最大值<$STR(N1)>

[@获取武器的第一个进度条的当前进度值]
#ACT
GetCustomItemProgressbarValue 1 0 1 <$STR(N2)>
SENDMSG 6 武器第一个进度条的当前值<$STR(N2)>

[@获取武器的第一个进度条的百分比]
#ACT
GetCustomItemProgressbarValue 1 0 2 <$STR(N3)>
SENDMSG 6 武器第一个进度条的当前百分比<$STR(N2)>

[@获取武器的第一个进度条的等级]
#ACT
GetCustomItemProgressbarValue 1 0 3 <$STR(N4)>
SENDMSG 6 武器第一个进度条的等级<$STR(N4)>

设置自定义装备进度条各种属性
SetCustomItemProgressbar装备位置 进度条序号(0,1) 属性类型(0~4) 参数4
属性类型(0~4；参数3)：
0：参数4表示是否开启进度条：参数4=0时，关闭进度条； 参数4=1时，开启进度条

1：参数4表示设置进度条名称【进度条名称会显示在进度条的左边，长度30字符】，名称可以使用特殊字符
特殊字符：\=换行； %p=当前进度值； %m=最大值； %r=进度百分比； %i:当前等级

2：参数4表示进度条名称颜色(0~255)

3：参数4表示设置进度条图片播放数量(0：不显示进度条；1~9：单张绘制；10~19：循环绘制）
用进度条0来举例：
如果参数4=1就会绘制621，
如果参数4=2就会绘制622。

如果参数4=11 表示在630~631之间循环绘制
如果参数4=12 表示在630~632之间循环绘制

4：参数4表示进度条数值显示方式【0=不显示；1=百分比显示(10%)；2=数值显示(10/100)；3=等级显示】

[@显示武器的第一个进度条]
#ACT
SetCustomItemProgressbar 1 0 0 1

[@显示武器的第二个进度条]
#ACT
SetCustomItemProgressbar 1 1 0 1

[@关闭武器的第一个进度条]
#ACT
SetCustomItemProgressbar 1 0 0 0

[@关闭武器的第二个进度条]
#ACT
SetCustomItemProgressbar 1 1 0 0

[@设置武器的第一个进度条的名称]
#ACT
SetCustomItemProgressbar 1 0 1 刀魂
;支持显示进度值、百分比、进度条等级 %p表示当前进度值 %m表进度条最大值 %r表示进度条百分比 %i表示进度条等级 特殊字符：\=换行；
;例如:
;SetCustomItemProgressbar 1 0 1 刀魂: %p-%m
;SetCustomItemProgressbar 1 0 1 刀魂: %m
;SetCustomItemProgressbar 1 0 1 刀魂: %r
;SetCustomItemProgressbar 1 0 1 老猫神剑\老猫剑魂: %i级

[@设置武器的第一个进度条的名称颜色]
#ACT
SetCustomItemProgressbar 1 0 2 254

[@设置武器的第一个进度条，不显示图片和背景，这样的情况下只显示进度条名称和数值]
#ACT
SetCustomItemProgressbar 1 0 3 0

[@设置武器的第一个进度条静态图片素材]
#ACT
SetCustomItemProgressbar 1 0 3 1
SENDMSG 6 武器的第一个进度条静态图片素材,使用NewopUI.PAK第621号

[@设置武器的第一个进度条动态图片素材]
#ACT
SetCustomItemProgressbar 1 0 3 19
SENDMSG 6 武器的第一个进度条动态图片素材,使用NewopUI.PAK第630~639号之间循环播放

[@设置武器的第二个进度条静态图片素材]
#ACT
SetCustomItemProgressbar 1 1 3 1
SENDMSG 6 武器的第二个进度条静态图片素材,使用NewopUI.PAK第641号

[@设置武器的第二个进度条动态图片素材]
#ACT
SetCustomItemProgressbar 1 1 3 19
SENDMSG 6 武器的第二个进度条动态图片素材,使用NewopUI.PAK第650~659号之间循环播放

[@设置武器的第一个进度条，不显示数值，这样的情况下只显示进度条名称和图片]
#ACT
SetCustomItemProgressbar 1 0 4 0

[@设置武器的第一个进度条百分比显示]
#ACT
SetCustomItemProgressbar 1 0 4 1

[@设置武器的第一个进度条数值显示]
#ACT
SetCustomItemProgressbar 1 0 4 2

[@设置武器的第一个进度条等级显示]
#ACT
SetCustomItemProgressbar 1 0 4 3

获取自定义进度条各种属性
GetCustomItemProgressbar装备位置 进度条序号(0,1) 属性类型(0~4) 变量
属性类型(0~4；参数3)：
0：获取进度条是否开启进度条：0=关闭进度条； 1=开启进度条
1：获取进度条显示名称
2：获取进度条名称颜色(0~255)
3：获取进度条图片播放数量(0：不显示进度条；1~9：单张绘制；10~19：循环绘制）
4：获取进度条数值显示方式【0=不显示；1=百分比显示(10%)；2=数值显示(10/100)；3=等级显示】

[@获取武器第一个自定义进度条开启状态：0未开启 或 1开启]
#ACT
GetCustomItemProgressbar 1 0 0 <$STR(N1)>
SENDMSG 6 武器第一个进度条状态<$STR(N1)>

[@获取武器第一个自定义进度条名称]
#ACT
GetCustomItemProgressbar 1 0 1 <$STR(S2)>
SENDMSG 6 武器第一个进度条名称<$STR(S2)>

[@获取武器第一个自定义进度条名称的颜色值]
#ACT
GetCustomItemProgressbar 1 0 2 <$STR(N1)>
SENDMSG 6 武器第一个进度条名称的颜色值<$STR(N1)>

[@获取武器第一个自定义进度条图片的参数]
#ACT
GetCustomItemProgressbar 1 0 3 <$STR(N1)>
SENDMSG 6 武器第一个进度条图片的参数<$STR(N1)>

[@获取武器第一个自定义进度条数值的参数]
#ACT
GetCustomItemProgressbar 1 0 4 <$STR(N1)>
SENDMSG 6 武器第一个进度条数值的参数<$STR(N1)>

============================================================================================

锁定装备更新：LockUpdateItem 装备位置
更新装备到客端： UpdateItem 装备位置

【★★注意★★：有 LockUpdateItem 必须有 UpdateItem；反过来说UpdateItem可以单独使用】
【★★注意★★：当调用两次锁定武器更新 LockUpdateItem 1; LockUpdateItem 1 时，必须调用两次 UpdateItem 1； UpdateItem 1 武器才会刷新到客户端】
【★★★★★★脚本实例：★★★★★★】

;★★★★ 锁定头盔更新 由于下面是对头盔的批量操作，锁定后，对头盔进行操作不会向客户端发包，直到 UpdateItem 4的出现，减少网络包的流量
LockUpdateItem 4

SetCustomItemText 4 [高级属性]
SetCustomItemTextColor 4 146

SetCustomItemAbil 4 2 1 3
SetCustomItemAbil 4 3 1 4
SetCustomItemAbil 4 4 1 5
SetCustomItemAbil 4 5 1 6
SetCustomItemAbil 4 6 1 7

SetCustomItemAbil 4 2 0 250
SetCustomItemAbil 4 3 0 250
SetCustomItemAbil 4 4 0 250
SetCustomItemAbil 4 5 0 250
SetCustomItemAbil 4 6 0 250

;★★★★解锁并更新头盔到客户端
UpdateItem 4

=====================================================================================================================

相关说明：
改物品的属性，需用LOCKUPDATEITEM
---------
物品在人物身上。
LOCKUPDATEITEM XX
UPDATEITEM
--------------

物品不在人物身上
LOCKUPDATEITEM XX
UPDATEITEM


血球界面的魔法球效果[!

播放界面的魔法球效果：

PLAYMAGICBALLEFFECT WIL文件序号 图片开始序号 播放张数 播放速度(毫秒) 有效时间(秒 -1时永久有效) 类型(0=HP 1=MP) 绘制高度(0=完整绘制 1=按照HP或者MP的高度绘制) 绘制模式(0=完整绘制 1=切割绘制(一张图包含HP和MP的效果，左边是HP右边是MP，会根据HP或MP只绘制一半图片)) 微调坐标X 微调坐标Y 类型(1=普通绘制 0或空=特效绘制)


 巡逻卫士

X:\MirServer\Mir200\Envir\GuardList.txt

请自行修改GuardList.txt文件!巡逻卫士配置如下:

;名称 区域 [坐标] dir(初始站的方向)
卫士 3 [380,347] : 3
卫士 3 [364,363] : 3
卫士 3 [360,367] : 3
卫士 3 [373,354] : 3
卫士 3 [379,332] : 1
卫士 3 [342,361] : 3
卫士 3 [346,361] : 3

巡逻卫士 3 [373,313|383,323] : 3

巡逻卫士 Monster.DB 以下字段不可搞错:Race必须为12
Race:12 Raceimg:12 appr:0

巡逻弓箭手DB ：142， 45， 71(配置文件跟巡逻卫士一个文件，一样的配置，只是名字改下就可以)

巡逻坐标请用"|"号分割!

注意: [ ]内不能含有空格


押镖车

押镖 镖车:

;数据库：
普通镖车;128;19;290;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
高级镖车;128;19;291;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
豪华镖车;128;19;292;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
奢华镖车;128;19;293;60;1;10;3000;3000;0;15;15;20;50;0;0;30;50;300;1;0;1200;;
;======================================================

------------------------------------------------------------
检测是否有押镖任务：ISESCORTING
------------------------------------------------------------
开始押镖: StartEscort 镖车数据库名称(镖车Race=128)
开始押镖相关触发（当前NPC)：
1、@isEscorting；正在押镖中
2、@EscortFail；接押镖任务失败，一般是数据库无对应的镖车或Race不对
3、@EscortOK，接押镖任务成功
------------------------------------------------------------
送至镖车处：MoveToEscort
送至刹车处相关触发（当前NPC)：
1、@MoveToEscort_Fail_1，无押镖镖车
2、@MoveToEscort_Fail_2，镖车地图为空
------------------------------------------------------------
镖车移到人物身边：MoveEscortToSelf
镖车移到人物身边相关触发（当前NPC)：
1、[@MoveToEscort_Fail_1]，无押镖镖车
2、[@MoveToEscort_Fail_2]，镖车地图为空
------------------------------------------------------------
放弃押镖/释放镖车：GiveUpEscort
触发（当前NPC)：
1、@GiveUpEscort_Fail，无押镖镖车
2、@GiveUpEscort_OK， 成功
------------------------------------------------------------
完成押镖：EscortFinish
触发（当前NPC)：
1、@FinishEscort_Fail_1，无押镖镖车
2、@FinishEscort_Fail_2，镖车还未到达目的地
3、@FinishEscort_镖车名称，交镖；交镖后释放镖车GiveUpEscort ,用于奖励

-------------------------------------------------------------

;自己镖车被杀死，自己触发（QF）
[@EscortDie_镖车]
#ACT
SENDMSG 0 你的镖车车被【<$CURRRTARGETNAME>】破坏了

;镖车被杀死触发,击杀者触发（QF）
[@Plunder_镖车]
#ACT
SENDMSG 0 凶狠的[<$USERNAME>]将[<$CurTargetMasterName>]的【<$CURRRTARGETNAME>】破坏了

;镖车受到攻击触发（QF，当人物和自己的镖车不在同一地图，或相距20格以上时）
[@EscortUnderFire]
#ACT
SENDMSG 0 你的镖车被攻击了

----------------------------------------------------------------------------------------------------------------

简易例子：

[@MAIN]
<开始押镖/@JSRW> <完成押镖/@完成押镖>

[@JSRW]
#IF
ISESCORTING
#SAY
您还没有完成上一次押镖任务.如果你要重新开始,请先放弃上一\
次未完成的护送任务。\ \
注意：放弃任务为任务失败！\ \
<放弃任务/@放弃任务> <送我至镖车丢失的地点/@flyto>\ \
<返回/@main>\
#ACT
break
#IF
#ACT
StartEscort 高级镖车
;StartEscort 豪华镖车 15
;命令 镖车名称 时间 ，时间(单位分钟)留空默认为45分钟
break

[@isEscorting]
#SAY
你的托运任务正在执行中，不能再接此任务\
<寻找镖车/@flyto> <放弃任务/@放弃任务> <关闭/@exit>\

[@完成押镖]
#IF
#ACT
EscortFinish

[@放弃任务]
#IF
#SAY
任务注销成功.可以再次接任务拉车！
#ACT
GiveUpEscort
break

[@flyto]
#IF
#ACT
MoveToEscort
break

[@EscortOK]
#IF
#ACT
MESSAGEBOX 恭喜你接到了【镖车】\一直往前走,直到看见镖务总管为止!
break

[@EscortFail]
#SAY
接镖车任务失败，数据中不存在镖车！\
<关闭/@exit>

;-------------传送至镖车位置失败触发--------------------------------------------
[@MoveToEscort_Fail_1] #SAY 你目前没有正在托运的镖车！\ <关闭/@exit>

[@MoveToEscort_Fail_2] #SAY 镖车地图错误！\ <关闭/@exit>

;-------------寻找镖车--------------------------------------------
;QF中有移动寻找镖车就需要在QF脚本中增加相关触发
[@MoveToEscort_Fail_1]
#SAY
你目前没有正在托运的镖车！\
<关闭/@exit>

[@MoveToEscort_Fail_2]
#SAY
镖车还未到达目的地！\
<关闭/@exit>

;---------------------------------------------------------
[@FinishEscort_Fail_1]
你没有镖车啊，提交什么任务！？\
<关闭/@exit>

[@FinishEscort_Fail_2]
镖车距离我太远了，叫我如何核查货物呢？\
<关闭/@exit>

[@GiveUpEscort_OK]
;这个会被封包利用，不要用于奖励之类.可用于提示，或者不用这个触发
#IF
#ACT
MESSAGEBOX 完成押镖
break

[@FinishEscort_高级镖车]
#SAY
押镖完成！\
#ACT
GIVEUPESCORT
GAMEGOLD + 200
SENDMSG 0 恭喜玩家%s成功将【高级镖车】押到.完成任务获得【200元宝】奖励！ 253 215
SENDMSG 0 恭喜玩家%s成功将【高级镖车】押到.完成任务获得【200元宝】奖励！ 253 215 30

;===============================================

QF：
[@Plunder_高级镖车]
#ACT
GAMEGOLD + 1
SENDMSG 6 您成功的将[<$CurTargetMasterName>]的【<$CURRRTARGETNAME>】破坏了，奖励1元宝
SENDMSG 0 凶狠的[<$USERNAME>]在%m(%x:%y)将[<$CurTargetMasterName>]的【<$CURRRTARGETNAME>】破坏了，获得1元宝奖励
break

[@EscortDie_高级镖车]
#ACT
SENDMSG 5 押镖失败，你的镖车被【<$CURRRTARGETNAME>】打劫了！！！
break

[@EscortUnderFire]
你押运的镖车正受攻击！！！\
<前往救急-花费10元宝/@rescue> <关闭/@exit>

[@rescue]
#IF
CHECKGAMEGOLD > 10
#ACT
GAMEGOLD - 10
MoveToEscort
break
#elseact
messagebox 你没有【10】个元宝，我没办法帮您传送过去?
break

;镖车到时死亡触发（主人在线时提示）
[@EscortDie]
#IF
#ACT
messagebox 押镖因超时失败，已被系统摧毁....
break

;QF中有移动寻找镖车就需要在QF脚本中增加相关触发
[@MoveToEscort_Fail_1]
#SAY
你目前没有正在托运的镖车！\
<关闭/@exit>

[@MoveToEscort_Fail_2]
#SAY
镖车还未到达目的地！\
<关闭/@exit>

示范脚本为简易脚本，个别触发可以不要，具体自由发挥.......


移动指定地图坐标的怪物到新的地图位置.、移动地图怪物

 功能说明：移动指定地图坐标的怪物到新的地图位置.

注意：Mir200\Envir\MoveMapMonToPosDisable.txt 文本中包含的怪物都不会被MoveMapMonToPos命令移走

格式：MoveMapMonToPos 怪物名(*不匹配怪物名) 老地图名 老坐标X 老坐标Y 范围 新地图名 新坐标X 新坐标Y 范围

;例子
[@main]
#act
MoveMapMonToPos 白野猪 3 329 349 10 2 188 433 10
sendmsg 6 你已经将盟重地图(329,349)10格范围内的白野猪传到了毒蛇山谷(188,433) 范围10以内


英雄连击配置[!]

相关命令：
H.READSKILLNG 开启英雄内功
H.CHANGENGLEVEL = 100 调整英雄内功等级

连击脚本:点击下载 （此脚本为人物和英雄连击脚本，自己按需求修改升级经络条件）


英雄魔法触发功能

-----------------------------------英雄魔法触发功能------------------------------

英雄使用技能时自身触发
[@HeroMagSelfFuncX]

英雄对目标人物使用时自身触发
[@HeroMagTagFuncX]

英雄对目标人物使用技能时目标触发
[@HeroMagTagFuncExX]

英雄对目标怪物使用技能时触发自身触发
[@HeroMagMonFuncX]


英雄在线改名系统

-----------------------------------英雄在线改名------------------------------
[@Main]
<我要改英雄名字/@@InputString2(请输入新的名称：)>\

[@InputString2]
#IF
Equal S2
#ACT
SENDMSG 6 请输入一个正确的名称
Break

#OR
CheckStringlength S2 > 14
CheckStringlength S2 < 4
#ACT
SENDMSG 6 输入名称长度不正确
Break

#IF
#ACT
CHANGEHERONAME S2

-----------------------------------------------------------------------------

QFunction-0.txt脚本相关触发

[@NameLengthFail]
名字长度必须在4-14个字符之间！\ \
<关闭/@exit>\

[@ChangeingHeroName]
正在修改英雄名，请稍后。。。\ \
<关闭/@exit>\

[@ChangeHeroNameOK]
你的名字修改成功，旧名称：<$HERONAME> 新名称：<$USERNEWNAME>\ \
<关闭/@exit>\

[@HeroNameFilter]
该名字存在非法字符！\ \
<关闭/@exit>\

[@HeroNameExists]
该名字已经被其他玩家占用，请选择其他名字\ \
<关闭/@exit>\

[@ChangeHeroNameFail]
改名失败！\ \
<关闭/@exit>\


游戏开宝箱功能[!]

功能：双击物品可以打开宝箱功
格式：无
说明：无
例：

宝箱相关数据:

宝箱的设置方法(M2-查看\列表信息二中编辑):

宝箱设置:StdMode=31 Shape=15--19(15=檀木宝箱,16=紫铜宝箱,17=白银宝箱,18=赤金宝箱,19=黄金宝箱,20-49=扩展的宝箱全部读取黄金宝箱的素材)
钥匙设置:StdMode=40 Shape=15--19（扩展为20-49，开启宝箱时候样式为黄金宝箱素材）

宝箱设置详细说明

第一步，数据库设置
name=宝箱
Stdmode=31
Shape=(15..19)分别带表五种不同的宝箱样子
Source=该值为宝箱文件名称，将在下面说明

name=钥匙
Stdmode=40
Shape=该值可以为15-49，但只有当该值与宝箱的Shape相同时才可以开启宝箱

第二步，设置宝箱文件

请先打开服务端目录下
X:\Mirserver\Mir200\Envir\Boxs\BoxsList.txt 如果你没看到该文件，可以先运行M2一次或者自已创建

BoxsList.txt说明
该文件只能设置为数值，类似于多个沙巴克设置List.txt文件，每行一个数值

例如：(不过请注意，只能为连续的数值，如0,1,2,3.. 不能间断，像 0,1,3,4是错的)
0 //该值与宝箱的Source相对应，配置文件中请删除该注释
1 //该值与宝箱的Source相对应
2 //该值与宝箱的Source相对应
3 //该值与宝箱的Source相对应
4 //该值与宝箱的Source相对应
....

BoxsList.txt中的每一个数值，对应同目录下的 X.txt文件

例如：Boxslist.txt 中的内容为 0

然后自己在当前目录下建立一个 0.txt 文本，该文本就是宝箱物品设置文件/

物品设置文件设置说明：
文本第一行为宝箱配置
是否开启多次(1为开启) 起始金币 起始元宝 累增金币 累增元宝 有效金币数 有效元宝数 最高次数(0.255)

第二行开始为宝箱物品设置
物品名称 物品类型(0,1,2,3) 0,表示可得物品,1,表示不可得物品,2表示中间一隔物品,3表示永远不可得物品
经验，金刚石，声望设置为 经验，金刚石，声望(数量) 物品类型(0,1,2,3) 例如：

0.txt文本内容 1 10 10 20 20 50 50 3 ;上句话的意思是，开启宝箱可以多次使用转盘，第二次开始收费金币10，元宝10，第三次和以后收费为(起始金币或元宝+累增值*(次数-2) 也就是10+20*(3-2)=30 第四次则为 10+20*(4-2)=50 ..... 后面的有效金币数和元宝数则表示，当人物消费总值大于或等于该值，则玩家有机会可以得到物品设置为不可得的物品。最高次数表示，该宝箱最多允许使用转盘次数)
天尊头盔 0
天尊项链 0
天尊手镯 0
天尊戒指 0
经验(2000) 0
金刚石(20) 0
声望(200) 0
圣战头盔 1
圣战项链 1
圣战戒指 1
圣战手镯 1
经验(10000) 1
金刚石(100) 1
声望(1000) 1
法神头盔 2
法神项链 2
法神戒指 2
法神手镯 2
经验(100) 2
金刚石(10) 2
声望(100) 2
经验(1000000) 3
金刚石(10000) 3
声望(100000) 3

最后附盛大五个宝箱的数据库完整设置

913;黄金宝箱;31;19;1;0;4;0;1192;1;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;255;0;0;0;
914;赤金宝箱;31;18;1;0;3;0;1105;1;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;255;0;0;0;
915;白银宝箱;31;17;1;0;2;0;1104;1;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;255;0;0;0;
916;紫铜宝箱;31;16;1;0;1;0;1103;1;0;0;0;0;0;0;0;0;0;0;0;0;3000;5;255;0;0;0;
917;檀木宝箱;31;15;1;0;1;0;1102;1;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;255;0;0;0;

918;黄金钥匙;40;19;1;0;0;0;1191;1;0;0;0;0;0;0;0;0;0;0;0;0;2500;5;255;0;0;0;
919;赤金钥匙;40;18;0;0;0;0;1184;1;0;0;0;0;0;0;0;0;0;0;0;0;5000;5;255;0;0;0;
920;白银钥匙;40;17;1;0;0;0;1183;1;0;0;0;0;0;0;0;0;0;0;0;0;3000;5;255;0;0;0;
921;紫铜钥匙;40;16;1;0;0;0;1182;1;0;0;0;0;0;0;0;0;0;0;0;0;2500;5;255;0;0;0;
922;木箱钥匙;40;15;1;0;0;0;1181;1;0;0;0;0;0;0;0;0;0;0;0;0;2500;5;255;0;0;0;
文件配置，请查看当前文件所在目录，直接覆盖既可

使用脚本打开宝箱（支持Source值0-255）
该文件只能设置为数值，类似于多个沙巴克设置List.txt文件，每行一个数值

例如：(不过请注意，只能为连续的数值，如0,1,2,3.. 不能间断，像 0,1,3,4是错的)
0 //该值与宝箱的Source相对应，配置文件中请删除该注释
1 //该值与宝箱的Source相对应
2 //该值与宝箱的Source相对应
3 //该值与宝箱的Source相对应
4 //该值与宝箱的Source相对应
......中间省略....
254 //该值与宝箱的Source相对应
255 //该值与宝箱的Source相对应

注意：宝箱获取经验值不得超过21亿.

[@open]
#if
#act
OpenDragonBox 30
#elsesay
你打开了Source值为30....Boxs文件夹内30.txt宝箱内容（注意前面必须有0-29.TXT）\ \
<返回/@Main>

  • 宝箱完整配置下载


游戏内活动按钮[!]

活动按钮使用

点击活动触发QF里的【活动日记】按钮触发

@ActionLogClick


增加怪物爆物品（直接调用怪物爆率免去杀怪过程直接触发爆率文件）

增加怪物爆物品（免去杀怪过程直接触发爆率文件）

-----------------------------------直接调用怪物爆率（免去杀怪过程直接触发爆率文件）---------------------------

增加爆怪物物品（免去杀怪过程直接触发爆率文件）

格式：ScatterMonItems 怪物名称 地图 X Y
;使用地图一般为要求爆在怪物身边，当地图为空时，坐标无效（地图和坐标为空则为人物身边）

[@获取白野猪爆率]
#act
ScatterMonItems 白野猪

[@KillMon]
#act
SENDMSG 7 你杀死<$KILLMONNAME>
;RandomMove 3
ScatterMonItems 半兽人 <$KillMonMap> <$KillMonX> <$KillMonY>


增加取随机值RANDOMEX非伪随机[!]

功能：
增加取随机值RANDOMEX非伪随机.

格式: RandomEx 55 100 ，100为母，55为子，母是随机范围，当随机值小于或等于子值 就执行脚本

示列：

;2分之1
RANDOMEX 1 2
;5分之4
RANDOMEX 4 5
;1000分之7
RANDOMEX 7 1000
;10000分之3
RANDOMEX 3 10000

讲解RandomEx 55 100 ，100为母，55为子，母是随机范围，当随机值小于或等于子值 就执行脚本


装备套装备注[!]

功能：装备套装备注
格式：装备名称=颜色(0~255)/备注描述1\备注描述2\
说明：文件保存在Data\ItemDesc.dat
例：

宝藏钥匙=250/可用来开启卧龙山庄中的“神秘宝藏”\253/直接获得其中的宝物

套装备注说明:
文件保存在Data\TzItemDesc.dat

格式如下:

激活颜色(0~255),未激活颜色(0~255)/套装名字|装备数量|颜色(0~255)/装备名称:颜色(0~255)/属性描述

例1. 140/套装激活条件：=99|1|250/红宝石戒指:140/激活效果：\255/血量 {+2%|250}\255/蓝量 {+1%|250}
例2. 223/套装名称=0|2|116/木剑|116/龙天魔甲:253/攻魔道提升
例3. 223/套装名称=1|2|116/木剑|116/凤天魔衣:253/攻魔道提升
例4. 223,249/套装名称|2|116/木剑|116/凤天魔衣:253/攻魔道提升

例1 不检测性别,所有性别均可见
例2 男性可见
例3 女性可见
例4 根据鼠标选择的装备自动显示男女(不检测性别)

“\”表示换行 “/”颜色分隔符 “|”套装的分隔符 “:”套装装备名称和属性之间的分隔符,, {文字内容|文字颜色0-255}单行文字插入自定义颜色

颜色分激活颜色和未激活颜色，用逗号隔离，如：223,249/土豪套装|2|116/金戒指|116/金项链:253/攻魔道提升{+15%|250}

===================================================================================================

文字均支持单行文字颜色自定义 插入：{文字内容|文字颜色0-255}


自定义安全区形状

说明: 支持任意类型的安全区设置和安全区光柱特效

自定义安全区
地图号：安全区所在地图
座标X：安全区所在地图座标X
座标Y：安全区所在地图座标Y
禁止说话：安全区内是否禁止说话(此功能未完成)
大小范围：安全区范围大小
光环类型：安全区边界显示类型(1-11编号均可使用，主流2或4或5，自行测试设置适合自己的安全区光圈)
PKZONE：安全区是否为PK比赛区域(此功能未完成)
PKFIRE：安全区PK区域边界显示类型(此功能未完成)

当安全区范围 < 0时，表示异形安全区的ID，异形安全区提供点和线的功能，如下：
X Y 均为一个数值时，表示画点
X1:Y1 X2:Y2 这样的形式描述，表示画线

坐标中间有:就是画线。无冒号就是画点 (点更强大，可以是任意形状) 点得意思是一个坐标一个点的绘制，一个安全区需要很多点~~

使用画线可以快速绘制安全区，如果是一个安全区，范围代码需要一致，比如是-1就全设置-1，同一个地图多安全区，范围负数值不要一样即可！
使用画点和画线配合可以组合成任何形状安全区。单纯使用画点就比较繁琐，但是支持任意类型，一般情况只画线，坐标首尾相连即可！

x3 140:113 159:132 0 -1 11 0 0
x3 159:132 140:151 0 -1 11 0 0
x3 140:151 121:132 0 -1 11 0 0
x3 121:132 140:113 0 -1 11 0 0

; 画菱形四条边(画线)
3 315:343 319:347 0 -1 11 0 0
3 319:347 315:351 0 -1 11 0 0
3 315:351 311:347 0 -1 11 0 0
3 311:347 315:343 0 -1 11 0 0

; 把菱形的四个角搞成不一样的效果(画点)
3 315 343 0 -2 4 0 0
3 319 347 0 -2 4 0 0
3 315 351 0 -2 4 0 0
3 311 347 0 -2 4 0 0

也就是首位坐标相连...
同地图多个自定义安全区 安全区范围修改为 -1 -2 -3 -4 -5 反正多个安全区范围不能相同，一个就-1,2个的话 其中一个需要设置-2 ··反正只要是负值就可以 -100也行~

特别注意 ：同一个地图负值不能重复。
地图A假如有2个安全区，可以定-1, -2 （这样不可以重复使用-1，可以设置-1 -2 -3 等等，只要不一样编号地图，不一定需要按照顺序）
地图B假如有1个安全区，可以定-1 （编号重复仅针对单个地图，不是一个地图全使用-1是可以的，只要相同地图编号不重复就OK）

-----------------------------------------------------------

自定义安全区光柱：

编号 20-75 每组10张图片 补丁名称：SafePointEffect.wzl
20：0-9
21:10-19

关于绘制：
编号： 20-55 透明
编号： 56-75 普通


自定义采集功能

自定义采集

命令格式：
SHOWPROGRESSBARDLG 时间(秒) 触发字段 提示信息 有动作是否中断(0不中断,1中断) 中断触发字段 参数1 参数2 参数3 参数4 参数5 参数6 参数7

参数1 =1 开启自定义素材 =0或留空时为 关闭
以下参数 参数1=1 时生效
参数2 采集背景所在文件WZL
参数3 采集背景序号
参数4 采集进度条所在文件WZL
参数5 采集进度条序号
参数6 采集进度条X坐标偏移,Y坐标偏移
参数7 采集文字X坐标偏移,Y坐标偏移
示例：
[@Main]
#ACT
Mov N$NEWUI 1
;15,12:文字偏移坐标 17,29:进度条偏移坐标
SHOWPROGRESSBARDLG 5 @采集完成 正在采集,进度%d%... 1 @采集中断 1 N$NEWUI 234 N$NEWUI 235 15,12 17,29

使用示例2：
[@Main]
#ACT
SHOWPROGRESSBARDLG 5 @采集完成 正在采集,进度%d%... 1 @采集中断
Break

QF触发
[@采集完成]
#ACT
Give 回城卷 1
SendMsg 5 你采集一个回城卷
Break

[@采集中断]
#ACT
SendMsg 5 采集被中断
Break

终止采集命令：StopCollect
注：当玩家同时点多条采集时候则以最后一个采集为准！！


自定义进度条和自定义属性演示脚本

自定义进度条和自定义属性示例脚本

[@main]
#SAY
\\
自定义装备进度条 <开启/@开启装备进度条> <值+20【带100%触发】/@装备进度条值+> <检测/@检测装备进度条> <取值/@取装备进度条值>\\

自定义装备属性 <开启/@开启装备属性> <值+20/@装备属性值+> <检测/@检测装备属性值> <取值/@取装备属性值>\\

;==============================================================
[@开启装备进度条]
#ACT
; 开启自定义装备进度条0
SETCUSTOMITEMPROGRESSBAR 1 0 0 1
; 设置自定义装备进度条0的名称
SETCUSTOMITEMPROGRESSBAR 1 0 1 刀魂%p-%m：
; 设置自定义装备进度条0的名称
SETCUSTOMITEMPROGRESSBAR 1 0 1 刀魂%r%：
; 设置自定义装备进度条0的颜色
SETCUSTOMITEMPROGRESSBAR 1 0 2 255
; 设置自定义装备进度条0的图片播放张数
SETCUSTOMITEMPROGRESSBAR 1 0 3 15
; 设置自定义装备进度条0上的值按数值方式显示
SETCUSTOMITEMPROGRESSBAR 1 0 4 2
; 设置自定义装备进度条0的最大值为 1000
SETCUSTOMITEMPROGRESSBARVALUE 1 0 0 = 1000
; 设置自定义装备进度条0的当前值为 60%
SETCUSTOMITEMPROGRESSBARVALUE 1 0 2 = 60

;==============================================================
[@取装备进度条值]
#ACT
GetCustomItemProgressbarValue 1 0 0 <$STR(N1)>
GetCustomItemProgressbarValue 1 0 1 <$STR(N2)>
GetCustomItemProgressbarValue 1 0 2 <$STR(N3)>
SENDMSG 6 最大值<$STR(N1)>
SENDMSG 6 当前值<$STR(N2)>
SENDMSG 6 百分比值<$STR(N2)>%

;==============================================================
[@武器进度条0满100%]
#ACT
SENDMSG 6 ★★★★★★★★进度条满了★★★★★★★★★★。。。。。

[@装备进度条值+]
#IF
CheckCustomItemProgressbarValue 1 0 2 < 100
#ACT
; 设置自定义装备进度条0的当前值+20
SETCUSTOMITEMPROGRESSBARVALUE 1 0 1 + 20
#ELSEACT
BREAK

;判断进度条是否达到100%
#IF
CheckCustomItemProgressbarValue 1 0 2 = 100
#ACT
goto @武器进度条0满100%

;==============================================================
[@检测装备进度条]
#IF
CheckCustomItemProgressbarValue 1 0 2 > 40
#ACT
SENDMSG 6 检测成功

;==============================================================
[@开启装备属性]
#IF
#ACT
SetCustomItemText 1 我的自定义属性显示
SetCustomItemTextColor 1 249
;设置自定义装备属性0的颜色
SetCustomItemAbil 1 0 0 250
;设置自定义装备属性0绑定属性1
SetCustomItemAbil 1 0 1 1
;设置自定义装备属性0的显示位置为1
SetCustomItemAbil 1 0 2 1
;设置自定义装备属性0为百分比显示
SetCustomItemAbil 1 0 3 1
;设置自定义装备属性0的值
SetCustomItemValue 1 0 = 20

;-------------------------------

;设置自定义装备属性1的颜色
SetCustomItemAbil 1 1 0 249
;设置自定义装备属性1绑定属性2
SetCustomItemAbil 1 1 1 2
;设置自定义装备属性1的显示位置为2
SetCustomItemAbil 1 1 2 2
;设置自定义装备属性1为非百分比
SetCustomItemAbil 1 1 3 0
;设置自定义装备属性1的值
SetCustomItemValue 1 1 = 40

;================================================================
[@装备属性值+]
#ACT
SetCustomItemValue 1 0 + 20

;================================================================
[@检测装备属性值]
#IF
CheckCustomItemValue 1 0 > 100
#ACT
SENDMSG 6 装备属性值0大于100

;================================================================
[@取装备属性值]
#ACT
GetCustomItemValue 1 0 <$STR(N1)> <$STR(N2)>

; 第2个变量不为0时，表示百分比
#IF
Equal <$STR(N2)> 0
#ACT
SENDMSG 6 装备属性值0为<$STR(N1)>
#ELSEACT
SENDMSG 6 装备属性值0为<$STR(N1)>%

=====================================================================================================================

相关说明：
改物品的属性，需用LOCKUPDATEITEM锁定要修改的装备
---------
物品在人物身上。
LOCKUPDATEITEM XX
UPDATEITEM

--------------

物品不在人物身上
LOCKUPDATEITEM XX
UPDATEITEM


自定义属性说明书

自定义属性说明

-----------------------------------自定义属性说明---------------------------

自定义属性说明书

自定义装备属性 该数据保存在人物Mir.DB里
功能说明：每个装备最多可以支持40个属性同时显示并生效，每个属性必须绑定属性才会显示。
自定义装备属性的名称控制(M2-选项-自定义装备属性设置)
自定义装备属性支持的装备位置如下：
-1 升级框
0--25：装备栏
30-35：首饰盒
40-51：神佑袋
boxitem0-boxitem7：OK框

注意 武器没有防御 魔防 生命 魔法值 属性 是不加可以加绑定这些属性的 装备有什么属性 才可以绑定增加什么自定义属性
[@设置自定义装备文字内容：(最大128个字符 支持特殊字符：\=换行) 支持无任何属性的情况下仅显示自定义装备文字内容]
#IF
#ACT
SetCustomItemText 装备位置 名字内容

[@设置自定义装备文字内容显示的颜色：]
#IF
#ACT
SetCustomItemTextColor 装备位置 文字颜色(0~255)

例：
[@main]
<设置衣服自定义文字(不超过10个汉字)/@@InputString1>\
<设置衣服自定义文字颜色(0~255)/@@InputInteger1>\

[@InputString1]
#ACT
SetCustomItemTextColor 0 S1

[@InputInteger1]
#ACT
SetCustomItemTextColor 0 N1

获取自定义装备文字内容：
GetCustomItemText 装备位置 变量

[@获取武器自定义装备文字内容：]
#IF
#ACT
GetCustomItemText 1 <$STR(S1)>
SENDMSG 6 武器自定义文字内容为<$STR(S1)>

获取自定义装备文字内容显示的颜色：
GetCustomItemTextColor 装备位置 变量(0~255)

[@获取武器自定义装备文字内容的颜色：]
#IF
#ACT
GetCustomItemTextColor 1 <$STR(N1)>
SENDMSG 6 武器自定义文字内容的颜色为<$STR(N1)>

检测自定义装备属性值：
CheckCustomItemValue 装备位置 属性位置(0~9) (检测符><=) 检测值
[@检测武器的第一条自定义属性值：]
#IF
#ACT
CheckCustomItemValue 1 0 > 10
SENDMSG 6 武器的第一个自定义属性值大于10

检测自定义装备属性绑定类型：
CheckCustomItemBindType 装备位置 属性位置(0~9) (检测符><=) 绑定类型值(0~17)
绑定类型值
0没有绑定
1绑定AC
2绑定MAC
3绑定DC
4绑定MC
5绑定SC
6绑定MaxHP
7绑定MaxMP
8~17为10个无属性的

[@检测武器的第一个自定义装备属性的绑定类型]
#IF
CheckCustomItemBindType 1 0 = 1
#ACT
SENDMSG 6 你的武器的第一个自定义属性绑定的是AC增加人物防御

设置自定义装备属性值：
SetCustomItemValue 装备位置 属性位置(0~9) (控制符+-=) 属性值

[@设定武器第一个绑定属性的属性值：]
#IF
#ACT
SetCustomItemValue 1 0 + 10
SENDMSG 6 武器的第一个绑定属性值+10

获取装备的自定义属性值：
GetCustomItemValue 装备位置 属性位置(0~9) 变量1 变量2
变量1为保存属性值
变量2是否为百分比，是为1，否为0

[@获取武器第一个绑定属性的属性值：]
#IF
#ACT
GetCustomItemValue 1 0 <$STR(N1)>
SENDMSG 6 武器的第一个绑定属性的属性值为：<$STR(N1)>

[@获取武器第一个绑定属性的属性值+百分比状态：]
#IF
#ACT
GetCustomItemValue 1 0 <$STR(N1)> <$STR(N2)>
SENDMSG 6 武器的第一个绑定属性的属性值为：<$STR(N1)>是否为百分比：<$STR(N2)>

修改自定义装备属性：
SetCustomItemAbil装备位置 属性位置(0~9) 属性类型(0~4) 属性值

属性类型(0~4 参数3) ：
0：参数4表示该属性显示的颜色(0~255)
1：参数4表示该属性绑定哪个属性(0~17)，必须绑定，否则该属性无效，登陆器不会显示
参数4绑定类型值：
0没有绑定
1绑定AC
2绑定MAC
3绑定DC
4绑定MC
5绑定SC
6绑定MaxHP
7绑定MaxMP
8~17为10个无属性的
2：参数4表示在属性框里的显示位置值(0~255；显示位置值相同的显示在同一行)
3：参数4表示该属性是否是百分比属性(0~1；0=非百分比；1=百分比)
4：参数4表示模块ID(0-14)
模块ID代码如下
0. 默认值(即:自定义属性)
1. 装备名称
2. 顶行描述
3. 装备图标(Ask)
4. 升级次数(星星)
5. 自定义进度条
6. 基础属性
7. 凹槽信息
8. 元素属性
9. 自定义属性
10. 投保信息
11. 物品来源
12. 卖给商店
13. 套装信息
14. 物品描述

;将装备自定义属性显示到 物品来源
SetCustomItemAbil 1 0 4 11

[@修改武器第一个自定义属性的颜色]
#IF
#ACT
SetCustomItemAbil 1 0 0 249
SENDMSG 6 修改武器的第一个自定义属性的颜色修改为红色

[@修改武器第一个自定义属性的绑定属性]
#IF
#ACT
SetCustomItemAbil 1 0 1 1
SENDMSG 6 修改武器的第一个自定义属性的绑定属性修改AC增加人物防御

[@修改武器第一个自定义属性的显示位置]
#IF
#ACT
SetCustomItemAbil 1 0 2 0
SENDMSG 6 修改武器的第一个自定义属性的显示位置为第一位显示

[@修改武器的自定义属性显示在同一行]
#ACT
SetCustomItemAbil 1 0 2 0
SetCustomItemAbil 1 1 2 0
;第四个参数相同的会显示在同一行
SENDMSG 6 修改武器的第一个自定义属性和第二个自定义属性显示在同一行

[@修改武器第一个自定义属性的显示为数值]
#IF
#ACT
SetCustomItemAbil 1 0 3 0
SENDMSG 6 修改武器的第一个自定义属性的属性为数值方式增加

[@修改武器第一个自定义属性的显示为百分比]
#IF
#ACT
SetCustomItemAbil 1 0 3 1
SENDMSG 6 修改武器的第一个自定义属性的属性为百分比方式增加

获取自定义装备属性：
GetCustomItemAbil装备位置 属性位置(0~9) 属性类型(0~4) 变量名
0：获取该属性显示的颜色(0~255)
1：获取该属性绑定哪个属性(0~17)
2：获取在属性框里的显示位置值(0~255；显示位置值相同的显示在同一行)
3：获取该属性是否是百分比属性(0~1；0=非百分比；1=百分比)

[@获取武器第一个自定义属性的颜色]
#IF
#ACT
GetCustomItemAbil 1 0 0 <$STR(N1)>
SENDMSG 6 获取武器的第一个自定义属性的颜色为<$STR(N1)>

[@获取武器第一个自定义属性的绑定属性]
#IF
#ACT
GetCustomItemAbil 1 0 1 <$STR(S1)>
SENDMSG 6 获取武器的第一个自定义属性的绑定属性为<$STR(S1)>

[@获取武器第一个自定义属性的显示位置]
#IF
#ACT
GetCustomItemAbil 1 0 2 <$STR(N1)>
SENDMSG 6 获取武器的第一个自定义属性的显示位置为<$STR(N1)>

[@获取武器第一个自定义属性的显示方式(0~1；0=非百分比；1=百分比)]
#IF
#ACT
GetCustomItemAbil 1 0 3 <$STR(N1)>
SENDMSG 6 获取武器的第一个自定义属性的属性增加方式为<$STR(N1)>

============================================================================================

锁定装备更新：LockUpdateItem 装备位置
更新装备到客端： UpdateItem 装备位置

【★★注意★★：有 LockUpdateItem 必须有 UpdateItem；反过来说UpdateItem可以单独使用】
【★★注意★★：当调用两次锁定武器更新 LockUpdateItem 1; LockUpdateItem 1 时，必须调用两次 UpdateItem 1； UpdateItem 1 武器才会刷新到客户端】
【★★★★★★脚本实例：★★★★★★】

;★★★★ 锁定头盔更新 由于下面是对头盔的批量操作，锁定后，对头盔进行操作不会向客户端发包，直到 UpdateItem 4的出现，减少网络包的流量
LockUpdateItem 4
SetCustomItemText 4 [高级属性]
SetCustomItemTextColor 4 146
SetCustomItemAbil 4 2 1 3
SetCustomItemAbil 4 3 1 4
SetCustomItemAbil 4 4 1 5
SetCustomItemAbil 4 5 1 6
SetCustomItemAbil 4 6 1 7
SetCustomItemAbil 4 2 0 250
SetCustomItemAbil 4 3 0 250
SetCustomItemAbil 4 4 0 250
SetCustomItemAbil 4 5 0 250
SetCustomItemAbil 4 6 0 250
;★★★★解锁并更新头盔到客户端
UpdateItem 4

=====================================================================================================================

无绑定属性函数总和的常量

NPC命令，计算人物所有装备绑定属性之和（主要计算“绑定无属性”的属性值）：

GetAllCustomItemValue 属性位置 变量1 变量2 值位置(0,1,2；0或空表示设置第一个值) 变量3
属性位置 (1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~57为49个无属性的 更多属性持续增加中)
变量1：非百分比值和
变量2：所有物品之单件物品百分比值之和
变量3: 所有物品之全身物品百分比值之和

示范脚本：

[@main]
<查看人物共有的多少点：【自定义属性1】/@查看自定义属性1总和>
<查看人物共有的多少点：【绑定无属性1】/@查看绑定无属性1总和>

[@查看绑定无属性1总和]
#act
;命令 属性位置(0-17) 当前人物值 当前人物百分比
GetAllCustomItemValue 0 N$自定义属性1值 N$自定义属性1百分比
SENDMSG 6 提示：您一共拥有“<$STR(N$自定义属性1值)>点自定义防御属性”和“<$STR(N$自定义属性1百分比)>%自定义防御属性”！

[@查看绑定无属性1总和]
#act
;命令 属性位置(0-17) 当前人物值 当前人物百分比
GetAllCustomItemValue 8 N$绑定无属性1值 N$绑定无属性1百分比
SENDMSG 6 提示：您一共拥有“<$STR(N$绑定无属性1值)>点绑定无属性1”和“<$STR(N$绑定无属性1百分比)>%绑定无属性1”！

;写入一个自定义属性到武器上面的示范
mov n$装备位置 1
;1表示武器位置
mov n$属性位置 0
;第几个属性（0-19）
mov n$属性类型 1
;属性类型(0~4 参数3) ，值0时表示修改属性的颜色，为1时表示绑定哪个属性（参考自定义属性面板，1-60）为2时属性显示的位置（数值小的显示再前面），属性3时（是否百分比，0=非百分比，1=单件装备属性百分比，2=全身属性百分比）注意：该参数与参数4挂钩
mov n$本条属性定义 3
SetCustomItemAbil <$str(n$装备位置)> <$str(n$属性位置)> <$str(n$属性类型)> <$str(n$本条属性定义)>
;定义了一条自定义属性的类型， 通常该命令会被定义几次
mov n$输出属性$$1 100
mov n$输出属性$$2 200
mov n$输出属性$$3 300
SetCustomItemValueEX <$str(n$装备位置)> <$str(n$属性位置)> = <$str(n$输出属性$$1)> <$str(n$输出属性$$2)> <$str(n$输出属性$$3)>
;给这属性赋值

;获取上面属性的示范=======================================================================================
GetCustomItemValueEx <$str(n$装备位置)> <$str(n$属性位置)> <$str(n$该条属性是否百分比)> <$str(n$获取属性$$1)> <$str(n$获取属性$$2)> <$str(n$获取属性$$3)>
;n$该条属性是否百分比,0=该条属性非百分比类型，1等于该属性为单件装备属性百分比类型，2等于该属性为全身属性百分比类型（这个值只能获取到0-2）

根据Text变量行数查看全身无绑定属性的合计值
GetAllCustomItemValueByTextLine 属性位置 属性值类型 Text变量行数 变量1 变量2 变量3
属性位置 (1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8-60:绑定无属性)
属性值类型（-1:不限; 0:点数; 1: 单件百分比; 2:全身百分比)
变量1：属性值1合计
变量2：属性值2合计
变量3：属性值3合计
GetAllCustomItemValueByTextLine 22 -1 3 N1 N2 N3
SendMsg 6 合计（值1：<$Str(N1)>；值2：<$Str(N2)>；值3：<$Str(N3)>）

=====================================================================================================================

文字支持单行文字颜色自定义 插入：{文字内容|文字颜色0-255}

=====================================================================================================================

相关说明：
只改物品的属性，需用LOCKUPDATEITEM
---------
物品在人物身上。
LOCKUPDATEITEM XX
UPDATEITEM

--------------
物品不在人物身上
LOCKUPDATEITEM XX
UPDATEITEM

如：
如果是修改 衣服位置的。就要这样写：

LockUpdateItem 0
;.............................对身上的衣服进行一堆的操作 ..............................
updateitem 0

------------2019年更新扩展-------------
扩展：自定义属性扩展为60个
扩展：自定义属性的值扩展为3个
扩展：自定义属性绑定显示扩展为80个字符
修改：自定义属性显示变量$$修改为$$1, $$2, $$3，如果有显示中有变量，请将$$改为$$1
-----------------------------------------------------------------------------------------------------------------
GetCustomItemValue 装备位置 属性位置(0~9) 变量1 变量2 值位置(0,1,2；0或空表示设置第一个值)
获取装备的自定义属性值：
GetCustomItemValue 装备位置 属性位置(0~9) 变量1 变量2 值位置(0,1,2；0或空表示设置第一个值)
变量1为保存属性值
变量2是否为百分比，是为1，否为0

GetAllCustomItemValue 属性位置 变量1 变量2 值位置(0,1,2；0或空表示设置第一个值)
属性位置 (1绑定AC 2绑定MAC 3绑定DC 4绑定MC 5绑定SC 6绑定MaxHP 7绑定MaxMP 8~57为49个无属性的 更多属性持续增加中)
变量1：非百分比值和
变量2：百分比值之和

CheckCustomItemValue 装备位置 属性位置(0~9) (检测符><=) 检测值 值位置(0,1,2；0或空表示设置第一个值)
----------------------------------------------------------------------------------------------------------------------
设置自定义装备属性值扩展：
SetCustomItemValueEx 装备位置 属性位置(0-19) 属性值1 属性值2 属性值3
获自定义装备属性值扩展：
GetCustomItemValueEx 装备位置 属性位置(0-19) 百分比变量 属性值1变量 属性值2变量 属性值3变量

示例：
;设置衣服自定义装备属性0的值1，值2，值3
SetCustomItemValueEx 0 0 = 1 2 3
;获取衣服自定义装备属性0的：百分比显示、值1、值2、值3
GetCustomItemValueEx 0 0 N1 N2 N3 N4
SENDMSG 6 衣服自定义属性0的：百分比显示(<$STR(N1)>) 值1(<$STR(N2)>) 值2(<$STR(N3)>) 值3(<$STR(N4)>)
----------------------------------------------------------------------------------------------------------------------
自定义属性增加了参数控制是否隐藏显示
----------------------------------------------------------------------------------------------------------------------
自定义装备属性高级显示　text在M2-选项-自定义装备属性设置text处设置

支持TEXT变量显示
:{[$$1-$$3]|249}
无属性支持： 多个text变量显示
text支持：$$变量显示

例
例如：
无属性18，
假设：
$$1=1
$$2=10
text变量内容如下：
第1行={攻击时，有|146}{[$$2%]|021}{机率使目标冰冻|146}
第2行={攻击时，有|146}{[$$2%]|021}{几率偷去敌人$$3生命值|146}
“那么实际的效果就是， 攻击时，有10%机率使目标冰冻”
这样 无属性18的 的功能 就可以非固定 可以是吸血，可以是冰冻

支持颜色自定义:
默认颜色{红色文字|249}

^分隔，当分隔内容中的变量值为0时不显示
攻击:$$1 ^魔法:$$2 ^道术:$$3

自定义属性增加分行“\”显示

----------------------------------------------------------------------------------------------------------------------


自动登录离线挂机人物[!]

功能：自动登录离线挂机人物
格式：无
说明：然后在M2操作-控制-加载脱机人物
例：

使用DBServer导出数据，导出的文件保存到X:\MirServer\Mir200\Envir\AutoLoadOffline.txt


页面正在加载,请稍候......


假人摆摊

功能：假人摆摊
格式：假人摆摊
说明：假人摆摊*****

;----------------------------------------------------------------

检测是否在摆摊
CheckShopStallStatus

;----------------------------------------------------------------

增加摆摊物品(从背包中找到物品并上架)：
HeroM2AddUserItem 物品名称 单个物品价格(如果是叠加物品，则计算总数量价格) 货币类型(0:元宝；1:游戏点；2:金币；3:金刚石；4:灵符)

#ACT
HeroM2AddUserItem 珊瑚戒指 10 2
;--------------------------------------------------- 删除摆摊物品
HeroM2DelUserItem 物品名称

#ACT
HeroM2DelUserItem 珊瑚戒指
;-------------------------------------------------------------

开始摆摊: HeroM2StartShopStall 显示文字
停止摆摊:HeroM2StopShopStall

[@摆摊]
#IF
CheckShopStallStatus
#ACT
HeroM2StopShopStall
#ELSEACT
HeroM2StartShopStall 这里有好东西，价格优惠，欲购从速

;================================================================

假人主体设置当前的锁定攻击目标
SetTarget 角色名 角色类型(0:人物;1:英雄;2:怪物) 名称是否过滤数字匹配(仅适用于怪物时；0:不过滤;1：过滤数字匹配)

英雄设置当前的锁定攻击目标
假人H.SetTarget 名称 人物或英雄或怪物(1:英雄，2:人物 3:怪物) 名称是否过滤数字匹配(仅适用于怪物时；0:不过滤;1：过滤数字匹配)


复制字符串,获取字符串长度,查找字符串

格式:

Ansi取字符串长度：TextLength 字符串 变量
Ansi复制字符串:TextCopy 字符串 起始位置(1开始) 长度 变量
Ansi字符串查找：TextPos 待查找的内容 源字符串 变量

Unicode取字符串长度：TextLengthW 字符串 变量
Unicode复制字符串:TextCopyW 字符串 起始位置(1开始) 长度 变量
Unicode字符串查找：TextPosW 待查找的内容 源字符串 变量

示范脚本：

Mov S1 测试文字
TextLength <$STR(S1)> N1
SendMsg 6 (单字节模式)<$Str(S1)>的长度为<$Str(N1)>

TextLengthW <$STR(S1)> N1
SendMsg 6 (双字节模式）<$Str(S1)>的长度为<$Str(N1)>

TextCopy <$Str(S1)> 1 4 S2
SendMsg 6 (单字节模式)<$Str(S1)>的前4位是:<$Str(S2)>

TextCopyW <$Str(S1)> 1 4 S2
SendMsg 6 (双字节模式)<$Str(S1)>的前4位是:<$Str(S2)>

TextPos 试 <$Str(S1)> N1
SendMsg 6 (单字节模式)"试"在字符串<$Str(S1)>的位置为<$Str(N1)>

TextPosW 试 <$Str(S1)> N1
SendMsg 6 (双字节模式)"试"在字符串<$Str(S1)>的位置为<$Str(N1)>


调整人物属性百分比

调整人物套装百分比属性

功能：调整人物套装属性百分比
脚本命令：ChangeHumGroupItemRate 调整人物套装百分比属性，与套装百分比同时叠加计算
格式: ChangeHumGroupItemRate 属性索引(0-25) 操作符(+ = -) 值

说明：属性索引0-25分别对应：
0：调整属性有效时间（请务必在最后调整，##如果要设置0，也必须调用，调用设置时间后，才会重新计算##； 0:表示在线一直有效）
1：MaxHP百分比
2：MaxMP百分比
3：防御下限百分比
4：防御上限百分比
5：魔防下限百分比
6：魔防上限百分比
7：攻击下限百分比
8：攻击上限百分比
9：魔法下限百分比
10：魔法上限百分比
11：道术下限百分比
12：道术上限百分比
13：准确百分比
14：敏捷百分比
15：魔法躲避百分比
16：毒躲避百分比
17：毒恢复百分比
17：HP恢复百分比
19：MP恢复百分比
20：刺术下限百分比
21：刺术上限百分比
22：箭术下限百分比
23：箭术上限百分比
24：武力下限百分比
25：武力上限百分比

*脚本命令

脚本命令：ClearHumGroupItemRates 清除调整人物的套装百分比（调用后，不会重新计算套装属性，除非后面有 ChangeHumGroupItemRate调整有效时间)
格式：ClearHumGroupItemRates

----------------------------------------------

脚本命令：GetHumGroupItemRate 获取人物套装百分比和ChangeHumGroupItemRate增加的百分比
格式: GetHumGroupItemRate 模式(0=命令加的 1= 套装加的) 属性索引(0-25) 返回值到变量

----------------------------------------------

[@清套装百分比属性]
#ACT
ClearHumGroupItemRates
;清完属性后，记得指定时间来重算属性
ChangeHumGroupItemRate 0 = 0

[@增加套装百分比属性]
#ACT
;可以先清一次
;ClearHumGroupItemRates
ChangeHumGroupItemRate 7 + 10
ChangeHumGroupItemRate 8 + 20
;调整完后，记得指定时间来重算属性
ChangeHumGroupItemRate 0 = 5
GetHumGroupItemRate 0 7 N7
GetHumGroupItemRate 0 8 N8
sendmsg 6 套装的攻击下限增加10%，达到<$STR(N7)>%
sendmsg 6 套装的攻击上限增加20%，达到<$STR(N8)>%
GetHumGroupItemRate 0 0 N0
sendmsg 6 属性有效时间为<$STR(N0)>秒


武器升级失败破碎前触发

-----------------------------------武器升级开刀破碎前(不包含成功)掉落触发---------------------------

QF触发字段：[@BeginWeaponBroken]

功能说明：武器升级开刀破碎前触发QF字段

中止武器破碎Npc命令: StopWeaponBroken

以下为QF触发示范：
[@BeginWeaponBroken]
#act
sendmsg 6 破碎前触发，不让破碎
StopWeaponBroken


检查是否评定过主副将英雄

功能说明: 检查是否评定过主副将英雄

说明：CheckAssessHero

--------------------------------------------------------

检查是否评定过主副将英雄命令 CheckAssessHero

[@删除英雄]
是否确认删除英雄\
<是，我确认删除英雄/@DelMyHero> <我考虑下/@exit>

[@DelMyHero]
#if
CheckAssessHero
#ACT
MESSAGEBOX 评定过的英雄禁止删除
BREAK
#ELSEACT
DELETEHERO
;//返回消息

[@NotHaveHero]
你没有英雄。\
<关闭/@exit>

[@LogOutHeroFirst]
请将英雄设置下线！ \
<关闭/@exit>